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1 Introduction 

This technical document is written for Trafikverket to help users perform analysis with the Samgods GUI. It 

contains a technical description of each model element in terms of input data, procedures, and methods 

applied. 

The Samgods GUI forms an integrated interface for several external programs developed over the years. They 

are related to the Standard Logistics Module and Rail Capacity Management Module. For details on the 

external programs, their control files and their usage and meaning of input and output, we refer to their 

technical documentation listed in the references chapter. The documentation is not written for programmers 

in the first place but for users of the model.  

The document has the following structure: 

Chapter 2: The file structure 

Chapter 3: Input and output files reference 

Chapter 4: Description of model structure 

Chapter 0: Description of applications 

Chapter 1: Methods applied in the model 

Chapter 7: Programs and licenses required 

Chapter 8: References 

List of contributors: 

Gabriella Sala SYSTRA Developer of GUI and model setup and co-author of the 

technical documentation  

Shan Li Sweco Reviewer of the technical documentation version 1.2.1 

Daniele Romano Citilabs Co-author of the technical documentation of version 1.2 

Henrik Edwards Sweco Developer, tester and specialist of the logistics module and 

RCM module 

Petter Hill The Swedish 

Transport 

Administration 

Project Manager 

 

Joar Lind The Swedish 

Transport 

Administration 

Developer and tester of version 1.2 
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1.1. Glossary 

Below are some important glossaries used in this manual. Observe that the explanations for some glossaries 

are specific to this context.  

BuildChain - Build Chain procedure associated with BuildChain.exe program 

ChainChoi - Chain Choi procedure associated with the ChainChoi.exe program 

ConsolidRateMode – Consolid Rate Mode procedure associated with ConsolidRateMode.jar 

consol - consolidation 

Extract - extraction procedure of tonnes, empty and loaded vehicle matrices associated with extract.exe 

program 

LogMod or STD - Standard Logistics Module 

MAT - extension for matrix file produced in Cube (binary format), also referred as Voyager Matrix. 

MergeRep is a procedure to merge all .rep files that ChainChoi produces into a unique .rep file. 

Associate to Mergerep.exe program 

Mode - aggregate mode used in chains. See Table A-2 1 for further details 

MSA algorithm - Method of Successive Averages algorithm 

ORIGCAP - Initial capacity in rail links provided with input capacity table 

PWC matrices - Production Warehouse Consumption matrices 

S/A user - Standard User / Advance User. 

RCM - Rail Capacity Management Module 

Submode - submode (vehicle type) used in mode. See Table A-2 1 for further details. 

V/C is the flow volume over capacity ratio for rail flows. 

NORIG - the node number in Emme numbering format. 

SCBSTANN - region code for Swedish zones and univocal number for the other countries. 

Vessel or Vessel Type - vehicle type for sea mode 

Vehicle type - type of vehicle described in the model. 5 types for road mode, 8 types for rail mode, 21 types 

for sea mode and one for air. 

VY - Voyager  

Warm start - start the model from a defined LP solution instead of ng from nothing.  

.314 - extension for matrix file in Emme numbering format, e.g. format derived by EMME software 

{CATALOG_DIR} - the directory where the .cat file is located 

{SCENARIO_DIR} - the directory where the scenario folder is located 

{SCENARIO_CODE} - the code associated with a specific scenario and specified during the creation under 

the scenario window 

{SCENARIO_SHORTNAME} - the scenario name under the scenario tree present in the scenario window 
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2 The file structure 

The file structure for the model is shown in Table 1. 

Table 1 - Folder structure of the model. 

Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

{CATALOG_DIR}  SamGods.cat 

Outputs_Calibrat

ion_Template_re

v10.xlsm 

   Catalog file: main file to access to the 

entire model 

Excel file with a template for statistics 

in calibration 

{CATALOG_DIR}  01_Programs    Folder for the external programs 

(LOGMOD and RCM). At this level, 

Samgods_Parallelization_Module.jar 

and its input files are present. The 

other external programs reside in 

subfolders. For a full list of files and 

an understanding of structure and 

programs, please refer to the 

documentation for each program, for 

example, reference Fel! Hittar inte 

referenskälla., reference 2 on 

section 6.10. 

{CATALOG_DIR}  01_Programs LogMod   Folder and subfolders with 

executables for different programs. 

Executables are placed in respective 

subfolders together with control files. 

The files in the LogMod folder are: 

• execution_times_logmod.tx

t - run time associated to 

each commodity. Used in 

parallelize LogMod run 

• Samgods_Parallelization_

Module.jar - program to 

parallelize LogMod and 

extract procedure 

{CATALOG_DIR}  01_Programs LogMod BUILDCHAIN  Folder containing executable files: 

• BuildChain.exe - First 

program of Standard 

Logistics Module or RCM 

and control files: 

• select.dat 

for selection of detailed cost and 

volume output. The following control 
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Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

files: 

• BuildChain_common.ctl 

• BuildChainNN.ctl 

• logselect.dat 

are produced by the model and saved 

under the scenario folder. Therefore, 

they are not present in the general 

folder. 

{CATALOG_DIR}  01_Programs LogMod ChainChoi  Folder containing executable files: 

• ChainChoi.exe - Second 

program of Standard 

Logistics Module or RCM 

• LP2CC.exe - Last program 

in RCM to derive the final 

solution in Standard 

Logistics module format 

• ConsolidRateMode.jar -  

third program of Standard 

Logistics Module 

and a control file: 

• Select.dat 

for the selection of detailed cost and 

volume output. 

The following control files: 

• ChainChoi_common.ctl 

• ChainChoi_Special.ctl 

• ChainChoiNN.ctl 

are produced by the model and saved 

under the scenario folder, NN being 

the commodity group number. 

Therefore, they are not present in the 

general folder  

{CATALOG_DIR}  01_Programs LogMod EXTRACT  The model produces a folder 

containing the executable file 

extract.exe to extract OD vehicles, 

empty vehicles, and tonnes in EMME 

format. These are saved under the 

scenario folder. Therefore, they are 

absent in the general folder. 

{CATALOG_DIR}  01_Programs LogMod INPUT   
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Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

{CATALOG_DIR}  01_Programs LogMod INPUT PWC\201

6\VY_F 

PWC\204

5\VY_F 

PWC matrices in Voyager format. 

Files present if PWC matrices has 

been run 

{CATALOG_DIR}  01_Programs LogMod LOG  The folder contains report files from 

the Logistics Module and RCM. 

{CATALOG_DIR}  01_Programs LogMod MERGEREP  Folder containing the executable for 

Mergerep procedure mergerep.exe 

{CATALOG_DIR}  01_Programs LogMod RCM  Folder containing the executables 

files: 

• clp64.exe - free software for 

linear programming 

problem 

• MPS.jar - executable to 

prepare inputs for 

lp_solve.exe and to extract 

results from the output  

• SelectDirect.jar – 

executable used to perform 

select link analysis 

{CATALOG_DIR}  02_Applications    The main folder for all the 

applications defined in the model 

{CATALOG_DIR}  02_Applications 1_Editing   Folder for “Create the editable files” 

and “Edit the data” applications 

{CATALOG_DIR}  02_Applications 1_Editing Capacity  Folder for the subgroup “Rail Capacity 

Checks” in the “Edit the data” 

application 

{CATALOG_DIR}  02_Applications 1_Editing Comparison  Folder for the subgroup “Compare 

Nodes and Node_terminals” in the 

“Edit the data” application 

{CATALOG_DIR}  02_Applications 1_Editing Numbering  Folder for the subgroup “Numbering 

System” in the “Edit the data” 

application 

{CATALOG_DIR}  02_Applications 1_Editing Regions  Folder for the subgroup “Regions for 

links” in the “Edit the data” 

application 

{CATALOG_DIR}  02_Applications 2_Run   Folder for the main application, 

“Samgods Model.” 

{CATALOG_DIR}  02_Applications 2_Run Ass_VY  Folder for the subgroup “Assignment” 

in the “Samgods Model” and other 

subgroups for this application: 



The file structure 

11 

Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

• Conversion from LogMod to 

VY 

• Road Assignment 

• Rail Assignment 

• Sea Assignment 

• Air Assignment 

{CATALOG_DIR}  02_Applications 2_Run Calibr  Folder for the subgroup “Parameters 

Calculation” in the “Samgods Model” 

application 

{CATALOG_DIR}  02_Applications 2_Run Costs_VY  Folder for the subgroup “LOS 

Calculation” in the “Samgods Model” 

and other subgroups for this 

application: 

• Data preparation 

• Tax Calculation 

• Road 

• Rail 

• Sea 

• Air 

• Conversion from VY-

matrices to LogMod-

matrices in emme format 

{CATALOG_DIR}  02_Applications 2_Run Ini  Folder for the subgroup 

“Initialization” in the “Samgods 

Model” application 

{CATALOG_DIR}  02_Applications 2_Run LogisticModVY  Folder for the subgroup “Logistic 

Module” in the “Samgods Model” and 

other subgroups for this application: 

• Prepare data 

• Prepare data second part 

• Prepare data third part 

• Run the logistic model 

• Save reports 

{CATALOG_DIR}  02_Applications 2_Run Results  Folder for the subgroup “Results” in 

the “Samgods Model” and other 

subgroups for the application: 

• Results 1.0 

• Port Areas 
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Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

• GIS maps by commodity 

group 

• Öresund Kiel and Jylland 

• Reports per geographical 

aggregation 

{CATALOG_DIR}  02_Applications 3_Compare   Folder for the “Compare” application 

and subgroups: 

• LOS matrices 

• Assignment 

{CATALOG_DIR}  02_Applications 3_Compare OD_matrices  Folder for the subgroup “OD 

matrices” inside “Compare” in the 

“Samgods Model” 

{CATALOG_DIR}  02_Applications 4_Handling   Folder for the main application 

“Handling Scenario” and subgroups: 

• Delete 

• Compact 

• Scenario export 

• Model Export 

• General tables 

• Create the new base 

• Create new scenario specific 

tables 

• Scenario import 

{CATALOG_DIR}  02_Applications 4_Handling Original  Folder with the empty catalog used as 

a template during the creation of a 

new model 

{CATALOG_DIR}  02_Applications 4_Handling Scenario_tables  Folder with scenario tables used in 

comparison with the new base. File 

produced during "Handling Scenario" 

application 

{CATALOG_DIR}  02_Applications 5_Installation   Folder for the “Installation” 

application 

{CATALOG_DIR}  02_Applications 6_PWC_matric

es 

  Folder for the “PWC_Matrices” 

application 

{CATALOG_DIR}  02_Applications 7_Matrix_form   Folder for the “Change matrix format” 

application 

{CATALOG_DIR}  02_Applications 09_RCM1   Folder for the subgroup “Rail Capacity 

Management” in the “Samgods 

Model” and other subgroups for this 
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Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

application: 

• Warm start 

{CATALOG_DIR}  02_Applications 09_RCM1 Ass_VY  Folder for the subgroup “RCM 

Assignment” in the “Samgods Model” 

and other subgroups for this 

application: 

• Conversion from LogMod 

matrices to VY matrices 

• Road Assignment RCM 

• Rail Assignment RCM 

• Sea Assignment RCM 

• Air Assignment RCM 

{CATALOG_DIR}  02_Applications 09_RCM1 Dataprep_LP  This is the folder for the subgroup 

“Data Preparation LP” inside “Rail 

Capacity Management” in the 

“Samgods Model.” 

{CATALOG_DIR}  02_Applications 09_RCM1 Final  Folder for the subgroup “Run Final 

Process” inside “Rail Capacity 

Management” in the “Samgods 

Model” and other subgroups for this 

application: 

• Prepare control files 

• Run the final process 

• Save Reports 

{CATALOG_DIR}  02_Applications 09_RCM1 LP  This is the folder for the subgroup “LP 

Loop” inside “Rail Capacity 

Management” in the “Samgods 

Model.” 

{CATALOG_DIR}  02_Applications 09_RCM1 LP LP0 Folder for the subgroup “LP0 step” 

inside “LP Loop” in the “Samgods 

Model” and other subgroups for this 

application: 

• Prepare CTL files - Extract 

procedure 

{CATALOG_DIR}  02_Applications 09_RCM1 LP LP1 Folder for subgroup “LP1+ step” 

inside “LP Loop” in the “Samgods 

Model” and other subgroups for this 

application: 

• Prepare CTL files 

• Run BuildChain4RCM and 
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Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

ChainChoi4RCM 

• Run MPS, LP and Extract 

• Check convergence 

{CATALOG_DIR}  02_Applications 09_RCM1 Results  Folder for subgroup “Results RCM” in 

the “Samgods Model” and other 

subgroups for the application: 

• Report 1.0 

• Port Areas 

• GIS maps by commodity 

group 

• Öresund Kiel and Jylland 

• Rail Capacity 

• Reports per geographical 

aggregation 

{CATALOG_DIR}  02_Applications 10_SelectLink   Folder with application and 

intermediate files for the " Select Link 

Analysis " application 

{CATALOG_DIR}  02_Applications 11_CBA   Folder for application “Cost Benefit 

Analysis – ASEK values” 

{CATALOG_DIR}  02_Applications 11_CBA LP2CC  Folder for subgroup “CBA Analysis.” 

{CATALOG_DIR}  02_Applications 12_Elasticity   Folder for application “Elasticity 

module” 

{CATALOG_DIR}  02_Applications 12_Elasticity 1_Run  LOS calculation and STD logmod 

stages for “Elasticity module” 

{CATALOG_DIR}  02_Applications 12_Elasticity 1_Run 1_Ini 

Analogous to 

02_Apllications\2_Run\Ini 

{CATALOG_DIR}  02_Applications 12_Elasticity 1_Run 2_Costs 

Analogous to 

02_Apllications\2_Run\Costs_VY 

{CATALOG_DIR}  02_Applications 12_Elasticity 1_Run 

3_Logistic

Mod 

Analogous to 

02_Apllications\2_Run\LogisticMod

VY 

{CATALOG_DIR}  02_Applications 12_Elasticity 1_Run 4_AssSTD 

Analogous to 

02_Apllications\2_Run\Ass_VY 

{CATALOG_DIR}  02_Applications 12_Elasticity 1_Run 

5_Results

STD 

Analogous to 

02_Apllications\2_Run\Results 

{CATALOG_DIR}  02_Applications 12_Elasticity 2_RCM  RCM stage for “Elasticity module” 

{CATALOG_DIR}  02_Applications 12_Elasticity 2_RCM 1_DataPre

par_LP 

Analogous to 

02_Apllications\9_RCM1\Dataprep_
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Catalog Folder First Level Second Level Third Level Fourth 

Level 

Description 

LP 

{CATALOG_DIR}  02_Applications 12_Elasticity 2_RCM 2_LP_ste

ps 

Analogous to 

02_Apllications\9_RCM1\Dataprep_

LP 

{CATALOG_DIR}  02_Applications 12_Elasticity 2_RCM 3_Final Analogous to 

02_Apllications\9_RCM1\Dataprep_

LP 

{CATALOG_DIR}  02_Applications 12_Elasticity 2_RCM 4_AssRC

M 

Analogous to 

02_Apllications\9_RCM1\Ass_VY 

{CATALOG_DIR}  02_Applications 12_Elasticity 2_RCM 5_Results

RCM 

Analogous to 

02_Apllications\9_RCM1\Results 

{CATALOG_DIR}  02_Applications 12_Elasticity 3_Elasticities  Elasticity calculation for STD and 

RCM stages 

{CATALOG_DIR}  03_Gis_Data    Folder for shape files, geodatabase 

gdb Mxd files, Empty and layer file 

(.lyr) 

{CATALOG_DIR}  04_Media    Folder for banners used in the 

interface 

{CATALOG_DIR}  05_Input_Data    Folder for the main geodatabase, 

containing all the input data 

(networks, tables and scenario specific 

tables) 

{CATALOG_DIR}  05_Input_Data Calibration   The folder contains calibration 

databases for Base2019 and 

MainSc2045.  

{CATALOG_DIR}  06_Reports    This is a folder containing Rtf files 

with the model operating instructions 

and report files (.rep) shown in the 

data panel Scenario Reports section. 

{CATALOG_DIR}  07_Python    Folder with Python scripts 

{CATALOG_DIR}  Scenario_Tree    Folder for results from the model; it 

contains several subfolders specific by 

scenario 
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3 Input and output file reference 

Here, we describe the input and output structure in Samgods. 

3.1. File summary 

The file list is organised per location. There is a main folder for the input data and an output folder for each 

scenario. 

Under the folder {CATALOG_DIR}\05_Input_data\Input_Data.mdb there is the main geodatabase with all 

the input data. The input data could be classified into the following classes: 

1. General tables to define lookup values and calibration parameters 

2. Tables that represent the base values used in the model 

3. Tables representing the values differ from the base values and are related to a specific scenario. 

These are denoted scenario specific tables 

4. Tables to manage database version information  

5. Structural tables to manage the geographical information (managed by Cube) 

Table 2 lists the content in the input data geodatabase and specifies the class for each object. 

Table 2 - Input data in geodatabase. 

Input name Format Class 

A_CountyName Table 

1 

A_default_frequencies Table 

A_F2FTypes Table 

A_LinkCategories Table 

A_MainModeStatistics Table 

A_Mode_Type Table 

A_NodeClass Table 

A_Par_Class Table 

A_Port_areas Table 

A_Trakbandel Table 

A_Transfer_Type Table 

A_Vessel_Type Table 

A_Zoning_system Table 

BuildChain_CONSOL Table 

BuildChain_MODES Table 

ChainChoice_MODES Table 

CSTVARI Table 

Chain_List_2019 Table 
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Input name Format Class 

Chain_List_2045 Table 

Direct_Access Table 

Extract_parameters Table 

Inzone_Distance Table 

LBD_Ratio Table 

MaxCapAndConsolExcept Table 

Macros_EMME Table 

Modes Table 

Other_statistics Table 

Port_statistics Table 

SamGods_zones (and 

SamGods_zones_Shape_Index) 

Stand-alone Feature class polygons 

V101_SpeedFlowCurves Table 

V102_SpeedFlowCurves Table 

Base2019 Network (five tables Base2019_Link, 

Base2019_Link_SHAPE_Index, Base2019_Node, 

Base2019_Node_SHAPE_Index, Base2019_SpdCap) 

2 

Frequency_Data_Base2019 Network (five tables Frequency_Data_Base2019_Link, 

Frequency_Data_Base2019_Link_SHAPE_Index, 

Frequency_Data_Base2019_Node, 

Frequency_Data_Base2019_Node_SHAPE_Index, 

Frequency_Data_Base2019_SpdCap 

Cargo_Base2019 Table 

Node_terminals_Base2019 Table 

Nodes_Base2019 Table 

Nodes_Commodities_Base2019 Table 

PropLink_Base2019 Table 

Rail_Capacity_Base2019 Table 

Tax_Category_Base2019 Table 

Tax_Country_Base2019 Table 

Tax_Link_Base2019 Table 

Toll_Link_Base2019 Table 

Vehicles_parameters_partA_Base2019 Table 

Vehicles_parameters_partB_Base2019 Table 

Scenarios_List Table 

General_Base2019 Table 3 
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Input name Format Class 

LogMod_Base2019 Table 

Sc_Base2019_Cargo Table 

Sc_Base2019_Frequency_Data_Link Table 

Sc_Base2019_Frequency_Data_Node Table 

Sc_Base2019_Link Table 

Sc_Base2019_Node Table 

Sc_Base2019_Node_Terminals Table 

Sc_Base2019_Nodes Table 

Sc_Base2019_Nodes_commodities Table 

Sc_Base2019_PropLink Table 

Sc_Base2019_Rail_Capacity Table 

Sc_Base2019_Tax_Category Table 

Sc_Base2019_Tax_Country Table 

Sc_Base2019_Tax_Link Table 

Sc_Base2019_Toll_Link Table 

Sc_Base2019_Vehicles_parameters_PartA Table 

Sc_Base2019_Vehicles_parameters_PartB Table 

History Table 

4 

Model_description Table 

CITILABS_NETWORKS Table 

5 

CITILABS_TRANSITGROUPS Table 

GDB_ColumnInfo Table 

GDB_DatabaseLocks Table 

GDB_GeomColumns Table 

GDB_ItemRelationships Table 

GDB_ItemRelationshipTypes Table 

GDB_Items Table 

GDB_Items_Shape_Index Table 

GDB_ItemTypes Table 

GDB_ReplicaLog Table 

GDB_SpatialRefs Table 
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Under the folder {CATALOG_DIR}\05_Input_data\Calibration two geodatabase files: 

• Input_Data_Calibration_Base2019.mdb and  

• Input_Data_Calibration_Base2045.mdb 

Section 6.8 describes the calibration process, and section 3.3 describes the structure of each table. 

Table 3 lists the content in the input data calibration geodatabases and specifies the class for each object. 

Table 3 - Input data calibration geodatabases. 

Input name Format Notes 

Base2019_Link, MainSc2045_Link Table Same table  

KielCanal_Parameter_Base2019, 

KielCanal_Parameter_MainSc2045 

Table Values 2.2 and 3.2 respectively 

Locked_2019, Locked_2045 and 

Locked_2045_Xore 

Table Different entries for each scenario 

Nodes_Base2019, Nodes_MianSc2045 Table Same table 

Parameters_Kielcalibration Table Present only in Input_Data_Calibration_Base2019.mdb 

Parameters_portcalibration Table Present only in Input_Data_Calibration_Base2019.mdb 

PortAreaParams_16_Comm_Base2019, 

PortAreaParams_16_Comm_MainSc2045 

Table Same table  

Rail_Capacity_Base2019, 

Rail_Capacity_MainSc2045 

Table 66 entries in Base2019 and no entries in MainSc2045. NB- the two 

entries in MainSc2045 have no effects (see section 6.9 for details) 

Tax_Country_Base2019, 

Tax_Country_MainSc2045 

Table The same table with empty entries (see section 6.9 for details) 

Tax_Link_Base2019, 

Tax_Link_MainSc2045 

Table 36 entries in MainSc2045 and no entries in Base2019 

Toll_Link_Base2019, 

Toll_Link_MainSc2045 

Table 146 entries in Base2019 and 176 in MainSc2045 

Vehicles_parameters_PartA_Base2019, 

Vehicles_parameters_PartA_MainSc2045 

Table Same table 

Vehicles_parameters_PartB_Base2019, 

Vehicles_parameters_PartB_MainSc2045 

Table Same table 

 

Under each scenario folder, for instance {CATALOG_DIR}\Scenario_Tree\Year_2019\Base2019, the 

following content will be present: 

• one or more LogMod_Y folders, where Y refers to the cycling process for calibration (or scenario ID 

in elasticity test). For a standard user, this will always be LogMod_1. This folder contains all the 

standard outputs from the Logistics and Rail Capacity Management modules. Chapter 2 describes 

the file system and structure. 

• one folder ABS_GIS{SCENARIO_SHORTNAME}. Inside the folder will be present personal 

geodatabase (gdb format) and related map document mxd that could be used in ArcGIS (without a 

Cube licence) (see section 3.4.8.7 for file list) 
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• one folder DIFF_GIS2045_2019 with personal geodatabase (gdb format) and related map document 

mxd that could be used in ArcGIS (without a Cube licence) on differences between scenarios (see 

section 3.4.8.7 for file list) 

• one folder SelectLink with several subfolders depending on the number of Select link analysis 

performed by the user (see section 3.4.8.6 for file list) 

• the output files (the ones produced depending on user choices) are listed in Table 4. In this example, 

the scenario is Base2019. A different scenario will have the same output files with the scenario name 

included in the file name; for instance, Output0_Base2019.mdb will be Output0_Base2019R62.mdb 

if the scenario is Base2019R62. In the next table and the rest of the document, we will refer to 

{SCENARIO_SHORTNAME} to highlight this concept.
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Table 4 - List of outputs under the scenario folder. Note that in the table below, X represents the commodity group number. 

File name Output name Format 

Output0_{SCENARIO_SHORTNAME}.mdb Model_description Table 

outputs Table 

Node_labels Table 

ProprLink_{SCENARIO_SHORTNAME} Table 

Load_net_Road_0 Network 

Load_net_Rail_0 Network 

Load_net_Sea_0 Network 

Load_net_Air_0 Network 

Loaded_Net_0 Network 

Loaded_Bid_0 Network 

CHAIN_OD_COV_{SCENARIO_SHORTNAME}_0_1 Table 

COM_L_D_{SCENARIO_SHORTNAME}_0_1 Table 

VHCL_OD_COV_{SCENARIO_SHORTNAME}_0_1 Table 

COM_{Select_commodity}_{Scenario_ShortName}_{ScenarioC_name} Network 

Report_1_{SCENARIO_SHORTNAME}_0 Table 

Report_3_TonKM_perMode_0 Table 

Report_4_{SCENARIO_SHORTNAME}_0 Table 

Report_5_{SCENARIO_SHORTNAME}_0 Table 

Report_6_{SCENARIO_SHORTNAME}_0 Table 

Report_6b_{SCENARIO_SHORTNAME}_0 Table 

Report_7_{SCENARIO_SHORTNAME}_0 Table 

Report_8_{SCENARIO_SHORTNAME}_0 Table 

Report_9_{SCENARIO_SHORTNAME}_0 Table 

Report_10_{SCENARIO_SHORTNAME}_0 Table 

Report_11_{SCENARIO_SHORTNAME}_0 Table 

Report_12_{SCENARIO_SHORTNAME}_0 Table 

Report_13_Portarea_0_STD Table 

Report_14_Oresund_Kiel_0_STD Table 

Report_16_{SCENARIO_SHORTNAME}_0 Table 
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File name Output name Format 

Report_17_{SCENARIO_SHORTNAME}_0 Table 

Report_18_{SCENARIO_SHORTNAME}_0 Table 

Report_19_{SCENARIO_SHORTNAME}_0 Table 

Load_net_Road_RCM Network 

Load_net_Rail_RCM Network 

Load_net_Sea_RCM Network 

Load_net_Air_RCM Network 

Loaded_Net_RCM Network 

Rail_BiDir Network 

Compare_Bid Network 

Loaded_Bid_RCM Network 

CHAIN_OD_COV_{SCENARIO_SHORTNAME}_RCM_1 Table 

COM_L_D_{SCENARIO_SHORTNAME}_RCM_1 Table 

VHCL_OD_COV_{SCENARIO_SHORTNAME}_RCM_1 Table 

COMR_{Scenario_ShortName}_{ScenarioC_name} Network 

Report_1_{SCENARIO_SHORTNAME}_RCM Table 

Report_3_TonKM_perModeRCM Table 

Report_4_{SCENARIO_SHORTNAME}_RCM Table 

Report_5_{SCENARIO_SHORTNAME}_RCM Table 

Report_6_{SCENARIO_SHORTNAME}_RCM Table 

Report_6b_{SCENARIO_SHORTNAME}_RCM Table 

Report_7_{SCENARIO_SHORTNAME}_RCM Table 

Report_8_{SCENARIO_SHORTNAME}_RCM Table 

Report_9_{SCENARIO_SHORTNAME}_RCM Table 

Report_10_{SCENARIO_SHORTNAME}_RCM Table 

Report_11_{SCENARIO_SHORTNAME}_RCM Table 

Report_12_{SCENARIO_SHORTNAME}_RCM Table 

Report_13_Portarea_RCM Table 

Report_14_Oresund_Kiel_RCM Table 

Report_15_RailLinksRMC Table 
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File name Output name Format 

Report_16_{SCENARIO_SHORTNAME}_RCM Table 

Report_17_{SCENARIO_SHORTNAME}_RCM Table 

Report_18_{SCENARIO_SHORTNAME}_RCM Table 

Report_19_{SCENARIO_SHORTNAME}_RCM Table 

Report_21_{SCENARIO_SHORTNAME}_RCM Table 

CHAIN_OD_COV_{SCENARIO_SHORTNAME}_CBA_1 Table 

COM_L_D_{SCENARIO_SHORTNAME}_CBA_1 Table 

VHCL_OD_COV_{SCENARIO_SHORTNAME}_CBA_1 Table 

Report_5_{SCENARIO_SHORTNAME}_CBA Table 

Report_6_{SCENARIO_SHORTNAME}_CBA Table 

Report_6b_{SCENARIO_SHORTNAME}_CBA Table 

Report_7_{SCENARIO_SHORTNAME}_CBA Table 

Report_8_{SCENARIO_SHORTNAME}_CBA Table 

Report_10_{SCENARIO_SHORTNAME}_CBA Table 

Report_11_{SCENARIO_SHORTNAME}_CBA Table 

Report_12_{SCENARIO_SHORTNAME}_CBA Table 

Report_19_{SCENARIO_SHORTNAME}_CBA Table 

Report_20_{SCENARIO_SHORTNAME}_CBA Table 

Vehicles_loaded_and_empty_witin_Swedish_territory_CBA Table 

Costs_D_I_X_T_{SCENARIO_SHORTNAME}_CBA Table 

COMMODITYFLows Network 

COMMODITYFLowsSTD Table 

Output0_{SCENARIO_SHORTNAME}.vpr   Visual project 

file 

(GRAPHICS) 

COST_ROAD_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

COST_RAIL_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

COST_SEA_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

COST_AIR_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

ROAD_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

RAIL_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

SEA_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 
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File name Output name Format 

AIR_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

ROAD_TON0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

RAIL_TON0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

SEA_TON0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

AIR_TON0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

ROAD_EMP0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

RAIL_EMP0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

SEA_EMP0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

AIR_EMP0_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

ROAD_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

RAIL_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

SEA_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

AIR_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

ROAD_TON_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

RAIL_TON_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

SEA_TON_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

AIR_TON_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

ROAD_EMP_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

RAIL_EMP_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

SEA_EMP_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

AIR_EMP_FIN_{SCENARIO_SHORTNAME}.MAT   Voyager Matrix 

Scenario_Data.mdb   Database 

Scenario_Data.vpr   Visual project 

file 

(GRAPHICS) 

Input_data.mxd   Visual project 

map file (GIS) Input_data.mxr   File index 

CalParameter_Loop_1.txt   Text File 

CalParameter_Loop_2.txt   Text File 

CalParameterNextLoop.txt   Text File 

FINAL_NETWORK_BS19.NET   Binary Network 

ParKiel_ini.txt   Text File 
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File name Output name Format 

ParKiel_BS19.txt  Text File 

REPORT_ED_BS19.txt   Text File 

REPORT_SG_BS19.txt   Text File 

Differences_BS19.csv   CSV File 

PortAreaParams_16_Comm.txt   CSV File 

EMME_NET_{SCENARIO_SHORTNAME}.211   Emme file 

V101_102_LINK_SPEEDS.DAT   DAT File 

General_Table_{SCENARIO_SHORTNAME}.DBF   Dbase File 

Capacity_table_BS19.DBF   Dbase File 

Nodes.DBF  Dbase File 

Parameters_Kielcalibration.dbf  Dbase File 

Parameters_portcalibration.dbf  Dbase File 

Rail_capacities_STD_BS19.DBF  Dbase File 

RENUM_NODES.DBF   Dbase File 

Scaling_nodes.dbf   Dbase File 

Scaling_PartA.dbf  Dbase File 

Scaling_PartB.dbf  Dbase File 

Scaling_Rail_Capacity.dbf  Dbase File 

Scaling_speed_network.dbf  Dbase File 

Scaling_Tax_country.dbf  Dbase File 

Scaling_Tax_Link.dbf  Dbase File 

Scaling_Toll_link.dbf  Dbase File 

Tax_by_Link_BS19.DBF   Dbase File 

Tax_Category_BS19.DBF   Dbase File 

Tax_Country_BS19.DBF   Dbase File 

Toll_by_link_BS19.DBF   Dbase File 

Vh_par_fin_1_8_BS19.DBF  Dbase File 

Vh_par_fin_9_16_BS19.DBF  Dbase File 

Vh_par_tot.DBF   Dbase File 

Vhl_par_PartA.DBF  Dbase File 



Input and output file reference 

File name Output name Format 

ChainChoi0_{SCENARIO_SHORTNAME}.rep   Report File 

ChainChoi0_{SCENARIO_SHORTNAME}FIN.rep   Report File 

Calibration_1.txt   Text File 

CBA_Final_report_BS19.txt   Text File 

Check_overcapacity_BS19.txt   Text File 

chainchoiCBA0_{SCENARIO_SHORTNAME}.rep   Text File 

Output_COM_STD_GIS_TON.mxd 

 

Visual project 

map file (GIS) 

Output_COM_STD_GIS_VHCL.mxd 

 

Visual project 

map file (GIS) 

 



Input and output file reference 

27 

3.2. Input data 

 We can categorise the input data into three categories. 

• Lookup tables 

• Base data 

• Scenario specific data 

There exists one and only one reference scenario described by the base data, and every other scenario refers 

to this scenario, showing their differences as scenario-specific data. The relation is explained in section 3.2.2.  

3.2.1. Lookup tables 

Here, the lookup tables are listed, including  

• the content of the table,  

• software requirements,  

• the description of use in the model,  

• editing options for the user and  

• which part of the model is acting on the table? 

3.2.1.1. A_CountyName 

05_Input_data\Input_data.mdb\A_CountyName 

The content of the table is listed in Table 5. 

Table 5 - Format of “A_CountyName” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

COUNTY Numerical identifier of county Integer 1 

NAME County name String Stockholm 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Used in reporting phase to associate the county description to reports. 

Editing Options: This does not need to be updated. (Only a new definition of county classification will require 

changes.) 

Used by: “Reports per geographical aggregation” subgroup under “Samgods Model > Results > Results 1.0” 

and under “Samgods Model > Results RCM > Reports 1.0”. 

 

3.2.1.2. A_default_frequencies 

05_Input_data\Input_data.mdb\A_default_frequencies 

The content of the table is listed in Table 6. 

Table 6 - Format of “A_default_frequencies” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_REL Counter Integer 1 
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Field Description Data Format Example 

TER_TYPE_O Terminal code for origin Integer 0 

TER_TYPE_D Terminal code for the destination Integer 0 

SYSTEM Frequency System  Double 0 

LORRY Frequency Lorry Double 84 

WAGONLOAD Frequency WaggonLoad Double 0 

RAILFERRY Frequency RailFerry Double 0 

ROADFERRY Frequency RoadFerry Double 0 

CON_VESSEL Frequency ContainerVessel Double 0 

OTH_VESSEL Frequency Other Vessels Double 0.5 

RORO_VESS Frequency RororVessel Double 0.2 

COMBI Frequency Combi Double 0 

AIR Frequency Air Double 5.0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Define the default frequencies for the frequency matrices based on the terminal type 

(road, rail, sea, ferry or air) per week.  

Editing Options: Only needs to be updated in case of changes in the default frequencies. 

Used by: “Frequency matrices” subgroup under “Edit the data > Create the tables specific of scenario” and 

“General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.3. A_F2FTypes 

05_Input_data\Input_data.mdb\A_F2FTypes 

The content of the table is listed in Table 7. 

Table 7 - Format of “A_F2FTypes” table. 

Field Description Data Format Example 

OBJECTID Counter Integer  1 

ID_F2F ID for the firm to firm relationship Integer 0 

DESCRIPTIO Description of the firm to firm relation String singular or transit 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Define the type of relations between firm to firm in the PWC matrices. 

Editing Options: No need to be updated. 

Used by: “General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.4. A_LinkCategories 

05_Input_data\Input_data.mdb\A_LinkCategories 
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The content of the table is listed in Table 8. 

Table 8 - Format of “A_LinkCategories” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

CATEGORY Link category code Integer 11 

MODE_T Description of the mode String Road 

MODE Code for allowed modes . Same coding is used in other 

tables with slightly a different labelling (MODE_L and 

MODE_N). _L and _N refer to type of element which 

MODE refers to, specifically _L is a link table and _N is a 

node table 

Integer 1 

ID_COUNTRY Country code Integer 1 

GENERAL_MO Description of the general mode as per table 

A_Mode_Type 

String Road 

DESCRIPTIO Description of infrastructure String Oresund Bridge 

AREA Description of geographical covered area String Baltic Sea 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of categories defined in the network and the associated country code. The main use is 

to derive the ID_COUNTRY code for each link in the network, e.g. geographical classification. Second use is 

to derive statistics at various levels in the reporting stage, such as vehiclekms and tonnekms per E10 roads 

(CATEGORY=11). 

Editing Options: Add a new line for each new category defined in the network. 

Used by: “Editable map data” and “Editable tables” subgroups under “Create the editable files”, “Emme 

Edits” subgroup under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup 

under “Samgods Model > LOS calculation > Data Preparation” and “General tables” subgroup under 

“Handling scenario > Scenario Export”. 

 

3.2.1.5. A_MainModeStatistics 

05_Input_data\Input_data.mdb\A_MainModeStatistics 

The content of the table is listed in Table 9. 

Table 9 - Format of “A_MainModeStatistics” table. 

Field Description Data Format Example 

ID Counter Integer 1 

ROAD Millions of domestic tonkm on road mode  Single 52.02 

RAIL Millions of domestic tonkm on rail mode Single 22.72 

SEA Millions of domestic tonkm on sea mode Single 29.61 

FERYEAR Year of statistics Integer 2019 
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Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Official Statistics on domestic million tonkm by mode in Sweden. The values are used in 

creating the output tables “Report_3_TonKM_perMode_0” and “Report_3_TonKM_perMode_RCM”. 

Editing Options: No need to be updated. 

Used by: “Numbering System Voyager” subgroup under “under “Samgods Model > Results > Results 1.0” and 

under “Samgods Model > Results RCM > Results1.0”. 

 

3.2.1.6. A_Mode_Type 

05_Input_data\Input_data.mdb\A_Mode_Type 

The content of the table is listed in Table 10. 

Table 10 - Format of “A_Mode_Type” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 5 

MODE Code for allowed modes Integer 4 

DESCRIPTIO Description of mode String Ferry 

GEN_MODE General mode code Integer 3 

DESCR_GEN Description of general mode String Sea 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of modes defined in the network and related MODE_L, MODE_N attributes in node 

and link tables. 

Editing Options: No need to be updated. (Only the introduction of new general will require changes on this. 

This will impact all the model structure and require several amendments). 

Used by: “Editable map data” subgroup under “Create the editable data”, “General tables” subgroup under 

“Handling scenario > Scenario Export” and graphical editor during the editing of the network. Is one of the 

codes mandatory to edit properly the network (other two are the country code and the region code). 

 

3.2.1.7. A_NodeClass 

05_Input_data\Input_data.mdb\A_NodeClass 

The content of the table is listed in Table 11. 

Table 11 - Format of “A_NodeClass” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 10 

ID_CLASS ID of node class Integer 10 

DESCRIPTIO Description of node class String Road - regional system 

RULE Rule to define node number String From 20000 to 259999 

MIN_V Lower limit for node number Double 20000 
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Field Description Data Format Example 

MAX_V Upper limit for node number Double 260000 

MODE Code for allowed modes Integer 1 

DES_MODE Description of mode String Road – Domestic 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of node classes defined in the network. The initial network used has been developed 

in EMME with a list of rules for numbering. Those rules are described in this table. To derive new EMME 

numbers when the network is modified in Cube GIS window, those rules are applied. 

Editing Options: No need to be updated. (Only the introduction of new general will require changes on this. 

This will impact all the model structure and require several amendments). 

Used by: “Numbering System Voyager” subgroup under “Edit the data > Create the tables specific of 

scenario”, “Tax calculation” subgroup under “Samgods Model > LOS calculation > Data Preparation” and 

“General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.8. A_Par_Class 

05_Input_data\Input_data.mdb\A_Par_Class 

The content of the table is listed in Table 12. 

Table 12 - Format of “A_Par_Class” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

CLASS ID of node class Integer 12 

MIN_R Minimum value for zones Integer 1 

MAX_R Maximum value for zones Integer 399 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: The hierarchic rule in EMME numbering has in the first three digits the region code. In 

this table are represented the minimum and maximum country code associated to the class of nodes present 

in A_NodeClass. 

Editing Options: No need to be updated. (Only the introduction of new numbering system will require 

changes on this. This will impact all the model structure and require several amendments). 

Used by: Not used in the system. Illustration purposes. 

 

3.2.1.9. A_Port_areas 

05_Input_data\Input_data.mdb\A_Port_areas 

The content of the table is listed in Table 13. 

Table 13 - Format of “A_Port_areas” table. 

Field Description Data Format Example 
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Field Description Data Format Example 

OBJECTID Counter Integer 9 

PortNodes_PortAreaNbr Port area number Integer 8 

DESCRIPTION Description of port area String Visby (Gotland) 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog 

Description of Use: List of defined domestic port areas. The calibration of the model conducted, requires as 

input a table with scaling factors by port area and commodity group, respectively. Each domestic port 

belongs to a specific port area. This table defines them. 

Editing Options: No need to be updated. (Only a new definition of port area classification will require 

changes on this). 

Used by: “Port Areas” subgroup under “Samgods Model > Results > Results 1.0” and under “Samgods Model 

> Results RCM > Reports 1.0” and “General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.10. A_TrakBandel 

05_Input_data\Input_data.mdb\A_TrakBandel 

The content of the table is listed in Table 14. 

Table 14 - Format of “A_TrakBandel” table. 

Field Description Data Format Example 

OBJECTID Record identifier Integer 1 

TrakBandel Trak Bandel code Integer 1110 

Section Description of the section String Kiruna-Vassijaure 

Corridor Description of the corridors String Malmbanan 

Tracks Number of tracks Integer 1 

DaysPerYr Operational days in a year Double 365 

Cap2040Öresund Number of trains per day (bidirectional) Double 99 

Cap2012Öresund Number of trains per day (bidirectional) Double 56 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of trak bandel codes used in later reporting (COMMODITYFLows and maps “GIS 

map with Ktons per commodity group” and “GIS map with vhcl per commodity group”). 

Editing Options: No need to be updated. (Only a new definition of trakbandel will require changes on this). 

Used by: Editable map data” subgroup under “Create the editable files” and “General tables” subgroup under 

“Handling scenario > Scenario Export”. 

 

3.2.1.11. A_Transfer_Type 

05_Input_data\Input_data.mdb\A_Transfer_type 

The content of the table is listed in Table 15. 
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Table 15 - Format of “A_Transfer_Type” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

TRANSF_TYP Transfer type code Integer 1 

DESCRIPTIO Description of transfer type String TransferRoadRoad 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of defined transfer types used in Nodes_Commodities_Base2019 table. 

Editing Options: No need to be updated. (Only a new definition of transfer type will require changes on this). 

Used by: Editable map data” subgroup under “Create the editable files” and “General tables” subgroup under 

“Handling scenario > Scenario Export”. 

 

3.2.1.12. A_Vessel_type 

05_Input_data\Input_data.mdb\A_Vessel_type 

The content of the table is listed in Table 16. 

Table 16 - Format of “A_Vessel_type” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

VES_TYPE Vessel type code Integer 1 

DESCRIPTION Description of vessel type String containers 

Software required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of vehicle types defined in the logistic chains (container and non-container). 

Editing Options: No need to be updated. (Only a new definition of special vehicle type will require changes on 

this). 

Used by: “General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.13. A_Zoning_System 

05_Input_data\Input_data.mdb\A_Zoning_System 

The content of the table is listed in Table 17. 

Table 17 - Format of “A_Zoning_System” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 2 

COUNTRY_CO Country code, later referred as ID_COUNTRY Integer 1 

REGION_COD Region code later referred as ID_REGION Integer 115 

COUNTRY Country description String Sweden 
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Field Description Data Format Example 

REGION Region description String Vallentuna 

CENTROID_C Centroid code in Emme format Integer 711500 

SCBSTANN Scbstann code Integer 115 

SWEDEN Boolean variable indicating if the zone is in Sweden Integer 1 

Software required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: List of zones and related country, region and scbstann codes. 

Editing Options: No need to be updated (a revision of zoning system would impact all the model, therefore 

for normal usage of the model is not recommended to change this). 

Used by: “Editable tables” subgroup under “Create the editable files”, “Numbering System Voyager” 

subgroup under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under 

“Samgods Model > LOS calculation > Data Preparation”, “Reports per geographical aggregation” subgroup 

under “Samgods Model > Results > Results 1.0” and under “Samgods Model > Results RCM > Reports 1.0” 

and “General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.14. BuildChain_CONSOL 

05_Input_data\Input_data.mdb\BuildChain_CONSOL 

The content of the table is listed in Table 18. 

Table 18 - Format of “BuildChain_CONSOL” table. 

Field Description Data Format Example 

ID Counter Integer 1 

MODE_C Sub-mode1 String A 

CONSOL_L default lower bound Double 0.4 

CONSOL_U default upper bound Double 0.6 

Mode Description String Road 

ID_MODE Associated number to mode Integer 1 

CONSOL_L01 lower bound for Commodity group 1 Double -1 

CONSOL_U01 upper bound for Commodity group 1 Double -1 

CONSOL_L02 lower bound for Commodity group 2 Double -1 

CONSOL_U02 upper bound for Commodity group 2 Double -1 

CONSOL_L03 lower bound for Commodity group 3 Double -1 

CONSOL_U03 upper bound for Commodity group 3 Double -1 

CONSOL_L04 lower bound for Commodity group 4 Double -1 

CONSOL_U04 upper bound for Commodity group 4 Double -1 

 
1 See Table A-2 in the User manual for full list of sub-modes and vehicle types 
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Field Description Data Format Example 

CONSOL_L05 lower bound for Commodity group 5 Double -1 

CONSOL_U05 upper bound for Commodity group 5 Double -1 

CONSOL_L06 lower bound for Commodity group 6 Double -1 

CONSOL_U06 upper bound for Commodity group 6 Double -1 

CONSOL_L07 lower bound for Commodity group 7 Double -1 

CONSOL_U07 upper bound for Commodity group 7 Double -1 

CONSOL_L08 lower bound for Commodity group 8 Double -1 

CONSOL_U08 upper bound for Commodity group 8 Double -1 

CONSOL_L09 lower bound for Commodity group 9 Double -1 

CONSOL_U09 upper bound for Commodity group 9 Double -1 

CONSOL_L10 lower bound for Commodity group 10 Double -1 

CONSOL_U10 upper bound for Commodity group 10 Double -1 

CONSOL_L11 lower bound for Commodity group 11 Double -1 

CONSOL_U11 upper bound for Commodity group 11 Double -1 

CONSOL_L12 lower bound for Commodity group 12 Double -1 

CONSOL_U12 upper bound for Commodity group 12 Double -1 

CONSOL_L13 lower bound for Commodity group 13 Double -1 

CONSOL_U13 upper bound for Commodity group 13 Double -1 

CONSOL_L14 lower bound for Commodity group 14 Double -1 

CONSOL_U14 upper bound for Commodity group 14 Double -1 

CONSOL_L15 lower bound for Commodity group 15 Double -1 

CONSOL_U15 upper bound for Commodity group 15 Double -1 

CONSOL_L16 lower bound for Commodity group 16 Double -1 

CONSOL_U16 upper bound for Commodity group 16 Double -1 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: The consolidation factors, specified as two values representing an allowed range, in this 

table are specified for all the commodities (CONSOL_L and CONSOL_U) and for each commodity groups. If 

under each commodity group is placed a “-1” value, the proper number will be derived from default values 

(CONSOL_L and CONSOL_U). A mechanism within the model will pull together the appropriated 

combination of values under each BuildChainXX.ctl file.  

Editing Options: Instructions on setting up different values for different scenarios has been explained in User 

Manual 6.1. The table could be copied via Data Manager and opened in dbf window in GUI interface. Its 

reference is controlled by catalog key "Consolidation factors table". 

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module” and “General 

tables” subgroup under “Handling scenario > Scenario Export”. 
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3.2.1.15. BuildChain_MODES 

05_Input_data\Input_data.mdb\BuildChain_MODES 

The content of the table is listed in Table 19. 

Table 19 - Format of “BuildChain_MODES” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COMM Commodity group Integer 1 

A Main vehicle type for chain type A Integer 104 

B Main vehicle type for chain type B Integer 102 

C Main vehicle type for chain type C Integer 104 

D Main vehicle type for chain type D Integer 201 

E Main vehicle type for chain type E Integer 202 

F Main vehicle type for chain type F Integer 208 

G Main vehicle type for chain type G Integer 202 

H Main vehicle type for chain type H Integer 208 

I Main vehicle type for chain type I Integer 204 

J Main vehicle type for chain type J Integer 0 

K Main vehicle type for chain type K Integer 0 

L Main vehicle type for chain type L Integer 0 

M Main vehicle type for chain type M Integer 310 

N Main vehicle type for chain type N Integer 315 

O Main vehicle type for chain type O Integer 317 

P Main vehicle type for chain type P Integer 319 

Q Main vehicle type for chain type Q Integer 322 

R Main vehicle type for chain type R Integer 401 

T Main vehicle type for chain type T Integer 205 

U Main vehicle type for chain type U Integer 206 

c_1 Main vehicle type for chain type c Integer 106 

d_1 Main vehicle type for chain type d Integer 210 

h_1 Main vehicle type for chain type h Integer 212 

i_1 Main vehicle type for chain type i Integer 211 

V Main vehicle type for chain type V Integer 322 

W Main vehicle type for chain type W Integer 322 

f_1 Main vehicle type for chain type f Integer 212 
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Field Description Data Format Example 

X Main vehicle type for chain type X Integer 106 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Main vehicle type used in the BuildChain process for each logistic chain and commodity 

group. It is the translation in access table of information present in reference 1 (Table 5).  

Editing Options: No need to be updated. 

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module” and “General 

tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.16. Chain_List_2019 and Chain_List_2045 

05_Input_data\Input_data.mdb\Chain_List_2019 

05_Input_data\Input_data.mdb\Chain_List_2045 

The content of the table is listed in Table 20. 

Table 20 - Format of “Chain_List_2019” and “Chain_List_2045” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 2 

ID_C Logistic chain code Integer 2 

CHAIN_TYPES Transport chain String ADA 

SEL_SEA Flag for chain containing sea mode Integer 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Specifies the possible chains in the model. Each letter represents a specific submode and 

vehicle type. It is the translation in the access table with information present in references 1 (Table 4a and 

Table 4b). The new vehicle types have imposed the creation of several new chain types. The SEL_SEA 

attribute is for report purposes during the creation of outputs.  

Editing Options: Needs to be updated when the chain types are revised. If sensitivity tests are required, 

create a copy and link the new table in “Samgods” application via catalog key.  

Used by: “Prepare Data third part” and “Save Reports” subgroups under “Samgods Model > Logistics 

Module” and “General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.17. ChainChoice_MODES 

05_Input_data\Input_data.mdb\ChainChoice_MODES 

The content of the table is listed in Table 21. 

Table 21 - Format of “ChainChoice_MODES” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

MODE_C Chain type String A 
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Field Description Data Format Example 

VHCL_NR Vehicle type, 3 digit format (as per 

Vehicles_parameters_PartA_Base2019 table) 

Integer 104 

VES_TYPE Container/non container Integer 1 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of use: Specifies the vehicle type and vessel type (specified in A_Vessel_type) associated to each 

mode present in Chain_List_2019 and Chain_List_2045. It is the translation in access table of information 

present in reference 1 (Table 3). 

This table is used in building the ChainChoixx.ctl files (xx being the commodity group number) for 

parameters VHCLA through VHCLR, see reference 2 (Figure 5-3). An example using values the example data 

in Table 22, results in(ChainChoi01.ctl): 

VHCLA=104,105 

VHCLD=201 

Editing Options: Needs to be updated when chain types and associated vehicle and vessel types are revised. 

Used by: “Prepare Data third part” and “Save Reports” subgroups under “Samgods Model > Logistics 

Module” and “General tables” subgroup under “Handling scenario > Scenario Export”. 

Table 22 - Example of rows in the access table. 

MODE_C VHCL_NR VES_TYPE 

A 104 1 

A 105 1 

D 201 1 

 

3.2.1.18. CSTVARI 

05_Input_data\Input_data.mdb\CSTVARI 

The content of the table is listed in Table 23. 

Table 23 - Format of “CSTVARI” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COM Commodity Group number Integer 1 

F2F_0 VAR parameter (lambda value in logit formulation) for flow to flow class 0 Double 0.1 

F2F_1 VAR parameter (lambda value in logit formulation) for flow to flow class 1 Double 0.1 

F2F_2 VAR parameter (lambda value in logit formulation) for flow to flow class 2 Double 0.1 

F2F_3 VAR parameter (lambda value in logit formulation) for flow to flow class 3 Double 0.1 

F2F_4 VAR parameter (lambda value in logit formulation) for flow to flow class 4 Double 0.1 

F2F_5 VAR parameter (lambda value in logit formulation) for flow to flow class 5 Double 0.1 

F2F_6 VAR parameter (lambda value in logit formulation) for flow to flow class 6 Double 0.1 

F2F_7 VAR parameter (lambda value in logit formulation) for flow to flow class 7 Double 0.1 

F2F_8 VAR parameter (lambda value in logit formulation) for flow to flow class 8 Double 0.1 

F2F_9 VAR parameter (lambda value in logit formulation) for flow to flow class 9 Double 0.1 
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Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Specifies the lambda value for logit formulation of probabilities across solutions (first, 

second, etc.) for each commodity group and flow to flow class.  

Editing Options: Needs to be updated when calibrating the model. 

Used by: “Samgods Model > Logistics Module”. 

 

3.2.1.19. Direct_Access 

05_Input_data\Input_data.mdb\Direct_Access 

The content of the table is listed in Table 24. 

Table 24 - Format of “Direct_Access” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COM Code of Commodity group Integer 1 

F2F_0 Flag to enable or disable direct access  Integer 1 

F2F_1 Flag to direct access for F2F type 1 Integer 0 

F2F_2 Flag to direct access for F2F type 2 Integer 0 

F2F_3 Flag to direct access for F2F type 3 Integer 1 

F2F_4 Flag to direct access for F2F type 4 Integer 0 

F2F_5 Flag to direct access for F2F type 5 Integer 0 

F2F_6 Flag to direct access for F2F type 6 Integer 1 

F2F_7 Flag to direct access for F2F type 7 Integer 1 

F2F_8 Flag to direct access for F2F type 8 Integer 1 

F2F_9 Flag to direct access for F2F type 9 Integer 1 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Define per each type of f2f flow (the types are described in table A_F2FTypes) and 

commodity group if direct access is allowed. 

This table is used when building the ChainChoixx.ctl files for the parameter DIRACC (xx is commodity group 

number). For more information please see reference 2. Each row has been translated from an access table 

given in Table 25. Inside the control file it looks like: 

DIRACC=1,0,0,1,0,0,1,1,1,1 

Editing Options: Needs to be updated when direct access for a specific f2f category and product group is 

revised. 

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module” and “General 

tables” subgroup under “Handling scenario > Scenario Export”. 
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Table 25 - Example of row with values from the access table. 

ID_COM F2F_0 F2F_1 F2F_2 F2F_3 F2F_4 F2F_5 F2F_6 F2F_7 F2F_8 F2F_9 

1 1 0 0 1 0 0 1 1 1 1 

 

3.2.1.20. Extract_parameters 

05_Input_data\Input_data.mdb\Extract_parameters 

The content of the table is listed in Table 26. 

Table 26 - Format of “Extract_parameters” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID Id of vehicle type extract parameters Integer 1 

VEH_NR Vehicle type Integer 101 

DIST1 First threshold distance Double 50 

EMPFAC1 Add-on factor applied up to DIST1 determining the proportion of empty vehicle 

flows to loaded vehicle flows. Between DIST1 and DIST2 a linear interpolation is 

conducted between EMPFAC1 and EMPFAC2 

Double 1 

DIST2 Second threshold distance Double 300 

EMPFAC2 Add-on factor applied above DIST2 determining the proportion of empty vehicle 

flows to loaded vehicle flows 

Double 0.52 

ASYM Threshold distance above which asymmetric loaded vehicle flows will generate the 

same empty vehicle flow 

Double 99888 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: The table provides, for each vehicle type, the function that will be applied in the extract 

procedure. The extract procedure reads the emptyfrac.dat placed under EXTRACT folder and applies the 

values specified in this table (DIST1, EMPFAC1, DIST2, EMPFAC2 etc. for specification of a piecewise linear 

function). The ASYM control parameter present in each extractXXX.ctl file is filed out with values from this 

table. 

Editing Options: Needs to be updated when specifying different curves. 

An example to understand the parameters in this table, using the curve in Figure 1 is: 

DIST1=50 km 

EMPFAC1=1 

DIST2=300 km 

EMPFAC2=0.52 

Used by: “prepare Data second part” and “Prepare Data third part” subgroups under “Samgods Model > 

Logistics Module” and “Prepare CTL Files” subgroup under “Samgods Model > Rail Capacity Management > 

LP Loop > LP0 step”, “Samgods Model > Rail Capacity Management > LP Loop > LP1+ step”, “Samgods 

Model > Rail Capacity Management > LP1 Adjust Capacities > LP Adjust Capacity Loop > LP1b step” and 

“Samgods Model > Rail Capacity Management > Run Final Process”. 



Input and output file reference 

41 

 

Figure 1 - The curve for empty vehicle fraction. 

3.2.1.21. Inzone_Distance 

05_Input_data\Input_data.mdb\Inzone_Distance 

The content of the table is listed in Table 27. 

Table 27 - Format of “Inzone_Distance” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 2 

ZONEID Zone code (NORIG value) Integer 711500 

DISTANCE Intrazonal distance [km] Double 5.53 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Inzone_Distance represents the default values for the intrazonal distances on domestic 

zones. This value will be added both for the distance, domestic distance and time skims during the cost 

calculation phases. 

Editing Options: No edits to be updated (the revision of this is connected to the revision of zoning system. 

therefore in the normal usage of the model is not recommended to change this). 

Used by: “Data Preparation” subgroup under “Samgods Model > LOS calculation” and “General tables” 

subgroup under “Handling scenario > Scenario Export”. 

 

3.2.1.22. Macros_EMME 

05_Input_data\Input_data.mdb\Macros_EMME 

The content of the table is listed in Table 28. 

Table 28 - Format of “Macros_EMME” table. 
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Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID Table identifier  Integer 1 

VEH_NR Vehicle type Integer 101 

DESCRIPTIO Vehicle description String Lorry light LGV.< 3.5 ton 

EMME2_C Name of the macro in EMME for cost calculation String ~<v100.mac 

MATIN Name of the macro in EMME for load the OD matrix String ~<veh_matin_100.mac 

EMME2_A Name of the macro in EMME for assignment String ~<asg100.mac 

ODMATRIX Name of OD matrix in EMME format String od_vhcl101.314 

ODEMME Matrix number in emme2bank  String mf11 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: The table is used to specify the matrix label printed out in OD matrices when extracted 

from the transport chain solutions. Values in ODEMME column will specified the value for control parameter 

ID in the extract control file. For instance for Vehicle type 101 in control file we have ID=mf11, and this value 

comes from ODEMME attribute in Table 29. 

Editing Options: If user wishes to change the matrix label, the values could be updated. 

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module”, “Prepare CTL 

Files” subgroup under “Samgods Model > Rail Capacity Management > LP Loop > LP0 step”, “Samgods 

Model > Rail Capacity Management > LP Loop > LP1+ step”, “Samgods Model > Rail Capacity Management 

> LP1 Adjust Capacity Loop > LP1b step” and “Samgods Model > Rail Capacity Management > Run Final 

Process”, “General tables” subgroup under “Handling scenario > Scenario Export”. 

Table 29 - Example from the access table. 

ID VEH_NR DESCRIPTIO EMME2_C MATIN EMME2_A ODMATRIX ODEMME 

1 101 Lorry light 

LGV <3.5 

~<v100.mac ~<veh_matin._ ~<asg100.mac od_vhcl101.314 mf11 

 

3.2.1.23.  MaxCapAndConsolExcept 

05_Input_data\Input_data.mdb\MaxCapConsolExcept 

The content of the table is listed in Table 30. 

Table 30 - Format of “MaxCapConsolExcep” table. 

Field Description Data Format Example 

ID Identified Integer 1 

OBJECTID Count Integer 1 

ORIG Zone origin Integer 971211 

DEST Zone destination Integer 970621 

MODE_C Mode associated String H 



Input and output file reference 

43 

Field Description Data Format Example 

CMD_SLCT String with 0/1 – position of 

the digit represent the 

commodity group. In the 

example the constrain is 

applied to the second 

commodity 

String 0100000000000000 

VEHCAP Fixed capacity Integer 2000 

CONSOLRATE Fixed consolidate rate Double 0.98 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Define for each commodity group, origin and destination and submode, the maximum 

vehicle capacity and consolidation rate. The values will overide the consolidation rate calculation in the 

logistic module. 

Editing Options: Update with new codes if need to add a different origin destination pair. 

Used by: “Samgods model> Logistic Module> Prepare data” and the Elasticity application. 

3.2.1.24. Modes 

05_Input_data\Input_data.mdb\Modes 

The content of the table is listed in Table 31. 

Table 31 - Format of “Modes” table. 

Field Description Data Format Example 

OBJECTID Count Integer 1 

CODE Code for each mode String x 

DESCR_MODE Description of the vehicle type associated to mode String All_m 

VAL1 Code 1: code used in Voyager process to sort properly some tables 

during the run 

Double 1 

VAL2 Code 2: code used in Voyager process to sort properly some tables 

during the run 

Double 1 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Define the modes in the network and some codes used in the Voyager application to 

properly sort records in intermediate files. 

Editing Options: Update with new codes if need to add a different vehicle type. 

Used by: “Editable map data” subgroup under “Create the editable files”, “Numbering System Voyager” 

subgroup under “Edit the data > Create the tables specific of scenario”, and “General tables” subgroup under 

“Handling scenario > Scenario Export”. 

 

3.2.1.25. Other_statistics 

05_Input_data\Input_data.mdb\Other_statistics 

The content of the table is listed in Table 32. 

Table 32 - Format of “Other_statistics” table. 
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Field Description Data Format Example 

ID Counter Integer 1 

A Start node of the link in VY Numbering  Integer 11964 

B End node of the link in VY Numbering  Integer 11969 

DES Description of statistics String OresundRoad 

Statistics Unit used for statistics (number of vehicles or tons per year) String Vehicles 

ID_S Identification number for unit in statistics (1 - number of 

vehicles, 2 - tons) 

Integer 1 

Value Tons or vehicles per year Double 377662.6 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: This table contains statistics on Oresund Bridge (both for rail and road components) and 

Kiel Canal and Jylland region. The values refer to base year 2019. The table also contains the links (A and B 

nodes) that represent those infrastructures or services. This table is used in setting up the comparisons 

between Base2019 scenario and statistics reported in Report #3. 

Editing Options: Since these are the reference numbers for comparisons, no edits are required. 

Used by: “Oresund Kiel and Jylland” subgroup under “Samgods Model > Results > Results 1.0” and 

“Oresund Kiel and Jylland” under “Samgods Model > Results RCM > Reports 1.0”. 

 

3.2.1.26. Port_statistics 

05_Input_data\Input_data.mdb\Port_statistics 

The content of the table is listed in Table 33. 

Table 33 - Format of “Port_statistics” table. 

Field Description Data Format Example 

PortAreaNbr Port area code Integer 1 

COM01 Tonnes/1000 through port area of commodity group 1 Double 1.964 

COM02 Tons/1000 on port area and COMMODITY group 2 Double 1536.803 

COM03 Tons/1000 on port area and COMMODITY group 3 Double 5770.829 

COM04 Tons/1000 on port area and COMMODITY group 4 Double 0.154 

COM05 Tons/1000 on port area and COMMODITY group 5 Double 0 

COM06 Tons/1000 on port area and COMMODITY group 6 Double 1155.889 

COM07 Tons/1000 on port area and COMMODITY group 7 Double 876.687 

COM08 Tons/1000 on port area and COMMODITY group 8 Double 580.82 

COM09 Tons/1000 on port area and COMMODITY group 9 Double 351.737 

COM10 Tons/1000 on port area and COMMODITY group 10 Double 182.252 

COM11 Tons/1000 on port area and COMMODITY group 11 Double 0.254 

COM12 Tons/1000 on port area and COMMODITY group 12 Double 6.204 
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Field Description Data Format Example 

COM13 Tons/1000 on port area and COMMODITY group 13 Double 0.163 

COM14 Tons/1000 on port area and COMMODITY group 14 Double 69.408 

COM15 Tons/1000 on port area and COMMODITY group 15 Double 400.604 

COM16 Tons/1000 on port area and COMMODITY group 16 Double 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: This table contains statistics on port areas divided by commodity group. The values refer 

to base year 2019. This table is used in setting up the comparisons between Base2019 scenario and statistics 

reported in Report #13. 

Editing Options: Since these are the reference numbers for comparisons, no edits are required. 

Used by: “Port Areas” subgroup under “Samgods Model > Results > Results 1.0”, “Port Areas” under 

“Samgods Model > Results RCM > Reports 1.0” and “General tables” subgroup under “Handling scenario > 

Scenario Export”. 

 

3.2.1.27. SamGods_zones 

05_Input_data\Input_data.mdb\SamGods_zones 

The content of the table is listed in Table 34. 

Table 34 - Format of “SamGods_zones” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 33 

Shape Feature class type OLE Object Long Binary Data 

COUNTRY_CO Country code Integer 518 

REGION_COD Region code Integer 201 

COUNTRY Description of country String Norway 

REGION Description of region String Akershus 

CENTROID_C Centroid code in Emme format Integer 960100 

SCBSTANN SCBSTANN code Integer 2601 

Shape_Length Length of perimeter in meters Double 393316.015 

Shape_Area Area of shape in square meters Double 5030650696.500 

Software Required: Cube GIS Window (see Help>Cube Base>GIS window) Or ArcMap 

Description of Use: Defines the zoning system in the model. It is used during the editing to assist the user in 

the definition of COUNTRY_CO and REGION_CO. It is also used to classify links on boundaries per 

SCBSTANN. The table “A_Zoning_System” contains the actual coding present in PWC matrices, while the 

feature class “SamGods_zones” is its translation in a visualizable layer. 

Editing Options: No need to be updated (a revision of zoning system would impact all the model, therefore 

for normal usage of the model is not recommended to change this).  
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Used by: “Prepare temporary data” subgroup under “Create the editable files”, “Regions for links” subgroup 

under “Edit the data > Save changes in the main gdb” and GIS window to select the country and region codes 

during the edit of the network. 

 

3.2.1.28. V101_SpeedFlowCurves and V102_SpeedFlowCurves 

05_Input_data\Input_data.mdb\V101_SpeedFlowCurves 

05_Input_data\Input_data.mdb\V102_SpeedFlowCurves 

The content of the tables is listed in Table 35. 

Table 35 - Format of “V101_SpeedFlowCurves” and “V101_SpeedFlowCurves” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

NUM_CURVE ID function when coding speed-flow curves relationships 

under Cube scripting 

Integer 1 

SPEEDBASE1 Base speed for first part of equation Double 111 

A1 A parameter for first part of equation Double 4.211003 

B1 B parameter for first part of equation Double 107.2412 

C1 C parameter for first part of equation Double 0.009474 

D1 D parameter for first part of equation Double 0.00007 

G1 G parameter for first part of equation Double 0.001405 

SPEEDBASE2 Base speed for second part of equation Double 0 

A2 A parameter for second part of equation Double 0 

B2 B parameter for second part of equation Double 0 

C2 C parameter for second part of equation Double 0 

D2 D parameter for second part of equation Double 0 

G2 G parameter for second part of equation Double 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Define the delay functions based on the category of the link for vehicle type 101 and 

vehicle type 102-106 respectively. 

Editing Options : No need to be updated. 

Used by: “Road” subgroup under “Samgods Model > LOS calculation”, “Road Assignment” subgroup under 

“Samgods Model > Assignment”, “Road Assignment” subgroup under “Samgods Model > RCM Assignment” 

and “General tables” subgroup under “Handling scenario > Scenario Export”. 

NOTE: This table represents the coefficients used in delay curves defined for each category. This table will be 

used if there will be no speed values for the road mode in Sweden. Their formats in the programs are 

discussed below. There are two different structures for the delay functions, depending on the number of lanes 

on a link: 

First structure: 
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TC[NUM_CURVE]=LI.UL2 / MIN ( SPEEDBASE1, (A1+(B1+(C1*exp(D1*(v/0.88)))/(1+G1*exp(D1*(v/0.88))) 

Second structure: 

TC[40]=CmpNumRetNum(LI.NLANES,'>',1.5,(LI.UL2/ (MIN(SPEEDBASE1,A1 + (B1 + C1 * exp(D1 *(V/0.12))) /(1 + G1 

* exp(D1 *(V/0.12)))))), (LI.UL2/ (MIN(SPEEDBASE2,A2 + (B2 + C2 * exp(D2 *(V/0.12))) / (1 + G2 * exp(D2 

*(V/0.12))))))) 

where: 

• LI.UL2 – Distance in km 

• V – Volume of vehicle flow (per hour or units per day) 

• LI. NLANES – Number of lanes. 

3.2.2. Interaction between Base data and Scenario specific data 

Base data works in pair with scenario specific data to form a specific scenario.  

The concept is that all the input data connected to a specific scenario is stored in the database as the 

differences between the current scenario and the base scenario (i.e., the reference scenario), as shown in 

Figure 2. The benefits of this approach are: 

• A smaller amount of data is stored, that is, only the differences between the base scenario and the 

alternative scenario(s) 

• It makes different alternative scenarios independent of each other, by letting the alternative 

scenarios having only the base scenario as a reference. The only redundancy of the system occurs 

when children are added to an alternative scenario since all scenarios (including child and parent 

scenarios) are independent of each other and only have the base scenario as a reference 

• When changes are made to the base scenario, there is no need to change all the other scenarios. This 

facilitates the handling of the overall scenarios. Furthermore, the changes and edits will be done only 

once, in the base scenario, avoiding risk of mistake when updating the correlated scenarios 

To create the editable files for a specific scenario and the scenario specific tables, two applications work in 

conjunction:  

• the Create the editable files application, which merges the base scenario with the scenario specific 

tables to view and edit a scenario, and  

• the Edit the data application, which stores the scenario-specific tables into the database after any 

edits have been made 
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Figure 2 - Database structure and scenario data of the Samgods GUI. 

To create the editable file for a specific scenario and vice versa, create the scenario specific tables, two 

applications work in conjunction, the first one is “Create the editable files” with the purpose to merge the 

base scenario with the scenario specific table to consolidate a scenario, and “Edit the data” application, that 

after the edits stores the scenario specific table into the database. 

The main database is always present in the model, under 05_Input_data folder; the temporary database is 

created in each run under the scenario folder and deleted on request by the user. 

Here, we will discuss the tables and networks that form the base data, e.g. the reference scenario. In the 

scenario folder, all the base data and scenario data (e.g. differences with Base Scenario) are merged forming a 

new set of input data editable from interface. In Table 36 the correspondences among each feature class or 

table present in Input_data.mdb and Scenario_data.mdb are presented. 

Table 36 - Correspondence between Input_data.mdb and Scenario_data.mdb. 

Input_Data.mdb Scenario_data.mdb 

Name Type Name Type 

Cargo_Base2019 Table 

Cargo_{SCENARIO_SHORTNAME} Table 

Sc_{SCENARIO_SHORTNAME}_Cargo Table 

Frequency_Data_Base2019 Network 

Frequency_network Network 

Sc_{SCENARIO_SHORTNAME}_Frequency_Dat

a_Link 
Node Table 

Sc_{SCENARIO_SHORTNAME}_Frequency_Dat

a_Node 
Link Table 

General_Base2019 Table General_{SCENARIO_SHORTNAME} Table 

LogMod_Base2019 Table LogMod_{SCENARIO_SHORTNAME} Table 
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Input_Data.mdb Scenario_data.mdb 

Name Type Name Type 

Base2019 Network 

Network Network Sc_{SCENARIO_SHORTNAME}_Link Node Table 

Sc_{SCENARIO_SHORTNAME}_Node Link Table 

Model_description Table Model_description  

Nodes_Base2019 Table 

Nodes 

Stand-alone 

Feature class 

points Sc_{SCENARIO_SHORTNAME}_Nodes Node Table 

Nodes_Commodities_Base2019 Table 

Nodes_Commodities 

Stand-alone 

Feature class 

points 

Sc_{SCENARIO_SHORTNAME}_Nodes_commo

dities 
Table 

Node_terminals_Base2019 Table 

Ports_Swe 

Stand-alone 

Feature class 

points 

Sc_{SCENARIO_SHORTNAME}_Node_Termina

ls 
Table 

Rail_Capacity_Base2019 Table Rail_Capacity_{SCENARIO_SHORTNAM

E} 
Table 

Sc_{SCENARIO_SHORTNAME}_Rail_Capacity Table 

SamGods_zones 

Stand-alone 

Feature class 

polygons 

SamGods_zones 

Stand-alone 

Feature class 

polygons 

Tax_Category_Base2019 Table Tax_Category_{SCENARIO_SHORTNAM

E} 
Table 

Sc_{SCENARIO_SHORTNAME}_Tax_Category Table 

Tax_Country_Base2019 Table Tax_Country_{SCENARIO_SHORTNAM

E} 
Table 

Sc_{SCENARIO_SHORTNAME}_Tax_Country Table 

Tax_Link_Base2019 Table 

Tax_Link_{SCENARIO_SHORTNAME} Table 

Sc_{SCENARIO_SHORTNAME}_Tax_Link Table 

Toll_Link_Base2019 Table 

Toll_Link_{SCENARIO_SHORTNAME} Table 

Sc_{SCENARIO_SHORTNAME}_Toll_Link Table 

Vehicles_parameters_PartA_Base2019 Table 

Vehicles_parameters_ 

Sc_{SCENARIO_SHORTNAME}_PartA 
Table Sc_{SCENARIO_SHORTNAME}_Vehicles_para

meters_PartA 
Table 

Vehicles_parameters_PartB_Base2019 Table 
Vehicles_parameters_ 

Sc_{SCENARIO_SHORTNAME}_PartB 
Table 

Sc_{SCENARIO_SHORTNAME}_Vehicles_para

meters_PartB 
Table   

 

The structure for each table is identical to the structure in Input_data.mdb with some exceptions: 
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• MODESTR, attribute present in the link table of the network, is converted into a set of attributes per link where the particular 

vehicle type is allowed/not allowed depending on the flag. For instance ' xc' is converted in two attributes ALL_M=1 and 

CAR=1. The correspondence is hold in Vehicle Parameters table under MODE_1 and MODE_2. Per each letter specified under 

MODESTR, a different attribute has specified. 

• Some new attributes are added to make the information more readable. For instance under Nodes_commodities a new field 

TRANSFER gives the information of which type of transfer the TRANSFER_TYPE number refers to. For instance 

TRANSFER_TYPE=1 means that TRANSFER= TransferRoadRoad. 

Please see reference 6 for further details on the structure and rules for editing. 

3.2.3. Base Data 

In this section all tables related to reference scenario are listed. 

3.2.3.1. Base2019 

05_Input_data\Input_data.mdb\Base2019 

The tables represent the network for the cost calculation and assignment processes. Physically it is 

constructed from two tables, the node and the link table in the geodatabase, presented in Table 37 and Table 

38 respectively. 

Table 37 - Format of “Base2019_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM)  Double 1620000 

Y Coordinate y (SWEREF99_TM)  Double 6601000 

NORIG Original node number in EMME numbering based 

on the combination of ID_Country, ID_region and 

MODE_N values 

Integer 711400 

SCBSTANN SCBSTANN code Integer 114 

ID_COUNTRY Country code Integer 1 

ID_REGION Region code Integer 114 

MODE_N Mode code for node Integer 0 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

GEOMETRYSOURCE Structural code representing source of node. In Base 

2019 always 1  

Double 1 

Table 38 - Format of “Base2019_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (lane) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 1 
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Field Description Data Format Example 

B End node in VY Numbering Integer 2659 

Shape_Length Length based on distance between coordinates in 

meters 

Double 230.86792762 

MODESTR String with all the allowed modes String Xabc 

SPEED_1 Speed in kms per hour for all modes except v102-106 in 

Sweden 

Double 50 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in 

Sweden 

Double 50 

CATEGORY Link category Integer 110 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable 

holding link lengths longer than 999 kms. 

Double 1.36 

UL3 Capacity for vessels on sea (dwell tons) Double 0 

GEOMETRYSOURCE Structural code representing source of node. In Base 

2019 always 1  

Double 1 

Software required: Microsoft Access, Cube GIS Window (see Help>Cube Base>GIS window), ArcMap. 

Description of Use: Define the base network. 

Editing Options: No edits; all the changes will be allowed only in the export phase merging the scenario 

specific tables and the base tables. 

Used by: All the applications. 

 

3.2.3.2. Frequency_data_Base2019 

05_Input_data\Input_data.mdb\Frequency_data_Base2019 

Frequency_data_Base2019 represents the frequency matrices for specific modes. Physically it is constructed 

from tables, the node and the link table in the geodatabase, presented in Table 42 and Table 43. The use of a 

network instead of a set of matrices is to save hard disk space (the network format is more compressed than 

the matrix format) and access time during the read/write phases. 

Each relation between zones is represented by: 

• a link if the connection is between two different zones 

• a node if the connection is between the same zone (origin coincides with destination) 

For instance in the link table the following link in Table 39, this will be translated into 3 rows in each file 

representing different frequencies. In the example: 

• FREQCONTAINERVESSEL.314 will take the value 0.1 from CONTAINERV and origin 711400 from ZONEORIG and 

destination 730521 from ZONEDEST 

• FREQOTHERVESSEL.314 will take the value 0.5 from OTHER and origin 711400 from ZONEORIG and destination 730521 

from ZONEDEST 
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• FREQRORVESSEL.314 will take the value 0.5 from OTHER and origin 711400 from ZONEORIG and destination 730521 from 

ZONEDEST 

In each .314-file we will find the corresponding record in Table 40. A similar process is conducted for the 

node table, where all the intrazonal frequencies are saved, i.e. values where origin is identical with 

destination. Values in node table with 0 in ZONEORIG_N and ZONEDEST_N represent that the intrazonal 

values are not available for that specific zone. The correspondence between .314-files and attributes in the 

network is shown in Table 41. 

Table 39 - Example showing a row from the access table. 

A B ZONEORIG ZONEDEST SYSTEM COMBI CONTAINERV LORRY OTHER ROROVES 

1 1100 711400 730521 0 0 0.1 0 0.5 0.2 

 

Table 40 - Example of content of the .314-files. 

File Record 

FREQCONTAINERVESSEL.314 711400 730521:0.1 

FREQOTHERVESSEL.314 711400 730521:0.5 

FREQROROVESSEL.314 711400 730521:0.2 

Table 41 - Correspondence between information in Frequency_network and LOS files under Input 

folder for logistics module. 

Attribute in node 

table 

Attribute in link table File under Input\LOS 

SYSTEM_N SYSTEM FREQSYSTEM.314 

AIR_N AIR FREQAIR.314 

COMBI_N COMBI FREQCOMBI.314 

CONTAINE_N CONTAINERV FREQCONTAINERVESSEL.314 

LORRY_N LORRY FREQLORRY.314 

OTHER_N OTHER FREQOTHERVESSEL.314 

ROROVES_N ROROVES FREQROROVESSEL.314 

WAGONL_N WAGONL FREQWAGGONLOAD.314 

RAILFERR_N RAILFERRY FREQRAILFERRY.314 

ROADFERR_N ROADFERRY FREQROADFERRY.314 

INWW_N INWW FREQIWW.314 

Table 42 - Format of “Frequency_data_Base2019_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 25 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 25 
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Field Description Data Format Example 

X Coordinate x (SWEREF99_TM) Double 1593100 

Y Coordinate y (SWEREF99_TM) Double 6562900 

ZONEORIG_N Original node number in EMME Numbering for the 

origin 

Integer 714000 

ZONEDEST_N Original node number in EMME Numbering for the 

destination 

Integer 714000 

SYSTEM_N Frequency System Double 0 

AIR_N Frequency air Double 0 

COMBI_N Frequency Combi Double 0 

CONTAINE_N Frequency ContainerVessel Double 0 

LORRY_N Frequency Lorry Double 84 

OTHER_N Frequency Other Vessels Double 0 

ROROVES_N Frequency RororVessel Double 0 

WAGONL_N Frequency WaggonLoad Double 0 

RAILFERR_N Frequency Railferry Double 0 

ROADFERR_N Frequency RoadFerry Double 0 

INWW_N Frequency Inland water  Double 0 

GEOMETRYSOURCE Number representing to which network the node 

belongs (1-Road 2-Rail 3_sea 4-Air) 

Double 4 

Table 43 - Format of “Frequency_data_Base2019_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (lane) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 1 

B End node in VY Numbering Integer 1100 

Shape_Length Length based on distance between coordinates in 

meters 

Double 6796881.71149 

ZONEORIG Original node number in EMME Numbering for the 

origin 

Integer 711400 

ZONEDEST Original node number  in EMME Numbering for the 

destination 

Integer 730521 

SYSTEM Frequency System Double 0 

AIR Frequency air Double 0 

COMBI Frequency Combi Double 0 

CONTAINERV Frequency ContainerVessel Double 0.1 
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Field Description Data Format Example 

LORRY Frequency Lorry Double 0 

OTHER Frequency Other Vessels Double 0.5 

ROROVES Frequency RororVessel Double 0.2 

WAGONL Frequency WaggonLoad Double 0 

RAILFERRY Frequency Railferry Double 0 

ROADFERRY Frequency RoadFerry Double 0 

INWW Frequency Inland water Double 0.0 

    

Software required: Microsoft Access, Cube GIS Window (see Help>Cube Base>GIS window), ArcMap. 

Description of Use: Define the base network. 

Editing Options: No edits; all the changes will be allowed only in the export phase merging the scenario 

specific tables and the base tables. 

Used by: All the applications. 

 

3.2.3.3. Cargo_Base2019 

05_Input_data\Input_data.mdb\Cargo_Base2019 

The table, Table 44, represents the default values for the commodities, with all the parameters used in the 

logistics module. 

Table 44 - Format of “Cargo_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COM Commodity code Integer 1 

DESC_COMM Description of commodity String Cereals 

VALUE_SEKT Value in SEK per ton Integer 1350 

INV_COST Inventory cost Integer 466 

ORD_COST Order cost Double 1829 

NSTR_NR NSTR code Integer 10 

AGGR_NUM Class used in reporting, if set from 1 to 16 is just commodity group number.  Integer 1 

AGGR_COM Commodity aggregation (three classes Dry bulk, General cargo, Liquid bulk) String Dry bulk 

COM_TYPE Code for the commodity aggregation (1 Dry bulk, 2 Liquid bulk, 3 general cargo) Integer 1 

PRORCOST ProportionalOrderCosts Parameter used for the calculation of the annual 

demand dependent order costs. The annual demand dependent order costs are 

calculated as: OrderCosts = FixedOrderCosts + ProportionalOrderCosts x 

AnnualDemand^Alpha 

Double 2.19109 

ALPHA Parameter used in the order cost calculation Single 0.5 
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Field Description Data Format Example 

SHIP_SIZE Typical shipment size for this commodity. This parameter is used to determine 

the shipment size q [tonnes per shipment] and calculate the logistic costs for the 

chains in the BuildChain phase.  This parameter can be either a number or 

DYNAMIC_MAX, DYNAMIC_AVERAGE or DYNAMIC_GEOMEAN. See 

Program_Documentation_Sweden_November_2019. Pg. 34 for details 

String 41 

OPTIP Code for including all costs or only transport costs for producers 0=include all 

costs 1=include only transport costs 

Integer 0 

OPTIW Code for including all costs or only transport costs for wholesale. 0=include all 

costs 1=include only transport costs 

Integer 0 

MFREQ Minimum frequency that is used when the default frequency is not available in 

the vehicle cost file 

Integer 1 

SELECT_BC Manage the existence of the select.dat file for BuildChain (0- no, 1 –yes) Integer 0 

SELECT_CC Manage the existence of the select.dat file for ChainChoi (0- no, 1 –yes) Integer 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcCatalog. 

Description of Use: Defines the values in INPUT\COST\CARGO.TXT and some control parameters 

(SELECT_BC and SELECT_CC) in BuildChain.ctl and ChainChoi.ctl control files. See reference 2 for more 

details. 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Create the tables specific of scenario” 

subgroup under “Edit the data”, “Data Preparation” subgroup under “Samgods Model > LOS calculation” and 

“Create the new base” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.3.4. Node_terminals_Base2019 

05_Input_data\Input_data.mdb\Node_terminals_Base2019 

The table, Table 45, holds the information of pilot fees for each port and vehicle type. 

Table 45 - Format of “Node_terminals_Base2019” table. 

Field Description Data Format Example 

OBJECTID Count Integer 9 

N Node number in VY Numbering Integer 211 

TERMINAL_N Code number in EMME Numbering for port Integer 808322 

PILOT_V301 Pilot fee for vehicle type 301 [SEK] Double 4932 

PILOT_V302 Pilot fee for vehicle type 302 [SEK] Double 7054 

PILOT_V303 Pilot fee for vehicle type 303 [SEK] Double 8240 

PILOT_V304 Pilot fee for vehicle type 304 [SEK] Double 11757 

PILOT_V305 Pilot fee for vehicle type 305 [SEK] Double 2393 

PILOT_V306 Pilot fee for vehicle type 306 [SEK] Double 3412 
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PILOT_V307 Pilot fee for vehicle type 307 [SEK] Double 3766 

PILOT_V308 Pilot fee for vehicle type 308 [SEK] Double 4224 

PILOT_V309 Pilot fee for vehicle type 309 [SEK] Double 5639 

PILOT_V310 Pilot fee for vehicle type 310 [SEK] Double 7054 

PILOT_V311 Pilot fee for vehicle type 311 [SEK] Double 8240 

PILOT_V312 Pilot fee for vehicle type 312 [SEK] Double 10692 

PILOT_V313 Pilot fee for vehicle type 313 [SEK] Double 10692 

PILOT_V314 Pilot fee for vehicle type 314 [SEK] Double 11757 

PILOT_V315 Pilot fee for vehicle type 315 [SEK] Double 7054 

PILOT_V316 Pilot fee for vehicle type 316 [SEK] Double 8240 

PILOT_V317 Pilot fee for vehicle type 317 [SEK] Double 9406 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Pilot fees for Swedish ports per vehicle type. Values are exported to 

INPUT\COST\PILOTFEES.TXT. 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable map data” subgroup under “Create the editable file”, “Compare Nodes and 

Node_terminals” subgroup under “Edit the data > Create the tables specific of scenario”, “Prepare data” 

subgroup under “Samgods Model > Logistics Module", and “Create the new base” subgroup under “Handling 

scenario > Scenario Export”. 

 

3.2.3.5. Nodes_Base2019 

05_Input_data\Input_data.mdb\Nodes_Base2019 

The table contains information about the zones and terminals, the format is shown in Table 46. 

Table 46 - Format of “Nodes_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 10 

N Zone number in VY Numbering Integer 10 

ZONEID Code number in EMME Numbering  for zone Integer 712500 

NAME Description of the zone/terminal String Zone: Ekerö 

ZONET Zone code for node location if direct access, 0 other cases Integer 712500 

DOMESTIC Dummy for domestic location (1=domestic, 0=non 

domestic) 

Integer 1 

C_TECH_FAC Cost efficiency factor in terminals Double 1 

T_TECH_FAC Time efficiency factor in terminals Double 1 

MAXDWTCONT Load constraint for container vessels that the port can Double 0 
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Field Description Data Format Example 

manage [tonnes] 

MAXDWTRORO Load constraint for RoRo vessels that the port can manage 

[tonnes] 

Double 0 

MAXDWOTHE Load constraint for other vessels that the port can manage 

[tonnes] 

Double 0 

SEAOUTPUT Yearly sea output[tonne]. Used for consolidation 

determination. 

Double 0 

SEACONTO Yearly container output [tonne] Used for consolidation 

determination. 

Double 0 

AIROUTPUT Yearly air output [tonne] Used for consolidation 

determination. 

Double 0 

TranOceFac Penalty factor applied during the LOS calculation for TIME. 

The final time will penalized by a factor in the following 

manner: 

TIME (from the network)* (1+OrigFactor)*(1+DestFactor) 

where OrigFactor is TranOceFac for the origin and 

DestFactor is TranOceFac for the destination 

Double 0 

PORTAREANR Port area number for the specific port. Values from 

A_Port_areas table 

Integer 0 

VANERNCAN Capacity associated to a port in Vänern Lake. Value 

represents dwell units allowed in the particular port. See 

section 6.6.2 for further details. 

Double 0 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: definition for each zone and terminal of different parameters representing capacities and 

location in .\Input\Nodes\NODES.TXT file. TranOceFac is explicitly used in the Samgods application 

generating the impedance factors per each origin and destination in LOS calculation (Matrix step #3 and 

HIGHWAY step #7) applied to TIME skim. 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable map data” subgroup under “Create the editable files”, “Compare Nodes and 

Node_terminals” subgroup under “Edit the data > Create the tables specific of scenario”, “Data Preparation” 

subgroup under “Samgods Model > LOS calculation”, “Prepare Data second” subgroup under “Samgods 

Model > Logistics Module” and “Create the new base” subgroup under “Handling scenario > Scenario 

Export”. 

 

3.2.3.6. Nodes_Commodities_Base2019 

05_Input_data\Input_data.mdb\Nodes_Commodities_Base2019 

The table contains information about the possibility of transfer in every zone and terminal by commodity, 

with format as shown in Table 47. In Table 50 the correspondence between Transfer Type and related input 

file in the logistics module. 

Table 47 - Format of “Nodes_Commodities_Base2019” table. 
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Field Description Data 

Format 

Example 

OBJECTID Count Integer 21 

N Zone number in VY Numbering Integer 21 

ZONEID Code number in EMME Numbering for zone or terminal Integer 713611 

TRANSF_TYP Transfer type code (referred to A_Transfer_type table) Integer 14 

COM_1 Dummy representing whether a transfer of a certain type is allowed 

for listed terminals etc for commodity group 1 

Integer 1 

COM_2 As above for commodity group 2 Integer 2 

COM_3 As above for commodity group 3 Integer 3 

COM_4 As above for commodity group 4 Integer 4 

COM_5 As above for commodity group 5 Integer 5 

COM_6 As above for commodity group 6 Integer 6 

COM_7 As above for commodity group 7 Integer 7 

COM_8 As above for commodity group 8 Integer 8 

COM_9 As above for commodity group 9 Integer 9 

COM_10 As above for commodity group 10 Integer 10 

COM_11 As above for commodity group 11 Integer 11 

COM_12 As above for commodity group 12 Integer 12 

COM_13 As above for commodity group 13 Integer 13 

COM_14 As above for commodity group 14 Integer 14 

COM_15 As above for commodity group 15 Integer 15 

COM_16 As above for commodity group 16 Integer 16 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Define per transfer type the list of terminals where at least one commodity may be 

subject to transfer. It is the source to produce files under Input\Nodes. Based on each transfer type.  

For instance, the following records in Table 48 will be translated into 3 rows in each file representing 

different transfer types, as shown in Table 49. Thus, 

• TRANSFERROADTRAIN.TXT (TRANSF_TYPE=3) will be given the commodity group number for all the commodities where 

COM_X<>0 and ZONEID=713611 

• DIRECTFEEDERTRAIN.TXT (TRANSF_TYPE=14) will be given the commodity group number for all the commodities where 

COM_X<>0 and ZONEID=713611 

• DIRECTFEEDERTRAIN.TXT (TRANSF_TYPE=16) will be given the commodity group number for all the commodities where 

COM_X<>0 and ZONEID=713611 
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Table 48 - Example of rows in the access table. 

N ZONEID TRANSF_TYP COM_1 COM_2 COM_3 COM_4 COM_5 COM_6 COM_7 

21 713611 3 1 2 3 4 5 6 7 

21 713611 14 1 2 3 4 5 6 7 

21 713611 16 0 0 0 0 0 0 0 

 

Table 49 - Example of output. 

File Record 

TRANSFERROADTRAIN.TXT 713611 Rail: Jordbro 1 2 3 4

 5 6 7 

FREQOTHERVESSEL.314 713611 Rail: Jordbro 1 2 3 4

 5 6 7 

DIRECTFEEDERTRAIN.TXT 713611 Rail: Jordbro 0 0 0 0

 0 0 0 

 

Table 50 - Correspondence between file system and Nodes_commodities table. 

TRANSF_TYP DESCRIPTIO File under Input\Nodes 

1 TransferRoadRoad TRANSFERROADROAD.TXT 

2 TransferRoadCombi TRANSFERROADCOMBI.TXT 

3 TransferRoadTrain TRANSFERROADTRAIN.TXT 

4 TransferRoadSea TRANSFERROADSEA.TXT 

5 TransferRoadRoadFerry TRANSFERROADROADFERRY.TXT 

6 TransferRoadAir TRANSFERROADAIR.TXT 

7 TransferCombiSea TRANSFERCOMBISEA.TXT 

8 TransferFeederTrainWagonload TRANSFERFEEDERTRAINWAGONLOAD.TXT 

9 TransferWagonloadSea TRANSFERWAGONLOADSEA.TXT 

10 TransferWagonloadRailFerry TRANSFERWAGONLOADRAILFERRY.TXT 

11 TransferSystemTrainSea TRANSFERSYSTEMTRAINSEA.TXT 

12 TransferSeaSea TRANSFERSEASEA.TXT 

13 ContainerHandling CONTAINERHANDLING.TXT 

14 DirectFeederTrain DIRECTFEEDERTRAIN.TXT 

15 DirectSea DIRECTSEA.TXT 
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TRANSF_TYP DESCRIPTIO File under Input\Nodes 

16 DirectSystemTrain DIRECTSYSTEMTRAIN.TXT 

17 DirectWagonLoad DIRECTWAGONLOAD.TXT 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables 

Used by: “Editable map data” subgroup under “Create the editable files”, “Compare other tables” subgroup 

under “Edit the data”, “Prepare Data second part” subgroup under “Samgods Model > Logistics Module” and 

“Create the new base” subgroup under “Handling scenario > Scenario Export” 

 

3.2.3.7. PropLink_Base2019 

05_Input_data\Input_data.mdb\PropLink_Base2019 

This table, Table 51, provides information about the proportion WEIGHT of a link A-B that resides in a zone 

REGION. The proportion is given in percent (0-100). 

Table 51 - Format of “PropLink_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 696 

A Start node in VY Numbering Integer 2793 

B End node in VY Numbering Integer 2794 

REGION SCBSTANN code Integer 136 

WEIGHT Weight proportional to the part of the link residing in the 

zone. 

Double 100 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Table with all road and rail links that share a different SCBSTANN area. Each record 

provides the proportion of the link length belonging to the listed SCBSTANN area. The proportion is used to 

classify tonneskm and vehicleskm statistics per region and county. (See reports #9, 16, 17 and 18). 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Reports per geographical aggregation” subgroup under “Samgods Model > Results > Results 1.0”, 

“Samgods Model > Results RCM > Results1.0”, “Create the new base” subgroup under “Handling scenario > 

Scenario Export” and “Create the scenario tables” subgroup under “Handling scenario > Scenario Export > 

Create the new scenario specific tables”. 

 

3.2.3.8. Rail_Capacity_Base2019 

05_Input_data\Input_data.mdb\Rail_Capacity_Base2019 

This table, Table 52, provides the capacity ORIGCAP for a link A-B having the trakbandel category 

TRAKBANDEL. 

Table 52 - Format of “Rail_Capacity_Base2019” table. 

Field Description Data Format Example 
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Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_LINK Link identified for rail link. Two links in opposite 

direction share the same ID_LINK.  

Integer 25 

A Start voyager node Integer 2000 

B End voyager node Integer 2001 

TRAKBANDEL Trakbandel code for link Integer 4333 

ORIGCAP Original value for capacity in bidirectional trains per day  Double 418 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: This table represents the main input for Rail Capacity Management module, since the 

number of total vehicles on rail links is compared with the ORIGCAP value. The links with ratio V/C equals 

or greater than the value in catalog key " Cut off criteria for RCM process (will consider links with V/C > 

XX% where XX is given in percentage)" will be selected as part of the linear programming problem. For 

details on edits of this table, please see reference 6. It is also a mandatory input for the Rail Assignment 

under "Samgods Model > RCM Assignment > Rail Assignment RCM" since in this case the assignment is 

based on capacity constraints, e.g. the delay functions are related to the ratio V/C.  

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Rail Capacity Checks” subgroup under 

“Edit the data > Create the tables specific of scenario”, “Data Preparation” subgroup under “Samgods Model 

> LOS calculation”, “Create the new base” subgroup under “Handling scenario > Scenario Export” and 

“Create the scenario tables” subgroup under “Handling scenario > Scenario Export > Create the new scenario 

specific tables”. 

 

3.2.3.9. Tax_Category_Base2019 

05_Input_data\Input_data.mdb\Tax_Category_Base2019 

This table, Table 53, provides information about the tax SEK per link category LINKTYPE and vehicle type 

ID_VEHICLE. 

Table 53 - Format of “Tax_Category_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 17 

LINKTYPE Link category Integer 580 

ID_VEHICLE Vehicle type Integer 317 

SEK Track fee or tax [SEK] Double 104218 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Specifies a link based tax defined by the link category and vehicle type. In the current 

model the only tax applied is for Kiel Canal (CATEGORY=570). 
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Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup 

under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods 

Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario 

> Scenario Export”. 

 

3.2.3.10. Tax_Country_Base2019 

05_Input_data\Input_data.mdb\Tax_Country_Base2019 

This table, Table 54, provides information about the tax SEK_KM per country ID_COUNTRY and vehicle 

type ID_VEHICLE. 

Table 54 - Format of “Tax_Country_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COUNTRY Country code Integer -1 

ID_VEHICLE Vehicle type Integer 201 

SEK_KM Country tax per km [SEK/km] Double 13.77 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Specifies a link based tax defined by country and vehicle type. (NB. -1 values refer to 

countries outside Sweden). 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup 

under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods 

Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario 

> Scenario Export”. 

 

3.2.3.11. Tax_Link_Base2019 

05_Input_data\Input_data.mdb\Tax_Link_Base2019 

This table, Table 55, provides information about the tax SEK per link A-B and vehicle type VEH_NR. 

Table 55 - Format of “Tax_Link_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 4 

A Start node in VY Numbering Integer 2015 

B End node in VY Numbering Integer 78051 

VEH_NR Vehicle type Integer 304 

SEK Track fee or tax [SEK] Double 3706.25 
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Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Specifies a link based tax by vehicle type. 

Editing Options: No edits; all the Changes will be allowed only in the export phase merging the scenario 

specific tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup 

under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods 

Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario 

> Scenario Export”. 

NOTE: For the same link it is possible to define tax values based on country criteria, category criteria and 

also its selection (three tables above). However the final result will be based on the following rule: 

TAX_COUNTRY < TAX_CATEGORY < TAX_LINK 

The value in the Tax_Link table will override the other values, so the final result will come from the 

evaluation of an OR logical condition. Zero values also have a meaning, inserting a zero in the table value will 

set the tax to zero. For instance 0 in the Tax_Link table will set the tax value for the specific link to zero.  

 

3.2.3.12. Toll_Link_Base2019 

05_Input_data\Input_data.mdb\Toll_Link_Base2019 

This table, Table 56, provides information about the toll SEK per link A-B and vehicle type VEH_NR. 

Table 56 - Format of “Toll_Link_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 4 

A Start node in VY Numbering Integer 11964 

B End node in VY Numbering Integer 11969 

VEH_NR Vehicle type Integer 104 

SEK Link toll [SEK] per passing vehicle Double 809 

DESCRIPT Description of the infrastructure (in general bridges) String Toll Oresund 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Defines a toll applied to a link per vehicle type. 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup 

under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods 

Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario 

> Scenario Export”. 

 

3.2.3.13. Vehicles_parameters_PartA_Base2019 

05_Input_data\Input_data.mdb\Vehicles_parameters_PartA_Base2019 
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This table, Table 57, provides information about the vehicle parameters related to the cost and property of 

the vehicle identified by vehicle type VEH_NR (or DESCRIPTIO or LABEL). 

Table 57 - Format of “Vehicles_parameters_PartA_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 4 

ID Index for vehicle type  Integer 4 

VEH_NR Vehicle number Integer 104 

DESCRIPTIO Description of vehicle type String Lorry HGV 25-

40 tonne 

LABEL Short name for the vehicle type String HGV24 

VESSELTYPE Vessel Type (container/non container) Integer 0 

CAPACITY Maximum Load Capacity (Tonnes) Double 28 

COORFACT Coordination factor. Factor used to catch the fact that the available 

volume for each vehicle movement will be lower than the calculated 

annual consolidation volumes on the OD-legs 

Single 10 

HOURS_COST Hour cost [SEK/h] Double 288 

KM_COST Km cost [SEK/km] Double 3.7794 

ONFER_H_C On Ferry Hour Cost (SEK/hour) Double 488.4 

ONFER_KM_C On Ferry Km Cost (SEK/km) Double 2.9 

POSICOST Positioning Cost (SEK/vehicle) Double 0 

DFLTFREQ Default frequency (per week) Double 84 

F_DUES_VH Fairway Dues per Vehicle (SEK/vessel) Double 0 

F_DUES_TON Fairway Dues per Tonne (SEK/tonne) Double 0 

SPEED Speed (only sea modes) (km/hour) Double -1 

VDF_SPEC Volume delay function index (FUNCTION in link table) Double 64 

MODE_1 Code for network mode alternative 1 String a 

MODE_2 Code for network mode alternative 2  String - 

FUNC_FILE Set of applied travel time functions applied  String V102 

EMPTY_V Dummy variable to take in account empty vehicles during the 

creation of OD vehicle matrices. (0=no 1=yes) 

Integer 1 

MAX_SPEED Define speed limits for road vehicles Double 116 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Defines all the parameters related to cost and time coefficients for the logistics model 

(files under LogMod\Input\COST) by vehicle type. Also controls the codes used in opening/closing links in 

the network (parameters SPEED, VDF_SPEC, MODE_1, MODE_2, FUNC_FILE) during LOS and 

assignment steps. 
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Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Create the tables specific of scenario” 

subgroup under “Edit the data” and its subgroup “Compare other tables”, “Data Preparation” subgroup 

under “Samgods Model > LOS calculation” and “Create the new base” subgroup under “Handling scenario > 

Scenario Export”. 

 

3.2.3.14. Vehicles_parameters_PartB_Base2019 

05_Input_data\Input_data.mdb\Vehicles_parameters_PartB_Base2019 

This table, Table 58, provides information about the vehicle parameters related to cost for loading and 

unloading identified by vehicle type VEH_NR and commodity ID_COM. 

Table 58 - Format of “Vehicles_parameters_PartB_Base2019” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 4 

ID Index for vehicle type  Integer 4 

ID_COM Identifier for commodity group Integer 16 

VEH_NR Vehicle number Integer 104 

CONT_LTI Container Load Time (hours) Double 1 

CONT_LCO Container Load Cost (SEK/tonne) Double 17 

CONT_LTI_T Container Load Time at transfer (hours) Double 1 

CONT_LCO_T Container Load Cost at transfer (SEK/tonne) Double 17 

NC_LTI Non container Load Time (hours) Double 2 

NC_LCO Non container Load Cost (SEK/tonne) Double 3 

NC_LTIT Non container Load Time at transfer (hours) Double 2 

NC_LCOT Non container Load Cost at transfer (SEK/tonne) Double 3 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Defines all the parameters related to cost and time coefficients for the logistics model 

(files under LogMod\Input\COST). 

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific 

tables and the base tables. 

Used by: “Editable tables” subgroup under “Create the editable files”, “Create the tables specific of scenario” 

subgroup under “Edit the data” and its subgroup “Compare other tables”, “Data Preparation” subgroup 

under “Samgods Model > LOS calculation” and “Create the new base” subgroup under “Handling scenario > 

Scenario Export”. 

 

3.2.3.15. Scenarios_List 

05_Input_data\Input_data.mdb\Scenarios_List 

This table, Table 59, holds information about the elasticity scenarios identified by ID_SCENARIO. 
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Table 59 - Format of “Scenarios_List” table. 

Field Description Data Format Example 

ID Counter Integer 4 

ID_SCENARIO Scenario number Integer 4 

Mode Description of mode in which sensitivity test is applied (can be a 

main mode or a combination of vehicle types) 

String Road 

Scenario Scenario types String KM_3 

KM_COST Variation in km cost Double 1.02 

HOURS_COST Variation in hour cost Double 1 

NC_LTI Variation in non-container loading time  Double 1 

NC_LTIT Variation in non-container loading time transit Double 1 

CONT_LTI Variation in container loading time Double 1 

CONT_LTI_T Variation in container loading time transfer Double 1 

TOLL Variation in toll Double 1 

TRACK_F Variation in track fee Double 1 

F_DUES_VH Variation in ferry due vehicles Double 1 

F_DUES_TON Variation in ferry due tons Double 1 

ID_VEHICLES Vehicle types range String 101-106 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Defines all the parameters related to cost and time coefficients for sensitivity tests within 

“Elasticity module”. 

Editing Options: Edits from Cube or Microsoft Access. 

Used by: “Elasticity module”. 

 

3.2.4. Scenario specific data 

In term of structure all the tables listed above have a copy in the scenario specific data, shown by the 

relations presented in Table 60. 

Table 60 - Relation between base and scenario specific data. 

Base Table Scenario Specific Table 

Base2019 Sc_{SCENARIO_SHORTNAME}_Link 

Sc_{SCENARIO_SHORTNAME}_Node 

Cargo_Base2019 Sc_{SCENARIO_SHORTNAME}_Cargo 

Frequency_Data_Base2019 Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Link 

Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Node 

Node_terminals_Base2019 Sc_{SCENARIO_SHORTNAME}_Node_Terminals 
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Nodes_Base2019 Sc_{SCENARIO_SHORTNAME}_Nodes 

Nodes_Commodities_Base2019 Sc_{SCENARIO_SHORTNAME}_Nodes_commodities 

PropLink_Base2019 Sc_{SCENARIO_SHORTNAME}_PropLink 

Rail_Capacity_Base2019 Sc_{SCENARIO_SHORTNAME}_Rail_Capacity 

Tax_Category_Base2019 Sc_{SCENARIO_SHORTNAME}_Tax_Category 

Tax_Country_Base2019 Sc_{SCENARIO_SHORTNAME}_Tax_Country 

Tax_Link_Base2019 Sc_{SCENARIO_SHORTNAME}_Tax_Link 

Toll_Link_Base2019 Sc_{SCENARIO_SHORTNAME}_Toll_Link 

Vehicles_parameters_PartA_Base2019 Sc_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA 

Vehicles_parameters_PartB_Base2019 Sc_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB 

All the scenario specific tables (except SC_{SCENARIO_SHORTNAME}_ProprLink, 

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA , 

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB and 

SC_{SCENARIO_SHORTNAME}_Cargo) have an extra attribute UP_DATE or UP_DATE_N that will 

record the differences between the scenario and the reference case. 

This field, with string format, is used to store the information regarding how to update the base data. The 

following values are used 

• U - Update an existing value in the base table; 

• A - Append a new record to the base table; 

• D - Delete a record from the base table. 

These values are automatically managed by the applications “Edit the data”. The user must not type, modify, 

or change them. For ProprLink and Vehicles_Parameters all the elements present in these table will 

overwrite those in the reference case, e.g. a simpler substitution.  

There are two other tables that are managed differently from the general rule: 

General_{SCENARIO_SHORTNAME} and LogMod_{SCENARIO_SHORTNAME}. These are scenario 

specific and are not managed through the general difference record keeping. Those tables hold the definition 

of several control parameters used in the Logistics Module and in the GUI. They contain parameters that are 

controlled by catalog keys and could vary between scenarios. 

3.2.4.1. General_{SCENARIO_SHORTNAME} 

05_Input_data\Input_data.mdb\General_{SCENARIO_SHORTNAME} 

This table, Table 61, holds general information about the scenario. 

Table 61 - Format of “General_{SCENARIO_SHORTNAME}” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SC_N Scenario number (1-default, higher if saved also in 

emmebank)  

Integer 1 

DATE_C Date and time of creation  String 14/08/2013 09:24 

DATE_L Date and time of last modification if the scenario is in 

read/write mode, otherwise the date of lock. 

String 14/08/2013 11:01 
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Field Description Data Format Example 

ZONES_M Number of zones Integer 1120 

GCOST Attribute name for extra cost on links [SEK] String EC_V 

GCOST_KM Attribute name for extra cost per km on links [SEK/km] String EC_KM_V 

DF Daily factor for all the modes except rail mode [number of 

days per year] 

Integer 250 

DFR Daily factor for rail mode [number of days per year] Integer 250 

READ_WRITE State of scenario (only read or read/write Yes=only read) String Yes 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: This table responds to a high variety of uses: 

• SC_N is used to recode where the base network was saved in the emmebank (1 if not, higher is 

saved). Since EMME is not used in the model anymore, it will always be 1 

• DATE_C and DATE_L are the time references to check when updating existing temporary data in 

the model. They are also used for long time storage purposes 

• ZONE_M, GCOST and GCOST_KM refer to this kind of attributes saved in the network 

• DF and DFR: general parameters for assignment 

• READ_WRITE: state variable to prevent further edits of a scenario, or to leave the scenario as 

editable. 

Editing Options: The first two points listed above, and the last one, are managed by the system, never 

changed by the user. The others (ZONE_M, GCPST, GCOST_KM,DF,DFR) are modifiable from catalog keys 

present in the interface under "Edit the data" application. 

Used by: “Prepare temporary data” subgroup under “Create the editable files”, “Create the tables specific of 

scenario” subgroup under “Edit the data”, “PWC_Matrices” and several subgroups under “Samgods Model”. 

 

3.2.4.2. LogMod_{SCENARIO_SHORTNAME} 

05_Input_data\Input_data.mdb\LogMod_{SCENARIO_SHORTNAME} 

This table, Table 62, holds information from the GUI used in the LogMod module. 

Table 62 - Format of “LogMod_{SCENARIO_SHORTNAME}” table. 

Field Description Data 

Format 

Example 

OBJECTID Counter Integer 1 

INTER_RATE Parameter INTEREST, interest rate used in cost calculations [%/year] Double 0.1 

STUFF Parameter STUFF, costs for stuffing and stripping of containers at the origin and 

destination of a chain [SEK per tonne] 

Double 60 

CONTYPE Parameter ALL_LORRY_TYPE_CONSOL, 0/1 switch that determines whether or not 

consolidation is allowed for all lorry types 

Integer 1 

INODLO Parameter INDIVIDUAL_OD_LEG_OPTIMIZE, 0/1 switch that determines whether 

or not the optimization is done for each chain leg individually in a transport chain 

Integer 1 
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MATD4FO Parameter MINIMUM_ANNUAL_TONNE_DEMAND_4_FREQ_OPTIMIZE 

[Tonnes], Minimum demand for frequency optimization 

Double 100 

CONSOL_L First value of parameter CONSOL. It sets the default lower bound for the consolidation 

levels.  

Double 0.05 

CONSOL_U Second value of parameter CONSOL. It sets the default upper bound for the 

consolidation levels.  

Double 0.95 

TONNES Parameter TONNES. If this parameter is a number, then this number will be used as 

the typical shipment size for this commodity. If this the parameter is set to 

DYNAMIC_MAX, DYNAMIC_AVERAGE or DYNAMIC_GEOMEAN the typical 

shipment size will be different for different zones and calculated as the maximum, 

average or geometric mean of the PWC matrix-values for the current origin zone 

String DYNAMIC_A

VERAGE 

LSTCNT Parameter LSTCNT It sets the number of output files: 1= only best chains; 2 = best 

chains and second best chains. The current default is 5. It is recommended to not 

change this default since it is related to Rail Capacity Management module. 

Integer 5 

DATA Parameter DATA, Output variables for the optimal transport solution [e.g.1,2,3, max is 

8]. Nbrs 6 and 7 are useful when analysing detail in the results since all relevant data 

for the transport chains are available. The cost data are split into different 

components, operational costs, loading/unloading costs and infrastructure costs. 

String 6,7 

FACTOR Parameter FACTOR, Initial consolidation factor in BuildChain (1st iteration) Single 0.75 

LOGCTL Parameter LOGCTL, indicator (0/1) that determines whether or not CTL file settings 

will be logged in the common log file for the commodity 

Integer 1 

LOGFLS Parameter LOGFLS, indicator (0/1) that determines whether or not input file 

information will be logged in the common log file for the commodity 

Integer 1 

LOGCST Parameter LOGCST, indicator (0/1) that determines whether or not cost parameters 

will be in the common log file for the commodity 

Integer 1 

BESTOUT Parameter BESTOUT, integer that determines whether or not DATA reports should be 

print out per each solution (best, second, third, etc. solution) 

Integer 1 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: This table is used in setting up the control files for BuildChain, ChainChoi, 

BuildChainRCM and ChainChoiRCM. All the parameters listed above control the process both in terms of 

reporting (log files) and settings for some variables. See reference 2 for their meaning and usage. 

Editing Options: In "Edit the data" application each parameter is present as catalog key. Its value could be 

revised directly from the Scenario Window. For further details see reference 6. 

Used by: “Prepare temporary data” subgroup under “Create the editable files,” “Prepare Data third part” 

subgroup under “Samgods Model > Logistics Module”, “Delete” and “Scenario Import” subgroups under 

“Handling scenario” and “General tables” subgroup under “Handling scenario > Scenario Export”. 

 

3.2.5. Manage database 

3.2.5.1. History 

05_Input_data\Input_data.mdb\History 

This table, Table 63, holds information about the different instances. 
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Table 63 - Format of “History” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

MODEL Folder of the original model used to create the new model 

(father model)  

String {CATALOG_DIR}  

BASE_SCE Name of Base scenario in original model String Base2019 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: For setting up new models (new model is created each time it is required to modify some 

general settings or input file such as chain types, etc). The table maintains the information of the father 

model used to setup the new model. This table traces the relationships among different versions. 

Editing Options: Always changed by the system. 

Used by: “General tables” subgroup under “Handling scenario > Scenario Export.” 

 

3.2.5.2. Model_description 

05_Input_data\Input_data.mdb\Model_description 

This table, Table 64, holds information about the programs related to the setup. 

Table 64 - Format of “Model_description” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

NAME Software name String Cube 

REALISE Software version String 6.1.0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcMap, ArcCatalog. 

Description of Use: Defines the release version for each program used in the model. This information could 

allow be checked regarding whether the correct version of a particular model is used. 

Editing Options: No edits; always changed by the system. 

Used by: “Installation,” “General tables” subgroup under “Handling scenario > Scenario Export” and 

“Scenario Import” subgroup under “Handling scenario”. 

 

3.3. Calibration data 

The calibration data is used when running the model in calibration mode. When using the model as standard 

or advance user this data is not modified along the run. It represents the calibrated conditions that should be 

used in evaluating different scenarios and represents an input an invariant input for the model. 

 

3.3.1. Speed and vessel capacity factors 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\ Base2019_Link 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\ MainSc2045_Link 
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This table,Table 65, provides the scaling and adding factors on network links. 

Table 65 - Format of “Base2019_Link“ and “MainSc2045_Link” tables. 

Field Description Data Format Example 

OBJECTID Index  Integer 1 

A Start node in VY Numbering Integer 2027 

B End node in VY Numbering Integer 2068 

SPEED_1_FA Scaling factor for Speed_1 Double 1.029411765 

SPEED_2_FA Scaling factor for Speed_2 Double 1.029411765 

Descript Name of the infrastructure with modified speed String _ 

SPEED_1_TE Adding factor for Speed_1 Double 0 

SPEED_2_TE Adding  factor for Speed_2 Double 0 

UL3_FA Scaling factor for Capacity for vessels on sea (dwell tons) Double 1 

UL3_TE Adding factor for Capacity for vessels on sea (dwell tons) Double 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines the scaling and adding factors applied to SPEED_1, SPEED2 and UL3 in the 

network links. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > LOS Calculation” (and elasticity module). 

 

3.3.2. Scaling factor for Kiel Canal 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\KielCanal_Parameter_Base2019 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\KielCanal_Parameter_MainSC204

5 

This table, Table 66, provide the scaling factor for the Kiel Canal tolls. 

Table 66 - Format of “KielCanal_Parameter_Base2019 “ and “KielCanal_Parameter_MainSC2045” 

tables. 

Field Description Data Format Example 

ID Index  Integer 1 

Factor Scaling factor for Kiel Canal Double 2.2 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines the toll scaling factor on Kiel. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > LOS Calculation” (and elasticity module). 

 

3.3.3. Locked solution list 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Locked_2019 
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05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\Locked_2045 

This table, Table 67, provides the list of locked solutions which will be excluded in the logistic chain choice, 

usually associated to high volumes. 

Table 67 - Format of “Locked_2019“ and “Locked_2045” tables. 

Field Description Data Format Example 

ID Index  Integer 49 

Commodity Commodity group  Integer 1 

FromNode Production zone Integer 960700 

SubCell Sub cell in the PWC matrix  Integer 0 

ToNode Attraction zone Integer 960100 

Freq Frequency Integer -1 

Mode Associated mode String I 

NNodes Number of nodes on the route Integer 3 

Node1 Starting terminal Integer 960711 

Node2 Next terminal Integer 930511 

Node3 Next terminal Integer 960111 

Node4 Next terminal Integer  

Node5 Next terminal Integer  

Node6 Next terminal Integer  

Name1 Description of first terminal String Rail:Narvik 

Name2 Description of second terminal String Rail:Bensjobacken 

Name3 Description of third terminal String Rail:Olso 

Name4 Description of fourth terminal String  

Name5 Description of fifth terminal String  

Name6 Description of sixth terminal String  

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines  the locked solutions. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > Logistic Module\RCM” (and elasticity 

module). 

 

3.3.4. Factors for cost terminals  

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Nodes_Base2019 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\Nodes_MianSc2045 

This table,Table 69, provides the scaling and adding factors to the cost and time technological factors on 

terminals and ports. 
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Table 68 - Format of “Nodes_Base2019“ and “Nodes_MainSc2045” tables. 

Field Description Data Format Example 

OBJECTID Index  Integer 1 

N Node number in VY Numbering Integer 386 

ZONEID Node number in  EMME Numbering Integer 848021 

C_TECH_FAC_FA Scaling factor for cost technological factor Double 0.8 

C_TECH_FAC_TE Adding factor for cost technological factor Double 0 

T_TECH_FAC_FA Scaling factor for time technological factor Double 0.8 

T_TECH_FAC_TE Adding factor for time technological factor Double 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines the scaling and adding factors applied to cost and time technological factors for 

terminals and ports. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > Logistic Module” (and elasticity module). 

3.3.5. Parameters_Kielcalibration 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Parameters_Kielcalibration 

This table, Table 69, holds information about the calibration of Kiel canal scaling factor. 

Table 69 - Format of “Parameters_Kielcalibration” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID ID record Integer 1.0 

STEP Step length in increasing or decreasing the Kiel canal scaling factor (starting from 

1, 1+STEP or 1-STEP depending the search function) 

Double 0.02 

MINVAL Minimum boundary for scaling factor. If after adjustment the value is below this 

value, it will be reset to VAL0 

Double 0.01 

DIFMAX Maximum difference between modelled and surveyed value. In this case the 

distribution of tons between Kiel Canal and Jylland. 2 is in percentage 

Double 2 

VAL0 Reset value used in case the procedure gives negative or less than MINVAL 

results. 

Double 0.02 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines the control parameters in the adjust procedure for the Kiel Canal scaling factor. 

Editing Options: No edits. Inputs for the calibration procedure. 

Used by: “Samgods\Parameters calculation,” “General tables” subgroup under “Handling scenario > 

Scenario Export” and “Scenario Import” subgroup under “Handling scenario”. 

 

3.3.6. Parameters_portcalibration 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Parameters_portcalibration 
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This table, Table 70, holds information about the searching method applied in the calibration process. . 

Table 70 - Format of “Parameters_portcalibration” table. 

Field Description Data 

Format 

Example 

OBJECTID Counter Integer 1 

ID ID record Integer 1.0 

STEP Step length in increasing or decreasing the Kiel canal scaling factor (starting 

from 1, 1+STEP or 1-STEP depending on the search direction) 

Double 0.02 

MINVAL Minimum boundary for scaling factor. If after adjustment the value is below 

this value, it will be reset to VAL0 

Double 0.01 

DIFMAX Maximum difference between modelled and surveyed value. In this case it is the 

total tonne throughput per port area and commodity group. (100*1000 tons 

since statistics are tons/1000) 

Double 100 

VAL0 Reset value used in case the procedure gives negative or less than MINVAL 

results. 

Double 0.02 

Software Required: Cube Data Window, Dbf editor. 

Description of Use: Defines the control parameters in the scaling factor adjustment procedure for Port Areas 

per commodity group. 

Editing Options: No edits. Inputs for the calibration procedure. 

Used by: “Samgods\Parameters calculation,” “General tables” subgroup under “Handling scenario > 

Scenario Export” and “Scenario Import” subgroup under “Handling scenario”. 

3.3.7. Port Area parameters per commodity group 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\PortAreaParams_16_Comm_Base2

019 and 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\PortAreaParams_16_Comm_Main

Sc2045 

This table, Table 71, provide the scaling factor per commodity and port area. 

Table 71 - Format of “PortAreaParams_16_Comm” table. 

Field Description Data Format Example 

ID Counter Integer 1 

PortArea Port Area number Integer 1 

COM01 Scaling factor for COMMODITY group 1 Long 1000 

COM02 Scaling factor for COMMODITY group 2 Long 0.5 

COM03 Scaling factor for COMMODITY group 3 Long 0.9 

COM04 Scaling factor for COMMODITY group 4 Long 1000 

COM05 Scaling factor for COMMODITY group 5 Long 1000 

COM06 Scaling factor for COMMODITY group 6 Long 2.4 

COM07 Scaling factor for COMMODITY group 7 Long 0.5 
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COM08 Scaling factor for COMMODITY group 8 Long 0.4 

COM09 Scaling factor for COMMODITY group 9 Long 3 

COM10 Scaling factor for COMMODITY group 10 Long 3 

COM11 Scaling factor for COMMODITY group 11 Long 1000 

COM12 Scaling factor for COMMODITY group 12 Long 1.5 

COM13 Scaling factor for COMMODITY group 13 Long 1000 

COM14 Scaling factor for COMMODITY group 14 Long 2.7 

COM15 Scaling factor for COMMODITY group 15 Long 3 

COM16 Scaling factor for COMMODITY group 16 Long 1000 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines the scaling factor applied in TIME skim per port area and commodity group. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods\Logistics Module\” “General tables” subgroup under “Handling scenario > Scenario 

Export” and “Scenario Import” subgroup under “Handling scenario.” 

 

 

3.3.8. Rail capacity factors 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Rail_Capacity_Base2019 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\Rail_Capacity_MainSc2045 

This table, Table 72, provides the scaling and adding factors on rail capacities at link level. 

Table 72 - Format of “Rail_Capacity_Base2019“ and “Rail_Capacity_MainSc2045” tables. 

Field Description Data Format Example 

OBJECTID Index  Integer 1 

A Start node in VY Numbering Integer 75557 

B End node in VY Numbering Integer 75563 

ORIGCAP_FA Scaling factor for rail capacity Double 0.044776119 

ORIGCAP_TE Adding factor for rail capacity Double 0 

OBJECTID Index  Integer 1 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window). 

Description of Use: Defines the scaling and adding factors applied to Rail capacity table. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > LOS Calculation” (and elasticity module). 

 

3.3.9. Factors for taxes by country 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Tax_Country_Base2019 
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05_Input_data\\Calibration\Input_Data_Calibration_MainSc2045.mdb\Tax_Country_MainSc2045 

This table,Table 73, provides information about the scaling and adding parameters for tax SEK_KM by 

country ID_COUNTRY and vehicle type ID_VEHICLE. 

Table 73 - Format of “Tax_Country_Base2019” and “Tax_Country_MainSc2045” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COUNTRY Country code Integer 501 

ID_VEHICLE Vehicle type Integer 201 

SEK_KM_FA Scaling factor for  country tax per km Double 1 

SEK_KM_TE Adding factor for country tax per km Double 0 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Specifies scaling and adding factors on the link based tax defined by country and vehicle 

type.  

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > Logistic Module” (and elasticity module). 

 

3.3.10. Factors for taxes by Link 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Tax_Link_Base2019 

05_Input_data\\Calibration\Input_Data_Calibration_MainSc2045.mdb\Tax_Link_MainSc2045 

This table, Table 74, provides information about the scaling and adding parameters on tax SEK per link A-B 

and vehicle type VEH_NR. 

Table 74 - Format of “Tax_Link_Base2019” and “Tax_Link_MainSc2045” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

A Start node in VY Numbering Integer 2015 

B End node in VY Numbering Integer 78051 

VEH_NR Vehicle type Integer 301 

SEK_FA Scaling factors for the track fee or tax  Double 1 

SEK_TE Adding factors for the track fee or tax Double 0 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Specifies scaling and adding factors on the link based tax defined by link and vehicle type.  

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > Logistic Module” (and elasticity module). 
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3.3.11. Factors for tolls by link 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Toll_Link_Base2019 

05_Input_data\\Calibration\Input_Data_Calibration_MainSc2045.mdb\Toll_Link_MainSc2045 

 

This table, Table 75, provides information about the scaling and adding parameters applied to the toll SEK 

per link A-B and vehicle type VEH_NR. 

Table 75 - Format of “Toll_Link_Base2019” and “Toll_Link_MainSc2045” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 260 

A Start node in VY Numbering Integer 11964 

B End node in VY Numbering Integer 11969 

VEH_NR Vehicle type Integer 101 

SEK_FA Scaling factor for the Link toll [SEK] per passing vehicle Double 0.82 

SORT Toll sorting index String 1196601101 

DESCRIPT Description of the infrastructure (in general bridges) String Toll Oresund 

SEK_TE Adding factor for the Link toll [SEK] per passing vehicle Double 809 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Defines a toll applied to a link per vehicle type. 

Editing Options: No edits. Results from the calibration procedure. 

Used by: “Samgods Model > Initialization”, “Samgods Model > Logistic Module” (and elasticity module). 

 

3.3.12. Scaling parameters for vehicle attributes Part A 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Vehicles_parameters_PartA_Base2

019 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\Vehicles_parameters_PartA_Main

Sc2045 

Table 76, provides information about the scaling of vehicle costs and properties. 

Table 76 - Format of “Vehicles_parameters_PartA_Base2019” and 

“Vehicles_parameters_PartA_MainSc2045” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID Index for vehicle type Integer 1 

VEH_NR Vehicle type Integer 101 

CAPACITY_FA Scaling factor for Capacity Double 1 

COORFACT_FA Scaling factor for coordination factor Double 1 

HOURS_COST_FA Scaling factor for hours cost Double 1.1 

KM_COST_FA Scaling factor for km cost Double 1.1 
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ONFER_H_C_FA Scaling factor for on ferry hour cost Double 0.5 

ONFER_KM_C_FA Scaling factor for on ferry km cost Double 0.5 

POSICOST_FA Scaling factor for positioning cost Double 1 

DFLTFREQ_FA Scaling factor for default frequency Double 1 

F_DUES_VH_FA Scaling factor for ferry dues vehicle cost Double 1 

F_DUES_TON_FA Scaling factor for ferry dues tons cost Double 1 

MAX_SPEED_FA Scaling factor for max speed Double 1 

CAPACITY_TE Adding factor for Capacity Double 0 

COORFACT_TE Adding factor for coordination factor Double 0 

HOURS_COST_TE Adding factor for hours cost Double 0 

KM_COST_TE Adding factor for km cost Double 0 

ONFER_H_C_TE Adding factor for on ferry hour cost Double 0 

ONFER_KM_C_TE Adding factor for on ferry km cost Double 0 

POSICOST_TE Adding factor for positioning cost Double 0 

DFLTFREQ_TE Adding factor for default frequency Double 0 

F_DUES_VH_TE Adding factor for ferry dues vehicle cost Double 0 

F_DUES_TON_TE Adding factor for ferry dues tons cost Double 0 

MAX_SPEED_TE Adding factor for max speed Double 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcCatalog. 

Description of Use: Define the scaling factors and Adding factors applied to vehicle parameters table in 

Samgods. 

Editing Options: Updated during the calibration process. No need to change for standard run. 

Used by: : “Samgods Model > Initialization”, “Samgods Model > Logistics Module\Prepare data application.” 

(and elasticity module). 

3.3.13. Scaling parameters for vehicle attributes Part B 

05_Input_data\Calibration\Input_Data_Calibration_Base2019.mdb\Vehicles_parameters_PartB_Base2

019 

05_Input_data\Calibration\Input_Data_Calibration_Base2045.mdb\Vehicles_parameters_PartB_Main

Sc2045 

Table 77 provides information about the scaling of vehicle costs and properties. 

Table 77 - Format of “Vehicles_parameters_PartB_Base2019” and 

“Vehicles_parameters_PartB_MainSc2045” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID Index for vehicle type Integer 1 

ID_COM Commodity group  Integer 1 

VEH_NR Vehicle number Integer 101 

CONT_LTI_FA Scaling factor for Container Load Time  Double 88 

CONT_LCO_FA Scaling factor for Container Load Cost   Double 88 

CONT_LTI_T_FA Scaling factor for Container Load Time at transfer Double 88 

CONT_LCO_T_FA Scaling factor for Container Load Cost at transfer Double 88 

NC_LTI_FA Scaling factor for Non container Load Time Double 0.9 

NC_LCO_FA Scaling factor for Non container Load Cost   (SEK/tonne) Double 0.9 

NC_LTIT_FA Scaling factor for Non container Load Time at transfer Double 0.9 
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NC_LCOT_FA Scaling factor for Non container Load Cost at transfer Double 0.9 

CONT_LTI_TE Adding factor for Container Load Time  Double 0 

CONT_LCO_TE Adding factor for Container Load Cost   Double 0 

CONT_LTI_T_TE Adding factor for Container Load Time at transfer Double 0 

CONT_LCO_T_TE Adding factor for Container Load Cost at transfer Double 0 

NC_LTI_TE Adding factor for Non container Load Time Double 0 

NC_LCO_TE Adding factor for Non container Load Cost   (SEK/tonne) Double 0 

NC_LTIT_TE Adding factor for Non container Load Time at transfer Double 0 

NC_LCOT_TE Adding factor for Non container Load Cost at transfer Double 0 

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window), 

ArcCatalog. 

Description of Use: Define the scaling factors and adding factors by vehicle type and commodity group to 

vehicle parameters table in Samgods. 

Editing Options: Updated during the calibration process. No need to change for standard run. 

Used by: : “Samgods Model > Initialization”, “Samgods Model > Logistics Module\Prepare data application.” 

(and elasticity module). 

 

3.4. Output data 

The output data can be split into two classes; the first one is the output that always will be generated by the 

model independently of the user choices, the second one is only generated on user request. 

3.4.1. General tables in geodatabase 

The general tables provide general information about the scenario. 

3.4.1.1. Model description 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Model_descripti

on 

This table, Table 78, is a copy of Table 64. 

Table 78 - Format of “Model_description” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

NAME Software name String Cube 

REALISE Software version String 6.1.0 

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Defines the release version for each program involved in the model. It is used for long-

term management of the model. 

Used by: Not used. 

Made by user choice: No. 

 

3.4.1.2. Outputs 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\outputs 
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This table, Table 79, holds information about which outputs that been produced. 

Table 79 - Format of “outputs” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 2 

OUTPUTR Description of the output String LOS_ROAD 

ID_COM Commodity code (0 for all) Double 0 

DATE_E Date of last modification for the input data used to create 

this output 

String 03-Feb-15 07:17 PM 

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Storage of some input data settings and some output data for the last model runs.  

Created by: “Prepare temporary data” subgroup under “Create the editable files.” 

Updated by: several subgroups in the “Samgods Model” application. 

Made by user choice: No. 

 

3.4.1.3. Node_labels 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Node_labels 

This table, Table 80, holds information about the nodes. 

Table 80 - Format of “Node_labels” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

N Node number VY Numbering Integer 1 

NORIG Node number Emme numbering Integer 711400 

SCBSTANN SCBSTANN code Integer 114 

ID_COUNTRY Country code Integer 1 

ID_REGION Region code Integer 114 

MODE_N Mode for access to terminals Integer 0 

UI4 User field (not used in the current model) Integer 0 

X Coordinate x (SWEREF99_TM) Integer 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Integer 6601000 

CENTRALL Description String Upplands-Väsby 

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Table with labels for each zone in the network. For reporting purposes and inside the 

model for mapping of data between Voyager and EMME node numbering systems. 
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Created by: “Data Preparation” subgroup under “Samgods Model > LOS calculation.” 

Used by: “Change matrix format” application. 

Made by user choice: No. 

 

3.4.1.4. ProprLink_{SCENARIO_SHORTNAME} 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\ProprLink_{SC

ENARIO_SHORTNAME} 

This table, Table 81, holds information about the output proportional table. 

Table 81 - Format of “ProprLink_{SCENARIO_SHORTNAME}” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 696 

A Start node Integer 2793 

B End node Integer 2794 

REGION SCBSTANN code Integer 136 

WEIGHT Proportion of the link within the SCBSTANN code (for 

instance 100 means 100% of the link is in 136 SCBSTANN 

code) 

Double 100 

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window), 

ArcCatalog. 

Description of Use: Table with all road and rail links that are distributed in different SCBSTANN areas. Each 

record gives the proportion of the length of the link part residing in each SCBSTANN area. The proportion is 

used to estimate tonne km and vehicle km statistics per region and county. (See reports #9, 16, 17 and 18). 

Used by: “Reports per geographical aggregation” subgroup under “Samgods Model > Results > Results 1.0,” 

“Samgods Model > Results RCM > Results1.0”, “Create the new base” subgroup under “Handling scenario > 

Scenario Export” and “Create the scenario tables” subgroup under “Handling scenario > Scenario Export > 

Create the new scenario specific tables”.



Input and output file reference 

3.4.2. Network format in geodatabase 

Here, the transports are presented in network format. The link tables are all identified by a link given in VY 

numbering. If not the network is does not contain the term Bid (or Bidir or similar, short for bidirectional) 

then the network is directed, otherwise it is aggregated to an undirected (bidirectional) network. 

3.4.2.1. Load_net_Road_0 and Load_net_Road_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Roa

d_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Roa

d_RCM 

The node table, Table 82, and the link table, Table 83, holds information about the transports per road link 

A-B. 

Table 82 - Format of “Load_net_Road_0_Node” and “Load_net_Road_RCM_Node” tables. 

Field Description Data 

Format 

Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of ID_Country, 

ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer 0 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

Table 83 - Format of “Load_net_Road_0_Link” and “Load_net_Road_RCM_Link” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 16 

SHAPE Feature class type (lane) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 16 

B End node in VY Numbering Integer 2813 

Shape_Length Length based on distance between coordinates in meters Double 1359.1541 

MODESTR String with all the allowed modes String Xabc 

SPEED_1 Vehicle speed in kms per hour for all vehicles except vehicles 102- Double 50 
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Field Description Data Format Example 

106 in Sweden 

SPEED_2 Vehicle speed in kms per hour for vehicles 102-106 in Sweden Double 50 

CATEGORY Link category Integer 201 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

UL3 Capacity for vessels on sea (dwell tons) Double 0 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 1 

DISTANCE Distance in kms ( not equals to UL2)  Double 1.36 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

LGV3 Yearly vehicle 101 flow (number of loaded vehicles)  Double 3 

LGV3T Yearly vehicle 101 tonne flow Double 2.1511 

LGV3E Yearly vehicle 101 flow (number of empty vehicles)(number of 

empty vehicles) 

Double 0.5 

MGV16 Yearly vehicle 102 flow (number of loaded vehicles) (number of 

loaded vehicles)  

Double 0 

MGV16T Yearly vehicle 102 tonne flow Double 0 

MGV16E Yearly vehicle 102 flow (number of empty vehicles)(number of 

empty vehicles) 

Double 0 

MGV24 Yearly vehicle 103 flow (number of loaded vehicles) (number of 

loaded vehicles)  

Double 0 

MGV24T Yearly vehicle 103 tonne flow Double 0 

MGV24E Yearly vehicle 103 flow (number of empty vehicles)(number of 

empty vehicles) 

Double 0 

HGV40 Yearly vehicle 104 flow (number of loaded vehicles) (number of 

loaded vehicles)  

Double 0 

HGV40T Yearly vehicle 104 tonne flow Double 0 

HGV40E Yearly vehicle 104 flow (number of empty vehicles)(number of 

empty vehicles) 

Double 0 

HGV60 Yearly vehicle 105 flow (number of loaded vehicles) (number of 

loaded vehicles)  

Double 0.17989 

HGV60T Yearly vehicle 105 tonne flow Double 0.8457 

HGV60E Yearly vehicle 105 flow (number of empty vehicles)(number of 

empty vehicles) 

Double 0.50340 
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Field Description Data Format Example 

HGV74 Yearly vehicle 106 flow (number of loaded vehicles) (number of 

loaded vehicles)  

Double 0 

HGV74T Yearly vehicle 106 tonne flow Double 0 

HGV74E Yearly vehicle 106 flow (number of empty vehicles)(number of 

empty vehicles) 

Double 0 

TOT_ROAD Yearly vehicle flow (number of loaded vehicles) (number of 

loaded vehicles) for the road mode  

Double 3.17989 

TOT_ROAD_T Yearly tonne flow for the road mode Double 2.9968 

TOT_ROAD_E Yearly vehicle flow (number of empty vehicles)(number of empty 

vehicles) for the road mode  

Double 1.00340 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for the road mode for standard logistic module and Rail Capacity 

Management. 

Created by: “Road Assignment” subgroup under “Samgods Model > Assignment” and “Road Assignment 

RCM” subgroup under “Samgods Model > RCM Assignment.” 

Used by: “Results” and "Results RCM" subgroups under “Samgods Model.” 

Made by user choice: No. 

 

3.4.2.2. Load_net_Rail_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Rail

_0 

The node table, Table 84, and the link table, Table 85, holds information about the transports per rail link A-

B. 

Table 84 - Format of “Load_net_Rail_0_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 
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Field Description Data Format Example 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

Table 85 - Format of “Load_net_Rail_0_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (Polyline) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 21 

B End node in VY Numbering Integer 2127 

Shape_Length Length based on distance between coordinates in meters Double 206.1552 

MODESTR String with all the allowed modes String Xabc 

SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0 

CATEGORY Link category Integer 211 

FUNCTION Index for vdf function Double 66 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

UL3 Field for capacity constrains in Vanel canal (tonnes) Double 0 

TRAKBANDEL Trakbandel number for specific link Integer 1011 

ORIGINALCAP Capacity on rail links from Capacity table (number of trains per 

day) 

Double 0 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 2 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

CLOSE_ Flag 0/1 to treat vehicles 202/203 Integer 0 

KOMBI Yearly vehicle 201 flow (number of loaded vehicles)  Double 0 

KOMBIT Yearly vehicle 201 tonne flow Double 0 

KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double 0 

KOMXL Yearly vehicle 210 flow (number of loaded vehicles)  Double 0 

KOMXLT Yearly vehicle 210 tonne flow Double 0 

KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double 0 

FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles)  Double 325.2379 

FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875 
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Field Description Data Format Example 

FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791 

SYS22 Yearly vehicle 204 flow (number of loaded vehicles)  Double 0 

SYS22T Yearly vehicle 204 tonne flow Double 0 

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double 0 

SYS25 Yearly vehicle 205 flow (number of loaded vehicles)  Double 0 

SYS25T Yearly vehicle 205 tonne flow Double 0 

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double 0 

SYS30 Yearly vehicle 206 flow (number of loaded vehicles)  Double 0 

SYS30T Yearly vehicle 206 tonne flow Double 0 

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double 0 

SYSXL Yearly vehicle 211 flow (number of loaded vehicles)  Double 0 

SYSXLT Yearly vehicle 211 tonne flow Double 0 

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double 0 

WG550 Yearly vehicle 207 flow (number of loaded vehicles)  Double 33.71220 

WG550T Yearly vehicle 207 tonne flow Double 14486.2989 

WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619 

WG750 Yearly vehicle 208 flow (number of loaded vehicles)  Double 0 

WG750T Yearly vehicle 208 tonne flow Double 0 

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900 

WG950 Yearly vehicle 209 flow (number of loaded vehicles)  Double 0 

WG950T Yearly vehicle 209 tonne flow Double 0 

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745 

WGEXL Yearly vehicle 212 flow (number of loaded vehicles)  Double 0 

WGEXLT Yearly vehicle 212 tonne flow Double 0 

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745 

FEEDW Yearly vehicle 203 flow (number of loaded vehicles)  Double 383.6697 

FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875 

FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791 

FEEDV Yearly vehicle 202 flow (number of loaded vehicles)  Double 0 

FEEDVT Yearly vehicle 202 tonne flow Double 0 

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double 0 

TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391 

TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875 
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Field Description Data Format Example 

TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for the rail mode. 

Created by: “Rail Assignment” subgroup under “Samgods Model > Assignment.” 

Used by: “Results” subgroup under “Samgods Model.” 

Made by user choice: No. 

 

3.4.2.3. Load_net_Sea_0 and Load_net_Sea_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Sea_

0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Sea_

RCM 

The node table, Table 86, and the link table, Table 87, holds information about the transports per sea link A-

B. 

Table 86 - Format of “Load_net_Sea_0_Node” and “Load_net_Sea_RCM_Node” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer 3 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

Table 87 - Format of “Load_net_Sea_0_Link” and “Load_net_Sea_RCM_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (lane) OLE Object Long Binary Data 
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Field Description Data Format Example 

A Start node in VY Numbering Integer 41 

B End node in VY Numbering Integer 2407 

Shape_Length Length based on distance between coordinates in meters Double 231.94827 

SPEED_1 Speed in kms per hour for all modes except vehicle 102-106 in 

Sweden 

Double 9.3 

SPEED_2 Speed in kms per hour for vehicle types vehicle 102-106 in 

Sweden 

Double 0 

CATEGORY Link category Integer 221 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

MODESTR String with all the allowed modes String Xabc 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 3 

CLOSED 0/1 flag to close links based on capacity saved in UL3 (applied to 

Kiel Canal) 

Integer 0 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

CV5 Yearly vehicle flow (number of loaded vehicles) for vehicle 301 Double 1328.875 

CV5T Yearly tonne flows for vehicle 301 Double 1576008.0087 

CV5E Yearly flow (number of empty vehicles) for vehicle 301 Double 494.89151 

CV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 302 Double 0.48649999499322 

CV16T Yearly tonne flows for vehicle 302 Double 1897.0262 

CV16E Yearly flow (number of empty vehicles) for vehicle 302 Double 92.2993011474609 

CV27 Yearly vehicle flow (number of loaded vehicles) for vehicle 303 Double 0.0064 

CV27T Yearly tonne flows for vehicle 303 Double 41.8562 

CV27E Yearly flow (number of empty vehicles) for vehicle 303 Double 59.1561012268066 

CV100 Yearly vehicle flow (number of loaded vehicles) for vehicle 304 Double 0 

CV100T Yearly tonne flows for vehicle 304 Double 0 

CV100E Yearly flow (number of empty vehicles) for vehicle 304 Double 0.04459999874234 

OV1 Yearly vehicle flow (number of loaded vehicles) for vehicle 305 Double 0.522 

OV1T Yearly tonne flows for vehicle 305 Double 104.5458 

OV1E Yearly flow (number of empty vehicles) for vehicle 305 Double 0.07059999555349 

OV2 Yearly vehicle flow (number of loaded vehicles) for vehicle 306 Double 0 

OV2T Yearly tonne flows for vehicle 306 Double 0 
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Field Description Data Format Example 

OV2E Yearly flow (number of empty vehicles) for vehicle 306 Double 0 

OV3 Yearly vehicle flow (number of loaded vehicles) for vehicle 307 Double 53.4078979492188 

OV3T Yearly tonne flows for vehicle 307 Double 46724.79296875 

OV3E Yearly flow (number of empty vehicles) for vehicle 307 Double 849.075988769531 

OV5 Yearly vehicle flow (number of loaded vehicles) for vehicle 308 Double 13.5809001922607 

OV5T Yearly tonne flows for vehicle 308 Double 16943.318359375 

OV5E Yearly flow (number of empty vehicles) for vehicle 308 Double 170.317993164062 

OV10 Yearly vehicle flow (number of loaded vehicles) for vehicle 309 Double 48.0507011413574 

OV10T Yearly tonne flows for vehicle 309 Double 120034.1796875 

OV10E Yearly flow (number of empty vehicles) for vehicle 309 Double 98.8669967651367 

OV20 Yearly vehicle flow (number of loaded vehicles) for vehicle 310 Double 8.51709938049316 

OV20T Yearly tonne flows for vehicle 310 Double 42584.1484375 

OV20E Yearly flow (number of empty vehicles) for vehicle 310 Double 34.8592987060547 

OV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 311 Double 2.90810012817383 

OV40T Yearly tonne flows for vehicle 311 Double 29069.599609375 

OV40E Yearly flow (number of empty vehicles) for vehicle 311 Double 0.25110000371933 

OV80 Yearly vehicle flow (number of loaded vehicles) for vehicle 312 Double  

OV80T Yearly tonne flows for vehicle 312 Double 17966.50390625 

OV80E Yearly flow (number of empty vehicles) for vehicle 312 Double 0.11080000549555 

OV100 Yearly vehicle flow (number of loaded vehicles) for vehicle 313 Double 0 

OV100T Yearly tonne flows for vehicle 313 Double 0 

OV100E Yearly flow (number of empty vehicles) for vehicle 313 Double 0 

OV250 Yearly vehicle flow (number of loaded vehicles) for vehicle 314 Double 0 

OV250T Yearly tonne flows for vehicle 314 Double 0 

OV250E Yearly flow (number of empty vehicles) for vehicle 314 Double 0 

RO3 Yearly vehicle flow (number of loaded vehicles) for vehicle 315 Double 71.7285995483398 

RO3T Yearly tonne flows for vehicle 315 Double 57497.5703125 

RO3E Yearly flow (number of empty vehicles) for vehicle 315 Double 54.013599395752 

RO6 Yearly vehicle flow (number of loaded vehicles) for vehicle 316 Double 0 

RO6T Yearly tonne flows for vehicle 316 Double 0 

RO6E Yearly flow (number of empty vehicles) for vehicle 316 Double 0 

RO10 Yearly vehicle flow (number of loaded vehicles) for vehicle 317 Double 0 

RO10T Yearly tonne flows for vehicle 317 Double 0 
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Field Description Data Format Example 

RO10E Yearly flow (number of empty vehicles) for vehicle 317 Double 0 

ROF2 Yearly vehicle flow (number of loaded vehicles) for vehicle 318 Double 0 

ROF2T Yearly tonne flows for vehicle 318 Double 0 

ROF2E Yearly flow (number of empty vehicles) for vehicle 318 Double 0 

ROF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 319 Double 0 

ROF5T Yearly tonne flows for vehicle 319 Double 0 

ROF5E Yearly flow (number of empty vehicles) for vehicle 319 Double 0 

ROF7 Yearly vehicle flow (number of loaded vehicles) for vehicle 320 Double 0 

ROF7T Yearly tonne flows for vehicle 320 Double 0 

ROF7E Yearly flow (number of empty vehicles) for vehicle 320 Double 0 

RAF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 321 Double 0 

RAF5T Yearly tonne flows for vehicle 321 Double 0 

RAF5E Yearly flow (number of empty vehicles) for vehicle 321 Double 0 

INW Yearly vehicle flow (number of loaded vehicles) for vehicle 322 Double 0 

INWT Yearly tonne flows for vehicle 322 Double 0 

INWE Yearly flow (number of empty vehicles) for vehicle 322 Double 0 

TOT_SEA Yearly vehicle flow (number of loaded vehicles) for mode sea Double 1528.982421875 

TOT_SEA_T Yearly tonne flows for mode sea Double 1908871.55018125 

TOT_SEA_E Yearly flow (number of empty vehicles) for mode sea Double 1853.9580078125 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for the sea mode 

Created by: “Sea Assignment” subgroup under “Samgods Model > Assignment” and “Sea Assignment RCM” 

subgroup under “Samgods Model > RCM Assignment.” 

Used by: “Results” and "Results RCM" subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.2.4. Load_net_Air_0 and Load_net_Air_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Air_

0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Air_

RCM 

The node table, Table 88, and the link table, Table 89, holds information about the transports per air link A-

B. 

Table 88 - Format of “Load_net_Air_0_Node” and “Load_net_Air_RCM_Node” tables. 
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Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x(SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

Table 89 - Format of “Load_net_Air_0_Link” and “Load_net_Air_RCM_Link” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (lane) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 62 

B End node in VY Numbering Integer 2356 

Shape_Length Length based on distance between coordinates in meters Double 476.759897627719 

SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 600 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0 

CATEGORY Link category Integer 241 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

MODESTR String with all the allowed modes String Xabc 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 5 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

FLYG Yearly vehicle flow (number of loaded vehicles) for vehicle 401 Double 0 

FLYGT Yearly tonne flows for vehicle 401 Double 0 
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Field Description Data Format Example 

FLYGE Yearly flow (number of empty vehicles) for vehicle 401 Double 0 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for the air mode. 

Created by: “Sea Assignment” subgroup under “Samgods Model > Assignment” and “Sea Assignment RCM” 

subgroup under “Samgods Model > RCM Assignment”. 

Used by: “Results” and "Results RCM" subgroup under “Samgods Model”. 

Made by user choice: No. 

 

3.4.2.5. Loaded_net_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Loaded_net_0 

The node table, Table 90, and the link table, Table 91, holds information about the transports per link A-B for 

the full network. 

Table 90 - Format of “Loaded_net_0_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

GEOMETRYSOURCE Number representing to which network the node belongs 

(1-Road 2-Rail 3_sea 4-Air) 

Double 4 

Table 91 - Format of “Loaded_net_0_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 40 

SHAPE Feature class type (polyline) OLE Object Long Binary Data 
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Field Description Data Format Example 

A Start node in VY Numbering Integer 36 

B End node in VY Numbering Integer 2791 

Shape_Length Length based on distance between coordinates in meters Double 325.729949474258 

SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 50 

CATEGORY Link category Integer 201 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

UL3 Capacity for vessels on sea (dwell tons) Double 0 

MODESTR String with all the allowed modes String Xabc 

DISTANCE Distance in kms ( not equals to UL2)  Double 1.36 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 1 

CLOSED Flag 0/1 for Sea assignment to close links where Vessel capacity > 

UL3 

Integer 0 

CLOSE_ Flag 0/1 for rail assignment to close links where train type 202 or 

203 is not allowed 

Integer 0 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

ORIGINALCAP Original capacity in bidirectional number of trains per day (from 

3.2.3.8 Rail_Capacity_Base2019) 

Double 0 

LGV3 Yearly vehicle flow (number of loaded vehicles)  for vehicle 101 Double 0 

LGV3T Yearly tonne flows for vehicle 101 Double 0 

LGV3E Yearly flow (number of empty vehicles) for vehicle 101 Double 0 

MGV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 102 Double 0 

MGV16T Yearly tonne flows for vehicle 102 Double 0 

MGV16E Yearly flow (number of empty vehicles) for vehicle 102 Double 0 

MGV24 Yearly vehicle flow (number of loaded vehicles) for vehicle 103 Double 0 

MGV24T Yearly tonne flows for vehicle 103 Double 0 

MGV24E Yearly flow (number of empty vehicles) for vehicle 103 Double 0 

HGV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 104 Double 0 

HGV40T Yearly tonne flows for vehicle 104 Double 0 

HGV40E Yearly flow (number of empty vehicles) for vehicle 104 Double 0 

HGV60 Yearly vehicle flow (number of loaded vehicles) for vehicle 105 Double 0 
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Field Description Data Format Example 

HGV60T Yearly tonne flows for vehicle 105 Double 0 

HGV60E Yearly flow (number of empty vehicles) for vehicle 105 Double 0 

HGV74 Yearly vehicle flow (number of loaded vehicles) for vehicle 106 Double 0 

HGV74E Yearly tonne flows for vehicle 106 Double 0 

HGV74T Yearly flow (number of empty vehicles) for vehicle 106 Double 0 

TOT_ROAD Yearly vehicle flow (number of loaded vehicles) for mode road Double 0 

TOT_ROAD_T Yearly tonne flows for mode road Double 0 

TOT_ROAD_E Yearly flow (number of empty vehicles) for mode road Double 0 

KOMBI Yearly vehicle 201 flow (number of loaded vehicles)  Double 0 

KOMBIT Yearly vehicle 201 tonne flow Double 0 

KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double 0 

KOMXL Yearly vehicle 210 flow (number of loaded vehicles)  Double 0 

KOMXLT Yearly vehicle 210 tonne flow Double 0 

KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double 0 

FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles)  Double 325.2379 

FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875 

FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791 

SYS22 Yearly vehicle 204 flow (number of loaded vehicles)  Double 0 

SYS22T Yearly vehicle 204 tonne flow Double 0 

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double 0 

SYS25 Yearly vehicle 205 flow (number of loaded vehicles)  Double 0 

SYS25T Yearly vehicle 205 tonne flow Double 0 

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double 0 

SYS30 Yearly vehicle 206 flow (number of loaded vehicles)  Double 0 

SYS30T Yearly vehicle 206 tonne flow Double 0 

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double 0 

SYSXL Yearly vehicle 211 flow (number of loaded vehicles)  Double 0 

SYSXLT Yearly vehicle 211 tonne flow Double 0 

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double 0 

WG550 Yearly vehicle 207 flow (number of loaded vehicles)  Double 33.71220 

WG550T Yearly vehicle 207 tonne flow Double 14486.2989 

WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619 

WG750 Yearly vehicle 208 flow (number of loaded vehicles)  Double 0 
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Field Description Data Format Example 

WG750T Yearly vehicle 208 tonne flow Double 0 

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900 

WG950 Yearly vehicle 209 flow (number of loaded vehicles)  Double 0 

WG950T Yearly vehicle 209 tonne flow Double 0 

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745 

WGEXL Yearly vehicle 212 flow (number of loaded vehicles)  Double 0 

WGEXLT Yearly vehicle 212 tonne flow Double 0 

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745 

FEEDW Yearly vehicle 203 flow (number of loaded vehicles)  Double 383.6697 

FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875 

FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791 

FEEDV Yearly vehicle 202 flow (number of loaded vehicles)  Double 0 

FEEDVT Yearly vehicle 202 tonne flow Double 0 

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double 0 

TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391 

TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875 

TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495 

CV5 Yearly vehicle flow (number of loaded vehicles) for vehicle 301 Double 0 

CV5T Yearly tonne flows for vehicle 301 Double 0 

CV5E Yearly flow (number of empty vehicles) for vehicle 301 Double 0 

CV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 302 Double 0 

CV16T Yearly tonne flows for vehicle 302 Double 0 

CV16E Yearly flow (number of empty vehicles) for vehicle 302 Double 0 

CV27 Yearly vehicle flow (number of loaded vehicles) for vehicle 303 Double 0 

CV27T Yearly tonne flows for vehicle 303 Double 0 

CV27E Yearly flow (number of empty vehicles) for vehicle 303 Double 0 

CV100 Yearly vehicle flow (number of loaded vehicles) for vehicle 304 Double 0 

CV100T Yearly tonne flows for vehicle 304 Double 0 

CV100E Yearly flow (number of empty vehicles) for vehicle 304 Double 0 

OV1 Yearly vehicle flow (number of loaded vehicles) for vehicle 305 Double 0 

OV1T Yearly tonne flows for vehicle 305 Double 0 

OV1E Yearly flow (number of empty vehicles) for vehicle 305 Double 0 

OV2 Yearly vehicle flow (number of loaded vehicles) for vehicle 306 Double 0 
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Field Description Data Format Example 

OV2T Yearly tonne flows for vehicle 306 Double 0 

OV2E Yearly flow (number of empty vehicles) for vehicle 306 Double 0 

OV3 Yearly vehicle flow (number of loaded vehicles) for vehicle 307 Double 0 

OV3T Yearly tonne flows for vehicle 307 Double 0 

OV3E Yearly flow (number of empty vehicles) for vehicle 307 Double 0 

OV5 Yearly vehicle flow (number of loaded vehicles) for vehicle 308 Double 0 

OV5T Yearly tonne flows for vehicle 308 Double 0 

OV5E Yearly flow (number of empty vehicles) for vehicle 308 Double 0 

OV10 Yearly vehicle flow (number of loaded vehicles) for vehicle 309 Double 0 

OV10T Yearly tonne flows for vehicle 309 Double 0 

OV10E Yearly flow (number of empty vehicles) for vehicle 309 Double 0 

OV20 Yearly vehicle flow (number of loaded vehicles) for vehicle 310 Double 0 

OV20T Yearly tonne flows for vehicle 310 Double 0 

OV20E Yearly flow (number of empty vehicles) for vehicle 310 Double 0 

OV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 311 Double 0 

OV40T Yearly tonne flows for vehicle 311 Double 0 

OV40E Yearly flow (number of empty vehicles) for vehicle 311 Double 0 

OV80 Yearly vehicle flow (number of loaded vehicles) for vehicle 312 Double 0 

OV80T Yearly tonne flows for vehicle 312 Double 0 

OV80E Yearly flow (number of empty vehicles) for vehicle 312 Double 0 

OV100 Yearly vehicle flow (number of loaded vehicles) for vehicle 313 Double 0 

OV100T Yearly tonne flows for vehicle 313 Double 0 

OV100E Yearly flow (number of empty vehicles) for vehicle 313 Double 0 

OV250 Yearly vehicle flow (number of loaded vehicles) for vehicle 314 Double 0 

OV250T Yearly tonne flows for vehicle 314 Double 0 

OV250E Yearly flow (number of empty vehicles) for vehicle 314 Double 0 

RO3 Yearly vehicle flow (number of loaded vehicles) for vehicle 315 Double 0 

RO3T Yearly tonne flows for vehicle 315 Double 0 

RO3E Yearly flow (number of empty vehicles) for vehicle 315 Double 0 

RO6 Yearly vehicle flow (number of loaded vehicles) for vehicle 316 Double 0 

RO6T Yearly tonne flows for vehicle 316 Double 0 

RO6E Yearly flow (number of empty vehicles) for vehicle 316 Double 0 

RO10 Yearly vehicle flow (number of loaded vehicles) for vehicle 317 Double 0 
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Field Description Data Format Example 

RO10T Yearly tonne flows for vehicle 317 Double 0 

RO10E Yearly flow (number of empty vehicles) for vehicle 317 Double 0 

ROF2 Yearly vehicle flow (number of loaded vehicles) for vehicle 318 Double 0 

ROF2T Yearly tonne flows for vehicle 318 Double 0 

ROF2E Yearly flow (number of empty vehicles) for vehicle 318 Double 0 

ROF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 319 Double 0 

ROF5T Yearly tonne flows for vehicle 319 Double 0 

ROF5E Yearly flow (number of empty vehicles) for vehicle 319 Double 0 

ROF7 Yearly vehicle flow (number of loaded vehicles) for vehicle 320 Double 0 

ROF7T Yearly tonne flows for vehicle 320 Double 0 

ROF7E Yearly flow (number of empty vehicles) for vehicle 320 Double 0 

RAF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 321 Double 0 

RAF5T Yearly tonne flows for vehicle 321 Double 0 

RAF5E Yearly flow (number of empty vehicles) for vehicle 321 Double 0 

INW Yearly vehicle flow (number of loaded vehicles) for vehicle 322 Double 0 

INWT Yearly tonne flows for vehicle 322 Double 0 

INWE Yearly flow (number of empty vehicles) for vehicle 322 Double 0 

TOT_SEA Yearly vehicle flow (number of loaded vehicles) for mode sea Double 0 

TOT_SEA_T Yearly tonne flows for mode sea Double 0 

TOT_SEA_E Yearly flow (number of empty vehicles) for mode sea Double 0 

FKYG Yearly vehicle flow (number of loaded vehicles) for vehicle 401 Double 0 

FKYGT Yearly tonne flows for vehicle 401 Double 0 

FKYGE Yearly flow (number of empty vehicles) for vehicle 401 Double 0 

VOLTO Yearly vehicle flow (number of loaded vehicles) for all modes Double 0 

TONTO Yearly tonne flows for all modes Double 0 

EMPTOE Yearly flow (number of empty vehicles) for all modes Double 0 

GEOMETRYSOUR

CE 

Number representing to which network the link belongs (1-Road 

2-Rail 3_sea 4-Air) 

Double 4 

TRAKBANDEL Trakbandel code for specific link Integer 1110 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Description of Use: Assigned network for all modes. It is the merge of each mode network 

(Loaded_net_road_0, Loaded_net_rail_0, Loaded_net_sea_0, Loaded_net_air)_0. 

Created by: “Results” subgroup under “Samgods Model”. 

Used by: “Data Preparation LP” subgroup under “Samgods Model\Rail Capacity Management”. 
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Made by user choice: No. 

 

3.4.2.6. Loaded_Bid_0 and Loaded_Bid_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Loaded_Bid_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Loaded_Bid_R

CM 

The node table, Table 92, and the link table, Table 93, holds information about the transports per 

(undirected, bidirectional) link A-B. 

Table 92 - Format of “Loaded_Bid_0_Node” and “Loaded_Bid_RCM_Node” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

Table 93 - Format of “Loaded_Bid_0_Link” and “Loaded_Bid_RCM_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (Polyline OLE Object Long Binary Data 

A Start node in VY Numbering Integer 1 

B End node in VY Numbering Integer 2659 

Shape_Length Length based on distance between coordinates in meters Double 230.867927616822 

CATEGORY Link category Integer 110 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 
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ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 1 

CLOSED Flag 0/1 for vehicles 202/203 Integer 0 

TOT_ROAD_TM_

BD 

Bidirectional yearly flow for the mode road (in millions) Double 1.35 

TOT_RAIL_TM_B

D 

Bidirectional yearly flow for the mode rail (in millions) Double 0 

TOT_SEA_TM_BD Bidirectional yearly flow for the mode sea (in millions) Double 0 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network with bidirectional flows for road, rail and sea. 

Created by: “Results 1.0” subgroup under “Samgods Model > Results” and : “Results 1.0” subgroup under 

“Samgods Model > Results RCM”. 

Used by: Not use in the model, final report (see Scenario Outputs > Samgods Reports > Reports > 

Bidirectional tons per mode and Scenario Outputs > RCM Reports > Bidirectional tons per mode). 

Made by user choice: No. 

 

3.4.2.7. Load_net_Rail_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_Rail

_RCM 

The node table, Table 94, and the link table, Table 95, holds information about the transports per rail link A-

B. Fields with * only have values for domestic rail links. 

Table 94 - Format of “Load_net_Rail_RCM_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 
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Field Description Data Format Example 

CENTRALL Node description in terms of location String Upplands-Väsby 

Table 95 - Format of “Load_net_Rail_RCM_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (Polyline) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 21 

B End node in VY Numbering Integer 2127 

Shape_Length Length based on distance between coordinates in meters Double 206.155281301845 

ID_LINK Link identified for rail link. Two links in opposite direction share 

the same ID_LINK.  

Integer 25 

SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0 

CATEGORY Link category Integer 211 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

MODESTR String with all the allowed modes String Xabc 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 2 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

CAP* Original capacity in bidirectional number of trains per day on rail 

links. From Capacity table 

Double 78 

PREVCAP* Capacity in previous Adjust Capacity Loop [bidirectional trains 

per day] - if not used PREVCAP=CAP 

Double 78 

FREMME2* Emme node number for start node on rail Integer 1002 

TOEMME2* Emme node number for end node on rail Integer 1003 

CURRENTCAP* Capacity in current Adjust Capacity Loop [bidirectional trains per 

day] - if not used CURRENTCAP=CAP. 

Double 78 

KOMBI Yearly vehicle 201 flow (number of loaded vehicles)  Double 0 

KOMBIT Yearly vehicle 201 tonne flow Double 0 

KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double 0 

KOMXL Yearly vehicle 210 flow (number of loaded vehicles)  Double 0 

KOMXLT Yearly vehicle 210 tonne flow Double 0 

KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double 0 
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Field Description Data Format Example 

FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles)  Double 325.2379 

FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875 

FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791 

SYS22 Yearly vehicle 204 flow (number of loaded vehicles)  Double 0 

SYS22T Yearly vehicle 204 tonne flow Double 0 

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double 0 

SYS25 Yearly vehicle 205 flow (number of loaded vehicles)  Double 0 

SYS25T Yearly vehicle 205 tonne flow Double 0 

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double 0 

SYS30 Yearly vehicle 206 flow (number of loaded vehicles)  Double 0 

SYS30T Yearly vehicle 206 tonne flow Double 0 

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double 0 

SYSXL Yearly vehicle 211 flow (number of loaded vehicles)  Double 0 

SYSXLT Yearly vehicle 211 tonne flow Double 0 

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double 0 

WG550 Yearly vehicle 207 flow (number of loaded vehicles)  Double 33.71220 

WG550T Yearly vehicle 207 tonne flow Double 14486.2989 

WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619 

WG750 Yearly vehicle 208 flow (number of loaded vehicles)  Double 0 

WG750T Yearly vehicle 208 tonne flow Double 0 

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900 

WG950 Yearly vehicle 209 flow (number of loaded vehicles)  Double 0 

WG950T Yearly vehicle 209 tonne flow Double 0 

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745 

WGEXL Yearly vehicle 212 flow (number of loaded vehicles)  Double 0 

WGEXLT Yearly vehicle 212 tonne flow Double 0 

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745 

FEEDW Yearly vehicle 203 flow (number of loaded vehicles)  Double 383.6697 

FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875 

FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791 

FEEDV Yearly vehicle 202 flow (number of loaded vehicles)  Double 0 

FEEDVT Yearly vehicle 202 tonne flow Double 0 

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double 0 
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Field Description Data Format Example 

TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391 

TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875 

TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495 

TRAKBANDEL Trakbandel code for specific link Integer 1110 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for the rail mode from Rail Capacity Management. 

Created by: “Rail Assignment RCM” subgroup under “Samgods Model > RCM Assignment”. 

Used by: “Results RCM” subgroup under “Samgods Model”. 

Made by user choice: No. 

 

3.4.2.8. Loaded_net_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Load_net_RCM 

The node table, Table 96, and the link table, Table 97, holds information about the transports per link A-B for 

the full network. Fields with * only have values for domestic rail links. 

Table 96 - Format of “Load_net_RCM_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

GEOMETRYSOURCE Number representing to which network the node belongs 

(1-Road 2-Rail 3_sea 4-Air) 

Double 4 

Table 97 - Format of “Load_net_RCM_Link” table. 

Field Description Data Format Example 
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Field Description Data Format Example 

OBJECTID Counter Integer 40 

SHAPE Feature class type (lane) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 36 

B End node in VY Numbering Integer 2791 

Shape_Length Length based on distance between coordinates in meters Double 325.729949474258 

SPEED_1 Speed in kms per hour for all modes except vehicles 102-106 in 

Sweden 

Double 50 

SPEED_2 Speed in kms per hour for vehicle types 102-106 in Sweden Double 50 

CATEGORY Link category Integer 201 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

DISTANCE Distance in kms ( not equals to UL2)  Double 1.36 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 1 

CLOSED Flag 0/1 for Sea assignment to close links where Vessel capacity > 

UL3 

Integer 0 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

LGV3 Yearly vehicle flow (number of loaded vehicles)  for vehicle 101 Double 0 

LGV3T Yearly tonne flows for vehicle 101 Double 0 

LGV3E Yearly flow (number of empty vehicles) for vehicle 101 Double 0 

MGV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 102 Double 0 

MGV16T Yearly tonne flows for vehicle 102 Double 0 

MGV16E Yearly flow (number of empty vehicles) for vehicle 102 Double 0 

MGV24 Yearly vehicle flow (number of loaded vehicles) for vehicle 103 Double 0 

MGV24T Yearly tonne flows for vehicle 103 Double 0 

MGV24E Yearly flow (number of empty vehicles) for vehicle 103 Double 0 

HGV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 104 Double 0 

HGV40T Yearly tonne flows for vehicle 104 Double 0 

HGV40E Yearly flow (number of empty vehicles) for vehicle 104 Double 0 

HGV60 Yearly vehicle flow (number of loaded vehicles) for vehicle 105 Double 0 

HGV60T Yearly tonne flows for vehicle 105 Double 0 

HGV60E Yearly flow (number of empty vehicles) for vehicle 105 Double 0 
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Field Description Data Format Example 

HGV74 Yearly vehicle flow (number of loaded vehicles) for vehicle 106 Double 0 

HGV74E Yearly tonne flows for vehicle 106 Double 0 

HGV74T Yearly flow (number of empty vehicles) for vehicle 106 Double 0 

TOT_ROAD Yearly vehicle flow (number of loaded vehicles) for mode road Double 0 

TOT_ROAD_T Yearly tonne flows for mode road Double 0 

TOT_ROAD_E Yearly flow (number of empty vehicles) for mode road Double 0 

KOMBI Yearly vehicle 201 flow (number of loaded vehicles)  Double 0 

KOMBIT Yearly vehicle 201 tonne flow Double 0 

KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double 0 

KOMXL Yearly vehicle 210 flow (number of loaded vehicles)  Double 0 

KOMXLT Yearly vehicle 210 tonne flow Double 0 

KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double 0 

FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles)  Double 325.2379 

FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875 

FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791 

SYS22 Yearly vehicle 204 flow (number of loaded vehicles)  Double 0 

SYS22T Yearly vehicle 204 tonne flow Double 0 

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double 0 

SYS25 Yearly vehicle 205 flow (number of loaded vehicles)  Double 0 

SYS25T Yearly vehicle 205 tonne flow Double 0 

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double 0 

SYS30 Yearly vehicle 206 flow (number of loaded vehicles)  Double 0 

SYS30T Yearly vehicle 206 tonne flow Double 0 

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double 0 

SYSXL Yearly vehicle 211 flow (number of loaded vehicles)  Double 0 

SYSXLT Yearly vehicle 211 tonne flow Double 0 

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double 0 

WG550 Yearly vehicle 207 flow (number of loaded vehicles)  Double 33.71220 

WG550T Yearly vehicle 207 tonne flow Double 14486.2989 

WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619 

WG750 Yearly vehicle 208 flow (number of loaded vehicles)  Double 0 

WG750T Yearly vehicle 208 tonne flow Double 0 

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900 



Input and output file reference 

105 

Field Description Data Format Example 

WG950 Yearly vehicle 209 flow (number of loaded vehicles)  Double 0 

WG950T Yearly vehicle 209 tonne flow Double 0 

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745 

WGEXL Yearly vehicle 212 flow (number of loaded vehicles)  Double 0 

WGEXLT Yearly vehicle 212 tonne flow Double 0 

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745 

FEEDW Yearly vehicle 203 flow (number of loaded vehicles)  Double 383.6697 

FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875 

FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791 

FEEDV Yearly vehicle 202 flow (number of loaded vehicles)  Double 0 

FEEDVT Yearly vehicle 202 tonne flow Double 0 

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double 0 

TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391 

TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875 

TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495 

CV5 Yearly vehicle flow (number of loaded vehicles) for vehicle 301 Double 0 

CV5T Yearly tonne flows for vehicle 301 Double 0 

CV5E Yearly flow (number of empty vehicles) for vehicle 301 Double 0 

CV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 302 Double 0 

CV16T Yearly tonne flows for vehicle 302 Double 0 

CV16E Yearly flow (number of empty vehicles) for vehicle 302 Double 0 

CV27 Yearly vehicle flow (number of loaded vehicles) for vehicle 303 Double 0 

CV27T Yearly tonne flows for vehicle 303 Double 0 

CV27E Yearly flow (number of empty vehicles) for vehicle 303 Double 0 

CV100 Yearly vehicle flow (number of loaded vehicles) for vehicle 304 Double 0 

CV100T Yearly tonne flows for vehicle 304 Double 0 

CV100E Yearly flow (number of empty vehicles) for vehicle 304 Double 0 

OV1 Yearly vehicle flow (number of loaded vehicles) for vehicle 305 Double 0 

OV1T Yearly tonne flows for vehicle 305 Double 0 

OV1E Yearly flow (number of empty vehicles) for vehicle 305 Double 0 

OV2 Yearly vehicle flow (number of loaded vehicles) for vehicle 306 Double 0 

OV2T Yearly tonne flows for vehicle 306 Double 0 

OV2E Yearly flow (number of empty vehicles) for vehicle 306 Double 0 
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Field Description Data Format Example 

OV3 Yearly vehicle flow (number of loaded vehicles) for vehicle 307 Double 0 

OV3T Yearly tonne flows for vehicle 307 Double 0 

OV3E Yearly flow (number of empty vehicles) for vehicle 307 Double 0 

OV5 Yearly vehicle flow (number of loaded vehicles) for vehicle 308 Double 0 

OV5T Yearly tonne flows for vehicle 308 Double 0 

OV5E Yearly flow (number of empty vehicles) for vehicle 308 Double 0 

OV10 Yearly vehicle flow (number of loaded vehicles) for vehicle 309 Double 0 

OV10T Yearly tonne flows for vehicle 309 Double 0 

OV10E Yearly flow (number of empty vehicles) for vehicle 309 Double 0 

OV20 Yearly vehicle flow (number of loaded vehicles) for vehicle 310 Double 0 

OV20T Yearly tonne flows for vehicle 310 Double 0 

OV20E Yearly flow (number of empty vehicles) for vehicle 310 Double 0 

OV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 311 Double 0 

OV40T Yearly tonne flows for vehicle 311 Double 0 

OV40E Yearly flow (number of empty vehicles) for vehicle 311 Double 0 

OV80 Yearly vehicle flow (number of loaded vehicles) for vehicle 312 Double 0 

OV80T Yearly tonne flows for vehicle 312 Double 0 

OV80E Yearly flow (number of empty vehicles) for vehicle 312 Double 0 

OV100 Yearly vehicle flow (number of loaded vehicles) for vehicle 313 Double 0 

OV100T Yearly tonne flows for vehicle 313 Double 0 

OV100E Yearly flow (number of empty vehicles) for vehicle 313 Double 0 

OV250 Yearly vehicle flow (number of loaded vehicles) for vehicle 314 Double 0 

OV250T Yearly tonne flows for vehicle 314 Double 0 

OV250E Yearly flow (number of empty vehicles) for vehicle 314 Double 0 

RO3 Yearly vehicle flow (number of loaded vehicles) for vehicle 315 Double 0 

RO3T Yearly tonne flows for vehicle 315 Double 0 

RO3E Yearly flow (number of empty vehicles) for vehicle 315 Double 0 

RO6 Yearly vehicle flow (number of loaded vehicles) for vehicle 316 Double 0 

RO6T Yearly tonne flows for vehicle 316 Double 0 

RO6E Yearly flow (number of empty vehicles) for vehicle 316 Double 0 

RO10 Yearly vehicle flow (number of loaded vehicles) for vehicle 317 Double 0 

RO10T Yearly tonne flows for vehicle 317 Double 0 

RO10E Yearly flow (number of empty vehicles) for vehicle 317 Double 0 
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Field Description Data Format Example 

ROF2 Yearly vehicle flow (number of loaded vehicles) for vehicle 318 Double 0 

ROF2T Yearly tonne flows for vehicle 318 Double 0 

ROF2E Yearly flow (number of empty vehicles) for vehicle 318 Double 0 

ROF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 319 Double 0 

ROF5T Yearly tonne flows for vehicle 319 Double 0 

ROF5E Yearly flow (number of empty vehicles) for vehicle 319 Double 0 

ROF7 Yearly vehicle flow (number of loaded vehicles) for vehicle 320 Double 0 

ROF7T Yearly tonne flows for vehicle 320 Double 0 

ROF7E Yearly flow (number of empty vehicles) for vehicle 320 Double 0 

RAF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 321 Double 0 

RAF5T Yearly tonne flows for vehicle 321 Double 0 

RAF5E Yearly flow (number of empty vehicles) for vehicle 321 Double 0 

INW Yearly vehicle flow (number of loaded vehicles) for vehicle 322 Double 0 

INWT Yearly tonne flows for vehicle 322 Double 0 

INWE Yearly flow (number of empty vehicles) for vehicle 322 Double 0 

TOT_SEA Yearly vehicle flow (number of loaded vehicles) for mode sea Double 0 

TOT_SEA_T Yearly tonne flows for mode sea Double 0 

TOT_SEA_E Yearly flow (number of empty vehicles) for mode sea Double 0 

FLYG Yearly vehicle flow (number of loaded vehicles) for vehicle 401 Double 0 

FLYGT Yearly tonne flows for vehicle 401 Double 0 

FLYGE Yearly flow (number of empty vehicles) for vehicle 401 Double 0 

VOLTO Yearly vehicle flow (number of loaded vehicles) for all modes Double 0 

TONTO Yearly tonne flows for all modes Double 0 

EMPTOE Yearly flow (number of empty vehicles) for all modes Double 0 

ID_LINK Link identified for rail link. Two links in opposite direction share 

the same ID_LINK.  

Integer 25 

CAP* Original capacity in bidirectional trains per day on rail links. 

From Capacity table 

Double 78 

PREVCAP* Capacity in previous Adjust Capacity Loop [bidirectional trains 

per day] - if not used PREVCAP=CAP 

Double 78 

FREMME2* Emme node number for start node  Integer 1002 

TOEMME2* Emme node number for end node Integer 1003 

CURRENTCAP Capacity in current Adjust Capacity Loop [bidirectional trains per 

day] - if not used CURRENTCAP=CAP. 

Double 78 

TRAKBANDEL Trakbandel code for specific link Integer 1110 
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Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for all modes from Rail Capacity Management. It is the merge of all 

mode networks (Load_net_road_RCM, Load_net_rail_RCM, Load_net_sea_RCM, Load_net_air_RCM). 

Created by: “Results RCM” subgroup under “Samgods Model”. 

Used by: “Results RCM” subgroup under “Samgods Model” to produce related reports (Report_1, Report_4, 

etc). 

Made by user choice: No. 

 

3.4.2.9. Rail_BiDir 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Rail_BiDir 

The node table, Table 98, and the link table, Table 99, holds information about the transports per rail 

(undirected, bidirectional) link A-B. Fields with * only have values for domestic rail links. 

Table 98 - Format of “Rail_BiDir_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) 

 

Double 1620000 

Y Coordinate y (SWEREF99_TM) 

 

Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

GEOMETRYSOURCE Number representing to which network the node belongs 

(1-Road 2-Rail 3_sea 4-Air) 

Double 4 

Table 99 - Format of “Rail_BiDir_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (Polyline) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 21 
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Field Description Data Format Example 

B End node in VY Numbering Integer 2127 

Shape_Length Length based on distance between coordinates in meters Double 206.155281301845 

ID_LINK Link identified for rail link. Two links in opposite direction share 

the same ID_LINK.  

Integer 25 

TRAKBANDEL 

Trakbandel number for specific link Integer 

1011 

CAP* 

Maximum number of bidirectional trains per day  (from 3.2.3.8 

Rail_Capacity_Base2019) 

String 

418 

TOT_LOAD Number of loaded bidirectional trains per day Double 71.24434 

TOT_EMPT Number of unloaded bidirectional trains per day Double 31.21692 

TOT_ASS Number of total bidirectional trains per day (loaded unloaded) Double 102.4613 

DIFF_VC Difference between TOT_ASS and CAP Double -315.539 

FLAG_OVCAP Flag 0/1. 1 means the link is overcapacity by at least 1 train Integer 1 

FLAG_PER Flag 0/1. 1 means the link is overcapacity by at least 10% Double 0 

FLAG_TOT Flag 0/1 if FLAG_OVCAP=1 or FLAG_PER=1 Double 1 

SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0 

CATEGORY Link category Integer 211 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

UL3 Capacity for vessels on sea (dwell tons) Double 0 

MODESTR String with all the allowed modes String Xabc 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 2 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

PREVCAP* Capacity in previous Adjust Capacity Loop [bidirectional trains 

per day] - if not used PREVCAP=CAP 

Double 78 

FREMME2 Start Emme node Integer 1002 

TOEMME2 End Emme node Integer 1003 

CURRENTCAP* Capacity in current Adjust Capacity Loop [bidirectional trains per 

day] - if not used CURRENTCAP=CAP. 

* values are present only for domestic rail links. 

Double 78 

KOMBI Yearly vehicle 201 flow (number of loaded vehicles)  Double 0 
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Field Description Data Format Example 

KOMBIT Yearly vehicle 201 tonne flow Double 0 

KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double 0 

KOMXL Yearly vehicle 210 flow (number of loaded vehicles)  Double 0 

KOMXLT Yearly vehicle 210 tonne flow Double 0 

KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double 0 

FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles)  Double 325.2379 

FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875 

FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791 

SYS22 Yearly vehicle 204 flow (number of loaded vehicles)  Double 0 

SYS22T Yearly vehicle 204 tonne flow Double 0 

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double 0 

SYS25 Yearly vehicle 205 flow (number of loaded vehicles)  Double 0 

SYS25T Yearly vehicle 205 tonne flow Double 0 

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double 0 

SYS30 Yearly vehicle 206 flow (number of loaded vehicles)  Double 0 

SYS30T Yearly vehicle 206 tonne flow Double 0 

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double 0 

SYSXL Yearly vehicle 211 flow (number of loaded vehicles)  Double 0 

SYSXLT Yearly vehicle 211 tonne flow Double 0 

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double 0 

WG550 Yearly vehicle 207 flow (number of loaded vehicles)  Double 33.71220 

WG550T Yearly vehicle 207 tonne flow Double 14486.2989 

WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619 

WG750 Yearly vehicle 208 flow (number of loaded vehicles)  Double 0 

WG750T Yearly vehicle 208 tonne flow Double 0 

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900 

WG950 Yearly vehicle 209 flow (number of loaded vehicles)  Double 0 

WG950T Yearly vehicle 209 tonne flow Double 0 

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745 

WGEXL Yearly vehicle 212 flow (number of loaded vehicles)  Double 0 

WGEXLT Yearly vehicle 212 tonne flow Double 0 

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745 

FEEDW Yearly vehicle 203 flow (number of loaded vehicles)  Double 383.6697 
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Field Description Data Format Example 

FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875 

FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791 

FEEDV Yearly vehicle 202 flow (number of loaded vehicles)  Double 0 

FEEDVT Yearly vehicle 202 tonne flow Double 0 

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double 0 

TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391 

TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875 

TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495 

GEOMETRYSOUR

CE 

Number representing to which network the link belongs (1-Road 

2-Rail 3_sea 4-Air) 

Double 4 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Assigned network for the rail mode from Rail Capacity Management with daily and yearly 

flows. 

Created by: “Reports 1.0” subgroup under “Samgods Model > Results RCM”. 

Made by user choice: No. 

 

3.4.2.10. Compare_Bid 

Scenario_Tree\Base2019\Output0_Base2019.mdb\Compare_Bid 

The node table, Table 100, and the link table, Table 101, holds information about the differences in 

transports per (undirected, bidirectional) link A-B. 

Table 100 - Format of “Compare_Bid_Node” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (point) OLE Object Long Binary Data 

N Node number in VY Numbering Integer 1 

X Coordinate x (SWEREF99_TM) Double 1620000 

Y Coordinate y (SWEREF99_TM) Double 6601000 

NORIG Original node number based on the combination of 

ID_Country, ID_region and MODE_N values 

Integer 711400 

SCBSTANN Scbstann code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Code for allowed vehicles accessing the node Integer MODE_N 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in term of location String Upplands-Väsby 
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Field Description Data Format Example 

GEOMETRYSOURCE Number representing to which network the node belongs 

(1-Road 2-Rail 3_sea 4-Air) 

Double 4 

Table 101 - Format of “Compare_Bid_Link” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

SHAPE Feature class type (Polyline) OLE Object Long Binary Data 

A Start node in VY Numbering Integer 1 

B End node in VY Numbering Integer 2659 

Shape_Length Length based on distance between coordinates in meters Double 230.867927616822 

CATEGORY Link category Integer 110 

FUNCTION Index for vdf function Double 61 

NLANES Number of lanes (could be with -decimals Double 1 

UL2 Distance in kms. User link data in emme used to enable holding 

link lengths longer than 999 kms. 

Double 1.36 

ID_COUNTRY Country code Integer 1 

MODE_L Code for allowed vehicles on the link Integer 1 

CLOSED Flag 0/1 for vehicles 202/203 Integer 0 

RAIL_STD 
Bidirectional yearly tonnes for mode Rail (in millions) from 

Standard Logistics Module 
Double 0 

SEA_STD 
Bidirectional yearly tonnes for mode Sea (in millions) from 

Standard Logistics Module 
Double 0 

ROAD_STD 
Bidirectional yearly tonnes for mode road (in millions) from 

Standard Logistics Module 
Double 1.35 

GEOMETRYSOUR

CE 
Flag 1/2: 1 from RCM network, 2 from Standard Logistics Module Double 1 

RAIL_RCM 
Bidirectional yearly tonnes for mode Rail (in millions) from Rail 

Capacity Management Procedure 
Double 0 

SEA_RCM 
Bidirectional yearly tonnes for mode Sea (in millions) from Rail 

Capacity Management Procedure 
Double 0 

ROAD_RCM 
Bidirectional yearly tonnes for mode road (in millions) from Rail 

Capacity Management Procedure 
Double 1.35 

DIF_A_ROAD 
Difference between ROAD_RCM and ROAD_STD (in millions of 

tonnes) 
Double 0 

DIF_A_RAIL 
Difference between RAIL_RCM and RAIL_STD (in millions of 

tonnes) 
Double 0 

DIF_A_SEA 
Difference between SEA_RCM and SEA_STD (in millions of 

tonnes) 
Double 0 
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Field Description Data Format Example 

DIF_P_ROAD Difference percentage between ROAD_RCM and ROAD_STD (%) Double 0 

DIF_P_RAIL Difference percentage between RAIL_RCM and RAIL_STD (%) Double 0 

DIF_P_SEA Difference percentage between SEA_RCM and SEA_STD (%) Double 0 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcMap. 

Description of Use: Differences of bidirectional flows (in millions of tons) for Road, Sea and Rail mode on 

two results, one from standard logistics module and the other from rail capacity management procedure.  

Created by: “Results 1.0” subgroup under “Samgods Model > Results” and : “Results 1.0” subgroup under 

“Samgods Model > Results RCM”. 

Used by: Not use in the model, final report (see Scenario Outputs\RCM Reports\ Comparison Ml Tons RCM 

vs. Standard per mode). 

Made by user choice: No. 
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3.4.3. Table format in geodatabase 

Here, tables in the geodatabase are presented. 

3.4.3.1. CHAIN_OD_COV_{SCENARIO_SHORTNAME}_0_1, 

CHAIN_OD_COV_{SCENARIO_SHORTNAME}_RCM_1 and 

CHAIN_OD_COV_{SCENARIO_SHORTNAME}_CBA_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\CHAIN_OD_C

OV_{SCENARIO_SHORTNAME}_0_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\CHAIN_OD_C

OV_{SCENARIO_SHORTNAME}_RCM_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\CHAIN_OD_C

OV_{SCENARIO_SHORTNAME}_CBA_1 

This table, Table 102, holds information of coverage of vehicles, created by the LogMod module. 

Table 102 - Format of “CHAIN_OD_COV_{SCENARIO_SHORTNAME}_0_1”, 

“CHAIN_OD_COV_{SCENARIO_SHORTNAME}_RCM_1” and 

“CHAIN_OD_COV_{SCENARIO_SHORTNAME}_CBA_1” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

CHAIN_TY Chain Type String A 

NSHIP_D Number of Shipments Domestic Double 9187.49 

NSHIP_I Number of Shipments International Double 239.81 

NSHIP_T Number of Shipments Total Domestic Double 9187.49 

KM_DOM Km Domestic Double 48992.5 

KM_INT Km International Double 2498.34 

KM_TOT Km Total Domestic Double 52656.48 

TON_DOM Tonnes Domestic Double 2492.91 

TON_INT Tonnes International Double 184.62 

TON_TOT Tonnes Total Domestic Double 2492.91 

TKM_DOM TonneKm Domestic Double 429749.55 

TKM_INT TonneKm International Double 37927.9 

TKM_TOT TonneKm Total Domestic Double 483111.92 

COST_DOM Costs (SEK) Domestic Double 8039900.44 

COST_INT Costs (SEK) International Double 383296.88 

COST_TOT Costs (SEK) Total Domestic Double 8039900.44 

AC_TKM_DOM Average Logistic Cost Domestic Double 18.71 

AC_TKM_INT Average Logistic Cost International Double 10.11 
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Field Description Data Format Example 

AC_TKM_TOT Average Logistic Cost Total Domestic Double 16.64 

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window). 

Description of Use: Translation of ChainChoi0_{SCENARIO_SHORTNAME}.rep, 

ChainChoi0FIN_{SCENARIO_SHORTNAME}.rep and ChainChoiCBA0_{SCENARIO_SHORTNAME}.rep 

in geodatabase tables for the part related to chain types. The first is the merge of all the reports 

ChainChoiXX.rep from Standard Logistics Module and the second is the merge of all the reports 

ChainChoiXXFIN.rep from Rail Capacity Management Module. The third one is from CBA. These files reside 

under LogMod_Y\ChainChoi\Output folder and OutputCBA folder and are merged via MERGE.exe 

program. 

The three geodatabase tables are the source for "Report_2_LM_CHAINS" under data panel Samgods Report 

> Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD.  

Created by: “Save Reports” subgroup under “Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.2. COM_L_D_{SCENARIO_SHORTNAME}_0_1, 

COM_L_D_{SCENARIO_SHORTNAME}_RCM_1 and COM_L_D_{SCENARIO_SHORTNAME}_CBA_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\COM_L_D_{SC

ENARIO_SHORTNAME}_0_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\COM_L_D_{SC

ENARIO_SHORTNAME}_RCM_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\COM_L_D_{SC

ENARIO_SHORTNAME}_CBA_1 

Table 103 - Format of “COM_L_D_{SCENARIO_SHORTNAME}_0_1”, 

“COM_L_D_{SCENARIO_SHORTNAME}_RCM_1” and 

“COM_L_D_{SCENARIO_SHORTNAME}_CBA_1” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

COMM Commodity group  Integer 1 

TRANVOL Actual transported tons (tonnes) Double 5212689 

DEMANDVOL PWC values (tonnes) Double 5212689 

SUCCESRATE Success Rate (100% means all the transport chains got a solution) Double 100 

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window). 

Description of Use: Translation of ChainChoi0_{SCENARIO_SHORTNAME}.rep, 

ChainChoi0FIN_{SCENARIO_SHORTNAME}.rep and ChainChoiCBA0_{SCENARIO_SHORTNAME}.rep 

in geodatabase tables for the part related to chain types. The first is the merge of all the reports 

ChainChoiXX.rep from Standard Logistics Module and the second is the merge of all the reports 

ChainChoiXXFIN.rep from Rail Capacity Management Module. The third one is from CBA. These files reside 
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under LogMod_Y\ChainChoi\Output folder and OutputCBA folder (for the normal user Y=1) and are merged 

via MERGE.exe program. 

The three geodatabase tables are the source for “Report_2_LM_DEMAND" under data panel Samgods 

Report > Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report 

> OD.  

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.3. VHCL_OD_COV_{SCENARIO_SHORTNAME}_0_1, 

VHCL_OD_COV_{SCENARIO_SHORTNAME}_RCM_1 and 

VHCL_OD_COV_{SCENARIO_SHORTNAME}_CBA_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\VHCL_OD_CO

V_{SCENARIO_SHORTNAME}_0_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\VHCL_OD_CO

V_{SCENARIO_SHORTNAME}_RCM_1 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\VHCL_OD_CO

V_{SCENARIO_SHORTNAME}_CBA_1 

Table 104 - Format of “VHCL_OD_COV_{SCENARIO_SHORTNAME}_0”, 

“VHCL_OD_COV_{SCENARIO_SHORTNAME}_RCM” and 

“VHCL_OD_COV_{SCENARIO_SHORTNAME}_CBA” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

VEH_TY Vehicle Type Integer 101 

DESCR Description of vehicle type 

String Lorry light LGV.< 

3.5 ton 

NSHIP_D Number of Shipments Domestic Double 59.56 

NSHIP_I Number of Shipments International Double 59.65 

NSHIP_T Number of Shipments Total Domestic Double 0.75 

NV_DOM Number of Vehicles Domestic Double 58.91 

NV_INT Number of Vehicles International Double 58.99 

NV_TOT Number of Vehicles Total Domestic Double 0.09 

KM_DOM Km Domestic Double 4608.5 

KM_INT Km International Double 4612.13 

KM_TOT Km Total Domestic Double 6.72 

TON_DOM Tonnes Domestic Double 92.61 

TON_INT Tonnes International Double 92.73 

TON_TOT Tonnes Total Domestic Double 0.12 
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Field Description Data Format Example 

TKM_DOM TonneKm Domestic Double 7529.42 

TKM_INT TonneKm International Double 7535.17 

TKM_TOT TonneKm Total Domestic Double 10.27 

ALF_DOM Average Load Factor Domestic Double 0.79 

ALF_INT Average Load Factor International  Double 0.79 

ALF_TOT Average Load Factor Total Domestic Double 0.68 

AVDIST_DOM Average Distance Domestic  Double 78.2 

AVDIST_INT Average Distance International Double 78.2 

AVDIST_TOT Average Distance Total Domestic Double 73.9 

Table 105 - Specific attributes for “VHCL_OD_COV_{SCENARIO_SHORTNAME}_CBA” table 

Field Description Data Format Example 

Fekm_DOM Ferry Km Domestic Double 0.5 

Fekm_INT Ferry Km International Double 2.6 

Fekm_TOT Ferry Km Total Domestic Double 7 

Description of Use: Translation of ChainChoi0_{SCENARIO_SHORTNAME}.rep, 

ChainChoi0FIN_{SCENARIO_SHORTNAME}.rep and ChainChoiCBA0_{SCENARIO_SHORTNAME}.rep 

in geodatabase tables for the part related to chain types. The first is the merge of all the reports 

ChainChoiXX.rep from Standard Logistics Module and the second is the merge of all the reports 

ChainChoiXXFIN.rep from Rail Capacity Management Module. The third one is from CBA. These files reside 

under LogMod_Y\ChainChoi\Output folder and OutputCBA folder and are merged via MERGE.exe 

program. 

The three geodatabase tables are the source for “Report_2_Logistics Module" under data panel Samgods 

Report\Logistics Module\OD Covered , RCM Reports\ Logistics Module\OD Covered, CBA Report\OD . 

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window). 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.4. Report_1_{SCENARIO_SHORTNAME}_0 and Report_1_{SCENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_1_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_1_{SCE

NARIO_SHORTNAME}_RCM 

Table 106 - Format of “Report_1_{SCENARIO_SHORTNAME}_0” and 

“Report_1_{SCENARIO_SHORTNAME}_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 
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Field Description Data Format Example 

VEH_NR Vehicle type Integer 101 

VEH_CLASS Description of vehicle String LGV3 

VKM_A_TOT Total vehicle kilometres Double 9277.03 

VKM_A_DTOT Total vehicle kilometres (Dtotal) Double 9258.29 

VKM_L_TOT Loaded vehicle kilometres Double 4600.46 

VKM_L_DTOT Loaded vehicle kilometres (Dtotal) Double 4591.29 

VKM_E_TOT Unloaded vehicle kilometres Double 4676.57 

VKM_E_DTOT Unloaded vehicles (Dtotal) Double 4666.99 

Description of Use: The two geodatabase tables are the source for "Report_1 Tot VHC and VHCKM by VHC 

Type" under data panel Reports > Logistics Module and Reports > Rail Capacity Management. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.5. COMMODITYFlows 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\COMMODITYFl

ows 

Table 107 - Format of “COMMODITYFlows” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

KEYLINK Primary key obtained as combination of A*100000+B. To let join further 

information in GIS or Access 

Integer 102659 

TRAKBANDE

L 

Trakbandel on rail links Integer 0 

EMMEFR  Emme start node Integer 711400 

EMMETO Emme end node Integer 300025 

A Start node in VY Numbering Integer 1 

B End node in VY Numbering Integer 2659 

KTONTO Total bidirectional ktons (all modes) in a year Double 2862 

VOLTO Daily total bidirectional loaded vehicles (all modes) Double 183.69 

EMPTOE Daily total bidirectional unloaded vehicles (all modes) Double 95.35 

P01_KTON Ktons bidirectional Commodity group 1 in a year Double 6 

P02_KTON Ktons bidirectional Commodity group 2 in a year Double 33 

P03_KTON Ktons bidirectional Commodity group 3 in a year Double 167 

P04_KTON Ktons bidirectional Commodity group 4 in a year Double 277 

P05_KTON Ktons bidirectional Commodity group 5 in a year Double 7 

P06_KTON Ktons bidirectional Commodity group 6 in a year Double 308 

P07_KTON Ktons bidirectional Commodity group 7 in a year Double 254 

P08_KTON Ktons bidirectional Commodity group 8 in a year Double 192 

P09_KTON Ktons bidirectional Commodity group 9 in a year Double 59 

P10_KTON Ktons bidirectional Commodity group 10 in a year Double 63 

P11_KTON Ktons bidirectional Commodity group 11 in a year Double 61 
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Field Description Data Format Example 

P12_KTON Ktons bidirectional Commodity group 12 in a year Double 125 

P13_KTON Ktons bidirectional Commodity group 13 in a year Double 44 

P14_KTON Ktons bidirectional Commodity group 14 in a year Double 37 

P15_KTON Ktons bidirectional Commodity group 15 in a year Double 8 

P16_KTON Ktons bidirectional Commodity group 16 in a year Double 0 

P01_VDAY Daily loaded vehicles bidirectional Commodity group 1 Double 1.017 

P02_VDAY Daily loaded vehicles bidirectional Commodity group 2 Double 4.375 

P03_VDAY Daily loaded vehicles bidirectional Commodity group 3 Double 14.957 

P04_VDAY Daily loaded vehicles bidirectional Commodity group 4 Double 40.773 

P05_VDAY Daily loaded vehicles bidirectional Commodity group 5 Double 1.629 

P06_VDAY Daily loaded vehicles bidirectional Commodity group 6 Double 37.202 

P07_VDAY Daily loaded vehicles bidirectional Commodity group 7 Double 25.631 

P08_VDAY Daily loaded vehicles bidirectional Commodity group 8 Double 30.838 

P09_VDAY Daily loaded vehicles bidirectional Commodity group 9 Double 10.801 

P10_VDAY Daily loaded vehicles bidirectional Commodity group 10 Double 13.365 

P11_VDAY Daily loaded vehicles bidirectional Commodity group 11 Double 18.668 

P12_VDAY Daily loaded vehicles bidirectional Commodity group 12 Double 20.557 

P13_VDAY Daily loaded vehicles bidirectional Commodity group 13 Double 12.467 

P14_VDAY Daily loaded vehicles bidirectional Commodity group 14 Double 5.511 

P15_VDAY Daily loaded vehicles bidirectional Commodity group 15 Double 0.904 

P16_VDAY Daily loaded vehicles bidirectional Commodity group 16 Double 0.275 

CAPUTIL Utilization rate ([number of trains per day / Capacity]*100) Double 0 

CAPTRAINS Daily capacity on rail links Double 0 

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1 

UL2 Distance in kms. User link data in emme used to enable holding link lengths longer 

than 999 kms. 

Double 1.36 

DISTANCE Distance in kms ( not equals to UL2)  Double 1.36 

MODE_L ID mode (1 road. 2 rail etc.) Integer 2 

Description of Use: The geodatabase table is the source for "layer in GIS map" under data panel Scenario 

output > RCM Report > GIS maps > GIS map with Ktons per commodity group. Annual vehicles can be 

calculated from daily vehicles multiplying by DF or DFR. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Results RCM” subgroup under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.6. Report_3_TonKM_perMode_0 and Report_3_TonKM_perMode_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_3_Ton

KM_perMode_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_3_Ton

KM_perMode_RCM 

Table 108 - Format of “Report_3_TonKM_perMode_0” and “Report_3_TonKM_perMode_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 
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Field Description Data Format Example 

SCENARIO STANDARD/RCM (method that produces the results) String STANDARD 

ROAD Total domestic tonnekm from model (in million) for road mode Double 42.04 

RAIL Total domestic tonnekm from model (in million) for rail mode Double 33.62 

SEA Total domestic tonnekm from model (in million) for sea mode Double 38.79 

AIR Total international tonnekm from model (in million) for air mode Double 2.34 

ROADS 

Total domestic tonnekm from statistics (in million) for road mode - 

value hardcoded in script 

02_APPLICATIONS\2_RUN\RESULTS\NEMAT01A.S 

Double 39.9 

RAILS 

Total domestic tonnekm from model (in million) for rail mode - 

value hardcoded in script 

02_APPLICATIONS\2_RUN\RESULTS\NEMAT01A.S 

Double 22.3 

SEAS 

Total domestic tonnekm from model (in million) for sea mode- 

value hardcoded in script 

02_APPLICATIONS\2_RUN\RESULTS\NEMAT01A.S 

Double 36.9 

ROADD Absolute Differences between modelled and statistics for road mode Double 2.14 

RAILD Absolute Differences between modelled and statistics for rail mode Double 11.32 

SEAD Absolute Differences between modelled and statistics for sea mode Double 1.89 

RMSE Root-mean-square error  Double 8.26 

Description of Use: The two geodatabase tables are the source for 

"Report_3_TonKm_per_Mode_with_2019Statistics" under data panel Reports > Logistics Module and 

Reports > Rail Capacity Management. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.7. Report_4_{SCENARIO_SHORTNAME}_0 and Report_4_{SCENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_4_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_4_{SCE

NARIO_SHORTNAME}_RCM 

Table 109 - Format of “Report_4_{SCENARIO_SHORTNAME}_0” and 

“Report_4_{SCENARIO_SHORTNAME}_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

VEH_NR Vehicle type Integer 101 

VEH_CLASS Description of vehicle type String LGV3 

TKM_TOT Total tonnekm Double 7520.17 
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TKM_DTOT Total domestic tonnekm Double 7505.61 

TKM_INT International tonnekm Double 14.56 

Description of Use: The two geodatabase tables are the source for " Report_4_Total tonkm by VHC Type" 

under data panel Reports > Logistics Module and Reports > Rail Capacity Management. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.8. Report_5_{SCENARIO_SHORTNAME}_0, Report_5_{SCENARIO_SHORTNAME}_RCM and 

Report_5_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_5_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_5_{SCE

NARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_5_{SCE

NARIO_SHORTNAME}_CBA 

Table 110 - Format of “Report_5_{SCENARIO_SHORTNAME}_0”, 

“Report_5_{SCENARIO_SHORTNAME}_RCM” and “Report_5_{SCENARIO_SHORTNAME}_CBA”  

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ZONE_N Zone number Integer 1 

ZONE_ORIG 

Original zone number based on the combination of ID_Country, 

ID_region and MODE_N values 

Integer 711400 

CENTRALL Node description in terms of location String Upplands-Väsby 

P01_IMPORT Total logistic cost in import for Commodity 1 Double 832.67 

P01_EXPORT Total logistic cost in export for Commodity 1 Double 859.21 

… … … … 

P16_IMPORT Total logistic cost in import for Commodity 16 Double 161690.81 

P16_EXPORT Total logistic cost in export for Commodity 16 Double 67590.22 

Description of Use: The three geodatabase tables are the source for “Report_5_Total logistic cost at zone-

level " under data panel Samgods Report\Logistics Module\OD Covered , RCM Reports\ Logistics 

Module\OD Covered, CBA Report\OD. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  
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3.4.3.9. Report_6_{SCENARIO_SHORTNAME}_0, Report_6_{SCENARIO_SHORTNAME}_RCM and 

Report_6_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_6_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_6_{SCE

NARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_6_{SCE

NARIO_SHORTNAME}_CBA 

Table 111 - Format of “Report_6_{SCENARIO_SHORTNAME}_0”, 

“Report_6_{SCENARIO_SHORTNAME}_RCM” and “Report_6_{SCENARIO_SHORTNAME}_CBA” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 93 

ZONE_N Zone number Integer 173 

ZONE_ORIG 

Original zone number based on the combination of ID_Country, 

ID_region and MODE_N values 

Integer 786011 

PORTAREANR Port area number Integer 2 

CENTRALL Node description in terms of location String Hultsfred 

P01_DAIMPORN Imported tons for commodity 1 Double 0.06 

P01_DAEXPORN Exported tons for commodity 1 Double 0.07 

P01_REGULARN Regular tons for commodity 1 Double 0.54 

… … … … 

P16_DAIMPORN Imported tons for commodity 35 Double 0 

P16_DAEXPORN Exported tons for commodity 35 Double 0 

P16_REGULARN Regular tons for commodity 35 Double 0 

Description of Use: The three geodatabase tables are the source for “Report_6_Goods flow through terminals 

(number of tonnes in and out per year)" under data panel Samgods Report > Logistics Module > OD Covered 

or RCM Reports > Logistics Module > OD Covered or CBA Report > OD.  

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.10. Report_6b_{SCENARIO_SHORTNAME}_0, Report_6b_{SCENARIO_SHORTNAME}_RCM 

and Report_6b_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_6b_{SC

ENARIO_SHORTNAME}_0 
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Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_6b_{SC

ENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_6b_{SC

ENARIO_SHORTNAME}_CBA 

Table 112 - Format of “Report_6_{SCENARIO_SHORTNAME}_0”, 

Report_6_{SCENARIO_SHORTNAME}_RCM” and “Report_6_{SCENARIO_SHORTNAME}_CBA” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 93 

ZONE_N Zone number Integer 173 

ZONE_ORIG 

Original zone number based on the combination of ID_Country, 

ID_region and MODE_N values 

Integer 786011 

PORTAREANR Port area number Integer 2 

CENTRALL Node description in terms of location String Hultsfred 

P01PORT 

Sum of all in and out flows from sea (exclusion of land based 

transfers) for Commodity 1 

Double 0.06 

P02PORT ……. Double 0.07 

…  … … 

P16PORT 

Sum of all in and out flows from sea (exclusion of land based 

transfers) for Commodity 35 

Double 0 

Description of Use: The three geodatabase tables are the source for “Report_6b_Goods flow through 

terminals (number of tonnes in and out per year)" under data panel Samgods Report > Logistics Module > 

OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD. They are also input for 

calculation of " Report_13_Tons_per_PortArea_and_Commodity_Group". 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No. 

 

3.4.3.11. Report_7_{SCENARIO_SHORTNAME}_0, Report_7_{SCENARIO_SHORTNAME}_RCM and 

Report_7_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_7_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_7_{SCE

NARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_7_{SCE

NARIO_SHORTNAME}_CBA 

Table 113 - Format of “Report_7_{SCENARIO_SHORTNAME}_0”, 

“Report_7_{SCENARIO_SHORTNAME}_RCM” and “Report_7_{SCENARIO_SHORTNAME}_CBA” 

tables. 
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Field Description Data Format Example 

OBJECTID Counter Integer 1 

COMMODITY Commodity type Integer 1 

ROAD Domestic tonnekm container on road Double 1003.78 

RAIL Domestic tonnekm container on rail Double 2440.79 

SEA Domestic tonnekm container on sea Double 0.84 

AIR Domestic tonnekm container on air Double 0 

V101 Domestic tonnekm container Vehicle type 101 Double 1.2 

.... Domestic tonnekm container .... Double ... 

V401 Domestic tonnekm container Vehicle type 401 Double 0 

Description of Use: The three geodatabase tables are the source for “Report_7_Domestic tonnekm with 

container per mode (road, rail, sea, air) and vehicle cl" under data panel Samgods Report > Logistics Module 

> OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.12. Report_8_{SCENARIO_SHORTNAME}_0, Report_8_{SCENARIO_SHORTNAME}_RCM and 

Report_8_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_8_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_8_{SCE

NARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_8_{SCE

NARIO_SHORTNAME}_CBA 

Table 114 - Format of “Report_8_{SCENARIO_SHORTNAME}_0”, 

“Report_8_{SCENARIO_SHORTNAME}_RCM” and “Report_8_{SCENARIO_SHORTNAME}_CBA” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

COMMODITY Commodity type String 1 

ROAD Domestic vehiclekm container on road Double 98.28 

RAIL Domestic vehiclekm container on rail Double 4.82 

SEA Domestic vehiclekm container on sea Double 0.09 

AIR Domestic vehiclekm container on air Double 0 
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Field Description Data Format Example 

V101 Domestic vehiclekm container Vehicle type 101 Double 1.2 

.... Domestic vehiclekm container .... Double ... 

V401 Domestic vehiclekm container Vehicle type 401 Double 0 

Description of Use: The three geodatabase tables are the source for “Report_8_Domestic vehicle kms with 

container per mode (road, rail, sea, air) and vehicle cl" under data panel Samgods Report > Logistics Module 

> OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.13. Report_9_{SCENARIO_SHORTNAME}_0 and Report_9_{SCENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_9_{SCE

NARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_9_{SCE

NARIO_SHORTNAME}_RCM 

Table 115 - Format of “Report_9_{SCENARIO_SHORTNAME}_0” and 

“Report_9_{SCENARIO_SHORTNAME}_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

REGION Region code Integer 114 

ID_COUNTRY Country code Integer 1 

DESCRIP Description of region String Upplands Väsby 

VKM_L_ROAD Road loaded vehiclekm Double 2134.9469 

TKM_ROAD Road tonnekm Double 46437.5225 

VKM_E_ROAD Road empty vehiclekm Double 1744.6717 

VKM_L_RAIL Rail loaded vehiclekm Double 38.3121 

TKM_RAIL Rail tonnekm Double 20523.7748 

VKM_E_RAIL Rail empty vehiclekm Double 11.7594 

VKM_A_ROAD Road total vehiclekm Double 3879.6186 

VKM_A_RAIL Rail total vehiclekm Double 50.0715 

Description of Use: The two geodatabase tables are the source for "Report_9_Vehicle kms and Tonne kms 

per geographic region" under data panel Samgods Reports > Reports and RCM Reports > Reports.  

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 
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Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.14. Report_10_{SCENARIO_SHORTNAME}_0, Report_10_{SCENARIO_SHORTNAME}_RCM 

and Report_10_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_10_{SC

ENARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_10_{SC

ENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_10_{SC

ENARIO_SHORTNAME}_CBA 

Table 116 - Format of “Report_10_{SCENARIO_SHORTNAME}_0”, 

“Report_10_{SCENARIO_SHORTNAME}_RCM” and “Report_10_{SCENARIO_SHORTNAME}_CBA” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

COMMODITY Commodity type String 1 

TYPE Domestic, International or Total Domestic String Domestic 

ROAD Tonka on road Double 397113.25 

RAIL Tonnekm on rail Double 39074.77 

SEA Tonnekm on sea Double 32762.63 

AIR Tonnekm on air Double 0 

V101 Tonnekm Vehicle type 101 Double 1.2 

.... Tonnekm.... Double ... 

V401 Tonnekm Vehicle type 401 Double 0 

Description of Use: The three geodatabase tables are the source for “Report_10_Transport work (tonne kms) 

per mode and vehicle cl, total and split per commodity, domestic, tdomestic and international" under data 

panel Samgods Report > Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered 

or CBA Report > OD Covered. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.15. Report_11_{SCENARIO_SHORTNAME}_0, Report_11_{SCENARIO_SHORTNAME}_RCM 

and Report_11_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_11_{SC

ENARIO_SHORTNAME}_0 
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Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_11_{SC

ENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_11_{SC

ENARIO_SHORTNAME}_CBA 

Table 117 - Format of “Report_11_{SCENARIO_SHORTNAME}_0”, 

“Report_11_{SCENARIO_SHORTNAME}_RCM” and “Report_11_{SCENARIO_SHORTNAME}_CBA” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

COMMODITY Commodity type String 1 

TYPE Domestic, International or Total Domestic String Domestic 

ROAD Tons on road Double 4805.92 

RAIL Tons on rail Double 421.46 

SEA Tons on sea Double 158.2 

AIR Tons on air Double 0 

V101 Tons Vehicle type 101 Double 1.2 

.... Tons.... Double ... 

V401 Tons Vehicle type 401 Double 0 

Description of Use: The three geodatabase tables are the source for “Report_11_ Transported goods volume 

per mode and vehicle cl, total and split per commodity, domestic, tdomestic and international" under data 

panel Samgods Report > Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered 

or CBA Report > OD Covered. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.16. Report_12_{SCENARIO_SHORTNAME}_0, Report_12_{SCENARIO_SHORTNAME}_RCM 

and Report_12_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_12_{SC

ENARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_12_{SC

ENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_12_{SC

ENARIO_SHORTNAME}_CBA 

Table 118 - Format of “Report_12_{SCENARIO_SHORTNAME}_0”, 

“Report_12_{SCENARIO_SHORTNAME}_RCM” and “Report_12_{SCENARIO_SHORTNAME}_CBA” 

tables. 
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Field Description Data 

Format 

Example 

OBJECTID Counter Integer 1 

COMMODITY Commodity type String 1 

VH_CL Vehicle type Integer 101 

DOM_NODEC Node cost pure domestic (SEK) Double 0 

DOM_LINKC Link cost pure domestic (SEK) Double 0 

IMPORT_NOD Node cost import (SEK) Double 0 

IMPORT_LIN Link cost import (SEK) Double 0 

EXPORT_NOD Node cost export (SEK) Double 0 

EXPORT_LIN Link cost export (SEK) Double 0 

INT_NODC Node cost international  (SEK) Double 0 

INT_LINC Link cost international (SEK) Double 0 

NCOSTDTOT Node cost total domestic (SEK) Double 0 

LCOSTDTOT Loading cost total domestic (SEK) Double 0 

LTIMEDTOT Loading time total domestic Cost (SEK) Double 0 

NINTERDTOT Node Interest total domestic Cost (SEK) Double 0 

POSCDTOT Positioning Cost total domestic (SEK) Double 0 

FWYCDTOT Fway Dues total domestic (SEK) Double 0 

PILTCDTOT Pilot Fee total domestic (SEK) Double 0 

LICOSDTOT Link cost total domestic (SEK) Double 0 

TRPTCDTOT Trp Time total domestic cost (SEK) Double 0 

LINTECDTOT Link interest cost total domestic (SEK) Double 0 

DISCDTOT Distance cost total domestic (SEK) Double 0 

INFRCDTOT Infrastructure cost total domestic (SEK) Double 0 

KMDTOT Km total domestic (km) Double 0 

TONSDTOT* Tonnes total domestic (Tonnes) Double 0 

LIFTDTOT Lifted tonnes total domestic (Tonnes) Double 0 

TRANSTDTOT Transfer tonnes total domestic (Tonnes) Double 0 
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Field Description Data 

Format 

Example 

TONKMDTOT Tonnekm total domestic (Tonnekm) Double 0 

TRTIMEDTOT Transport time total domestic (hours) Double 0 

LOADTMDTOT Loading time total domestic (hours) Double 0 

NCOSTINT Node cost international (SEK) Double 0 

LCOSTINT Loading cost international (SEK) Double 0 

LTIMEINT Loading time international Cost (SEK) Double 0 

NINTERINT Node Interest international Cost (SEK) Double 0 

POSCINT Positioning Cost international (SEK) Double 0 

FWYCINT Fway Dues international (SEK) Double 0 

PILTCINT Pilot Fee international (SEK) Double 0 

LICOSINT Link cost international (SEK) Double 0 

TRPTCINT Trp Time international cost (SEK) Double 0 

LINTERCINT Link interest cost international (SEK) Double 0 

DISCINT Distance cost international (SEK) Double 0 

INFRCINT Infrastructure cost international (SEK) Double 0 

KMINT Km international (km) Double 0 

TONINT* Tonnes international (Tonnes) Double 0 

LIFTINT Lifted tonnes international (Tonnes) Double 0 

TRANSTINT Transfer tonnes total domestic (Tonnes) Double 0 

TONKMINT Tonnekm international (Tonnekm) Double 0 

TRTIMEINT Transport time international (hours) Double 0 

LOADTMINT Loading time international (hours) Double 0 

Description of Use: The three geodatabase tables are the source for “Report_12_node and link costs per 

vehicle and product group" under data panel Samgods Report > Logistics Module > OD Covered or RCM 

Reports > Logistics Module > OD Covered or CBA Report > OD Covered. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 
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Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

Other notes: Attributes related to kms and tonnekms are comparable with  

• CHAIN_OD_COV_{Scenario_ShortName}_{Select_commodity}_1,  

• CHAIN_OD_COV_{Scenario_ShortName}_RCM_1 and  

• CHAIN_OD_COV_{Scenario_ShortName}_CBA_1 

Attributes with * cannot compare since for shipments, vehicles and tonnes as double counting is introduced. 

The problem is related to red cell that is assigned to both International and DomesticTotal, shown in Table 

119. 

Table 119 – Double counting. 

Domestic Orig&Dest node     D 

Foreign Orig/Dest node 

Idist>0 

Ddist>0 I/Dtotal 

DDist=0 I 

Idist=0   Dtotal 

 

3.4.3.17. Report_13_Portarea_0_STD and Report_13_Portarea_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_13_Port

area_0_STD 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_13_Port

area_RCM 

Table 120 - Format of “Report_13_Portarea_0_STD” and “Report_13_Portarea_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

PORTAREA Port area number Integer 1 

DES 

3 tables are saved, each of them has a different DES (Model results, 

Statistics, Differences) 

String Model results 

PDES Port area description 

String Haparanda-

Skellefteå 

COM01 Tons/1000 per port area and commodity group 1 Double 0 

… … … … 

COM16 Tons/1000 per port area and commodity group 16 Double 21.52 

TOT Total Tons/1000 per port area Double 9170.14 

Description of Use: The two geodatabase tables are the source for 

"Report_13_Tons_per_PortArea_and_Commodity_Group" under data panel Reports > Logistics Module 

and Reports > Rail Capacity Management. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog 
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Created by: Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No.  

 

3.4.3.18. Report_14_Oresund_Kiel_0_STD and Report_14_Oresund_Kiel_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_14_Ore

sund_Kiel_0_STD 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_14_Ore

sund_Kiel_RCM 

Table 121 - Format of “Report_14_Oresund_Kiel_0_STD” and “Report_14_Oresund_Kiel_RCM” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

DES 

Description of type of statistics and infrastructure (Oresund road, 

Oresund rail, Kiel Canal, Jylland) 

String OresundRoad 

STATISTIC 

Unit of statistics (vehicles or tons): the model results will be 

compared against vehicles or tons depending on the value 

present in this field 

String Vehicles 

VALUE_ Value of statistics (tons or vehicles depending on ID_S) Integer 251589 

TOTVH Total vehicles from model Double 495658 

TOTTON Total tons from model Double 5418635.63197 

DIF Absolute differences between MODEL and VALUE_ Double 244069 

DIF_PER Relative differences between MODEL and VALUE_ Double 0.97 

MODEL Total vehicles or tons from model depending on ID_S value Double 495658 

Description of Use: The two geodatabase tables are the source for "Report_14_Oresund Bridge_Kiel 

Canal_Jylland" under data panel Reports > Logistics Module and Reports > Rail Capacity Management. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No.  

 

3.4.3.19. Report_15_RailLinksRCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_15_Rail

LinksRCM 

Table 122 - Format of “Report_15_RailLinksRCM” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_LINK ID_LINK from capacity table Integer 1 

A Start node in VY Numbering Integer 2000 

B End node in VY Numbering Integer 2001 
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Field Description Data Format Example 

EMME_A Start Emme node Integer 1002 

EMME_B End Emme node Integer 1003 

TRAKBANDEL Trakbandel code for specific link Integer 1110 

CAP Capacity in bidirectional trains per day (from Capacity table) String 418 

TOT_LOAD Number of loaded bidirectional trains per day Double 71.24434 

TOT_EMPT Number of unloaded bidirectional trains per day Double 31.21692 

TOT_ASS Number of total bidirectional trains per day (loaded+unloaded) Double 102.4613 

DIFF_VC Difference between TOT_ASS and CAP Double -315.539 

FLAG_OVCAP Flag 0/1. 1 means the link is overcapacity by at least 1 train Integer 0 

FLAG_PER Flag 0/1. 1 means the link is overcapacity by at least 1% Integer 0 

FLAG_TOT 

Flag 0/1. 1 means that the FLAG_OVCAP=1 or FLAG_PER=1. 

Represent all the links with overcapacity conditions. 

Integer 

0 

MARG_COST Marginal cost Double 0.5 

Description of Use: The table is the source for "Report_15_Trains per day (tot, empty, loaded) (RCM)" under 

data panel Reports > Rail Capacity Management. This specific output is produced only for Rail Capacity 

Management. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Results RCM” subgroup under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.20. Report_16_{SCENARIO_SHORTNAME}_0 and 

Report_16_{SCENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_16_{SC

ENARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_16_{SC

ENARIO_SHORTNAME}_RCM 

Table 123 - Format of “Report_16_{SCENARIO_SHORTNAME}_0” and 

“Report_16_{SCENARIO_SHORTNAME}_RCM” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COUNTY County code 
Integer 1 

NAME County name 
String Stockholm 

VKM_LGV3 VehicleKm Vehicle type 101 
Double 773.22 

VKM_MGV16 VehicleKm Vehicle type 102 
Double 15643.87 
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Field Description Data Format Example 

VKM_MGV24 VehicleKm Vehicle type 103 
Double 25213.88 

VKM_HGV40 VehicleKm Vehicle type 104 
Double 30262.45 

VKM_HGV60 VehicleKm Vehicle type 105 
Double 106313.66 

VKM_HGV74 VehicleKm Vehicle type 106 
Double 0 

VKM_ROAD VehicleKm total road 
Double 178207.09 

VKM_LGV3P Percentage Vehicle type 101 (VHM_LGV3/VHM_ROAD*100) 
Double 0.43 

VKM_MGV16P Percentage Vehicle type 102 (VKM_MGV16/VHM_ROAD*100) 
Double 8.78 

VKM_MGV24P Percentage Vehicle type 103 (VKM_MGV24/VHM_ROAD*100) 
Double 14.15 

VKM_HGV40P Percentage Vehicle type 104 (VKM_HGV40/VHM_ROAD*100) 
Double 16.98 

VKM_HGV60P Percentage Vehicle type 105 (VKM_HGV60/VHM_ROAD*100) 
Double 59.66 

VKM_HGV74P Percentage Vehicle type 106 (VKM_HGV60/VHM_ROAD*100) 
Double 0 

Description of Use: The two geodatabase tables are the source for "Report_16_VHCLKM and distribution by 

county - totals" under data panel Samgods Reports > Reports and RCM Reports > Reports.  

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.21. Report_17_{SCENARIO_SHORTNAME}_0 and 

Report_17_{SCENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_17_{SC

ENARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_17_{SC

ENARIO_SHORTNAME}_RCM 

Table 124 - Format of “Report_17_{SCENARIO_SHORTNAME}_0” and 

“Report_17_{SCENARIO_SHORTNAME}_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COUNTY County code Integer 1 

NAME County name String Stockholm 

VKLGV311 VehicleKm Vehicle type 101 Double 442.74 

VKMGV1611 VehicleKm Vehicle type 102 Double 10749.62 
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Field Description Data Format Example 

VKMGV2411 VehicleKm Vehicle type 103 Double 16649.97 

VKHGV4011 VehicleKm Vehicle type 104 Double 22261.32 

VKHGV6011 VehicleKm Vehicle type 105 Double 67905.24 

VKMHGV7411 VehicleKm Vehicle type 106 Double 0 

VKROAD11 VehicleKm total road Double 118008.9 

VKLGV3P11 

Percentage Vehicle type 101 

(VHM_LGV3_11/VHM_ROAD_11*100) 

Double 0.38 

VKMGV16P11N 

Percentage Vehicle type 102 

(VKM_MGV16_11/VHM_ROAD_11*100) 

Double 9.11 

VKMGV24P11N 

Percentage Vehicle type 103 

(VKM_MGV24_11/VHM_ROAD_11*100) 

Double 14.11 

VKHGV40P11N 

Percentage Vehicle type 104 

(VKM_HGV40_11/VHM_ROAD_11*100) 

Double 18.86 

VKHGV60P11N 

Percentage Vehicle type 105 

(VKM_HGV60_11/VHM_ROAD_11*100) 

Double 57.54 

VKHGV74P11N 

Percentage Vehicle type 106 

(VKM_HGV60_11/VHM_ROAD_11*100) 

Double 0 

Description of Use: The two geodatabase tables are the source for “Report_17_VHCLKM and distribution by 

county - E10 roads" under data panel Samgods Reports > Reports and RCM Reports > Reports. It contains 

the same results as per Report_16 but filtered on roads with CATEGORY=11 (E10 roads). 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.22. Report_18_{SCENARIO_SHORTNAME}_0 and 

Report_18_{SCENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_18_{SC

ENARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_18_{SC

ENARIO_SHORTNAME}_RCM 

Table 125 - Format of “Report_18_{SCENARIO_SHORTNAME}_0” and 

“Report_18_{SCENARIO_SHORTNAME}_RCM” tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COUNTY County code Integer 1 

NAME County name String Stockholm 

VKLGV3OR VehicleKm Vehicle type 101 Double 330.48 
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Field Description Data Format Example 

VKMGV16OR VehicleKm Vehicle type 102 Double 4894.25 

VKMGV24OR VehicleKm Vehicle type 103 Double 8563.91 

VKHGV40OR VehicleKm Vehicle type 104 Double 8001.13 

VKHGV60OR VehicleKm Vehicle type 106 Double 38408.42 

VKHGV74OR VehicleKm Vehicle type 106 Double 38408.42 

VKROADOR VehicleKm total road Double 60198.19 

VKLGV3POR 

Percentage Vehicle type 101 

(VHM_LGV3_OR/VHM_ROAD_OR*100) 

Double 0.55 

VKMGV16POR 

Percentage Vehicle type 102 

(VKM_MGV16_ORN/VHM_ROAD_OR*100) 

Double 8.13 

VKMGV24POR 

Percentage Vehicle type 103 

(VKM_MGV24_ORN/VHM_ROAD_OR*100) 

Double 14.23 

VKHGV40POR 

Percentage Vehicle type 104 

(VKM_HGV40_ORN/VHM_ROAD_OR*100) 

Double 13.29 

VKHGV60POR 

Percentage Vehicle type 106 

(VKM_HGV60_ORN/VHM_ROAD_OR*100) 

Double 63.8 

VKHGV74POR 

Percentage Vehicle type 106 

(VKM_HGV60_ORN/VHM_ROAD_OR*100) 

Double 0 

Description of Use: The two geodatabase tables are the source for "Report_18_VHCLKM and distribution by 

country - Other roads" under data panel Samgods Reports > Reports and RCM Reports > Reports. It 

contains the same results as per Report_16 but filtered on roads with CATEGORY<>11. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”. 

Made by user choice: No. 

 

3.4.3.23. Report_19_{SCENARIO_SHORTNAME}_0, Report_19_{SCENARIO_SHORTNAME}_RCM 

and Report_19_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_19_{SC

ENARIO_SHORTNAME}_0 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_19_{SC

ENARIO_SHORTNAME}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_19_{SC

ENARIO_SHORTNAME}_CBA 

Table 126 - Format of “Report_19_{SCENARIO_SHORTNAME}_0”, 

“Report_19_{SCENARIO_SHORTNAME}_RCM” and “Report_19_{SCENARIO_SHORTNAME}_CBA” 

tables. 

Field Description Data Format Example 

OBJECTID Counter Integer 35 



Input and output file reference 

ZONE_N Voyager node number Integer 35 

ZONE_ORIG Emme node number Integer 718012 

CENTRALL Terminal description String Stockholm-Årsta 

P01LOAD Loaded tons on rail terminal commodity 01 Double 0.66 

P01UNLOAD Unloaded tons on rail terminal Commodity 01 Double 10.73 

P02LOAD Loaded tons on rail terminal commodity 02 Double 55 

P02UNLOAD Unloaded tons on rail terminal Commodity 02 Double 484.36 

P03LOAD Loaded tons on rail terminal commodity 03 Double 2.48 

P03UNLOAD Unloaded tons on rail terminal Commodity 03 Double 14.54 

P04LOAD Loaded tons on rail terminal commodity 04 Double 1.87 

P04UNLOAD Unloaded tons on rail terminal Commodity 04 Double 1.44 

P05LOAD Loaded tons on rail terminal commodity 05 Double 3.8 

P05UNLOAD Unloaded tons on rail terminal Commodity 05 Double 3.47 

P06LOAD Loaded tons on rail terminal commodity 06 Double 14.93 

P06UNLOAD Unloaded tons on rail terminal Commodity 06 Double 328.54 

P07LOAD Loaded tons on rail terminal commodity 07 Double 0.04 

P07UNLOAD Unloaded tons on rail terminal Commodity 07 Double 167.98 

P08LOAD Loaded tons on rail terminal commodity 08 Double 0 

P08UNLOAD Unloaded tons on rail terminal Commodity 08 Double 0 

P09LOAD Loaded tons on rail terminal commodity 09 Double 1.45 

P09UNLOAD Unloaded tons on rail terminal Commodity 09 Double 12.66 

P10LOAD Loaded tons on rail terminal commodity 10 Double 676.26 

P10UNLOAD Unloaded tons on rail terminal Commodity 10 Double 1384.15 

P11LOAD Loaded tons on rail terminal commodity 11 Double 1.64 

P11UNLOAD Unloaded tons on rail terminal Commodity 11 Double 33.77 

P12LOAD Loaded tons on rail terminal commodity 12 Double 7.6 

P12UNLOAD Unloaded tons on rail terminal Commodity 12 Double 6.57 

P13LOAD Loaded tons on rail terminal commodity 13 Double 0 

P13UNLOAD Unloaded tons on rail terminal Commodity 13 Double 116.52 

P14LOAD Loaded tons on rail terminal commodity 14 Double 567.28 

P14UNLOAD Unloaded tons on rail terminal Commodity 14 Double 381.28 

P15LOAD Loaded tons on rail terminal commodity 15 Double 0.01 

P15UNLOAD Unloaded tons on rail terminal Commodity 15 Double 0 

P16LOAD Loaded tons on rail terminal commodity 16 Double 7.02 

P16UNLOAD Unloaded tons on rail terminal Commodity 16 Double 3.93 

Description of Use: The three geodatabase tables are the source for “Report #19 Loaded and unloaded tons 

on rail terminals" under data panel Samgods Report > Logistics Module > OD Covered or RCM Reports > 

Logistics Module > OD Covered or CBA Report > OD.  It contains the total loaded and unloaded tons divided 

by scale parameter per each rail terminal. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog, 

ArcCatalog. 

Created by: “Save Reports” subgroup under ”Samgods Model > Logistics Module” and “Save Reports” 

subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports” 

subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

 

Made by user choice: No. 
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3.4.3.24. Report_20_{SCENARIO_SHORTNAME}_CBA  

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_20_{SC

ENARIO_SHORTNAME}_CBA 

Table 127 - Format of “Report_20_{SCENARIO_SHORTNAME}_CBA” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

ID_COM Commodity type String 1 

ORDCDTOT Order cost domestic String 155713694 

INVCDTOT Inventory cost domestic Double 292369180 

ORDCINT Order cost international Double 43217624 

INVCINT Inventory cost international Double 87972825 

Description of Use: The geodatabase table is the for “Report #20 Order and inventory costs for TDOM and 

INT (CBA)" under data panel ”CBA Report > OD Covered”. 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog. 

Created by: “Save Reports” subgroup under “CBA Analysis – ASEK values > Logistics Module”. 

Made by user choice: No.  

 

3.4.3.25. Report_21_{Scenario_ShortName}_RCM 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Report_21_{SC

ENARIO_SHORTNAME}_RCM 

Table 128 - Format of “Report_21_{SCENARIO_SHORTNAME}_RCM” table. 

Field Description Data Format Example 

ID Counter Integer 1 

COMMODITY Commodity group String COM 1 

KTKMDOM Total domestic tonkm (year) Double 4452970.43 

KTKMINT International tonkm (year) Double 17883038.00 

VKMDOM Total domestic loaded vhclkm (daily) Double 313307.98 

VKMINT International loaded vhclkm (daily) Double 692097.85 

EVKMTDOM Total domestic empty vhclkm (daily) Double 0.00 

EVKMTINT International empty vhclkm (daily) Double 0.00 

Description of Use: The geodatabase table is the input table for “Report #21 Domestic Total and 

International Tonskm and Vkm per commodity group RCM - Rail" under data panel ”RCM Report > 

Reports” 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog 

Created by: “Results RCM” subgroups under “Samgods Model” 
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Made by user choice: No.  

 

3.4.3.26. Vehicles_loaded_and_empty_witin_Swedish_territory_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Vehicles_loaded

_and_empty_witin_Swedish_territory_CBA 

Table 129 - Format of “Vehicles_loaded_and_empty_witin_Swedish_territory_CBA” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

GVEH_TY Vehicle Type  to sort the results in three cases: 

• All vehicles apart ferries => GVEH_TY=0 

• Road and rail vehicles on ferry => GVEH_TY=300 

• Ferry vehicles => GVEH_TY=301 

Integer 
 

300 

VEH_TY Vehicle Type Double 101 

KM_L_TOT Km Total Domestic Loaded Vehicles Double 1792.95 

KM_E_TOT Km Total Empty Domestic Double 1203.88 

KM_TOT Number of Km Total Domestic Total vehicles (Loaded 

+Empties) 

Double 341.33 

TKM_L_TOT TonneKm Total Domestic Loaded Vehicles Double 1917.77 

TKM_TOT Number of TonneKm  Total Domestic Total vehicles 

(Loaded +Empties) 

Double 184.3 

NV_L_TOT Number of  Total Domestic Loaded Vehicles Double 32.07 

NV_E_TOT Number of Empty Vehicles Total Domestic Double 19.11 

NV_TOT Number of Total Domestic Total vehicles (Loaded 

+Empties) 

Double 4.46 

Description of Use: The geodatabase table is the input table for “Vehicles, loaded and empty, within Swedish 

territory" under data panel “CBA Report > Main Reports” 

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog 

Created by: “Main Reports” subgroups under “Cost Benefit Analysis - ASEK Values > CBAAnalysis” 

 

Made by user choice: No.  

3.4.3.27. Costs_D_I_X_T_{SCENARIO_SHORTNAME}_CBA 

Scenario_Tree\{SCENARIO_SHORTNAME}\Output0_{SCENARIO_SHORTNAME}.mdb\Costs_D_I_X_

T_{SCENARIO_SHORTNAME}_CBA 

Table 130 - Format of “Costs_D_I_X_T_{SCENARIO_SHORTNAME}_CBA” table. 

Field Description Data Format Example 

OBJECTID Counter Integer 1 

GVEH_TY Vehicle Type to sort the results in three cases: 

• All vehicles apart ferries => 0 

• Road and rail vehicles on ferry => 300 

• Ferry vehicles => 301 

Integer 
 

300 

VH_TY Vehicle Type number Double 101 

VHCLONFERR Vehicle Type number on ferry Double 101 

DMXT Flag for 0=domestic 1=import 2= export 3= transit Integer 1 

DESC_ Description for DMXT String domestic 
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TRPCOSTRCM Transport Cost RCM Double 187903.91 

INVCOSTRCM Inventory Cost RCM Double 1284034.49 

EMPCOSTRCM Empties Cost RCM Double 27455.54 

TRPCOSTCBA Transport Cost CBA Double 187903.91 

INVCOSTCBA Inventory Cost CBA Double 1284034.49 

EMPCOSTCBA Empties Cost CBA Double 27455.54 

 

Description of Use: CBA, linked in the interface as 2 Report B Costs_D_I_X_T by vehicle type”. Used to 

produce {SCENARIO_DIR}\CBA_Final_report_{SCENARIO_CODE}.txt.  

Visualizing Options: Microsoft Access or Cube GUI, ArcCatalog. 

Created by: “Main Reports” subgroups under “Cost Benefit Analysis - ASEK Values > CBA Analysis”. 

Made by user choice: No.  
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3.4.4. Results in matrix format 

In the following tables there are the list of matrices created by the model. 

3.4.4.1. LOS matrices 
Table 131 - LOS matrices. 

Folder Name of matrix file Name of matrix Description User 

choice: 

{Scenario_Dir} COST_ROAD_{SCENARIO_SHORTNAME}.MAT D101_{SCENARIO_SHORTNAME}, … 

D106_{SCENARIO_SHORTNAME} 

Distance (km) for vehicle type 101-106 Yes 

T101_{SCENARIO_SHORTNAME}, … 

T106_{SCENARIO_SHORTNAME} 

Time (hours) for vehicle type 101-106 

X101_{SCENARIO_SHORTNAME}, … 

X106_{SCENARIO_SHORTNAME} 

Extra costs for vehicle type 101-106 

DD101_{SCENARIO_SHORTNAME}, … 

DD106_{SCENARIO_SHORTNAME} 

Domestic distance (km) for vehicle type 101-

106 

{Scenario_Dir} COST_RAIL_{SCENARIO_SHORTNAME}.MAT D201_{SCENARIO_SHORTNAME} 

D202_{SCENARIO_SHORTNAME} 

D204_{SCENARIO_SHORTNAME}, 

…D212_{SCENARIO_SHORTNAME} 

Distance (km) for vehicle type 201, … Yes 

T201_{SCENARIO_SHORTNAME}, 

T202_{SCENARIO_SHORTNAME}, 

T204_{SCENARIO_SHORTNAME}, } 

…T212_{SCENARIO_SHORTNAME} 

Time (hours) for vehicle type 201, … 

X201_{SCENARIO_SHORTNAME} 

X202_{SCENARIO_SHORTNAME} 

X204_{SCENARIO_SHORTNAME} 

…X212_{SCENARIO_SHORTNAME} 

Extra costs for vehicle type 201, … 

DD201_{SCENARIO_SHORTNAME} 

DD202_{SCENARIO_SHORTNAME} 

DD204_{SCENARIO_SHORTNAME 

Domestic distance (km) for vehicle type 201, 

…212 
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Folder Name of matrix file Name of matrix Description User 

choice: 

…DD212_{SCENARIO_SHORTNAME 

{Scenario_Dir} COST_SEA_{SCENARIO_SHORTNAME}.MAT D301_{SCENARIO_SHORTNAME}  

…D322_{SCENARIO_SHORTNAME}, 

Distance (km) for vehicle type 301-322 Yes 

T301_{SCENARIO_SHORTNAME} … 

T322_{SCENARIO_SHORTNAME} 

Time (hours) for vehicle type 301-322 

X301_{SCENARIO_SHORTNAME} … 

X322_{SCENARIO_SHORTNAME}, 

Extra costs for vehicle type 301-322 

DD301_{SCENARIO_SHORTNAME…DD322_{

SCENARIO_SHORTNAME} 

Domestic distance (km) for vehicle type 301-

322 

{Scenario_Dir} COST_AIR_{SCENARIO_SHORTNAME}.MAT D401_{SCENARIO_SHORTNAME} Distance (km) for vehicle type 401 Yes 

T401_{SCENARIO_SHORTNAME} Time (hours) for vehicle type 401 

X401_{SCENARIO_SHORTNAME} Extra costs for vehicle type 401 

DD01_{SCENARIO_SHORTNAME} Domestic distance (km) for vehicle type 401 

Structure: Origin (on rows), Destination (on columns), Value (double) on matrix cell. 

Description of Use: to store the LOS matrices at the end of cost calculation phase. 

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window). 

Created by: “LOS calculation” subgroup under “Samgods Model”. 

Made by user choice: Yes. 

 

3.4.4.2. Trip Matrices from Standard Logistic Module 
Table 132 - Trip Matrices from Standard Logistic Module. 
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Folder Name of matrix file Name of matrix Description User 

choice: 

{Scenario_Dir} ROAD_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Loaded Vehicles 101 per year No 

102_{SCENARIO_SHORTNAME} OD Loaded Vehicles 102 per year 

103_{SCENARIO_SHORTNAME} OD Loaded Vehicles 103 per year 

104_{SCENARIO_SHORTNAME} OD Loaded Vehicles 104 per year 

105_{SCENARIO_SHORTNAME} OD Loaded Vehicles 105 per year 

106_{SCENARIO_SHORTNAME} OD Loaded Vehicles 106 per year 

Road_{SCENARIO_SHORTNAME} OD Loaded Vehicles total road mode per year 

{Scenario_Dir} RAIL_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Loaded Vehicles 201 per year No 

202_{SCENARIO_SHORTNAME} OD Loaded Vehicles 202 per year 

204_{SCENARIO_SHORTNAME} OD Loaded Vehicles 204 per year 

205_{SCENARIO_SHORTNAME} OD Loaded Vehicles 205 per year 

206_{SCENARIO_SHORTNAME} OD Loaded Vehicles 206 per year 

207_{SCENARIO_SHORTNAME} OD Loaded Vehicles 207 per year 

208_{SCENARIO_SHORTNAME} OD Loaded Vehicles 208 per year 

209_{SCENARIO_SHORTNAME} OD Loaded Vehicles 209 per year 

210_{SCENARIO_SHORTNAME} OD Loaded Vehicles 210 per year 

211_{SCENARIO_SHORTNAME} OD Loaded Vehicles 211 per year 

212_{SCENARIO_SHORTNAME} OD Loaded Vehicles 212 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

Rail_{SCENARIO_SHORTNAME} OD Loaded Vehicles total rail mode per year 

{Scenario_Dir} SEA_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Loaded Vehicles 301 per year No 

302_{SCENARIO_SHORTNAME} OD Loaded Vehicles 302 per year 

303_{SCENARIO_SHORTNAME} OD Loaded Vehicles 303 per year 

304_{SCENARIO_SHORTNAME} OD Loaded Vehicles 304 per year 

305_{SCENARIO_SHORTNAME} OD Loaded Vehicles 305 per year 

306_{SCENARIO_SHORTNAME} OD Loaded Vehicles 306 per year 

307_{SCENARIO_SHORTNAME} OD Loaded Vehicles 307 per year 

308_{SCENARIO_SHORTNAME} OD Loaded Vehicles 308 per year 

309_{SCENARIO_SHORTNAME} OD Loaded Vehicles 309 per year 

310_{SCENARIO_SHORTNAME} OD Loaded Vehicles 310 per year 

311_{SCENARIO_SHORTNAME} OD Loaded Vehicles 311 per year 

312_{SCENARIO_SHORTNAME} OD Loaded Vehicles 312 per year 

313_{SCENARIO_SHORTNAME} OD Loaded Vehicles 313 per year 

314_{SCENARIO_SHORTNAME} OD Loaded Vehicles 314 per year 

315_{SCENARIO_SHORTNAME} OD Loaded Vehicles 315 per year 

316_{SCENARIO_SHORTNAME} OD Loaded Vehicles 316 per year 

317_{SCENARIO_SHORTNAME} OD Loaded Vehicles 317 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

318_{SCENARIO_SHORTNAME} OD Loaded Vehicles 318 per year 

319_{SCENARIO_SHORTNAME} OD Loaded Vehicles 319 per year 

320_{SCENARIO_SHORTNAME} OD Loaded Vehicles 320 per year 

321_{SCENARIO_SHORTNAME} OD Loaded Vehicles 321 per year 

322_{SCENARIO_SHORTNAME} OD Loaded Vehicles 322 per year 

Sea_{SCENARIO_SHORTNAME} OD Loaded Vehicles total Sea mode per year 

{Scenario_Dir} AIR_VHCLFLOW0_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Loaded Vehicles 401 per year. (mode air) No 

{Scenario_Dir} ROAD_TON0_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Tons 101 per year No 

102_{SCENARIO_SHORTNAME} OD Tons 102 per year 

103_{SCENARIO_SHORTNAME} OD Tons 103 per year 

104_{SCENARIO_SHORTNAME} OD Tons 104 per year 

105_{SCENARIO_SHORTNAME} OD Tons 105 per year 

106_{SCENARIO_SHORTNAME} OD Tons 106 per year 

Road_{SCENARIO_SHORTNAME} OD Tons total road mode per year 

{Scenario_Dir} RAIL_TON0_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Tons 201 per year No 

202_{SCENARIO_SHORTNAME} OD Tons 202 per year 

204_{SCENARIO_SHORTNAME} OD Tons 204 per year 

205_{SCENARIO_SHORTNAME} OD Tons 205 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

206_{SCENARIO_SHORTNAME} OD Tons 206 per year 

207_{SCENARIO_SHORTNAME} OD Tons 207 per year 

208_{SCENARIO_SHORTNAME} OD Tons 208 per year 

209_{SCENARIO_SHORTNAME} OD Tons 209 per year 

210_{SCENARIO_SHORTNAME} OD Tons 210 per year 

211_{SCENARIO_SHORTNAME} OD Tons 211 per year 

212_{SCENARIO_SHORTNAME} OD Tons 212 per year 

Rail_{SCENARIO_SHORTNAME} OD Tons total rail mode per year 

{Scenario_Dir} SEA_TON0_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Tons 301 per year No 

302_{SCENARIO_SHORTNAME} OD Tons 302 per year 

303_{SCENARIO_SHORTNAME} OD Tons 303 per year 

304_{SCENARIO_SHORTNAME} OD Tons 304 per year 

305_{SCENARIO_SHORTNAME} OD Tons 305 per year 

306_{SCENARIO_SHORTNAME} OD Tons 306 per year 

307_{SCENARIO_SHORTNAME} OD Tons 307 per year 

308_{SCENARIO_SHORTNAME} OD Tons 308 per year 

309_{SCENARIO_SHORTNAME} OD Tons 309 per year 

310_{SCENARIO_SHORTNAME} OD Tons 310 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

311_{SCENARIO_SHORTNAME} OD Tons 311 per year 

312_{SCENARIO_SHORTNAME} OD Tons 312 per year 

313_{SCENARIO_SHORTNAME} OD Tons 313 per year 

314_{SCENARIO_SHORTNAME} OD Tons 314 per year 

315_{SCENARIO_SHORTNAME} OD Tons 315 per year 

316_{SCENARIO_SHORTNAME} OD Tons 316 per year 

317_{SCENARIO_SHORTNAME} OD Tons 317 per year 

318_{SCENARIO_SHORTNAME} OD Tons 318 per year 

319_{SCENARIO_SHORTNAME} OD Tons 319 per year 

320_{SCENARIO_SHORTNAME} OD Tons 320 per year 

321_{SCENARIO_SHORTNAME} OD Tons 321 per year 

322_{SCENARIO_SHORTNAME} OD Tons 322 per year 

Sea_{SCENARIO_SHORTNAME} OD Tons total Sea mode per year 

{Scenario_Dir} AIR_TON0_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Tons 401 per year. (mode air) No 

{Scenario_Dir} ROAD_EMP0_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 101 per year No 

102_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 102 per year 

103_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 103 per year 

104_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 104 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

105_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 105 per year 

106_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 106 per year 

Road_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total road mode per year 

{Scenario_Dir} RAIL_EMP0_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 201 per year No 

202_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 202 per year 

204_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 204 per year 

205_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 205 per year 

206_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 206 per year 

207_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 207 per year 

208_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 208 per year 

209_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 209 per year 

210_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 210 per year 

211_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 211 per year 

212_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 212 per year 

Rail_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total rail mode per year 

{Scenario_Dir} SEA_EMP0_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 301 per year No 

302_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 302 per year 

303_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 303 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

304_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 304 per year 

305_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 305 per year 

306_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 306 per year 

307_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 307 per year 

308_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 308 per year 

309_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 309 per year 

310_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 310 per year 

311_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 311 per year 

312_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 312 per year 

313_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 313 per year 

314_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 314 per year 

315_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 315 per year 

316_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 316 per year 

317_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 317 per year 

318_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 318 per year 

319_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 319 per year 

320_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 320 per year 

321_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 321 per year 
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Folder Name of matrix file Name of matrix Description User 

choice: 

322_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 322 per year 

Sea_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total Sea mode per year 

{Scenario_Dir} AIR_EMP0_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 401 per year. (mode air) No 

Structure: Origin (on rows), Destination (on columns), Value (18.6 double) on matrix cell 

Description of Use: to store the trip matrices calculated by standard logistic module 

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window) 

Created by: “Conversion from LogMod to VY” subgroup under “Samgods Model > Assignment” 

Made by user choice: No 

 

3.4.4.3. Trip Matrices from Rail Capacity Management 
Table 133 - Trip Matrices from Rail Capacity Management. 

 

Folder Name of matrix file Name of matrix Description Made by 

user: 

{Scenario_Dir} ROAD_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}

.MAT 

101_{SCENARIO_SHORTNAME} OD Loaded Vehicles 101 per year No 

102_{SCENARIO_SHORTNAME} OD Loaded Vehicles 102 per year 

103_{SCENARIO_SHORTNAME} OD Loaded Vehicles 103 per year 

104_{SCENARIO_SHORTNAME} OD Loaded Vehicles 104 per year 

105_{SCENARIO_SHORTNAME} OD Loaded Vehicles 105 per year 

106_{SCENARIO_SHORTNAME} OD Loaded Vehicles 106 per year 
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Folder Name of matrix file Name of matrix Description Made by 

user: 

Road_{SCENARIO_SHORTNAME} OD Loaded Vehicles total road mode per year 

{Scenario_Dir} RAIL_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.

MAT 

201_{SCENARIO_SHORTNAME} OD Loaded Vehicles 201 per year No 

202_{SCENARIO_SHORTNAME} OD Loaded Vehicles 202 per year 

204_{SCENARIO_SHORTNAME} OD Loaded Vehicles 204 per year 

205_{SCENARIO_SHORTNAME} OD Loaded Vehicles 205 per year 

206_{SCENARIO_SHORTNAME} OD Loaded Vehicles 206 per year 

207_{SCENARIO_SHORTNAME} OD Loaded Vehicles 207 per year 

208_{SCENARIO_SHORTNAME} OD Loaded Vehicles 208 per year 

209_{SCENARIO_SHORTNAME} OD Loaded Vehicles 209 per year 

210_{SCENARIO_SHORTNAME} OD Loaded Vehicles 210 per year 

211_{SCENARIO_SHORTNAME} OD Loaded Vehicles 211 per year 

212_{SCENARIO_SHORTNAME} OD Loaded Vehicles 212 per year 

Rail_{SCENARIO_SHORTNAME} OD Loaded Vehicles total rail mode per year 

{Scenario_Dir} SEA_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.

MAT 

301_{SCENARIO_SHORTNAME} OD Loaded Vehicles 301 per year No 

302_{SCENARIO_SHORTNAME} OD Loaded Vehicles 302 per year 

303_{SCENARIO_SHORTNAME} OD Loaded Vehicles 303 per year 

304_{SCENARIO_SHORTNAME} OD Loaded Vehicles 304 per year 

305_{SCENARIO_SHORTNAME} OD Loaded Vehicles 305 per year 
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Folder Name of matrix file Name of matrix Description Made by 

user: 

306_{SCENARIO_SHORTNAME} OD Loaded Vehicles 306 per year 

307_{SCENARIO_SHORTNAME} OD Loaded Vehicles 307 per year 

308_{SCENARIO_SHORTNAME} OD Loaded Vehicles 308 per year 

309_{SCENARIO_SHORTNAME} OD Loaded Vehicles 309 per year 

310_{SCENARIO_SHORTNAME} OD Loaded Vehicles 310 per year 

311_{SCENARIO_SHORTNAME} OD Loaded Vehicles 311 per year 

312_{SCENARIO_SHORTNAME} OD Loaded Vehicles 312 per year 

313_{SCENARIO_SHORTNAME} OD Loaded Vehicles 313 per year 

314_{SCENARIO_SHORTNAME} OD Loaded Vehicles 314 per year 

315_{SCENARIO_SHORTNAME} OD Loaded Vehicles 315 per year 

316_{SCENARIO_SHORTNAME} OD Loaded Vehicles 316 per year 

317_{SCENARIO_SHORTNAME} OD Loaded Vehicles 317 per year 

318_{SCENARIO_SHORTNAME} OD Loaded Vehicles 318 per year 

319_{SCENARIO_SHORTNAME} OD Loaded Vehicles 319 per year 

320_{SCENARIO_SHORTNAME} OD Loaded Vehicles 320 per year 

321_{SCENARIO_SHORTNAME} OD Loaded Vehicles 321 per year 

322_{SCENARIO_SHORTNAME} OD Loaded Vehicles 322 per year 

Sea_{SCENARIO_SHORTNAME} OD Loaded Vehicles total Sea mode per year 
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Folder Name of matrix file Name of matrix Description Made by 

user: 

{Scenario_Dir} AIR_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.

MAT 

Air_{SCENARIO_SHORTNAME} OD Loaded Vehicles 401 per year. (mode air) No 

{Scenario_Dir} ROAD_TON_FIN_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Tons 101 per year No 

102_{SCENARIO_SHORTNAME} OD Tons 102 per year 

103_{SCENARIO_SHORTNAME} OD Tons 103 per year 

104_{SCENARIO_SHORTNAME} OD Tons 104 per year 

105_{SCENARIO_SHORTNAME} OD Tons 105 per year 

106_{SCENARIO_SHORTNAME} OD Tons 106 per year 

Road_{SCENARIO_SHORTNAME} OD Tons total road mode per year 

{Scenario_Dir} RAIL_TON_FIN_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Tons 201 per year No 

202_{SCENARIO_SHORTNAME} OD Tons 202 per year 

204_{SCENARIO_SHORTNAME} OD Tons 204 per year 

205_{SCENARIO_SHORTNAME} OD Tons 205 per year 

206_{SCENARIO_SHORTNAME} OD Tons 206 per year 

207_{SCENARIO_SHORTNAME} OD Tons 207 per year 

208_{SCENARIO_SHORTNAME} OD Tons 208 per year 

209_{SCENARIO_SHORTNAME} OD Tons 209 per year 

210_{SCENARIO_SHORTNAME} OD Tons 210 per year 

211_{SCENARIO_SHORTNAME} OD Tons 211 per year 
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Folder Name of matrix file Name of matrix Description Made by 

user: 

212_{SCENARIO_SHORTNAME} OD Tons 212 per year 

Rail_{SCENARIO_SHORTNAME} OD Tons total rail mode per year 

{Scenario_Dir} SEA_TON_FIN_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Tons 301 per year No 

302_{SCENARIO_SHORTNAME} OD Tons 302 per year 

303_{SCENARIO_SHORTNAME} OD Tons 303 per year 

304_{SCENARIO_SHORTNAME} OD Tons 304 per year 

305_{SCENARIO_SHORTNAME} OD Tons 305 per year 

306_{SCENARIO_SHORTNAME} OD Tons 306 per year 

307_{SCENARIO_SHORTNAME} OD Tons 307 per year 

308_{SCENARIO_SHORTNAME} OD Tons 308 per year 

309_{SCENARIO_SHORTNAME} OD Tons 309 per year 

310_{SCENARIO_SHORTNAME} OD Tons 310 per year 

311_{SCENARIO_SHORTNAME} OD Tons 311 per year 

312_{SCENARIO_SHORTNAME} OD Tons 312 per year 

313_{SCENARIO_SHORTNAME} OD Tons 313 per year 

314_{SCENARIO_SHORTNAME} OD Tons 314 per year 

315_{SCENARIO_SHORTNAME} OD Tons 315 per year 

316_{SCENARIO_SHORTNAME} OD Tons 316 per year 



Input and output file reference 

Folder Name of matrix file Name of matrix Description Made by 

user: 

317_{SCENARIO_SHORTNAME} OD Tons 317 per year 

318_{SCENARIO_SHORTNAME} OD Tons 318 per year 

319_{SCENARIO_SHORTNAME} OD Tons 319 per year 

320_{SCENARIO_SHORTNAME} OD Tons 320 per year 

321_{SCENARIO_SHORTNAME} OD Tons 321 per year 

322_{SCENARIO_SHORTNAME} OD Tons 322 per year 

Sea_{SCENARIO_SHORTNAME} OD Tons total Sea mode per year 

{Scenario_Dir} AIR_TON_FIN_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Tons 401 per year. (mode air) No 

{Scenario_Dir} ROAD_EMP_FIN_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 101 per year No 

102_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 102 per year 

103_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 103 per year 

104_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 104 per year 

105_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 105 per year 

106_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 106 per year 

Road_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total road mode per year 

{Scenario_Dir} RAIL_EMP_FIN_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 201 per year No 

202_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 202 per year 

204_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 204 per year 
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Folder Name of matrix file Name of matrix Description Made by 

user: 

205_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 205 per year 

206_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 206 per year 

207_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 207 per year 

208_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 208 per year 

209_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 209 per year 

210_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 210 per year 

211_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 211 per year 

212_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 212 per year 

Rail_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total rail mode per year 

{Scenario_Dir} SEA_EMP_FIN_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 301 per year No 

302_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 302 per year 

303_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 303 per year 

304_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 304 per year 

305_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 305 per year 

306_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 306 per year 

307_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 307 per year 

308_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 308 per year 

309_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 309 per year 
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Folder Name of matrix file Name of matrix Description Made by 

user: 

310_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 310 per year 

311_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 311 per year 

312_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 312 per year 

313_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 313 per year 

314_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 314 per year 

315_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 315 per year 

316_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 316 per year 

317_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 317 per year 

318_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 318 per year 

319_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 319 per year 

320_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 320 per year 

321_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 321 per year 

322_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 322 per year 

Sea_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total Sea mode per year 

{Scenario_Dir} AIR_EMP_FIN_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 401 per year. (mode air) No 

Structure: Origin (on rows), Destination (on columns), Value (18.6 double) on matrix cell 

Description of Use: to store the trip matrices calculated by Rail Capacity Management module 

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window) 

Created by: “Conversion from LogMod to VY” subgroup under “Samgods Model > RCM Assignment” 
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Made by user choice: No 



Input and output file reference 

3.4.4.4. Other matrices 

All the following matrices: 

COMPARE_LOS_ROAD_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_LOS_RAIL_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_LOS_SEA_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_LOS_AIR_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_OD_ROAD_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_OD_RAIL_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_OD_SEA_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_OD_AIR_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_TON_ROAD_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_TON_RAIL_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_TON_SEA_X_{SCENARIO_SHORTNAME}_Base2019 

COMPARE_TON_AIR_X_{SCENARIO_SHORTNAME}_Base2019 

Will be created if the user wishes to verify differences between scenarios. 

Structure: Origin (on rows), Destination (on columns), Value (double) on matrix cell. 

Description of Use: store the differences between scenarios for the same matrix. The differences are 

calculated with the equation 

Dif_of_pair_value=OD_pair_value current scenario – OD_pair_value base scenario  

(i.e. values greater than zero mean that the OD pair value in the current scenario is greater than the base 

scenario). 

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window). 

Created by: ”Compare” application. 

Made by user choice: Yes. 

 

3.4.4.5. Other output related to matrices 

Each matrix listed in the point 3.4.4.1and 3.4.4.2 is also exportable in csv or dbf format. The exported 

matrices will have the following file name: 

{Scenario_DIR}\{Type of matrix}_{Type of mode}_{Matrix name}{Vhclnubmber}_VOY.CSV (or DBF). 

Table 134 - Matrix format. 
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Field Description Data Format 

Origin Origin zone Integer 

Destination Destination zone Integer 

Value Value Double 

Visualizing Options: Microsoft excel. 

Created by: ”Change matrix format” application 

Made by user choice: Yes 

3.4.5. Report files 

Under scenario folder after having run all the applications in the model will be five files: 

• Report_SG_{Scenario_code}.txt 

• Report_ED_{Scenario_code}.txt 

• Report_HL_{Scenario_code}.txt 

• Calibration_1.txt 

• CBA_Final_report_{Scenario_code}.txt 

For the description of the first three reports created and their meaning, please see reference 6 for further 

details. 

Calibration_1.txt is a report produced which holds information of main reporting managed by 

Outputs_Calibration_Template_rev10.xlsm (see section 3.4.8.8 Outputs_Calibration_Template_rev10.xlsm 

for details). 

CBA_Final_report contains CBA analysis applying Trafikverket outlined methodology (see reference 4 for 

further details). 

3.4.6. Temporary data to visualize scenario data 

Under scenario folder after having run all the application in the model will be four files: 

• Input_data.mxr and Input_data.mxd, Scenario_Data.vpr 

• Scenario_Data.mdb 

The first group has the purpose to define default legends to visualize in the GIS window all the data. 

The second file is the temporary geodatabase with the scenario data created by join of the scenario specific 

tables and base tables, in other words the real scenario data. It could be exist or not based on the user 

choices. It is used only by the “Edit the data application” and no other applications point to it.
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3.4.7. LogMod folder 

The structure and input/output files for LogMod folder is covered by reference 2. Here will be listed the input and output files highlighting the outputs related to 

the Rail Capacity Management and CBA – ASEK Value. For a description of RCM procedure please refer to section 6.7. For a description of Cost Benefit Analysis 

– ASEK Value, please see reference 6 for further details. 

Table 135 - LogMod folder. 

Catalog Folder First Level Second Level Third Level Fourth Level Description 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y   Main folder with all the inputs and outputs for Logistics Module and Rail Capacity 

Management Module. 

Executable and input files for parallelization of processes and log file from RCM 

procedure Error.log 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y BUILDCHAIN  Folder with all the control files and executable for BuildChain.exe 

The control files are two groups: 

BuildChain_Common.ctl, BuildChain_Special.ctl,  

BuildChainXX.ctl 

Logselect.dat 

Select.dat 

The first group has general parameters for all the commodities or specific 

commodity groups. The second one specific settings per each commodity (XX). 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y BUILDCHAIN OUTPUT BuildChainxx.log (only if Do you want to produce BuildChainxx.log files? catalog 

key set to 'yes' or 'all') 

Chainsxx.dat 

Connectionxx.lst (related to Select.dat) 

Chainsxx_RCM.dat 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y ChainChoi  Folder with all the control files and executable for ChainChoi.exe, and LP2CC.exe 

The control files are two groups: 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

ChainChoi_Common.ctl, ChainChoi_Special.ctl,  

ChainChoiXX.ctl 

The first group has general parameters for all the commodities or specific 

commodity groups. The second one specific settings per each commodity (XX). 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y ChainChoi OUTPUT Output data files from ChainChoi.exe in standard logmod procedure by 

commodity group (XX): 

• ChainChoiXXSTD.rep 

• ChainChoiXXSTD.out 

• ChainChoXXdata06STD.out 

• ChainChoiXXdata07STD.out 

• ConnectionXX.lst (related to Select.dat) 

• VhclRepXXSTD.rep 

• VhclRepXXSTD.fac 

Output data files from ChainChoi.exe in RCM procedure by commodity group XX: 

• ChainChoiXXLPX.out (as ChainChoixxSTD.out with solutions from LP) 

• ChainChoXXdata06RCM.out 

• ChainChoiXXRCM.out 

• ChainChoiXXRCM.rep 

• VhclRepXXRCM.rep 

• VhclRepXXRCM.fac 

From LP2CC.exe by commodity group XX: 

• ChainChoiXXXTD.rep 

• ChainChoiXXXTD.out 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

• ChainChoXXdata06XTD.out 

• ChainChoiXXdata07XTD.out 

• VhclRepXXXTD.rep 

• VhclRepXXXTD.fac 

LockedXX.log with locked solutions by (commodity group XX) 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y ChainChoi OUTPUT\CoVo By commodity group XX 

• CONSOLXX_CHAINTYPE.314 

• VOLUMEXX_ CHAINTYPE.314 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y ChainChoi outputCBA From LP2CC.exe by commodity group XX: 

• ChainChoiXXCBA.fac  

• ChainChoiXXCBA.rep 

• VhclRepXXCBA.fac 

• VhclRepXXCBA.rep 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y ChainChoi ConsolRate4Mode From ConsolidRateMode.exe by commodity group XX: 

• CONSOLXX-MODE.314 

 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y EXTRACT   

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y EXTRACT OUTPUT The first set of files represent the OD matrices for empties, tonnes and total 

vehicles and has been produced by extract procedure by vehicle XXX. 

• OD_EmpXXX_STD.314 

• OD_EmpXXX_FIN.314 

• OD_TonnesXXX_STD.314 

• OD_TonnesXXX_FIN.314 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

• OD_VhclXXX_STD.314 

• OD_VhclXXX_FIN.314 

 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT  Chaintype.lis is used by Standard Logistics Module and Rail Capacity 

Management Module. 

 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT COST CARGO.TXT, 

OtherCostMatters.txt (file with INTER and STUFF values), 

PILOTFEES.TXT, and by commodity group XX 

VHCLS_COMXX.TXT  

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT GENERAL averageVehicleCpacity.txt 

CalibrationParameters.txt is used to rescale LOS matrices using the scaling factors 

per port area. They are input to Standard Logistic Module and Rail Capacity 

Management internally scaling the LOS matrices per each commodity group. 

OtherCostMatters.ctl main parameters for logmod and rcm 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT Locked LockedXXXX.dat with list of chains locked where XXXX is scenario year 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT LOS FreqAir.314 

FreqCombi.314 

FreqContainerVessel.314 

FreqLorry.314 

FreqOtherVessel.314 

FreqRailFerry.314 

FreqRoadFerry.314 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

FreqRoRoVessel.314 

FreqSystem.314 

FreqWaggonlod.314 

And by vehicle type XXX 

• VXXX_ddist.314 

• VXXX_dist.314 

• VXXX_timeh.314 

• VXXX_xkr.314 

• VXXX_MC.314 (marginal cost matrices) 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT NODES ContainerHandling.txt 

DirectFeederTrain.txt 

DirectSea.txt 

DirectSystemTrain.txt 

DirectWagonLoad.txt 

Nodes.txt 

TransferCombiSea.txt 

Transferfeedertrainwagonload.txt 

TransferRoadAir.txt 

TransferRoadCombi.txt 

TransferRoadRoad.txt 

TransferRoadRoadFerry.txt 

TransferRoadSea.txt 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

TransferRoadTrain.txt 

TransferSeaSea.txt 

TransferSystemTrainSea.txt 

TransferWagonloadRailFerry.txt 

TransferWagonloadSea.txt 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT_CBA COST CARGO.TXT, 

OtherCostMatters.txt (file with INTER and STUFF values), 

PILOTFEES.TXT, and by commodity group XX 

VHCLS_COMXX.TXT  

(*) Values modified by table ScalingF_VehASEK 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT_CBA GENERAL averageVehicleCpacity.txt 

CalibrationParameters.txt is used to rescale LOS matrices using the scaling factors 

per port area. For CBA is equals to 1. 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT_CBA LOS By vehicle type XXX 

• vXXX_dtimeh.314 (domestic time - new) 

• vXXX_dxkr.314 (domestic cost - new) 

• vXXX_timeh.314 (time without rescaling parameters) 

• vXXX_xkr.314 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y INPUT_CBA NODES ContainerHandling.txt 

DirectFeederTrain.txt 

DirectSea.txt 

DirectSystemTrain.txt 

DirectWagonLoad.txt 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

Nodes.txt 

TransferCombiSea.txt 

transferfeedertrainwagonload.txt 

TransferRoadAir.txt 

TransferRoadCombi.txt 

TransferRoadRoad.txt 

TransferRoadRoadFerry.txt 

TransferRoadSea.txt 

TransferRoadTrain.txt 

TransferSeaSea.txt 

TransferSystemTrainSea.txt 

TransferWagonloadRailFerry.txt 

TransferWagonloadSea.txt 

Same files as NODES folder except Nodes.txt. Here the technological factors are 

all rescaled to 1 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y MERGEREP  Mergerep.exe program, related mergerep.ctl file and MERGEREPALL.BAT (for 

standard) and MERGEREPFIN.BAT (for final process) 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y LOG  Folder with all .log files from Standard Logistics Module and Rail Capacity 

Management module (by commodity group XX): 

• logXXFIN.log 

• logXXSTD.log 

• logXXCBA.log 

• logXX_4RCM.log 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

• EXTRACT_FIN.LOG 

• EXTRACT_STD.LOG 

• MERGEREP.LOG 

• mergerepSTD.log 

And chk files, when each program is successful, this produces chk file by 

commodity group XX 

• BuildChainXX_4RCM.chk 

• ChainChoiXX.chk 

• ChainChoXX_4RCM.chk 

• ChainChoiXXCBA.chk 

• extract0FIN.chk 

• extract0STD.chk 

• mergerepSTD.chk 

• mergerepFIN.chk 

• mergerepCBA.chk 

• SD_ok.chk 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y MERGEREP OUTPUT ChainChoiSTD.rep 

ChainChoiXTD.rep 

ChainChoiCBA.rep 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y RCM  Folder with MPS.jar, CLP64.exe  and SOplex.exe programs together: 

control files for different steps: 

• Compact.ctl – compact spanning tree data 

• LOS_CBA.CTL 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

• mps_LP.ctl - control file for LP0, LP1, etc 

• UTI_CBA.ctl – control file for CBA analysis 

• COMMODITY.CTL - reports for maps by commodity group 

Input data: 

• Spanning tree data for all modes (PathTreeRail.txt, PathTreeSea.txt, 

PathTreeRoad.txt and PathTreeAir.txt) 

• Compacted spanning tree data for all modes (PathTreeRail.cmp, 

PathTreeSea.cmp, PathTreeRoad.cmp and PathTreeAir.cmp) 

• Links_List.txt and Nodes_List.txt 

• RailLinkCapacitiesBidirectional_STD.dat and 

RailLinkCapacitiesBidirectional_STD.new 

• Exported_network_BS19.txt (used in Cost Benefit analysis – network 

with time and cost per link) 

• Exported_network_BS19_Original.txt 

Intermediate files: 

• mps_ok_COPY_0JCM_1.chk 

• mps_ok_COPY_0W_1.chk 

• mps_ok_COPY_1CM_1.chk 

• mps_ok_COPY_1W_1.chk 

• mps_ok_COPY_1_2.chk 

• JLISTA.dat 

• LinkFlows_Itr0.dat 

• LinkFlows_Itr1.dat 

• LowFlows_LP0.dat 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

• LowFlows_LP1.dat 

• LP_Rail_defs.dat 

• MPS_ColumnInfo.dat 

• MPS_ColumnSelectInfo.dat 

• LP_Rail_LP0.MPS 

• LP_Rail_LP1.MPS 

• LP_RAIL_LP0.out 

• LP_RAIL_LP1.out 

• JLISTA.sln 

• ErrorSL.txt 

• ErrorSTN.txt 

• LockedSTDLogMod_Soln_CapImpact_0.txt 

• LockedSTDLogMod_Soln_CapImpact_1.txt 

log files 

• IOLog_LP0.log 

• IOLog_LP1.log 

• IO_LOG.log 

• LOS_STN.log 

• LP0-A.log 

• LP1-A.log 

• LP_iter.log 

• RunTime_mps_LP.log 

For explanation of relationship between steps, programs and files in RCM see 
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Catalog Folder First Level Second Level Third Level Fourth Level Description 

section 6.7. 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y RCM ColumnMerge Intermediate files for each commodity group XX : 

• ColGen2LPXX.dat 

• LP_RailXX.dat 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y RCM ColumnData Intermediate files for ach commodity group XX: 

• ColGen2LPXX-1.dat 

• ColGen2LPXX-2.dat 

• LP_RailXX-1.dat 

• LP_RailXX-2.dat 

{CATALOG_DIR}  {Scenario_Folder} LogMod_Y RCM Output EmptyCost.data – costs for empty vehicles 

Commodity.dat – converted into COMMODITYFlows table present in GDB 

CBA_aggr.txt – total costs aggregated by mode and 

international/domestic/import/export components 

chk.txt 

Debug.log 

DEIT_Empties.dat 

DEIT_L+E.dat 

DEIT_L+E_Ferry.dat 

EmptyCostRCM.dat 

EmptyCost_SplitCheck.dat 

LOS.dat 

RAIL_TONKM_VKM_SUM.DAT 

VhcRepRCM.Dat 
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While all the outputs above are described under specific documentation for logistic module and Rail Capacity 

Management, Exported_Network_XX.txt is produced through Cube and its format is as follow: 

Table 136 - Exported_network_xx.txt 

Field Description Data Format Example 

A A node Integer 1 

B B node Integer 2049 

LinkType Link type Integer 110 

Length Length in km Double 0.26 

T101 Time in hours (calculation from UL2/SPEED_1) Double 0.31 

T102 Time in hours (calculation from UL2/SPEED_2) Double 0.31 

T103 Time in hours (calculation from UL2/SPEED_2) Double 0.31 

T104 Time in hours (calculation from UL2/SPEED_2) Double 0.31 

T105 Time in hours (calculation from UL2/SPEED_2) Double 0.31 

T106 Time in hours (calculation from UL2/SPEED_2) Double -1 

T201 Time in hours (calculation from UL2/SPEED_2) Double -1 

T202 Time in hours (calculation from UL2/SPEED_2) Double -1 

T203 Time in hours (calculation from UL2/SPEED_2) Double -1 

T204 Time in hours (calculation from UL2/SPEED_2) Double -1 

T205 Time in hours (calculation from UL2/SPEED_2) Double -1 

T206 Time in hours (calculation from UL2/SPEED_2) Double -1 

T207 Time in hours (calculation from UL2/SPEED_2) Double -1 

T208 Time in hours (calculation from UL2/SPEED_2) Double -1 

T209 Time in hours (calculation from UL2/SPEED_2) Double -1 

T210 Time in hours (calculation from UL2/SPEED_2) Double -1 

T211 Time in hours (calculation from UL2/SPEED_2) Double -1 

T212 Time in hours (calculation from UL2/SPEED_2) Double -1 

T301 
Speed has two options: 

if CATEGORY is 80, 85, 89 & 540 speed comes from SPEED_1 present in the 

network  

For all the others from vehicle parameters table based on vehicle number 

  

  

  

  

Double -1 

T302 Double -1 

T303 Double -1 

T304 Double -1 

T305 Double -1 

T306 Double -1 

T307 Double -1 

T308 Double -1 
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Field Description Data Format Example 

T309   

  

  

  

  

  

  

  

  

  

  

  

  

  

  

Double -1 

T310 Double -1 

T311 Double -1 

T312 Double -1 

T313 Double -1 

T314 Double -1 

T315 Double -1 

T316 Double -1 

T317 Double -1 

T318 Double -1 

T319 Double -1 

T320 Double -1 

T321 Double -1 

T322 Double -1 

T401 Time in hours (calculation from UL2/SPEED_1) Double -1 

C101 C101=KM_TAX101*UL2 + TOLL101 Double 0 

C102 C102=KM_TAX102*UL2 + TOLL102 Double 0 

C103 C103=KM_TAX103*UL2 + TOLL103 Double 0 

C104 C104=KM_TAX104*UL2 + TOLL104 Double 0 

C105 C105=KM_TAX105*UL2 + TOLL105 Double 0 

C106 C106=KM_TAX106*UL2 + TOLL106 Double 0 

C201 C201=KM_TAX201*UL2 + TOLL201 Double 5.55 

C202 C202=KM_TAX202*UL2 + TOLL202 Double 4.62 

C203 C203=KM_TAX202*UL2 + TOLL202 Double 4.62 

C204 C204=KM_TAX204*UL2 + TOLL204 Double 8.21 

C205 C205=KM_TAX205*UL2 + TOLL205 Double 9.27 

C206 C206=KM_TAX206*UL2 + TOLL206 Double 46.61 

C207 C207=KM_TAX207*UL2 + TOLL207 Double 6.36 

C208 C208=KM_TAX208*UL2 + TOLL208 Double 7.4 

C209 C209=KM_TAX209*UL2 + TOLL209 Double 7.82 

C210 C210=KM_TAX210*UL2 + TOLL210 Double 6.44 

C211 C211=KM_TAX211*UL2 + TOLL211 Double 7.4 
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Field Description Data Format Example 

C212 C212=KM_TAX212*UL2 + TOLL212 Double 9.6 

C301 C301=KM_TAX301*UL2 + TOLL301 Double 0 

C302 C302=KM_TAX302*UL2 + TOLL302 Double 0 

C303 C303=KM_TAX303*UL2 + TOLL303 Double 0 

C304 C304=KM_TAX304*UL2 + TOLL304 Double 0 

C305 C305=KM_TAX305*UL2 + TOLL305 Double 0 

C306 C306=KM_TAX306*UL2 + TOLL306 Double 0 

C307 C307=KM_TAX307*UL2 + TOLL307 Double 0 

C308 C308=KM_TAX308*UL2 + TOLL308 Double 0 

C309 C309=KM_TAX309*UL2 + TOLL309 Double 0 

C310 C310=KM_TAX310*UL2 + TOLL310 Double 0 

C311 C311=KM_TAX311*UL2 + TOLL311 Double 0 

C312 C312=KM_TAX312*UL2 + TOLL312 Double 0 

C313 C313=KM_TAX313*UL2 + TOLL313 Double 0 

C314 C314=KM_TAX314*UL2 + TOLL314 Double 0 

C315 C315=KM_TAX315*UL2 + TOLL315 Double 0 

C316 C316=KM_TAX316*UL2 + TOLL316 Double 0 

C317 C317=KM_TAX317*UL2 + TOLL317 Double 0 

C318 C318=KM_TAX318*UL2 + TOLL318 Double 0 

C319 C319=KM_TAX319*UL2 + TOLL319 Double 0 

C320 C320=KM_TAX320*UL2 + TOLL320 Double 0 

C321 C321=KM_TAX321*UL2 + TOLL321 Double 0 

C322 C322=KM_TAX322*UL2 + TOLL322 Double 0 

C401 C401=KM_TAX401*UL2 + TOLL401 Double 0 

ID_COUNTRY Flag of nationality Integer 1 

3.4.8. Other files with different purposes 

Under scenario folder a set of files is present with different purposes: 

• calibration procedure files 

• exported information in dbf, Emme, csv format from geodatabase (to exchange the data with users 

without Cube Interface) 

• general results from Standard Logistics Module and Rail Capacity Management Module 

• warm start procedure 

• debugging 

• select link analysis 
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• visualization in GIS environment 

• results using general statistics in excel and comparison across different scenarios 

3.4.8.1. Calibration procedure files 

The Calibration procedure invokes a cycling process where scaling factors for Port Areas and commodity 

groups together the Kiel canal scaling factor are altered along the run. The process produces some txt files 

that keep the scaling factor information in each loop. 

The scaling factors for port areas and commodity groups are saved in the following files: 

• CalParameter_Loop_1.txt - parameters in the first loop - this file is a copy of the file specified in " 

Initial values for port calibration by Port Area and commodity group:", in the current model " 

PortAreaParams_16_Comm.txt" under 05_Inputs\Calibration 

• CalParameter_Loop_2.txt - parameters estimated after completion of loop 1 

• CalParameterNextLoop.txt - parameters used in next loop - identical to 

CalParameter_Loop_"lastloop".txt, in the example lastloop=2 

The scaling factor for Kiel Canal has a different treatment since is only one value: 

• The initial value is provided by the interface with catalog key " Starting value for scaling factor on 

Kiel canal" is copied in ParKiel_{Scenario_code}.txt file; 

• KielNextValue.txt holds the scaling factor along all the iterations. Its structure is LoopNbr Scaling 

factor. The value used is obtained looking up LoopNbr. 

The following files contain statistics on the calibration procedure: 

• Differences_{Scenario_code}.csv - differences in tons between modelled and statistics per port area 

and commodity group 

• PortArea_report_{Scenario_code}_loop1.csv - same information present in 

Report_13_Tons_per_PortArea_and_Commodity_Group, 

• PortArea_report_RCM_{Scenario_code}_Loop1.csv - same information present in 

Report_13_Tons_per_PortArea_and_Commodity_Group (RCM) 

• RMSE_loops.txt – same content of Report_14_Oresund Bridge_Kiel Canal and Jylland for STD and 

RCM in each loop 

3.4.8.2. Exported files 

The following files represent information saved in main geodatabase and exported to allow access to 

information for modellers or users without a valid Cube Licence. 

• Capacity_table_{Scenario_Code}.dbf - scenario specific table with ID_LINK and CAPACITY for all 

rail links. This is the export of Rail_Capacity_{SCENARIO_SHORTNAME} (merged table between 

Rail_Capacity_Base2019 and SC_Rail_Capacity_{SCENARIO_SHORTNAME}). See 3.2.3.8 for 

table structure. 

• Rail_capacities_STD_{Scenario_Code}.DBF - scenario specific table with initial values from Adjust 

Procedure. Rail_Capacity_{SCENARIO_SHORTNAME} (merged table between 

Rail_Capacity_Base2019 and SC_Rail_Capacity_{SCENARIO_SHORTNAME}). See 3.2.3.8 for 

table structure. 

• EMME_NET_Base2019.211 and V101_102_LINK_SPEEDS.DAT: Scenario network exported in 

EMME format (211) together the speed definitions per each link in DAT format. The speed table has 

the following headers " Inode Jnode v101 v102" where: 

o Inode=Initial emme node number 
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o Jnode=final emme node number 

o V101 = speed in km/h for vehicle type 101 

o V102 = speed in km/h for vehicle types 102-106 

• General_Table_{SCENARIO_SHORTNAME}.DBF is the exported table 

General_{SCENARIO_SHORTNAME} containing all the main parameters of the model. It is used in 

the Samgods application when is required to read a general variable. 

• RENUM_NODES.DBF has the same information of RENUM_NODES table. This file could be link in 

the Matrix Window showing the emme zone number instead of the voyager node numbers. For 

details refer to Matrix Window > Using zone labels on the Cube Help. 

3.4.8.3. Reports from STD Logistics Module , Rail Capacity Management Module and Cost Benefit 

Analysis – ASEK values runs 

Three report files are produced using MERGE.exe program: 

• ChainChoi0_Base2019.rep 

• ChainChoi0_Base2019FIN.rep 

• chainchoiCBA0_Base2019.rep 

For their description refer to Logistic Module technical documentation. 

Each report contains statistics at vehicle type level, chain level and commodity level. These files are saved as 

reports (Report_2_Logistics Module, Report_2_LM_CHAINS, Report_2_LM_DEMAND) and tables 

(VHCL_OD_COV, CHAIN_OD_COV, COM_L_D) in the model. 

3.4.8.4. Warm start procedure 

The cycling process for LP could be restart after a previous run from a different point. For instance if in a 

previous run only LP0 has been performed, it is possible to run Rail Capacity Management module adding 

LP1. To recode the history of previous run, the type of stages performed is recoded in Log_file.log. 

The system maintains this file and the user must never change its content.  

Each step (Standard Logistic Module, LP0, LP1 and so forth) produces a line with a different code. These 

codes are used to manage the right execution order. 

The codes associated to each step are listed in Table 137. 

Table 137 - Codes under log_file_x.log. 

LP LPAdjust Description Date Time 

99 99 STD  16-Feb-15 1:06 AM 

-1 0 LP0  16-Feb-15 1:57 AM 

99 99 FIN  16-Feb-15 6:52 AM 

1 0 LP1  17-Feb-15 8:52 AM 

The file logfile_scenario.dat contains the last values printed out from the model, it is a temporary file. 

Information is later on saved in log_file_x.log where x is the loop number. Per each loop a different log file is 

produced and maintained. 

3.4.8.5. Debugging 

Some intermediate outputs are saved in scenario folder to allow checks on some complex calculations. 

The calculation carried out in application Samgods\LOS Calculation\Data preparation leads to a network 

containing all the tolls and taxes defined with the different input tables (TAX_by_link, 

mk:@MSITStore:C:/Program%20Files%20(x86)/Citilabs/Cube/CubeBase.chm::/MatrixWindow.12.1.html#1075717
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TAX_by_CATEGORY, TAX_by_COUNTRY, TOLL_BY_LINK and user extra attributes EC_V and 

EC_KM_V) together the different rules to open or close a particular link to a particular vehicle type. The 

intermediate output with all the information required for the next steps (LOS calculation, assignment in 

Standard Logistics Module and Rail Capacity Management Module) is saved under scenario folder with name 

FINAL_NETWORK_{Scenario_Code}.NET. This file can be accessed from Data Panel under Scenario 

Outputs\Other\ Network with costs for checking. 

The .NET file is a binary format used in Cube Interface, therefore only Cube can open and visualize the 

network in the Network Window (Graphics). A part this, the structure is identical to a Geodatabase network. 

In the network are present the node, Table 138, and link, Table 139, tables. 

Table 138 - Format of “FINAL_NETWORK_{Scenario_Code}.NET.node” table. 

Field Description Data Format Example 

N Node number Integer 1 

NORIG Original node number based on the combination of ID_Country, 

ID_region and MODE_N values 

Integer 711400 

SCBSTANN SCBSTANN code Integer 114 

ID_REGION Region code Integer 114 

MODE_N Mode code Integer 0 

UI4 User field (not used in the current model) Double 0 

CENTRALL Node description in terms of location String Upplands-Väsby 

X Coordinate x  (SWEREF99_TM) Double 1620000 

Y Coordinate y  (SWEREF99_TM) Double 6601000 

Table 139 - Format of “FINAL_NETWORK_{Scenario_Code}.NET.Link” table. 

Field Description Data Format Example 

AX/BX Minimum X coordinate Double 10648 

AY/BY Minimum Y coordinate Double 257 

A Start node Integer 2231 

B End node Integer 2353 

OBJECTID ID object Integer 625 

ID_LINK Link identified for rail link. Two links in opposite direction share the 

same ID_LINK.  

Integer 25 

ORIGINALCAP Original value for capacity in bidirectional trains per day Double 23 

M_101 Flag 0/1 If 1 open to 101 Integer 0 

M_102 Flag 0/1 If 1 open to 102 Integer 0 

M_103 Flag 0/1 If 1 open to 103 Integer 0 

M_104 Flag 0/1 If 1 open to 104 Integer 0 

M_106 Flag 0/1 If 1 open to 106 Integer 0 

M_201 Flag 0/1 If 1 open to 201 Integer 1 
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Field Description Data Format Example 

M_202 Flag 0/1 If 1 open to 202 Integer 3 

M_204 Flag 0/1 If 1 open to 204 Integer 1 

M_205 …… Integer 1 

M_401 Flag 0/1 If 1 open to 401 Integer 0 

MODESTR String with all the allowed modes String xdwhi 

SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 70 

SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0 

CATEGORY Link category Integer 70 

FUNCTION Index for vdf function Double 66 

NLANES Number of lanes (may be a decimal number) Double 1 

UL2 Distance in kms. User link data in emme used to enable holding link 

lengths longer than 999 kms. 

Double 1.36 

UL3 Capacity for vessels on sea (dwell tons) Double 0 

ID_COUNTRY Country code Integer 1 

EC_V101 Extra cost on link (defined via EC_V attribute in the network) for v101 Double -99999 

EC_KM_V101 
Extra costkm on link (defined via EC_KM_V attribute in the network) 

for v101 
Double -99999 

EC_V102 Extra cost on link (defined via EC_V attribute in the network) for v102 Double -99999 

EC_KM_V102 
Extra costkm on link (defined via EC_KM_V attribute in the network) 

for v102 
Double -99999 

EC_V103 ….. Double -99999 

EC_KM_V103 …… Double -99999 

AORIG Emme initial node number Integer 4246 

BORIG Emme final node number Integer 9088 

KM_TAX101 Sum of TAX_C, EC_KM_V for V101 Double 0 

TOLL101 Sum of TAX_LT, TAX_L, EC_V,TOLL_L for V101 Double 0 

KM_TAX102 Sum of TAX_C, EC_KM_V for V102 Double 0 

TOLL102 Sum of TAX_LT, TAX_L, EC_V,TOLL_L for V102 Double 0 

KM_TAX103 ….. Double 0 

TOLL103 ….. Double 0 

KM_TAX401 Sum of TAX_C, EC_KM_V for V401 Double 0 

TOLL401 Sum of TAX_LT, TAX_L, EC_V,TOLL_L for V401 Double 0 

MODE_L Mode Integer 2 

The variables listed above has the following meaning: 

• TAX_C: country tax based on Tax_Country_{SCENARIO_SHORTNAME} table - SEK/km 
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• TAX_LT: tax by category on Tax_Category_{SCENARIO_SHORTNAME} table - SEK 

• TAX_L: tax by link on Tax_Link_{SCENARIO_SHORTNAME} table - SEK 

• TOLL_L: toll on link from Toll_Link_{SCENARIO_SHORTNAME} table - SEK 

• EC_V: extra cost applied using EC_V attribute in the network (see user manual for details) - SEK 

• EC_KM_V: extra cost km applied using EC_KM_V attribute in the network (see user manual for details) - SEK 

Those taxes and tolls are recombined into two attributes: 

• KM_TAX: includes TAX_C and EC_KM_V, in other words values based on distance 

• TOLL: includes TAX_LT, TAX_L , TOLL_L and EC_V, therefore values based on a link 

The final results of KM_TAX and TOLL are not merely the sum of the individual values since TAX_C, 

TAX_LT and TAX_L mutually exclude each other. We have the following cases: 

• if TAX_L is specified, TAX_C and TAX_LT will be not applied 

• if TAX_L is not specified and TAX_LT has a value, only TAX_LT will be applied 

• if TAX_L and TAX_LT are not specified, only TAX_C will be applied. 

Also values equal to zero have a meaning, since a zero-valued tax could be specified by TAX_L=0, and that 

will give a tax level at 0. To treat this case all the values are initialized to -99999, before applying any specific 

values from tables in geodatabase. 

Furthermore, the following tables are saved: 

• Tax_by_Link_{Scenario_code}.DBF: taxes for each link in specific scenario (see structure from 3.2.3.11) 

• Tax_Category_{Scenario_code}.DBF: Taxes by category type (see structure from 3.2.3.9) 

• Tax_Country_{Scenario_code}.DBF: Taxes by country (see structure from 3.2.3.10) 

• Toll_by_link_{Scenario_code}.DBF: tolls by link (see structure from 3.2.3.12) 

• Vh_par_tot.DBF: union of part A and Part B vehicle parameters tables by vehicle type and commodity group 

• Check_overcapacity_{Scenario_code}.DBF: number of links overcapacity before applying RCM procedure.  

3.4.8.6. Select link analysis 

The Select Link application has two different modalities: 

• The former allows to skim the loaded vehicles and tons for specific chains going through a list of nodes or links and per 

commodity. 

• The latter is a fixed tool to produce the road matrices (in terms of loaded, unloaded and ton matrices for road mode). 

The standard output for the two cases is therefore different. All the outputs for option A (select link) are 

linked in the GUI. No outputs for Option B are accessible from the interface but reside under the SelectLink 

folder selected in setting up the scenario. 

Option A: Select Link 

Under SelectLink\{SelectLink_name} the following files listed in Table 140 will be present. 

Table 140 - List of outputs under SelectLink folder for SelectLink output Suffix STD refers to 

Standard Logistics Results, SL to RCM. 

File name Type Description 

SelectDirect.ctl Control file control file for program 
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File name Type Description 

SelectDirectSTD.ctl 
 

ErrorSL.txt 

Output 

LOG error 

ErrorSLSTD.txt LOG error 

RCM.NET Output network with selected volumes by vehicle type 

STD.NET Output network with selected volumes by vehicle type 

RCM_COMMODITY.NET Output network with selected volumes by commodity group 

STD_COMMODITY.NET Output network with selected volumes by commodity group 

AIR_TON_FIN_MainSc2045.MAT 

Matrices in Binary format 

AIR_TON_MainSc2045.MAT 

AIR_VHCLFLOW_FIN_MainSc2045.MAT 

AIR_VHCLFLOW_MainSc2045.MAT 

RAIL_TON_FIN_MainSc2045.MAT 

RAIL_TON_MainSc2045.MAT 

RAIL_VHCLFLOW_FIN_MainSc2045.MAT 

RAIL_VHCLFLOW_MainSc2045.MAT 

ROAD_TON_FIN_MainSc2045.MAT 

ROAD_TON_MainSc2045.MAT 

ROAD_VHCLFLOW_FIN_MainSc2045.MAT 

ROAD_VHCLFLOW_MainSc2045.MAT 

SEA_TON_FIN_MainSc2045.MAT 

SEA_TON_MainSc2045.MAT 

SEA_VHCLFLOW_FIN_MainSc2045.MAT 

SEA_VHCLFLOW_MainSc2045.MAT 

ChainsSL.dat Selected chain list in RCM 

ChainsSLSTD.dat Selected chain list in STD 

ConCumSL.dat Matrix in dat format 

ConCumSLSTD.dat Matrix in dat format 

ConnectionsSL.dat 
 

ConnectionsSLSTD.dat 
 

LinksSumSL.dat Link list with loaded vehicles and tons 

LinksSumSLSTD.dat Link list with loaded vehicles and tons 
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Option B: Traversal Matrices 

Table 141 - List of outputs under SelectLink folder for a Traversal Matrices output. 

File name Output name Format 

SelectLink\SLTravmat ErrorSL.txt String file  

ErrorSLSTD.txt String file 

SelectDirect.ctl Control file 

SelectDirectSTD.ctl Control file 

SelectLink\SLTravmat\FIN 

 

v101_emp.314 314 Emme matrix file 

v101_ton.314 314 Emme matrix file 

v101_vhcl.314 314 Emme matrix file 

v102_emp.314 314 Emme matrix file 

v102_ton.314 314 Emme matrix file 

v102_vhcl.314 314 Emme matrix file 

v103_emp.314 314 Emme matrix file 

v103_ton.314 314 Emme matrix file 

v103_vhcl.314 314 Emme matrix file 

v104_emp.314 314 Emme matrix file 

v104_ton.314 314 Emme matrix file 

v104_vhcl.314 314 Emme matrix file 

v105_emp.314 314 Emme matrix file 

v105_ton.314 314 Emme matrix file 

v105_vhcl.314 314 Emme matrix file 

SelectLink\SLTravmat\STD 

 

v101_emp.314 314 Emme matrix file 

v101_ton.314 314 Emme matrix file 

v101_vhcl.314 314 Emme matrix file 

v102_emp.314 314 Emme matrix file 

v102_ton.314 314 Emme matrix file 

v102_vhcl.314 314 Emme matrix file 

v103_emp.314 314 Emme matrix file 

v103_ton.314 314 Emme matrix file 

v103_vhcl.314 314 Emme matrix file 

v104_emp.314 314 Emme matrix file 

v104_ton.314 314 Emme matrix file 

v104_vhcl.314 314 Emme matrix file 
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v105_emp.314 314 Emme matrix file 

v105_ton.314 314 Emme matrix file 

v105_vhcl.314 314 Emme matrix file 

   

 

3.4.8.7. GIS maps 

These folders contain compatible output networks for ArcGIS users. The folder can be shared among other 

people without the Cube interface requirements. 

The maps are listed in Table 142 where: 

• The first folder has the absolute tons and vehicles per commodity group and totals saved in a geodatabase feature class under 

the gdb file. 

• The second folder has the differences between the two scenarios for the same quantities.  

For unit and meaning of attributes present in ABS_GIS{SCENARIO_SHORTNAME}, folder refer to Table 

107. 

Table 142 - GIS maps. 

File name Output name Format 

ABS_GIS{SCENARIO

_SHORTNAME} 

GeodatabaseYYYY_COM.gdb where YYYY is the base year 2019 or 

the prognosis year 2045 
Personal geodatabase ArcGIS format  

GeodatabaseYYYY_COM.vpr (present after mxd is opened) where 

YYYY is the base year 2019 or the prognosis year 2045 
Cube visual project file 

Output_COM_STD_GIS_TON.mxd 
ArcGIS map document for tons (by commodity 

group) Standard Logistic  Model 

Output_COM_STD_GIS_VHCL.mxd 
ArcGIS map document for vehicles (by 

commodity group) Standard Logistic Model 

Output_COM_RCM_GIS_TON.mxd 
ArcGIS map document for tons (by commodity 

group) Rail Capacity Management 

Output_COM_RCM_GIS_VHCL.mxd 
ArcGIS map document for vehicles (by 

commodity group) Rail Capacity Management 

DIFF_GISYYYY_2019 

GeodatabaseDIFFYYYY-2019_STAN.gdb where YYYY is the base year 

2019 or the prognosis year 2045 
Personal geodatabase ArcGIS format  

GeodatabaseDIFFYYYY-2019_STAN.vpr where YYYY is the base year 

2019 or the prognosis year 2045 
Cube visual project file 

Output_BaseYYYY_2019_COM_GIS.mxd where YYYY is the base 

year 2019 or the prognosis year 2045 
ArcGIS map document 

 

3.4.8.8. Outputs_Calibration_Template_rev10.xlsm 

In the past several reports were post produced after full run with quite an important level of effort. Thus, the 

reports were created to ease this procedure and for further easement the output called “Calibration_1.txt” is 

produced for each scenario which contains all the following reports: 

• Report 1 TonKm (*1,000,000) total domestic by mode (international for air) 
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• Report 2 Port areas statistics (ktons) 

• Report 3 ktonkm by commodity group on rail 

• Report 4 Kiel and Oresund bridges (percentage diff on Oresund, Percentage transport on Kiel Canal vs Kiel+Jylland) 

• Report 5 Tonkm Road vehicle type distribution 

• Report 6 Tonkm Rail main vehicle types 

• Report 7 Vhkm Road distribution 

• Report 8 Tons Sea distribution 

The spreadsheet has the following tabs: 

• Inputs 

• Data Import 

• Reports 

• Diagrams_1_scenario 

• Diagrams_all_scenarios 

To import calibration_1.txt go under “Inputs” tab and click on “Import Data” button (providing location of 

scenario you want to import) seen in Figure 3. 

All tables under “Reports” and diagrams under “Diagrams_1_scenario” are automatically updated. 

There is also the option to import other scenarios for comparison from other excel files. In the example under 

“Outputs_Calibration_Test6.xlsm” Test6 has been imported. To import another scenario, it is sufficient to 

click “Get comparison data”. This will automatically update “Reports” and “Diagrams_all_scenarios”. 

The excel file has been built with the following principles: 

1. You must create a file for each scenario; 

2. You can keep track of all previous scenarios, importing incrementally each previous scenario. For 

instance: first scenario in my example is Base2012. This will be populated only with statistics and 

Base2012 values. Second scenario will import first its own values (Test1) and Base2012 values will be 

paste from first excel. Test 2 will be populated with its own values and Test1 and Base 2012 will be 

copied from “Output_Calibration_Test1.xlsm” file. Etc.  

3. It is possible to keep memory up to 22 scenarios.  

No actions are required by final user in updating tables or diagrams. The user must just fill out properly 

fields (entries marked as <-- just change this) present under “Inputs” spreadsheet and click two buttons.  
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Figure 3 - Interface to import results for base year. 
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4 The model structure 

The Samgods model could be described as a set of different software integrated in a standalone interface. The 

technical documentation refers to the GUI interface implemented in Cube software and in this chapter the 

different physical elements constituting the model will be explored. The naming and syntax used is derived 

from the Cube Software. 

The model can be viewed in Cube interface opening the catalog file, always placed under the model folder, 

having extension .cat. The purpose with this file is to coordinate all the various parts of the model in terms of: 

• Applications - files with .app extension 

• Scenario keys - elements saved in .cat file 

• Location of input and output data - based on program steps present in each application 

• Give access to all the input and output data by scenario 

• Define the rules on how to use the model (developer or user class) 

The catalog file (named SamGods.cat) stores all the connections, maps and definition values for each entity 

listed above.  

The catalog keys, listed in the catalog files, have a variety of purposes. They can define: 

• The execution order for the applications 

• Enable or disable the creation of specific outputs 

• Point to an input file or parameter 

The Cube-applications represent the programming parts, using the input data and applying the set of rules 

defined via the scripting language, they produce specific outputs and manage the data (see the description of 

each application for more details).
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The list of catalog keys defined in the model, classified by user rights and application usage are listed in Table 143. 

Table 143 - Catalog keys. 

Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

Install_driver Hard Drive where the model resides 
 

C:\ Developer Installation 

Samgods Model 

Elasticity module 

Cube_software Cube software 6.4.5 Developer Installation 

GIS_software ArcGis Software 10.6.0 Developer Installation 

Python_Software Python software 27 Developer Installation 

LogMod_software Logistics Model Software 1.2.2 Developer Installation 

Installation_DOS Path to cmd.exe C:\windows\sysnative\cmd.exe Developer Installation 

Samgods Model 

Select Link Analysis 

Elasticity module 

Cost Benefit Analysis - ASEK Values 

Python Location of python program C:\Python27\ArcGIS10.6 Developer Installation 

JavaVersion Location of Java folder C:\Windows\System32 Developer Samgods Model 

Handling scenario 

Compare Scenarios 

Select Link Analysis 

Elasticity module 

Installation 



The model structure 

187 

Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

Base_Scenario Scenario name for the BASE Scenario Base2019 Developer Create the editable files 

Edit the data 

Samgods Model 

Handling scenario 

Compare Scenarios 

Select Link Analysis 

Elasticity module 

Installation 

Scenario_copy Which scenario do you want to copy as new 

scenario? 

Base2019 All Create the editable files 

Waittime Wait time for prompt messages during 

execution (default 10 minutes=600 seconds) 

600 Developer and 

Advanced User 

Create the editable files 

read_write Do you want to lock the scenario permanently 

from further editing? 

Yes All Edit the data 

Calibration _scenario Calibration parameters for reference scenario 

(Base2019 for year 2019 and MainSc2045 for 

year 2045) 

Base2019 All Edit the data 

Samgods Model 

Elasticity module 

Edit_soft Select from which source you want to import 

your edits 

GIS Window (Use input files constructed by the Cube 

GUI) 

All Edit the data 

EMME_data Emme network file C:\Models\SamGods_V12\05_Input_Data\2019_2045

\rev150424\Base2045_corr\Samgods_Base_2045(rev1

50424).211 

All Edit the data 

EMME_speed Emme speed table C:\Models\SamGods_V12\05_Input_Data\2019_2045 All Edit the data 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

\rev150424\new_road_2030_Samgods_1_0_V101_10

2_link_speeds.DAT 

Up_parameters General parameters [Table] {CATALOG_DIR}\Scenario_Data.mdb\General_Base2

019 

Developer Edit the data 

GCOST Attribute name for the extracost on specific 

link (SEK) 

EC_V All Edit the data 

GCOST_D Attribute name for the extracost on specific 

link (SEK/km) 

EC_KM_V All Handling scenario 

Edit the data 

DF Number of operating days per year for all 

modes (except for Rail Mode) (days/year) 

250 Developer and 

Advanced User 

Handling scenario 

Edit the data 

DFR Number of operating days per year for Rail 

Mode (days/year) 

250 Developer and 

Advanced User 

Handling scenario 

Edit the data 

Zones Number of zones/terminals in network (see 

value in scenario network) 

1382 All Create the editable files 

Edit the data 

Samgods Model 

Handling scenario 

Compare Scenarios 

Select Link Analysis 

Elasticity module 

LogParam General parameters for Logistic Module 

[Table] 

{CATALOG_DIR}\Scenario_Tree\Base2019\Scenario_

Data.mdb\LogMod_Base2019 

Developer Handling scenario 

Edit the data 

INTER_RATE Interest rate used in cost calculations 0.1 All Handling scenario 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

(%/year) Edit the data 

STUFF Stuffing cost (SEK/tonne) 60 (18 for ASEK) All Handling scenario 

Edit the data 

LSTCNT Number of transport chain solutions for the 

Logistics Module 

5 All Handling scenario 

Edit the data 

DATA Output variables for the optimal transport 

solution [e.g.1,2,3, max is 8] 

6,7 All Handling scenario 

Edit the data 

FACTOR Initial consolidation factor in BuildChain 

(First iteration - from 0 to 1) 

0.75 All Handling scenario 

Edit the data 

CONTYPE Allow consolidation for all lorry types Yes All Handling scenario 

Edit the data 

INODLO Evaluate transport chains one leg at a time Yes All Handling scenario 

Edit the data 

MATD4FO Lower bound for frequency optimisation 

(Annual Tonnes/Shipment) 

100 All Handling scenario 

Edit the data 

CONSOL_L Lower bound for consolidation factor 

(applied to all commodities - from 0 to 1) 

0.05 All Handling scenario 

Edit the data 

CONSOL_U Upper bound for consolidation factor 

(applied to all commodities from 0 to 1) 

0.95 All Handling scenario 

Edit the data 

TONNES Calculation for demand affecting shipment 

size 

DYNAMIC_AVERAGE All Handling scenario 

Edit the data 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

LOGCTL Do you want to log parameters from control 

files?  

Yes All Handling scenario 

Edit the data 

LOGFLS Do you want to log reading of input data? Yes All Handling scenario 

Edit the data 

LOGCST Do you want to log cost values from vehicle 

files? 

Yes All Handling scenario 

Edit the data 

BESTOUT For which logistic solutions do you want to 

produce output data? (0=none, 1=Best 

solution, 2=Best + Second) 

1 All Handling scenario 

Edit the data 

Del_tmp Do you want to delete the temporary 

geodatabase? (Tick=yes) 

Tick All Handling scenario 

Edit the data 

Mxd_file ArcMap GIS Project File  {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Input_Data.mxd 

All Edit the data 

Up_cargo Commodity data [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Cargo_{SCENARIO_SH

ORTNAME} 

All Edit the data 

Up_Vehicles_par General parameters of  Vehicle types [Table] {CATALOG_DIR}\Scenario_Tree\Base2019\Scenario_

Data.mdb\Vehicles_Parameters_Base2019_PartA 

All Edit the data 

Up_Vehicles_par_B Specific parameters of  Vehicle types by 

commodity group [Table] 

{CATALOG_DIR}\Scenario_Tree\Base2019\Scenario_

Data.mdb\Vehicles_Parameters_Base2019_PartB 

All Edit the data 

Up_Tax_C Table with tax by country (SEK/km) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Tax_Country_{SCENA

RIO_SHORTNAME} 

All Edit the data 

Up_Tax_L Tax by Category (SEK) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR All Edit the data 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

TNAME}\Scenario_Data.mdb\Tax_Category_{SCENA

RIO_SHORTNAME} 

Up_tax_link Tax by Link (SEK) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Tax_Link_{SCENARIO

_SHORTNAME} 

All Edit the data 

Up_toll Toll for bridges (SEK) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Toll_Link_{SCENARIO

_SHORTNAME} 

All Edit the data 

Up_net Network specific of scenario [Geodata] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Network 

All Edit the data 

Up_node_terminals Port terminals pilot fees values  

(SEK/vehicle) [Geodata] 

{CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Ports_Swe 

All Edit the data 

Up_nodes Zones and terminals attributes  [Geodata] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Nodes 

All Edit the data 

Up_no_comm Nodes commodities (interchanges allow) 

[Geodata] 

{CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Nodes_commodities 

All Edit the data 

Up_freq Frequency data (# transport/ week)[Geodata] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Frequency_network 

All Edit the data 

Up_Rail_Capacity Table with Rail Capacity [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Scenario_Data.mdb\Rail_Capacity_{SCENA

RIO_SHORTNAME} 

All Edit the data 

Step_by_step Run only one step, or run all steps All steps All Samgods Model 

Year Choose PWC matrices 2019 All Elasticity Module 

Samgods Model 

Select_cal_cos_mode Select the mode for the LOS Calculation and All  All PWC_Matrices 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

the Assignment steps Select Link Analysis 

Elasticity Module 

Samgods Model 

Select_commodity Select commodities for the Logistics Module 

(for all commodities, select 0) 

0 All Elasticity Module 

Samgods Model 

log_out Do you want to produce buildchainxx.log 

files? 

None All Compare Scenarios 

Handling scenario 

Change matrix format 

Cost Benefit Analysis - ASEK Values 

Elasticity Module 

Samgods Model 

CSTVARI Stochastic approach: parameter for logit 

distribution (0=no stochastic approach used 

or actual value i.e. 0.1) by commodity and f2f 

type 

C:\Models\Samgods_V12D_20200501\05_Input_Dat

a\Input_Data.mdb\CSTVARI 

Developer Samgods model 

Cost Benefit Analysis - ASEK Values 

Elasticity Module 

N_flows Total number of commodities (excluding 

empty commodities) 

16 Developer Samgods model 

Cost Benefit Analysis - ASEK Values 

Elasticity Module 

PWC_Matrices 

CON_RATE_SELECTION Do you want to use exogenous consolidation 

rates? 

No All Samgods Model 

Elasticity Module 

FOLDER_CR If yes in previous catalog key, provide location of {CATALOG_DIR}\Scenario_Tree\Year_2019\Base2019\LogM All Samgods Model 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

consolidation rates folder od_1\ChainChoi\output\ Elasticity Module 

Cluster_p Do you want to run the Logistics Module on 

several processors? 

Yes All Samgods Model 

Elasticity Module 

Cluster_nodes How many processors would you like to run 

simultaneously? 

4 All Cost Benefit Analysis - ASEK Values 

Samgods Model 

Elasticity Module 

Cluster_nodes_LP2CC How many processors would you like to run 

simultaneously for LP2CC? 

4 All Cost Benefit Analysis - ASEK Values 

Samgods Model 

Elasticity Module 

scal_factor Scaling factor for outputs Thousands All Cost Benefit Analysis - ASEK Values 

Samgods Model 

Elasticity Module 

RescLOS Do you want to produce rescaled LOS and MC 

matrices per commodity group? 

No All Cost Benefit Analysis - ASEK Values 

Samgods model 

Elasticity Module 

UTIL_PERCENT Cut off criteria for RCM process (will consider 

links with Number of vehicles over Capacity > 

XX% where XX is the value defined) 

30 D/A-user Samgods model 

Elasticity Module 

maxiters_EA Maximum number of iterations in Rail 

assignment 

1 D/A-user Samgods model 

Elasticity Module 

SpeedFlowCurve Delay function for Empty assignment 

(Derivate) 

2*10000*(MAX(0,VOLC[LI.ID_LINK]-C)) D/A-user Select Link Analysis 

Samgods model 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

Elasticity Module 

Save_Output_RCM Options to save output files from RCM 

process 

Yes, for all iterations All Select Link Analysis 

Samgods Model 

Elasticity Module 

RCM_Loop Maximum number of loops for Linear 

Programming process (LP) 

1 All Samgods Model 

Elasticity Module 

Lock_file Table with list of locked solutions 2019 D/A-user Samgods Model 

Elasticity Module 

SHIPCUT Shipment size cut-off (tonnes) 1 All Samgods model 

Elasticity Module 

CAPCOST Marginal cost limit in MPS.jar (SEK) 998801 All Samgods model 

Elasticity Module 

EXTRA_CAPCOST Acquisition of extra capacity (SEK) 1000000000 All Samgods model 

Elasticity Module 

Debug_checklist Link number to use in debug mode  

CheckLinkN_itXX.dat Max 10 links (comma 

s, ex. 1,25,182,164) 

342 D/A-user Cost Benefit Analysis - ASEK Values 

Samgods Model 

Elasticity Module 

RAIlMODES List of rail modes in RCM GHhIiTUDdEFf D/A-user Samgods Model 

Elasticity Module 

RAILVHCL List of vehicle types on Rail mode 201,202,203,204,205,206,207,208,209,210,211,212 D/A-user Cost Benefit Analysis - ASEK Values 

Samgods Model 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

Elasticity Module 

Chains List of chains for different numbers of vehicle 

types 

Chain_List_2045 D/A-user Samgods model 

Elasticity Module 

Cost Benefit Analysis - ASEK Values 

OverallLoopMax Maximum number of loops in calibration 

process 

1 Developer Samgods Model 

Select Link Analysis 

Resume_option Restart process from loop 1 Developer Samgods Model 

Elasticity Module 

Cost Benefit Analysis - ASEK Values 

ConsolTable Consolidation factors table {CATALOG_DIR}\05_Input_Data\Input_Data.mdb\B

uildChain_CONSOL 

D/A-user Elasticity Module 

Samgods Model 

Handling scenario 

Cost Benefit Analysis - ASEK Values 

Elasticity Module 

Select_compare What do you want to compare? All All Compare Scenarios 

ScenarioC_name Scenario's name to use in comparison (ex. 

Test17) 

Base2019 All Compare Scenarios  

ScenarioC_dir Scenario folder for comparison (ex. 

{CATALOG_DIR}\Scenario_Tree\Year_2019

\Test17\) 

{CATALOG_DIR}\Scenario_Tree\Base2019\ All Compare Scenarios 

Choice Select how you want to use Handling 

Scenario application 

(3) EXPORT the model in a new folder using the 

current scenario as Base 

All Handling scenario 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

New_folder For choice 3 or 4  provide an absolute path to 

the location of the destination model (ex. 

C:\Samgods_New_version\) 

C:\SamGods_v2\ All Handling scenario 

New_Base For choice 3 or 4  provide the name of the 

base scenario in the destination model 

Base2019 All Handling scenario 

Format Do you want to export in csv, DBF or GDB 

format? 

CSV 
 

All Change matrix format 

GDB_c_u Do you want to create a new geodatabase or 

use an existing one? 

Existing 

 

All Change matrix format 

GDB_folder Define the GDB where the matrix should be 

exported 

{CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHOR

TNAME}\Output0_{SCENARIO_SHORTNAME}.mdb 

COST  

All Change matrix format 

Type_mat What kind of matrix do you want to export? COST All Change matrix format 

Type_mode What is the mode that you want for the 

matrices? 

ROAD All Change matrix format 

Type_VHCL What vehicle type do you want for the LOS 

matrices? 

101 All Change matrix format 

Type_COST Do you want the distance, time, domestic 

distance or extracost LOS matrix? 

Extracost All Change matrix format 

Type_VHCL_1 What type of vehicle type (or total) do you 

want for the VEHICLES and TONNES 

matrices? 

202 All Change matrix format 

ReferenceScenario ASEK costs (Base2019ASEK if Year_2019, 

MainSc2045ASEK if Year_2045) 

Base2019ASEK All Cost Benefit Analysis - ASEK Values 

ScenarioJA_Dir Full scenario folder for comparison (JA- C:\Models\Samgods_V12D_20190531\Scenario_Tree\ All Cost Benefit Analysis - ASEK Values 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

reference scenario - before investment) 

(Base2019 folder if Year_2019, MainSc2045 

folder if Year_2045) 

Year_2019\Base2019\ 

ScenarioJA_Name Scenario's name to use in comparison (JA- 

reference scenario - before investment) 

(Base2019 if Year_2019, MainSc2045 if 

Year_2045) 

Base2019 All Cost Benefit Analysis - ASEK Values 

Include_empties Include the cost of empty transports in the 

calculation of system costs 

No All Cost Benefit Analysis - ASEK Values 

Domestic_W Weighting factor Domestic 1.0 All Cost Benefit Analysis - ASEK Values 

Import_W Weighting factor Import 0.5 All Cost Benefit Analysis - ASEK Values 

Export_W Weighting factor Export 0.5 All Cost Benefit Analysis - ASEK Values 

Transit_W Weighting factor Transit 0.0 All Cost Benefit Analysis - ASEK Values 

FolderSL SelectLink analysis name (max 6 characters) SL1 All Select Link Analysis 

List_type  Numbering system for link list ID_LINK (Example 1,2,201,207) All Select Link Analysis 

A_B List of links 1,15,329 All Select Link Analysis 

VISITLINK Selection criteria for links ANY ; any of given links must be used All Select Link Analysis 

List_type_n Numbering system for node list Voyager  (Example 1,2049,2083,2039) All Select Link Analysis 

N List of nodes 111,011,102 All Select Link Analysis 

VISITNODE Selection criteria for nodes ANY ; any of given nodes must be used All Select Link Analysis 

SL_Comm List of commodities for Select Link Analysis 

(0 for All) 

0 All Select Link Analysis 

Selection_rule Select the method being applied for 

conditions on nodes and links 

node AND link selection (both met) All Select Link Analysis 
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Catalog key name Example of value 
 

User Application 
 

Catalog name Interface name 

TravMat Do you want to produce traversal matrices? 

(Untick=no Tick=yes) 

Yes All Select Link Analysis 

GISMaps Do you want to produce GIS Maps by 

Commodity group? 

Yes All Select Link Analysis 

Scenario_Table Table with scenarios want to run for the 

elasticity calculation 

C:\Models\Samgods_V12D_20190829\05_Input_Dat

a\Input_Data.mdb\Scenarios_List 

All Elasticity Module 

Min_Loop Lowest scenario in sensitivity run 2 All Elasticity Module 

Max_Loop Highest scenario in sensitivity run 10 All Elasticity Module 
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The list of applications and subgroups defined in the model is shown in Table 144. Numbers between 

parentheses represent the execution order within a subgroup. 

Table 144 - Applications and subgroups. 

Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

Installati

on         

{CATALOG_DIR}\02_Applicaions\5_Installation\Inst

allation_st.app 

Create 

the 

editable 

files 

        

{CATALOG_DIR}\02_Applications\1_Editing\Setup.a

pp 

Prepare 

temporary 

data (1)       

{CATALOG_DIR}\02_Applications\1_Editing\EDIT_

PREPAR.app 

Editable 

tables (2)       

{CATALOG_DIR}\02_Applications\1_Editing\EDIT_

TABLES.app 

Editable map 

data (3)       

{CATALOG_DIR}\02_Applications\1_Editing\EDIT_

MAP.app 

Edit the 

data 

        

{CATALOG_DIR}\02_Applications\1_Editing\Edit.ap

p 

Create the 

tables specific 

of scenario (1)       

{CATALOG_DIR}\02_Applications\1_Editing\CREAT

E_TABLES.app 

  

Numbering 

System 

Voyager     

{CATALOG_DIR}\02_Applications\1_Editing\Numbe

ring\NUMBER01.app 

  Emme Edits     

{CATALOG_DIR}\02_Applications\1_Editing\EMME

EDITS.app 

  

Compare 

Nodes and 

Node_termi

nals     

{CATALOG_DIR}\02_Applications\1_Editing\Compar

ison\COMPAR01.app 

  

Compare 

other tables     

{CATALOG_DIR}\02_Applications\1_Editing\EDIT_

OTHERS.app 

  

Rail Capacity 

and Net 

Checks     

{CATALOG_DIR}\02_Applications\1_Editing\Capacit

y\RAILCA01.app 

  

Frequency 

matrices     

{CATALOG_DIR}\02_Applications\1_Editing\Freque

ncy.app 

Consistency 

checks with 

calibration 

tables (2)    

{CATALOG_DIR}\02_Applications\1_Editing\Consist

ency_checks.app 
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

Save changes 

in the main 

gdb (3)       

{CATALOG_DIR}\02_Applications\1_Editing\CREAT

E_SAVE.app 

  

Regions for 

links     

{CATALOG_DIR}\02_Applications\1_Editing\Regions

\REGION01.app 

Samgods 

Model 

        

{CATALOG_DIR}\02_Applications\2_Run\SamGod_

VY.app 

Initialization 

(1)       

{CATALOG_DIR}\02_Applications\2_Run\Ini\INITI

A00.app 

LOS 

calculation 

(4)       

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

COST_VY.app 

  

Data 

Preparation     

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

DATAPREPARATION_VY.app 

    

Tax 

calculation   

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

DATAPREPARATION_VY_01.app 

    

Data for 

RCM   

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

DATARCM.APP 

Samgods 

Model 

  Road     

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

ROAD.app 

  Rail     

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

RAIL.app 

  Sea     

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

SEA.app 

  Air     

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

AIR.app 

  

Conversion 

from VY to 

LogMod     

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

CONVERALL.app 

    

From VY to 

LogMod 

Road   

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

CONCOSTVYE2.app 

    

From VY to 

LogMod Rail   

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

CONRAILVYE2.app 

    

From VY to 

LogMod Sea   

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

CONSEAVYE2.app 

    

From VY to 

LogMod Air   

{CATALOG_DIR}\02_Applications\2_Run\Costs_VY\

CONAIRVYE2.app 

Logistics 
      

{CATALOG_DIR}\02_Applications\2_Run\LogisticM
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

Module (5) odVY\LOGMOD.app 

  Prepare data     

{CATALOG_DIR}\02_Applications\2_Run\LogisticM

odVY\PREPARE.app 

  

Prepare Data 

second part     

{CATALOG_DIR}\02_Applications\2_Run\LogisticM

odVY\PREPARE_01.app 

  

Prepare Data 

third part     

{CATALOG_DIR}\02_Applications\2_Run\LogisticM

odVY\PREPARE_02_rev.app 

  

Run the 

logistic 

model     

{CATALOG_DIR}\02_Applications\2_Run\LogisticM

odVY\RUNTMODEL.app 

  Save Reports     

{CATALOG_DIR}\02_Applications\2_Run\LogisticM

odVY\SAVEREPORTS.app 

Assignment 

(6)       

{CATALOG_DIR}\02_Applications\2_Run\ASS_VY\A

SS_VY.app 

  

Conversion 

from 

LogMod to 

VY     

{CATALOG_DIR}\02_Applications\2_Run\ASS_VY 

\CONVERSION OF EMME MATRICES.app 

  

Road 

Assignment     

{CATALOG_DIR}\02_Applications\2_Run\ASS_VY 

\ASS_ROAD_VY.app 

  

Rail 

Assignment     

{CATALOG_DIR}\02_Applications\2_Run\ASS_VY 

\ASS_RAIL_VY.app 

  

Sea 

Assignment     

{CATALOG_DIR}\02_Applications\2_Run\ASS_VY 

\ASS_SEA_VY.app 

  

Air 

Assignment     

{CATALOG_DIR}\02_Applications\2_Run\ASS_VY 

\ASS_AIR_VY.app 

Results (7)       

{CATALOG_DIR}\02_Applications\2_Run\Results\R

ESULTS.app 

  Results 1.0     

{CATALOG_DIR}\02_Applications\2_Run\Results\R

ESULTS_NEW.app 

Samgods 

    Port Areas   

{CATALOG_DIR}\02_Applications\2_Run\Results\P

ORTAR01.app 

  

GIS maps by 

Commodity 

groups 
 

{CATALOG_DIR}\02_Applications\2_Run\Results\ 

Bidire02.app 

    

Oresund Kiel 

and Jylland   

{CATALOG_DIR}\02_Applications\2_Run\Results\O

RESUN01.app 

    
Reports per 

geographical 
  

{CATALOG_DIR}\02_Applications\2_Run\Results\R

EPORT01.app 
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

aggregation 

Rail Capacity 

Management 

(8)       

{CATALOG_DIR}\02_Applications\9_RCM1\RAILCA

01.app 

  

Data 

Preparation 

LP     

{CATALOG_DIR}\02_Applications\9_RCM1\Datapre

p_LP\DATAPR01.app 

  Warm start     

{CATALOG_DIR}\02_Applications\9_RCM1\WARMS

T01.app 

  LP Loop     

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LPL

OOP01.app 

    LP0 step   

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP0\

LP0STEP.app 

    LP1+ step   

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP1\

LP1ST01.app 

      

Run 

BuildChainR

CM and 

ChainChoiR

CM 

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP1\

RUNBUILDCHAINRCM.app 

      

Run MPS LP 

Extract 

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP1\

RUNMPS_LP_EXTRACT.app 

      

Check 

convergence 

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP1\

CHECKC01.app 

  

Run Final 

Process     

{CATALOG_DIR}\02_Applications\9_RCM1\Final\R

UNFIN01.app 

    

Prepare 

control files   

{CATALOG_DIR}\02_Applications\9_RCM1\Final\P

REPARE_02.app 

    

Run the final 

process   

{CATALOG_DIR}\02_Applications\9_RCM1\Final\R

UNTMODEL.app 

    Save Reports   

{CATALOG_DIR}\02_Applications\9_RCM1\Final\SA

VEREPORTS.app 

RCM 

Assignment 

(9)       

{CATALOG_DIR}\02_Applications\9_RCM1\ASS_VY

\ASS_VY.app 

  

Conversion 

from 

LogMod to 

VY     

{CATALOG_DIR}\02_Applications\\9_RCM1\ASS_V

Y\\CONVERSION OF EMME MATRICES.app 
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

  

Road 

Assignment 

RCM     

{CATALOG_DIR}\02_Applications\\9_RCM1\ASS_V

Y\\ASS_ROAD_VY.app 

  

Rail 

Assignment 

RCM     

{CATALOG_DIR}\02_Applications\\9_RCM1\ASS_V

Y\\ASS_RAIL_VY.app 

  

Sea 

Assignment 

RCM     

{CATALOG_DIR}\02_Applications\\9_RCM1\ASS_V

Y\\ASS_SEA_VY.app 

Samgods 

  

Air 

Assignment 

RCM     

{CATALOG_DIR}\02_Applications\\9_RCM1\ASS_V

Y\\ASS_AIR_VY.app 

Results RCM 

(10)       

{CATALOG_DIR}\02_Applications\9_RCM1\Results\

RESULTS.app 

  Reports 1.0     

{CATALOG_DIR}\02_Applications\9_RCM1\Results\

REPORTNEW.app 

    

PORT 

AREAS   

{CATALOG_DIR}\02_Applications\9_RCM1\Results\

PORTAR01.app 

    

GIS maps on 

commodity 

groups   

{CATALOG_DIR}\02_Applications\9_RCM1\Results\ 

Bidire01.app 

    

Oresund Kiel 

and Jylland   

{CATALOG_DIR}\02_Applications\9_RCM1\Results\

ORESUN01.app 

    Rail Capacity   

{CATALOG_DIR}\02_Applications\9_RCM1\Results\

RAILCA01.app 

    

Reports per 

geographical 

aggregation   

{CATALOG_DIR}\02_Applications\9_RCM1\Results\

REPORT01.app 

Parameters 

calculation 

(11)       

{CATALOG_DIR}\02_Applications\2_Run\Calibr\PA

RAMETERS.app 

Compare 

Scenarios 

        

{CATALOG_DIR}\02_Applications\3_Compare\Comp

are.app 

LOS Matrices 

(1)       

{CATALOG_DIR}\02_Applications\3_Compare\LOS

MAT.app 

OD Matrices 

(2)       

{CATALOG_DIR}\02_Applications\3_Compare\OD_

matrices\ODMATR01.app 

Assignment 

(3)       

{CATALOG_DIR}\02_Applications\3_Compare\ASSI

GNMENT.app 
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ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

Comparison 

(4)       

{CATALOG_DIR}\02_Applications\3_Compare\Comp

ar01.app 

Handling 

scenario 

        

{CATALOG_DIR}\02_Applications\4_Handling\Hand

ling.app 

Delete (1)       

{CATALOG_DIR}\02_Applications\4_Handling\DEL

ETE.app 

Compact (2)       

{CATALOG_DIR}\02_Applications\4_Handling\COM

PACT.app 

Scenario 

Export (3)       

{CATALOG_DIR}\02_Applications\4_Handling\SCE

NARIOEXPORT.app 

  

Model 

Export     

{CATALOG_DIR}\02_Applications\4_Handling\MOD

ELEXPORT.app 

  

General 

tables     

{CATALOG_DIR}\02_Applications\4_Handling\GEN

ERAL_TABLES.app 

  

Create the 

new base     

{CATALOG_DIR}\02_Applications\4_Handling\CRE

ATE_NEW_BSE.app 

  

Create the 

new scenario 

specific 

tables     

{CATALOG_DIR}\02_Applications\4_Handling\CRE

ATE_SS_TABLE_T.app 

    

Create the 

scenario 

tables   

{CATALOG_DIR}\02_Applications\4_Handling\CRE

ATE_SS_TABLE.app 

    

Create the 

scenario 

specific 

tables   

{CATALOG_DIR}\02_Applications\4_Handling\CRE

ATE_SS_TABLE_2.app 

Scenario 

Import (4)       

{CATALOG_DIR}\02_Applications\4_Handling\SCE

NARIOIMPORT.app 

PWC_Ma

trices         

{CATALOG_DIR}\02_Applications\6_PWC_matrices\

PWC_MA01.app 

Change 

matrix 

format         

{CATALOG_DIR}\02_Applications\7_Matrix_form\C

hange01.app 

Select 

Link 

Analysis 

        

{CATALOG_DIR}\02_Applications\10_SelectLink\Sel

ectLink01.app 

Data 

prepare(1)       

{CATALOG_DIR}\02_Applications\10_SelectLink\DA

TAPR01.app 

Selection for 

loaded 
      

{CATALOG_DIR}\02_Applications\10_SelectLink\SE
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

unloaded 

vehicles and 

tons(2) 

LECTION_T_LV.app 

  

Create 

selection files     

{CATALOG_DIR}\02_Applications\10_SelectLink\CR

EATEFILES.app 

  

Produce 

matrices 

with volumes 

and tons     

{CATALOG_DIR}\02_Applications\10_SelectLink\PR

ODUCEMAPS.app 

  

Produce 

maps with 

volumes and 

tons     

{CATALOG_DIR}\02_Applications\10_SelectLink\PR

ODUCMAPS.app 

  

Produce 

maps by 

Commodity 

group     

{CATALOG_DIR}\02_Applications\10_SelectLink\ST

AN.app 

Cost 

Benefit 

Analysis - 

ASEK 

Values 

        

{CATALOG_DIR}\02_Applications\11_CBA\CBA_AS0

1.app 

Data 

Preparation       

{CATALOG_DIR}\02_Applications\11_CBA\DATAPR

EPARATION_VY.APP 

  

Tax 

calculation     

{CATALOG_DIR}\02_Applications\11_CBA\DATAPR

EPARATION_VY_01.APP 

  Data for CBA     

{CATALOG_DIR}\02_Applications\11_CBA\DATARC

M.APP 

CBA 

Analysis(2)       

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\L

P2CCCBA.APP 

  Prepare data     

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\P

REPARE.app 

  

Prepare Data 

second part     

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\P

REPARE_01.app 

  

Prepare Data 

third part     

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\P

REPARE_02.app 

  Los call     

{CATALOG_DIR}\02_Applications\11_CBA\LOSCAL0

1.APP 

  Run LP2CC     

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\R

UNTMODEL.app 

  Save Reports     

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\S

AVEREPORTS.app 
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

  

Main 

Reports     

{CATALOG_DIR}\02_Applications\11_CBA\LP2CC\M

AINREPORTS01.app 

Elasticity 

Module 

        

{CATALOG_DIR}\02_Applications\12_Elasticity\Elas

ticity_Module_v2.app 

Initialization 

(1)       

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\1_Ini\INITIA00.app 

LOS 

calculation 

(4)       

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\COST_VY.app 

  

Data 

Preparation     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\DATAPREPARATION_VY.app 

    

Tax 

calculation   

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\DATAPREPARATION_VY_EL.app 

    

Data for 

RCM   

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\DATARCM.APP 

  Road     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\ROAD.app 

  Rail     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\RAIL.app 

  Sea     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\SEA.app 

  Air     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\AIR.app 

  

Conversion 

from VY to 

LogMod     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\CONVERALL.app 

    

From VY to 

LogMod 

Road   

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\CONCOSTVYE2.app 

    

From VY to 

LogMod Rail   

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\CONRAILVYE2.app 

    

From VY to 

LogMod Sea   

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\CONSEAVYE2.app 

    

From VY to 

LogMod Air   

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\2_Costs\CONAIRVYE2.app 

Logistics 

Module (5)       

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\3_LogisticMod\LOGMOD.app 

  Prepare data     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\3_LogisticMod\PREPARE.app 
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

  

Prepare Data 

second part     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\3_LogisticMod\PREPARE_01.app 

  

Prepare Data 

third part     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\3_LogisticMod\PREPARE_02_rev.app 

  

Run the 

logistic 

model     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\3_LogisticMod\RUNTMODEL.app 

  Save Reports     

{CATALOG_DIR}\02_Applications\12_Elasticity\1_R

un\3_LogisticMod\SAVEREPORTS.app 

Rail Capacity 

Management 

(6)       

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\RAILCAPACITYMANAGEMENT.app 

  

Data 

Preparation 

LP     

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\1_Dataprep_LP\DATAPR01.app 

  LP Loop     

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\2_LP_steps\LPLOOP01.app 

    LP0 step   

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\2_LP_steps\LP0STEP.app 

    LP1+ step   

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\2_LP_steps\LP1ST01.app 

      

Run 

BuildChainR

CM and 

ChainChoiR

CM 

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\2_LP_steps\RUNBUILDCHAINRCM.app 

      

Run MPS LP 

Extract 

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\2_LP_steps\RUNMPS_LP_EXTRACT.app 

      

Check 

convergence 

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\2_LP_steps\CHECKC01.app 

Elasticity 

Report (7) 
   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\ELASTI01.app   

Assignment 

(8)* 
   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\4_AssSTD\ASS_VY.app 

 

Conversion 

from 

LogMod to 

VY   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\4_AssSTD\CONVERSION OF EMME 

MATRICES.app 

 

Road 

Assignment   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\4_AssSTD\ASS_ROAD_VY.app 
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ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

 

Rail 

Assignment   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\4_AssSTD\ASS_Rail_VY.app 

 

Sea 

Assignment   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\4_AssSTD\ASS_SEA_VY.app 

 

Air 

Assignment   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\4_AssSTD\ASS_AIR_VY.app 

Results (9)* 
   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\5_ResultsSTD\Results.app 

 Results 1.0   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\5_ResultsSTD\REPORT_New.app 

  Port Areas  

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\5_ResultsSTD\PORTAR01.app 

  

Oresund Kiel 

and Jylland  

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\5_ResultsSTD\ORESUN01.app 

  

Reports per 

geographical 

aggregation  

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\1_Run\5_ResultsSTD\REPORT01.app 

RCM 

Assignment 

(10)* 
   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\2_RCM\4_AssRCM\ASS_VY.app 

 

Conversion 

from 

LogMod to 

VY   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\2_RCM\4_AssRCM\CONVERSION OF 

EMME MATRICES.app 

 

Road 

Assignment 

RCM   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\2_RCM\4_AssRCM\ASS_ROAD_VY.app 

 

Rail 

Assignment 

RCM   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\2_RCM\4_AssRCM\ASS_RAIL_VY.app 

 

Sea 

Assignment 

RCM   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\2_RCM\4_AssRCM\ASS_SEA_VY.app 

 

Air 

Assignment 

RCM   

{CATALOG_DIR}\02_Applications\12_Elasticity\3_El

asticities\2_RCM\4_AssRCM\ASS_AIR_VY.app 

Results RCM 

(11)*    

CATALOG_DIR}\02_Applications\12_Elasticity\2_RC

M\5_ResultsRCM\RESULTS.app 

 Results 1.0   
{CATALOG_DIR}\02_Applications\12_Elasticity\2_R
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Applicat

ion 

name 

Subgroup 

level 1 

Subgroup 

level 2 

Subgroup 

level 3 

Subgroup 

level 4 File name 

CM\5_ResultsRCM\REPORTNEW.app 

  Port Areas  

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\5_ResultsRCM\PORTAR01.app 

  

Oresund Kiel 

and Jylland  

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\5_ResultsRCM\ORESUN01 

  Rail Capacity  

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\5_ResultsRCM\RAILCA01.app 

  

Reports per 

geographical 

aggregation  

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\5_ResultsRCM\REPORT01 

 
  

 GIS maps by 

Commodity 

groups   

{CATALOG_DIR}\02_Applications\12_Elasticity\2_R

CM\5_ResultsRCM\BIDIRE01.app 

*Inactive in the elasticity model – kept for future development
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5 The application structure 

5.1. “Installation” application 

Input data: 

• None 

Output data: 

• Create the “Model_description” table in the Input_data.mdb and empty.mdb (under 

{CATALOG_DIR}\02_Applications\Edits) files. The first one is the general geodatabase, the second one is the template used 

for all the output geodatabases. 

Purposes: 

• Change the map for the files used in the model structure. 

• Store the general definitions of the model for long-term storage purposes. 

5.2. “Create the editable files” application 

Input data:  

• Scenario specific tables in the main geodatabase and base tables. 

Output data:  

• Scenario specific tables in the main geodabase and scenario data in the temporary geodatabase under scenario folder with 

name Scenario_data.mdb. Txt files under the work folder {CATALOG_DIR}\02_Applications\1_Editing to manage different 

checks and time data. 

Purpose: 

• Join the scenario tables and the base tables to create the editable data for the current scenario. 

Application Description Programs 

Prepare 

temporary data 

verify if scenario already exists under main database (Input_data.mdb) through a 

set of batch files 

1 to 7 

- create the check.txt file (check if general parameters table already exist in the main 

geodatabase) 

- create the date_time1.txt (last modification of Scenario_data.mdb) 

- create the date_time.txt (current time) 

- create the report1.txt (verify if the temporary geodatabase already exists) 

First case: The scenario does not exist 

- jump step 4 because the temporary geodatabase does not exist 

- copy all the scenario specific table from the scenario selected by Scenario_copy catalog key 

Second case: The scenario already exists but without temporary geodatabase 

- jump step 4 because the temporary geodatabase does not exist 

Third case: The scenario already exists and exist the temporary geodatabase 

First sub case: the scenario is lock - no actions are required. Process goes to end 
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Application Description Programs 

Second sub case: the scenario is still editable - go to next step and check if any edit was made 

before this run in the temporary geodatabase. If yes goes to next step. If no goes to end. 

Copy the scenario specific table in the temporary geodatabase Scenario_data.mdb - 

General_{SCENARIO_SHORTNAME} 8 

Logmod__{SCENARIO_SHORTNAME} 9 

SC_{SCENARIO_SHORTNAME}_Cargo 10 

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters Part A 11 

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters Part B 12 

SC_{SCENARIO_SHORTNAME}_Link 13 

SC_{SCENARIO_SHORTNAME}_Node 13 

SC_{SCENARIO_SHORTNAME}_Node_Terminals (Port_swe) 14 

SC_{SCENARIO_SHORTNAME}_Nodes 15 

SC_{SCENARIO_SHORTNAME}_Nodes_commodities 16 

SC_{SCENARIO_SHORTNAME}_Frequency_data_link 17 

SC_{SCENARIO_SHORTNAME}_Frequency_data_node 18 

SC_{SCENARIO_SHORTNAME}_Tax_Country 19 

SC_{SCENARIO_SHORTNAME}_Tax_Category 20 

SC_{SCENARIO_SHORTNAME}_Tax_Link 21 

SC_{SCENARIO_SHORTNAME}_Toll_Link 22 

SC_{SCENARIO_SHORTNAME}_PropLink 23 

SC_{SCENARIO_SHORTNAME}_Rail_Capacity 24 

Editable tables 

(2) 

Merge the scenario tables with the base tables in the temporary geodatabase - 

SC_{SCENARIO_SHORTNAME}_Cargo plus Cargo_Base2019 1 

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA plus 

Vehicles_parameters_Base2019_PartA 
2 

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB plus 

Vehicles_parameters_Base2019_PartB 
3 

SC_{SCENARIO_SHORTNAME}_Tax_Country plus Tax_Country_Base2019 4 

SC_{SCENARIO_SHORTNAME}_Tax_Category plus Tax_Category_Base2019 5 

SC_{SCENARIO_SHORTNAME}_Tax_Link plus Tax_Link_Base2019 6 

SC_{SCENARIO_SHORTNAME}_Toll_Link plus Toll_Link_Base2019 7 

SC_{SCENARIO_SHORTNAME}_Rail_Capacity plus Rail_Capacity_Base2019 8 

Editable map 

data (3) 

Merge the scenario tables with the base tables in the temporary geodatabase 

creating networks and feature classes to use in GIS window 
- 

Sc_{SCENARIO_SHORTNAME}_Link and Sc_{SCENARIO_SHORTNAME}_Node plus - 
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Application Description Programs 

Base2019_Link and Base2019_Node 

prepare the data to add general information from lookup tables (modes table) and create Cube 

network 
1 to 4 

save in EMME format the Cube network created in the previous steps 5 

SC_ {SCENARIO_SHORTNAME}_node_Terminals plus Node_terminals_Base2019 6 to 7 

Sc_{SCENARIO_SHORTNAME}_Nodes plus Nodes_Base2019 8 to 9 

Sc_{SCENARIO_SHORTNAME}_Nodes_commodities_Base2019 10 to 11 

Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Link and 

Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Node plus Base:2019_Frequency_Data 

Network 

12 to 13 

Copy Samgods_zones feature class in temporary geodatabase and end the process 14 

 

5.3. “Edit the data” application 

Input data:  

• Scenario tables in the temporary geodatabase Scenario_Data.mdb under scenario folder. 

Output data:  

• Scenario specific tables in the main geodabase. Txt files under the work folder {CATALOG_DIR}\02_Applications\1_Editing 

to manage time data. 

Purpose: 

• Compare the editable tables, networks and feature classes in the temporary geodatabase with the base data in the main 

geodatabase Input_data.mdb; after comparison save the updated scenario tables, General_{SCENARIO_SHORTNAME} and 

Logmod_{SCENARIO_SHORTNAME} tables. 

Application Description 
Program

s 

Subprogra

ms 

Create the 

tables 

specific of 

scenario 

(1) 

 

Check if “Create the editable files” was run 1  

Check if the scenario is in read or write/read mode 2  

Delete the previous report file REPORT_ED_BS06.txt 3  

if read mode, any change in scenario specific table is NOT copied 

back in the main database. All next steps will be skipped.  4 
 

if read/write mode then all next steps will be run  

Create SC_{SCENARIO_SHORTNAME}_Cargo in temporary 

geodatabase 
5  

Create 

SC_{SCENARIO_SHORTNAME}_Vehicles_parameters_PartA 

in temporary geodatabase 

6  

Create 

SC_{SCENARIO_SHORTNAME}_Vehicles_parameters_PartB 

in temporary geodatabase 

7  
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Application Description 
Program

s 

Subprogra

ms 

Check if edits come from the Voyager or the Emme network 8  

Numberin

g system  

In case of edits from Voyager, check all the codes to 

create the correct original number for the nodes: 

9 

 

Check the number of zones, ID_REGION, ID_COUNTRY and 

MODE_N codes 
1,2 

Based on the previous codes defined set the SCBSTANN code 3 

Code the NORIG value for the zones 4,5,6 

Code the NORIG value for the nodes 7,8 

Delete the information related to modes joined in the "Create 

editable files" 
9,10 

Merge all the new ORIG codes created 11 

Skim network for subsequent steps 12 

Dump the base scenario network 13,16 

Dump the current scenario network 14 

Convert network from EMME to Voyager format  15 

Compare node and link tables of the base scenario with the 

current scenario 
17 

 Check if edits come from the Voyager or the Emme network 10  

Emme 

Edits 

In case of edits from EMME, check all the codes to create 

the correct original number for the nodes: 

11 

 

Check if EMME network is defined in 211 format; in other words 

if catalog key has proper value 
1 

Create link and node tables from EMME network 2 

Check the number of zones, ID_REGION, ID_COUNTRY and 

MODE_N codes 
3 

Based on the previous codes defined set the SCBSTANN code 4 

Check the number of zones 5,6,7,8 

Node table union 9 

Recode the link table 10 

Recode the extra attribute 11 

Merge link and node data in the current scenario network  12 

Dump the current scenario network 13 

Dump the base scenario network in dbf format for subsequent 

steps 
14 

Compare node and link tables of base scenario with current 15 
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Program

s 

Subprogra

ms 

scenario 

Recodes modes on EMME rules 17,18,19 

 
Coming from edits from Voyager or edits from EMME, the 

process continues from this point 
12  

Compare 

Nodes and 

Node_ter

minals 

Compare current scenario with base scenario and 

scenario specific tables for nodes and node terminals 

13 

 

Dump Base scenario Node terminals 1 

Dump current scenario Node terminals 2 

Compare node terminals tables of current scenario with base 

scenario 
3 

Create SC_{SCENARIO_SHORTNAME}_Node_Terminals 4 

Dump Base scenario Nodes 5 

Dump current scenario Nodes 6 

Compare nodes tables of current scenario with base scenario 7 

Create SC_{SCENARIO_SHORTNAME}_Nodes 8 

Compare 

other 

tables 

Compare current scenario with base scenario and create the 

following scenario specific tables: 

14 

 

SC_{SCENARIO_SHORTNAME}_Nodes_Commodities 1 

SC_{SCENARIO_SHORTNAME}_Tax_Country 2 

SC_{SCENARIO_SHORTNAME}_Tax_Category 3 

SC_{SCENARIO_SHORTNAME}_Tax_Link 4 

SC_{SCENARIO_SHORTNAME}_Toll_Link 5 

Rail 

Capacity 

Checks 

Check rail management data and create a scenario 

specific table for rail capacity 

15 

 

Check consistency with network and ID_LINK numbers 1,2,3 

Dump Rail capacity table for base scenario 4 

Dump Rail capacity table for current scenario 5 

Create SC_{SCENARIO_SHORTNAME}_Rail_Capacity 6 

Create node list from network link table step 1  7 

Create node list from network link table step 2  8 

Compare node list from node and link tables to identify UNUSED 

nodes 
 9 

 Verify the maximum zone number among different tables 16 to 21  

 If the network does not have any new zones, create the 

Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Link and 
22 to 26  
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Application Description 
Program

s 

Subprogra

ms 

SC_{SCENARIO_SHORTNAME}_Freqeuncy_Data_Node tables 

in the temporary geodatabase 

Frequency 

matrices 

If new terminals are added to the network it will create a 

list of frequency values based on the default frequency 

table 

27 

 

Create the LOS matrices to understand the connections between 

terminals 
1,2 

Set the default values for the frequency matrices based on the 

A_default_frequency table 
3 

Filter the default values only for the new zones 4,5,6 

Convert the frequency matrices to network format and merge 

with the scenario frequency network to preserve previous edits 
7 

Dump the network 8 

 

Create the 

Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Link and 

SC_{SCENARIO_SHORTNAME}_Freqeuncy_Data_Node tables 

in the temporary geodatabase 

28  

 Jump specific steps (if not need to updated frequencies) 29  

     

Consisten

cy checks 

with 

calibratio

n tables 

(2) 

  

Compare the list of calibration parameters from 

Input_data_calibration.mdb and the related input data in current 

scenario. The application will identify if some parameters are 

missing in the current scenario 

  

  
Move the calibration parameters for Nodes table from mdb to dbf 

format 
 1 

  
Compare the Nodes table between the current scenario and the 

calibration parameters and list number of error detected 
 2 

  
Move the calibration parameters for Tax_country  table from 

mdb to dbf format 
 3 

  
Compare the Tax_Country table between the current scenario 

and the calibration parameters and list number of error detected 
 4 

  
Move the calibration parameters for Tax_link table from mdb to 

dbf format 
 5 

  
Compare the Tax_link table between the current scenario and the 

calibration parameters and list number of error detected 
 6 

  
Move the calibration parameters for Toll_link table from mdb to 

dbf format 
 7 

  
Compare the Toll_link table between the current scenario and the 

calibration parameters and list number of error detected 
 8 
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Program

s 

Subprogra

ms 

  
Move the calibration parameters for Capacity table from mdb to 

dbf format 
 9 

  
Compare the Capacity table between the current scenario and the 

calibration parameters and list number of error detected 
 10 

  
Move the calibration parameters for Speed_1, Speed 2 and UL 3 

link table from mdb to dbf format 
 11 

  
Compare the Link table between the current scenario and the 

calibration parameters and list number of error detected 
 12 

  

Sum the number of errors across the different tables and produce 

the {SCENARIO_DIR}\Total_errors_{SCENARIO_CODE}.DBF 

table. In errors >0, Samgods will be not run. 

 13 

  
If errors are present, the scenario tables will be not saved in the 

Input_Data.mdb database, skipping step 3 in the application 
 14 

    

Save 

changes in 

the main 

gdb (3) 

Regions 

for links 

Delete check.txt 

1 

1 

Check the record number in SC_Links 2,3 

Dump network 4 

Classify cases 5 

If you need the geoprocessing tool to classify links 6 

Create temporary network considering classified cases 7 

Call python for link classification 8 

Check if you need weight calculation 9,10 

Weight calculation 11,12 

Merge all tables and create 

SC_{SCENARIO_SHORTNAME}_PropLink 
13,14,15,16 

 
Save the scenario specific tables from the temporary 

geodatabase to the main geodatabase: 
  

 SC_{SCENARIO_SHORTNAME}_Cargo 2  

 SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA 3  

 SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB 4  

 
Copy SC_{SCENARIO_SHORTNAME}_Link and 

SC_{SCENARIO_SHORTNAME}_Node tables via python script 
5  

 SC_{SCENARIO_SHORTNAME}_Node_Terminals (Port_Swe) 6  

 SC_{SCENARIO_SHORTNAME}_nodes 7  

 SC_{SCENARIO_SHORTNAME}_nodes_commodities 8  

 SC_{SCENARIO_SHORTNAME}_Frequency_Data_Link 9  
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Application Description 
Program

s 

Subprogra

ms 

 SC_{SCENARIO_SHORTNAME}_Frequency_Data_Node 10  

 SC_{SCENARIO_SHORTNAME}_Tax_Country 11  

 SC_{SCENARIO_SHORTNAME}_Tax_Category 12  

 SC_{SCENARIO_SHORTNAME}_Tax_Link 13  

 SC_{SCENARIO_SHORTNAME}_Toll_Link 14  

 SC_{SCENARIO_SHORTNAME}_PropLink 15  

 SC_{SCENARIO_SHORTNAME}_Rail_Capacity 16  

 Delete temporary txt file containing time and date stamps 17  

 Update information of time and date on temporary txt 18  

 
Update the state of the scenario (write to only read) and 

ZONES_M 
19  

 Update the General_Base table:   

 
Save new value in the temporary geodatabase 

Scenario_Data.mdb 
20  

 Save new value in the main geodatabase Input_Data.mdb 21  

 Update the LogMod_Base table:   

 

Save new value in the temporary geodatabase 

Scenario_Data.mdb and in the main geodatabase 

Input_Data.mdb 

22,23  

 Delete all the temporary files created along the run 24  
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5.4. "Samgods” application 

Input data:  

• Scenario tables and base tables in main geodatabase Input_data.mdb. 

Output data:  

• Refer to Output section 3.4. 

Purpose: 

• Provide all the input data required by the Logistics and the Rail Capacity Management Modules and derive a set of standard 

outputs alongside the results under Logmod folder produced by the external programs. 

The description has two tables, the first one related to the Standard Logistics Module in Table 145, the 

second one to the Rail Capacity Management Module in Table 146. 

Table 145 - Samgods application: first part Standard Logistics Module. 

Application Description 

Progr

ams 

Subprogr

ams 

Initialization (1) 

Check free space available on computer and pull out freespace.txt 

file and exogenous consolidation rates 1  

Read freespace.txt and process the number to a token variable 2,3  

Based on values in token variable, give a warning to user. If there 

is enough space no warning is raised. 4  

Set initial value for Kiel Canal and provide the file to cycling 

process 
5  

Port and kiel canal parameters for search function, initial scaling 

factors by port area and lock solutions 

6-9 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Vehicles_

parameters_PartA_{Calibration_scenario} in DBF format 

10 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Vehicles_

parameters_PartB_{Calibration_scenario} in DBF format 

11 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Nodes_{C

alibration_scenario} in DBF format 

12 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Rail_Cap

acity_{Calibration_scenario} in DBF format 

13 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Tax_Coun

try_{Calibration_scenario} in DBF format 

14 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Tax_Link

_{Calibration_scenario} in DBF format 

15 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\Toll_Link

_{Calibration_scenario} in DBF format 

16 
 

Conversion of  

\Input_Data_Calibration_{Calibration_scenario}.mdb\{Calibrati

on_scenario}_Link in DBF format 

17 
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Application Description 

Progr

ams 

Subprogr

ams 

Conversion of Input_Data.mdb\V101_SpeedFlowCurves and 

Input_Data.mdb\V102_SpeedFlowCurves for stability issues in 

the road assignment 

18,19 
 

Pilot program to skip checks on consistency between calibration 

parameters and current scenario 

20 
 

Read number of errors produced in Edit the data 21 
 

Pilot preventing the full run if any error is encountered. 22 
 

Loop (2) Copy the input parameters for the current loop 2  

Pilot (3) 

Control the resume option of cycling process and warm start 

procedure within a fixed loop 3  

LOS 

calcula

tion 

(4) 

Data 

Preparat

ion (1) 

 Create if outputX.mdb exists, if not it is created.  1 1   

 

Load the parameters from general_{SCENARIO_SHORTNAME} 

table into the system variables 1 2   

 

Verify if few outputs already exist and if they have the same input 

data 1 3   

 Check if the scenario is locked or still editable 1 4   

 Create the Vehicle_parameter_PartA table for the scenario 1 5   

 

Apply factor and term values from 

{Scenario_DIR}\Scaling_PartA.DBF 

1 6 

 

 Create the Cargo table for the scenario 1 7  

 Create the network for the scenario  1 8   

 Dump in dbf format the link and node tables 1 9   

Tax calculation 

Set the node class (see table A_nodeclass) value for all the nodes 1 10 1 

Classify the links based on the class node and the ID_COUNTRY 

in the A_Categories code - identify the country id for each link 1 10 2 

Merge the tax by category tables (base and current scenario) and 

expand table for all links 1 10 3,4 

Print in a executable file the list of condictions to create the 

temporary attributes in the network 1 10 13 

Merge the tax by country tables (base and current scenario), apply 

the scaling parameters for tax by country and expand table for all 

links 1 10 

5,6,

7,8 

Merge the tax by link tables (base and current scenario), apply the 

scaling parameters for tax by link and expand table for all links.  

Update all attributes using the manipulation file produced instep 

13 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\TAX
1 10 

9,10

,14 
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Application Description 

Progr

ams 

Subprogr

ams 

_BY_LINK_M.TXT (File Output #10) 

Merge the toll by link tables (base and current scenario), apply the 

scaling parameters for toll by link and expand table for all links 

Update all attributes using the manipulation file produced instep 

13 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\TAX

_BY_LINK_M.TXT (File Output #10) 1 10 

11,1

2,15 

Merge all attributes created in the previous steps using 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\GE

N_NET.TXT produced under step 13 (File Output #1) 1 10 16 

Update all attributes using the manipulation files produced instep 

13 

READ FILE = 

"{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\TA

X_BY_LINKTYPE.TXT" (File Output #2) 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\EC_

BY_LINK.TXT (File Output #3) 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\TAX

_BY_COUNTRY.TXT (File Output #4) 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\TAX

_BY_LINK.TXT (File Output #7) 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\TOL

L_BY_LINK.TXT (File Output #8) 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\EC_

KM_BY_LINK.TXT (File Output #9) 1 10 17 

Recode the mode for each vehicle type using the manipulation file 

produced in step 13: 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\MO

DE_BY_VEHICLE.TXT  (File Output #5) 1 10 18 

Union of the different taxes and tolls 1 10 19 

Create the equations to save the final value for tax and extracost 1 10 20 

Save the final values (TAX_TOT,EXCTTOT and TOLL) for each 

link and by vehicle type using the final manilupation produced in 

step 20: 

{CATALOG_DIR}\02_APPLICATIONS\2_RUN\COSTS_VY\FIN

AL_MAN.TXT 1 10 21 

 Create the intrazonal matrix in dbf format 1 

11-

12   

 Change the format of intrazonal matrix from dbf to MAT 1 13   
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Application Description 

Progr

ams 

Subprogr

ams 

 Save the node_labels table in Output0.mdb 1 14  

 Create the port area table for the scenario 1 15  

 

Control the execution order and skip some steps not required in 

cycling process 1 16  

 Create the Capacity_table for current scenario 1 17  

 

Merge the network from step 9 and the Capacity table to use in 

next assignments 1 18  

Data for RCM 

Export final network with time and cost per link for usage in ASEK 

calculation or external checks 1 19 1 

Create {SCENARIO_DIR}\LogMod\RCM\Nodes_List.txt 1 19 2 

Create {SCENARIO_DIR}\LogMod\RCM\Links_List.txt 1 19 3 

Read Capacity_table_{SCENARIO_CODE}.DBF and prepare data 

for next step 1 

19 

4,5 

 

Control the execution order on cycling process and options to run 

step by step the model 1 20  

PILOT 2   Select which mode run based on Select_cal_cos_mode catalog key 2     

Road (3) 

  Execution order, start the road mode 3 1   

 

Delete {SCENARIO_DIR}\LogMod\RCM\PathTreeRoad.txt if 

exist 3 2  

  Loop between vehicle types (from 101 to 106)  3 3   

  

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table 3 4   

  

Calculate the Km_TAX, TOLL, DIST_COST, VOT variables and 

MAX_SPEED 3 5   

  Define the speed values and free flow times 3 6   

  Skim the los matrices 3 7   

  Merge the 5 LOS matrices in one file 3 8   

  Updated the outputs table with new output 3 

9 to 

10   

  Skip all the other steps if Select_cal_cos_mode has "Road" value  3 11  

Rail (4) 

  Execution order, start the rail mode 4 1   

 Delete {SCENARIO_DIR}\LogMod\RCM\PathTreeRail.txt if exist 4 2  

  Loop between vehicle types (from 201 to 212)  4 3   

  

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table for the first mode  4 4   

  Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 4 5   
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Application Description 

Progr

ams 

Subprogr

ams 

  Skim the los matrices 4 6   

  

For all the vehicle types except 202 there is a unique mode, so 

jump the subsequent steps. For 202 go to next step 4 7   

  Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 4 8   

  Skim the los matrices 4 9   

  Label to skip the steps 7 and 8 if vehicle type different from 202 4 10   

  Merge the 9 LOS matrices in one file 4 11   

  Updated the outputs table with new output 4 

12,1

3   

  Skip all the other steps if Select_cal_cos_mode has "Rail" value 4 14   

Sea (5) 

  Execution order, start the sea mode 5 1   

 Delete {SCENARIO_DIR}\LogMod\RCM\PathTreeSea.txt if exist 5 2  

 

Read Port Area table and set up transoceanic factors in MAT 

format 5 3  

  Loop between vehicle types (from 301 to 322)  5 4   

  

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table for the first mode  5 5   

  Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 5 6   

  Skim the los matrices 5 7   

  Merge the 21 LOS matrices in one file 5 

8 to 

10   

  Updated the outputs table with new output 5 

11 to 

12   

  Skip all the other steps if Select_cal_cos_mode has "Sea" value 5 13   

Air (6) 

  Execution order, start the air mode 6 1   

 Delete {SCENARIO_DIR}\LogMod\RCM\PathTreeAir.txt if exist 6 2  

 Set the value of vehicle type 6 3  

  

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table for the first mode  6 4   

  Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 6 5   

  Skim the los matrices 6 6   

  Updated the outputs table with new output 6 

7 to 

8   

  Skip all the other steps if Select_cal_cos_mode has "Air" value 6 9   

Convers
  Select which mode run based on Select_cal_cos_mode catalog key 7 1   
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Application Description 

Progr

ams 

Subprogr

ams 

ion from 

VY to 

LogMod 

(7) 

From VY to LogMod 

Road 

Mode Road 7 2 1 

Loop between vehicle types (from 1 to 5)  7 2 2 

Read the vehicle type number to rename properly the output files 7 2 3 

Crate the dbf tables from the matrix file adding the NORIG code 7 2 4 

Sort the records and create the V10x_dist.314,V10x_timeh.314, 

V10xxkr.314 and V10x_ddist.314 under LogMod\Input\LOS 

folder 7 2 5 

Skip all the other steps if Select_cal_cos_mode has "Road" value 7 2 6 

From VY to LogMod Rail 

Mode Rail 7 3 1 

Loop between vehicle types (from 6 to 13)  7 3 2 

Read the vehicle type number to rename properly the output files 7 3 3 

Crate the dbf tables from the matrix file adding the NORIG code 7 3 4 

Sort the records and create the V20x_dist.314,V20x_timeh.314, 

V20x_xkr.314 and V20x_ddist.314 under LogMod\Input\LOS 

folder 7 3 5 

Skip all the other steps if Select_cal_cos_mode has "Rail" value 7 3 6 

From VY to LogMod Sea 

Mode Sea 7 4 1 

Loop between vehicle types (from 14 to 34)  7 4 2 

Read the vehicle type number to rename properly the output files 7 4 3 

Crate the dbf tables from the matrix file adding the NORIG code 7 4 4 

Sort the records and create the V30x_dist.314,V30x_timeh.314, 

V30x_xkr.314 and V30x_ddist.314 under LogMod\Input\LOS 

folder 7 4 5 

Skip all the other steps if Select_cal_cos_mode has "Sea" value 7 4 6 

From VY to LogMod Air 

Mode air 7 5  1 

Crate the dbf tables from the matrix file adding the NORIG code      2 

Sort the records and create the V401_dist.314,V401_timeh.314, 

V401_xkr.314 and V401_ddist.314 under LogMod\Input\LOS 

folder 7 5  3 

Skip all the other steps if Select_cal_cos_mode has "Air" value 7 5  4 

PILOT 8 
 

Label to skip properly the unselected modes and select if run the 

logistic model, selection based on Step_by_Step catalog key 8   

Logisti

c 

Modul

e 01 

Prepare 

data  (1) 

  

Write in txt format the Cargo_Base2019 table under 

LogMod\Input\Cost with name Cargo.txt 1 1   

  
Merge the scenario specific table and the base table for 

1 2   
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Application Description 

Progr

ams 

Subprogr

ams 

(5) Node_terminals_Base2019 

  

Write in txt format the 

Node_terminals_{SCENARIO_SHORTNAME} table under 

LogMod\Input\Cost with name Pilotfees.txt 1 3   

 

Merge Vehicle parameters table A and B and apply scaling 

parameters 1 

4,5,

6  

  

Write in txt format the Vehicle_parameters table under 

LogMod\Input\Cost with name VHCLS_COM01.TXT, 

VHCLS_COM02.TXT, VHCLS_COM03.TXT, 

VHCLS_COM04.TXT, VHCLS_COM05.TXT, 

VHCLS_COM06.TXT, VHCLS_COM07.TXT, 

VHCLS_COM08.TXT, VHCLS_COM09.TXT 

,VHCLS_COM10.TXT, VHCLS_COM11.TXT, 

VHCLS_COM12.TXT, VHCLS_COM13.TXT, 

VHCLS_COM14.TXT, VHCLS_COM15.TXT and 

VHCLS_COM16.TXT 1 7,8   

  

Write in txt format the Vehicle_parameters table under 

LogMod\Input\General with name averagevehiclecapacity.txt 1 9   

 Convert LDB_ratio from the geodatabase table onto dat file 1 10  

 

Convert MaxCap and consol exception from the geodatabase table 

onto dat file 1 11  

  

Move in dbf format for the scenario specific tables 

SC_{SCENARIO_SHORTNAME}_Frequency_data_Link and 

SC_{SCENARIO_SHORTNAME}_Frequency_Data_node 1 12   

  Merge the dbf table with the base frequency network 1 13   

  Change the format from network to matrix 1 14   

  

Write in txt format under LOGMOD\INPUT\LOS\ the 10 files for 

frequency (.314) 1 15   

 

Write in txt format under LOGMOD\INPUT\LOS\ the 

FREQIWW.314 file 1 16  

Prepare 

data 

second 

part (2) 

  

Merge the scenario specific table and the base table for 

Nodes_{SCENARIO_SHORTNAME} 2 1   

  Add parameters for Varner Kanal  2 2   

 

Write in txt format the Nodes_{SCENARIO_SHORTNAME}table 

under LogMod\Input\Nodes with name Nodes.txt 2 3  

  

Merge the scenario specific table and the base table for 

Nodes_commodities_{SCENARIO_SHORTNAME} 2 4   

  
Write in txt format the 

Nodes_Commodities_{SCENARIO_SHORTNAME} table under 
2 

5 to 

6   
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Application Description 

Progr

ams 

Subprogr

ams 

LogMod\Input\Nodes into 17 txt files 

 

Create {SCENARIO_DIR}\LogMod\Extract\emptyfrac.dat for 

EXTRACT procedure 2 7  

Prepare 

data 

third 

part (3) 

 

Prepare consolidation factors by commodity group for subsequent 

steps 3 1  

  

Change the format for BuildChain_MODES table for subsequent 

steps 3 2   

 Prepare BuildChain_Common.ctl and BuildChain_Special.ctl 3 3  

 

Prepare ChainChain_Common.ctl, ChainChoi_Special.ctl and 

\INPUT\GENERAL\OtherCostMatters.ctl files 3 4  

 

Manage the execution order of building 

exogenous_consolidation_rate_dir.ctl. If no external files are 

provided, the process skips the creation of the control file. 3 5  

 

Create the exogenous_consolidation_rate_dir.ctl file under 

ChainChoi folder with information of the location of the external 

consolidation rates. 3 6  

 

Manage the execution order of building 

exogenous_consolidation_rate_dir.ctl. If no external files are 

provided, the process skips the creation of the control file. 3 7  

  Built CTL files for BuildChain 3 8   

 Identify starting and ending part for each commodity group  3 9  

 Build CTL files for ChainChoi  3 10  

 Identify starting and ending part for each commodity group 3 11  

 

Loop from commodity 1 to commodity 16 to create the control files 

for BuildChain.exe, ChainChoi.exe and LP2CC.exe programs 3 12  

 Control if jump another commodities 3 13  

  Create control files for BuildChain under LogMod\BUILDCHAIN 3 14   

  Create control files for ChainChoi under LogMod\CHAINCHOI 3 15   

 Skip other commodities if not selected All (0) 3 16  

  

Convert the Chain_list table in txt format under 

LOGMOD\INPUT\CHAINTYPE.LIS 3 17   

  Create control files for Extract program under LogMod\Extract 3 18   

 

Create control files for Mergerep program under 

LogMod\MERGEREP\ 3 19  
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Progr

ams 

Subprogr

ams 

 Control execution order 3 20  

Run the 

logistic 

model 

(4) 

  Create RUNALL batch file based on catalog key selection 4 1  

  

Create COMMODITY.BAT to call buildchain,  chainchoi  and 

ConsolidRateMode iteratively  4 2  

 Create batch files to call extract procedure  4 3  

  Create batch files to call runall.bat procedure and parallel process 4 4  

  

Call to normal process (no parallelization) and parallelization 

process 4 5  

  Create Mergerepall.bat 4 6  

 Run mergerep process 4 7  

 Prepare CTL for compact spanning trees 4 8  

 Create Compact Batch file 4 9  

  Run Compact program 4 10  

Save 

Reports 

(5) 

  

Save the report file from ChainChoi.exe (.rep) under scenario 

folder 5 1   

  Change the format of report file into Voyager 5 

2 to 

3   

 Merge domestic distances from LOS files for subsequent step 5 4  

 

Delete temporary files used to accumulate results from all 

commodities 5 

5 to 

11  

 Filter node table and produce table with only zones 5 12  

 Loop over commodities (ID_LOOPC) 5 13  

 

Control the commodities that must be used (if all or single 

commodity) 5 14  

 

Delete headers from ChainChoi\OUTPUT\ChainChoiXX01.out 

files 5 15  

 Calculate sum of variables for reports 5,6,7,8 5 16  

 Merge ChainChoiXX.rep files (input for reports 10 and 11) 5 17  

 Merge VhclRepXXrep files (input for reports 12) 5 18  

 Merge ChainChoiXX.rep files (input for report 6b) 5 19  

 Merge ChainChoiXX.rep files (input for report 19) 5 20  

 

Script to control the commodities that must be used (works in pair 

with 14) 5 21  

 Calculate report 5 and 6 5 22  
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Application Description 

Progr

ams 

Subprogr

ams 

 Calculate report 7 and 8 5 23  

 Calculate report 10 and 11 5 24  

 Calculate report 12 5 25  

 Calculate report 6b and 19 5 26  

 Updated the outputs table with new output 5 

27 to 

28  

 Label to skip the report phase 5 29  

Assign

ment 

(6) 

Convers

ion from 

LogMod 

to VY (1) 

 Loop for all the commodities (from 1 to 35) 1 1   

 Load the vehicle number from Vehicle_parameters table 1 2   

 Covert the 314 format in matrix format 1 

3 to 

5   

 Merge by mode the matrices 1 

6 to 

11   

 Updated the output tables with new output 1 

12 to 

13   

PILOT 2  Select the mode based on Select_cal_cos_mode catalog key 2   

Road 

Assignm

ent (3) 

 Execution order, start the road mode 3 1   

 Loop between vehicle types (from 1 to 6)  3 2   

 

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table 3 3   

 

Calculate the Km_TAX, TOLL, DIST_COST, VOT variables and 

MAX_SPEED 3 4   

 Define the speed values and free flow times 3 5   

 Assignment 3 6   

 Merge the 6 networks, one for each lorry type, into one file 3 7   

 Updated the outputs table with new output 3 

8 to 

9   

 Skip all the other steps if Select_cal_cos_mode has "Road" value 3 10   

Rail 

Assignm

ent (4) 

 Execution order, start the rail mode 4 1   

 Loop between vehicle types (from 7 to 17)  4 2   

 

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table for the first mode  4 3   

 Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 4 4   

 Assignment 4 5   

 
For all the vehicle types except 202 there is a unique mode, so 

4 6   
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Progr

ams 

Subprogr

ams 

jump the subsequent steps. For 202 go to next step 

 Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 4 7   

  Assignment 4 8   

  Label to skip the steps 7 and 8 if vehicle type different from 202 4 9   

  

Merge the12, one for each train type (one is done for vehicle 203, 

but that one is integrated with 202),networks into one file 4 10,11   

  Updated the outputs table with new output 4 

12 to 

13   

  Skip all the other steps if Select_cal_cos_mode has "Rail" value 4 14   

Sea 

Assignm

ent (5) 

  Execution order, start the sea mode 5 1   

  Loop between vehicle types (from 18 to 39)  5 2   

  

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table for the first mode  5 3   

  Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 5 4   

  Assignment 5 5   

  

Merge the 22, one for each sea vessel or ferry type, networks in one 

file 5 

6 to 

8   

  Updated the outputs table with new output 5 

9 to 

10   

  Skip all the other steps if Select_cal_cos_mode has "Sea" value 5 11   

Air 

Assignm

ent (6) 

  Execution order, start the air mode 6 1   

  

Set the values for VOT and KMCOST reading the 

Vehicle_parameters table for the first mode  6 2   

  Calculate the Km_TAX, TOLL, DIST_COST and VOT variables 6 3   

  Assignment 6 4   

  Save the network in geodatabase format 6 5   

  Updated the outputs table with new output 6 

6 to 

7   

  Skip all the other steps if Select_cal_cos_mode has "Air" value 6 8   

PILOT 7   Set the execution order 7     

Result

s (7) 

    

Label to start the report phase and check in the matrices and the 

networks exist under the scenario folder 1    

    

Merge all the assigned networks by mode into a single, common 

network 2    

    Create the report for vehicle and vehicle km 3    
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Progr

ams 

Subprogr

ams 

    Save the report in the geodatabase 4    

Results 

1.0 (5) 

 Create network with bidirectional flow 5 1  

 Produce report 3  5 2  

Port Areas (3) 

Read report 6b  5 3 1 

Sum over port areas 5 3 2 

Produce report 13 5 3 3 

GIS maps by Commodity 

groups (4) 

Create ArcGIS folder to export maps in ESRI format 5 4 1 

Prepare COMMODITY_STD.BAT 5 4 2 

Prepare COMMODITY_STD.CTL 5 4 3 

Run selectdirect to produce output by commodity group 

({SCENARIO_DIR}\LogMod\RCM\Output\COMMODITY_STD.

dat) 5 4 4 

Prepare table for map 5 4 

5 to 

7 

Export SHP file 5 4 8 

Run python to import SHP file onto gdb and update mxd with 

scenario name 5 4 9 

Oresund Kiel and 

Jylland (5) 

Merge final network with other statistics 5 5 1 

Calculate total values 5 5 2 

Produce report 14 5 5 3 

Reports per 

geographical 

aggregation (6) 

Merge Prop_link_Base2019 with scenario table 5 6 1 

Dump link table for assigned network 5 6 2 

Add CATEGORY ID_COUNTRY REGION ID_COUNTY attributes 

based on values in Prop_link 5 6 3 

Produce report 9 5 6 4 

Produce first part of report 17 5 6 5 

Produce first part of report 18 5 6 6 

Produce report 16 totals 5 6 7 

Produce report 17 totals 5 6 8 

Produce report 18 totals 5 6 9 

Produce report 16 adding county names 5 6 10 

Produce report 17 adding county names 5 6 11 

Produce report 18 adding county names 5 6 12 

  Updated the outputs table with new output 6 to 7   
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Progr

ams 

Subprogr

ams 

  

Update REPORT_GS_{SCENARIO_SHORTNAME}.prn file with 

the list of outputs created during the run 8   

    Delete all the temporary files  9    

    Update the logfile for entire run 10    

 

Table 146 - Samgods application: second part Rail Capacity Management Module.
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Application Description 

Pro

gra

ms 

Subprograms 

Rail 

Capacit

y 

Manag

ement 

(8) 

Data 

Preparati

on LP (1) 

    
Set the number of rail links as temporary 

variable 
1 1     

    Rename OD vehicles from _0 to _STD  1 2     

Warm 

start (2) 

   
Read log_file.log and set up variables that will 

be evaluated in next step 
2 1    

   

Set the execution order for LP Loop (3) 

depending on which step has been performed 

in previous run (LP0, LP1 or LP2+) 

2 2    

LP Loop 

(3) 

LP0 step (1) 

  Setup MPS.ctl control file 3 1 1   

  Prepare 1_RUN_MPS_LP0_step1.BAT 3 1 2   

  Execute 1_RUN_MPS_LP0_step1.BAT 3 1 3   

  
Check if run finished successfully, otherwise 

prompt the user 
3 1 4   

  
Check number of links over capacity, if not 

present any link, skip RCM 
3 1 5-6   

  Prepare 2_runLP.bat 3 1 7   

  Execute 2_runLP.bat 3 1 8   

  Prepare 3_RUN_MPS_LP0_step2.BAT 3 1 9   

  Execute 3_RUN_MPS_LP0_step2.BAT 3 1 10   

  
Check if run finished successfully, otherwise 

prompt the user 
3 1 11   

  
Back up LP0 results before moving to the next 

iteration 
3 1 12   

  Update log_file.log file 3 1 13   

  Skip next steps (user choice) 3 1 14   

LP1+ (2) 

  Label for LP1+ process 3 2 1   

  

Loop over maximum number of LP1 from 

catalog key "Maximum number of loops for 

Linear Programming process (LP)" 

3 2 2   

  Set minimum loop number for a warm start 3 2 3   

Run 

BuildC

hainRC

 

Print out the RUNALL_RCM.BAT batch file 

for running the column generation step for all 

the commodities 

3 2 4 1  
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Application Description 

Pro

gra

ms 

Subprograms 

M and 

ChainC

hoiRC

M (4) 

 

Print out the batch file for calling the 

BuildChain and ChainChoi programs in proper 

sequence 

3 2 4 2  

 
Select if run parallelization or normal 

procedure 
3 2 4 3  

 Label to jump to parallelization process 3 2 4 4  

 Prepare control files for parallelization process 3 2 4 5  

 Run parallelization process 3 2 4 6  

Run 

MPS 

LP 

Extract 

(5) 

 Prepare 1_RUN_MPS_LP1_step1.BAT 3 2 5 1  

 Execute 1_RUN_MPS_LP1_step1.BAT 3 2 5 2  

 
Check if run finished successfully, otherwise 

prompt the user 
3 2 5 3  

 Prepare 2_run1.bat 3 2 5 4  

 Execute 2_run1.bat 3 2 5 5  

 Prepare 3_RUN_MPS_LP1_step2.BAT 3 2 5 6  

 Execute 3_RUN_MPS_LP1_step2.BAT 3 2 5 7  

 
Check if run finished successfully, otherwise 

prompt the user 
3 2 5 8  

Check 

conver

gence 

(6) 

 Setup RCM_last_loop 3 2 6 1  

 Back up current loop  3 2 6 2  

 Update log_file.log 3 2 6 3  

 
Skip the process if the maximum number of 

loops has been reached 
3 2 6 4  

Run final 

process 

(4) 

Prepare control files 

(1) 

  Label for final process 5 1  1   

  Build control file for extract procedure 5 1 2   

  
Check if no links are overcapacity. If so skip 

final process 
5 1 3   

Run the final process 

(2) 

  

Print out the RUNALL_FIN.BAT batch file for 

calling the LP2CC program for all the 

commodities 

5 2 1   

  

Print out the batch file COMMODITY.BAT for 

call alternatively the BuildChain and 

ChainChoi programs 

5 2 2   
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Application Description 

Pro

gra

ms 

Subprograms 

  Create the batch file for the extract procedure 5 2 3   

  Set up files to describe the number of 

processors and batch file for calling 

Samgods_Parallelization_Module.jar 

5 2 4   

  

Run RUNALL.BAT and EXTRACTALL.BAT 

using the Parallelization Module or standard 

procedure 

5 2 5   

  Create the batch file for merge.exe 5 2 6   

  Call the external program "Merge reports" 5 2 7   

Save Reports (3) 

  Save the report file from ChainChoi.exe (.rep) 5 3 1   

  Change the format of the report file in Voyager 5 3 
2 to 

3 
  

  
Merge domestic distances from LOS files for 

subsequent step 
5 3 4   

  
Delete temporary files used to accumulate 

results from all commodities 
5 3 

5 to 

11 
  

  Print out the zone labels table   12   

  Loop over commodities (ID_LOOPC) 5 3 13   

  
Control the commodities that must be used (if 

all or single commodity) 
5 3 14   

  
Delete headers from 

ChainChoi\OUTPUT\ChainChoiXX01.out files 
5 3 15   

  Calculate sum of variables for reports 5,6,7,8 5 3 16   

  
Merge ChainChoiXX.rep files (input for 

reports 10 and 11) 
5 3 17   

  
Merge VhclRepXXrep files (input for reports 

12) 
5 3 18   

  
Merge ChainChoiXX.rep files (input for report 

6b) 
5 3 19   

  
Merge ChainChoiXX.rep files (input for 

reports 19) 
5 3 20   

  
Control the commodities that must be used 

(works in pair with step 14) 
5 3 21   

  Calculate report 5 and 6 5 3 22   

  Calculate report 7 and 8 5 3 23   

  Calculate report 10 and 11 5 3 24   
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Application Description 

Pro

gra

ms 

Subprograms 

  Calculate report 12 5 3 25   

  Calculate report 6b and 19 5 3 26   

  Updated output tables with new output 5 3 

27 

to 

28 

  

  
Rename LogMod\LOG\logxx.log into 

logxxSTD.log 
5 3 29   

  Update log file 5 3 30   

RCM 

Assign

ment 

(9) 

Conversi

on from 

LogMod 

to VY (1) 

Note: Same as for 

STD 
  Loop for all the vehicle types (from 1 to 40) 1 1     

    
Load the vehicle number from 

Vehicle_parameters table 
1 2     

    Covert the 314 format into matrix format 1 

3 

to 

5 

    

    
Merge the matrices by mode in a unique MAT 

file 
1 

6 

to 

11 

    

    Updated output tables with new output 1 

12 

to 

13 

    

PILOT 

(2) 
   Choose mode for assignment 2     

Road 

Assignm

ent (3) 

Note: Same as for 

STD 
  Loop between vehicle types (from 1 to 6) 3 1     

    
Set the values for VOT and KMCOST reading 

the Vehicle_parameters table 
3 2     

    
Calculate the Km_TAX, TOLL, 

DIST_COST,VOT variables and MAX_SPEED 
3 3     

    Define the speed values and free flow times 3 4     

    Assignment 3 5     

    Merge the 5 network in one file 3 6     

    Updated the outputs table with new output 3 

7 

to 

8 

    

Rail 

Assignm

ent (4) 

Note: Different from 

STD 
  

Read number of bidirectional links with 

capacity value (maximum ID_LINK) 
4 1     

    Prepare network for assignment 4 2     
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Application Description 

Pro

gra

ms 

Subprograms 

    
Calculate OD Empty, Loaded and Tons 

matrices in daily volumes  
4 3     

    Assign Loaded, Empties and Tons matrices 4 4     

    

Merge results from empty assignment and 

tons and loaded assignment -  convert in 

Year 

4 5     

    Updated the outputs table with new output 4 

6 

to 

7 

    

Sea 

Assignm

ent (5) 

Note: Same as for 

STD 
  Loop between vehicle types (from 18 to 39) 5 1     

    

Set the values for VOT and KMCOST reading 

the Vehicle_parameters table for the first 

mode  

5 2     

    
Calculate the Km_TAX, TOLL, DIST_COST 

and VOT variables 
5 3     

    Assignment 5 4     

    Merge the 21 networks in one file 5 

5 

to 

7 

    

    Updated the outputs table with new output 5 

8 

to 

9 

    

Air 

Assignm

ent (6) 

 

   

Set the values for VOT and KMCOST reading 

the Vehicle_parameters table for the first 

mode  6 1   

 

  

  
  

Calculate the Km_TAX, TOLL, DIST_COST 

and VOT variables 6 2   
 

  

    Assignment 6 3      

    Save the network in geodatabase format 6 4      

  

  Updated the outputs table with new output 6 

5 

to 

6   

 

  

PILOT 

(7) 
   Just run a single step or all RCM process 7     

Results 

RCM 

(10) 

    Check execution order a label to jump here 1     

      
Merge all the assigned network by mode in a 

unique network 
2      
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Application Description 

Pro

gra

ms 

Subprograms 

      Create the report for vehicle and vehicle km 3      

      Save the report in the geodatabase 4      

Reports 

1.0 (5) 

   Create network with bidirectional flow 5 1    

   Compare assigned networks STD and RCM 5 2    

   Produce report 3  5 3    

Port Areas (4) 

  Read report 6  5 4 1   

  Sum over port areas 5 4 2   

  Produce report 13 5 4 3   

GIS maps by 

Commodity groups 

(5) 

  
Create ArcGIS folder to export maps in ESRI 

format 
5 5 1   

  Prepare CTL and Batch files 5 5 
2 - 

3 
  

  

Run selectdirect to produce output by 

commodity group 

{SCENARIO_DIR}\LogMod\RCM\Output\C

OMMODITY_XTD.dat 

5 5 4   

  Prepare table for map 5 5 
5 – 

6 
  

  Export SHP file 5 5 7   

  Calculate report 21 5 5 8   

  
Run python to import SHP file onto gdb and 

update mxd with scenario name 
5 5 9   

Oresund Kiel and 

Jylland (6) 

  Merge final network with other statistics 5 6 1   

  Calculate total values 5 6 2   

  Produce report 14 5 6 3   

Rail Capacity (7) 

  
Create bidirectional flow from 

LOAD_NET_RAIL_RCM 
5 7 1,4   

  Create report 15 first step 5 7 2   

  Create report 15 second step 5 7 3   

Reports per 

geographical 

aggregation (8) 

  
Merge Prop_link_Base2019 with scenario 

table 

5 8 1   

  Dump link table for assigned network 5 8 2   

  

Add CATEGORY ID_COUNTRY REGION 

ID_COUNTY attributes based on values in 

Prop_link 

5 8 3   
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Application Description 

Pro

gra

ms 

Subprograms 

  Produce report 9 5 5 4   

  Produce first part of report 17 5 5 5   

  Produce first part of report 18 5 5 6   

  Produce report 16 totals 5 5 7   

  Produce report 16 adding county names 5 5 8   

  Produce report 17 totals 5 5 9   

  Produce report 17  adding county names 5 5 10   

  Produce report 18 totals 5 5 11   

  Produce report 18 adding county names 5 5 12   

    Domestic tonkm for calibration.txt file 5 9    

    Updated the outputs table with new output 
6 to 

7 
    

    Save RCM results and other report 8     

    

Update 

REPORT_GS_{SCENARIO_SHORTNAME}.p

rn file with the list of outputs created during 

the run 

9     

Parame

ters 

Calcula

tion 

(11) 

    
Skip the process if user selected to run step by 

step some parts 
1     

    
Calculation of scaling factors per port area and 

commodity group. See 6.9.2 for details 
2     

    Prepare data for next calculation 3     

    
Calculation of scaling factor for Kiel canal. See 

6.9.3 for details 
4     

    Label to skip the process 5     

Pilot 

#12 
    End of cycling process      
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5.5. “Compare scenarios” application 

Input data:  

• LOS matrices 

• OD matrices STD 

• loaded networks STD and RCM for base scenario and selected scenario. 

Output data:  

• matrices with differences and networks with differences under scenario folder. 

Purpose: 

• Compare the matrices and the loaded network between scenarios. 

Application Description Programs Subprograms 

LOS matrices 

(1) 

  Execution order based on "Select_compare" catalog key 1 1 

  Compare Road LOS matrix between base scenario and selected scenario 1 2 

  Compare Rail LOS matrix between base scenario and selected scenario 1 3 

  Compare Sea LOS matrix between base scenario and selected scenario 1 4 

  Compare Air LOS matrix between base scenario and selected scenario 1 5 

OD Matrices 

(2) 

  Execution order based on "Select_compare" catalog key 2 1 

  Compare OD Loaded vehicle matrices by road 2 2 

  Compare OD Loaded vehicle matrices by rail 2 3 

  Compare OD Loaded vehicle matrices by sea 2 4 

  Compare OD Loaded vehicle matrices by air 2 5 

  Compare OD tonne matrices by road  2 6 

  Compare OD tonne matrices by rail 2 7 

  Compare OD tonne matrices by sea 2 8 

  Compare OD tonne matrices by air 2 9 

 Compare OD empty vehicle matrices by road  2 10 

 Compare OD empty vehicle matrices by rail 2 11 

 Compare OD empty vehicle matrices by sea 2 12 

 Compare OD empty vehicle matrices by air 2 13 

Assignment 

(3) 

  Execution order based on "Select_compare" catalog key 3 1 

  Compare the loaded networks from Standard Logistics Module  3 2 

 Compare the loaded networks from Rail Capacity Management Module 3 3 

  End of process  3 4 
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Application Description Programs Subprograms 

Comparison 

(4) 

 Create {Scenario_Dir}\DIFF_GIS2045_2019 where store gdb and mxd 4 1 

 Calculate differences among COMMODITYflows tables 4 2 

 Move information in shp format 4 3 

 Save in gdb feature class 4 4 

 

5.6. “Handling scenario” 

Input data:  

• For the export function of the entire model.  

Output data:  

• Depends on the choice made by user. With the export function a new model will be set up in the folder indicated by 

“New_folder” catalog key. It will also result in an exported scenario in another model in case the “Exp_selection” catalog key 

is set to 2. 

Purpose: 

• To manage the model in the following ways: 

• To delete a scenario,  

• To compress the geodatabases,  

• To export a model or a single scenario,  

• To check the catalog values for an imported scenario. 

Application Description 

Progra

ms Subprograms 

Delete (1) 

    Set the execution order based on "Delete" catalog key  1 1      

    

Check if the scenario is in read mode. In this case go to the end of 

process  1 2      

    Skip all the other applications  1 3      

Compact 

(2)     

Call the python script compact_GDB.pyt to compress the 

input_data.mdb and output0.mdb  2 1     

 

Model 

Export 

(1)   

If "Exp_selection" is equal to 1, create the entire model structure 

in a new folder and copy all the applications and script files.  3 1 1 1   

General 

Tables 

(2) 

  

Create DaTE_TIME.TXT to check the data of the system and 

change the execution order based on "Exp_selection" catalog key  3 2 1    

  

Update the Model_description table in the new Input_Data.mdb 

file in the new model folder  3 2 

2 

to 

3    

  

Copy the tables and feature classes from the existing 

input_data.mdb to the new one. Also if the "Exp_selection" is set 

to 2, verify that the Input_Data.mdb exists in the new folder  3 2 4    
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Application Description 

Progra

ms Subprograms 

  If not exist jump all the processes to allow a verification by user.  3 2 

5 

to 

6    

  Update the General_NewBase table in the new geodatabase  3 2 7    

 Update the LogMod_NewBase table in the new geodatabase 3 2 8   

Create 

the new 

base (3) 

  

Skip all these steps if "Exp_selection" catalog key is set to 2. The 

previous check (2.3.4) has pointed out if is possible run this part.  3 3 1    

  

Merge SC_{SCENARIO_SHORTNAME}_Link and 

SC_{SCENARIO_SHORTNAME}_Node with base data to create 

the new base network  3 3 2    

  

Merge the 

SC_{SCENARIO_SHORTNAME}_Frequency_Data_Link and 

SC_{SCENARIO_SHORTNAME}_Frequency_Data_Node with 

the base frequency_data_Base2019 to obtain the new frequency 

network  3 3 3    

  

Merge Sc_{SCENARIO_SHORTNAME}_Cargo and 

Cargo_Base2019 to create the new cargo table  3 3 4    

  

Merge Sc_ {SCENARIO_SHORTNAME}_Node_Terminals with 

Node_Terminals_Base2019 to obtain the new Node_Terminals 

Base table  3 3 5    

  

Merge Sc_{SCENARIO_SHORTNAME}_Nodes_Commodities 

with Nodes_Commodities_Base2019 to create the new 

Nodes_Commodities table  3 3 6    

  

Merge SC_Nodes_{SCENARIO_SHORTNAME}to 

Nodes_Base2019 to obtain the new base nodes table   3 3 7    

  

Create the new Tax_Country_{SCENARIO_SHORTNAME}table 

joining Sc_{SCENARIO_SHORTNAME}_Tax_Country with 

Tax_Country_Base2019  3 3 8    

  

Create the new Tax_Category_{SCENARIO_SHORTNAME}table 

joining Sc_{SCENARIO_SHORTNAME}_Tax_Category with 

Tax_Category_Base2019  3 3 9    

  

Create the new Tax_Link_{SCENARIO_SHORTNAME}table 

joining Sc_{SCENARIO_SHORTNAME}_Tax_Link with 

Tax_Link_Base2019  3 3 10    

  

Create the new Toll_Link_{SCENARIO_SHORTNAME}table 

joining Sc_{SCENARIO_SHORTNAME}_Toll_Link with 

Toll_Link_Base2019  3 3 11    

  

Merge Vehciles_parameters_Base2019_PartA with 

SC_{SCENARIO_SHORTNAME}_Vehicle_parameters_PartA to 

obtain a new Vehicle_parameters base table  3 3 12    
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Application Description 

Progra

ms Subprograms 

 

Merge Vehciles_parameters_Base2019_PartB with 

SC_{SCENARIO_SHORTNAME}_Vehicle_parameters_PartB to 

obtain a new Vehicle_parameters base table  3 3 13   

 

Merge ProprLink_Base2019 with 

SC_{SCENARIO_SHORTNAME}_ProprLink to obtain a new 

PropLink base table 3 3 14   

 

Merge Rail_Capacity_Base2019 with 

SC_{SCENARIO_SHORTNAME}_Rail_Capacity to obtain a new 

Rail_Capacity base table 3 3 15   

Create 

the new 

scenario 

specific 

tables (4) 

Create 

the 

scenari

o tables 

(1) 

Do the next steps if "Exp_selection" is equal to 2. If equal 1 the 

base scenario already exists  3 4 1 1  

Rebuild the base scenario for the current scenario  3 4 1 

2 

to 

15  

Create 

the 

scenari

o 

specific 

tables(

2) 

Compare all the tables between the new base and the current 

scenario  3 4 2 

1 

to 

18  

Scenario 

Import 

(4) 

    

Select the execution order based on "Imp_Selection" catalog key 

and create Ckeck.txt file to verify if the scenario exists in the 

Input_Data.mdb  4 1       

    

Check if the selected scenario exists, otherwise give a prompt and 

go to the end of process  4 

2 

t

o 

3       

    

Compare the values for the catalog keys existing in the catalog file 

and in general_{SCENARIO_SHORTNAME}table, creating a 

report REPORT_HL_BS05.TXT  4 4       

 
  End of the process 4 5    

 

5.7. “PWC_matrices” application 

Input data:  

• PWC matrices under {CATALOG_DIR}\ 01_Programs\LogMod\Input\{Year}\PWC folder in txt format. {Year} is the catalog 

key controlling the set of matrices per each provided year (for example 2016 or 2045). 

Output data:  
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• PWC matrices under {CATALOG_DIR}\ 01_Programs\LogMod\Input\PWC\VY_F folder in binary voyager format. 

Purpose: 

• Visualize the PWC_matrices with Cube Interface. 

Description Programs 

Check existence of PWC matrices, if not warning the user 1 

Prepare lookup table with correspondence between Voyager and EMME numbers for zones and terminals  2 

Loop over commodities 1 to 9, read PWC matrices, convert in DBF tables and finally in Voyager MAT files From 3 to 11 

Loop over commodities 10 to 16, read PWC matrices, convert in DBF tables and finally in Voyager MAT files From 12 to 

19 

Delete temporary txt files (to save disk space) From 20 to 

29 

If PWC matrices not present, skip all process to let user check settings 30 

 

5.8. “Change matrix format” application 

Input data:  

• COST and 

• OD matrices for vehicles and tonnes under {CATALOG_DIR}\Scenario_Tree\{Scenario_name} folder. 

Output data:  

• dbf or txt file of a selected matrix. 

Purpose: 

• Export a specific matrix into dbf or csv format. 

Description Programs 

Detect the user choice and create temporary variable to jump at the right process 1 

Read the temporary variable and jump to the right process 2 

Export cost matrix in CSV format, DBF format or as table under MDB From 3 to 8 

Jump here if chosen Demand matrices instead 9 

Export demand matrix in CSV format, DBF format or as table under MDB From 10 to 

17 

 

5.9. “Select Link Analysis” application 

Input data:  

• Results from Samgods full run (both STD and RCM). Provide a list of nodes, links and commodities for the analysis. 

Output data:  

• Under SelectLink folder the output data listed in section 3.4.8.6. 

Purpose:  

• Perform select link analysis 
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Application Description 

Pro

gra

ms 

Subprogr

ams 

Data prepare (1)     Prepare the vehicle parameters table 1         

Selection for loaded 

unloaded vehicles and 

tons (2) 

  

Create selection files 

(1) 

  
Prepare the folder for outputs and necessary programs in 

RCM folder 
2 1 1     

  
Read link list (RCM\Links_List.txt) and prepare dbf table 

for next steps 
2 1 

2 

to 

3 

    

  

Read ID_LINK values in catalog key and prepare file for 

next steps 
2 1 4     

  

Read A and B r values in catalog key and prepare file for 

next steps 
2 1 5     

  

Union of link selection and conversion of Voyager 

numbering to Emme numbering 
2 1 6     

  Read node table from node list RENUM_NODES.DBF 2 1 7     

  

Read N vr values in catalog key and prepare file for next 

steps 
2 1 8     

  Conversion of node list in Emme numbers if required 2 1 9     

  

Check the combination of selections (maximum number 

of selections allowed for nodes and links) 
2 1 

1

0 
    

  Warning windows if exceeding some limits 2 1 11     

  
Set up control files for DirectSelect.jar program 2 1 

1

2 
    

  
Setup batch files to run DirectSelect.jar program 2 1 

1

3 
    

  
Run the program 2 1 

1

4 
    

Produce matrices 

with volumes and 

tons (2) 

  Move the results from RCM folder to Selectlink folder 2 2 1     

 Strip off header  2 2 2   

  Read output file STD solutions and convert in dbf 2 2 3     

  Read dbf table and convert in in OD table 2 2 4     

  Read OD table and convert in MAT file 2 2 5     

 Strip off header 2 2 6   

  Read output file RCM solutions and convert in dbf 2 2 7     

  Read dbf table and convert in in OD table 2 2 8     

  Read OD table and convert in MAT file 2 2 9     

Produce maps with   Delete headers in LinksSumSLSTD.dat (STD results) 2 3 1     
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Application Description 

Pro

gra

ms 

Subprogr

ams 

volumes and tons 

(3) 

  Convert link results in DBF format 2 3 2     

  Create attribute names and values 2 3 3     

  Delete headers in LinksSumSL.dat (RCM results) 2 3 4     

  Convert link results in DBF format 2 3 5     

  Create attribute names and values 2 3 6     

  Dump network in NET format 2 3 7     

  Create NET file with results of select link analysis STD 2 3 8     

  Create NET file with results of select link analysis RCM 2 3 9     

Produce maps by 

Commodity group 

(4) 

 

Call selectdirect.jar to produce outputs by commodity 

group 
2 4 1   

 Convert CommoditySLSTD.dat in DBF format  2 4 2   

 

Merge bidirectional network and commodity table for 

STD and produce SHP file 
2 4 3   

 Convert CommoditySL.dat in DBF format  2 4 4   

 

Merge bidirectional network and commodity table for 

RCM and produce SHP file 
2 4 5   

 

Call python to move data from SHP to gdb format 

(independently by Cube) or Option to skip GDB and 

produce net format 

2 4 6   

 Produce NET for STD 2 4 7   

 Produce NET for RCM 2 4 8   

 Handle choice between gdb or net output 2 4 9   

  

5.10. “Cost Benefit Analysis - ASEK Values” application 

Input data:  

• Results from Samgods full run (both STD and RCM). Provide the Toll, tax, scaling factors parameters from ASEK scenario 

(need to specify ASEK catalog key). 

Output data:  

• Listed in section 3.4. 

Purpose: 

• Produce reports and statistics excluding the calibration factors and using as basis the ASEK values (e.g. values suitable for 

Cost Benefit Analysis). 

Application Description 
Prog

rams 
Subprograms 

PILO   Set specific folders under LogMod for CBA calculation 1     



The application structure 

245 

Application Description 
Prog

rams 
Subprograms 

T (1) 

Data 

Prepa

ration 

(2) 

  
Check the choices made by user; if not right starts a prompt. Create the outputX.mdb if 

not exist and if required.  2 
1 1   

  
Load the parameters from general_{SCENARIO_SHORTNAME} table into the system 

variables 2 
1 2   

  Verify if few outputs already exist and if they have the same input data 2 1 3   

  Check if the scenario is locked or still editable 2 1 4   

  Create the Vehicle_parameter table for the scenario 2 1 5   

 Apply coordination factorsfrom {Scenario_DIR}\Scaling_PartA.DBF 2 1 6   

  Create the Cargo table for the scenario 2 1 7   

  Create the network for the scenario  2 1 8   

  Dump in dbf format the link and node tables 2 1 9   

Tax 

calculati

on 

Set the node class (see table A_nodeclass) value for all the nodes 2 1 10 1  

Classify the links based on the class node and the ID_COUNTRY in the A_Categories code 

- identify the country id for each link 2 
1 10 2  

Convert all the scenario tables for taxes and tolls to a link format 

2 

1 10 

3 

to 

12 

 

Create the network with all the extra attributes with undefined values 2 1 10 13  

Recode the mode for each vehicle type 2 1 10 15  

Update with scenario values all the extra attributes 2 1 10 14  

Add the fields for MODE 2 1 10 16  

Create the equations to save the final value for tax and extracost 2 1 10 17  

Save the final values (TAX_TOT, EXCTTOT and TOLL) for each link and by vehicle type 2 1 10 18  

  Create the intrazonal matrix in dbf format 2 1 11   

  Change the format of intrazonal matrix from dbf to MAT 2 1 12   

  Save the node_labels table in Output0.mdb 2 1 13   

Data for 

CBA 

Export final network with time and cost per link for usage in ASEK calculation or external 

checks 2 
1 14 1  

CBA 

Analy

sis (3) 

 Prepare 

data (1)  

Write in txt format the Cargo_Base2019 table under LogMod\Input\Cost with name 

Cargo.txt 3 1 1 
  

Merge the scenario specific table and the base table for Node_terminals_Base2019 3 1 2 
  

Write in txt format the Node_terminals_{SCENARIO_SHORTNAME} table under 

LogMod\Input\Cost with name Pilotfees.txt 3 1 3 
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Application Description 
Prog

rams 
Subprograms 

Merge Vehicle parameters table A and B and apply scaling parameters 3 1 

4,5,

6 
  

Write in txt format the Vehicle_parameters table under LogMod\Input\Cost with name 

VHCLS_COM01.TXT, VHCLS_COM02.TXT, VHCLS_COM03.TXT, 

VHCLS_COM04.TXT, VHCLS_COM05.TXT, VHCLS_COM06.TXT, 

VHCLS_COM07.TXT, VHCLS_COM08.TXT, VHCLS_COM09.TXT 

,VHCLS_COM10.TXT, VHCLS_COM11.TXT, VHCLS_COM12.TXT, VHCLS_COM13.TXT, 

VHCLS_COM14.TXT, VHCLS_COM15.TXT and VHCLS_COM16.TXT 3 1 7,8 
  

Write in txt format the Vehicle_parameters table under LogMod\Input\General with 

name averagevehiclecapacity.txt 3 1 9   

 Prepare 

data 

second 

part (2)  

Copy all the other files from Input\Nodes to  Input_CBA\Nodes 3 2 1 
  

Merge the scenario specific table and the base table for 

Nodes_{SCENARIO_SHORTNAME} 3 
2 2 

  

Add parameters for Varner Kanal 3 2 3   

Write in txt format the Nodes_{SCENARIO_SHORTNAME}table under 

LogMod\Input_CBA\Nodes with name Nodes.txt 3 
2 4 

  

Prepare 

data 

third 

part (3) 

Convert the Chain_list table in txt format under LOGMOD\Input_CBA\CHAINTYPE.LIS 

3 

3 1 

  

LOS Call 

(4) 

Move parameters for port areas in CBA folder 3 4 1   

Prepare {SCENARIO_DIR}\LogMod\RCM\LOS_CBA.ctl control file for LOS rescaling 3 4 2   

Prepare CB_RUN_LOS.BAT to call selectDirect.jar to rescale LOS matrices 3 4 3   

Run process and infill LOS folder with proper matrices 3 4 4   

 Run  

LP2CC 

(5)  

Print out the batch file to call logistic model selecting the commodity based on the value in 

Select_commodity catalog key 3 
5 1 

  

Print out the batch file for call ASEK calculation 3 5 2 
  

Change the execution order if selected the normal logistic model or advanced. Call the 

batch files RUNALL.BAT 3 
5 3 

  

Label to jump the normal logistic model and run advanced 3 5 4 
  

Set up files to describe then number of processors and batch file for call the 

Samgods_Parallelization_Module.jar 3 
5 5 

  

Run RUNALL.BAT using Parallelization Module 3 5 6 
  

Create the batch file for merge.exe 3 5 7 
  

Call the external program "Merge reports" and check results  3 5 8 
  

Prepare {SCENARIO_DIR}\LogMod\RCM\UTI_CBA.ctl 3 5 9   
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Application Description 
Prog

rams 
Subprograms 

{SCENARIO_DIR}\LogMod\RCM\CB_RUN_UTI.BAT 3 5 10   

Run CB_RUN_UTI.BAT to get rescaled costs and reports for empties 3 5 11   

 Save 

Reports 

(6)  

Pilot to skip process if not main JA scenario 3 6 1   

Delete temporary files used to accumulate results from all commodities 3 6 2   

Save the report file from ChainChoi (.rep) 3 6 3 
  

Change the format of report file into Voyager 3 6 4 
  

Merge domestic distances from LOS files for subsequent step 3 6 5 
  

Loop over commodities (ID_LOOPC) 3 6 6 
  

Control the commodities that must be used (if all or single commodity) 3 6 7 
  

Delete headers from ChainChoi\OUTPUT\ChainChoiXX01.out files 3 6 8 
  

Calculate sum of variables for reports 5,6,7,8 3 6 9 
  

Merge ChainChoiXX.rep files (input for reports 10 and 11) 3 6 10 
  

Merge VhclRepXXrep files (input for reports 12) 3 6 11 
  

Merge ChainChoiXX.rep files (input for report 6b) 3 6 12 
  

Merge ChainChoiXX.rep files (input for report 19) 3 6 13 
  

Script to control the commodities that must be used (works in pair with 14) 3 6 14 
  

Calculate report 5 and 6 3 6 15 
  

Calculate report 7 and 8 3 6 16 
  

Calculate report 10 and 11 3 6 17 
  

Calculate report 12 3 6 18 
  

Calculate report 6b and 19 3 6 19 
  

OrderCosts and Inventory Report 20 3 6 20 
  

Updated the outputs table with new output 

3 

6 

21 

and 

22 
  

Jump here to skip reports if not JA 3 6 23 
  

Create report on empties for UA scenario 3 6 24   

Skip previous step if JA scenario 3 6 25   

Main 

Reports 

(7) 

Read {SCENARIO_DIR}\LogMod\RCM\output\VehicleTrpEmpInv_Input_CBA.dat and 

convert in DBF – table holds vehicle costs and vehicles on ferry costs and vhvclkm and 

tonkm 

3 

7 1   

Add attributes to handle ferry vehicles and vehicles on ferry  3 7 2   

Create  Vehicles_loaded_and_empty_witin_Swedish_territory_CBA report 3 7 3   

Read {SCENARIO_DIR}\LogMod\RCM\output\VehicleTrpEmpInv_Input_XTD.dat and 3 7 4   
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Application Description 
Prog

rams 
Subprograms 

convert in DBF – table holds vehicle costs and vehicles on ferry costs and vhvclkm and 

tonkm 

Add attributes to handle ferry vehicles and vehicles on ferry 3 7 5   

Merge CBA and RCM reports to create table 

Costs_D_I_X_T_{Scenario_ShortName}_CBA 
3 

7 6   

Comparison of Costs_D_I_X_T_{Scenario_ShortName}_CBA across JA and UA 

scenarios for final report {SCENARIO_DIR}\CBA_Final_report_{SCENARIO_CODE}.txt 
3 

7 7   

Update list of reports under {SCENARIO_DIR}\REPORT_SG_{SCENARIO_CODE}.TXT 3 

7 

fro

m 8 

to 

10   

 PILO

T (4)   
Rename back Logmod folder 4 

    

 

5.11. “Elasticity module” application 

The structure is identical to Samgods , with the following exceptions: 

• all the assignment and report steps are deactivated 

• The derivation of consolidation rates for iteration >1, where ID_SCENARIO>1 in Scenarios_List 

table”, the exogenous consolidation rates will be derived from the Samgods model run (equivalent to 

iteration 1), i.e. the reference. Please find further details under the User Manual.

  

The extra module Elasticity Report calculates elasticities based on Webtag formulation (see par. 8.12.7 of 

User Manual for details) and produces final report.  

Description Program Subprograms 

Jump here after RCM 7 1 

Calculate elasticities for STD process comparing scenario 1 vs current scenario 7 2 

Calculate elasticities for RCM process comparing scenario 1 vs current scenario 7 3 

Merge previous calculations together and save final report 7 4 

Jump to the end of the process 7 5 
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6 Applied methods in the model 

6.1. New calibration method in V1.2.2 

Calibration of the Samgods model is mainly performed by applying calibration parameters to scale existing 

costs-attributes within the model in order to obtain correlation between model results and available 

measurements. In the previous version of the Samgods model (version 1.2.1) a limited amount of calibration 

parameters was provided (table VehicleParameters), adjustments of other attributes required changes to the 

actual attribute values in the model, which is was scaled back in the ASEK tables. This approach was not ideal 

in clarify which changes were genuinely made for changes in costs or taxes and which ones were there for 

calibration purposes. 

In order to preserve flexibility when calibrating the model and also maintain “realistic” attribute values 

within the input tables, all available model-attributes within the input database have now corresponding 

calibration parameters. In addition, calibration parameters can be added both as multiplicative factors 

and/or additional terms, while only multiplicative parameters were available in V1.2.1. 

To maintain a clear structure of the calibration parameters, all model attributes used in the calibration 

process are now included in two separate databases (Input_data_Calibration_Base2019.mdb and 

Input_data_Calibration_MainSc2045.mdb). 

The calibration parameters provides only objects covered by calibration changes. If no calibration parameter 

is provided for the model attribute, the information given in the original input database would be loaded into 

the model without any transformation. 

The general equation applied in all the modified attributes is as follow: 

𝑀𝑎,𝑘 =  𝐼𝑎,𝑘 ∗ 𝐶𝑎,𝑘
𝑓

+ 𝐶𝑎,𝑘
𝑡  

Where: 

• Ma,k: modified values (calibrated values) of the attribute a in table k – produced when running the 

model 

• Ia,k: original values in Input_Data.mdb of the attribute a in table k – original values 

• Ca,k
f and Ca,k

t= multiplicative and additive calibration parameters. – present in 

Input_data_Calibration_Base2019.mdb and Input_data_Calibration_MainSc2045.mdb with suffix 

_FA (f=factor) and _TE (t=additive term).- produced during the  

For example, the attribute SPEED_1 (a), in table Input_Data.mdb\Base209_Link (k) included will have the 

corresponding factor and additive terms in Input_data_Calibration_Base2019.mdb\Base209_Link denoted 

as SPEED_1_FA (Ca,k
f) and SPEED_1_TE (Ca,k

t). 

A numerical example of the implementation is given below, where the data provided in Table 147 represents 

It,k and the values in Table 148 represents Ca,k
f and Ca,k

t. In this case the table t is 

“Vehicles_parameters_PartA_Base2017” and attribute k is the distance based cost “KM_COST”.  

 

Table 147 It,k 

OBJECTID A B SPEED_1 

2151 2027 2068 69.5 

2152 2027 2070 69.5 
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Table 148 Ca,k
f and Ca,k

t factors 

OBJECTID A B SPEED_1_FA SPEED_1_TE 

1 2027 2068 1.029411765 0 

2 2027 2070 1.029411765 0 

 

Combining the information from Table 147 and  Table 148 gives the data M_(SPEED_1,Link_Base2019) 

provided into the model. 

M_(SPEED_1,Link_Base2019)= 69.5*1.029411765+0= 71.54412 

 

The input data which is subject to calibration parameters Ca,k
f and Ca,k

t is:  

• Link table: SPEED_1, SPEED2 AND UL3; 

• Vehicle cost Part A and B  

• Rail capacity 

• Link tolls 

• Tax_Link 

• Tax_Country 

• Nodes_Base2017: required for technological factors on cost and time on terminals 

The following data has only the Ca,k
f component: 

• Kiel-canal factor 

• Port area parameters 

Since the iterative calibration mechanism present in V1.2.1 has not been revised.  

The following tables are present for the iterative calibration mechanism.  

• Parameters_Kielcalibration.dbf 

• Parameters_portcalibration.dbf 

Finally the Locked solutions previously save in a txt files, are now moved in the same 

Input_Data_Calibration.mdb for consistency and they hold their specific structure.  

In order to minimize the user interaction, information about if a calibration parameter is pointing to 

something that does not exists in a specific scenario is provided when running “Edit the data” application. If 

any error occurs, the main application “Samgods” will fail pointing to the issue.   

6.2. Manage different loading times, costs and capacities for different 
commodities 

The vehicle cost table has been divided in two parts, first part (A) is by vehicle type and second part is by 

vehicle type and commodity group (B). Factors are applied in both cases arriving at maximum flexibility 

where all different attributes can be modified by commodity group.  

To setup this differentiation the following technique has been applied: 

1. For each commodity, the original values in Vehicle parameters table are multiplied by the factors 

present in Input_Data_Calibration.  
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2. In each control file for BuildChainXX.ctl the definition of VHCL control parameter that gives the 

name and location of vehicle parameters has modified using commodity name (where XX is the 

commodity group number) VHCL=.\Input\Cost\VHCLS_COMXX.TXT 

3. In each control file for ChainCHainXX.ctl the definition of VHCL control parameter that gives the 

name and location of vehicle parameters has modified using commodity name (where XX is the 

commodity group number) VHCL=.\Input\Cost\VHCLS_COMXX.TXT 

Table 149 and Table 150 show the coupling between Vehicle parameters Part A and B and calibration  

parameters. 

Table 149 - Factors and vehicle parameter table A. 

Attribute in table Vehicle parameters Part 
A 

Factor attribute under Calibration Term attribute under Calibration 

CAPACITY CAPACITY_FA CAPACITY_TE 

COORFACT COORFACT_FA COORFACT_TE 

HOURS_COST HOURS_COST_FA HOURS_COST_TE 

KM_COST KM_COST_FA KM_COST_TE 

ONFER_H_C ONFER_H_C_FA ONFER_H_C_TE 

ONFER_KM_C ONFER_KM_C_FA ONFER_KM_C_TE 

POSICOST POSICOST_FA POSICOST_TE 

DFLTFREQ DFLTFREQ_FA DFLTFREQ_TE 

F_DUES_VH F_DUES_VH_FA F_DUES_VH_TE 

F_DUES_TON F_DUES_TON_FA F_DUES_TON_TE 

SPEED None  

VDF_SPEC   

MODE_1   

MODE_2   

FUNC_FILE   

EMPTY_V   

MAX_SPEED MAX_SPEED_FA MAX_SPEED_TE 

 

Table 150 - Factors and vehicle parameter table B. 

Attribute in table Vehicle parameters Part 
B 

Factor attribute under Calibration Term attribute under Calibration 

CONT_LTI CONT_LTI_FA CONT_LTI_TE 

CONT_LCO CONT_LCO_FA CONT_LCO_TE 

CONT_LTI_T CONT_LTI_T_FA CONT_LTI_T_TE 

CONT_LCO_T CONT_LCO_T_FA CONT_LCO_T_TE 

NC_LTI NC_LTI_FA NC_LTI_TE 

NC_LCO NC_LCO_FA NC_LCO_TE 

NC_LTIT NC_LTIT_FA NC_LTIT_TE 

NC_LCOT NC_LCOT_FA NC_LCOT_TE 

 

In Table 151 the list of VHCL definitions in BuildChain and ChainChoi. 

Table 151 - List of values for VHCL control parameter in BuildChain and ChainChoi control files. 

ID_COM VHCL in BuildChain and 

ChainChoi 

1 VHCLS_COM01.TXT 

2 VHCLS_COM02.TXT 

3 VHCLS_COM03.TXT 

4 VHCLS_COM04.TXT 

5 VHCLS_COM05.TXT 
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6 VHCLS_COM06.TXT 

7 VHCLS_COM07.TXT 

8 VHCLS_COM08.TXT 

9 VHCLS_COM09.TXT 

10 VHCLS_COM10.TXT 

11 VHCLS_COM11.TXT 

12 VHCLS_COM12.TXT 

13 VHCLS_COM13.TXT 

14 VHCLS_COM14.TXT 

15 VHCLS_COM15.TXT 

16 VHCLS_COM16.TXT 

 

6.3. Manage different consolidation factors for different commodity 
groups 

The consolidation range, expressed as a lower and upper limit, can be specified in two separate ways in the 

general control file for BuildChain and ChainChoi.  

A first control parameter, CONSOL, represents a general range used when no mode specific range is 

specified. These range can be specified in the GUI via the following two catalog keys: 

• Lower bound for consolidation factor  (applied to all commodities - from 0 to 1) 0.05 

• Upper bound for consolidation factor (applied to all commodities from 0 to 1) 0.95 

A second set of CONSOL<mode> parameters can be specified using the table: 

• "Low and upper bounds for consolidation factors" under Scenario Inputs\General tables of Data Panel. 

The access to this table is only for developer or advance user in application Edit the data. 

The Logistics Module will give the priority to the second values, specified by submode and commodity, and 

ignore the first general values. An example of general control file with these parameters specified is (notice 

the difference between CONSOL CONSOL<mode>): 

• CONSOL=0.05,0.95 

• CONSOLA=0.05,0.5 

• CONSOLB=0.05,0.5 

• CONSOLC=0.05,0.5 

• CONSOLS=0.5,0.9 

In the calibration process a unique set of consolidation parameters per mode has shown limitations and 

different sets for specific commodities have been used for the calibration. BuildChain_CONSOL table has 16 

commodity lower and upper bounds for consolidation parameters. The implemented logic is: 

• CONSOL_L and CONSOL_U hold the default values 

• CONSOL_LXX - CONSOL_UXX, where XX is commodity, hold values that change in comparison to 

the default values. Where there is a value -1, the default value will be used 
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The current structure has the advantage to clearly point to differences in values across each commodity.  

Table 152 - CONSOL<mode> parameters General (CONSOL_L, CONSOL_U) and by commodity 

group. 

 

In each BuildChainxx.ctl or ChainChoixx.ctl the control parameter INCL=points to the right values 

depending if xx (the commodity group number) has a value that differ from general values (value in table 

different from -1). In all the other cases, the general values will be used.  

To manage the different cases the following process is in place: 

• From BuildChain_CONSOL, commodity by commodity, it is determined if special values are applied checking how many -1 

are present under CONSOL_LXX and CONSOL_UXX. If the count of -1s sums to 29 it means default values must be used. 

• If default values must be used under BuildChainxx.ctl INCL=BuildChain_Common.ctl will be included, otherwise 

INCL=BuildChain_Special.ctl will be present and under BuildChainxx.ctl it will be present the section for modified Lower and 

upper bound; 

• Similarly to BuildChain, Chainchoixx.CTL will have INCL=ChainChoi-Common.ctl if default values must be used, while 

INCL=ChainChoi_Special.ctl will be present and under ChainChoixx.ctl all values for lower and upper bound will be included.  

• BuildChain_Special.ctl and ChainChoi_Special.ctl just exclude the section with default values for lower and upper bound.  

For instance, commodity group uses default values, so we have: 

 

And BuildChain_Common.ctl looks like: 

ID M
O
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1 A 0.2 0.5 Road 1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 Default

2 B 0.2 0.5 Road 1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 From Default

3 c 0.2 0.5 Road 1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 Commodity Specific

4 C 0.2 0.5 Road 1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

5 S 0.3 0.7 Road 1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

6 X 0.3 0.7 Road 1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

7 d 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

8 D 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

9 E 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

10 F 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

11 f 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

12 G 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

13 h 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

14 H 0.8 1 Rail 2 -1 -1 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 0.98 0.8 0.98 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

15 i 0.8 1 Rail 2 -1 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

16 I 0.8 1 Rail 2 -1 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

17 T 0.8 1 Rail 2 -1 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

18 U 0.8 1 Rail 2 -1 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 0.8 -1 0.8 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

19 J 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

20 K 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

21 L 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

22 M 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

23 N 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

24 O 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

25 P 0.2 0.9 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

26 Q 0.2 0.9 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

27 V 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

28 W 0.1 0.6 Sea 3 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1

29 R 0.2 0.8 Air 4 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1
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Commodity group 2 uses special values, so under BuildChainxx.ctl we have: 

 

And BuildChain_Special.ctl misses section with lower and upper bound: 

 

6.4. Control files revision for ASEK calculation 

In the current implementation (v1.2.2) the ASEK calculation requires to rerun LP2CC.exe (last step for RCM) 

with the original set of costs and parameters (saved under Logmod\Input_CBA) and a different INTEREST 

and STUFF values. Instead of recreating the control parameters (CTL) for ChainChoi, the control setup has 

changed in the following manner: 
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• In ChainChoi_Common.ctl a new control parameter ASEK=..\Input_CBA will redirect the reading of 

the input data from Input folder to Input_CBA folder (e.g. the control file will contain always Input 

folder, in CBA analysis the folder name will be replaced by ASEK name) 

• A second control parameter is OTHERCOST=..\Input\COST\OtherCostMatters.txt that points to the 

file that contains INTEREST and STUFF values 

• A new file resides under LOGMOD\INPUT\COST\OtherCostMatters.txt and 

LOGMOD\INPUT_CBA\COST\OtherCostMatters.txt respectively. The first with values for Standard 

Logistic Module and RCM, the second for the specific calculation of CBA. 

6.5. Maximum Speed on Road Mode 

The speed limits for road vehicles can be specified in the MAX_SPEED attribute under 

Input_Data.mdb\Vehicles_parameters_PartA_{ScenarioName}. 116 km/h is the defined speed limit as it 

has been identified as the maximum speed in current network.  

In Table 153 the maximum of Speed_1 (vehicle 101) and Speed_2 (vehicles 102 to 106) from the current 

network is shown, grouping by Modestr. As can be seen, road modes c, a, b and B have the maximum speed 

116 km/h in Speed_1 and 110 km/h in Speed_2. 

Table 153 - Maximum speed in current network 

SPEED_1 SPEED_2 MODESTR 

90 0 x 

50 50 xabBc 

116 95 xabc 

110 110 xac 

76 0 xd 

40 0 xdfFhitDIH 

50 0 xdfFhitu 

50 0 xdfFhituDIH 

75 0 xdfh 

112 0 xdfhi 

91 0 xdFhit 

64 0 xdFhitu 

96 0 xdFht 

50 0 xdh 

122 0 xdhi 

91 0 xdhit 

64 0 xdhitu 

55 0 xfFh 

94 0 xfh 

81 0 xFhi 

85 0 xFhit 

92 0 xh 

121 0 xhi 

40 0 xhitu 

49 0 xhtu 

40 0 xp 

25 0 xpq 

600 0 xr 

12 0 xy 

12 0 xyz 
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The MAX_SPEED has been included in the input table as a new attribute and the implementation of 

constraints in maximum speed within the road assignment under Samgods model assignment and RCM 

assignment. 

6.6. Capacity constraints on sea mode 

There are two different mechanisms in place for the sea mode to limit the usage of some services and ports: 

A. Constraints applied at network level (e.g. by link level, as for the Kiel Canal example, see Figure 

4). This are managed at the BuildChain step and applies only to the type vehicle. Should a too 

large vehicle be used as type vehicle, any path using the link cannot be used. As described below 

this is managed by removing links with too low capacity before running the LOS-calculations for 

the type vehicle. 

B. Constraints applied in the evaluation of alternatives during ChainChoi process (as per the Vänern 

Lake). When evaluated at the ChainChoi-level the generated alternatives may be generated with a 

too large vehicle, but at this level only the vehicles small enough will be allowed. As described 

below this is managed by using a port capacity limit in lake Vänern for the allowed vessel capacity 

in the Vänern ports (otherwise the paths would have to be scrutinized after the LOS-calculations 

which is possible but not efficient). 

In the following two paragraphs will be discuss their implementation in the model. 

6.6.1. Capacity constrains in Kiel Canal 

To apply capacity constraints on network level different actions have been performed: 

• provided the information of which Dwell Capacity is allowed in Kiel Canal 

• compared the capacity of the vessel type with the allowed capacity in the Kiel Canal 

• removed the Kiel Canal as available link when skimming the LOS matrices for sea 

The first point required a modification on the input network: 

• Modified for the links 551679-550658 and 550658-551679 the mode attribute allowing all the vessel types ("xyzpq") 

Coded in UL3 field the maximum dwell capacity of 20.000 tonnes. 
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Figure 4 - The Kiel canal link. 

The second and third point has required a change in the scripting related the network handling and LOS 

calculation: 

1. when setting up the network attributes (Network step 6 under LOS Calculation > Sea application). 

The vessel capacity from vehicle parameter table (red file in the picture) is read via a Lookup 

command: 

LOOKUP LOOKUPI=1 NAME=SEA_COST, 

  LOOKUP[1]=VEH_NR, RESULT=KM_COST, ; KM_COST (distance cost in SEK) 

  LOOKUP[2]=VEH_NR, RESULT=HOURS_COST, ; HOURS_COST (Vot in SEK) 

  LOOKUP[3]=VEH_NR, RESULT=SPEED,  ; Speed for vehicles classes 1-17 

  LOOKUP[4]=VEH_NR, RESULT=CAPACITY ;capacity for vessel - to compare with UL3 

The capacity per each vehicle type (denoted as @MATRIX.N_VEHICLES@) is compared in the script with 

the capacity coded in the network (LI.1.UL3). If the vessel capacity is greater than the link capacity, the link is 

marked with a new attribute CLOSED=1: 

IF(LI.1.UL3<SEA_COST(4,@MATRIX.N_VEHICLES@)&&LI.1.UL3<>0);comparison between vessel capacity and 

canal capacity coded in UL3 

CLOSED=1 

ENDIF 

2. During the LOS calculation (Highway step 7 under LOS Calculation > Sea application) 

The information of which links must be closed has recorded in the network attribute CLOSED=1 previously 

generated in the Network program. Using an IF statement, all the links marked as closed are added to 

GROUP=1. GROUP is an array available inside the HIGHWAY program to mark group of links and used for 

different purposes, in this case to exclude those links from the path calculation. 

IF(LI.CLOSED=1) ADDTOGROUP=1 
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In the phase ILOOP, when generating the paths, the keyword EXCLUDEGROUP filter the available links 

excluding those on group 1.  

PATHLOAD PATH=LW.SEA@MATRIX.N_VEHICLES@, 

    MW[1]=PATHTRACE(LI.UL2), 

    MW[2]=PATHTRACE(LI.T0_SEA@MATRIX.N_VEHICLES@), 

    MW[3]=PATHTRACE(LW.SEA@MATRIX.N_VEHICLES@), 

    MW[4]=PATHTRACE(LW.EXTRACOST@MATRIX.N_VEHICLES@), 

    MW[5]=PATHTRACE(LW.DDIST@MATRIX.N_VEHICLES@), EXCLUDEGROUP=1 

 

6.6.2. Capacity constrains in Vänern Lake 

Some issues have been detected when applying the method described in the previous paragraph to Vänern 

Lake: 

• the method limits the available choices with connectivity described in the LOS-matrices 

• the LOS-matrices are fully applied in ChainChoi procedure for all vehicles. In the BuildChain 

procedure only the "typical" vessel is applied 

• if there are no paths built for the "typical" vessel, no solution would be available for the evaluation 

• for the Kiel Canal that has not represented a problem since there is an alternative path not using the 

canal, but for Vänern Lake there is only one path in and out from Vänern. Since the appointed 

"typical" vessel does not comply with the capacity limits there is not any available connection, and 

therefore the chain is not constructed. Consequently, ChainChoi cannot at the succeeding stage select 

an appropriate vessel for the OD-leg through Vänern canal. 

The solution applied is therefore the following: 

• in the BuildChain stage the values for MaxDwtContainerVessel(Tonnes), MaxDwtRoroVessel(Tonnes) and 

MaxDwtOtherVessel(Tonnes) are unconstrained (e.g. 9999999) 

• in the ChainChain stage the values for MaxDwtContainerVessel(Tonnes), MaxDwtRoroVessel(Tonnes) and 

MaxDwtOtherVessel(Tonnes) are specified as 4001 tons (limit for ports in the lake). 

The solution has required: 

• changes in input data (Nodes_Base2019) table adding the VanernCan attribute (with ton limits for each port in port area 14) 

• A new set of attributes under nodes.txt table is used in ChainChoi CC_MAXDWTCONV, CC_MAXDWTRORV and 

CC_MAXDWTOTHV with values present under VanernCan 

• When running BuildChain it will be used MAXDWTCONV, MAXDWTRORV and MAXDWTOTHV values 

• When running ChainChoi it will be used CC_MAXDWTCONV, CC_MAXDWTRORV and CC_MAXDWTOTHV values 

6.7. Rail Capacity Management procedure 

For a detailed description of Rail Capacity Management procedure see reference Fel! Hittar inte 

referenskälla.. Here, we will describe the implementation in the Cube Interface, and the flow chart of 

information in each step of the procedure.  

As a general concept the RCM procedure is an iterative process that: 

• starts from the results obtained from the Standard Logistics Module 

• uses some extra input files placed under LogMod\RCM folder 

mailto:LW.DDIST@MATRIX.N_VEHICLES@
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• sets up a linear programming problem that will generate viable alternative solutions in each iteration (compared to the best 

solution from standard logistics module). Should not any new alternative solutions be generated we are at the optimum! 

• produces a new set of output files in terms ChainChoiNN_01LPX.out solutions to set up new OD matrices for empties and 

loaded vehicles  

• the number of iterations is controlled by the user (setting up the related catalog key "Maximum number of loops for Linear 

Programming process (LP)")  

All the steps could be summarized in Figure 5. 

 

Figure 5 - Flow chart of the logistics model and RCM. 

6.7.1. LP0 step 

LP0 steps corresponds to point 2.2. in Figure 5. This process invokes four different steps with the following 

purposes: 
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• Step 1: all the results from the Standard Logistics Module, including spanning tree data for the railway paths to allow for link 

load calculations, are merged together in some extra input files for construction of the standardized MPS-formatted file 

LP_Rail_LP0.MPS. This is the file with all the variables and equations in the linear programming problem with the proper 

format for LP_Solve.exe program. The MPS.jar program is called from Cube with its control file mps_LP.ctl that contains all 

the input and output files (locations and names), and control parameters in the related batch file (JCMW). We refer to the 

documentation of the Java-program mps.jar for further details, please see reference Fel! Hittar inte referenskälla.. 

• Step 2: the external linear program solver software is called to solve the LP problem and produces the LP_Rail_LP0.out file 

• Step 3: reads the LP_Rail_Lp0.out files and extract information about marginal costs for active capacity constraints. These 

are summarized into marginal costs per railway path using the spanning tree data and placed into marginal cost matrices 

(Vxxx_MC.314). ChainChoi solutions are assembled from the LP-solution and placed into approximate firm-to-firm solution 

files (ChainChoiNN_02LPX.out). f2f-solutions split into two or more alternatives are split exactly according to the LP-

solution, without a detailed recalculation of the costs. 

• Step 4: From the ChainChoiNN_02LPX.out files the extract procedure is used to estimate a new set of OD matrices for 

empties and loaded trains (also for tonnes but that is not needed) for all the train types.  

In Figure 6 the file naming and flow chart representing the process is shown. 

 

Figure 6 - LP0 process: input and output data and processes involved, where XXX is vehicle number 

3 digit format and NN is the commodity group number. 

The requested input data, apart from the ones produced by the Standard Logistics Module, is produced in 

different steps of the Samgods application: 

1. PathTreeRail.txt: this file contains spanning tree data (reference Fel! Hittar inte referenskälla. 

(Appendix C) for details on the structure) that represents all the possible paths from each origin to 

each destination present in the rail network. This is produced during the LOS calculation for Rail 

under Samgods Model > LOS Calculation > Rail application in Highway steps #6 and #9. This is not 

a standard output for Voyager software since it is a customization required by Trafikverket. The 

instructions for the proper installation are given in the User Manual. First batch file 0_Compact.bat 

transform spanning tree data to compact format (extension cmp). 

2. Nodes_List.txt and Links_List.txt: List of nodes and links in the network both with emme and 

voyager number systems and primary key (Internal_node_number) per each element. They are 

produced under Samgods Model > LOS Calculation > Data Preparation > Data for RCM at steps #2 

and #3. These are necessary because the backtracking of the paths utilize the mapping between these 

two sets of nodes and links, respectively. 
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3. RailLinkCapacitiesBidirectional_STD.dat: this is the translation in String format (ascii) of the 

Rail_Capacity_{SCENARIO_SHORTNAME} table for the specific scenario. The file is produced 

under Samgods Model > LOS Calculation > Data Preparation > Data for RCM at steps #4. 

The output files from the process are presented in Table 154.  

Table 154 - Output files from LP0, where XXX is vehicle type 3 digit format. 

Output file Description 

RCM\JLISTA.dat List of transport chain solutions from all the commodity 

groups and definition of super index, e.g. a primary key for 

each solution. This primary key will be referred to in the MPS 

file 

RCM\ColumnData\ColGen2LPNN-1.dat  Intermediate file 

RCM\ColumnData\LP_RailNN.dat Intermediate file 

RCM\LP_Rail_defs.dat Computed data for the constraints in the Linear programming 

problem 

RCM\LP_Rail_LP0.MPS Linear Programming problem in MPS format that will be 

solved by LP_Solve.exe program 

RCM\LP_Rail_LP0.out  Results of linear programming problem solution in 

LP_Solve.exe format 

INPUT\LOS\vXXX_MC.314  Marginal cost matrices for V201, V202, ..V212 (only rail 

mode). 

ChainChoi\OUTPUT\ChainChoiNN01LPX.out Transport chain solutions produced 

6.7.2. LP1 step 

LP1 steps corresponds to point 2.3 in Figure 5. This process invokes the same four steps as LP0 but with two 

extra steps as shown in Figure 7: 

• Step 1: run BuildChain.exe and ChainChoi.exe programs (Column generation model). These are special runs of the logistics 

modules BuildChain and ChainChoi that only operates on the transport relations defined in JLISTA.dat (the ones initially 

using railway). They are used for computing a new first best solution given the updated marginal costs. The modules are run 

with the same conditions as in iteration 3 of Standard Logistics Module in which a large number of endogenously generated 

input data, such as consolidation factors and volumes, are left unchanged.  

• Step 2, 3, 4 and 5: same steps 1, 2, 3 of LP0 
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Step 5: convergence check to establish if the process should be iterated further or can be stopped. The 

number of iterations is controlled by “Maximum number of loops for Linear Programming process (LP)". The 

output files from the process can be seen in Table 155. 

 

Figure 7 - LP1 process: input and output data and processes involved. 

Table 155 - Output files from LP1, where XXX is the vehicle type 3 digit format and NN is the 

commodity group number. 

Output file Description 

ChainChoi\OUTPUT\ChainChoiNNRCM.out  Transport chains in column generator process 

RCM\ColumnData\ColGen2LPNN-2.dat  Intermediate file 

RCM\ColumnData\LP_RailNN-2.dat Intermediate file 

RCM\LP_Rail_LP1.MPS Linear Programming problem in MPS format that will be solved by 

LP_Solve.exe program 

RCM\LP_Rail_LP1.out  Results of linear programming problem solution in LP_Solve.exe format 

INPUT\LOS\vXXX_MC.314 (over-writing previous files) Marginal cost matrices for V201, V202, .V212 (only rail mode). 

ChainChoi\OUTPUT\ChainChoiNN01LPX.out (over-writing 

previous files) 

Transport chain solutions produced 

 

6.7.3. Final process (FIN) 

The final results of Rail Capacity Management saved in ChainChoiNNLPX.out files are read and rewritten to 

the final solution files ChainChoiNNXTD.out, where NN is commodity group number, shown in Figure 8. In 

theory only the split solutions from the LP model should be modified in this process, but marginal changes in 

transport costs and total costs occur in many places. The output files from the process are presented in Table 

156. 
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Figure 8 - Final process: input and output data and processes involved. 

Table 156 - Output files from FIN process. 

Output file Description 

ChainChoi\OUTPUT\ChainChoiNNXTD.out  Final transport chain solutions with STD 

Logmod format 

ChainChoi\OUTPUT\ChainChoiNNXTD.fac Aggregate report on load factors for commodity 

NN 

ChainChoi\OUTPUT\ChainChoiNNXTD.rep Aggregate report on costs, tonne volumes, 

transport statistics etc. for commodity NN 

ChainChoi\OUTPUT\ChainChoiNNXTD.cst detailed cost log for commodity NN for selected 

cases 

 

6.8. Rail Assignment 

6.8.1. Capacity constraints 

In current implementation the process is not used since optimization lead in LP0 and 1 do not require any 

further balancing. It is kept here for reference. 

To distribute empty trains according to an assignment including options to distribute the empty train routes 

while considering generalized time, marginal cost and on top of that capacity constraints the following 

assignment model has been coded in Highway assignment: 

𝒎𝒊𝒏 ∑ ∑ (𝒓𝒆𝒈𝒖𝒍𝒂𝒓 𝒄𝒐𝒔𝒕𝒔)𝒍𝒊𝒏𝒌𝒔 ∗ (𝒆𝒎𝒑𝒕𝒚 𝒕𝒓𝒂𝒊𝒏𝒔 𝒇𝒍𝒐𝒘𝒔) + ∑ 𝑷𝒆𝒏𝒂𝒍𝒕𝒚(𝒐𝒗𝒆𝒓𝒍𝒐𝒂𝒅)𝒄𝒂𝒑𝒂𝒄𝒊𝒕𝒊𝒆𝒔𝒕𝒓𝒂𝒊𝒏 𝒕𝒚𝒑𝒆𝒔   

       (5.1) 

where: 

• Penalty(overload): an optional function for penalizing loading above capacity 

• Costs: costs specified in vehicle parameters and network (operational costs, taxes, tolls and extra costs) 

• Overload: total bidirectional trains minus bidirectional capacity  

The penalty function used in the equation (5.1) is: 

𝑷𝒆𝒏𝒂𝒍𝒕𝒚(𝒐𝒗𝒆𝒓𝒍𝒐𝒂𝒅) = 𝟏𝟎𝟎𝟎𝟎 × (𝒎𝒂𝒙[𝟎, (∑ ∑ (𝒆𝒎𝒑𝒕𝒚 𝒂𝒏𝒅 𝒍𝒐𝒂𝒅𝒆𝒅 𝒕𝒓𝒂𝒊𝒏 𝒇𝒍𝒐𝒘𝒔)𝒅𝒊𝒓𝒆𝒄𝒕𝒊𝒐𝒏𝒔𝒕𝒓𝒂𝒊𝒏𝒕𝒚𝒑𝒆𝒔 −

𝒄𝒂𝒑𝒂𝒄𝒊𝒕𝒚])
𝟐
(5.2) 

The Assignment method described above is formulated as system optimization instead of user equilibrium. 

The first formulation is not applicable in Voyager scripting; therefore the optimal solution has been 

reformulated as: 

INTEGRAL(0,Q) t(q)dq = [T(q)]0
Q = T(Q) – T(0) = T(Q). 

where: 

• t(q) = vd-function 
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• T(q) = the primitive function of the vd-function 

Thus, by using as vd-function the derivative of the penalty function: 

𝑽𝒅𝒇(𝒐𝒗𝒆𝒓𝒍𝒐𝒂𝒅) = 𝟐 × 𝟏𝟎𝟎𝟎𝟎 ×

(𝒎𝒂𝒙[𝟎, (∑ ∑ (𝒆𝒎𝒑𝒕𝒚 𝒂𝒏𝒅 𝒍𝒐𝒂𝒅𝒆𝒅 𝒕𝒓𝒂𝒊𝒏 𝒇𝒍𝒐𝒘𝒔)𝒅𝒊𝒓𝒆𝒄𝒕𝒊𝒐𝒏𝒔𝒕𝒓𝒂𝒊𝒏𝒕𝒚𝒑𝒆𝒔 − 𝑪𝒂𝒑𝒂𝒄𝒊𝒕𝒚]) 

       
   (5.3) 

and integrating over flows from 0 to Q (=all flows on the link), we obtain an objective value equal to the 

system optimal value for the penalty function term. 

The proposed assignment method has been implemented in the highway program via the following steps: 

• the bidirectional volumes for each rail link with capacity are stored in one array where the dimension is the ID_LINK from 

capacity table 

• in the adjust procedure, when the times are corrected based on the vdf functions, two functions are applied: 

• for all rail links that have no capacity (e.g. 0) the fix time derived from vehicle parameters is applied 

• for all rail links with specified capacity, the bidirectional flows stored in the array are retrieved and compared to the capacity, 

if overcapacity the vdf function specified in (5.3) is applied 

• the volumes are averaged along the iterations using the MSA algorithm (CONVERGENCE=AVE). 

6.8.2. Domestic flows allowed only on domestic links 

In current implementation the process is not used since revision of network has made redundant this feature. 

To avoid unrealistic routes for domestic flows (e.g. where the origin and destination are inside Sweden and 

foreign railway links are used for empty flows) a designated procedure has been put in place. The procedure 

works in the following manner: 

• a dummy matrix containing information if an OD is domestic or not is used to filter the demand matrix 

• two different classes (domestic flows and all the others) are provided to the assignment 

• in the LINKREAD phase (when all the variables for the assignment are specified) an IF statement is used to add to group 10 all 

the non-domestic links (similar technique used also in Kiel Canal) 

• in the ILOOP phase (when all the possible paths are constructed) two different sets of paths are produced: 

• the first set has the input matrix containing only the domestic flows and the links on group 10 are excluded (using 

EXCLUDEGROUP=10) statement in PATHLOAD commend 

• the second set uses the matrix with all the other flows and all the links are open in the network (no EXCLUDEGROUP is coded 

for 10). 

6.9. Other Calibration procedures  

6.9.1. Forbidden over-seas ship transports to domestic small ports 

In current implementation the process is not used since revision of network has made redundant this feature. 

It is included as potential tool. 

To prevent over-seas transport to enter selected small ports in Sweden in the LOS matrices the combination 

of OD from/to transoceanic ports is entered with a high impedance. 

The following changes have been made in the model: 

• The table "PortNodes" has been updated with a new field: TransOceanFac. Ports having the value 

equals 10 are small ports in Sweden (74 ports) 
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• In the Sea application, under LOS calculation, Adding logic has been inserted in step 3 of the 

MATRIX procedure. Its function is to read the PortNodes table to identify small ports and to read the 

Transoceanic factor. Furthermore, it sets a dummy matrix with scaling factors that will be applied in 

the next Highway step. The details of calculation are: 

TransOceanL='1075-1099' ;range of zones that represent the transoceanic ports 

JLOOP 

OrigZone=Renumber(1,I) ; origin zone number in emme format 

DestZone=Renumber(1,J) ; destination zone number in emme format 

OrigFactor=TransOceanic(1,OrigZone) ; origin factor from port definition table (-1 means is not a port)  

DestFactor=TransOceanic(1,DestZone) ; destination factor from port definition table (-1 means is not a port) 

 

;not transoceanic  

IF((INLIST(I,TransOceanL)=0)&&(INLIST(J,TransOceanL)=0)) ;if both the ports are domestic no factors are applied 

MW[1]=1 ;no factor 

ENDIF 

 

IF((INLIST(I,TransOceanL)=1)||(INLIST(J,TransOceanL)=1)) ;if one of them is transoceanic the final factor is the 

multiplication of factor in origin and factor in destination 

MW[1]=(1+OrigFactor)*(1+DestFactor) 

ENDIF 

ENDJLOOP 

• In the Sea application, under LOS calculation, the HIGHWAY step 7 reads the dummy matrix 

produced with the previous step and applies the factor to the TIME skim:  

MW[200]=MI.1.1 ;LOS factor 

MW[2]=MW[2]*MW[200] ;apply los factor 

 

6.9.2. Rescaling factors for LOS matrices in sea mode 

The rescaling factors are produced by the cycling process and they are used to rescale the TIME skims 

applying a factor that varies per port area and commodity group.  

Their implementation and calibration have required several steps in various parts of the model. They are: 

• a revision of Nodes table including information of PORTAREANR 

• a revision of nodes.txt file including information of PORTAREANR 

• a new routine in BuildChain.exe and Chainchoi.exe that reads the scaling factors and holds in memory the rescaled values for 

the following LOS matrices: 

• V301_timeh.314, ..., V322_timeh.314 LOS  

• The time value is rescaled for each OD applying the combined factor from port area in origin and destination and commodity 

group. An example is shown in Table 157. 
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• the program uses the input Table CalibrationParameters placed under 

Input\Calibration\Input_data_calibration_{Scenario}.mdb.  

• Under the Parameters Calculation application the scaling factors are re-estimated by comparing the port statistics per port 

area and commodity group with model values. The values are adjusted based on the results. The function applied is as follow: 

 If (Abs(Diff) < 100) Then ; if the difference between modelled and statistics is less than 100 tons (DIFMAX) 

  Adjust = factor    ; the previous value is maintained  

 End if 

  If (Diff < 0) Then   ; if the difference is a negative value it means we have to reduce the factor (that is an impedance) 

   Adjust = factor - 0.05 ; new factor = previous factor -0.05 (STEP) 

   If (Adjust < 0.01) Then  ; if the adjust factor is less than 0.01 (MINVAL) 

    Adjust = 0.05   ; is set to a minimum value 0.05 (VAL0) 

   End If 

  Else      ; if the difference is a positive value it means we have to increase the factor (that is an impedance) 

   Adjust = factor + 0.05 ; new factor = previous factor+0.05 (STEP)  

  End If 

 End If 

• The parameters that control the process are: 

• DIFMAX: maximum difference between modelled and statistics (100 means 100 tons) 

• STEP: the value that will use to increase the factor 

• MINVAL: boundary value to evaluate small or negative factors. if Adjust <= MINVAL then Adjust = VAL0 

• VAL0: reset value used if the function goes negative  

• All of them could be revised modifying the table Parameters_portcalibration.dbf, see Table 158. 

• The statistic used for the comparison is {CATALOG_DIR}\05_Input_Data\Input_Data.mdb\Port_statistics  

Table 157 - Example on rescaling calculation for LOS sea mode. 

Orig Dest TIMEH 

Origin weighting factor 

(Commodity group 1) 

Destination weighting factor 

(Commodity group 1) 

Final 

value 

Final 

TIMEH 

718021 718121 10.067336 1.1 1.1 1.21 (1.1*1.1) 12.18148 

718021 718221 0.637215 1.1 1.1 1.21 0.77103 

718021 718821 9.59218 1.1 1.1 1.21 11.60654 

718021 719221 7.884646 1.1 1.1 1.21 9.540422 

718021 730521 12.73721 1.1 1 1.1 14.01093 

718021 731921 11.457068 1.1 1 1.1 12.60277 

718021 738221 9.061406 1.1 1 1.1 9.967547 

718021 738222 9.066202 1.1 1 1.1 9.972822 
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Table 158 - Parameter to control the revision of scaling factors. 

ID STEP MINVAL DIFMAX VAL0 

1 0.02 0.01 100 0.02 

The set of matrices per commodity group are provided to the Logistics Module and Rail Capacity 

Management procedure specifying a different LOS folder in the BuildChainXX.ctl and ChainChoi.ctl control 

files, an example for commodity 01 could look like: 

INCL=buildchain_common.ctl 

COMMODITY=01 

VHCL=..\Input\Cost\vhcls_dry_bulk.txt 

LOSDIR=..\Input\LOS\S01 

PWC={CATALOG_DIR} _150307\01_Programs\LogMod\Input\PWC\2030\PWC_01.txt 

6.9.3. Rescaling factor for Kiel Canal 

A similar procedure to the one described in section 6.9.2 has been applied to toll on Kiel Canal. 

Its implementation has been developed as follow: 

• An initial scaling factor is provided using the table “KielCanal_Parameter_Base2019” under 

Input_data_Calibration_Base2019.mdb. The table can be selected in each scenario using the catalog key " Starting value for 

scaling factor on Kiel canal" 

• Under "LOS calculation > Data preparation" the application Network step 17 takes this value and rescale the TOLL value for 

each vessel type: 

TOLL301=LI.1.TOLL301*parKiel(1,@LOOP_CAL@) 

 TOLL302=LI.1.TOLL302*parKiel(1,@LOOP_CAL@) 

 TOLL303=LI.1.TOLL303*parKiel(1,@LOOP_CAL@) 

 TOLL304=LI.1.TOLL304*parKiel(1,@LOOP_CAL@) 

 TOLL305=LI.1.TOLL305*parKiel(1,@LOOP_CAL@) 

where @LOOP_CAL@ represent the variable representing the current loop. 

• A new set of output LOS matrices has produced rerunning the LOS calculation for Sea Mode 

• Those matrices are subsequently rescaled for the scaling factors per port area and commodity group 

• Under Parameters Calculation application the scaling factor is re-estimated comparing the distribution of flows between Kiel 

Canal and North of Jylland (here is compared the percentage of the tons through Kiel Canal against those going north of 

Jylland) from the model results and statistics (present in 

{CATALOG_DIR}\05_Input_Data\Input_Data.mdb\Other_statistics table). The function applied is as follow: 

 If (Abs(Diff) < 100) Then ; if the difference between modelled and statistics is less than 100 tons (DIFMAX) 

  Adjust = factor    ; the previous value is maintained  

 endif 

  If (Diff < 0) Then   ; if the difference is a negative value it means we have to reduce the factor (that is an impedance) 

   Adjust = factor - 0.05 ; new factor = previous factor -0.05 (STEP) 

   If (Adjust < 0.01) Then  ; if the adjust factor is less than 0.01 (MINVAL) 
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    Adjust = 0.05   ; is set to a minimum value 0.05 (VAL0) 

   End If 

  Else      ; if the difference is a positive value it means we have to increase the factor (that is an impedance) 

   Adjust = factor + 0.05 ; new factor = previous factor+0.05 (STEP)  

  End If 

 End If 

• The parameters that control the process are: 

• DIFMAX: maximum difference between modelled and statistics (2 means 2%) 

• STEP: the value that will use to increase the factor 

• MINVAL: cut off value to evaluate small or negative factors 

• VAL0: reset value used if the function goes negative  

• All of them could be revised modifying the table Parameters_kielcalibration.dbf, see Table 158. 

• The statistic used for the comparison is {CATALOG_DIR}\05_Input_Data\Input_Data.mdb\Other_statistics table 

6.10. Samgods Parallelization Module 

The purpose of the Samgods Parallelization Module is to speed up the execution process by using 

parallelization. This is done by splitting up the workload of two or several independent program calls from 

running on one processor in a sequence to run on several processors in parallel. 

Initially the module sorts the workload of program execution steps from the longest runtime to the shortest, 

then starts executing the program steps given the priority from the sorted list. The program steps are 

executed in parallel until the number of simultaneous executions have reached a specified limit given by the 

user. Each time one program step has finished, the module tries to run the next program step on the list. In 

the end of the process the module returns after having checked that all steps in the original program call 

sequence did finish. 

The input to the program is three input files with fixed file names:  

• “execution_times.txt",  

• "runall.bat"  

• "NR_OF_PROGRAM_INSTANCES.TXT”.  

The file name runall.bat may be altered and overrun with the first expression in the parameter list of the 

module.  

6.10.1. The input files 

• “execution_times.txt”: This file gives the information the module needs to sort list of execution steps. The input in this file has 

two pieces of information per row. One is a reference to the program call to be run and the other one is the estimated runtime 

for that program to finish. Semicolon is used as a delimiter. 

• “runall.bat”: This file contains the sequence of program calls to be executed. The parallelization module interprets two 

keywords namely call and rem. If the line starts with call the module reads the line and if the line starts with rem the module 

jumps to the next line. After the word call the name to the file to be called by the OS is found and lastly the parameter passed 

to the file to be called (this is the reference number to the execution times mentioned above.) It may look something like this: 

“call commodity 10”. 
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• “nr_of_program_instances.txt”: This file contains one number that tells the module how many program steps that could be 

ran simultaneously. It is good practice to set this number to less or equal the number of processors available for execution on 

the CPU or Server used. (One limiting factor may also be the available memory.) 

6.10.2. Controlling the execution 

After having read the input files and sorted the list of program steps, the module writes a batch file for all 

steps that are associated with a corresponding stop file. Each batch file contains the call that where originally 

found in “runall.bat”. The last line in each batch file has a command to delete the corresponding stop file. For 

the module to know that a particular program step has finished, frequently checks are made if the associated 

stop file still exist or not. If it does not, the module tries to run the next program execution step on the list. If 

there are no steps left to run and there are no stop files left, the execution finishes and returns. 
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7 Programs and licenses required 

7.1. Programs 

7.1.1. Cube software 

For the Samgods GUI to function, certain Cube software is required. They are: 

• Cube Base: 6.4.5  

• Cube Voyager: 6.4.5  

• Cube GIS: ArcGIS 10.6  

This software is available at  

• http://citilabs-website-resources.s3.amazonaws.com/release/cube645setup.exe 

7.1.2. JAVA software 

• Java runtime environment (jre). Platform: 1.6. Product: 1.6.0_17 (later program versions are also possible to use) 

• Java virtual machine Windows x64 

Location for the above programs:  

• http://www.java.com/sv/download/ or http://download.oracle.com/otn-pub/java/jdk/7/jre-7-windows-x64.exe 

• http://www.oracle.com/technetwork/java/javase/downloads/java-se-jre-7-download-432255.html 

7.1.3. LP solver software 

The linear program solver is an external program. Currently the solver is CLP. It is a 64-bit version of the 

linear programming optimizer built in June 2018 with C++ in Microsoft Development Studio. For more 

information, please consult https://projects.coin-or.org/Clp. Microsoft Visual C++ Redistributable for Visual 

Studio software might be required. The 64 bit version is required since tests with the 32-bit version of CLP 

resulted in failures for larger problems (recoding of CLP could have solved the problem). 

7.1.4. Licence requirements 

• Cube software 

For the above Cube software, Citilabs License 2019 is required (but newer software and license versions may 

be available later on).  

• JAVA software 

No licences are required. 

• CLP64 

Eclipse Public License (EPL). No licences are required. 

  

http://citilabs-website-resources.s3.amazonaws.com/release/cube645setup.exe
http://www.java.com/sv/download/
http://download.oracle.com/otn-pub/java/jdk/7/jre-7-windows-x64.exe
http://www.oracle.com/technetwork/java/javase/downloads/java-se-jre-7-download-432155.html
https://projects.coin-or.org/Clp
http://www.opensource.org/licenses/eclipse-1.0
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