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Introduction

1 Introduction

This technical document is written for Trafikverket in order to help users to perform analysis with the
Samgods GUI. It contains a technical description of each element of the model in terms of input data and
output data, procedures and methods applied.

The Samgods GUI forms an integrated interface for several external programs developed along the years.
They are related to the Standard Logistics Module and Rail Capacity Management Module. For details on the
external programs, their control files and their usage and meaning of input and output, we refer to their own
technical documentation listed in chapter 8. The focus is on the logistics model for Sweden. The
documentation is not written for programmers in the first place, but for the users of the model.

The document has the following structure:
Chapter 2: The file structure

Chapter 3: Input and output files reference
Chapter 4: Description of model structure
Chapter o: Description of applications
Chapter 6: Methods applied in the model
Chapter 7: Programs and licenses required
Chapter 8: References

List of contributors:

Gabriella Sala SYSTRA Developer of GUI and model setup and co-author of the
technical documentation
Shan Li Sweco Reviewer of the technical documentation version 1.2.1
Daniele Romano Citilabs Co-author of the technical documentation of version 1.2
Henrik Edwards Sweco Developer, tester and specialist of the logistics module and
RCM module
Petter Hill The Swedish Project Manager
Transport
Administration
Joar Lind The Swedish Developer and tester of version 1.2
Transport

Administration



1.1. Glossary

Below some important glossaries used in this manual are collected. Observe that for some glossaries the
explanation is specific for this context.

BuildChain - Build Chain procedure associated to BuildChain.exe program

ChainChoi - Chain Choi procedure associated to ChainChoi.exe program
ConsolidRateMode — Consolid Rate Mode procedure associated to ConsolidRateMode.jar
consol - consolidation

Extract - extraction procedure of tonnes, empty and loaded vehicles matrices associated to extract.exe
program

LogMod or STD - Standard Logistics Module
MAT - extension for matrix file produced in Cube (binary format), referred also as Voyager Matrix.

MergeRep - procedure to merge all .rep files produced by ChainChoi in a unique .rep file. Associate to
Mergerep.exe program

Mode - aggregate mode used in chains. See table A-2 2 for further details

MSA algorithm - Method of Successive Averages algorithm

ORIGCAP - Initial capacity in rail links provided with input capacity table

PWC matrices - Production Warehouse Consumption matrices

S/A user - Standard User / Advance User.

RCM - Rail Capacity Management Module

Submode - submode (vehicle type) used in mode. See table A-2 2 for further details
V/C — flow volume over capacity ratio for rail flows.

NORIG - the node number in Emme numbering format.

SCBSTANN - region code for Swedish zones and univocal number for the other countries.
Vessel or Vessel Type - vehicle type for sea mode

Vehicle type - type of vehicle described in the model. 5 types for road mode, 8 types for rail mode, 21 types
for sea mode and one for air.

VY - Voyager

Warm start - start the model from a defined LP solution instead of start from nothing.

.314 - extension for matrix file in Emme numbering format, e.g. format derived by EMME software
{CATALOG_DIR} - the directory where the .cat file is located

{SCENARIO_DIR} - the directory where the scenario folder is located

{SCENARIO_CODE} - the code associated to a specific scenario and specified during the creation under
scenario window

{SCENARIO_SHORTNAME} - the scenario name under the scenario tree present in scenario window



2 The file structure

The file structure for the model is shown in Table 1.

Table 1 - Folder structure of the model.

The file structure

Catalog Folder First Level Second Level | Third Level Fourth

Level

Description

{CATALOG_DIR} | SamGods.cat

Catalog file: main file to access to the

entire model

{CATALOG_DIR} | o1_Programs

Folder for the external programs
(LOGMOD and RCM). At this level
present
Samgods_Parallelization_Module.jar
and its input files. The other external
programs reside in subfolders. For full
list of files and understanding of
structure and programs please refer to
documentation for each program, for
example reference 1, reference 3 or

section 6.9.

{CATALOG_DIR} | o1_Programs LogMod

Folder and subfolders with
executables for different programs.
Executables are placed in respective

subfolders together with control files.
The files in LogMod folder are:

execution_times_LogMod.txt - run
time associated to each commodity.

Used in parallelize LogMod run

execution_times_ extract.txt - ID per
each vehicle type. Used to parallelize

extract procedure

Samgods_ Parallelization_Module.jar
- program to parallelize LogMod and

extract procedure

{CATALOG_DIR} | o1_Programs LogMod BUILDCHAIN

Folder containing executable files:

e BuildChain.exe - First
program of Standard
Logistics Module or
RCM

and control files:

e select.dat




The file structure

Catalog Folder First Level Second Level | Third Level Fourth Description
Level
for selection of detailed cost and
volume output. The following control
files:

e BuildChain_common.
ctl

e BuildChainNN.ctl

o logselect.dat

are produced by the model and saved

under scenario folder. Therefore they

are not present in the general folder.
{CATALOG_DIR} | o1_Programs LogMod ChainChoi Folder containing executable files:

e ChainChoi.exe -
Second program of
Standard Logistics
Module or RCM

e LP2CC.exe - Last
program in RCM to
derive the final
solution in Standard
Logistics module
format

e ConsolidRateMode.ex
e - third program of
Standard Logistics
Module

and a control file:
e Select.dat
for selection of detailed cost and
volume output.
The following control files:

e ChainChoi_common.c
tl

e ChainChoi_Special.ctl

e ChainChoiNN.ctl

are produced by the model and saved
under scenario folder, NN being the
commodity group number. Therefore
they are not present in the general
folder

{CATALOG_DIR} | o01_Programs LogMod EXTRACT Folder containing the executable file

extract.exe file to extract OD vehicles,




The file structure

Catalog Folder

First Level

Second Level

Third Level

Fourth

Level

Description

empty vehicles and tonnes in EMME
format are produced by the model and
saved under scenario folder. Therefore
they are not present in the general
folder

{CATALOG_DIR}

01_Programs

LogMod

INPUT

PWC\201
6

PWC\204
o

Different sets of PWC matrices.

The selection in the model is done via
catalog key {Year} catalog key " Year
of PWC matrices"

Each set marked with “Potential” has

transit volumes from/to Norway

{CATALOG_DIR}

01_Programs

LogMod

INPUT

PWC\201
6\VY_F

PWC\204
o\VY_F

PWC matrices in Voyager format.
Files present if PWC matrices has

been run

{CATALOG_DIR}

01_Programs

LogMod

INPUT

{CATALOG_DIR}

01_Programs

LogMod

Input

Locked

Folder containing the list of locked

solutions to use in each scenario:
e Locked_2017.dat
e Locked_2040.dat
e Locked_empty.dat

See user manual for further details on

those three files.

{CATALOG_DIR}

01_Programs

LogMod

LOG

Folder containing report files from
Logistics Module and RCM.

{CATALOG_DIR}

01_Programs

LogMod

MERGEREP

Folder containing the executable for

Mergerep procedure mergerep.exe

{CATALOG_DIR}

01_Programs

LogMod

RCM

Folder containing the executables

files:

e clp64.exe - free
software for linear
programming
problem

e  MPS.jar - executable
to prepare inputs for
Ip_solve.exe and to
extract results from
output

e SelectDirect.jar —
executable used to




The file structure

Catalog Folder

First Level

Second Level

Third Level

Fourth

Level

Description

perform select link
analysis

{CATALOG_DIR}

02_Applications

Main folder for all the applications

defined in the model

{CATALOG_DIR}

02_Applications

1_Editing

Folder for “Create the editable files”
and “Edit the data” applications

{CATALOG_DIR}

02_Applications

1_Editing

Capacity

Folder for the subgroup “Rail Capacity
Checks” in the “Edit the data”

application

{CATALOG_DIR}

02_Applications

1_Editing

Comparison

Folder for the subgroup “Compare
Nodes and Node_ terminals” in the

“Edit the data” application

{CATALOG_DIR}

02_Applications

1_Editing

Numbering

Folder for the subgroup “Numbering
System” in the “Edit the data”

application

{CATALOG_DIR}

02_Applications

1_Editing

Regions

Folder for the subgroup “Regions for
links” in the “Edit the data”

application

{CATALOG_DIR}

02_Applications

2_Run

Folder for the main application
“Samgods Model”

{CATALOG_DIR}

02_Applications

2_Run

Folder for the subgroup “Assignment”
in the “Samgods Model” and other

subgroups for this application:

e Conversion from
LogMod to VY

e Road Assignment
e Rail Assignment
e Sea Assignment

e Air Assignment

{CATALOG_DIR}

02_Applications

2_Run

Calibr

Folder for the subgroup “Parameters
Calculation” in the “Samgods Model”

application

{CATALOG_DIR}

02_Applications

2_Run

Costs_VY

Folder for the subgroup “LOS
Calculation” in the “Samgods Model”
and other subgroups for this

application:
e Data preparation
e Tax Calculation

e Road




The file structure

Catalog Folder First Level Second Level | Third Level Fourth Description
Level
e Rail
e Sea
o Air
e Conversion from VY-
matrices to LogMod-
matrices in emme
format
{CATALOG_DIR} | o2_Applications | 2_Run Ini Folder for the subgroup
“Initialization” in the “Samgods
Model” application
{CATALOG_DIR} | o2_Applications | 2_Run LogisticModVY Folder for the subgroup “Logistic
Module” in the “Samgods Model” and
other subgroups for this application:
e DPrepare data
e Prepare data second
part
e Prepare data third
part
e  Run the logistic model
e Save reports
{CATALOG_DIR} | o2_Applications 2_Run Results Folder for the subgroup “Results” in
the “Samgods Model” and other
subgroups for the application:
e Results 1.0
e Port Areas
e GIS maps by
commodity group
e Oresund Kiel and
Jylland
e Reports per
geographical
aggregation
{CATALOG_DIR} | 02_Applications | 3_Compare Folder for the “Compare” application
and subgroups:
e LOS matrices
e Assignment
{CATALOG_DIR} | o2_Applications 3_Compare OD_ matrices Folder for the subgroup “OD

matrices” inside “Compare” in the

“Samgods Model”

11




The file structure

Catalog Folder First Level Second Level | Third Level Fourth Description
Level
{CATALOG_DIR} | 02_Applications 4_Handling Folder for the main application
“Handling Scenario” and subgroups:
o Delete
e Compact
e Scenario export
e Model Export
e General tables
e Create the new base
e Create the new
scenario specific
tables
e Scenario import
{CATALOG_DIR} | o2_Applications | 4_Handling Original Folder with the empty catalog used as
template during the creation of a new
model
{CATALOG_DIR} | o02_Applications | 4_Handling Scenario_tables Folder with scenario tables used in

comparison with the new base. File
produced during "Handling Scenario"

application

{CATALOG_DIR}

02_Applications

5_Installation

Folder for the “Installation”

application

{CATALOG_DIR}

02_Applications

6_PWC_matric

es

Folder for the “PWC_Matrices”

application

{CATALOG_DIR}

02_Applications

7_Matrix_form

Folder for the “Change matrix format”

application

{CATALOG_DIR}

02_Applications

09_RCM1

Folder for the subgroup “Rail Capacity
Management” in the “Samgods
Model” and other subgroups for this

application:

e Warm start

{CATALOG_DIR}

02_Applications

09_RCM1

Folder for the subgroup “RCM
Assignment” in the “Samgods Model”
and other subgroups for this

application:

e Conversion from
LogMod matrices to
VY matrices

e Road Assignment
RCM




The file structure

Catalog Folder

First Level

Second Level

Third Level

Fourth

Level

Description

e Rail Assignment RCM
e Sea Assignment RCM
e Air Assignment RCM

{CATALOG_DIR}

02_Applications

09_RCM1

Dataprep_LP

Folder for the subgroup “Data
Preparation LP” inside “Rail Capacity
Management” in the “Samgods
Model”

{CATALOG_DIR}

02_Applications

09_RCM1

Final

Folder for the subgroup “Run Final
Process” inside “Rail Capacity
Management” in the “Samgods
Model” and other subgroups for this

application:
e  Prepare control files
e Run the final process

e Save Reports

{CATALOG_DIR}

02_Applications

09_RCM1

LP

Folder for the subgroup “LP Loop”
inside “Rail Capacity Management” in
the “Samgods Model”

{CATALOG_DIR}

02_Applications

09_RCM1

LP

LPo

Folder for the subgroup “LPo step”
inside “LP Loop” in the “Samgods
Model” and other subgroups for this

application:

e Prepare CTL files -
Extract procedure

{CATALOG_DIR}

02_Applications

09_RCM1

LP

LP1

Folder for subgroup “LP1+ step”
inside “LP Loop” in the “Samgods
Model” and other subgroups for this

application:
e Prepare CTL files

¢ Run BuildChaingRCM
and ChainChoi4gRCM

e Run MPS, LP and
Extract

e  Check convergence

{CATALOG_DIR}

02_Applications

09_RCM1

Results

Folder for subgroup “Results RCM” in
the “Samgods Model” and other

subgroups for the application:
e Report1.0

e Port Areas

13




The file structure

Catalog Folder

First Level

Second Level

Third Level

Fourth

Level

Description

o  GIS maps by
commodity group

e Oresund Kiel and
Jylland

e Rail Capacity

e Reports per
geographical
aggregation

{CATALOG_DIR}

02_Applications

10_SelectLink

Folder with application and
intermediate files for " Select Link

Analysis " application

{CATALOG_DIR}

02_Applications

10_SelectLink

LP

Folder for RCM assignment related to
subgroup RCM Assignment

{CATALOG_DIR}

02_Applications

10_SelectLink

STD

Folder for STD assignment related to
subgroup Assignment STD

{CATALOG_DIR}

02_Applications

11_CBA

Folder for application “Cost Benefit
Analysis — ASEK values”

{CATALOG_DIR}

02_Applications

11_CBA

LP2CC

Folder for subgroup “CBA Analysis”

{CATALOG_DIR}

02_Applications

12_Elasticity

Folder for application “Elasticity

module”

{CATALOG_DIR}

02_Applications

12_Elasticity

1_Run

LOS calculation and STD logmod

stages for “Elasticity module”

{CATALOG_DIR}

02_Applications

12_Elasticity

1_Run

1_Ini

Analogous to

02_Apllications\2_Run\Ini

{CATALOG_DIR}

02_Applications

12_Elasticity

1_Run

2_Costs

Analogous to
02_Apllications\2_Run\Costs_VY

{CATALOG_DIR}

02_Applications

12_Elasticity

1_Run

3_Logistic
Mod

Analogous to
02_Apllications\2_Run\LogisticMod
A%

{CATALOG_DIR}

02_Applications

12_Elasticity

1_Run

4_AssSTD

Analogous to
02_Apllications\2_Run\Ass_VY

{CATALOG_DIR}

02_Applications

12_Elasticity

1_Run

5_Results
STD

Analogous to

02_Apllications\2_Run\Results

{CATALOG_DIR}

02_Applications

12_ Elasticity

2_RCM

RCM stage for “Elasticity module”

{CATALOG_DIR}

02_Applications

12_ Elasticity

2_RCM

1_DataPre

par_LP

Analogous to
02_Apllications\9_RCM1\Dataprep_
LP




The file structure

Catalog Folder First Level Second Level | Third Level Fourth Description
Level
{CATALOG_DIR} | o2_Applications 12_Elasticity 2_RCM 2_LP_ste | Analogousto
ps 02_Apllications\9_RCM1\Dataprep__
LP
{CATALOG_DIR} | o2_Applications 12_Elasticity 2. RCM 3_Final Analogous to
02_Apllications\9_RCM1\Dataprep__
LP
{CATALOG_DIR} | o2_Applications 12_Elasticity 2_ RCM 4_AssRC Analogous to
M 02_Apllications\9_RCM1\Ass_VY
{CATALOG_DIR} | o2_Applications | 12_Elasticity 2_RCM 5_Results | Analogous to
RCM 02_Apllications\9_RCM1\Results

{CATALOG_DIR}

02_Applications

12_Elasticity

3_Elasticities

Elasticity calculation for STD and
RCM stages

{CATALOG_DIR} | 03_Gis_Data Folder for shape files, geodatabase
gdb Mxd files, Empty and layer file
(lyr)

{CATALOG_DIR} | 04_Media Folder for banners used in the

interface

{CATALOG_DIR}

05_Input_Data

Folder for the main geodatabase,
containing all the input data
(networks, tables and scenario specific
tables)

{CATALOG_DIR} | os5_Input_Data Calibration Folder containing calibration files
{CATALOG_DIR} | 06_Reports Folder containing Rtf files with the
model operating instructions and
report files (.rep) shown in data panel
Scenario Reports section
{CATALOG_DIR} | o7_Python Folder with Python scripts
{CATALOG_DIR} | o7_Python Original Folder with Python scripts used to

install the model

{CATALOG_DIR}

Scenario_Tree

Folder for results from model; it
contains several subfolders specific by

scenario

15




Input and output file reference

3 Input and output file reference

Here we describe the input and output structure in Samgods.
3.1. File summary

The file list is organised per location. There is a main folder for the input data and an output folder for each
scenario.

Under the folder {CATALOG_DIR}\05_Input_data\Input_Data.mdb there is the main geodatabase with all
the input data. The input data could be classified in the following classes:

1. General tables to define lookup values and calibration parameters
2. Tables that represent the base values used in the model

3. Tables that represent the values that differ from the base values and are related to a specific scenario.
These are denoted scenario specific tables

4. Tables to manage database information

Table 2 lists the content in the input data geodatabase and specifies the class for each object.

Table 2 - Input data in geodatabase.

Input name Format Class
A_CountyName Table

A_default_frequencies Table

A_F2FTypes Table

A_LinkCategories Table

A_Mode_Type Table

A_MainModeStatistics Table

A_NodeClass Table

A_Par Class Table

A_Port_areas Table

A_Trakbandel Table 1
A_Transfer_Type Table

A_Vessel_Type Table

A_Zoning_system Table

BuildChain_ CONSOL Table

BuildChain_ MODES Table

ChainChoice_ MODES Table

CSTVARI Table

Chain_ List_2017 Table

Chain_ List_2040 Table




Input and output file reference

Input name Format Class
Direct_Access Table

Extract_parameters Table

Inzone_ Distance Table

LBD_Ratio Table

MaxCapAndConsolExcept Table

Macros_ EMME Table

Modes Table

Other_ statistics Table

Port_ statistics Table

SamGods_zones Stand-alone Feature class polygons
V101_SpeedFlowCurves Table

V1o2_SpeedFlowCurves Table

ScalingF_Veh Table

ScalingF_VehASEK Table

Base2017 Network
Frequency_Data_Base2017 Network

Cargo_Base2017 Table

Node_ terminals_Base2017 Table

Nodes_Base2017 Table

Nodes_Commodities_ Base2017 Table

PropLink_Base2017 Table

Rail_Capacity_Base2017 Table 2
Tax_Category_Base2017 Table

Tax_Country_Base2017 Table

Tax_Link_Base2017 Table

Toll_Link_Base2017 Table
Vehicles_parameters_partA_Base2017 Table
Vehicles_parameters_partB_Base2017 Table

Scenarios_ List Table

General_Base2017 Table

LogMod_Base2017 Table

Sc_Base2017_Cargo Table °
Sc_Base2017_Frequency_Data_Link Table

17



Input and output file reference

Input name Format Class
Sc_Base2017_Frequency_Data_Node Table
Sc_Base2017_Link Table
Sc_Base2017_Node Table
Sc_Base2017_Node_Terminals Table
Sc_Base2017_Nodes Table
Sc_Base2017_Nodes_ commodities Table
Sc_Base2017_PropLink Table
Sc_Base2017_Rail_Capacity Table
Sc_Base2017_Tax_Category Table
Sc_Base2017_Tax_Country Table
Sc_Base2017_Tax_Link Table
Sc_Base2017_Toll_Link Table
Sc_Base2017_Vehicles_parameters_PartA Table
Sc_Base2017_Vehicles_parameters_PartB Table
History Table
4
Model_description Table

Under the folder {CATALOG_DIR}\05_Input_data\Calibration three files:

PortAreaParams_16_Comm.txt: this file is a result of the calibration procedure conducted for port
areas.

Parameters_ Kielcalibration.dbf and Parameters_portcalibration.dbf - in the calibration process the
parameters for a new loop are estimated in a calculation that requires some control parameters.
These tables hold the parameters used.

Description of the calibration process is provided in section 6.8, and description of the file structure in
section 3.3.

Under each scenario folder, for instance {CATALOG_DIR}\Scenario_Tree\Base2017, the following content
will be present:

one or more LogMod_Y folders, where Y refers to the cycling process for calibration (or scenario ID
in elasticity test). For a standard user, this will always be LogMod_ 1. This folder contains all the
standard outputs from the Logistics and Rail Capacity Management modules. A description of the
file system and structure is provided in chapter 2.

one folder ABS_GIS{SCENARIO_SHORTNAME}. Inside the folder will be present personal
geodatabase (gdb format) and related map document mxd that could be used in ArcGIS (without a
Cube licence) (see section 3.4.8.7 for file list)

one folder DIFF_GIS2040_ 2017 with personal geodatabase (gdb format) and related map document
mxd that could be used in ArcGIS (without a Cube licence) on differences between scenarios (see
section 3.4.8.7 for file list)

one folder SelectLink with several subfolders depending on the number of Select link analysis
performed by the user (see section 3.4.8.6 for file list)
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the output files (the ones produced depends on user choices) as listed in Table 3. In this example the
scenario is Base2017. A different scenario will have the same output files with the scenario name
included in the file name, for instance Outputo_Base2017.mdb will be Outputo_Base2017R62.mdb
if the scenario is Base2017R62. In the next table and the rest of the document we will refer to
{SCENARIO_SHORTNAME} to highlight this concept.
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Table 3 - List of outputs under scenario folder. Note that in the table below X represents the commodity group number

File name Output name Format

Outputo_{SCENARIO_SHORTNAME}.mdb Model_description Table
outputs Table
Node_labels Table
ProprLink_{SCENARIO_SHORTNAME} Table
Load_net_Road_o Network
Load_net_Rail_o Network
Load_net_Sea_o Network
Load_net_Air_o Network
Loaded_Net_o Network
Loaded_Bid_o Network
CHAIN_OD_COV_{SCENARIO_SHORTNAME} o_1 Table
COM_L_D_{SCENARIO_SHORTNAME} o_1 Table
VHCL_OD_COV_{SCENARIO_SHORTNAME} o_1 Table
COM_ {Select_commodity}_{Scenario_ShortName}_{ScenarioC_name} Network
Report_1_{SCENARIO_SHORTNAME}_ o Table
Report_3_TonKM_perMode_o Table
Report_4_{SCENARIO_SHORTNAME}_o Table
Report_5 {SCENARIO_SHORTNAME}_ o Table
Report_6_{SCENARIO_SHORTNAME}_ o Table
Report_6b_{SCENARIO_SHORTNAME}_ o Table
Report_7_{SCENARIO_SHORTNAME}_ o Table
Report_8_{SCENARIO_SHORTNAME}_ o Table
Report_9_{SCENARIO_SHORTNAME} o Table
Report_10_{SCENARIO_SHORTNAME}_o Table
Report_11_{SCENARIO_SHORTNAME}_o Table
Report_12_{SCENARIO_SHORTNAME}_ o Table
Report_13_Portarea_o_STD Table
Report_14_Oresund_Kiel_o_STD Table
Report_16_{SCENARIO_SHORTNAME}_o Table
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File name Output name Format
Report_17_{SCENARIO_SHORTNAME}_ o Table
Report_18_{SCENARIO_SHORTNAME}_ o Table
Report_19_{SCENARIO_SHORTNAME}_ o Table
Load_net_Road_RCM Network
Load_net_Rail RCM Network
Load_net_Sea_ RCM Network
Load_net_Air RCM Network
Loaded_Net_RCM Network
Rail_BiDir Network
Compare_Bid Network
Loaded_Bid_RCM Network
CHAIN_OD_COV_{SCENARIO_SHORTNAME} RCM_1 Table
COM_L_D_{SCENARIO_SHORTNAME} RCM_1 Table
VHCL_OD_COV_{SCENARIO_SHORTNAME} RCM_1 Table
COMR_{Scenario_ShortName}_{ScenarioC_name} Network
Report_1_{SCENARIO_SHORTNAME}_ RCM Table
Report_3_TonKM_perModeRCM Table
Report_4_{SCENARIO_SHORTNAME} RCM Table
Report_5_{SCENARIO_SHORTNAME}_ RCM Table
Report_6_{SCENARIO_SHORTNAME} RCM Table
Report_6b_{SCENARIO_SHORTNAME} RCM Table
Report_7_{SCENARIO_SHORTNAME} RCM Table
Report_8_{SCENARIO_SHORTNAME} RCM Table
Report_9_{SCENARIO_SHORTNAME} RCM Table
Report_10_{SCENARIO_SHORTNAME} RCM Table
Report_11_{SCENARIO_SHORTNAME} RCM Table
Report_12_{SCENARIO_SHORTNAME} RCM Table
Report_13_Portarea_ RCM Table
Report_14_Oresund_Kiel RCM Table
Report_15_RailLinksRMC Table
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File name Output name Format
Report_16_{SCENARIO_SHORTNAME} RCM Table
Report_17_{SCENARIO_SHORTNAME} RCM Table
Report_18_{SCENARIO_SHORTNAME}_ RCM Table
Report_19_{SCENARIO_SHORTNAME} RCM Table
Report_21_ {SCENARIO_SHORTNAME} RCM Table
CHAIN_OD_COV_{SCENARIO_SHORTNAME}_CBA_1 Table
COM_L_D_{SCENARIO_SHORTNAME}_ CBA_1 Table
VHCL_OD_COV_{SCENARIO_SHORTNAME} CBA_1 Table
Report_5_{SCENARIO_SHORTNAME}_ CBA Table
Report_6_{SCENARIO_SHORTNAME}_ CBA Table
Report_6b_{SCENARIO_SHORTNAME} CBA Table
Report_7_{SCENARIO_SHORTNAME}_ CBA Table
Report_8_{SCENARIO_SHORTNAME}_ CBA Table
Report_10_{SCENARIO_SHORTNAME} CBA Table
Report_11_{SCENARIO_SHORTNAME}_ CBA Table
Report_12_{SCENARIO_SHORTNAME}_ CBA Table
Report_19_{SCENARIO_SHORTNAME}_ CBA Table
Report_20_{SCENARIO_SHORTNAME}_CBA Table
Vehicles_loaded_and_empty_witin_Swedish_territory_ CBA Table
Costs_D_I_X_T {SCENARIO_SHORTNAME} CBA Table
COMMODITYFLows Network
COMMODITYFLowsSTD Table

Outputo_{SCENARIO_SHORTNAME}.vpr

Visual project

COST_ROAD_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
COST_RAIL_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
COST_SEA_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
COST_AIR_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
ROAD_VHCLFLOWo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
RAIL,_ VHCLFLOWo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
SEA_VHCLFLOWo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
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File name Output name Format
AIR_VHCLFLOWoO_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
ROAD_TONo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
RAIL_TONo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
SEA_TONo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
AIR_TONo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
ROAD_EMPo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
RAIL_EMPo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
SEA_EMPo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
AIR_EMPo_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
ROAD_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
RAIL_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
SEA_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}. MAT Voyager Matrix
AIR_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
ROAD_TON_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
RAIL_TON_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
SEA_TON_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
AIR_TON_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
ROAD_EMP_FIN_{SCENARIO_SHORTNAME}. MAT Voyager Matrix
RAIL_EMP_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
SEA_EMP_FIN_{SCENARIO_SHORTNAME} MAT Voyager Matrix
AIR_EMP_FIN_{SCENARIO_SHORTNAME}.MAT Voyager Matrix
Scenario_Data.mdb Database
Scenario_Data.vpr Visual project
Input_data.mxd Visual project
Input_data.mxr File index
CalParameter_Loop_1.txt Text File
CalParameter_Loop_ 2.txt Text File
CalParameterNextLoop.txt Text File
FINAL_NETWORK_B17.NET Binary Network
KielNextValue.txt Text File
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File name Output name Format
Log_File.log Text File
logfile_scenario.dat Dat file
ParKiel_BS17.txt Text File
REPORT_ED_BS17.txt Text File
REPORT_SG_BS17.txt Text File
Differences_BS17.csv CSV File
PortArea_report_BS17_Loop1.csv CSV File
PortArea_report_ RCM_BS17_Loop1.csv CSV File
EMME_NET_{SCENARIO_SHORTNAME}.211 Emme file
V101_102_LINK_SPEEDS.DAT DAT File
RENUM_NODES.DBF Dbase File
Rail_capacities_STD_BS17.DBF Dbase File
General_Table_{SCENARIO_SHORTNAME}.DBF Dbase File
Capacity_table_BS17.DBF Dbase File
ChainChoio_{SCENARIO_SHORTNAME}.rep Report File
ChainChoio_{SCENARIO_SHORTNAME}FIN.rep Report File
Tax_by_Link_BS17.DBF Dbase File
Tax_Category_BS17.DBF Dbase File
Tax_Country_BS17.DBF Dbase File
Toll_by_link_BS17.DBF Dbase File
Vh_par_tot.DBF Dbase File
Calibration_ 1.txt Text File
CBA_Final_report_BS17.txt Text File
Check_overcapacity BS17.txt Text File
chainchoiCBAo_{SCENARIO_SHORTNAME}.rep Text File

Output_COM_STD_GIS_TON.mxd

Visual project
map file (GIS)

Output_COM_STD_GIS_VHCL.mxd

Visual project
map file (GIS)




3.2. Input data

We can
[ ]
[ ]

categorize the input data into three categories
Lookup tables
Base data

Scenario specific data
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There exists one and only one reference scenario describes by the base data, and every other scenario refer to
this scenario by the differences by the scenario specific data. The relation is explained in section 3.2.2.

3.2.1.
Here, th

3.2.1.1.

Lookup tables

e lookup tables are listed including
the content of the table,
software requirements,
the description of use in the model,

editing options for the user and

which parts of the model that is acting on the table.

A_CountyName

o5_Input_data\Input_data.mdb\A_ CountyName

The content of the table is listed in Table 4.

Table 4 - Format of “A_CountyName” table.
Field Description Data Format Example
OBJECTID Counter Integer 1
COUNTY Numerical identifier of county Integer 1
NAME County name String Stockholm

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),

ArcMap, ArcCatalog.

Description of Use: Used in reporting phase to associate the county description to reports.

Editing Options: No need to be updated. (Only a new definition of counties classification will require changes

on this).

Used by: “Reports per geographical aggregation” subgroup under “Samgods Model > Results > Results 1.0”

and under “Samgods Model > Results RCM > Reports 1.0”.

3.2.1.2.

A_default_frequencies

o5_Input_data\Input_data.mdb\A_default_frequencies

The content of the table is listed in Table 5.

Table 5 - Format of “A_default_frequencies” table.
Field Description Data Format Example
OBJECTID Counter Integer 1
ID_REL Counter Integer 1
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Field Description Data Format Example
TER_TYPE_O Terminal code for origin Integer [}
TER_TYPE_D Terminal code for destination Integer o
SYSTEM Frequency System Double 0
LORRY Frequency Lorry Double 84
WAGONLOAD Frequency WaggonLoad Double 0
RAILFERRY Frequency RailFerry Double 0
ROADFERRY Frequency RoadFerry Double 0
CON_VESSEL Frequency ContainerVessel Double 0
OTH_VESSEL Frequency Other Vessels Double 0.5
RORO_VESS Frequency RororVessel Double 0.2
COMBI Frequency Combi Double 0
AIR Frequency Air Double 5.0

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Define the default frequencies for the frequency matrices based on the terminal type
(road, rail, sea, ferry or air) per week.

Editing Options: Only needs to be updated in case of changes of the default frequencies.

Used by: “Frequency matrices” subgroup under “Edit the data > Create the tables specific of scenario” and
“General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.3. A _F2FTypes
o5_Input_data\Input_data.mdb\A_F2FTypes

The content of the table is listed in Table 6.
Table 6 - Format of “A_F2FTypes” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

ID_F2F ID for the firm to firm relationship Integer 0

DESCRIPTIO Description of the firm to firm relation String singular or transit

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Define the type of relations between firm to firm in the PWC matrices.

Editing Options: No need to be updated.

Used by: “General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.4. A_LinkCategories
o5_Input_data\Input_data.mdb\A_LinkCategories
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The content of the table is listed in Table 7.
Table 7 - Format of “A_LinkCategories” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
CATEGORY Link category code Integer 11
MODE_T Description of the mode String Road
MODE Code for allowed modes . Same coding is used in other Integer 1

tables with slightly a different labelling (MODE_L and
MODE_N). _L and _N refer to type of element which
MODE refers to, specifically _Lis a link table and _ N is

a node table

ID_COUNTRY Country code Integer 1

GENERAL_MO Description of the general mode as per table String Road
A_Mode_Type

DESCRIPTIO Description of infrastructure String Oresund Bridge

AREA Description of geographical covered area String Baltic Sea

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of categories defined in the network and the associated country code. The main use is
to derive the ID_COUNTRY code for each link in the network, e.g. geographical classification. Second use is

to derive statistics at various levels in the reporting stage, such as vehiclekms and tonnekms per E10 roads
(CATEGORY=11).

Editing Options: Add a new line for each new category defined in the network.

Used by: “Editable map data” and “Editable tables” subgroups under “Create the editable files”, “Emme
Edits” subgroup under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup
under “Samgods Model > LOS calculation > Data Preparation” and “General tables” subgroup under
“Handling scenario > Scenario Export”.

3.2.1.5. A_MainModeStatistics
o5_Input_data\Input_data.mdb\A_MainModeStatistics

The content of the table is listed in Table 8.
Table 8 - Format of “A_MainModeStatistics” table.

Field Description Data Format Example
D Counter Integer 1

ROAD Millions of domestic tonkm on road mode Single 50.73
RAIL Millions of domestic tonkm on rail mode Single 20.84
SEA Millions of domestic tonkm on sea mode Single 35.57
FERYEAR Year of statistics Integer 2017
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Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Official Statistics on domestic million tonkm by mode in Sweden. The values are used in
creating the output tables “Report_3_TonKM_perMode_o0” and “Report_3_TonKM_perMode_RCM”.

Editing Options: No need to be updated.

Used by: “Numbering System Voyager” subgroup under “under “Samgods Model > Results > Results 1.0” and
under “Samgods Model > Results RCM > Results1.0”.

3.2.1.6. A_Mode_Type
o5_Input_data\Input_data.mdb\A_Mode_Type

The content of the table is listed in Table 9.
Table 9 - Format of “A_Mode_Type” table.

Field Description Data Format Example
OBJECTID Counter Integer 5

MODE Code for allowed modes Integer 4
DESCRIPTIO Description of mode String Ferry
GEN_MODE General mode code Integer 3
DESCR_GEN Description of general mode String Sea

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of modes defined in the network and related MODE_L, MODE_ N attributes in node
and link tables.

Editing Options: No need to be updated. (Only the introduction of new general will require changes on this.
This will impact all the model structure and require several amendments).

Used by: “Editable map data” subgroup under “Create the editable data”, “General tables” subgroup under
“Handling scenario > Scenario Export” and graphical editor during the editing of the network. Is one of the
codes mandatory to edit properly the network (other two are the country code and the region code).

3.2.1.7. A NodeClass
o5_Input_data\Input_data.mdb\A_NodeClass

The content of the table is listed in Table 10.
Table 10 - Format of “A_NodeClass” table.

Field Description Data Format Example

OBJECTID Counter Integer 10

ID_CLASS ID of node class Integer 10

DESCRIPTIO Description of node class String Road - regional system
RULE Rule to define node number String From 20000 to 259999
MIN_V Lower limit for node number Double 20000
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Field Description Data Format Example

MAX V Upper limit for node number Double 260000

MODE Code for allowed modes Integer 1

DES_MODE Description of mode String Road — Domestic

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of node classes defined in the network. The initial network used has been developed
in EMME with a list of rules for numbering. Those rules are described in this table. To derive new EMME
numbers when the network is modified in Cube GIS window, those rules are applied.

Editing Options: No need to be updated. (Only the introduction of new general will require changes on this.
This will impact all the model structure and require several amendments).

Used by: “Numbering System Voyager” subgroup under “Edit the data > Create the tables specific of
scenario”, “Tax calculation” subgroup under “Samgods Model > LOS calculation > Data Preparation” and
“General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.8. A Par_Class
o5_Input_data\Input_data.mdb\A_Par_Class

The content of the table is listed in Table 11.
Table 11 - Format of “A_Par_Class” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

CLASS ID of node class Integer 12
MIN_R Minimum value for zones Integer 1

MAX_R Maximum value for zones Integer 399

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: The hierarchic rule in EMME numbering has in the first three digits the region code. In
this table are represented the minimum and maximum country code associated to the class of nodes present
in A_NodeClass.

Editing Options: No need to be updated. (Only the introduction of new numbering system will require
changes on this. This will impact all the model structure and require several amendments).

Used by: Not used in the system. Illustration purposes.

3.2.1.9. A Port_areas
o5_Input_data\Input_data.mdb\A_Port_areas

The content of the table is listed in Table 12.
Table 12 - Format of “A_Port_areas” table.

29



Input and output file reference

Field Description Data Format Example
OBJECTID Counter Integer 9

PortNodes_ PortAreaNbr Port area number Integer 8
DESCRIPTION Description of port area String Visby (Gotland)

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog

Description of Use: List of defined domestic port areas. The calibration of the model conducted, requires as
input a table with scaling factors by port area and commodity group respectively. Each domestic port belongs
to a specific port area. This table defines them.

Editing Options: No need to be updated. (Only a new definition of port area classification will require
changes on this).

Used by: “Port Areas” subgroup under “Samgods Model > Results > Results 1.0” and under “Samgods Model
> Results RCM > Reports 1.0” and “General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.10. A_TrakBandel
o5_Input_data\Input_data.mdb\A_ TrakBandel

The content of the table is listed in Table 13.
Table 13 - Format of “A_TrakBandel” table.

Field Description Data Format Example
OBJECTID Record identifier Integer 1

TrakBandel Trak Bandel code Integer 1110

Section Description of the section String Kiruna-Vassijaure
Corridor Description of the corridors String Malmbanan
Tracks Number of tracks Integer 1

DaysPerYr Operational days in a year Double 365
Cap20400resund Number of trains per day (bidirectional) Double 99
Cap20170resund Number of trains per day (bidirectional) Double 56

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of trak bandel codes used in later reporting (COMMODITYFLows and maps “GIS
map with Ktons per commodity group” and “GIS map with vhel per commodity group”).

Editing Options: No need to be updated. (Only a new definition of trakbandel will require changes on this).

Used by: Editable map data” subgroup under “Create the editable files” and “General tables” subgroup under
“Handling scenario > Scenario Export”.

3.2.1.11. A Transfer_Type
o5_Input_data\Input_data.mdb\A_ Transfer_type

The content of the table is listed in Table 14.
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Table 14 - Format of “A_Transfer_Type” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

TRANSF_TYP Transfer type code Integer 1

DESCRIPTIO Description of transfer type String TransferRoadRoad

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of defined transfer types used in Nodes_ Commodities_ Base2017 table.

Editing Options: No need to be updated. (Only a new definition of transfer type will require changes on this).

Used by: Editable map data” subgroup under “Create the editable files” and “General tables” subgroup under
“Handling scenario > Scenario Export”.

3.2.1.12. A Vessel_type
o5_Input_data\Input_data.mdb\A_Vessel type

The content of the table is listed in Table 15.
Table 15 - Format of “A_Vessel_type” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
VES_TYPE Vessel type code Integer 1
DESCRIPTION Description of vessel type String containers

Software required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of vehicle types defined in the logistic chains (container and non-container).

Editing Options: No need to be updated. (Only a new definition of special vehicle type will require changes on
this).

Used by: “General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.13. A_Zoning_System
o5_Input_data\Input_data.mdb\A_Zoning_ System

The content of the table is listed in Table 16.
Table 16 - Format of “A_Zoning_System” table.

Field Description Data Format Example
OBJECTID Counter Integer 2
COUNTRY_CO Country code, later referred as ID_COUNTRY Integer 1
REGION_COD Region code later referred as ID_REGION Integer 115
COUNTRY Country description String Sweden
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Field Description Data Format Example
REGION Region description String Vallentuna
CENTROID_C Centroid code in Emme format Integer 711500
SCBSTANN Scbstann code Integer 115
SWEDEN Boolean variable indicating if the zone is in Sweden Integer 1

Software required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: List of zones and related country, region and scbstann codes.

Editing Options: No need to be updated (a revision of zoning system would impact all the model, therefore
for normal usage of the model is not recommended to change this).

Used by: “Editable tables” subgroup under “Create the editable files”, “Numbering System Voyager”
subgroup under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under
“Samgods Model > LOS calculation > Data Preparation”, “Reports per geographical aggregation” subgroup
under “Samgods Model > Results > Results 1.0” and under “Samgods Model > Results RCM > Reports 1.0”
and “General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.14. BuildChain_CONSOL
o5_Input_data\Input_data.mdb\BuildChain_ CONSOL

The content of the table is listed in Table 17.
Table 17 - Format of “BuildChain_CONSOL” table.

Field Description Data Format Example
ID Counter Integer 1
MODE_C Sub-modet! String A
CONSOL_L default lower bound Double 0.4
CONSOL_U default upper bound Double 0.6
Mode Description String Road
ID_MODE Associated number to mode Integer 1
CONSOL_Lo1 lower bound for Commodity group 1 Double -1
CONSOL_Uo1 upper bound for Commodity group 1 Double -1
CONSOL_Lo2 lower bound for Commodity group 2 Double -1
CONSOL_Uo2 upper bound for Commodity group 2 Double -1
CONSOL_Los lower bound for Commodity group 3 Double -1
CONSOL_Uo3 upper bound for Commodity group 3 Double -1
CONSOL_Log lower bound for Commodity group 4 Double -1
CONSOL_Uo4 upper bound for Commodity group 4 Double -1

1 See Table A-2 in the User manual for full list of sub-modes and vehicle types
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Field Description Data Format Example
CONSOL_Los lower bound for Commodity group 5 Double -1
CONSOL_Uos upper bound for Commodity group 5 Double -1
CONSOL_Lo6 lower bound for Commodity group 6 Double -1
CONSOL_Uo6 upper bound for Commodity group 6 Double -1
CONSOL_Loy lower bound for Commodity group 7 Double -1
CONSOL_Uoy upper bound for Commodity group 7 Double -1
CONSOL_Lo8 lower bound for Commodity group 8 Double -1
CONSOL_Uo8 upper bound for Commodity group 8 Double -1
CONSOL_Log lower bound for Commodity group 9 Double -1
CONSOL_Uog upper bound for Commodity group 9 Double -1
CONSOL_L10 lower bound for Commodity group 10 Double -1
CONSOL_U1o upper bound for Commodity group 10 Double -1
CONSOL_Li11 lower bound for Commodity group 11 Double -1
CONSOL_U11 upper bound for Commodity group 11 Double -1
CONSOL_Li12 lower bound for Commodity group 12 Double -1
CONSOL_U12 upper bound for Commodity group 12 Double -1
CONSOL_L13 lower bound for Commodity group 13 Double -1
CONSOL_U13 upper bound for Commodity group 13 Double -1
CONSOL_L14 lower bound for Commodity group 14 Double -1
CONSOL_U14 upper bound for Commodity group 14 Double -1
CONSOL_L1s lower bound for Commodity group 15 Double -1
CONSOL_Uis upper bound for Commodity group 15 Double -1
CONSOL_L16 lower bound for Commodity group 16 Double -1
CONSOL_U16 upper bound for Commodity group 16 Double -1

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),

ArcMap, ArcCatalog.

Description of Use: The consolidation factors, specified as two values representing an allowed range, in this

table are specified for all the commodities (CONSOL_L and CONSOL_U) and for each commodity groups. If
under each commodity group is placed a “-1” value, the proper number will be derived from default values
(CONSOL_L and CONSOL_U). A mechanism within the model will pull together the appropriated

combination of values under each BuildChainXX.ctl file.

Editing Options: Instructions on setting up different values for different scenarios has been explained in User

Manual 6.1. The table could be copied via Data Manager and opened in dbf window in GUT interface. Its

reference is controlled by catalog key "Consolidation factors table".

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module” and “General

tables” subgroup under “Handling scenario > Scenario Export”.
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3.2.1.15. BuildChain_MODES
o5_Input_data\Input_data.mdb\BuildChain_MODES

The content of the table is listed in Table 18.
Table 18 - Format of “BuildChain_MODES” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
ID_COMM Commodity group Integer 1

A Main vehicle type for chain type A Integer 104
B Main vehicle type for chain type B Integer 102
C Main vehicle type for chain type C Integer 104
D Main vehicle type for chain type D Integer 201
E Main vehicle type for chain type E Integer 202
F Main vehicle type for chain type F Integer 208
G Main vehicle type for chain type G Integer 202
H Main vehicle type for chain type H Integer 208
I Main vehicle type for chain type I Integer 204
J Main vehicle type for chain type J Integer o)

K Main vehicle type for chain type K Integer 0

L Main vehicle type for chain type L Integer o)
M Main vehicle type for chain type M Integer 310
N Main vehicle type for chain type N Integer 315
(0} Main vehicle type for chain type O Integer 317
P Main vehicle type for chain type P Integer 319
Q Main vehicle type for chain type Q Integer 322
R Main vehicle type for chain type R Integer 401
T Main vehicle type for chain type T Integer 205
U Main vehicle type for chain type U Integer 206
c_1 Main vehicle type for chain type ¢ Integer 106
d_1 Main vehicle type for chain type d Integer 210
h_1 Main vehicle type for chain type h Integer 212
i1 Main vehicle type for chain type i Integer 211
Y Main vehicle type for chain type V Integer 322
w Main vehicle type for chain type W Integer 322
f1 Main vehicle type for chain type f Integer 212
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Field Description Data Format Example

X Main vehicle type for chain type X Integer 106

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Main vehicle type used in the BuildChain process for each logistic chain and commodity
group. It is the translation in access table of information present in reference 2 (Table 5).

Editing Options: No need to be updated.

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module” and “General
tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.16. Chain_List 2017 and Chain_List 2040
o5_Input_data\Input_data.mdb\Chain_List_2017

o5_Input_data\Input_data.mdb\Chain_List_2040

The content of the table is listed in Table 19.
Table 19 - Format of “Chain_List_2017” and “Chain_List_2040” tables.

Field Description Data Format Example
OBJECTID Counter Integer 2

ID_C Logistic chain code Integer 2
CHAIN_TYPES Transport chain String ADA
SEL_SEA Flag for chain containing sea mode Integer o)

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Specifies the possible chains in the model. Each letter represents a specific submode and
vehicle type. It is the translation in the access table with information present in references 2 (Table 4a and
Table 4b). The new vehicle types have imposed the creation of several new chain types. The SEL_SEA
attribute is for report purposes during the creation of outputs.

Editing Options: Needs to be updated when the chain types are revised. If sensitivity tests are required,
create a copy and link the new table in “Samgods” application via catalog key.

Used by: “Prepare Data third part” and “Save Reports” subgroups under “Samgods Model > Logistics
Module” and “General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.1.17. ChainChoice_ MODES
o5_Input_data\Input_data.mdb\ChainChoice_ MODES

The content of the table is listed in Table 20.
Table 20 - Format of “ChainChoice_ MODES” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
MODE_C Chain type String A
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Field Description Data Format Example

VHCL_NR Vehicle type, 3 digit format (as per Integer 104

Vehicles_parameters_PartA_Base2017 table)

VES_TYPE Container/non container Integer 1

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of use: Specifies the vehicle type and vessel type (specified in A_Vessel_type) associated to each
mode present in Chain_ List_2017 and Chain_List_204o0. It is the translation in access table of information
present in reference 2 (Table 3).

This table is used in building the ChainChoixx.ctl files (xx being the commodity group number) for
parameters VHCLA through VHCLR, see reference 3 (Figure 5-3). An example using values the example data
in Table 21, results in(ChainChoioz1.ctl):

VHCLA=104,105

VHCLD=201

Editing Options: Needs to be updated when chain types and associated vehicle and vessel types are revised.

Used by: “Prepare Data third part” and “Save Reports” subgroups under “Samgods Model > Logistics
Module” and “General tables” subgroup under “Handling scenario > Scenario Export”.

Table 21 - Example of rows in the access table.

MODE_C VHCL_NR VES_TYPE

A 104 1
A 105 1
D 201 1

3.2.1.18. CSTVARI
o5_Input_data\Input_data.mdb\CSTVARI

The content of the table is listed in Table 22.
Table 22 - Format of “CSTVARI” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
ID_COM Commodity Group number Integer 1
F2F o VAR parameter (lambda value in logit formulation) for flow to flow class o Double 0.1
F2F 1 VAR parameter (lambda value in logit formulation) for flow to flow class 1 Double 0.1
F2F 2 VAR parameter (lambda value in logit formulation) for flow to flow class 2 Double 0.1
FoF 3 VAR parameter (lambda value in logit formulation) for flow to flow class 3 Double 0.1
FoF 4 VAR parameter (lambda value in logit formulation) for flow to flow class 4 Double 0.1
F2F 5 VAR parameter (lambda value in logit formulation) for flow to flow class 5 Double 0.1
F2F 6 VAR parameter (lambda value in logit formulation) for flow to flow class 6 Double 0.1
FoF 7 VAR parameter (lambda value in logit formulation) for flow to flow class 7 Double 0.1
FoF 8 VAR parameter (lambda value in logit formulation) for flow to flow class 8 Double 0.1
FoF ¢ VAR parameter (lambda value in logit formulation) for flow to flow class 9 Double 0.1
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Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Specifies the lambda value for logit formulation of probabilities across solutions (first,
second, etc.) for each commodity group and flow to flow class.

Editing Options: Needs to be updated when calibrating the model.

Used by: “Samgods Model > Logistics Module”.

3.2.1.19. Direct_Access
o5_Input_data\Input_data.mdb\Direct_Access

The content of the table is listed in Table 23.

Table 23 - Format of “Direct_Access” table.

Field Description Data Format Example
OBJECTID | Counter Integer 1
ID_COM Code of Commodity group Integer 1
F2F_o Flag to enable or disable direct access Integer 1
F2F_1 Flag to direct access for F2F type 1 Integer o)
F2F_2 Flag to direct access for F2F type 2 Integer o)
F2F_3 Flag to direct access for F2F type 3 Integer 1
F2F_4 Flag to direct access for F2F type 4 Integer o)
F2F_5 Flag to direct access for F2F type 5 Integer o)
F2F_6 Flag to direct access for F2F type 6 Integer 1
F2F_7 Flag to direct access for F2F type 7 Integer 1
F2F_8 Flag to direct access for F2F type 8 Integer 1
F2F_o9 Flag to direct access for F2F type 9 Integer 1

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Define per each type of f2f flow (the types are described in table A_F2FTypes) and
commodity group if direct access is allowed.

This table is used when building the ChainChoixx.ctl files for the parameter DIRACC (xx is commodity group
number). For more information please see reference 3. Each row has been translated from an access table
given in Table 24. Inside the control file it looks like:

DIRACC=1,0,0,1,0,0,1,1,1,1

Editing Options: Needs to be updated when direct access for a specific f2f category and product group is
revised.

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module” and “General
tables” subgroup under “Handling scenario > Scenario Export”.
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Table 24 - Example of row with values from the access table.

ID_COM F2F_o F2F 1 F2F 2 F2F_3 F2F_4 F2F_5 F2F_6 F2F_7 F2F_8 F2F_o

1 1 (0] (0] 1 o (0] 1 1 1 1

3.2.1.20. Extract_parameters
o5_Input_data\Input_data.mdb\Extract_parameters

The content of the table is listed in Table 25.

Table 25 - Format of “Extract_parameters” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

1D Id of vehicle type extract parameters Integer 1
VEH_NR Vehicle type Integer 101

DIST1 First threshold distance Double 50
EMPFAC1 Add-on factor applied up to DIST1 determining the proportion of empty vehicle Double 0.5

flows to loaded vehicle flows. Between DIST1 and DIST2 a linear interpolation is
conducted between EMPFAC1 and EMPFAC2

DIST2 Second threshold distance Double 300

EMPFAC2 Add-on factor applied above DIST2 determining the proportion of empty vehicle Double 0.1

flows to loaded vehicle flows

ASYM Threshold distance above which asymmetric loaded vehicle flows will generate the Double 50

same empty vehicle flow

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: The table provides, for each vehicle type, the function that will be applied in the extract
procedure. The extract procedure reads the emptyfrac.dat placed under EXTRACT folder and applies the
values specified in this table (DIST1, EMPFAC1, DIST2, EMPFACz2 etc. for specification of a piecewise linear
function). The ASYM control parameter present in each extractXXX.ctl file is filed out with values from this
table.

Editing Options: Needs to be updated when specifying different curves.

An example to understand the parameters in this table, using the curve in Figure 1 is:

DIST1=50 km
EMPFAC1=0.5
DIST2=300 km

EMPFAC2=0.1

Used by: “prepare Data second part” and “Prepare Data third part” subgroups under “Samgods Model >
Logistics Module” and “Prepare CTL Files” subgroup under “Samgods Model > Rail Capacity Management >
LP Loop > LPo step”, “Samgods Model > Rail Capacity Management > LP Loop > LP1+ step”, “Samgods
Model > Rail Capacity Management > LP1 Adjust Capacities > LP Adjust Capacity Loop > LP1b step” and
“Samgods Model > Rail Capacity Management > Run Final Process”.
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Figure 1 - The curve for empty vehicle fraction.

3.2.1.21. Inzone_Distance
o5_Input_data\Input_data.mdb\Inzone_Distance

The content of the table is listed in Table 26.

Table 26 - Format of “Inzone_Distance” table.

Field Description Data Format Example
OBJECTID Counter Integer 2
ZONEID Zone code (NORIG value) Integer 711500
DISTANCE Intrazonal distance [km] Double 5.53

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Inzone_ Distance represents the default values for the intrazonal distances on domestic

zones. This value will be added both for the distance, domestic distance and time skims during the cost
calculation phases.

Editing Options: No edits to be updated (the revision of this is connected to the revision of zoning system.
therefore in the normal usage of the model is not recommended to change this).

Used by: “Data Preparation” subgroup under “Samgods Model > LOS calculation” and “General tables”
subgroup under “Handling scenario > Scenario Export”.

3.2.1.22. Macros_ EMME
o5_Input_data\Input_data.mdb\Macros_ EMME

The content of the table is listed in Table 27.
Table 27 - Format of “Macros_EMME” table.
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Field Description Data Format Example

OBJECTID Counter Integer 1

ID Table identifier Integer 1

VEH_NR Vehicle type Integer 101

DESCRIPTIO Vehicle description String Lorry light LGV.< 3.5 ton
EMME2_C Name of the macro in EMME for cost calculation String ~<v100.mac

MATIN Name of the macro in EMME for load the OD matrix String ~<veh_matin_100.mac
EMME2_A Name of the macro in EMME for assignment String ~<asg100.mac
ODMATRIX Name of OD matrix in EMME format String od_vhcl101.314
ODEMME Matrix number in emme2bank String mf11

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: The table is used to specify the matrix label printed out in OD matrices when extracted
from the transport chain solutions. Values in ODEMME column will specified the value for control parameter
ID in the extract control file. For instance for Vehicle type 101 in control file we have ID=mf11, and this value
comes from ODEMME attribute in Table 28.

Editing Options: If user wishes to change the matrix label, the values could be updated.

Used by: “Prepare Data third part” subgroup under “Samgods Model > Logistics Module”, “Prepare CTL
Files” subgroup under “Samgods Model > Rail Capacity Management > LP Loop > LPo step”, “
Model > Rail Capacity Management > LP Loop > LP1+ step”, “Samgods Model > Rail Capacity Management
> LP1 Adjust Capacity Loop > LP1b step” and “Samgods Model > Rail Capacity Management > Run Final

Process”, “General tables” subgroup under “Handling scenario > Scenario Export”.

Samgods

Table 28 - Example from the access table.

ID VEH_NR DESCRIPTIO | EMME2_C MATIN EMME2_A ODMATRIX ODEMME
1 101 Lorry light ~<vioo.mac | ~<veh_matin._ | ~<asgioo.mac | od_vhcl101.314 | mf11
LGV <3.5

3.2.1.23. Modes

o5_Input_data\Input_data.mdb\Modes

The content of the table is listed in Table 29.

Table 29 - Format of “Modes” table.
Field Description Data Format | Example
OBJECTID Count Integer 1
CODE Code for each mode String X
DESCR_MODE Description of the vehicle type associated to mode String All_m
VAL1 Code 1: code used in Voyager process to sort properly some tables Double 1

during the run
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Field Description Data Format | Example

VAL2 Code 2: code used in Voyager process to sort properly some tables Double 1

during the run

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Define the modes in the network and some codes used in the Voyager application to
properly sort records in intermediate files.

Editing Options: Update with new codes if need to add a different vehicle type.

Used by: “Editable map data” subgroup under “Create the editable files”, “Numbering System Voyager”
subgroup under “Edit the data > Create the tables specific of scenario”, and “General tables” subgroup under
“Handling scenario > Scenario Export”.

3.2.1.24. Other_statistics
o5_Input_data\Input_data.mdb\Other_statistics

The content of the table is listed in Table 30.
Table 30 - Format of “Other_statistics” table.

Field Description Data Format Example
ID Counter Integer 1
A Start node of the link in VY Numbering Integer 24604
B End node of the link in VY Numbering Integer 2566
DES Description of statistics String OresundRoad
Statistics Unit used for statistics (number of vehicles or tons per year) String Vehicles
ID_S Identification number for unit in statistics (1 - number of Integer 1
vehicles, 2 - tons)
Value Tons or vehicles per year Double 251589

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: This table contains statistics on Oresund Bridge (both for rail and road components) and
Kiel Canal and Jylland region. The values refer to base year 2017. The table also contains the links (A and B
nodes) that represent those infrastructures or services. This table is used in setting up the comparisons

between Base2017 scenario and statistics reported in Report #3.

Editing Options: Since these are the reference numbers for comparisons, no edits are required.

Used by: “Oresund Kiel and Jylland” subgroup under “Samgods Model > Results > Results 1.0” and
“Oresund Kiel and Jylland” under “Samgods Model > Results RCM > Reports 1.0”.

3.2.1.25. Port_statistics
o5_Input_data\Input_data.mdb\Port_statistics

The content of the table is listed in Table 31.
Table 31 - Format of “Port_statistics” table.
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Field Description Data Format Example
PortAreaNbr Port area code Integer 1
COMo1 Tonnes/1000 through port area of commodity group 1 Double 0.74
COMoz2 Tons/1000 on port area and COMMODITY group 2 Double 889.46
COMo3 Tons/1000 on port area and COMMODITY group 3 Double 879.24
COMog4 Tons/1000 on port area and COMMODITY group 4 Double 2.33
COMos Tons/1000 on port area and COMMODITY group 5 Double 1722.14
COMo6 Tons/1000 on port area and COMMODITY group 6 Double 5904.2
COMo7 Tons/1000 on port area and COMMODITY group 7 Double 5445.77
COMo8 Tons/1000 on port area and COMMODITY group 8 Double 123.8
COMo9g Tons/1000 on port area and COMMODITY group 9 Double 571.43
COM10 Tons/1000 on port area and COMMODITY group 10 Double 730.06
COM11 Tons/1000 on port area and COMMODITY group 11 Double 613.97
COM12 Tons/1000 on port area and COMMODITY group 12 Double 12.74
COM13 Tons/1000 on port area and COMMODITY group 13 Double 571.43
COM14 Tons/1000 on port area and COMMODITY group 14 Double 730.06
COM15 Tons/1000 on port area and COMMODITY group 15 Double 613.97
COM16 Tons/1000 on port area and COMMODITY group 16 Double 12.74

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: This table contains statistics on port areas divided by commodity group. The values refer
to base year 2017. This table is used in setting up the comparisons between Base2017 scenario and statistics
reported in Report #13.

Editing Options: Since these are the reference numbers for comparisons, no edits are required.

Used by: “Port Areas” subgroup under “Samgods Model > Results > Results 1.0”, “Port Areas” under
“Samgods Model > Results RCM > Reports 1.0” and “General tables” subgroup under “Handling scenario >
Scenario Export”.

3.2.1.26. SamGods_zones
o5_Input_data\Input_data.mdb\SamGods_ zones

The content of the table is listed in Table 32.

Table 32 - Format of “SamGods_zones” table.

Field Description Data Format Example
OBJECTID Counter Integer 33
Shape Feature class type OLE Object Long Binary Data

COUNTRY_CO Country code Integer 518
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Field Description Data Format Example
REGION_COD Region code Integer 201

COUNTRY Description of country String Norway
REGION Description of region String Akershus
CENTROID_C Centroid code in Emme format Integer 960100
SCBSTANN SCBSTANN code Integer 2601

Shape_ Length Length of perimeter in meters Double 393316.015
Shape_Area Area of shape in square meters Double 5030650696.500

Software Required: Cube GIS Window (see Help>Cube Base>GIS window) Or ArcMap

Description of Use: Defines the zoning system in the model. It is used during the editing to assist the user in
the definition of COUNTRY_CO and REGION_CO. It is also used to classify links on boundaries per
SCBSTANN. The table “A_Zoning_System” contains the actual coding present in PWC matrices, while the
feature class “SamGods_zones” is its translation in a visualizable layer.

Editing Options: No need to be updated (a revision of zoning system would impact all the model, therefore
for normal usage of the model is not recommended to change this).

Used by: “Prepare temporary data” subgroup under “Create the editable files”, “Regions for links” subgroup
under “Edit the data > Save changes in the main gdb” and GIS window to select the country and region codes
during the edit of the network.

3.2.1.27. V101_SpeedFlowCurves and V102_SpeedFlowCurves
o5_Input_data\Input_data.mdb\Vio1_SpeedFlowCurves

o5_Input_data\Input_data.mdb\Vio2_SpeedFlowCurves

The content of the tables is listed in Table 33.
Table 33 - Format of “V101_SpeedFlowCurves” and “V101_SpeedFlowCurves” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
NUM_CURVE ID function when coding speed-flow curves relationships Integer 1

under Cube scripting
SPEEDBASE1 Base speed for first part of equation Double 111
A1 A parameter for first part of equation Double 4.211003
B1 B parameter for first part of equation Double 107.2412
C1 C parameter for first part of equation Double 0.009474
D1 D parameter for first part of equation Double 0.00007
G1 G parameter for first part of equation Double 0.001405
SPEEDBASE2 Base speed for second part of equation Double o)
A2 A parameter for second part of equation Double o)
B2 B parameter for second part of equation Double 0
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Field Description Data Format Example
C2 C parameter for second part of equation Double 0
D2 D parameter for second part of equation Double o)
G2 G parameter for second part of equation Double o)

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Define the delay functions based on the category of the link for vehicle type 101 and
vehicle type 102-106 respectively.

Editing Options : No need to be updated.

Used by: “Road” subgroup under “Samgods Model > LOS calculation”, “Road Assignment” subgroup under
“Samgods Model > Assignment”, “Road Assignment” subgroup under “Samgods Model > RCM Assignment”
and “General tables” subgroup under “Handling scenario > Scenario Export”.

NOTE: This table represents the coefficients used in delay curves defined for each category. This table will be
used if there will be no speed values for the road mode in Sweden. Their formats in the programs are
discussed below. There are two different structures for the delay functions, depending on the number of lanes
on a link:

First structure:

TC[NUM_CURVE]=LI.UL2 / MIN ( SPEEDBASE1, (A1+(B1+(C1*exp(D1*(v/0.88)))/(1+G1*exp(D1*(v/0.88)))

Second structure:

TC[40]=CmpNumRetNum(LI.NLANES,'>",1.5,(LI.UL2/ (MIN(SPEEDBASE1,A1 + (B1 + C1 * exp(D1 *(V/0.12))) /(1 + G1
*exp(D1 *(V/0.12)))))), (LI.UL2/ (MIN(SPEEDBASE2,A2 + (B2 + C2 * exp(D2 *(V/0.12))) / (1 + G2 * exp(D2
*(V/0.12)))))))

where:
e LI.UL2 - Distance in km
eV —Volume of vehicle flow (per hour or units per day)
e LI.NLANES — Number of lanes.

3.2.2. Interaction between Base data and Scenario specific data

Base data works in pair with scenario specific data to form a specific scenario.

The concept is that all the input data connected to a specific scenario is stored in the database as the
differences between the current scenario and the base scenario (i.e., the reference scenario), as shown in
Figure 2. The benefits of this approach are:

e A smaller amount of data is stored, that is, only the differences between the base scenario and the
alternative scenario(s)

e It makes different alternative scenarios independent of each other, by letting the alternative
scenarios having only the base scenario as a reference. The only redundancy of the system occurs
when children are added to an alternative scenario since all scenarios (including child and parent
scenarios) are independent of each other and only have the base scenario as a reference

o When changes are made to the base scenario, there is no need to change all the other scenarios. This
facilitates the handling of the overall scenarios. Furthermore, the changes and edits will be done only
once, in the base scenario, avoiding risk of mistake when updating the correlated scenarios
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To create the editable files for a specific scenario and the scenario specific tables, two applications work in
conjunction:

o the Create the editable files application, which merges the base scenario with the scenario specific
tables to view and edit a scenario, and

o the Edit the data application, which stores the scenario-specific tables into the database after any

edits have been made

Main geodatabase
{Input_data.mdb)

Scenario 1
Scenario 2
Scenario 2

Scenarion

Base
seenario

Iy
Temporary geodatabase
I (Scenario_data.mdb)

G

-

elte the editable files application
Editable data

Edit the dato application

Figure 2 - Database structure and scenario data of the Samgods GUI.

To create the editable file for a specific scenario and vice versa, create the scenario specific tables, two
applications work in conjunction, the first one is “Create the editable files” with the purpose to merge the
base scenario with the scenario specific table to consolidate a scenario, and “Edit the data” application, that
after the edits stores the scenario specific table into the database.

The main database is always present in the model, under o5_Input_data folder; the temporary database is
created in each run under the scenario folder and deleted on request by the user.

Here, we will discuss the tables and networks that form the base data, e.g. the reference scenario. In the
scenario folder, all the base data and scenario data (e.g. differences with Base Scenario) are merged forming a
new set of input data editable from interface. In Table 34 the correspondences among each feature class or
table present in Input_data.mdb and Scenario_data.mdb are presented.

Table 34 - Correspondence between Input_data.mdb and Scenario_data.mdb.

Input_Data.mdb Scenario_data.mdb
Name Type Name Type
Cargo_Base2017 Table

Cargo_{SCENARIO_SHORTNAME} Table
Sc_{SCENARIO_SHORTNAME}_Cargo Table
Frequency_Data_Base2017 Network Frequency_network Network
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Input_Data.mdb

Scenario_data.mdb

Name Type Name Type
Sc_{SCENARIO_SHORTNAME}_Frequency_D
Node Table
ata_Link
Sc_{SCENARIO_SHORTNAME}_Frequency_D .
Link Table
ata_Node
General_Base2017 Table General_{SCENARIO_SHORTNAME} Table
LogMod_Base2017 Table LogMod_{SCENARIO_SHORTNAME} Table
Base2017 Network
Sc_{SCENARIO_SHORTNAME}_Link Node Table Network Network
Sc_{SCENARIO_SHORTNAME}_Node Link Table
Model_description Table Model_description
Nodes_Base2017 Table Stand-alone
Nodes Feature class
Sc_{SCENARIO_SHORTNAME}_ Nodes Node Table points
Nodes_ Commodities_ Base2017 Table Stand-alone
Sc {SCENARIO SHORTNAME} Nodes comm Nodestommodities Feature class
- - o a Table int
odities points
Node_terminals_Base2017 Table Stand-alone
Sc_{SCENARIO_SHORTNAME} Node_Termin Ports_Swe Feature class
als Table points
Rail_Capacity_Base2017 Table Rail_Capacity_{SCENARIO_SHORTNA | _
able
Sc_{SCENARIO_SHORTNAME}_Rail Capacity | Table ME}

SamGods_ zones

Stand-alone

Feature class

SamGods_ zones

Stand-alone

Feature class

polygons polygons
Tax_Category_Base2017 Table Tax_Category_ {SCENARIO_SHORTNA |
able
Sc_{SCENARIO_SHORTNAME} Tax_Category | Table ME}
Tax_Country_Base2017 Table Tax_Country_{SCENARIO_SHORTNA |
able
Sc_{SCENARIO_SHORTNAME} Tax_Country | Table ME}
Tax_Link_Base2017 Table
Tax_Link_{SCENARIO_SHORTNAME} Table
Sc_{SCENARIO_SHORTNAME}_Tax_Link Table
Toll_Link_Base2017 Table
Toll_Link_{SCENARIO_SHORTNAME} | Table
Sc_{SCENARIO_SHORTNAME}_Toll_Link Table
Vehicles_parameters_PartA_Base2017 Table
Vehicles_parameters_ Tabl
. able
Sc_{SCENARIO_SHORTNAME}_ Vehicles_para Table Sc_{SCENARIO_SHORTNAME}_PartA

meters_ PartA
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Input_Data.mdb

Scenario_data.mdb

Name

Type Name

Type

Vehicles_parameters_PartB_Base2017 Table

Vehicles_parameters_
Sc_{SCENARIO_SHORTNAME}_ PartB

Table

meters_PartB

Sc_{SCENARIO_SHORTNAME}_Vehicles_para

Table

The structure for each table is identical to the structure in Input_data.mdb with some exceptions:

e MODESTR, attribute present in the link table of the network, is converted into a set of attributes per
link where the particular vehicle type is allowed/not allowed depending on the flag. For instance ' xc'
is converted in two attributes ALL,_M=1 and CAR=1. The correspondence is hold in Vehicle
Parameters table under MODE_1 and MODE_ 2. Per each letter specified under MODESTR, a
different attribute has specified.

e Some new attributes are added to make the information more readable. For instance under
Nodes_commodities a new field TRANSFER gives the information of which type of transfer the

TRANSFER_TYPE number refers to. For instance TRANSFER_TYPE=1 means that TRANSFER=
TransferRoadRoad.

Please see reference 6 for further details on the structure and rules for editing.

3.2.3. Base Data

In this section all tables related to reference scenario are listed.

3.2.3.1. Base2017

o5_Input_data\Input_data.mdb\Base2017

The tables represent the network for the cost calculation and assignment processes. Physically it is
constructed from two tables, the node and the link table in the geodatabase, presented in Table 35 and Table

36 respectively.

Table 35 - Format of “Base2017_Node” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 1
X Coordinate x (SWEREF99_TM) Double 1620000
Y Coordinate y (SWEREFgg9_TM) Double 6601000
NORIG Original node number in EMME numbering based Integer 711400
on the combination of ID_ Country, ID_region and
MODE_ N values
SCBSTANN SCBSTANN code Integer 114
ID_COUNTRY Country code Integer 1
ID_REGION Region code Integer 114
MODE_N Mode code for node Integer o)
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2017 always 1

Field Description Data Format Example

Ul4 User field (not used in the current model) Double 0

CENTRALL Node description in terms of location String Upplands-Vasby
GEOMETRYSOURCE Structural code representing source of node. In Base | Double 1

Table 36 - Format of “Base2017_Link” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (lane) OLE Object Long Binary Data
A Start node in VY Numbering Integer 1
B End node in VY Numbering Integer 2659
Shape_Length Length based on distance between coordinates in Double 230.86792762
meters
MODESTR String with all the allowed modes String Xabce
SPEED_1 Speed in kms per hour for all modes except v102-106 in | Double 50
Sweden
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Double 50
Sweden
CATEGORY Link category Integer 110
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable | Double 1.36
holding link lengths longer than 999 kms.
UL3 Capacity for vessels on sea (dwell tons) Double o)

Software required: Microsoft Access, Cube GIS Window (see Help>Cube Base>GIS window), ArcMap.

Description of Use: Define the base network.

Editing Options: No edits; all the changes will be allowed only in the export phase merging the scenario
specific tables and the base tables.

Used by: All the applications.

3.2.3.2. Frequency_data_Base2017
o5_Input_data\Input_data.mdb\Frequency_data_Base2017

Frequency_data_Base2017 represents the frequency matrices for specific modes. Physically it is constructed
from tables, the node and the link table in the geodatabase, presented in Table 40 and Table 41. The use of a
network instead of a set of matrices is to save hard disk space (the network format is more compressed than

the matrix format) and access time during the read/write phases.

Each relation between zones is represented by:
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e alink, if the connection is between two different zones
e anode, if the connection is between the same zone (origin coincides with destination)

For instance in the link table the following link in Table 37, this will be translated into 3 rows in each file
representing different frequencies. In the example:

e FREQCONTAINERVESSEL.314 will take the value 0.1 from CONTAINERYV and origin 711400 from
ZONEORIG and destination 730521 from ZONEDEST

¢ FREQOTHERVESSEL.314 will take the value 0.5 from OTHER and origin 711400 from ZONEORIG
and destination 730521 from ZONEDEST

¢ FREQRORVESSEL.314 will take the value 0.5 from OTHER and origin 711400 from ZONEORIG and
destination 730521 from ZONEDEST

In each .314-file we will find the corresponding record in Table 38. A similar process is conducted for the
node table, where all the intrazonal frequencies are saved, i.e. values where origin is identical with
destination. Values in node table with 0 in ZONEORIG_N and ZONEDEST_N represent that the intrazonal
values are not available for that specific zone. The correspondence between .314-files and attributes in the
network is shown in Table 39.

Table 37 - Example showing arow from the access table.

A|B ZONEORIG | ZONEDEST | SYSTEM | COMBI | CONTAINERV | LORRY | OTHER | ROROVES

1 | 1100 | 711400 730521 o o 0.1 o 0.5 0.2

Table 38 - Example of content of the .314-files.

File Record

FREQCONTAINERVESSEL.314 711400 730521:0.1

FREQOTHERVESSEL.314 711400 730521:0.5

FREQROROVESSEL.314 711400 730521:0.2

Table 39 - Correspondence between information in Frequency_network and LOS files under Input
folder for logistics module.

Attribute in node Attribute in link table File under Input\LOS
table

SYSTEM_N SYSTEM FREQSYSTEM.314
AIR_N AIR FREQAIR.314

COMBI_N COMBI FREQCOMBL.314
CONTAINE_N CONTAINERV FREQCONTAINERVESSEL.314
LORRY_N LORRY FREQLORRY.314
OTHER_N OTHER FREQOTHERVESSEL.314
ROROVES_N ROROVES FREQROROVESSEL.314
WAGONL_N WAGONL FREQWAGGONLOAD.314
RAILFERR_N RAILFERRY FREQRAILFERRY.314
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Attribute in node Attribute in link table File under Input\LOS
table

ROADFERR_N ROADFERRY FREQROADFERRY.314
INWW_N INWW FREQIWW.314

Table 40 - Format of “Frequency_data_Base2017_Node” table.

Field Description Data Format Example
OBJECTID Counter Integer 25
SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 25
X Coordinate x (SWEREF99_TM) Double 1593100
Y Coordinate y (SWEREF9g9_TM) Double 6562900
ZONEORIG_N Original node number in EMME Numbering for the Integer 714000
origin
ZONEDEST_N Original node number in EMME Numbering for the Integer 714000
destination
SYSTEM_N Frequency System Double o)
AIR_N Frequency air Double o)
COMBI_N Frequency Combi Double 0
CONTAINE_N Frequency ContainerVessel Double 0
LORRY_N Frequency Lorry Double 84
OTHER_N Frequency Other Vessels Double o)
ROROVES_N Frequency RororVessel Double o)
WAGONL_N Frequency WaggonLoad Double o)
RAILFERR_N Frequency Railferry Double o)
ROADFERR_N Frequency RoadFerry Double o)
INWW_N Frequency Inland water Double 0
GEOMETRYSOURCE Number representing to which network the node Double 4
belongs (1-Road 2-Rail 3_sea 4-Air)
Table 41 - Format of “Frequency_data_Base2017_Link” table.
Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (lane) OLE Object Long Binary Data
A Start node in VY Numbering Integer 1
B End node in VY Numbering Integer 1100
Shape_Length Length based on distance between coordinates in Double 6796881.71149
meters
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Field Description Data Format Example
ZONEORIG Original node number in EMME Numbering for the Integer 711400
origin
ZONEDEST Original node number in EMME Numbering for the Integer 730521
destination
SYSTEM Frequency System Double 0
AIR Frequency air Double 0
COMBI Frequency Combi Double 0
CONTAINERV Frequency ContainerVessel Double 0.1
LORRY Frequency Lorry Double 0
OTHER Frequency Other Vessels Double 0.5
ROROVES Frequency RororVessel Double 0.2
WAGONL Frequency WaggonLoad Double o]
RAILFERRY Frequency Railferry Double o]
ROADFERRY Frequency RoadFerry Double 0
INWW Frequency Inland water Double 0.0

Software required: Microsoft Access, Cube GIS Window (see Help>Cube Base>GIS window), ArcMap.

Description of Use: Define the base network.

Editing Options: No edits; all the changes will be allowed only in the export phase merging the scenario

specific tables and the base tables.

Used by: All the applications.

3.2.3.3. Cargo_Base2017
o5_Input_data\Input_data.mdb\Cargo_ Base2017

The table, Table 42, represents the default values for the commodities, with all the parameters used in the

logistics module.

Table 42 - Format of “Cargo_Base2017” table.

Field Description Data Example
Format
OBJECTID Counter Integer 1
ID_COM Commodity code Integer 1
DESC_COMM Description of commodity String Cereals
VALUE_SEKT Value in SEK per ton Integer 1350
INV_COST Inventory cost Integer 466
ORD_COST Order cost Double 1829
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Field Description Data Example
Format

NSTR_NR NSTR code Integer 10
AGGR_NUM Class used in reporting, if set from 1 to 16 is just commodity group number. Integer 1
AGGR_COM Commodity aggregation (three classes Dry bulk, General cargo, Liquid bulk) String Dry bulk
COM_TYPE Code for the commodity aggregation (1 Dry bulk, 2 Liquid bulk, 3 general Integer 1

cargo)
PRORCOST ProportionalOrderCosts Parameter used for the calculation of the annual Double 2.19109

demand dependent order costs. The annual demand dependent order costs are

calculated as: OrderCosts = FixedOrderCosts + ProportionalOrderCosts x

AnnualDemand” Alpha
ALPHA Parameter used in the order cost calculation Single 0.5
SHIP_SIZE Typical shipment size for this commodity. This parameter is used to determine | String 41

the shipment size q [tonnes per shipment] and calculate the logistic costs for
the chains in the BuildChain phase. This parameter can be either a number or
DYNAMIC_MAX, DYNAMIC_AVERAGE or DYNAMIC_GEOMEAN. See

Program_ Documentation_Sweden_November_2019. Pg. 34 for details

OPTIP Code for including all costs or only transport costs for producers o=include all | Integer 0

costs 1=include only transport costs

OPTIW Code for including all costs or only transport costs for wholesale. o=include all | Integer o

costs 1=include only transport costs

MFREQ Minimum frequency that is used when the default frequency is not available in | Integer 1

the vehicle cost file

SELECT_BC Manage the existence of the select.dat file for BuildChain (0- no, 1 —yes) Integer o)

SELECT_CC Manage the existence of the select.dat file for ChainChoi (0- no, 1 —yes) Integer o

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcCatalog.

Description of Use: Defines the values in INPUT\COST\CARGO.TXT and some control parameters
(SELECT_BC and SELECT_CC) in BuildChain.ctl and ChainChoi.ctl control files. See reference 3 for more
details.

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

Used by: “Editable tables” subgroup under “Create the editable files”, “Create the tables specific of scenario”
subgroup under “Edit the data”, “Data Preparation” subgroup under “Samgods Model > LOS calculation” and
“Create the new base” subgroup under “Handling scenario > Scenario Export”.

3.2.3.4. Node_terminals_Base2017
o5_Input_data\Input_data.mdb\Node_terminals_Base2017

The table, Table 43, holds the information of pilot fees for each port and vehicle type.

Table 43 - Format of “Node_terminals_Base2017” table.
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Field Description Data Format Example
OBJECTID Count Integer 9

N Node number in VY Numbering Integer 211
TERMINAL_N Code number in EMME Numbering for port Integer 808322
PILOT_V3o01 Pilot fee for vehicle type 301 [SEK] Double 4932
PILOT_V302 Pilot fee for vehicle type 302 [SEK] Double 7054
PILOT V303 Pilot fee for vehicle type 303 [SEK] Double 8240
PILOT_V304 Pilot fee for vehicle type 304 [SEK] Double 11757
PILOT_V305 Pilot fee for vehicle type 305 [SEK] Double 2393
PILOT_V306 Pilot fee for vehicle type 306 [SEK] Double 3412
PILOT_V307 Pilot fee for vehicle type 307 [SEK] Double 3766
PILOT_V308 Pilot fee for vehicle type 308 [SEK] Double 4224
PILOT_V309 Pilot fee for vehicle type 309 [SEK] Double 5639
PILOT_V310 Pilot fee for vehicle type 310 [SEK] Double 7054
PILOT_V311 Pilot fee for vehicle type 311 [SEK] Double 8240
PILOT_V312 Pilot fee for vehicle type 312 [SEK] Double 10692
PILOT V313 Pilot fee for vehicle type 313 [SEK] Double 10692
PILOT_V314 Pilot fee for vehicle type 314 [SEK] Double 11757
PILOT V315 Pilot fee for vehicle type 315 [SEK] Double 7054
PILOT_V316 Pilot fee for vehicle type 316 [SEK] Double 8240
PILOT V317 Pilot fee for vehicle type 317 [SEK] Double 9406

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Pilot fees for Swedish ports per vehicle type. Values are exported to
INPUT\COST\PILOTFEES.TXT.

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

Used by: “Editable map data” subgroup under “Create the editable file”, “Compare Nodes and
Node_terminals” subgroup under “Edit the data > Create the tables specific of scenario”, “Prepare data”
subgroup under “Samgods Model > Logistics Module", and “Create the new base” subgroup under “Handling
scenario > Scenario Export”.

3.2.3.5. Nodes_Base2017
o5_Input_data\Input_data.mdb\Nodes_Base2017

The table contains information about the zones and terminals, the format is shown in Table 44.

Table 44 - Format of “Nodes_Base2017” table.
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Field Description Data Format Example
OBJECTID Counter Integer 10
N Zone number in VY Numbering Integer 10
ZONEID Code number in EMME Numbering for zone Integer 712500
NAME Description of the zone/terminal String Zone: Ekero
ZONET Zone code for node location if direct access, 0 other cases Integer 712500
DOMESTIC Dummy for domestic location (1=domestic, 0=non Integer 1
domestic)
C_TECH_FAC Cost efficiency factor in terminals Double 1
T_TECH_FAC Time efficiency factor in terminals Double 1
MAXDWTCONT Load constraint for container vessels that the port can Double 0
manage [tonnes]
MAXDWTRORO Load constraint for RoRo vessels that the port can manage | Double o]
[tonnes]
MAXDWOTHE Load constraint for other vessels that the port can manage | Double o]
[tonnes]
SEAOUTPUT Yearly sea output[tonne]. Used for consolidation Double o]
determination.
SEACONTO Yearly container output [tonne] Used for consolidation Double o]
determination.
AIROUTPUT Yearly air output [tonne] Used for consolidation Double [}
determination.
TranOceFac Penalty factor applied during the LOS calculation for Double o]
TIME. The final time will penalized by a factor in the
following manner:
TIME (from the network)* (1+OrigFactor)*(1+DestFactor)
where OrigFactor is TranOceFac for the origin and
DestFactor is TranOceFac for the destination
PORTAREANR Port area number for the specific port. Values from Integer o]
A_Port_areas table
VANERNCAN Capacity associated to a port in Vénern Lake. Value Double o]
represents dwell units allowed in the particular port. See
section 6.5.2 for further details.

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),

ArcCatalog.

Description of Use: definition for each zone and terminal of different parameters representing capacities and

location in .\Input\Nodes\NODES.TXT file. TranOceFac is explicitly used in the Samgods application

generating the impedance factors per each origin and destination in LOS calculation (Matrix step #3 and
HIGHWAY step #7) applied to TIME skim.

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific

tables and the base tables.
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Used by: “Editable map data” subgroup under “Create the editable files”, “Compare Nodes and
Node_terminals” subgroup under “Edit the data > Create the tables specific of scenario”, “Data Preparation”
subgroup under “Samgods Model > LOS calculation”, “Prepare Data second” subgroup under “Samgods
Model > Logistics Module” and “Create the new base” subgroup under “Handling scenario > Scenario
Export”.

3.2.3.6. Nodes_Commodities_Base2017
o5_Input_data\Input_data.mdb\Nodes_Commodities_Base2017

The table contains information about the possibility of transfer in every zone and terminal by commodity,
with format as shown in Table 45. In Table 48 the correspondence between Transfer Type and related input
file in the logistics module.

Table 45 - Format of “Nodes_Commodities_Base2017” table.

Field Description Data Example
Format
OBJECTID Count Integer 21
N Zone number in VY Numbering Integer 21
ZONEID Code number in EMME Numbering for zone or terminal Integer 713611
TRANSF_TYP Transfer type code (referred to A_Transfer_type table) Integer 14
COM_1 Dummy representing whether a transfer of a certain type is allowed Integer 1
for listed terminals etc for commodity group 1
COM_2 As above for commodity group 2 Integer 2
COM_3 As above for commodity group 3 Integer 3
COM_4 As above for commodity group 4 Integer 4
COM_5 As above for commodity group 5 Integer 5
COM_6 As above for commodity group 6 Integer 6
COM_7 As above for commodity group 7 Integer 7
COM_8 As above for commodity group 8 Integer 8
COM_9 As above for commodity group 9 Integer 9
COM._10 As above for commodity group 10 Integer 10
COM_11 As above for commodity group 11 Integer 11
COM_12 As above for commodity group 12 Integer 12
COM_13 As above for commodity group 13 Integer 13
COM_14 As above for commodity group 14 Integer 14
COM_15 As above for commodity group 15 Integer 15
COM_16 As above for commodity group 16 Integer 16

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.
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Description of Use: Define per transfer type the list of terminals where at least one commodity may be
subject to transfer. It is the source to produce files under Input\Nodes. Based on each transfer type.

For instance the following records in Table 46 will be translated into 3 rows in each file representing different
transfer types, as shown in Table 47. Thus,

o TRANSFERROADTRAIN.TXT (TRANSF_TYPE=3) will be given the commodity group number for
all the commodities where COM_X<>0 and ZONEID=713611

¢ DIRECTFEEDERTRAIN.TXT (TRANSF_TYPE=14) will be given the commodity group number for
all the commodities where COM_X<>0 and ZONEID=713611

¢ DIRECTFEEDERTRAIN.TXT (TRANSF_TYPE=16) will be given the commodity group number for
all the commodities where COM_X<>0 and ZONEID=713611

Table 46 - Example of rows in the access table.

N ZONEID TRANSF_TYP COM_1 COM_2 COM_3 COM_4 COM_5 COM_6 COM_7
21 713611 3 1 2 3 4 5 6 7
21 713611 14 1 2 3 4 5 6 7
21 713611 16 o o o o o o (o}

Table 47 - Example of output.

File Record

TRANSFERROADTRAIN.TXT | 713611 Rail: Jordbro 1 2 3 4
5 6 7

FREQOTHERVESSEL.314 713611 Rail: Jordbro 1 2 3 4
5 6 7

DIRECTFEEDERTRAIN.TXT | 713611 Rail: Jordbro 0 0 0 o)
0 0 0

Table 48 - Correspondence between file system and Nodes_commodities table.

TRANSF_TYP DESCRIPTIO File under Input\Nodes

1 TransferRoadRoad TRANSFERROADROAD.TXT

2 TransferRoadCombi TRANSFERROADCOMBI.TXT

3 TransferRoadTrain TRANSFERROADTRAIN.TXT

4 TransferRoadSea TRANSFERROADSEA.TXT

5 TransferRoadRoadFerry TRANSFERROADROADFERRY.TXT
6 TransferRoadAir TRANSFERROADAIR.TXT

7 TransferCombiSea TRANSFERCOMBISEA.TXT
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TRANSF_TYP DESCRIPTIO File under Input\Nodes

8 TransferFeederTrainWagonload TRANSFERFEEDERTRAINWAGONLOAD.TXT
9 TransferWagonloadSea TRANSFERWAGONLOADSEA.TXT

10 TransferWagonloadRailFerry TRANSFERWAGONLOADRAILFERRY.TXT
11 TransferSystemTrainSea TRANSFERSYSTEMTRAINSEA.TXT

12 TransferSeaSea TRANSFERSEASEA. TXT

13 ContainerHandling CONTAINERHANDLING.TXT

14 DirectFeederTrain DIRECTFEEDERTRAIN.TXT

15 DirectSea DIRECTSEA.TXT

16 DirectSystemTrain DIRECTSYSTEMTRAIN.TXT

17 DirectWagonLoad DIRECTWAGONLOAD.TXT

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables

Used by: “Editable map data” subgroup under “Create the editable files”, “Compare other tables” subgroup
under “Edit the data”, “Prepare Data second part” subgroup under “Samgods Model > Logistics Module” and
“Create the new base” subgroup under “Handling scenario > Scenario Export”

3.2.3.7. PropLink_Base2017
o5_Input_data\Input_data.mdb\PropLink_Base2017

This table, Table 49, provides information about the proportion WEIGHT of a link A-B that resides in a zone
REGION. The proportion is given in percent (0-100).

Table 49 - Format of “PropLink_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 696
A Start node in VY Numbering Integer 2793
B End node in VY Numbering Integer 2794
REGION SCBSTANN code Integer 136
WEIGHT Weight proportional to the part of the link residing in the | Double 100

zone.

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Table with all road and rail links that share a different SCBSTANN area. Each record
provides the proportion of the link length belonging to the listed SCBSTANN area. The proportion is used to
classify tonneskm and vehicleskm statistics per region and county. (See reports #9, 16, 17 and 18).

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.
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Used by: “Reports per geographical aggregation” subgroup under “Samgods Model > Results > Results 1.0,
“Samgods Model > Results RCM > Results1.0”, “Create the new base” subgroup under “Handling scenario >
Scenario Export” and “Create the scenario tables” subgroup under “Handling scenario > Scenario Export >
Create the new scenario specific tables”.

3.2.3.8. Rail_Capacity_Base2017
o5_Input_data\Input_data.mdb\Rail _Capacity_Base2017

This table, Table 50, provides the capacity ORIGCAP for a link A-B having the trakbandel category
TRAKBANDEL.

Table 50 - Format of “Rail_Capacity_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
ID_LINK Link identified for rail link. Two links in opposite Integer 25

direction share the same ID_LINK.

A Start voyager node Integer 2000
B End voyager node Integer 2001
TRAKBANDEL Trakbandel code for link Integer 4333
ORIGCAP Original value for capacity in bidirectional trains per day Double 418

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: This table represents the main input for Rail Capacity Management module, since the
number of total vehicles on rail links is compared with the ORIGCAP value. The links with ratio V/C equals
or greater than the value in catalog key " Cut off criteria for RCM process (will consider links with V/C >
XX% where XX is given in percentage)" will be selected as part of the linear programming problem. For
details on edits of this table, please see reference 6. It is also a mandatory input for the Rail Assignment
under "Samgods Model > RCM Assignment > Rail Assignment RCM" since in this case the assignment is
based on capacity constraints, e.g. the delay functions are related to the ratio V/C.

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

Used by: “Editable tables” subgroup under “Create the editable files”, “Rail Capacity Checks” subgroup under
“Edit the data > Create the tables specific of scenario”, “Data Preparation” subgroup under “Samgods Model
> LOS calculation”, “Create the new base” subgroup under “Handling scenario > Scenario Export” and
“Create the scenario tables” subgroup under “Handling scenario > Scenario Export > Create the new scenario
specific tables”.

3.2.3.9. Tax_Category_Base2017
o5_Input_data\Input_data.mdb\Tax_Category_Base2017

This table, Table 51, provides information about the tax SEK per link category LINKTYPE and vehicle type
ID_VEHICLE.

Table 51 - Format of “Tax_Category_Base2017” table.
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Field Description Data Format Example
OBJECTID Counter Integer 17
LINKTYPE Link category Integer 580
ID_VEHICLE Vehicle type Integer 317

SEK Track fee or tax [SEK] Double 53700

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Specifies a link based tax defined by the link category and vehicle type. In the current
model the only tax applied is for Kiel Canal (CATEGORY=570).

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup
under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods
Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario
> Scenario Export”.

3.2.3.10. Tax_Country_Base2017
o5_Input_data\Input_data.mdb\Tax_Country_Base2017

This table, Table 52, provides information about the tax SEK_KM per country ID_ COUNTRY and vehicle
type ID_VEHICLE.

Table 52 - Format of “Tax_Country_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
ID_COUNTRY Country code Integer -1
ID_VEHICLE Vehicle type Integer 201
SEK_KM Country tax per km [SEK/km] Double 4.47

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Specifies a link based tax defined by country and vehicle type. (NB. -1 values refer to
countries outside Sweden).

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

”» o«

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup
under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods
Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario
> Scenario Export”.

3.2.3.11. Tax_Link_Base2017
o5_Input_data\Input_data.mdb\Tax_Link_Base2017

This table, Table 53, provides information about the tax SEK per link A-B and vehicle type VEH_NR.
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Table 53 - Format of “Tax_Link_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 4

A Start node in VY Numbering Integer 1007

B End node in VY Numbering Integer 1009
VEH_NR Vehicle type Integer 101

SEK Track fee or tax [SEK] Double 18

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Specifies a link based tax by vehicle type.

Editing Options: No edits; all the Changes will be allowed only in the export phase merging the scenario
specific tables and the base tables.

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup
under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods
Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario
> Scenario Export”.

NOTE: For the same link it is possible to define tax values based on country criteria, category criteria and
also its selection (three tables above). However the final result will be based on the following rule:

TAX_ COUNTRY < TAX CATEGORY < TAX LINK

The value in the Tax_ Link table will override the other values, so the final result will come from the
evaluation of an OR logical condition. Zero values also have a meaning, inserting a zero in the table value will
set the tax to zero. For instance 0 in the Tax_Link table will set the tax value for the specific link to zero.

3.2.3.12. Toll_Link_Base2017
o5_Input_data\Input_data.mdb\Toll_Link_Base2017

This table, Table 54, provides information about the toll SEK per link A-B and vehicle type VEH_NR.
Table 54 - Format of “Toll_Link_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 4

A Start node in VY Numbering Integer 2001

B End node in VY Numbering Integer 25742
VEH_NR Vehicle type Integer 205

SEK Link toll [SEK] per passing vehicle Double 5070
DESCRIPT Description of the infrastructure (in general bridges) String Toll Oresund

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Defines a toll applied to a link per vehicle type.
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Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

» &«

Used by: “Editable tables” subgroup under “Create the editable files”, “Compare other tables” subgroup
under “Edit the data > Create the tables specific of scenario”, “Tax calculation” subgroup under “Samgods
Model > LOS calculation > Data Preparation” and “Create the new base” subgroup under “Handling scenario
> Scenario Export”.

Vehicles_parameters_PartA_Base2017
o5_Input_data\Input_data.mdb\Vehicles_parameters_PartA_Base2017

This table, Table 55, provides information about the vehicle parameters related to the cost and property of
the vehicle identified by vehicle type VEH_NR (or DESCRIPTIO or LABEL).

Table 55 - Format of “Vehicles_parameters_PartA_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 4
ID Index for vehicle type Integer 4
VEH_NR Vehicle number Integer 104
DESCRIPTIO Description of vehicle type String Lorry HGV
25-40 tonne

LABEL Short name for the vehicle type String HGV24
KM_COST Km cost [SEK/km] Double 3.7794
HOURS_COST Hour cost [SEK/h] Double 288
DFLTFREQ Default frequency (per week) Double 84
F_DUES_VH Fairway Dues per Vehicle (SEK/vessel) Double 0
F_DUES_TON Fairway Dues per Tonne (SEK/tonne) Double o]
CAPACITY Maximum Load Capacity (Tonnes) Double 28
VESSELTYPE Vessel Type (container/non container) Integer o)
ONFER_H _C On Ferry Hour Cost (SEK/hour) Double 488.4
ONFER_KM_C On Ferry Km Cost (SEK/km) Double 2.9
POSICOST Positioning Cost (SEK/vehicle) Double o]
SPEED Speed (only sea modes) (km/hour) Double -1
VDF_SPEC Volume delay function index (FUNCTION in link table) Double 64
MODE_1 Code for network mode alternative 1 String a
MODE_2 Code for network mode alternative 2 String -
FUNC_FILE Set of applied travel time functions applied String Vio2
EMPTY_V Dummy variable to take in account empty vehicles during the Integer 1

creation of OD vehicle matrices. (0=no 1=yes)
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COORFACT Coordination factor. Factor used to catch the fact that the available | Single 10
volume for each vehicle movement will be lower than the

calculated annual consolidation volumes on the OD-legs

MAX_SPEED Define speed limits for road vehicles Double 116

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Defines all the parameters related to cost and time coefficients for the logistics model
(files under LogMod\Input\COST) by vehicle type. Also controls the codes used in opening/closing links in
the network (parameters SPEED, VDF_SPEC, MODE_1, MODE_ 2, FUNC_FILE) during LOS and
assignment steps.

Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

Used by: “Editable tables” subgroup under “Create the editable files”, “Create the tables specific of scenario”
subgroup under “Edit the data” and its subgroup “Compare other tables”, “Data Preparation” subgroup
under “Samgods Model > LOS calculation” and “Create the new base” subgroup under “Handling scenario >
Scenario Export”.

3.2.3.13. Vehicles_parameters_PartB_Base2017
o5_Input_data\Input_data.mdb\Vehicles_parameters_PartB_Base2017

This table, Table 56, provides information about the vehicle parameters related to cost for loading and
unloading identified by vehicle type VEH_NR and commodity ID_ COM.

Table 56 - Format of “Vehicles_parameters_PartB_Base2017” table.

Field Description Data Format Example
OBJECTID Counter Integer 4
D Index for vehicle type Integer 4
ID_COM Identifier for commodity group Integer 16
VEH_NR Vehicle number Integer 104
NC_LCO Non container Load Cost (SEK/tonne) Double 3
NC_LTI Non container Load Time (hours) Double 2
NC_LCOT Non container Load Cost at transfer (SEK/tonne) Double 3
NC_LTIT Non container Load Time at transfer (hours) Double 2
CONT_LCO Container Load Cost (SEK/tonne) Double 17
CONT_LTI Container Load Time (hours) Double 1
CONT_LCO_T Container Load Cost at transfer (SEK/tonne) Double 17
CONT_LTI_T Container Load Time at transfer (hours) Double 1

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Defines all the parameters related to cost and time coefficients for the logistics model
(files under LogMod\Input\COST).
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Editing Options: No edits; Changes will be allowed only in the export phase merging the scenario specific
tables and the base tables.

» &«

Used by: “Editable tables” subgroup under “Create the editable files”, “Create the tables specific of scenario”
subgroup under “Edit the data” and its subgroup “Compare other tables”, “Data Preparation” subgroup
under “Samgods Model > LOS calculation” and “Create the new base” subgroup under “Handling scenario >
Scenario Export”.

3.2.3.14. Scenarios_List
o5_Input_data\Input_data.mdb\Scenarios_List

This table, Table 57, holds information about the elasticity scenarios identified by ID_SCENARIO.

Table 57 - Format of “Scenarios_List” table.

Field Description Data Format Example

ID Counter Integer 4

ID_SCENARIO Scenario number Integer 4

Mode Description of mode in which sensitivity test is applied (can be a String Road
main mode or a combination of vehicle types)

Scenario Scenario types String KM_3

KM_COST Variation in km cost Double 1.02

HOURS_COST Variation in hour cost Double 1

NC_LTI Variation in non-container loading time Double 1

NC_LTIT Variation in non-container loading time transit Double 1

CONT_LTI Variation in container loading time Double 1

CONT_LTL_T Variation in container loading time transfer Double 1

TOLL Variation in toll Double 1

TRACK_F Variation in track fee Double 1

F DUES _VH Variation in ferry due vehicles Double 1

F_DUES_TON Variation in ferry due tons Double 1

ID_VEHICLES Vehicle types range String 101-106

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Defines all the parameters related to cost and time coefficients for sensitivity tests within
“Elasticity module”.

Editing Options: Edits from Cube or Microsoft Access.

Used by: “Elasticity module”.

3.2.4. Scenario specific data

In term of structure all the tables listed above have a copy in the scenario specific data, shown by the
relations presented in Table 58.
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Table 58 - Relation between base and scenario specific data.

Base Table Scenario Specific Table
Base2017 Sc_{SCENARIO_SHORTNAME}_Link
Sc_{SCENARIO_SHORTNAME}_Node
Cargo_Base2017 Sc_{SCENARIO_SHORTNAME}_Cargo
Frequency_Data_Base2017 Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Link
Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Node
Node_terminals_Base2017 Sc_{SCENARIO_SHORTNAME}_ Node_Terminals
Nodes_Base2017 Sc_{SCENARIO_SHORTNAME}_Nodes
Nodes_ Commodities_ Base2017 Sc_{SCENARIO_SHORTNAME}_ Nodes_commodities
PropLink_Base2017 Sc_{SCENARIO_SHORTNAME}_PropLink
Rail_Capacity_Base2017 Sc_{SCENARIO_SHORTNAME}_Rail_Capacity
Tax_Category_Base2017 Sc_{SCENARIO_SHORTNAME}_ Tax_Category
Tax_Country_Base2017 Sc_{SCENARIO_SHORTNAME}_Tax_Country
Tax_Link_Base2017 Sc_{SCENARIO_SHORTNAME}_ Tax_Link
Toll_Link_Base2017 Sc_{SCENARIO_SHORTNAME}_Toll_Link
Vehicles_parameters_PartA_Base2017 Sc_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA
Vehicles_parameters_PartB_Base2017 Sc_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB

All the scenario specific tables (except SC_{SCENARIO_SHORTNAME}_ ProprLink,
SC_{SCENARIO_SHORTNAME}_ Vehicles_Parameters_PartA ,
SC_{SCENARIO_SHORTNAME} Vehicles Parameters_ PartB and
SC_{SCENARIO_SHORTNAME}_Cargo) have an extra attribute UP_DATE or UP_DATE_N that will
record the differences between the scenario and the reference case.

This field, with string format, is used to store the information regarding how to update the base data. The
following values are used

e U - Update an existing value in the base table;
e A-Append a new record to the base table;
e D - Delete a record from the base table.

These values are automatically managed by the applications “Edit the data”. The user must not type, modity,
or change them. For ProprLink and Vehicles_Parameters all the elements present in these table will
overwrite those in the reference case, e.g. a simpler substitution.

There are two other tables that are managed differently from the general rule:
General_{SCENARIO_SHORTNAME} and LogMod_{SCENARIO_SHORTNAME}. These are scenario
specific and are not managed through the general difference record keeping. Those tables hold the definition
of several control parameters used in the Logistics Module and in the GUI. They contain parameters that are
controlled by catalog keys and could vary between scenarios.

3.2.4.1. General {SCENARIO_SHORTNAME}
o5_Input_data\Input_data.mdb\General {SCENARIO_SHORTNAME}

This table, Table 59, holds general information about the scenario.
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Field Description Data Format Example
OBJECTID Counter Integer 1
SC_N Scenario number (1-default, higher if saved also in Integer 1
emmebank)
DATE_C Date and time of creation String 14/08/2013 09:24
DATE_L Date and time of last modification if the scenario is in String 14/08/2013 11:01
read/write mode, otherwise the date of lock.
ZONES_M Number of zones Integer 1120
GCOST Attribute name for extra cost on links [SEK] String EC_V
GCOST_KM Attribute name for extra cost per km on links [SEK/km] String EC_KM_V
DF Daily factor for all the modes except rail mode [number of | Integer 250
days per year]
DFR Daily factor for rail mode [number of days per year] Integer 250
READ_WRITE State of scenario (only read or read/write Yes=only read) | String Yes

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),

ArcCatalog.

Description of Use: This table responds to a high variety of uses:

e SC_Nis used to recode where the base network was saved in the emmebank (1 if not, higher is
saved). Since EMME is not used in the model anymore, it will always be 1

e DATE_C and DATE_L are the time references to check when updating existing temporary data in
the model. They are also used for long time storage purposes

e ZONE_M, GCOST and GCOST_KM refer to this kind of attributes saved in the network

e DF and DFR: general parameters for assignment

e READ_WRITE: state variable to prevent further edits of a scenario, or to leave the scenario as

editable.

Editing Options: The first two points listed above, and the last one, are managed by the system, never

changed by the user. The others (ZONE_M, GCPST, GCOST_KM,DF,DFR) are modifiable from catalog keys
present in the interface under "Edit the data" application.

Used by: “Prepare temporary data” subgroup under “Create the editable files”, “Create the tables specific of
scenario” subgroup under “Edit the data”, “PWC_Matrices” and several subgroups under “Samgods Model”.

3.2.4.2. LogMod_{SCENARIO_SHORTNAME}
o5_Input_data\Input_data.mdb\LogMod_{SCENARIO_SHORTNAME}

This table, Table 60, holds information from the GUI used in the LogMod module.

Table 60 - Format of “LogMod_{SCENARIO_SHORTNAME}” table.

Field

Description

Data Example

Format
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OBJECTID Counter Integer 1

INTER_RATE Parameter INTEREST, interest rate used in cost calculations [%/year] Double 0.1

STUFF Parameter STUFF, costs for stuffing and stripping of containers at the origin and Double 60
destination of a chain [SEK per tonne]

CONTYPE Parameter ALL,LORRY_TYPE_CONSOL, 0/1 switch that determines whether or not Integer 1
consolidation is allowed for all lorry types

INODLO Parameter INDIVIDUAL_OD_LEG_OPTIMIZE, o/1 switch that determines whether Integer 1
or not the optimization is done for each chain leg individually in a transport chain

MATD4FO Parameter MINIMUM_ANNUAL_TONNE_DEMAND_4_FREQ_OPTIMIZE Double 100
[Tonnes], Minimum demand for frequency optimization

CONSOL_L First value of parameter CONSOL. It sets the default lower bound for the consolidation | Double 0.05
levels.

CONSOL_U Second value of parameter CONSOL. It sets the default upper bound for the Double 0.95
consolidation levels.

TONNES Parameter TONNES. If this parameter is a number, then this number will be used as String DYNAMIC_A
the typical shipment size for this commodity. If this the parameter is set to VERAGE
DYNAMIC_MAX, DYNAMIC_AVERAGE or DYNAMIC_GEOMEAN the typical
shipment size will be different for different zones and calculated as the maximum,
average or geometric mean of the PWC matrix-values for the current origin zone

LSTCNT Parameter LSTCNT It sets the number of output files: 1= only best chains; 2 = best Integer 5
chains and second best chains. The current default is 5. It is recommended to not
change this default since it is related to Rail Capacity Management module.

DATA Parameter DATA, Output variables for the optimal transport solution [e.g.1,2,3, maxis | String 6,7
8]. Nbrs 6 and 7 are useful when analysing detail in the results since all relevant data
for the transport chains are available. The cost data are split into different
components, operational costs, loading/unloading costs and infrastructure costs.

FACTOR Parameter FACTOR, Initial consolidation factor in BuildChain (1%t iteration) Single 0.75

LOGCTL Parameter LOGCTL, indicator (0/1) that determines whether or not CTL file settings Integer 1
will be logged in the common log file for the commodity

LOGFLS Parameter LOGFLS, indicator (0/1) that determines whether or not input file Integer 1
information will be logged in the common log file for the commodity

LOGCST Parameter LOGCST, indicator (0/1) that determines whether or not cost parameters Integer 1
will be in the common log file for the commodity

BESTOUT Parameter BESTOUT, integer that determines whether or not DATA reports should be | Integer 1
print out per each solution (best, second, third, etc. solution)

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),

ArcCatalog.

Description of Use: This table is used in setting up the control files for BuildChain, ChainChoi,

BuildChainRCM and ChainChoiRCM. All the parameters listed above control the process both in terms of

reporting (log files) and settings for some variables. See reference 3 for their meaning and usage.

Editing Options: In "Edit the data" application each parameter is present as catalog key. Its value could be

revised directly from the Scenario Window. For further details see reference 6.
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Used by: “Prepare temporary data” subgroup under “Create the editable files,” “Prepare Data third part”
subgroup under “Samgods Model > Logistics Module”, “Delete” and “Scenario Import” subgroups under
“Handling scenario” and “General tables” subgroup under “Handling scenario > Scenario Export”.

3.2.5. Manage database

3.2.5.1. History
o5_Input_data\Input_data.mdb\History

This table, Table 61, holds information about the different instances.

Table 61 - Format of “History” table.

Field Description Data Format Example

OBJECTID Counter Integer 1

MODEL Folder of the original model used to create the new model | String {CATALOG_DIR}
(father model)

BASE_SCE Name of Base scenario in original model String Base2017

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: For setting up new models (new model is created each time it is required to modify some
general settings or input file such as chain types, etc). The table maintains the information of the father
model used to setup the new model. This table traces the relationships among different versions.

Editing Options: Always changed by the system.

Used by: “General tables” subgroup under “Handling scenario > Scenario Export.”

3.2.5.2. Model_description
o5_Input_data\Input_data.mdb\Model_description

This table, Table 62, holds information about the programs related to the setup.

Table 62 - Format of “Model_description” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

NAME Software name String Cube
REALISE Software version String 6.1.0

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),
ArcMap, ArcCatalog.

Description of Use: Defines the release version for each program used in the model. This information could
allow be checked regarding whether the correct version of a particular model is used.

Editing Options: No edits; always changed by the system.

” «

Used by: “Installation,” “General tables” subgroup under “Handling scenario > Scenario Export” and
“Scenario Import” subgroup under “Handling scenario”.
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3.3. Calibration data

The calibration data is used when running the model in calibration mode. When using the model as standard
or advance user this data is not modified along the run. It represents the calibrated conditions that should be
used in evaluating different scenarios and represents an input an invariant input for the model.

3.3.1. Port Area parameters per commodity group

o5_Input_data\Calibration\ PortAreaParams_16_Comm.txt and 05_Input_data\Calibration\
PortAreaParams_16_CBA.txt

This table, Table 63, provide the scaling factor per commodity and port area.

Table 63 - Format of “PortAreaParams_16_Comm.txt” table.

Field Description Data Format Example
PortArea Port Area number Integer 1.0
COMo1 Scaling factor for COMMODITY group 1 Long 0.02
COMo2 Scaling factor for COMMODITY group 2 Long 0.02
COMos3 Scaling factor for COMMODITY group 3 Long 1.00
COMog4 Scaling factor for COMMODITY group 4 Long 0.02
COMos Scaling factor for COMMODITY group 5 Long 0.02
COMo6 Scaling factor for COMMODITY group 6 Long 2.22
COMo7y Scaling factor for COMMODITY group 7 Long 0.90
COMo8 Scaling factor for COMMODITY group 8 Long 1.40
COMo9 Scaling factor for COMMODITY group 9 Long 0.88
COM10 Scaling factor for COMMODITY group 10 Long 0.02
COM11 Scaling factor for COMMODITY group 11 Long 1.00
COM12 Scaling factor for COMMODITY group 12 Long 1.00
COM13 Scaling factor for COMMODITY group 13 Long 0.88
COM14 Scaling factor for COMMODITY group 14 Long 0.02
COM15 Scaling factor for COMMODITY group 15 Long 1.00
COM16 Scaling factor for COMMODITY group 16 Long 1.00

Software Required: Notepad or similar.

Description of Use: Defines the scaling factor applied in TIME skim per port area and commodity group.

Editing Options: No edits. Results from the calibration procedure.

2 «

Used by: “Samgods\Logistics Module\” “General tables” subgroup under “Handling scenario > Scenario

Export” and “Scenario Import” subgroup under “Handling scenario.”

3.3.2. Parameters_Kielcalibration.dbf
o5_Input_data\Calibration\ Parameters_ Kielcalibration.dbf
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This table, Table 64, holds information about the calibration of Kiel canal scaling factor.

Table 64 - Format of “Parameters_Kielcalibration.dbf” table.

Field Description Data Example
Format

ID ID record Integer 1.0

STEP Step length in increasing or decreasing the Kiel canal scaling factor (starting Double 0.02
from 1, 1+STEP or 1-STEP depending the search function)

MINVAL Minimum boundary for scaling factor. If after adjustment the value is below Double 0.01
this value, it will be reset to VALo

DIFMAX Maximum difference between modelled and surveyed value. In this case the Double 2
distribution of tons between Kiel Canal and Jylland. 2 is in percentage

VALo Reset value used in case the procedure gives negative or less than MINVAL Double 0.02
results.

Software Required: Cube Data Window, Dbf editor.

Description of Use: Defines the control parameters in the adjust procedure for the Kiel Canal scaling factor.

Editing Options: No edits. Inputs for the calibration procedure.

Used by: “Samgods\Parameters calculation,” “General tables” subgroup under “Handling scenario >
Scenario Export” and “Scenario Import” subgroup under “Handling scenario”.

3.3.3. Parameters_portcalibration.dbf

o5_Input_data\Calibration\ Parameters_portcalibration.dbf

This table, Table 65, holds information about the calibration of port area factors.

Table 65 - Format of “Parameters_portcalibration.dbf” table.

Field Description Data Example
Format

ID ID record Integer 1.0

STEP Step length in increasing or decreasing the Kiel canal scaling factor (starting Double 0.02
from 1, 1+STEP or 1-STEP depending on the search direction)

MINVAL Minimum boundary for scaling factor. If after adjustment the value is below Double 0.01
this value, it will be reset to VALo

DIFMAX Maximum difference between modelled and surveyed value. In this case it is the | Double 100
total tonne throughput per port area and commodity group. (100*1000 tons
since statistics are tons/1000)

VALo Reset value used in case the procedure gives negative or less than MINVAL Double 0.02
results.

Software Required: Cube Data Window, Dbf editor.

Description of Use: Defines the control parameters in the scaling factor adjustment procedure for Port Areas

per commodity group.

Editing Options: No edits. Inputs for the calibration procedure.
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Used by: “Samgods\Parameters calculation,
Scenario Export” and “Scenario Import” subgroup under “Handling scenario”.

3.3.4. ScalingF_Veh
o5_Input_data\Input_data.mdb\ScalingF_Veh

o5_Input_data\Input_data.mdb\ScalingF_VehASEK

This table, Table 66, provides information about the scaling of vehicle costs and properties.

Table 66 - Format of “ScalingF_Veh” table.

General tables” subgroup under “Handling scenario >

Field Description Data Format Example
OBJECTID Counter Integer 1

ID Index for vehicle type Integer 1
VEH _NR Vehicle type Integer 101
DESCRIPTIO Description of vehicle type String Lorry light LGV.<
LABEL Label for vehicle type String LGV3
NC_LCO Scaling factor for Non container Load Cost (SEK/tonne) Double 1

NC LTI Scaling factor for Non container Load Time Double 1
DFLTFREQ Scaling factor for default frequency Double 1
CONT LCO Scaling factor for Container Load Cost Double 1
CONT LTI Scaling factor for Container Load Time Double 1
F_DUES VH Scaling factor for Fairway Dues per Vehicle Double 1
F_DUES TON Scaling factor for Fairway Dues per Tonne Double 1
CAPACITY Scaling factor for Maximum Load Capacity Double 1
VESSELTYPE Scaling factor for Vesseltype Double 1
ONFER H C Scaling factor for On Ferry Hour Cost Double 1
ONFER KM C Scaling factor for On Ferry Km Cost Double 1
POSICOST Scaling factor for Positioning Cost Double 1
NC_LCOT Scaling factor for Non container Load Cost at transfer Double o]
NC_LTIT Scaling factor for Non container Load Time at transfer Double o]
CONT LCO T Scaling factor for Container Load Cost at transfer Double 0
CONT _LTI_T Scaling factor for Container Load Time at transfer Double 0
COORFACT Scaling factor for coordination factor Double 0
ID_COM Commodity group - if 0 value is applied to all commodities Integer 1

Software Required: Microsoft Access, Cube Database Window (see Help -> Cube Base -> Database window),

ArcCatalog.

Description of Use: Define the scaling factors applied to vehicle parameters table per commodity group in

Samgods and CBA (in this case all the scaling factors are equal to 1).

Editing Options: Updated during the calibration process. No need to change for standard run.

Used by: “Samgods Model > Logistics Module\Prepare data application.”
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3.4. Output data

The output data can be split into two classes; the first one is the output that always will be generated by the
model independently of the user choices, the second one is only generated on user request.

3.4.1. General tables in geodatabase

The general tables provide general information about the scenario.

3.4.1.1. Model description
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Model_descripti
on

This table, Table 67, is a copy of Table 62.

Table 67 - Format of “Model_description” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

NAME Software name String Cube
REALISE Software version String 6.1.0

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Defines the release version for each program involved in the model. It is used for long-

term management of the model.
Used by: Not used.

Made by user choice: No.

3.4.1.2. Outputs
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\outputs

This table, Table 68, holds information about which outputs that been produced.

Table 68 - Format of “outputs” table.

Field Description Data Format Example

OBJECTID Counter Integer 2

OUTPUTR Description of the output String LOS_ROAD

ID_COM Commodity code (o for all) Double [}

DATE_E Date of last modification for the input data used to create | String 03-Feb-15 07:17 PM
this output

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),
ArcCatalog.

Description of Use: Storage of some input data settings and some output data for the last model runs.

Created by: “Prepare temporary data” subgroup under “Create the editable files.”
Updated by: several subgroups in the “Samgods Model” application.
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Made by user choice: No.

3.4.1.3. Node labels
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Node_ labels

This table, Table 69, holds information about the nodes.
Table 69 - Format of “Node_labels” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

N Node number VY Numbering Integer 1

NORIG Node number Emme numbering Integer 711400
SCBSTANN SCBSTANN code Integer 114
ID_COUNTRY Country code Integer 1
ID_REGION Region code Integer 114
MODE_N Mode for access to terminals Integer o)

Ul4 User field (not used in the current model) Integer [}

X Coordinate x (SWEREF99_TM) Integer 1620000
Y Coordinate y (SWEREFgg9_TM) Integer 6601000
CENTRALL Description String Upplands-Visby

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),

ArcCatalog.

Description of Use: Table with labels for each zone in the network. For reporting purposes and inside the

model for mapping of data between Voyager and EMME node numbering systems.

Created by: “Data Preparation” subgroup under “Samgods Model > LOS calculation.”

Used by: “Change matrix format” application.

Made by user choice: No.

3.4.1.4. ProprLink {SCENARIO_SHORTNAME}

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\ProprLink_{SC

ENARIO_SHORTNAME}

This table, Table 70, holds information about the output proportional table.
Table 70 - Format of “ProprLink_{SCENARIO_SHORTNAME}” table.

Field Description Data Format Example
OBJECTID Counter Integer 696

A Start node Integer 2793

B End node Integer 2794
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REGION

SCBSTANN code

Integer

136

WEIGHT

Proportion of the link within the SCBSTANN code (for
instance 100 means 100% of the link is in 136 SCBSTANN

code)

Double

100

Software Required: Microsoft Access or Cube Database window (see Help>Cube Base>Database window),

ArcCatalog.

Description of Use: Table with all road and rail links that are distributed in different SCBSTANN areas. Each

record gives the proportion of the length of the link part residing in each SCBSTANN area. The proportion is
used to estimate tonne km and vehicle km statistics per region and county. (See reports #9, 16, 17 and 18).

Used by: “Reports per geographical aggregation” subgroup under “Samgods Model > Results > Results 1.0,”
“Samgods Model > Results RCM > Results1.0”, “Create the new base” subgroup under “Handling scenario >
Scenario Export” and “Create the scenario tables” subgroup under “Handling scenario > Scenario Export >

Create the new scenario specific tables”.
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3.4.2. Network format in geodatabase

Here, the transports are presented in network format. The link tables are all identified by a link given in VY
numbering. If not the network is does not contain the term Bid (or Bidir or similar, short for bidirectional)
then the network is directed, otherwise it is aggregated to an undirected (bidirectional) network.

3.4.2.1. Load_net Road 0 and Load_net Road RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Roa
do

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Roa
d RCM

The node table, Table 71, and the link table, Table 72, holds information about the transports per road link A-
B.

Table 71 - Format of “Load_net_Road_0_Node” and “Load_net_Road_RCM_Node” tables.

Field Description Data Example
Format

OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data

N Node number in VY Numbering Integer 1

X Coordinate x (SWEREF99_TM) Double 1620000

Y Coordinate y (SWEREFgg9_TM) Double 6601000

NORIG Original node number based on the combination of ID_Country, Integer 711400

ID_region and MODE_ N values

SCBSTANN Scbstann code Integer 114
ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer 0

Ul4 User field (not used in the current model) Double 0

CENTRALL Node description in terms of location String Upplands-Visby

Table 72 - Format of “Load_net_Road_0_Link” and “Load_net_Road_RCM_Link” tables.

Field Description Data Format Example
OBJECTID Counter Integer 16

SHAPE Feature class type (lane) OLE Object Long Binary Data
A Start node in VY Numbering Integer 16

B End node in VY Numbering Integer 2813
Shape_Length Length based on distance between coordinates in meters Double 1359.1541
MODESTR String with all the allowed modes String Xabc
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Field Description Data Format Example

SPEED_1 Vehicle speed in kms per hour for all vehicles except vehicles 102- | Double 50
106 in Sweden

SPEED_2 Vehicle speed in kms per hour for vehicles 102-106 in Sweden Double 50

CATEGORY Link category Integer 201

FUNCTION Index for vdf function Double 61

NLANES Number of lanes (may be a decimal number) Double 1

UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.

UL3 Capacity for vessels on sea (dwell tons) Double o)

ID_COUNTRY Country code Integer 1

MODE_L Code for allowed vehicles on the link Integer 1

DISTANCE Distance in kms ( not equals to UL2) Double 1.36

SWEDEN Boolean variable indicating if the link is in Sweden Integer 1

LGV3 Yearly vehicle 101 flow (number of loaded vehicles) Double 3

LGV3T Yearly vehicle 101 tonne flow Double 2.1511

LGV3E Yearly vehicle 101 flow (number of empty vehicles)(number of Double 0.5
empty vehicles)

MGV16 Yearly vehicle 102 flow (number of loaded vehicles) (number of Double 0o
loaded vehicles)

MGV16T Yearly vehicle 102 tonne flow Double o)

MGV16E Yearly vehicle 102 flow (number of empty vehicles)(number of Double o)
empty vehicles)

MGV24 Yearly vehicle 103 flow (number of loaded vehicles) (number of Double o
loaded vehicles)

MGV24T Yearly vehicle 103 tonne flow Double o)

MGV24E Yearly vehicle 103 flow (number of empty vehicles)(number of Double o)
empty vehicles)

HGV40 Yearly vehicle 104 flow (number of loaded vehicles) (number of Double o
loaded vehicles)

HGV40T Yearly vehicle 104 tonne flow Double o)

HGV40E Yearly vehicle 104 flow (number of empty vehicles)(number of Double 0
empty vehicles)

HGV60 Yearly vehicle 105 flow (number of loaded vehicles) (number of Double 0.17989
loaded vehicles)

HGV60T Yearly vehicle 105 tonne flow Double 0.8457

HGV60E Yearly vehicle 105 flow (number of empty vehicles)(number of Double 0.50340

empty vehicles)
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Field Description Data Format Example

HGV74 Yearly vehicle 106 flow (number of loaded vehicles) (number of Double o
loaded vehicles)

HGV74T Yearly vehicle 106 tonne flow Double 0

HGV74E Yearly vehicle 106 flow (number of empty vehicles)(number of Double o)
empty vehicles)

TOT_ROAD Yearly vehicle flow (number of loaded vehicles) (number of Double 3.17989
loaded vehicles) for the road mode

TOT_ROAD_T Yearly tonne flow for the road mode Double 2.9968

TOT_ROAD_E Yearly vehicle flow (number of empty vehicles)(number of empty | Double 1.00340
vehicles) for the road mode

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,

ArcMap.

Description of Use: Assigned network for the road mode for standard logistic module and Rail Capacity

Management.

Created by: “Road Assignment” subgroup under “Samgods Model > Assignment” and “Road Assignment
RCM” subgroup under “Samgods Model > RCM Assignment.”

Used by: “Results” and "Results RCM" subgroups under “Samgods Model.”

Made by user choice: No.

3.4.2.2.

o

The node table, Table 73, and the link table, Table 74, holds information about the transports per rail link A-

B.

Load_net_Rail 0
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Rail

Table 73 - Format of “Load_net_Rail_0_Node” table.

Field Description Data Format Example

OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data

N Node number in VY Numbering Integer 1

X Coordinate x (SWEREF99_TM) Double 1620000

Y Coordinate y (SWEREFg99_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400
ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114

ID_REGION Region code Integer 114
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Field Description Data Format Example
MODE_N Code for allowed vehicles accessing the node Integer MODE_N
Ul4 User field (not used in the current model) Double o
CENTRALL Node description in terms of location String Upplands-Vasby
Table 74 - Format of “Load_net_Rail_0_Link” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (Polyline) OLE Object Long Binary Data
A Start node in VY Numbering Integer 21
B End node in VY Numbering Integer 2127
Shape_Length Length based on distance between coordinates in meters Double 206.1552
MODESTR String with all the allowed modes String Xabc
SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double o)
CATEGORY Link category Integer 211
FUNCTION Index for vdf function Double 66
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36

link lengths longer than 999 kms.
UL3 Field for capacity constrains in Vanel canal (tonnes) Double 0
TRAKBANDEL Trakbandel number for specific link Integer 1011
ORIGINALCAP Capacity on rail links from Capacity table (number of trains per Double o)

day)
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 2
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
CLOSE_ Flag 0/1 to treat vehicles 202/203 Integer o)
KOMBI Yearly vehicle 201 flow (number of loaded vehicles) Double o)
KOMBIT Yearly vehicle 201 tonne flow Double o)
KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double o)
KOMXL Yearly vehicle 210 flow (number of loaded vehicles) Double o
KOMXLT Yearly vehicle 210 tonne flow Double 0
KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double o)
FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles) Double 325.2379
FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875
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Field Description Data Format Example
FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791
SYS22 Yearly vehicle 204 flow (number of loaded vehicles) Double o

SYS22T Yearly vehicle 204 tonne flow Double o)

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double 0

SYS25 Yearly vehicle 205 flow (number of loaded vehicles) Double 0

SYS25T Yearly vehicle 205 tonne flow Double o)

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double o)

SYS30 Yearly vehicle 206 flow (number of loaded vehicles) Double o)

SYS30T Yearly vehicle 206 tonne flow Double o)

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double o)

SYSXL Yearly vehicle 211 flow (number of loaded vehicles) Double o

SYSXLT Yearly vehicle 211 tonne flow Double o)

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double o)

WG550 Yearly vehicle 207 flow (number of loaded vehicles) Double 33.71220
WG550T Yearly vehicle 207 tonne flow Double 14486.2989
WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619
WG750 Yearly vehicle 208 flow (number of loaded vehicles) Double o)

WG750T Yearly vehicle 208 tonne flow Double [}

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900
WGo50 Yearly vehicle 209 flow (number of loaded vehicles) Double o

WG950T Yearly vehicle 209 tonne flow Double [}

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745
WGEXL Yearly vehicle 212 flow (number of loaded vehicles) Double o

WGEXLT Yearly vehicle 212 tonne flow Double o)

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745
FEEDW Yearly vehicle 203 flow (number of loaded vehicles) Double 383.6697
FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875
FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791
FEEDV Yearly vehicle 202 flow (number of loaded vehicles) Double o

FEEDVT Yearly vehicle 202 tonne flow Double 0

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double 0
TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391
TOT_RAIL T Yearly tonne flow for the rail mode Double 180550.71875
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Field Description Data Format Example

TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network for the rail mode.

Created by: “Rail Assignment” subgroup under “Samgods Model > Assignment.”
Used by: “Results” subgroup under “Samgods Model.”

Made by user choice: No.

3.4.2.3. Load net Sea 0 and Load_net Sea RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Sea__
o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Sea_
RCM

The node table, Table 775, and the link table, Table 76, holds information about the transports per sea link A-
B.

Table 75 - Format of “Load_net_Sea_0_Node” and “Load_net_Sea_RCM_Node” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 1

X Coordinate x (SWEREFg99_TM) Double 1620000

Y Coordinate y (SWEREF99_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400

ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114
ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer 3

Ul4 User field (not used in the current model) Double o)

CENTRALL Node description in terms of location String Upplands-Visby

Table 76 - Format of “Load_net_Sea_0_Link” and “Load_net_Sea_RCM_Link” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (lane) OLE Object Long Binary Data
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Field Description Data Format Example
A Start node in VY Numbering Integer 41
B End node in VY Numbering Integer 2407
Shape_Length Length based on distance between coordinates in meters Double 231.94827
SPEED_1 Speed in kms per hour for all modes except vehicle 102-106 in Double 9.3
Sweden
SPEED_2 Speed in kms per hour for vehicle types vehicle 102-106 in Double o)
Sweden
CATEGORY Link category Integer 221
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.
MODESTR String with all the allowed modes String Xabc
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 3
CLOSED 0/1 flag to close links based on capacity saved in UL3 (applied to Integer o)
Kiel Canal)
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
CVs Yearly vehicle flow (number of loaded vehicles) for vehicle 301 Double 1328.875
CV5T Yearly tonne flows for vehicle 301 Double 1576008.0087
CV5E Yearly flow (number of empty vehicles) for vehicle 301 Double 494.89151
CV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 302 Double 0.48649999499322
CV16T Yearly tonne flows for vehicle 302 Double 1897.0262
CV16E Yearly flow (number of empty vehicles) for vehicle 302 Double 92.2993011474609
CVa7y Yearly vehicle flow (number of loaded vehicles) for vehicle 303 Double 0.0064
CV27T Yearly tonne flows for vehicle 303 Double 41.8562
CV27E Yearly flow (number of empty vehicles) for vehicle 303 Double 59.1561012268066
CVio0 Yearly vehicle flow (number of loaded vehicles) for vehicle 304 Double o
CVi1io00T Yearly tonne flows for vehicle 304 Double o
CV100E Yearly flow (number of empty vehicles) for vehicle 304 Double 0.04459999874234
OV1 Yearly vehicle flow (number of loaded vehicles) for vehicle 305 Double 0.522
OoviT Yearly tonne flows for vehicle 305 Double 104.5458
OV1iE Yearly flow (number of empty vehicles) for vehicle 305 Double 0.07059999555349
[0)] Yearly vehicle flow (number of loaded vehicles) for vehicle 306 Double o
OVaT Yearly tonne flows for vehicle 306 Double 0
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Field Description Data Format Example

OV2E Yearly flow (number of empty vehicles) for vehicle 306 Double o)

(0)%:] Yearly vehicle flow (number of loaded vehicles) for vehicle 307 Double 53.4078979492188
OV3T Yearly tonne flows for vehicle 307 Double 46724.79296875
OV3E Yearly flow (number of empty vehicles) for vehicle 307 Double 849.075988769531
(0)%: Yearly vehicle flow (number of loaded vehicles) for vehicle 308 Double 13.5809001922607
OVsT Yearly tonne flows for vehicle 308 Double 16943.318359375
OV5E Yearly flow (number of empty vehicles) for vehicle 308 Double 170.317993164062
OVio Yearly vehicle flow (number of loaded vehicles) for vehicle 309 Double 48.0507011413574
OV1ioT Yearly tonne flows for vehicle 309 Double 120034.1796875
OV1oE Yearly flow (number of empty vehicles) for vehicle 309 Double 98.8669967651367
OV20 Yearly vehicle flow (number of loaded vehicles) for vehicle 310 Double 8.51709938049316
OV2oT Yearly tonne flows for vehicle 310 Double 42584.1484375
OV20E Yearly flow (number of empty vehicles) for vehicle 310 Double 34.8592987060547
0OV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 311 Double 2.90810012817383
OV40T Yearly tonne flows for vehicle 311 Double 29069.599609375
OV40E Yearly flow (number of empty vehicles) for vehicle 311 Double 0.25110000371933
OV8o Yearly vehicle flow (number of loaded vehicles) for vehicle 312 Double

OV8oT Yearly tonne flows for vehicle 312 Double 17966.50390625
OV80oE Yearly flow (number of empty vehicles) for vehicle 312 Double 0.11080000549555
OVio0 Yearly vehicle flow (number of loaded vehicles) for vehicle 313 Double o

OV1io0T Yearly tonne flows for vehicle 313 Double o)

OV100E Yearly flow (number of empty vehicles) for vehicle 313 Double o)

OV250 Yearly vehicle flow (number of loaded vehicles) for vehicle 314 Double o

OVa250T Yearly tonne flows for vehicle 314 Double 0

OV250E Yearly flow (number of empty vehicles) for vehicle 314 Double o

RO3 Yearly vehicle flow (number of loaded vehicles) for vehicle 315 Double 71.7285995483398
RO3T Yearly tonne flows for vehicle 315 Double 57497.5703125
RO3E Yearly flow (number of empty vehicles) for vehicle 315 Double 54.013599395752
RO6 Yearly vehicle flow (number of loaded vehicles) for vehicle 316 Double o

RO6T Yearly tonne flows for vehicle 316 Double o

RO6E Yearly flow (number of empty vehicles) for vehicle 316 Double 0

RO10 Yearly vehicle flow (number of loaded vehicles) for vehicle 317 Double o

RO10T Yearly tonne flows for vehicle 317 Double o
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Field Description Data Format Example
RO10E Yearly flow (number of empty vehicles) for vehicle 317 Double o)

ROF2 Yearly vehicle flow (number of loaded vehicles) for vehicle 318 Double o

ROF2T Yearly tonne flows for vehicle 318 Double o)

ROF2E Yearly flow (number of empty vehicles) for vehicle 318 Double o)

ROF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 319 Double 0

ROF5T Yearly tonne flows for vehicle 319 Double o

ROF5E Yearly flow (number of empty vehicles) for vehicle 319 Double o)

ROF7 Yearly vehicle flow (number of loaded vehicles) for vehicle 320 Double o

ROF7T Yearly tonne flows for vehicle 320 Double o)

ROF7E Yearly flow (number of empty vehicles) for vehicle 320 Double o)

RAF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 321 Double 0

RAF5T Yearly tonne flows for vehicle 321 Double 0

RAF5E Yearly flow (number of empty vehicles) for vehicle 321 Double 0

INW Yearly vehicle flow (number of loaded vehicles) for vehicle 322 Double 0o

INWT Yearly tonne flows for vehicle 322 Double o)

INWE Yearly flow (number of empty vehicles) for vehicle 322 Double [}

TOT_SEA Yearly vehicle flow (number of loaded vehicles) for mode sea Double 1528.982421875
TOT_SEA_T Yearly tonne flows for mode sea Double 1908871.55018125
TOT_SEA_E Yearly flow (number of empty vehicles) for mode sea Double 1853.9580078125

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network for the sea mode

Created by: “Sea Assignment” subgroup under “Samgods Model > Assignment” and “Sea Assignment RCM”
subgroup under “Samgods Model > RCM Assignment.”

Used by: “Results” and "Results RCM" subgroups under “Samgods Model”.

Made by user choice: No.

3.4.2.4. Load_net_Air_0 and Load_net_Air RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Air_
0

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Air_
RCM

The node table, Table 77, and the link table, Table 78, holds information about the transports per air link A-
B.

Table 77 - Format of “Load_net_Air_0_Node” and “Load_net_Air_RCM_Node” tables.



Input and output file reference

Field Description Data Format Example

OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data

N Node number in VY Numbering Integer 1

X Coordinate x(SWEREF9g9_TM) Double 1620000

Y Coordinate y (SWEREFg99_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400
ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114

ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer MODE_N

Ul4 User field (not used in the current model) Double [}

CENTRALL Node description in terms of location String Upplands-Visby

Table 78 - Format

of “Load_net_Air_0_Link” and “Load_net_Air_RCM_Link” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (lane) OLE Object Long Binary Data
A Start node in VY Numbering Integer 62
B End node in VY Numbering Integer 2356
Shape_ Length Length based on distance between coordinates in meters Double 476.759897627719
SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 600
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double o)
CATEGORY Link category Integer 241
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.
MODESTR String with all the allowed modes String Xabc
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 5
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
FLYG Yearly vehicle flow (number of loaded vehicles) for vehicle 401 Double o
FLYGT Yearly tonne flows for vehicle 401 Double 0
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Field

Description

Data Format

Example

FLYGE

Double

o

Yearly flow (number of empty vehicles) for vehicle 401

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network for the air mode.

Created by: “Sea Assignment” subgroup under “Samgods Model > Assignment” and “Sea Assignment RCM”
subgroup under “Samgods Model > RCM Assignment”.

Used by: “Results” and "Results RCM" subgroup under “Samgods Model”.

Made by user choice: No.

3.4.2.5. Loaded net O
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Loaded _net_o

The node table, Table 79, and the link table, Table 80, holds information about the transports per link A-B
for the full network.

Table 79 - Format of “Loaded_net_0_Node” table.

Field Description Data Format | Example

OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data

N Node number in VY Numbering Integer 1

X Coordinate x (SWEREF99_TM) Double 1620000

Y Coordinate y (SWEREF9g9_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400
ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114

ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer MODE_N

Ul4 User field (not used in the current model) Double 0

CENTRALL Node description in terms of location String Upplands-Visby

GEOMETRYSOURCE Number representing to which network the node belongs | Double 4
(1-Road 2-Rail 3_sea 4-Air)

Table 80 - Format of “Loaded_net_0_Link” table.

Field Description Data Format Example

OBJECTID Counter Integer 40

SHAPE Feature class type (polyline) OLE Object Long Binary Data
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Field Description Data Format Example
A Start node in VY Numbering Integer 36
B End node in VY Numbering Integer 2791
Shape_Length Length based on distance between coordinates in meters Double 325.720949474258
SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 50
CATEGORY Link category Integer 201
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.
UL3 Capacity for vessels on sea (dwell tons) Double o)
MODESTR String with all the allowed modes String Xabc
DISTANCE Distance in kms ( not equals to UL2) Double 1.36
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 1
CLOSED Flag o/1 for Sea assignment to close links where Vessel capacity > | Integer o)
ULs3
CLOSE_ Flag o/1 for rail assignment to close links where train type 202 or | Integer o)
203 is not allowed
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
ORIGINALCAP Original capacity in bidirectional number of trains per day (from | Double 0
3.2.3.8 Rail__Capacity_Base2017)
LGV3 Yearly vehicle flow (number of loaded vehicles) for vehicle 101 Double o
LGV3T Yearly tonne flows for vehicle 101 Double 0
LGV3E Yearly flow (number of empty vehicles) for vehicle 101 Double o)
MGV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 102 Double o
MGV16T Yearly tonne flows for vehicle 102 Double o)
MGV16E Yearly flow (number of empty vehicles) for vehicle 102 Double o)
MGV24 Yearly vehicle flow (number of loaded vehicles) for vehicle 103 Double o
MGV24T Yearly tonne flows for vehicle 103 Double [}
MGV24E Yearly flow (number of empty vehicles) for vehicle 103 Double o)
HGV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 104 Double [}
HGV40T Yearly tonne flows for vehicle 104 Double o
HGV40E Yearly flow (number of empty vehicles) for vehicle 104 Double 0
HGV60 Yearly vehicle flow (number of loaded vehicles) for vehicle 105 Double o
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Field Description Data Format Example
HGV60T Yearly tonne flows for vehicle 105 Double o
HGV60E Yearly flow (number of empty vehicles) for vehicle 105 Double o)

HGV74 Yearly vehicle flow (number of loaded vehicles) for vehicle 106 Double 0
HGV74E Yearly tonne flows for vehicle 106 Double o)
HGV74T Yearly flow (number of empty vehicles) for vehicle 106 Double o)
TOT_ROAD Yearly vehicle flow (number of loaded vehicles) for mode road Double o)
TOT_ROAD_T Yearly tonne flows for mode road Double o)
TOT_ROAD_E Yearly flow (number of empty vehicles) for mode road Double o)

KOMBI Yearly vehicle 201 flow (number of loaded vehicles) Double o)
KOMBIT Yearly vehicle 201 tonne flow Double o)
KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double o)
KOMXL Yearly vehicle 210 flow (number of loaded vehicles) Double [}
KOMXLT Yearly vehicle 210 tonne flow Double 0
KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double o)
FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles) Double 325.2379
FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875
FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791
SYS22 Yearly vehicle 204 flow (number of loaded vehicles) Double o

SYS22T Yearly vehicle 204 tonne flow Double o)

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double o)

SYS25 Yearly vehicle 205 flow (number of loaded vehicles) Double [}

SYS25T Yearly vehicle 205 tonne flow Double o)

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double o)

SYS30 Yearly vehicle 206 flow (number of loaded vehicles) Double o

SYS30T Yearly vehicle 206 tonne flow Double 0

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double o)

SYSXL Yearly vehicle 211 flow (number of loaded vehicles) Double o

SYSXLT Yearly vehicle 211 tonne flow Double 0
SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double 0

WGs550 Yearly vehicle 207 flow (number of loaded vehicles) Double 33.71220
WGs50T Yearly vehicle 207 tonne flow Double 14486.2989
WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619
WG750 Yearly vehicle 208 flow (number of loaded vehicles) Double o
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Field Description Data Format Example
WG750T Yearly vehicle 208 tonne flow Double 0

WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900
WG950 Yearly vehicle 209 flow (number of loaded vehicles) Double o

WG950T Yearly vehicle 209 tonne flow Double 0

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745
WGEXL Yearly vehicle 212 flow (number of loaded vehicles) Double o)

WGEXLT Yearly vehicle 212 tonne flow Double o)

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745
FEEDW Yearly vehicle 203 flow (number of loaded vehicles) Double 383.6697
FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875
FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791
FEEDV Yearly vehicle 202 flow (number of loaded vehicles) Double [}

FEEDVT Yearly vehicle 202 tonne flow Double 0

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double o)
TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391
TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875
TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495
CVs Yearly vehicle flow (number of loaded vehicles) for vehicle 301 Double [}

CV5T Yearly tonne flows for vehicle 301 Double 0

CV5E Yearly flow (number of empty vehicles) for vehicle 301 Double o

CV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 302 Double [}

CV16T Yearly tonne flows for vehicle 302 Double o)

CV16E Yearly flow (number of empty vehicles) for vehicle 302 Double o)

CVa7y Yearly vehicle flow (number of loaded vehicles) for vehicle 303 Double 0

CVa27T Yearly tonne flows for vehicle 303 Double o

CVa27E Yearly flow (number of empty vehicles) for vehicle 303 Double o)

CVio0 Yearly vehicle flow (number of loaded vehicles) for vehicle 304 Double 0

CVi1io00T Yearly tonne flows for vehicle 304 Double o

CV100E Yearly flow (number of empty vehicles) for vehicle 304 Double 0

OV1 Yearly vehicle flow (number of loaded vehicles) for vehicle 305 Double o

OoviT Yearly tonne flows for vehicle 305 Double [}

OVi1E Yearly flow (number of empty vehicles) for vehicle 305 Double o

(0)% Yearly vehicle flow (number of loaded vehicles) for vehicle 306 Double o
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Field Description Data Format Example
OVaT Yearly tonne flows for vehicle 306 Double o
OV2E Yearly flow (number of empty vehicles) for vehicle 306 Double o)
(0)%:] Yearly vehicle flow (number of loaded vehicles) for vehicle 307 Double 0
OV3T Yearly tonne flows for vehicle 307 Double o
OV3E Yearly flow (number of empty vehicles) for vehicle 307 Double o)
OVs Yearly vehicle flow (number of loaded vehicles) for vehicle 308 Double o
OV5T Yearly tonne flows for vehicle 308 Double 0
OV5E Yearly flow (number of empty vehicles) for vehicle 308 Double o)
OVio Yearly vehicle flow (number of loaded vehicles) for vehicle 309 Double o
OV1oT Yearly tonne flows for vehicle 309 Double 0
OV1ioE Yearly flow (number of empty vehicles) for vehicle 309 Double [}
OV20 Yearly vehicle flow (number of loaded vehicles) for vehicle 310 Double o}
OV20T Yearly tonne flows for vehicle 310 Double 0
OV20E Yearly flow (number of empty vehicles) for vehicle 310 Double o)
0OV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 311 Double 0
OV40T Yearly tonne flows for vehicle 311 Double o)
OV40E Yearly flow (number of empty vehicles) for vehicle 311 Double o)
OV8o Yearly vehicle flow (number of loaded vehicles) for vehicle 312 Double 0
OV80T Yearly tonne flows for vehicle 312 Double o)
OV8oE Yearly flow (number of empty vehicles) for vehicle 312 Double o)
OVio00 Yearly vehicle flow (number of loaded vehicles) for vehicle 313 Double [}
OViooT Yearly tonne flows for vehicle 313 Double 0
OV100E Yearly flow (number of empty vehicles) for vehicle 313 Double o)
OVa50 Yearly vehicle flow (number of loaded vehicles) for vehicle 314 Double 0
OVa250T Yearly tonne flows for vehicle 314 Double o
OV250E Yearly flow (number of empty vehicles) for vehicle 314 Double o)
RO3 Yearly vehicle flow (number of loaded vehicles) for vehicle 315 Double 0
RO3T Yearly tonne flows for vehicle 315 Double o
RO3E Yearly flow (number of empty vehicles) for vehicle 315 Double 0
RO6 Yearly vehicle flow (number of loaded vehicles) for vehicle 316 Double o
RO6T Yearly tonne flows for vehicle 316 Double 0
RO6E Yearly flow (number of empty vehicles) for vehicle 316 Double o)
RO10 Yearly vehicle flow (number of loaded vehicles) for vehicle 317 Double o
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Field Description Data Format Example
RO10T Yearly tonne flows for vehicle 317 Double o
RO10E Yearly flow (number of empty vehicles) for vehicle 317 Double o)
ROF2 Yearly vehicle flow (number of loaded vehicles) for vehicle 318 Double o
ROF2T Yearly tonne flows for vehicle 318 Double o)
ROF2E Yearly flow (number of empty vehicles) for vehicle 318 Double o)
ROF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 319 Double o
ROF5T Yearly tonne flows for vehicle 319 Double 0
ROF5E Yearly flow (number of empty vehicles) for vehicle 319 Double o)
ROF7 Yearly vehicle flow (number of loaded vehicles) for vehicle 320 Double o
ROF7T Yearly tonne flows for vehicle 320 Double 0
ROF7E Yearly flow (number of empty vehicles) for vehicle 320 Double 0
RAF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 321 Double 0
RAF5T Yearly tonne flows for vehicle 321 Double 0
RAF5E Yearly flow (number of empty vehicles) for vehicle 321 Double o)
INW Yearly vehicle flow (number of loaded vehicles) for vehicle 322 Double [}
INWT Yearly tonne flows for vehicle 322 Double 0
INWE Yearly flow (number of empty vehicles) for vehicle 322 Double o)
TOT_SEA Yearly vehicle flow (number of loaded vehicles) for mode sea Double [}
TOT _SEA_ T Yearly tonne flows for mode sea Double o
TOT_SEA_E Yearly flow (number of empty vehicles) for mode sea Double o
FKYG Yearly vehicle flow (number of loaded vehicles) for vehicle 401 Double [}
FKYGT Yearly tonne flows for vehicle 401 Double o)
FKYGE Yearly flow (number of empty vehicles) for vehicle 401 Double o)
VOLTO Yearly vehicle flow (number of loaded vehicles) for all modes Double o
TONTO Yearly tonne flows for all modes Double 0
EMPTOE Yearly flow (number of empty vehicles) for all modes Double o)
GEOMETRYSOUR | Number representing to which network the link belongs (1-Road | Double 4
CE 2-Rail 3_sea 4-Air)

TRAKBANDEL Trakbandel code for specific link Integer 1110

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Description of Use: Assigned network for all modes. It is the merge of each mode network

(Loaded_net_road_o, Loaded_net_rail_o0, Loaded_net_sea_o0, Loaded_net_air)_o.

Created by: “Results” subgroup under “Samgods Model”.

Used by: “Data Preparation LP” subgroup under “Samgods Model\Rail Capacity Management”.

89




Input and output file reference

Made by user choice: No.

3.4.2.6. Loaded Bid 0 and Loaded Bid RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Loaded Bid_o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Loaded Bid_R
CM

The node table, Table 81, and the link table, Table 82, holds information about the transports per
(undirected, bidirectional) link A-B.

Table 81 - Format of “Loaded_Bid_0_Node” and “Loaded_Bid_RCM_Node” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 1

X Coordinate x (SWEREFg99_TM) Double 1620000

Y Coordinate y (SWEREF99_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400

ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114
ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer MODE_N

Ul4 User field (not used in the current model) Double o

CENTRALL Node description in terms of location String Upplands-Vasby

Table 82 - Format of “Loaded_Bid_0_Link” and “Loaded_Bid_RCM_Link” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (Polyline OLE Object Long Binary Data
A Start node in VY Numbering Integer 1
B End node in VY Numbering Integer 2659
Shape_Length Length based on distance between coordinates in meters Double 230.867927616822
CATEGORY Link category Integer 110
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36

link lengths longer than 999 kms.
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ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 1
CLOSED Flag o/1 for vehicles 202/203 Integer o)
TOT_ROAD_TM__ Bidirectional yearly flow for the mode road (in millions) Double 1.35
BD

TOT_RAIL_TM_B Bidirectional yearly flow for the mode rail (in millions) Double o)

D

TOT_SEA_TM_BD | Bidirectional yearly flow for the mode sea (in millions) Double o

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network with bidirectional flows for road, rail and sea.

Created by: “Results 1.0” subgroup under “Samgods Model > Results” and : “Results 1.0” subgroup under
“Samgods Model > Results RCM”.

Used by: Not use in the model, final report (see Scenario Outputs > Samgods Reports > Reports >
Bidirectional tons per mode and Scenario Outputs > RCM Reports > Bidirectional tons per mode).

Made by user choice: No.

3.4.2.7. Load_net Rail RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_Rail
_RCM

The node table, Table 83, and the link table, Table 84, holds information about the transports per rail link A-
B. Fields with * only have values for domestic rail links.

Table 83 - Format of “Load_net_Rail_RCM_Node” table.

Field Description Data Format Example

OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data

N Node number in VY Numbering Integer 1

X Coordinate x (SWEREF99_TM) Double 1620000

Y Coordinate y (SWEREF99_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400
ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114

ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer MODE_N

Ul User field (not used in the current model) Double o
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Field

Description

Data Format

Example

CENTRALL

Node description in terms of location

String

Upplands-Vasby

Table 84 - Format

of “Load_net_Rail_RCM_Link” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (Polyline) OLE Object Long Binary Data
A Start node in VY Numbering Integer 21
B End node in VY Numbering Integer 2127
Shape_Length Length based on distance between coordinates in meters Double 206.155281301845
ID_LINK Link identified for rail link. Two links in opposite direction share | Integer 25
the same ID_LINK.
SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0
CATEGORY Link category Integer 211
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.
MODESTR String with all the allowed modes String Xabc
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 2
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
CAP* Original capacity in bidirectional number of trains per day on rail | Double 78
links. From Capacity table
PREVCAP* Capacity in previous Adjust Capacity Loop [bidirectional trains Double 78
per day] - if not used PREVCAP=CAP
FREMME2* Emme node number for start node on rail Integer 1002
TOEMME2* Emme node number for end node on rail Integer 1003
CURRENTCAP* Capacity in current Adjust Capacity Loop [bidirectional trains per | Double 78
day] - if not used CURRENTCAP=CAP.
KOMBI Yearly vehicle 201 flow (number of loaded vehicles) Double o
KOMBIT Yearly vehicle 201 tonne flow Double 0
KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double o)
KOMXL Yearly vehicle 210 flow (number of loaded vehicles) Double o
KOMXLT Yearly vehicle 210 tonne flow Double 0
KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double o)
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Field Description Data Format Example
FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles) Double 325.2379
FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875
FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791
SYS22 Yearly vehicle 204 flow (number of loaded vehicles) Double o)

SYS22T Yearly vehicle 204 tonne flow Double o)

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double o)

SYS25 Yearly vehicle 205 flow (number of loaded vehicles) Double 0

SYS25T Yearly vehicle 205 tonne flow Double o)

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double o)

SYS30 Yearly vehicle 206 flow (number of loaded vehicles) Double 0o

SYS30T Yearly vehicle 206 tonne flow Double 0

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double o)

SYSXL Yearly vehicle 211 flow (number of loaded vehicles) Double o

SYSXLT Yearly vehicle 211 tonne flow Double o)

SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double o)

WGs550 Yearly vehicle 207 flow (number of loaded vehicles) Double 33.71220
WG550T Yearly vehicle 207 tonne flow Double 14486.2989
WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619
WG750 Yearly vehicle 208 flow (number of loaded vehicles) Double o)
WG750T Yearly vehicle 208 tonne flow Double o
WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900
WG950 Yearly vehicle 209 flow (number of loaded vehicles) Double o)
WG950T Yearly vehicle 209 tonne flow Double o
WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745
WGEXL Yearly vehicle 212 flow (number of loaded vehicles) Double o)
WGEXLT Yearly vehicle 212 tonne flow Double o)
WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745
FEEDW Yearly vehicle 203 flow (number of loaded vehicles) Double 383.6697
FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875
FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791
FEEDV Yearly vehicle 202 flow (number of loaded vehicles) Double o
FEEDVT Yearly vehicle 202 tonne flow Double 0
FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double o)
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Field Description Data Format Example
TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391
TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875
TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495
TRAKBANDEL Trakbandel code for specific link Integer 1110

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network for the rail mode from Rail Capacity Management.

Created by: “Rail Assignment RCM” subgroup under “Samgods Model > RCM Assignment”.
Used by: “Results RCM” subgroup under “Samgods Model”.

Made by user choice: No.

3.4.2.8. Loaded_net RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Load_net_RCM

The node table, Table 85, and the link table, Table 86, holds information about the transports per link A-B
for the full network. Fields with * only have values for domestic rail links.

Table 85 - Format of “Load_net_RCM_Node” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 1
X Coordinate x (SWEREF99_TM) Double 1620000
Y Coordinate y (SWEREF99_TM) Double 6601000
NORIG Original node number based on the combination of Integer 711400
ID_Country, ID_region and MODE_N values
SCBSTANN Scbstann code Integer 114
ID_REGION Region code Integer 114
MODE_N Code for allowed vehicles accessing the node Integer MODE_N
Ulg User field (not used in the current model) Double o
CENTRALL Node description in terms of location String Upplands-Visby
GEOMETRYSOURCE Number representing to which network the node belongs | Double 4
(1-Road 2-Rail 3_sea 4-Air)

Table 86 - Format of “Load_net_RCM_Link” table.
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Field Description Data Format Example
OBJECTID Counter Integer 40
SHAPE Feature class type (lane) OLE Object Long Binary Data
A Start node in VY Numbering Integer 36
B End node in VY Numbering Integer 2791
Shape_Length Length based on distance between coordinates in meters Double 325.7290949474258
SPEED_1 Speed in kms per hour for all modes except vehicles 102-106 in Double 50
Sweden
SPEED_2 Speed in kms per hour for vehicle types 102-106 in Sweden Double 50
CATEGORY Link category Integer 201
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.
DISTANCE Distance in kms ( not equals to UL2) Double 1.36
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 1
CLOSED Flag o/1 for Sea assignment to close links where Vessel capacity > | Integer o)
UL3
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
LGV3 Yearly vehicle flow (number of loaded vehicles) for vehicle 101 Double o
LGV3T Yearly tonne flows for vehicle 101 Double 0
LGV3E Yearly flow (number of empty vehicles) for vehicle 101 Double o)
MGV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 102 Double o
MGV16T Yearly tonne flows for vehicle 102 Double 0
MGV16E Yearly flow (number of empty vehicles) for vehicle 102 Double o)
MGV24 Yearly vehicle flow (number of loaded vehicles) for vehicle 103 Double [}
MGV24T Yearly tonne flows for vehicle 103 Double 0
MGV24E Yearly flow (number of empty vehicles) for vehicle 103 Double o)
HGV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 104 Double 0
HGV40T Yearly tonne flows for vehicle 104 Double [}
HGV40E Yearly flow (number of empty vehicles) for vehicle 104 Double o)
HGV60 Yearly vehicle flow (number of loaded vehicles) for vehicle 105 Double o
HGV60T Yearly tonne flows for vehicle 105 Double o
HGV60E Yearly flow (number of empty vehicles) for vehicle 105 Double 0
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Field Description Data Format Example
HGV74 Yearly vehicle flow (number of loaded vehicles) for vehicle 106 Double o)
HGV74E Yearly tonne flows for vehicle 106 Double 0
HGV74T Yearly flow (number of empty vehicles) for vehicle 106 Double o)
TOT_ROAD Yearly vehicle flow (number of loaded vehicles) for mode road Double o)
TOT_ROAD_T Yearly tonne flows for mode road Double o)
TOT_ROAD_E Yearly flow (number of empty vehicles) for mode road Double o)

KOMBI Yearly vehicle 201 flow (number of loaded vehicles) Double o
KOMBIT Yearly vehicle 201 tonne flow Double o)
KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double o)
KOMXL Yearly vehicle 210 flow (number of loaded vehicles) Double 0o
KOMXLT Yearly vehicle 210 tonne flow Double 0
KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double o)
FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles) Double 325.2379
FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875
FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791
SYS22 Yearly vehicle 204 flow (number of loaded vehicles) Double o

SYS22T Yearly vehicle 204 tonne flow Double o)

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double o)

SYS25 Yearly vehicle 205 flow (number of loaded vehicles) Double o)

SYS25T Yearly vehicle 205 tonne flow Double o)

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double o)

SYS30 Yearly vehicle 206 flow (number of loaded vehicles) Double o

SYS30T Yearly vehicle 206 tonne flow Double 0

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double o)

SYSXL Yearly vehicle 211 flow (number of loaded vehicles) Double o
SYSXLT Yearly vehicle 211 tonne flow Double o)
SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double o)

WG550 Yearly vehicle 207 flow (number of loaded vehicles) Double 33.71220
WGs50T Yearly vehicle 207 tonne flow Double 14486.2989
WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619
WG750 Yearly vehicle 208 flow (number of loaded vehicles) Double [}
WG750T Yearly vehicle 208 tonne flow Double o
WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900
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Field Description Data Format Example
WGo950 Yearly vehicle 209 flow (number of loaded vehicles) Double 0

WG950T Yearly vehicle 209 tonne flow Double 0

WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745
WGEXL Yearly vehicle 212 flow (number of loaded vehicles) Double o)

WGEXLT Yearly vehicle 212 tonne flow Double o)

WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745
FEEDW Yearly vehicle 203 flow (number of loaded vehicles) Double 383.6697
FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875
FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791
FEEDV Yearly vehicle 202 flow (number of loaded vehicles) Double 0o

FEEDVT Yearly vehicle 202 tonne flow Double 0

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double o)
TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391
TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875
TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495
CVs Yearly vehicle flow (number of loaded vehicles) for vehicle 301 Double [}

CV5T Yearly tonne flows for vehicle 301 Double 0

CV5E Yearly flow (number of empty vehicles) for vehicle 301 Double o

CV16 Yearly vehicle flow (number of loaded vehicles) for vehicle 302 Double o

CV16T Yearly tonne flows for vehicle 302 Double 0

CV16E Yearly flow (number of empty vehicles) for vehicle 302 Double o)

CVa7y Yearly vehicle flow (number of loaded vehicles) for vehicle 303 Double 0

CVa27T Yearly tonne flows for vehicle 303 Double o

CVa27E Yearly flow (number of empty vehicles) for vehicle 303 Double o)

CVio0 Yearly vehicle flow (number of loaded vehicles) for vehicle 304 Double o

CV100T Yearly tonne flows for vehicle 304 Double 0

CV100E Yearly flow (number of empty vehicles) for vehicle 304 Double o)

OV1 Yearly vehicle flow (number of loaded vehicles) for vehicle 305 Double o

OoviT Yearly tonne flows for vehicle 305 Double [}

OViE Yearly flow (number of empty vehicles) for vehicle 305 Double o

[0)] Yearly vehicle flow (number of loaded vehicles) for vehicle 306 Double o

OV2T Yearly tonne flows for vehicle 306 Double o

OV2E Yearly flow (number of empty vehicles) for vehicle 306 Double o)
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Field Description Data Format Example
OV3 Yearly vehicle flow (number of loaded vehicles) for vehicle 307 Double o
OV3T Yearly tonne flows for vehicle 307 Double 0
OV3E Yearly flow (number of empty vehicles) for vehicle 307 Double o)
OVs Yearly vehicle flow (number of loaded vehicles) for vehicle 308 Double o
OV5T Yearly tonne flows for vehicle 308 Double 0
OV5E Yearly flow (number of empty vehicles) for vehicle 308 Double o)
OVio Yearly vehicle flow (number of loaded vehicles) for vehicle 309 Double 0
OVi1ioT Yearly tonne flows for vehicle 309 Double o
OV1oE Yearly flow (number of empty vehicles) for vehicle 309 Double o
OV20 Yearly vehicle flow (number of loaded vehicles) for vehicle 310 Double [}
OV20T Yearly tonne flows for vehicle 310 Double 0
OV20E Yearly flow (number of empty vehicles) for vehicle 310 Double o)
OV40 Yearly vehicle flow (number of loaded vehicles) for vehicle 311 Double 0
OV40T Yearly tonne flows for vehicle 311 Double 0
OV40E Yearly flow (number of empty vehicles) for vehicle 311 Double o)
OV8o Yearly vehicle flow (number of loaded vehicles) for vehicle 312 Double 0
OV8o0T Yearly tonne flows for vehicle 312 Double o)
OV8oE Yearly flow (number of empty vehicles) for vehicle 312 Double o)
OV1io00 Yearly vehicle flow (number of loaded vehicles) for vehicle 313 Double 0
OV1io0T Yearly tonne flows for vehicle 313 Double o)
OV1i00E Yearly flow (number of empty vehicles) for vehicle 313 Double o)
OVa50 Yearly vehicle flow (number of loaded vehicles) for vehicle 314 Double 0
OVa250T Yearly tonne flows for vehicle 314 Double o
OV250E Yearly flow (number of empty vehicles) for vehicle 314 Double o)
RO3 Yearly vehicle flow (number of loaded vehicles) for vehicle 315 Double o
RO3T Yearly tonne flows for vehicle 315 Double 0
RO3E Yearly flow (number of empty vehicles) for vehicle 315 Double o)
RO6 Yearly vehicle flow (number of loaded vehicles) for vehicle 316 Double o
RO6T Yearly tonne flows for vehicle 316 Double 0
RO6E Yearly flow (number of empty vehicles) for vehicle 316 Double o)
RO10 Yearly vehicle flow (number of loaded vehicles) for vehicle 317 Double [}
RO10T Yearly tonne flows for vehicle 317 Double o
RO10E Yearly flow (number of empty vehicles) for vehicle 317 Double o
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Field Description Data Format Example
ROF2 Yearly vehicle flow (number of loaded vehicles) for vehicle 318 Double o
ROF2T Yearly tonne flows for vehicle 318 Double o)
ROF2E Yearly flow (number of empty vehicles) for vehicle 318 Double o)
ROF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 319 Double o
ROF5T Yearly tonne flows for vehicle 319 Double 0
ROF5E Yearly flow (number of empty vehicles) for vehicle 319 Double o)
ROF7 Yearly vehicle flow (number of loaded vehicles) for vehicle 320 Double 0
ROF7T Yearly tonne flows for vehicle 320 Double o)
ROF7E Yearly flow (number of empty vehicles) for vehicle 320 Double o)
RAF5 Yearly vehicle flow (number of loaded vehicles) for vehicle 321 Double 0
RAF5T Yearly tonne flows for vehicle 321 Double 0
RAF5E Yearly flow (number of empty vehicles) for vehicle 321 Double o)
INW Yearly vehicle flow (number of loaded vehicles) for vehicle 322 Double [}
INWT Yearly tonne flows for vehicle 322 Double o)
INWE Yearly flow (number of empty vehicles) for vehicle 322 Double o)
TOT_SEA Yearly vehicle flow (number of loaded vehicles) for mode sea Double [}
TOT_SEA_T Yearly tonne flows for mode sea Double o)
TOT_SEA_E Yearly flow (number of empty vehicles) for mode sea Double [}
FLYG Yearly vehicle flow (number of loaded vehicles) for vehicle 401 Double o
FLYGT Yearly tonne flows for vehicle 401 Double 0
FLYGE Yearly flow (number of empty vehicles) for vehicle 401 Double 0
VOLTO Yearly vehicle flow (number of loaded vehicles) for all modes Double o
TONTO Yearly tonne flows for all modes Double 0
EMPTOE Yearly flow (number of empty vehicles) for all modes Double o)
ID_LINK Link identified for rail link. Two links in opposite direction share | Integer 25
the same ID_LINK.
CAP* Original capacity in bidirectional trains per day on rail links. Double 78
From Capacity table
PREVCAP* Capacity in previous Adjust Capacity Loop [bidirectional trains Double 78
per day] - if not used PREVCAP=CAP
FREMME2* Emme node number for start node Integer 1002
TOEMME2* Emme node number for end node Integer 1003
CURRENTCAP Capacity in current Adjust Capacity Loop [bidirectional trains per | Double 78
day] - if not used CURRENTCAP=CAP.
TRAKBANDEL Trakbandel code for specific link Integer 1110
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Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network for all modes from Rail Capacity Management. It is the merge of all
mode networks (Load_net_road_RCM, Load_net_rail_RCM, Load_net_sea_ RCM, Load_net_air_ RCM).

Created by: “Results RCM” subgroup under “Samgods Model”.
Used by: “Results RCM” subgroup under “Samgods Model” to produce related reports (Report_1, Report_4,

ete).

Made by user choice: No.

3.4.2.9. Rail_BiDir

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_ {SCENARIO_SHORTNAME}.mdb\Rail_BiDir

The node table, Table 87, and the link table, Table 88, holds information about the transports per rail

(undirected, bidirectional) link A-B. Fields with * only have values for domestic rail links.

Table 87 - Format of “Rail_BiDir_Node” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 1
X Coordinate x (SWEREFg99_TM) Double 1620000
Y Coordinate y (SWEREFgg9_TM) Double 6601000
NORIG Original node number based on the combination of Integer 711400
ID_Country, ID_region and MODE_N values
SCBSTANN Scbstann code Integer 114
ID_REGION Region code Integer 114
MODE_N Code for allowed vehicles accessing the node Integer MODE_N
Ul4 User field (not used in the current model) Double 0
CENTRALL Node description in terms of location String Upplands-Visby
GEOMETRYSOURCE Number representing to which network the node belongs Double 4
(1-Road 2-Rail 3_sea 4-Air)
Table 88 - Format of “Rail_BiDir_Link” table.
Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (Polyline) OLE Object Long Binary Data
A Start node in VY Numbering Integer 21
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Field Description Data Format Example
B End node in VY Numbering Integer 2127
Shape_Length Length based on distance between coordinates in meters Double 206.155281301845
ID_LINK Link identified for rail link. Two links in opposite direction share | Integer 25

the same ID_LINK.

Trakbandel number for specific link Integer
TRAKBANDEL 1011

Maximum number of bidirectional trains per day (from 3.2.3.8 String
CAP* Rail_Capacity_Base2017) 418
TOT_LOAD Number of loaded bidirectional trains per day Double 71.24434
TOT_EMPT Number of unloaded bidirectional trains per day Double 31.21692
TOT_ASS Number of total bidirectional trains per day (loaded+unloaded) Double 102.4613
DIFF_VC Difference between TOT_ASS and CAP Double -315.539
FLAG_OVCAP Flag 0/1. 1 means the link is overcapacity by at least 1 train Integer 1
FLAG_PER Flag 0/1. 1 means the link is overcapacity by at least 10% Double o)
FLAG_TOT Flag o/1if FLAG_OVCAP=1 or FLAG_PER=1 Double 1
SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 50
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0
CATEGORY Link category Integer 211
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36

link lengths longer than 999 kms.
UL3 Capacity for vessels on sea (dwell tons) Double o)
MODESTR String with all the allowed modes String Xabce
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 2
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1
PREVCAP* Capacity in previous Adjust Capacity Loop [bidirectional trains Double 78

per day] - if not used PREVCAP=CAP
FREMME2 Start Emme node Integer 1002
TOEMME2 End Emme node Integer 1003
CURRENTCAP* Capacity in current Adjust Capacity Loop [bidirectional trains per | Double 78

day] - if not used CURRENTCAP=CAP.

* values are present only for domestic rail links.
KOMBI Yearly vehicle 201 flow (number of loaded vehicles) Double o
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Field Description Data Format Example
KOMBIT Yearly vehicle 201 tonne flow Double o)
KOMBIE Yearly vehicle 201 flow (number of empty vehicles) Double o)
KOMXL Yearly vehicle 210 flow (number of loaded vehicles) Double o
KOMXLT Yearly vehicle 210 tonne flow Double o)
KOMXLE Yearly vehicle 210 flow (number of empty vehicles) Double o)
FS_TRAIN Yearly vehicle 202 flow (number of loaded vehicles) Double 325.2379
FS_TRAINT Yearly vehicle 202 tonne flow Double 166064.421875
FS_TRAINE Yearly vehicle 202 flow (number of empty vehicles) Double 325.23791
SYS22 Yearly vehicle 204 flow (number of loaded vehicles) Double o)

SYS22T Yearly vehicle 204 tonne flow Double o)

SYS22E Yearly vehicle 204 flow (number of empty vehicles) Double o)

SYS25 Yearly vehicle 205 flow (number of loaded vehicles) Double o)

SYS25T Yearly vehicle 205 tonne flow Double 0

SYS25E Yearly vehicle 205 flow (number of empty vehicles) Double o)

SYS30 Yearly vehicle 206 flow (number of loaded vehicles) Double 0o

SYS30T Yearly vehicle 206 tonne flow Double 0

SYS30E Yearly vehicle 206 flow (number of empty vehicles) Double o)

SYSXL Yearly vehicle 211 flow (number of loaded vehicles) Double o
SYSXLT Yearly vehicle 211 tonne flow Double o)
SYSXLE Yearly vehicle 211 flow (number of empty vehicles) Double o)

WG550 Yearly vehicle 207 flow (number of loaded vehicles) Double 33.71220
WG550T Yearly vehicle 207 tonne flow Double 14486.2989
WG550E Yearly vehicle 207 flow (number of empty vehicles) Double 130.22619
WG750 Yearly vehicle 208 flow (number of loaded vehicles) Double o)
WG750T Yearly vehicle 208 tonne flow Double o
WG750E Yearly vehicle 208 flow (number of empty vehicles) Double 0.956900
WG950 Yearly vehicle 209 flow (number of loaded vehicles) Double o)
WG950T Yearly vehicle 209 tonne flow Double o
WG950E Yearly vehicle 209 flow (number of empty vehicles) Double 36.2745
WGEXL Yearly vehicle 212 flow (number of loaded vehicles) Double o
WGEXLT Yearly vehicle 212 tonne flow Double 0
WGEXLE Yearly vehicle 212 flow (number of empty vehicles) Double 36.2745
FEEDW Yearly vehicle 203 flow (number of loaded vehicles) Double 383.6697
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Field Description Data Format Example
FEEDWT Yearly vehicle 203 tonne flow Double 166064.421875
FEEDWE Yearly vehicle 203 flow (number of empty vehicles) Double 325.23791
FEEDV Yearly vehicle 202 flow (number of loaded vehicles) Double o

FEEDVT Yearly vehicle 202 tonne flow Double o)

FEEDVE Yearly vehicle 202 flow (number of empty vehicles) Double o)

TOT_RAIL Yearly vehicle flow (number of loaded vehicles) for the rail mode Double 417.3819391
TOT_RAIL_T Yearly tonne flow for the rail mode Double 180550.71875
TOT_RAIL_E Yearly vehicle flow (number of empty vehicles) for the rail mode Double 492.695495
GEOMETRYSOUR | Number representing to which network the link belongs (1-Road Double 4

CE 2-Rail 3_sea 4-Air)

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcMap.

Description of Use: Assigned network for the rail mode from Rail Capacity Management with daily and yearly
flows.

Created by: “Reports 1.0” subgroup under “Samgods Model > Results RCM”.

Made by user choice: No.

3.4.2.10. Compare_Bid
Scenario_Tree\Base2017\Outputo_Base2017.mdb\Compare_Bid

The node table, Table 89, and the link table, Table 90, holds information about the differences in transports
per (undirected, bidirectional) link A-B.

Table 89 - Format of “Compare_Bid_Node” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

SHAPE Feature class type (point) OLE Object Long Binary Data
N Node number in VY Numbering Integer 1

X Coordinate x (SWEREF99_TM) Double 1620000

Y Coordinate y (SWEREF99_TM) Double 6601000

NORIG Original node number based on the combination of Integer 711400

ID_Country, ID_region and MODE_N values

SCBSTANN Scbstann code Integer 114
ID_REGION Region code Integer 114

MODE_N Code for allowed vehicles accessing the node Integer MODE_N

Ul4 User field (not used in the current model) Double o

CENTRALL Node description in term of location String Upplands-Visby
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Field Description Data Format Example
GEOMETRYSOURCE Number representing to which network the node belongs | Double 4
(1-Road 2-Rail 3_sea 4-Air)
Table 90 - Format of “Compare_Bid_Link” table.
Field Description Data Format Example
OBJECTID Counter Integer 1
SHAPE Feature class type (Polyline) OLE Object Long Binary Data
A Start node in VY Numbering Integer 1
B End node in VY Numbering Integer 2659
Shape_Length Length based on distance between coordinates in meters Double 230.867927616822
CATEGORY Link category Integer 110
FUNCTION Index for vdf function Double 61
NLANES Number of lanes (could be with -decimals Double 1
UL2 Distance in kms. User link data in emme used to enable holding Double 1.36
link lengths longer than 999 kms.
ID_COUNTRY Country code Integer 1
MODE_L Code for allowed vehicles on the link Integer 1
CLOSED Flag o/1 for vehicles 202/203 Integer 0
Bidirectional yearly tonnes for mode Rail (in millions) from
RAIL_STD . Double o
Standard Logistics Module
Bidirectional yearly tonnes for mode Sea (in millions) from
SEA_STD o Double 0
Standard Logistics Module
Bidirectional yearly tonnes for mode road (in millions) from
ROAD_STD . Double 1.35
Standard Logistics Module
GEOMETRYSOUR o
CE Flag 1/2: 1 from RCM network, 2 from Standard Logistics Module | Double 1
Bidirectional yearly tonnes for mode Rail (in millions) from Rail
RAIL_RCM . Double o)
Capacity Management Procedure
Bidirectional yearly tonnes for mode Sea (in millions) from Rail
SEA_RCM . Double o
Capacity Management Procedure
Bidirectional yearly tonnes for mode road (in millions) from Rail
ROAD_RCM . Double 1.35
Capacity Management Procedure
Difference between ROAD_RCM and ROAD_STD (in millions of
DIF_A_ROAD Double o
tonnes)
Difference between RAIL_RCM and RAIL_STD (in millions of
DIF_A_RAIL Double o
tonnes)
Difference between SEA_RCM and SEA_STD (in millions of
DIF_A_SEA Double o
tonnes)
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Field Description Data Format Example
DIF_P_ROAD Difference percentage between ROAD_RCM and ROAD_STD (%) | Double o
DIF_P_RAIL Difference percentage between RAIL_RCM and RAIL_STD (%) Double o)
DIF_P_SEA Difference percentage between SEA_RCM and SEA_STD (%) Double o)

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,

ArcMap.

Description of Use: Differences of bidirectional flows (in millions of tons) for Road, Sea and Rail mode on

two results, one from standard logistics module and the other from rail capacity management procedure.

Created by: “Results 1.0” subgroup under “Samgods Model > Results” and : “Results 1.0” subgroup under
“Samgods Model > Results RCM”.

Used by: Not use in the model, final report (see Scenario Outputs\RCM Reports\ Comparison Ml Tons RCM
vs. Standard per mode).

Made by user choice: No.
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3.4.3. Table format in geodatabase

Here, tables in the geodatabase are presented.

3.4.3.1. CHAIN_OD_COV_{SCENARIO_SHORTNAME} 0 1,
CHAIN_OD_COV_{SCENARIO_SHORTNAME} RCM_1 and
CHAIN_OD_COV_{SCENARIO_SHORTNAME} CBA_1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\CHAIN_OD_C
OV_{SCENARIO_SHORTNAME} o 1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\CHAIN_OD_C
OV_{SCENARIO_SHORTNAME} RCM_1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\CHAIN_OD_C
OV_{SCENARIO_SHORTNAME} CBA_1

This table, Table 91, holds information of coverage of vehicles, created by the LogMod module.

Table 91

- Format of

“CHAIN_OD_COV_{SCENARIO_SHORTNAME}_0_1",
“CHAIN_OD_COV_{SCENARIO_SHORTNAME}_RCM_1”"
“CHAIN_OD_COV_{SCENARIO_SHORTNAME} CBA_1” tables.

and

Field Description Data Format Example
OBJECTID Counter Integer 1
CHAIN_TY Chain Type String A
NSHIP_D Number of Shipments Domestic Double 9187.49
NSHIP_I Number of Shipments International Double 239.81
NSHIP_T Number of Shipments Total Domestic Double 9187.49
KM_DOM Km Domestic Double 48992.5
KM_INT Km International Double 2498.34
KM_TOT Km Total Domestic Double 52656.48
TON_DOM Tonnes Domestic Double 2492.91
TON_INT Tonnes International Double 184.62
TON_TOT Tonnes Total Domestic Double 2492.91
TKM_DOM TonneKm Domestic Double 429749.55
TKM_INT TonneKm International Double 37927.9
TKM_TOT TonneKm Total Domestic Double 483111.92
COST_DOM Costs (SEK) Domestic Double 8039900.44
COST_INT Costs (SEK) International Double 383206.88
COST_TOT Costs (SEK) Total Domestic Double 8039900.44
AC_TKM_DOM Average Logistic Cost Domestic Double 18.71
AC_TKM_INT Average Logistic Cost International Double 10.11
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Field Description Data Format Example

AC_TKM_TOT Average Logistic Cost Total Domestic Double 16.64

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window).

Description of Use: Translation of ChainChoio_{SCENARIO_SHORTNAME}.rep,
ChainChoioFIN_{SCENARIO_SHORTNAME}.rep and ChainChoiCBAo_{SCENARIO_SHORTNAME}.rep
in geodatabase tables for the part related to chain types. The first is the merge of all the reports
ChainChoiXX.rep from Standard Logistics Module and the second is the merge of all the reports
ChainChoiXXFIN.rep from Rail Capacity Management Module. The third one is from CBA. These files reside
under LogMod_Y\ChainChoi\Output folder and OutputCBA folder and are merged via MERGE.exe
program.

The three geodatabase tables are the source for "Report_2_LM_CHAINS" under data panel Samgods Report
> Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD.

Created by: “Save Reports” subgroup under “Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.2. COM_L_D {SCENARIO_SHORTNAME} 0 1, COM_L_D {SCENARIO_SHORTNAME} RCM_1

and COM_L_D_{SCENARIO_SHORTNAME} CBA 1
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\COM_1I_D_{SC
ENARIO_SHORTNAME} o 1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\COM_L_D_{SC
ENARIO_SHORTNAME} RCM_1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\COM_IL_D_{SC
ENARIO_SHORTNAME} CBA 1

Table 92 - Format of “COM_L_D_{SCENARIO_SHORTNAME} 0_17,
“COM_L_D_{SCENARIO_SHORTNAME}_RCM_1” and
“COM_L_D_{SCENARIO_SHORTNAME}_CBA_1” tables.

Field Description Data Format Example

OBJECTID Counter Integer 1

COMM Commodity group Integer 1

TRANVOL Actual transported tons (tonnes) Double 5212689

DEMANDVOL PWC values (tonnes) Double 5212689
Success Rate (100% means all the transport chains got a Double 100

SUCCESRATE solution)

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window).

Description of Use: Translation of ChainChoio_{SCENARIO_SHORTNAME}.rep,
ChainChoioFIN_{SCENARIO_SHORTNAME}.rep and ChainChoiCBAo_{SCENARIO_SHORTNAME}.rep
in geodatabase tables for the part related to chain types. The first is the merge of all the reports
ChainChoiXX.rep from Standard Logistics Module and the second is the merge of all the reports
ChainChoiXXFIN.rep from Rail Capacity Management Module. The third one is from CBA. These files reside
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under LogMod_ Y\ChainChoi\Output folder and OutputCBA folder (for the normal user Y=1) and are merged
via MERGE.exe program.

The three geodatabase tables are the source for “Report_2_LM_DEMAND" under data panel Samgods
Report > Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report
> OD.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.3. VHCL_OD_COV_{SCENARIO_SHORTNAME} 0 1,
VHCL_OD_COV_{SCENARIO_SHORTNAME} RCM_1 and
VHCL_OD_COV_{SCENARIO_SHORTNAME} CBA 1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\VHCL_OD_CO

V_{SCENARIO_SHORTNAME} o_1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\VHCL_OD_CO
V_{SCENARIO_SHORTNAME} RCM 1

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\VHCL_OD_CO
V_{SCENARIO_SHORTNAME} CBA_1

Table 93 - Format of “VHCL_OD_COV_{SCENARIO_SHORTNAME} 0”,
“VHCL_OD_COV_{SCENARIO_SHORTNAME}_RCM” and
“VHCL_OD_COV_{SCENARIO_SHORTNAME} CBA” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
VEH_TY Vehicle Type Integer 101

String Lorry light LGV.<
DESCR Description of vehicle type 3.5 ton
NSHIP_D Number of Shipments Domestic Double 59.56
NSHIP_I Number of Shipments International Double 59.65
NSHIP_T Number of Shipments Total Domestic Double 0.75
NV_DOM Number of Vehicles Domestic Double 58.91
NV_INT Number of Vehicles International Double 58.99
NV_TOT Number of Vehicles Total Domestic Double 0.09
KM_DOM Km Domestic Double 4608.5
KM_INT Km International Double 4612.13
KM_TOT Km Total Domestic Double 6.72
TON_DOM Tonnes Domestic Double 92.61
TON_INT Tonnes International Double 92.73
TON_TOT Tonnes Total Domestic Double 0.12




Input and output file reference

Field Description Data Format Example
TKM_DOM TonneKm Domestic Double 7529.42
TKM_INT TonneKm International Double 7535.17
TKM_TOT TonneKm Total Domestic Double 10.27
ALF_DOM Average Load Factor Domestic Double 0.79
ALF_INT Average Load Factor International Double 0.79
ALF_TOT Average Load Factor Total Domestic Double 0.68
AVDIST _DOM Average Distance Domestic Double 78.2
AVDIST_INT Average Distance International Double 78.2
AVDIST_TOT Average Distance Total Domestic Double 73.9
Table 94 - Specific attributes for “VHCL_OD_COV_{SCENARIO_SHORTNAME}_CBA” table
Field Description Data Format Example
Fekm_DOM Ferry Km Domestic Double 0.5
Fekm_INT Ferry Km International Double 2.6
Fekm_TOT Ferry Km Total Domestic Double 7

Description of Use: Translation of ChainChoio_{SCENARIO_SHORTNAME}.rep,
ChainChoioFIN_{SCENARIO_SHORTNAME}.rep and ChainChoiCBAo_{SCENARIO_SHORTNAME}.rep
in geodatabase tables for the part related to chain types. The first is the merge of all the reports
ChainChoiXX.rep from Standard Logistics Module and the second is the merge of all the reports
ChainChoiXXFIN.rep from Rail Capacity Management Module. The third one is from CBA. These files reside
under LogMod_Y\ChainChoi\Output folder and OutputCBA folder and are merged via MERGE.exe
program.

The three geodatabase tables are the source for “Report_2_ Logistics Module" under data panel Samgods
Report\Logistics Module\OD Covered , RCM Reports\ Logistics Module\OD Covered, CBA Report\OD .

Visualizing Options: Microsoft Access or Cube Database window (see Help>Cube Base>Database window).

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.4. Report_1 {SCENARIO SHORTNAME} 0 and Report 1 {SCENARIO_SHORTNAME} RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_1_{SCE
NARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_1_{SCE
NARIO _SHORTNAME} RCM

Table 95 - Format of “Report_1_{SCENARIO_SHORTNAME} 0” and
“Report_1_{SCENARIO_SHORTNAME}_RCM” tables.

Field

Description

Data Format

Example

OBJECTID

Counter

Integer

1
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Field Description Data Format Example
VEH_NR Vehicle type Integer 101
VEH_CLASS Description of vehicle String LGV3
VKM_A_TOT Total vehicle kilometres Double 9277.03
VKM_A_DTOT Total vehicle kilometres (Dtotal) Double 9258.29
VKM_L _TOT Loaded vehicle kilometres Double 4600.46
VKM_L_DTOT Loaded vehicle kilometres (Dtotal) Double 4591.29
VKM_E_TOT Unloaded vehicle kilometres Double 4676.57
VKM_E_DTOT Unloaded vehicles (Dtotal) Double 4666.99

Description of Use: The two geodatabase tables are the source for "Report_1 Tot VHC and VHCKM by VHC
Type" under data panel Reports > Logistics Module and Reports > Rail Capacity Management.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.
Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.5. COMMODITYFlows
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\COMMODITYFI
ows

Table 96 - Format of “COMMODITYFlows” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
KEYLINK Primary key obtained as combination of A*100000+B. To let join further Integer 102659
TRAKBANDE | Trakbandel on rail links Integer 0
EMMEFR Emme start node Integer 711400
EMMETO Emme end node Integer 300025
A Start node in VY Numbering Integer 1

B End node in VY Numbering Integer 2659
KTONTO Total bidirectional ktons (all modes) in a year Double 2862
VOLTO Daily total bidirectional loaded vehicles (all modes) Double 183.69
EMPTOE Daily total bidirectional unloaded vehicles (all modes) Double 95.35
Po1_KTON Ktons bidirectional Commodity group 1 in a year Double 6
Po2_KTON Ktons bidirectional Commodity group 2 in a year Double 33
Po3_KTON Ktons bidirectional Commodity group 3 in a year Double 167
Po4_KTON Ktons bidirectional Commodity group 4 in a year Double 277
Po5_KTON Ktons bidirectional Commodity group 5 in a year Double 7
Po6_KTON Ktons bidirectional Commodity group 6 in a year Double 308
Po7_KTON Ktons bidirectional Commodity group 7 in a year Double 254
Po8_KTON Ktons bidirectional Commodity group 8 in a year Double 192
Pog_KTON Ktons bidirectional Commodity group 9 in a year Double 59
P1o_KTON Ktons bidirectional Commodity group 10 in a year Double 63

P11 KTON Ktons bidirectional Commodity group 11 in a year Double 61
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Field Description Data Format Example
P12_KTON Ktons bidirectional Commodity group 12 in a year Double 125
P13_KTON Ktons bidirectional Commodity group 13 in a year Double 44
P14_KTON Ktons bidirectional Commodity group 14 in a year Double 37
P15_KTON Ktons bidirectional Commodity group 15 in a year Double 8
P16_KTON Ktons bidirectional Commodity group 16 in a year Double 0
Po1_VDAY Daily loaded vehicles bidirectional Commodity group 1 Double 1.017
Po2_VDAY Daily loaded vehicles bidirectional Commodity group 2 Double 4.375
Po3_VDAY Daily loaded vehicles bidirectional Commodity group 3 Double 14.957
Pog_VDAY Daily loaded vehicles bidirectional Commodity group 4 Double 40.773
Po5_VDAY Daily loaded vehicles bidirectional Commodity group 5 Double 1.629
P0o6_VDAY Daily loaded vehicles bidirectional Commodity group 6 Double 37.202
Po7 VDAY Daily loaded vehicles bidirectional Commodity group 7 Double 25.631
Po8_VDAY Daily loaded vehicles bidirectional Commodity group 8 Double 30.838
Pog_VDAY Daily loaded vehicles bidirectional Commodity group 9 Double 10.801
P10_VDAY Daily loaded vehicles bidirectional Commodity group 10 Double 13.365
P11 VDAY Daily loaded vehicles bidirectional Commodity group 11 Double 18.668
Pi2_ VDAY Daily loaded vehicles bidirectional Commodity group 12 Double 20.557
P13_VDAY Daily loaded vehicles bidirectional Commodity group 13 Double 12.467
P14_ VDAY Daily loaded vehicles bidirectional Commodity group 14 Double 5.511
P15_ VDAY Daily loaded vehicles bidirectional Commodity group 15 Double 0.904
P16_VDAY Daily loaded vehicles bidirectional Commodity group 16 Double 0.275
CAPUTIL Utilization rate ([number of trains per day / Capacity]*100) Double 0
CAPTRAINS Daily capacity on rail links Double 0
SWEDEN Boolean variable indicating if the link is in Sweden Integer 1

UL2 Distance in kms. User link data in emme used to enable holding link lengths Double 1.36
DISTANCE Distance in kms ( not equals to UL2) Double 1.36
MODE_L ID mode (1 road. 2 rail etc.) Integer 2

Description of Use: The geodatabase table is the source for "layer in GIS map" under data panel Scenario
output > RCM Report > GIS maps > GIS map with Ktons per commodity group. Annual vehicles can be
calculated from daily vehicles multiplying by DF or DFR.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.
Created by: “Results RCM” subgroup under “Samgods Model”.

Made by user choice: No.

3.4.3.6. Report_3 TonKM_perMode_0 and Report_3 TonKM_perMode_RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_3_Ton
KM_perMode_o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_3_Ton
KM_perMode RCM

Table 97 - Format of “Report_3_TonKM_perMode_0” and “Report_3_TonKM_perMode_RCM” tables.

Field

Description

Data Format

Example

OBJECTID

Counter

Integer

1
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Field Description Data Format Example
SCENARIO STANDARD/RCM (method that produces the results) String STANDARD
ROAD Total domestic tonnekm from model (in million) for road mode Double 42.04
RAIL Total domestic tonnekm from model (in million) for rail mode Double 33.62
SEA Total domestic tonnekm from model (in million) for sea mode Double 38.79
AIR Total international tonnekm from model (in million) for air mode Double 2.34
Total domestic tonnekm from statistics (in million) for road mode - | Double 39.9
value hardcoded in script
ROADS 02_APPLICATIONS\2_RUN\RESULTS\NEMAT01A.S
Total domestic tonnekm from model (in million) for rail mode - Double 22.3
value hardcoded in script
RAILS 02_APPLICATIONS\2_RUN\RESULTS\NEMATO01A.S
Total domestic tonnekm from model (in million) for sea mode- Double 36.9
value hardcoded in script
SEAS 02_APPLICATIONS\2_RUN\RESULTS\NEMAT01A.S
Absolute Differences between modelled and statistics for road Double 2.14
ROADD mode
RAILD Absolute Differences between modelled and statistics for rail mode | Double 11.32
SEAD Absolute Differences between modelled and statistics for sea mode | Double 1.89
RMSE Root-mean-square error Double 8.26

Description of Use:

The two geodatabase tables are the source for

"Report_3_TonKm_per_Mode_with_2017Statistics" under data panel Reports > Logistics Module and

Reports > Rail Capacity Management.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.7. Report_4 {SCENARIO_SHORTNAME} 0 and Report_4_{SCENARIO_SHORTNAME} _RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_4 {SCE
NARIO _SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_4 {SCE
NARIO _SHORTNAME} RCM

Table 98 - Format of “Report_4_{SCENARIO_SHORTNAME}_0” and
“Report_4 {SCENARIO_SHORTNAME}_RCM” tables.
Field Description Data Format Example
OBJECTID Counter Integer 1
VEH_NR Vehicle type Integer 101
VEH_CLASS Description of vehicle type String LGV3




Input and output file reference

TKM_TOT Total tonnekm Double 7520.17
TKM_DTOT Total domestic tonnekm Double 7505.61
TKM_INT International tonnekm Double 14.56

Description of Use: The two geodatabase tables are the source for " Report_4_Total tonkm by VHC Type"
under data panel Reports > Logistics Module and Reports > Rail Capacity Management.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.
Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.8. Report 5 {SCENARIO_SHORTNAME} 0, Report 5 {SCENARIO_SHORTNAME} RCM and

Report_5 {SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_5_{SCE
NARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_5_{SCE
NARIO SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_5_{SCE
NARIO _SHORTNAME} CBA

Table 99 - Format of “Report_5 {SCENARIO_SHORTNAME} 0”,
“Report_5 {SCENARIO_SHORTNAME} RCM” and “Report_5 {SCENARIO_SHORTNAME} CBA”
tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
ZONE_N Zone number Integer 1

Original zone number based on the combination of ID_ Country, Integer 711400
ZONE_ORIG ID_region and MODE_ N values
CENTRALL Node description in terms of location String Upplands-Vasby
Po1_IMPORT Total logistic cost in import for Commodity 1 Double 832.67
Po1_EXPORT Total logistic cost in export for Commodity 1 Double 859.21
P16_IMPORT Total logistic cost in import for Commodity 16 Double 161690.81
P16_EXPORT Total logistic cost in export for Commodity 16 Double 67590.22

Description of Use: The three geodatabase tables are the source for “Report_5_Total logistic cost at zone-
level " under data panel Samgods Report\Logistics Module\OD Covered , RCM Reports\ Logistics
Module\OD Covered, CBA Report\OD.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcCatalog.

Created by: “Save Reports” subgroup under “Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.
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Made by user choice: No.

3.4.3.9. Report_6_{SCENARIO_SHORTNAME} 0, Report_6_{SCENARIO_SHORTNAME} RCM and

Report_6_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_6_{SCE
NARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_6_{SCE
NARIO_SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_6_{SCE
NARIO _SHORTNAME} CBA

Table 100 - Format of “Report_6_{SCENARIO_SHORTNAME}_0”,
“Report_6_{SCENARIO_SHORTNAME} RCM” and “Report_6_{SCENARIO_SHORTNAME} CBA”
tables.
Field Description Data Format Example
OBJECTID Counter Integer 93
ZONE_N Zone number Integer 173
Original zone number based on the combination of ID_Country, Integer 786011
ZONE_ORIG ID_region and MODE_N values
PORTAREANR Port area number Integer 2
CENTRALL Node description in terms of location String Hultsfred
Po1_ DAIMPORN Imported tons for commodity 1 Double 0.06
Po1_DAEXPORN Exported tons for commodity 1 Double 0.07
Po1_REGULARN Regular tons for commodity 1 Double 0.54
P16_DAIMPORN Imported tons for commodity 35 Double 0
P16_DAEXPORN Exported tons for commodity 35 Double 0
P16_REGULARN Regular tons for commodity 35 Double 0

Description of Use: The three geodatabase tables are the source for “Report_6_Goods flow through terminals
(number of tonnes in and out per year)" under data panel Samgods Report > Logistics Module > OD Covered
or RCM Reports > Logistics Module > OD Covered or CBA Report > OD.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Save Reports” subgroup under “Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.
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3.4.3.10. Report_6b_{SCENARIO_SHORTNAME} 0, Report_6b_{SCENARIO_SHORTNAME} RCM and

Report_6b_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_6b_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_6b_{SC
ENARIO_SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_6b_{SC
ENARIO SHORTNAME} CBA

Table 101 - Format of “Report_6_{SCENARIO_SHORTNAME}_0”,
Report_6_{SCENARIO_SHORTNAME} RCM” and “Report_6_{SCENARIO_SHORTNAME} CBA”
tables.
Field Description Data Format Example
OBJECTID Counter Integer 93
ZONE_N Zone number Integer 173
Original zone number based on the combination of ID_Country, Integer 786011
ZONE_ORIG ID_region and MODE_N values
PORTAREANR Port area number Integer 2
CENTRALL Node description in terms of location String Hultsfred
Sum of all in and out flows from sea (exclusion of land based Double 0.06
Po1PORT transfers) for Commodity 1
Po2PORT | ... Double 0.07
Sum of all in and out flows from sea (exclusion of land based Double ¢}
P16PORT transfers) for Commodity 35

Description of Use: The three geodatabase tables are the source for “Report_6b_Goods flow through
terminals (number of tonnes in and out per year)" under data panel Samgods Report > Logistics Module >
OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD. They are also input for
calculation of " Report_13_Tons_per_PortArea_and_Commodity_Group".

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.11. Report_7_{SCENARIO_SHORTNAME} 0, Report_7_{SCENARIO_SHORTNAME} RCM and

Report_7_{SCENARIO_SHORTNAME} _CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_7 {SCE
NARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_7 {SCE
NARIO _SHORTNAME} RCM
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Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_7 {SCE
NARIO_SHORTNAME} CBA

Table 102

- Format of

“Report_7_{SCENARIO_SHORTNAME} _0”,

“Report_7_{SCENARIO_SHORTNAME} RCM” and “Report_7_{SCENARIO_SHORTNAME} CBA”
tables.
Field Description Data Format Example
OBJECTID Counter Integer 1
COMMODITY Commodity type Integer 1
ROAD Domestic tonnekm container on road Double 1003.78
RAIL Domestic tonnekm container on rail Double 2440.79
SEA Domestic tonnekm container on sea Double 0.84
AIR Domestic tonnekm container on air Double o)
Vio1 Domestic tonnekm container Vehicle type 101 Double 1.2
Domestic tonnekm container .... Double
V401 Domestic tonnekm container Vehicle type 401 Double o)

Description of Use: The three geodatabase tables are the source for “Report_7_Domestic tonnekm with
container per mode (road, rail, sea, air) and vehicle cl" under data panel Samgods Report > Logistics Module
> OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.12. Report_8 {SCENARIO_SHORTNAME} 0, Report 8 {SCENARIO_SHORTNAME} RCM and

Report_8_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_8 {SCE
NARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_8 {SCE
NARIO_SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_8 {SCE
NARIO _SHORTNAME} CBA

Table 103 - Format of “Report_8 {SCENARIO_SHORTNAME} 0",
“Report_8 {SCENARIO_SHORTNAME} RCM” and “Report_8 {SCENARIO_SHORTNAME}_ CBA”
tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
COMMODITY Commodity type String 1
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Field Description Data Format Example

ROAD Domestic vehiclekm container on road Double 98.28

RAIL Domestic vehiclekm container on rail Double 4.82

SEA Domestic vehiclekm container on sea Double 0.09

AIR Domestic vehiclekm container on air Double o

Vio1 Domestic vehiclekm container Vehicle type 101 Double 1.2
Domestic vehiclekm container .... Double

V401 Domestic vehiclekm container Vehicle type 401 Double 0

Description of Use: The three geodatabase tables are the source for “Report_8_Domestic vehicle kms with
container per mode (road, rail, sea, air) and vehicle cl" under data panel Samgods Report > Logistics Module
> OD Covered or RCM Reports > Logistics Module > OD Covered or CBA Report > OD.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.13. Report_9 {SCENARIO_SHORTNAME} 0 and Report_9 {SCENARIO_SHORTNAME} RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_9 {SCE
NARIO _SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_9_{SCE
NARIO_SHORTNAME} RCM

Table 104 - Format of “Report_9_{SCENARIO_SHORTNAME}_0” and
“Report_9_{SCENARIO_SHORTNAME}_RCM” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1

REGION Region code Integer 114
ID_COUNTRY Country code Integer 1

DESCRIP Description of region String Upplands Viasby
VKM_L_ROAD Road loaded vehiclekm Double 2134.9469
TKM_ROAD Road tonnekm Double 46437.5225
VKM_E_ROAD Road empty vehiclekm Double 1744.6717
VKM_L_RAIL Rail loaded vehiclekm Double 38.3121
TKM_RAIL Rail tonnekm Double 20523.7748
VKM_E_RAIL Rail empty vehiclekm Double 11.7594
VKM_A_ROAD Road total vehiclekm Double 3879.6186
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Field Description Data Format Example

VKM_A_RAIL Rail total vehiclekm Double 50.0715

Description of Use: The two geodatabase tables are the source for "Report_9_Vehicle kms and Tonne kms
per geographic region" under data panel Samgods Reports > Reports and RCM Reports > Reports.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcCatalog.

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.14. Report_10_{SCENARIO_SHORTNAME} 0, Report 10 {SCENARIO_SHORTNAME} RCM and

Report_10_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_10_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_10_{SC
ENARIO_SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_10_{SC
ENARIO_SHORTNAME} CBA

Table 105 - Format of “Report_10_{SCENARIO_SHORTNAME} 0",
“Report_10_{SCENARIO_SHORTNAME} RCM” and “Report_10_{SCENARIO_SHORTNAME}_ CBA”
tables.

Field Description Data Format Example

OBJECTID Counter Integer 1

COMMODITY Commodity type String 1

TYPE Domestic, International or Total Domestic String Domestic

ROAD Tonka on road Double 397113.25

RAIL Tonnekm on rail Double 39074.77

SEA Tonnekm on sea Double 32762.63

AIR Tonnekm on air Double o)

Vio1 Tonnekm Vehicle type 101 Double 1.2
Tonnekm.... Double

V401 Tonnekm Vehicle type 401 Double o)

Description of Use: The three geodatabase tables are the source for “Report_10_Transport work (tonne kms)
per mode and vehicle cl, total and split per commodity, domestic, tdomestic and international" under data
panel Samgods Report > Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered
or CBA Report > OD Covered.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.
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Made by user choice: No.

3.4.3.15. Report_11_{SCENARIO_SHORTNAME} 0, Report_11_{SCENARIO_SHORTNAME} RCM and

Report_11_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_11_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_11_{SC
ENARIO SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_11_{SC
ENARIO SHORTNAME} CBA

Table 106 - Format of “Report_11_{SCENARIO_SHORTNAME}_0”,
“Report_11_{SCENARIO_SHORTNAME}_RCM” and “Report_11_{SCENARIO_SHORTNAME}_CBA”
tables.

Field Description Data Format Example

OBJECTID Counter Integer 1

COMMODITY Commodity type String 1

TYPE Domestic, International or Total Domestic String Domestic

ROAD Tons on road Double 4805.92

RAIL Tons on rail Double 421.46

SEA Tons on sea Double 158.2

AIR Tons on air Double o)

Vio1 Tons Vehicle type 101 Double 1.2
Tons.... Double

V401 Tons Vehicle type 401 Double [}

Description of Use: The three geodatabase tables are the source for “Report_11_ Transported goods volume
per mode and vehicle cl, total and split per commodity, domestic, tdomestic and international" under data
panel Samgods Report > Logistics Module > OD Covered or RCM Reports > Logistics Module > OD Covered
or CBA Report > OD Covered.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.16. Report_12_{SCENARIO_SHORTNAME} 0, Report_12_{SCENARIO_SHORTNAME} RCM and

Report_12_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_12_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_12_{SC
ENARIO_SHORTNAME} RCM
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Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_ {SCENARIO_SHORTNAME}.mdb\Report_12_{SC
ENARIO_SHORTNAME} CBA

Table 107 - Format of “Report_12_{SCENARIO_SHORTNAME} 0”,

“Report_12_{SCENARIO_SHORTNAME} RCM” and “Report_12_{SCENARIO_SHORTNAME} CBA”

tables.
Field Description Data Example

Format

OBJECTID Counter Integer 1
COMMODITY Commodity type String 1
VH_CL Vehicle type Integer 101
DOM_NODEC Node cost pure domestic (SEK) Double 0
DOM_LINKC Link cost pure domestic (SEK) Double 0
IMPORT_NOD Node cost import (SEK) Double 0
IMPORT_LIN Link cost import (SEK) Double 0
EXPORT_NOD Node cost export (SEK) Double 0
EXPORT_LIN Link cost export (SEK) Double 0
INT_NODC Node cost international (SEK) Double 0
INT_LINC Link cost international (SEK) Double 0
NCOSTDTOT Node cost total domestic (SEK) Double 0
LCOSTDTOT Loading cost total domestic (SEK) Double 0
LTIMEDTOT Loading time total domestic Cost (SEK) Double 0
NINTERDTOT Node Interest total domestic Cost (SEK) Double 0
POSCDTOT Positioning Cost total domestic (SEK) Double 0
FWYCDTOT Fway Dues total domestic (SEK) Double 0
PILTCDTOT Pilot Fee total domestic (SEK) Double 0
LICOSDTOT Link cost total domestic (SEK) Double 0
TRPTCDTOT Trp Time total domestic cost (SEK) Double o}
LINTECDTOT Link interest cost total domestic (SEK) Double 0
DISCDTOT Distance cost total domestic (SEK) Double 0
INFRCDTOT Infrastructure cost total domestic (SEK) Double o}
KMDTOT Km total domestic (km) Double 0
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Field Description Data Example
Format
TONSDTOT* Tonnes total domestic (Tonnes) Double o
LIFTDTOT Lifted tonnes total domestic (Tonnes) Double 0
TRANSTDTOT Transfer tonnes total domestic (Tonnes) Double o
TONKMDTOT Tonnekm total domestic (Tonnekm) Double 0
TRTIMEDTOT Transport time total domestic (hours) Double [}
LOADTMDTOT Loading time total domestic (hours) Double 0
NCOSTINT Node cost international (SEK) Double [}
LCOSTINT Loading cost international (SEK) Double 0
LTIMEINT Loading time international Cost (SEK) Double [}
NINTERINT Node Interest international Cost (SEK) Double 0
POSCINT Positioning Cost international (SEK) Double [}
FWYCINT Fway Dues international (SEK) Double 0
PILTCINT Pilot Fee international (SEK) Double 0
LICOSINT Link cost international (SEK) Double 0
TRPTCINT Trp Time international cost (SEK) Double 0
LINTERCINT Link interest cost international (SEK) Double [}
DISCINT Distance cost international (SEK) Double 0
INFRCINT Infrastructure cost international (SEK) Double 0
KMINT Km international (km) Double 0
TONINT* Tonnes international (Tonnes) Double [}
LIFTINT Lifted tonnes international (Tonnes) Double 0
TRANSTINT Transfer tonnes total domestic (Tonnes) Double 0
TONKMINT Tonnekm international (Tonnekm) Double o}
TRTIMEINT Transport time international (hours) Double o}
LOADTMINT Loading time international (hours) Double | o
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Description of Use: The three geodatabase tables are the source for “Report_12_node and link costs per
vehicle and product group” under data panel Samgods Report > Logistics Module > OD Covered or RCM
Reports > Logistics Module > OD Covered or CBA Report > OD Covered.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”
subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

Other notes: Attributes related to kms and tonnekms are comparable with
e CHAIN_OD_COV_{Scenario_ShortName}_{Select_commodity}_1,
e CHAIN_OD_COV_{Scenario_ShortName} RCM_1and
e CHAIN_OD_COV_{Scenario_ShortName} CBA_1

Attributes with * cannot compare since for shipments, vehicles and tonnes as double counting is introduced.
The problem is related to red cell that is assigned to both International and DomesticTotal, shown in Table
108.

Table 108 — Double counting.

Domestic Orig&Dest node D

Ddist>0 I/Dtotal

Idist>0
Foreign Orig/Dest node DDist=0 I

Idist=0 Dtotal

3.4.3.17. Report_13 Portarea_0_STD and Report_13 Portarea_ RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_13_Port
area_o_STD

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_13_Port
area_ RCM

Table 109 - Format of “Report_13_Portarea_0_STD” and “Report_13_Portarea_RCM” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
PORTAREA Port area number Integer 1

3 tables are saved, each of them has a different DES (Model results, | String Model results
DES Statistics, Differences)

String Haparanda-

PDES Port area description Skellefted
COMo1 Tons/1000 per port area and commodity group 1 Double o)
COM16 Tons/1000 per port area and commodity group 16 Double 21.52
TOT Total Tons/1000 per port area Double 9170.14
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Description of Use: The two geodatabase tables are the source for
"Report_13_Tons_per_PortArea_and_Commodity Group" under data panel Reports > Logistics Module
and Reports > Rail Capacity Management.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog
Created by: Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.18. Report_14 Oresund_Kiel 0_STD and Report_14 Oresund_Kiel RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_14_Ore
sund_Kiel o _STD

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_14_Ore
sund_Kiel RCM

Table 110 - Format of “Report_14_Oresund_Kiel_0_STD” and “Report_14_Oresund_Kiel _RCM” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
Description of type of statistics and infrastructure (Oresund road, | String OresundRoad
DES Oresund rail, Kiel Canal, Jylland)
Unit of statistics (vehicles or tons): the model results will be String Vehicles
compared against vehicles or tons depending on the value
STATISTIC present in this field
VALUE_ Value of statistics (tons or vehicles depending on ID_S) Integer 251589
TOTVH Total vehicles from model Double 495658
TOTTON Total tons from model Double 5418635.63197
DIF Absolute differences between MODEL and VALUE_ Double 244069
DIF_PER Relative differences between MODEL and VALUE_ Double 0.97
MODEL Total vehicles or tons from model depending on ID_S value Double 495658

Description of Use: The two geodatabase tables are the source for "Report__

14_Oresund Bridge_Kiel

Canal_Jylland" under data panel Reports > Logistics Module and Reports > Rail Capacity Management.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.19. Report_15_RailLinksRCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_15_Rail

LinksRCM

Table 111 - Format of “Report_15_RailLinksRCM” table.

Field

Description

Data Format

Example

OBJECTID

Counter

Integer

1
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Field Description Data Format Example
ID_LINK ID_LINK from capacity table Integer 1
A Start node in VY Numbering Integer 2000
B End node in VY Numbering Integer 2001
EMME_A Start Emme node Integer 1002
EMME_B End Emme node Integer 1003
TRAKBANDEL Trakbandel code for specific link Integer 1110
CAP Capacity in bidirectional trains per day (from Capacity table) String 418
TOT_LOAD Number of loaded bidirectional trains per day Double 71.24434
TOT_EMPT Number of unloaded bidirectional trains per day Double 31.21692
TOT_ASS Number of total bidirectional trains per day (loaded+unloaded) Double 102.4613
DIFF_VC Difference between TOT_ASS and CAP Double -315.539
FLAG_OVCAP Flag 0/1. 1 means the link is overcapacity by at least 1 train Integer 0
FLAG_PER Flag 0/1. 1 means the link is overcapacity by at least 1% Integer o]

Flag 0/1. 1 means that the FLAG_OVCAP=1 or FLAG_PER=1. Integer
FLAG_TOT Represent all the links with overcapacity conditions. 0
MARG_COST Marginal cost Double 0.5

Description of Use: The table is the source for "Report_15_Trains per day (tot, empty, loaded) (RCM)" under

data panel Reports > Rail Capacity Management. This specific output is produced only for Rail Capacity

Management.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.

Created by: “Results RCM” subgroup under “Samgods Model”.

Made by user choice: No.

3.4.3.20. Report_16_{SCENARIO_SHORTNAME} 0 and Report_16_{SCENARIO_SHORTNAME} RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_16_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_16_{SC
ENARIO_SHORTNAME} RCM

Table 112

- Format of

“Report_16_{SCENARIO_SHORTNAME} RCM?” table.

“Report_16_{SCENARIO_SHORTNAME}_0”

and

Field Description Data Format Example
OBJECTID Counter Integer 1

Integer 1
ID_COUNTY County code

String Stockholm
NAME County name
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Field Description Data Format Example
. . Double 773.22
VKM_LGV3 VehicleKm Vehicle type 101
. . Double 15643.87
VKM_MGV16 VehicleKm Vehicle type 102
. . Double 25213.88
VKM_MGV24 VehicleKm Vehicle type 103
. . Double 30262.45
VKM_HGV40 VehicleKm Vehicle type 104
. . Double 106313.66
VKM_HGV60 VehicleKm Vehicle type 105
. . Double 0
VKM_HGV74 VehicleKm Vehicle type 106
. Double 178207.09
VKM_ROAD VehicleKm total road
. Double 0.43
VKM_LGV3P Percentage Vehicle type 101 (VHM_LGV3/VHM_ROAD*100)
. Double 8.78
VKM_MGV16P Percentage Vehicle type 102 (VKM_MGV16/VHM_ROAD*100)
. Double 14.15
VKM_MGV24P Percentage Vehicle type 103 (VKM_MGV24/VHM_ROAD*100)
) Double 16.98
VKM_HGV40P Percentage Vehicle type 104 (VKM_HGV40/VHM_ROAD*100)
. Double 59.66
VKM_HGV60P Percentage Vehicle type 105 (VKM_HGV60/VHM_ROAD*100)
) Double 0
VKM_HGV74P Percentage Vehicle type 106 (VKM_HGV60/VHM_ROAD*100)

Description of Use: The two geodatabase tables are the source for "Report_16_VHCLKM and distribution by
county - totals" under data panel Samgods Reports > Reports and RCM Reports > Reports.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcCatalog.

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.21. Report_17_{SCENARIO_SHORTNAME} 0 and Report_17 {SCENARIO_SHORTNAME} RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_17_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_17_{SC
ENARIO_SHORTNAME} RCM

Table 113 - Format of “Report_17_{SCENARIO_SHORTNAME}_0” and
“Report_17_{SCENARIO_SHORTNAME}_RCM” tables.

Field Description Data Format Example
OBJECTID Counter Integer 1
ID_COUNTY County code Integer 1
NAME County name String Stockholm
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Field Description Data Format Example
VKLGV311 VehicleKm Vehicle type 101 Double 442.74
VKMGV1611 VehicleKm Vehicle type 102 Double 10749.62
VKMGV2411 VehicleKm Vehicle type 103 Double 16649.97
VKHGV4011 VehicleKm Vehicle type 104 Double 22261.32
VKHGV6011 VehicleKm Vehicle type 105 Double 67905.24
VKMHGV7411 VehicleKm Vehicle type 106 Double 0
VKROAD11 VehicleKm total road Double 118008.9

Percentage Vehicle type 101 Double 0.38
VKLGV3P11 (VHM_LGV3_11/VHM_ROAD_11*100)

Percentage Vehicle type 102 Double 9.11
VKMGV16P11N (VKM_MGV16_11/VHM_ROAD_11*100)

Percentage Vehicle type 103 Double 14.11
VKMGV24P11N (VKM_MGV24_11/VHM_ROAD_11*100)

Percentage Vehicle type 104 Double 18.86
VKHGV40P11N (VKM_HGV40_11/VHM_ROAD_11*100)

Percentage Vehicle type 105 Double 57.54
VKHGV60P11N (VKM_HGV60_11/VHM_ROAD_11*100)

Percentage Vehicle type 106 Double 0
VKHGV74P11N (VKM_HGV60_11/VHM_ROAD_11*100)

Description of Use: The two geodatabase tables are the source for “Report_17_VHCLKM and distribution by

county - E10 roads" under data panel Samgods Reports > Reports and RCM Reports > Reports. It contains
the same results as per Report_16 but filtered on roads with CATEGORY=11 (E10 roads).

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,

ArcCatalog.

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.22. Report_18_{SCENARIO_SHORTNAME} 0 and Report_18_{SCENARIO_SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_18 {SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_18 {SC
ENARIO_SHORTNAME} RCM

Table 114 - Format of “Report_18_{SCENARIO_SHORTNAME}_0” and
“Report_18_{SCENARIO_SHORTNAME}_RCM” tables.

Field Description Data Format Example

OBJECTID Counter Integer 1

ID_COUNTY County code Integer 1
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Field Description Data Format | Example
NAME County name String Stockholm
VKLGV30R VehicleKm Vehicle type 101 Double 330.48
VKMGV160R VehicleKm Vehicle type 102 Double 4894.25
VKMGV240R VehicleKm Vehicle type 103 Double 8563.91
VKHGV400R VehicleKm Vehicle type 104 Double 8001.13
VKHGV600R VehicleKm Vehicle type 106 Double 38408.42
VKHGV740R VehicleKm Vehicle type 106 Double 38408.42
VKROADOR VehicleKm total road Double 60198.19

Percentage Vehicle type 101 Double 0.55
VKLGV3POR (VHM_LGV3_OR/VHM_ROAD_OR*100)

Percentage Vehicle type 102 Double 8.13
VKMGV16POR (VKM_MGV16_ORN/VHM_ROAD_OR*100)

Percentage Vehicle type 103 Double 14.23
VKMGV24POR (VKM_MGV24_ORN/VHM_ROAD_OR*100)

Percentage Vehicle type 104 Double 13.29
VKHGV40POR (VKM_HGV40_ORN/VHM_ROAD_OR*100)

Percentage Vehicle type 106 Double 63.8
VKHGV60POR (VKM_HGV60_ORN/VHM_ROAD_OR*100)

Percentage Vehicle type 106 Double 0
VKHGV74POR (VKM_HGV60_ORN/VHM_ROAD_OR*100)

Description of Use: The two geodatabase tables are the source for "Report_18_VHCLKM and distribution by
country - Other roads" under data panel Samgods Reports > Reports and RCM Reports > Reports. It
contains the same results as per Report_16 but filtered on roads with CATEGORY<>11.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,
ArcCatalog.

Created by: “Results” and “Results RCM” subgroups under “Samgods Model”.

Made by user choice: No.

3.4.3.23. Report_19 {SCENARIO_SHORTNAME} 0, Report_19 {SCENARIO_SHORTNAME} RCM and

Report_19 {SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_19_{SC
ENARIO_SHORTNAME} o

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_19_{SC
ENARIO_SHORTNAME} RCM

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_19_{SC
ENARIO_SHORTNAME} CBA

Table 115 - Format of “Report_19_{SCENARIO_SHORTNAME}_0",
“Report_19_{SCENARIO_SHORTNAME}_RCM” and “Report_19_{SCENARIO_SHORTNAME}_CBA”
tables.
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Field Description Data Format | Example
OBJECTID Counter Integer 35
ZONE_N Voyager node number Integer 35
ZONE_ORIG Emme node number Integer 718012
CENTRALL Terminal description String Stockholm-Arsta
P0o1LOAD Loaded tons on rail terminal commodity 01 Double 0.66
Po1UNLOAD Unloaded tons on rail terminal Commodity 01 Double 10.73
Po2LOAD Loaded tons on rail terminal commodity 02 Double 55
Po2UNLOAD Unloaded tons on rail terminal Commodity 02 Double 484.36
Po3LOAD Loaded tons on rail terminal commodity 03 Double 2.48
Po3UNLOAD Unloaded tons on rail terminal Commodity 03 Double 14.54
Po4LOAD Loaded tons on rail terminal commodity 04 Double 1.87
Po4UNLOAD Unloaded tons on rail terminal Commodity 04 Double 1.44
Pos5LOAD Loaded tons on rail terminal commodity 05 Double 3.8
Po5UNLOAD Unloaded tons on rail terminal Commodity 05 Double 3.47
Po6LOAD Loaded tons on rail terminal commodity 06 Double 14.93
Po6UNLOAD Unloaded tons on rail terminal Commodity 06 Double 328.54
Po7LOAD Loaded tons on rail terminal commodity 07 Double 0.04
Po7UNLOAD Unloaded tons on rail terminal Commodity 07 Double 167.98
PoSLOAD Loaded tons on rail terminal commodity 08 Double 0
PoSUNLOAD Unloaded tons on rail terminal Commodity 08 Double 0
Po9LOAD Loaded tons on rail terminal commodity 09 Double 1.45
PogUNLOAD Unloaded tons on rail terminal Commodity 09 Double 12.66
P10LOAD Loaded tons on rail terminal commodity 10 Double 676.26
P1oUNLOAD Unloaded tons on rail terminal Commodity 10 Double 1384.15
P11LOAD Loaded tons on rail terminal commodity 11 Double 1.64
P11UNLOAD Unloaded tons on rail terminal Commodity 11 Double 33.77
P12LOAD Loaded tons on rail terminal commodity 12 Double 7.6
P12UNLOAD Unloaded tons on rail terminal Commodity 12 Double 6.57
P13LOAD Loaded tons on rail terminal commodity 13 Double o)
P13UNLOAD Unloaded tons on rail terminal Commodity 13 Double 116.52
P14LOAD Loaded tons on rail terminal commodity 14 Double 567.28
P14UNLOAD Unloaded tons on rail terminal Commodity 14 Double 381.28
P15LOAD Loaded tons on rail terminal commodity 15 Double 0.01
P15UNLOAD Unloaded tons on rail terminal Commodity 15 Double 0
P16LOAD Loaded tons on rail terminal commodity 16 Double 7.02
P16UNLOAD Unloaded tons on rail terminal Commodity 16 Double 3.93

Description of Use: The three geodatabase tables are the source for “Report #19 Loaded and unloaded tons

on rail terminals" under data panel Samgods Report > Logistics Module > OD Covered or RCM Reports >
Logistics Module > OD Covered or CBA Report > OD. It contains the total loaded and unloaded tons divided
by scale parameter per each rail terminal.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog,

ArcCatalog.

Created by: “Save Reports” subgroup under "Samgods Model > Logistics Module” and “Save Reports”
subgroup under “Samgods Model > Rail Capacity Management > Run Final Process” and “Save Reports”

subgroup under “CBA Analysis — ASEK values > Logistics Module”.
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Made by user choice: No.

3.4.3.24. Report_20_{SCENARIO_SHORTNAME} CBA
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Report_20_{SC
ENARIO_SHORTNAME} CBA

Table 116 - Format of “Report_20_{SCENARIO_SHORTNAME}_CBA” table.

Field Description Data Format Example
OBJECTID Counter Integer 1

ID_COM Commodity type String 1
ORDCDTOT Order cost domestic String 155713694
INVCDTOT Inventory cost domestic Double 292369180
ORDCINT Order cost international Double 43217624
INVCINT Inventory cost international Double 87972825

Description of Use: The geodatabase table is the for “Report #20 Order and inventory costs for TDOM and
INT (CBA)" under data panel "CBA Report > OD Covered”.

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog.
Created by: “Save Reports” subgroup under “CBA Analysis — ASEK values > Logistics Module”.

Made by user choice: No.

3.4.3.25. Report_21_{Scenario_ShortName} RCM
Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_ {SCENARIO_SHORTNAME}.mdb\Report_21_{SC
ENARIO_SHORTNAME} RCM

Table 117 - Format of “Report_21_{SCENARIO_SHORTNAME}_RCM” table.

Field Description Data Format Example

ID Counter Integer 1
COMMODITY Commodity group String COM 1
KTKMDOM Total domestic tonkm (year) Double 4452970.43
KTKMINT International tonkm (year) Double 17883038.00
VKMDOM Total domestic loaded vhelkm (daily) Double 313307.98
VKMINT International loaded vhelkm (daily) Double 692097.85
EVKMTDOM Total domestic empty vhelkm (daily) Double 0.00
EVKMTINT International empty vhelkm (daily) Double 0.00

Description of Use: The geodatabase table is the input table for “Report #21 Domestic Total and
International Tonskm and Vkm per commodity group RCM - Rail" under data panel "RCM Report >
Reports”

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog
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Created by: “Result

Made by user choic

le reference

s RCM” subgroups under “Samgods Model”

e: No.

3.4.3.26. Vehicles_loaded_and_empty witin_Swedish_territory CBA

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Vehicles loaded

_and_empty_witin_Swedish_ territory_CBA

Table 118 - Format of “Vehicles_loaded_and_empty_witin_Swedish_territory_CBA” table.

Field Description Data Format Example
OBJECTID Counter Integer 1
GVEH_TY Vehicle Type to sort the results in three cases: Integer 300

e All vehicles apart ferries and vehicles on ferries =>

GVEH_TY=0

. Road and rail vehicles on ferry => GVEH_TY=300

e  Ferry vehicles => GVEH_TY=301
VEH_TY Vehicle Type Double 101
KM_L_TOT Km Total Domestic Loaded Vehicles Double 1792.95
KM_E_TOT Km Total Empty Domestic Double 1203.88
KM_TOT Number of Km Total Domestic Total vehicles (Loaded Double 341.33

+Empties)
TKM_L_TOT TonneKm Total Domestic Loaded Vehicles Double 1917.77
TKM_TOT Number of TonneKm Total Domestic Total vehicles Double 184.3

(Loaded +Empties)
NV_L_TOT Number of Total Domestic Loaded Vehicles Double 32.07
NV_E_TOT Number of Empty Vehicles Total Domestic Double 19.11
NV_TOT Number of Total Domestic Total vehicles (Loaded Double 4.46

Description of Use:

territory” under data panel “CBA Report > Main Reports”

Visualizing Options: Microsoft Access or Cube GIS window (see Help>Cube Base>GIS window), ArcCatalog

The geodatabase table is the input table for “Vehicles, loaded and empty, within Swedish

Created by: “Main Reports” subgroups under “Cost Benefit Analysis - ASEK Values > CBAAnalysis”

Made by user choice: No.

3.4.3.27. Costs_D_|_X_T_{SCENARIO_SHORTNAME} CBA

Scenario_Tree\{SCENARIO_SHORTNAME}\Outputo_{SCENARIO_SHORTNAME}.mdb\Costs D_I X_

T _{SCENARIO_SHORTNAME} CBA
Table 119 - Format of “Costs_D_|_X_T_{SCENARIO_SHORTNAME}_CBA” table.

Field Description Data Format | Example
OBJECTID Counter Integer 1
GVEH_TY Vehicle Type to sort the results in three cases: Integer 300
VH_TY Vehicle Type number Double 101
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VHCLONFERR Vehicle Type number on ferry Double 101

DMXT Flag for o=domestic 1=import 2= export 3= transit Integer 1

DESC_ Description for DMXT String domestic
TRPCOSTRCM Transport Cost RCM Double 187903.91
INVCOSTRCM Inventory Cost RCM Double 1284034.49
EMPCOSTRCM Empties Cost RCM Double 27455.54
TRPCOSTCBA Transport Cost CBA Double 187903.91
INVCOSTCBA Inventory Cost CBA Double 1284034.49
EMPCOSTCBA Empties Cost CBA Double 27455.54

Description of Use: CBA, linked in the interface as 2 Report B Costs_D_I_X_T by vehicle type”. Used to

produce {SCENARIO_DIR}\CBA_Final_report_{SCENARIO_CODE}.txt.

Visualizing Options: Microsoft Access or Cube GUI, ArcCatalog.

Created by: “Main Reports” subgroups under “Cost Benefit Analysis - ASEK Values > CBA Analysis”.

Made by user choice: No.
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3.4.4. Results in matrix format

In the following tables there are the list of matrices created by the model.

3.4.4.1. LOS matrices
Table 120 - LOS matrices.

D202_{SCENARIO_SHORTNAME}
D204_{SCENARIO_SHORTNAME},
...D212_{SCENARIO_SHORTNAME}

T201_{SCENARIO_SHORTNAME},
T202_{SCENARIO_SHORTNAME},
T204_{SCENARIO_SHORTNAME}, }
...T212_{SCENARIO_SHORTNAME}

Time (hours) for vehicle type 201, ...

X201_{SCENARIO_SHORTNAME}
X202_{SCENARIO_SHORTNAME}
X204_{SCENARIO_SHORTNAME}
..X212_{SCENARIO_SHORTNAME}

Extra costs for vehicle type 201, ...

DD201_{SCENARIO_SHORTNAME}
DD202_{SCENARIO_SHORTNAME}

Domestic distance (km) for vehicle type 201,

...212

Folder Name of matrix file Name of matrix Description User
choice:
{Scenario_Dir} COST_ROAD_{SCENARIO_SHORTNAME}.MAT Di1o1_{SCENARIO_SHORTNAME}, ... Distance (km) for vehicle type 101-106 Yes
D106_{SCENARIO_SHORTNAME}
T101_{SCENARIO_SHORTNAME}, ... Time (hours) for vehicle type 101-106
T106_{SCENARIO_SHORTNAME}
X101_{SCENARIO_SHORTNAME}, ... Extra costs for vehicle type 101-106
X106_{SCENARIO_SHORTNAME}
DDi1o1_{SCENARIO_SHORTNAME}, ... Domestic distance (km) for vehicle type 101-
DD106_{SCENARIO_SHORTNAME} 106
{Scenario_Dir} COST_RAIL_{SCENARIO_SHORTNAME}.MAT D201_{SCENARIO_SHORTNAME} Distance (km) for vehicle type 201, ... Yes
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T401_{SCENARIO_SHORTNAME}

Time (hours) for vehicle type 401

X401_{SCENARIO_SHORTNAME}

Extra costs for vehicle type 401

DDo1_{SCENARIO_SHORTNAME}

Domestic distance (km) for vehicle type 401

Folder Name of matrix file Name of matrix Description User
choice:

DD204_{SCENARIO_SHORTNAME
...DD212_{SCENARIO_SHORTNAME

{Scenario_ Dir} COST_SEA_{SCENARIO_SHORTNAME}.MAT D301_{SCENARIO_SHORTNAME} Distance (km) for vehicle type 301-322 Yes
...D322_{SCENARIO_SHORTNAME},
T301_{SCENARIO_SHORTNAME} ... Time (hours) for vehicle type 301-322
T322_{SCENARIO_SHORTNAME}
X301_{SCENARIO_SHORTNAME} ... Extra costs for vehicle type 301-322
X322 {SCENARIO_SHORTNAME},
DD301_{SCENARIO_SHORTNAME...DD322_{ | Domestic distance (km) for vehicle type 301-
SCENARIO_SHORTNAME} 322

{Scenario_Dir} COST_AIR_{SCENARIO_SHORTNAME}.MAT D401_{SCENARIO_SHORTNAME} Distance (km) for vehicle type 401 Yes

Structure: Origin (on rows), Destination (on columns), Value (double) on matrix cell.

Description of Use: to store the LOS matrices at the end of cost calculation phase.

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window).

Created by: “LOS calculation” subgroup under “Samgods Model”.

Made by user choice: Yes.

3.4.4.2. Trip Matrices from Standard Logistic Module

Table 121 - Trip Matrices from Standard Logistic Module.
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Folder Name of matrix file Name of matrix Description User
choice:
{Scenario_Dir} ROAD_VHCLFLOWo_{SCENARIO_SHORTNAME}.MA | 101_{SCENARIO_SHORTNAME} OD Loaded Vehicles 101 per year No
T

102_{SCENARIO_SHORTNAME} OD Loaded Vehicles 102 per year
103_{SCENARIO_SHORTNAME} OD Loaded Vehicles 103 per year
104_{SCENARIO_SHORTNAME} OD Loaded Vehicles 104 per year
105_{SCENARIO_SHORTNAME} OD Loaded Vehicles 105 per year
106_{SCENARIO_SHORTNAME} OD Loaded Vehicles 106 per year
Road_{SCENARIO_SHORTNAME} OD Loaded Vehicles total road mode per year

{Scenario_ Dir} RAIL_VHCLFLOWoO_{SCENARIO_SHORTNAME}.MAT | 201_{SCENARIO_SHORTNAME} OD Loaded Vehicles 201 per year No

202_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 202 per year

204_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 204 per year

205_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 205 per year

206_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 206 per year

207_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 207 per year

208_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 208 per year

209_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 209 per year

210_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 210 per year

211_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 211 per year

212_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 212 per year
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Folder Name of matrix file Name of matrix Description User
choice:
Rail_{SCENARIO_SHORTNAME} OD Loaded Vehicles total rail mode per year
SEA_VHCLFLOWo_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Loaded Vehicles 301 per year No

{Scenario_Dir}

302_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 302 per year

303_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 303 per year

304_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 304 per year

305_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 305 per year

306_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 306 per year

307_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 307 per year

308_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 308 per year

309_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 309 per year

310_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 310 per year

311_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 311 per year

312_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 312 per year

313_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 313 per year

314_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 314 per year

315_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 315 per year

316_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 316 per year

317_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 317 per year
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Folder Name of matrix file Name of matrix Description User
choice:
318_{SCENARIO_SHORTNAME} OD Loaded Vehicles 318 per year
319_{SCENARIO_SHORTNAME} OD Loaded Vehicles 319 per year
320_{SCENARIO_SHORTNAME} OD Loaded Vehicles 320 per year
321_{SCENARIO_SHORTNAME} OD Loaded Vehicles 321 per year
322 {SCENARIO_SHORTNAME} OD Loaded Vehicles 322 per year
Sea_{SCENARIO_SHORTNAME} OD Loaded Vehicles total Sea mode per year
{Scenario_Dir} AIR_VHCLFLOWo_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Loaded Vehicles 401 per year. (mode air) No
{Scenario_Dir} ROAD_TONo_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Tons 101 per year No
102_{SCENARIO_SHORTNAME} OD Tons 102 per year
103_{SCENARIO_SHORTNAME} OD Tons 103 per year
104_{SCENARIO_SHORTNAME} OD Tons 104 per year
105_{SCENARIO_SHORTNAME} OD Tons 105 per year
106_{SCENARIO_SHORTNAME} OD Tons 106 per year
Road_{SCENARIO_SHORTNAME} OD Tons total road mode per year
{Scenario_Dir} RAIL_TONo_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Tons 201 per year No

202_{SCENARIO_SHORTNAME}

OD Tons 202 per year

204_{SCENARIO_SHORTNAME}

OD Tons 204 per year

205_{SCENARIO_SHORTNAME}

OD Tons 205 per year
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Folder Name of matrix file Name of matrix Description User
choice:

206_{SCENARIO_SHORTNAME} OD Tons 206 per year

207_{SCENARIO_SHORTNAME} OD Tons 207 per year

208_{SCENARIO_SHORTNAME} OD Tons 208 per year

209_{SCENARIO_SHORTNAME} OD Tons 209 per year

210_{SCENARIO_SHORTNAME} OD Tons 210 per year

211_{SCENARIO_SHORTNAME} OD Tons 211 per year

212_{SCENARIO_SHORTNAME} OD Tons 212 per year

Rail_{SCENARIO_SHORTNAME} OD Tons total rail mode per year

{Scenario_Dir} SEA_TONo_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Tons 301 per year No

302_{SCENARIO_SHORTNAME} OD Tons 302 per year

303_{SCENARIO_SHORTNAME} OD Tons 303 per year

304_{SCENARIO_SHORTNAME} OD Tons 304 per year

305_{SCENARIO_SHORTNAME} OD Tons 305 per year

306_{SCENARIO_SHORTNAME} OD Tons 306 per year

307_{SCENARIO_SHORTNAME} OD Tons 307 per year

308_{SCENARIO_SHORTNAME} OD Tons 308 per year

309_{SCENARIO_SHORTNAME} OD Tons 309 per year

310_{SCENARIO_SHORTNAME} OD Tons 310 per year
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Folder Name of matrix file Name of matrix Description User
choice:
311_{SCENARIO_SHORTNAME} OD Tons 311 per year
312_{SCENARIO_SHORTNAME} OD Tons 312 per year
313_{SCENARIO_SHORTNAME} OD Tons 313 per year
314_{SCENARIO_SHORTNAME} OD Tons 314 per year
315_{SCENARIO_SHORTNAME} OD Tons 315 per year
316_{SCENARIO_SHORTNAME} OD Tons 316 per year
317_{SCENARIO_SHORTNAME} OD Tons 317 per year
318_{SCENARIO_SHORTNAME} OD Tons 318 per year
319_{SCENARIO_SHORTNAME} OD Tons 319 per year
320_{SCENARIO_SHORTNAME} OD Tons 320 per year
321_{SCENARIO_SHORTNAME} OD Tons 321 per year
322_{SCENARIO_SHORTNAME} OD Tons 322 per year
Sea_{SCENARIO_SHORTNAME} OD Tons total Sea mode per year
{Scenario_Dir} AIR_TONo_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Tons 401 per year. (mode air) No
{Scenario_Dir} ROAD_EMPo_{SCENARIO_SHORTNAME} MAT 101_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 101 per year No

102_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 102 per year

103_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 103 per year

104_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 104 per year
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Folder Name of matrix file Name of matrix Description User
choice:

105_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 105 per year
106_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 106 per year
Road_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total road mode per year

{Scenario_Dir} RAIL_EMPo_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 201 per year No
202_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 202 per year
204_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 204 per year
205_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 205 per year
206_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 206 per year
207_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 207 per year
208_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 208 per year
209_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 209 per year
210_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 210 per year
211_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 211 per year
212_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 212 per year
Rail_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total rail mode per year

{Scenario_Dir} SEA_EMPo_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 301 per year No

302_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 302 per year

303_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 303 per year
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Folder

Name of matrix file

Name of matrix

Description

User

choice:

304_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 304 per year

305_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 305 per year

306_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 306 per year

307_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 307 per year

308_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 308 per year

309_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 309 per year

310_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 310 per year

311_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 311 per year

312_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 312 per year

313_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 313 per year

314_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 314 per year

315_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 315 per year

316_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 316 per year

317_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 317 per year

318_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 318 per year

319_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 319 per year

320_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 320 per year

321_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 321 per year
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Folder Name of matrix file Name of matrix Description User
choice:
322_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 322 per year
Sea_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total Sea mode per year
{Scenario_ Dir} AIR_EMPo_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 401 per year. (mode air) No
Structure: Origin (on rows), Destination (on columns), Value (18.6 double) on matrix cell
Description of Use: to store the trip matrices calculated by standard logistic module
Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window)
Created by: “Conversion from LogMod to VY” subgroup under “Samgods Model > Assignment”
Made by user choice: No
3.4.4.3. Trip Matrices from Rail Capacity Management
Table 122 - Trip Matrices from Rail Capacity Management.
Folder Name of matrix file Name of matrix Description Made by
{Scenario_Dir} ROAD_VHCLFLOW_FIN_{SCENARIO_SHORTNAME | 101_{SCENARIO_SHORTNAME} OD Loaded Vehicles 101 per year No

+.MAT

102_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 102 per year

103_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 103 per year

104_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 104 per year

105_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 105 per year

106_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 106 per year
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Folder Name of matrix file Name of matrix Description Made by
Road_{SCENARIO_SHORTNAME} OD Loaded Vehicles total oad mode poryear |

{Scenario_Dir} RAIL_VHCLFLOW_FIN_{SCENARIO_SHORTNAME} | 201_{SCENARIO_SHORTNAME} OD Loaded Vehicles 201 per year No

MAT

202_{SCENARIO_SHORTNAME} OD Loaded Vehicles 202 per year
204_{SCENARIO_SHORTNAME} OD Loaded Vehicles 204 per year
205_{SCENARIO_SHORTNAME} OD Loaded Vehicles 205 per year
206_{SCENARIO_SHORTNAME} OD Loaded Vehicles 206 per year
207_{SCENARIO_SHORTNAME} OD Loaded Vehicles 207 per year
208_{SCENARIO_SHORTNAME} OD Loaded Vehicles 208 per year
209_{SCENARIO_SHORTNAME} OD Loaded Vehicles 209 per year
210_{SCENARIO_SHORTNAME} OD Loaded Vehicles 210 per year
211_{SCENARIO_SHORTNAME} OD Loaded Vehicles 211 per year
212_ {SCENARIO_SHORTNAME} OD Loaded Vehicles 212 per year
Rail_{SCENARIO_SHORTNAME} OD Loaded Vehicles total rail mode per year

{Scenario_Dir} SEA_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}. | 301_{SCENARIO_SHORTNAME} OD Loaded Vehicles 301 per year No

MAT

302_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 302 per year

303_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 303 per year

304_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 304 per year

305_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 305 per year
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Folder

Name of matrix file

Name of matrix

Description

I3 cnwee

306_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 306 per year

307_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 307 per year

308_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 308 per year

309_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 309 per year

310_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 310 per year

311_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 311 per year

312_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 312 per year

313_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 313 per year

314_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 314 per year

315_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 315 per year

316_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 316 per year

317_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 317 per year

318_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 318 per year

319_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 319 per year

320_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 320 per year

321_{SCENARIO_SHORTNAME}

OD Loaded Vehicles 321 per year

322 {SCENARIO_SHORTNAME}

OD Loaded Vehicles 322 per year

Sea_ {SCENARIO_SHORTNAME}

OD Loaded Vehicles total Sea mode per year
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Folder Name of matrix file Name of matrix Description Made by
{Scenario_Dir} AIR_VHCLFLOW_FIN_{SCENARIO_SHORTNAME}. | Air {SCENARIO_SHORTNAME} OD Loaded Vehicles 401 per year. (mode air) ;\‘I:)m"
MAT
{Scenario_Dir} ROAD_TON_FIN_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Tons 101 per year No
102_{SCENARIO_SHORTNAME} OD Tons 102 per year
103_{SCENARIO_SHORTNAME} OD Tons 103 per year
104_{SCENARIO_SHORTNAME} OD Tons 104 per year
105_{SCENARIO_SHORTNAME} OD Tons 105 per year
106_{SCENARIO_SHORTNAME} OD Tons 106 per year
Road_{SCENARIO_SHORTNAME} OD Tons total road mode per year
{Scenario_Dir} RAIL_TON_FIN_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Tons 201 per year No

202_{SCENARIO_SHORTNAME}

OD Tons 202 per year

204_{SCENARIO_SHORTNAME}

OD Tons 204 per year

205_{SCENARIO_SHORTNAME}

OD Tons 205 per year

206_{SCENARIO_SHORTNAME}

OD Tons 206 per year

207_{SCENARIO_SHORTNAME}

OD Tons 207 per year

208_{SCENARIO_SHORTNAME}

OD Tons 208 per year

209_{SCENARIO_SHORTNAME}

OD Tons 209 per year

210_{SCENARIO_SHORTNAME}

OD Tons 210 per year

211_{SCENARIO_SHORTNAME}

OD Tons 211 per year
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Folder Name of matrix file Name of matrix Description Made by
212_{SCENARIO_SHORTNAME} obTomszmperyesr |
Rail_{SCENARIO_SHORTNAME} OD Tons total rail mode per year
{Scenario_Dir} SEA_TON_FIN_{SCENARIO_SHORTNAME}.MAT 301_{SCENARIO_SHORTNAME} OD Tons 301 per year No
302_{SCENARIO_SHORTNAME} OD Tons 302 per year
303_{SCENARIO_SHORTNAME} OD Tons 303 per year
304_{SCENARIO_SHORTNAME} OD Tons 304 per year
305_{SCENARIO_SHORTNAME} OD Tons 305 per year
306_{SCENARIO_SHORTNAME} OD Tons 306 per year
307_{SCENARIO_SHORTNAME} OD Tons 307 per year
308_{SCENARIO_SHORTNAME} OD Tons 308 per year
309_{SCENARIO_SHORTNAME} OD Tons 309 per year
310_{SCENARIO_SHORTNAME} OD Tons 310 per year
311_{SCENARIO_SHORTNAME} OD Tons 311 per year
312_{SCENARIO_SHORTNAME} OD Tons 312 per year
313_{SCENARIO_SHORTNAME} OD Tons 313 per year
314_{SCENARIO_SHORTNAME} OD Tons 314 per year
315_{SCENARIO_SHORTNAME} OD Tons 315 per year
316_{SCENARIO_SHORTNAME} OD Tons 316 per year
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Folder Name of matrix file Name of matrix Description Made by
317_{SCENARIO_SHORTNAME} oDTomssmperyear |
318_{SCENARIO_SHORTNAME} OD Tons 318 per year
319_{SCENARIO_SHORTNAME} OD Tons 319 per year
320_{SCENARIO_SHORTNAME} OD Tons 320 per year
321_{SCENARIO_SHORTNAME} OD Tons 321 per year
322_{SCENARIO_SHORTNAME} OD Tons 322 per year
Sea_{SCENARIO_SHORTNAME} OD Tons total Sea mode per year

{Scenario_Dir} AIR_TON_FIN_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Tons 401 per year. (mode air) No

{Scenario_Dir} ROAD_EMP_FIN_{SCENARIO_SHORTNAME}.MAT 101_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 101 per year No
102_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 102 per year
103_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 103 per year
104_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 104 per year
105_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 105 per year
106_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 106 per year
Road_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total road mode per year

{Scenario_Dir} RAIL_EMP_FIN_{SCENARIO_SHORTNAME}.MAT 201_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 201 per year No

202_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 202 per year

204_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 204 per year
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Folder

Name of matrix file

Name of matrix

Description

I3 cnwee

205_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 205 per year

206_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 206 per year

207_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 207 per year

208_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 208 per year

209_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 209 per year

210_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 210 per year

211_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 211 per year

212_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 212 per year

Rail_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles total rail mode per year

{Scenario_Dir}

SEA_EMP_FIN_{SCENARIO_SHORTNAME}.MAT

301_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 301 per year

302_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 302 per year

303_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 303 per year

304_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 304 per year

305_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 305 per year

306_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 306 per year

307_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 307 per year

308_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 308 per year

309_{SCENARIO_SHORTNAME}

OD Empty Loaded Vehicles 309 per year
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Folder Name of matrix file Name of matrix Description Made by
310_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles gt peryear |
311_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 311 per year
312_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 312 per year
313_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 313 per year
314_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 314 per year
315_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 315 per year
316_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 316 per year
317_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 317 per year
318_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 318 per year
319_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 319 per year
320_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 320 per year
321_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 321 per year
322_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 322 per year
Sea_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles total Sea mode per year

{Scenario_Dir} AIR_EMP_FIN_{SCENARIO_SHORTNAME}.MAT Air_{SCENARIO_SHORTNAME} OD Empty Loaded Vehicles 401 per year. (mode air) No

Structure: Origin (on rows), Destination (on columns), Value (18.6 double) on matrix cell

Description of Use: to store the trip matrices calculated by Rail Capacity Management module

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window)

Created by: “Conversion from LogMod to VY” subgroup under “Samgods Model > RCM Assignment”
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Made by user choice: No
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3.4.4.4. Other matrices
All the following matrices:

COMPARE_LOS_ROAD_{SCENARIO_SHORTNAME} Base2017

COMPARE_LOS_RAIL_{SCENARIO_SHORTNAME} Base2017

COMPARE_LOS_SEA {SCENARIO_SHORTNAME} Base2017

COMPARE_LOS_AIR_{SCENARIO_SHORTNAME} Base2017

COMPARE_OD_ROAD_X_{SCENARIO_SHORTNAME} Base2017

COMPARE_OD_RAIIL_X {SCENARIO_SHORTNAME} Base2017

COMPARE_OD_SEA X_{SCENARIO_SHORTNAME} Base2017

COMPARE_OD_AIR_X_ {SCENARIO_SHORTNAME} Base2017

COMPARE_TON_ROAD_X_{SCENARIO_SHORTNAME} Base2017

COMPARE_TON_RAIIL,_X {SCENARIO_SHORTNAME} Base2017

COMPARE_TON_SEA_X {SCENARIO_SHORTNAME} Base201;7

COMPARE_TON_AIR X {SCENARIO_SHORTNAME} Base2017

Will be created if the user wishes to verify differences between scenarios.
Structure: Origin (on rows), Destination (on columns), Value (double) on matrix cell.

Description of Use: store the differences between scenarios for the same matrix. The differences are

calculated with the equation
Dif of pair_value=0OD_pair_value current scenario — OD_pair_value base scenario

(i.e. values greater than zero mean that the OD pair value in the current scenario is greater than the base
scenario).

Visualizing Options: Cube Matrix window (see Help>Cube Base>Matrix window).
Created by: "Compare” application.

Made by user choice: Yes.

3.4.4.5. Other output related to matrices

Each matrix listed in the point 3.4.4.1and 3.4.4.2 is also exportable in csv or dbf format. The exported
matrices will have the following file name:

{Scenario_DIR}\{Type of matrix}_{Type of mode}_{Matrix name}{Vhclnubmber}_VOY.CSV (or DBF).
Table 123 - Matrix format.
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Field Description Data Format
Origin Origin zone Integer
Destination Destination zone Integer
Value Value Double

Visualizing Options: Microsoft excel.
Created by: Change matrix format” application
Made by user choice: Yes

3.4.5. Report files

Under scenario folder after having run all the applications in the model will be five files:

e Report_SG_{Scenario_code}.txt

e Report_ED_{Scenario_code}.txt

e Report_HL_{Scenario_code}.txt

e Calibration_1.txt

e CBA_Final_report_{Scenario_code}.txt

For the description of the first three reports created and their meaning, please see reference 6 for further
details.

Calibration_ 1.txt is a report produced which holds information of main reporting managed by
Outputs_ Calibration_Template_rev4.xlsm (see section 3.4.8.8 Outputs_Calibration_Template_rev4.xlsm
for details).

CBA_Final_report contains CBA analysis applying Trafikverket outlined methodology (see reference 5 for
further details).

3.4.6. Temporary data to visualize scenario data

Under scenario folder after having run all the application in the model will be four files:
e Input_data.mxr and Input_data.mxd, Scenario_Data.vpr
e Scenario_Data.mdb
The first group has the purpose to define default legends to visualize in the GIS window all the data.

The second file is the temporary geodatabase with the scenario data created by join of the scenario specific
tables and base tables, in other words the real scenario data. It could be exist or not based on the user
choices. It is used only by the “Edit the data application” and no other applications point to it.
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3.4.7. LogMod folder

The structure and input/output files for LogMod folder is covered by reference 3. Here will be listed the input and output files highlighting the outputs related to
the Rail Capacity Management and CBA — ASEK Value. For a description of RCM procedure please refer to section 6.6. For a description of Cost Benefit Analysis
— ASEK Value, please see reference 6 for further details.

Table 124 - LogMod folder.

Catalog Folder

First Level

Second Level

Third Level

Fourth Level

Description

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

Main folder with all the inputs and outputs for Logistics Module and Rail
Capacity Management Module.

Executable and input files for parallelization of processes and log file from RCM

procedure Error.log

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

BUILDCHAIN

Folder with all the control files and executable for BuildChain.exe
The control files are two groups:

BuildChain_Common.ctl, BuildChain_ Special.ctl,
BuildChainXX.ctl

Logselect.dat

Select.dat

The first group has general parameters for all the commodities or specific

commodity groups. The second one specific settings per each commodity (XX).

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

BUILDCHAIN

OUTPUT

BuildChainxx.log (only if Do you want to produce BuildChainxx.log files? catalog
key set to 'yes' or 'all’)

Chainsxx.dat
Connectionxx.lIst (related to Select.dat)

Chainsxx_ RCM.dat

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

ChainChoi

Folder with all the control files and executable for ChainChoi.exe, and LP2CC.exe

The control files are two groups:
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Catalog Folder

First Level

Second Level

Third Level

Fourth Level

Description

ChainChoi_Common.ctl, ChainChoi_Special.ctl,
ChainChoiXX.ctl

The first group has general parameters for all the commodities or specific

commodity groups. The second one specific settings per each commodity (XX).

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

ChainChoi

OUTPUT

Output data files from ChainChoi.exe in standard logmod procedure by

commodity group (XX):
¢  ChainChoiXXSTD.rep
¢ ChainChoiXXSTD.out
e ChainChoXXdatao6STD.out
e ChainChoiXXdatao7STD.out
e ConnectionXX.Ist (related to Select.dat)
e  VhclRepXXSTD.rep
e  VhclRepXXSTD.fac

Output data files from ChainChoi.exe in RCM procedure by commodity group

XX:

¢ ChainChoiXXLPX.out (as ChainChoixxSTD.out with

solutions from LP)
e ChainChoXXdatao6RCM.out
¢ ChainChoiXXRCM.out
¢ ChainChoiXXRCM.rep
e VhclRepXXRCM.rep
e VhclRepXXRCM.fac

From LP2CC.exe by commodity group XX:

e  ChainChoiXXXTD.rep
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Catalog Folder First Level Second Level Third Level Fourth Level Description

¢  ChainChoiXXXTD.out

¢ ChainChoXXdatao6XTD.out

e ChainChoiXXdatao7XTD.out

e VhclRepXXXTD.rep

e VhclRepXXXTD.fac

LockedXX.log with locked solutions by (commodity group XX)

{CATALOG_DIR} {Scenario_Folder} LogMod_Y ChainChoi OUTPUT\CoVo By commodity group XX

e CONSOLXX_ CHAINTYPE.314

e VOLUMEXX_ CHAINTYPE.314
{CATALOG_DIR} {Scenario_Folder} LogMod_Y ChainChoi outputCBA From LP2CC.exe by commodity group XX:

e ChainChoiXXCBA.fac

e ChainChoiXXCBA.rep

e VhclRepXXCBA.fac

e VhclRepXXCBA.rep
{CATALOG_DIR} {Scenario_Folder} LogMod_Y ChainChoi ConsolRateqMod | From ConsolidRateMode.exe by commodity group XX:

¢ e CONSOLXX-MODE.314

{CATALOG_DIR} {Scenario_Folder} LogMod_Y EXTRACT
{CATALOG_DIR} {Scenario_Folder} LogMod_Y EXTRACT OUTPUT The first set of files represent the OD matrices for empties, tonnes and total

vehicles and has been produced by extract procedure by vehicle XXX.
e OD_EmpXXX_STD.314
e OD_EmpXXX_FIN.314
e OD_TonnesXXX_STD.314




Input and output file reference

Catalog Folder

First Level

Second Level

Third Level

Fourth Level

Description

e OD_TonnesXXX_FIN.314
e OD_VhclXXX_STD.314
e OD_VhclXXX_FIN.314

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

INPUT

Chaintype.lis is used by Standard Logistics Module and Rail Capacity

Management Module.

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

INPUT

COST

CARGO.TXT,
OtherCostMatters.txt (file with INTER and STUFF values),
PILOTFEES.TXT, and by commodity group XX

VHCLS_COMXX.TXT

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

INPUT

GENERAL

averageVehicleCpacity.txt

CalibrationParameters.txt is used to rescale LOS matrices using the scaling
factors per port area. They are input to Standard Logistic Module and Rail

Capacity Management internally scaling the LOS matrices per each commodity

group.

OtherCostMatters.ctl main parameters for logmod and rem

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

INPUT

Locked

LockedXXXX.dat with list of chains locked where XXXX is scenario year

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

INPUT

LOS

FreqAir.314
FreqCombi.314
FreqContainerVessel.314
FreqLorry.314
FreqOtherVessel.314

FreqRailFerry.314
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Catalog Folder First Level

Second Level

Third Level

Fourth Level

Description

FreqRoadFerry.314
FreqRoRoVessel.314
FreqSystem.314
FreqWaggonlod.314
And by vehicle type XXX
e  VXXX_ddist.314
o  VXXX_dist.314
. VXXX_timeh.314
o  VXXX_xkr.314

e  VXXX_MC.314 (marginal cost matrices)

{CATALOG_DIR} {Scenario_Folder}

LogMod_Y

INPUT

NODES

ContainerHandling.txt
DirectFeederTrain.txt
DirectSea.txt
DirectSystemTrain.txt
DirectWagonLoad.txt
Nodes.txt
TransferCombiSea.txt
Transferfeedertrainwagonload.txt
TransferRoadAir.txt
TransferRoadCombi.txt
TransferRoadRoad.txt

TransferRoadRoadFerry.txt
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Catalog Folder First Level Second Level Third Level Fourth Level Description

TransferRoadSea.txt
TransferRoadTrain.txt
TransferSeaSea.txt
TransferSystemTrainSea.txt
TransferWagonloadRailFerry.txt

TransferWagonloadSea.txt

{CATALOG_DIR} {Scenario_Folder} LogMod_Y INPUT_CBA COST CARGO.TXT,

OtherCostMatters.txt (file with INTER and STUFF values),
PILOTFEES.TXT, and by commodity group XX
VHCLS_COMXX.TXT

(*) Values modified by table ScalingF_VehASEK

{CATALOG_DIR} {Scenario_Folder} LogMod_Y INPUT_CBA GENERAL averageVehicleCpacity.txt

CalibrationParameters.txt is used to rescale LOS matrices using the scaling

factors per port area. For CBA is equals to 1.

{CATALOG_DIR} {Scenario_Folder} LogMod_Y INPUT_CBA LOS By vehicle type XXX

e  VXXX_dtimeh.314 (domestic time - new)

e  VvXXX_dxkr.314 (domestic cost - new)

e  vXXX_timeh.314 (time without rescaling parameters)

o  VXXX_xkr.314

{CATALOG_DIR} {Scenario_Folder} LogMod_Y INPUT_CBA NODES ContainerHandling.txt
DirectFeederTrain.txt
DirectSea.txt

DirectSystemTrain.txt
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Catalog Folder

First Level

Second Level

Third Level

Fourth Level

Description

DirectWagonLoad.txt

Nodes.txt

TransferCombiSea.txt
transferfeedertrainwagonload.txt
TransferRoadAir.txt
TransferRoadCombi.txt
TransferRoadRoad.txt
TransferRoadRoadFerry.txt
TransferRoadSea.txt
TransferRoadTrain.txt
TransferSeaSea.txt
TransferSystemTrainSea.txt
TransferWagonloadRailFerry.txt
TransferWagonloadSea.txt

Same files as NODES folder except Nodes.txt. Here the technological factors are

all rescaled to 1

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

MERGEREP

Mergerep.exe program, related mergerep.ctl file and MERGEREPALL.BAT (for
standard) and MERGEREPFIN.BAT (for final process)

{CATALOG_DIR}

{Scenario_Folder}

LogMod_Y

LOG

Folder with all .log files from Standard Logistics Module and Rail Capacity
Management module (by commodity group XX):

o logXXFIN.log
e 10gXXSTD.log
e logXXCBA.log
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Catalog Folder First Level Second Level Third Level Fourth Level Description
e logXX_4RCM.log
o EXTRACT_FIN.LOG
e EXTRACT_STD.LOG
e MERGEREP.LOG
o mergerepSTD.log
And chk files, when each program is successful, this produces chk file by
commodity group XX
e BuildChainXX_4RCM.chk
e ChainChoiXX.chk
¢ ChainChoXX_4RCM.chk
¢ ChainChoiXXCBA.chk
e extractoFIN.chk
e extractoSTD.chk
e mergerepSTD.chk
o mergerepFIN.chk
¢ mergerepCBA.chk
e SD_ok.chk
{CATALOG_DIR} {Scenario_Folder} LogMod_Y MERGEREP OUTPUT ChainChoiSTD.rep
ChainChoiXTD.rep
ChainChoiCBA.rep
{CATALOG_DIR} {Scenario_Folder} LogMod_Y RCM Folder with MPS jar, CLP64.exe and SOplex.exe programs together:

control files for different steps:

e Compact.ctl — compact spanning tree data
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Catalog Folder First Level Second Level Third Level Fourth Level Description

e LOS_CBA.CTL
o mps_LP.ctl - control file for LPo, LP1, etc
e UTI_CBA.ctl — control file for CBA analysis

e COMMODITY.CTL - reports for maps by commodity
group

Input data:

e Spanning tree data for all modes (PathTreeRail.txt,
PathTreeSea.txt, PathTreeRoad.txt and PathTreeAir.txt)

o Compacted spanning tree data for all modes
(PathTreeRail.cmp, PathTreeSea.cmp,
PathTreeRoad.cmp and PathTreeAir.cmp)

e Links List.txt and Nodes_ List.txt

e RailLinkCapacitiesBidirectional _STD.dat and
RailLinkCapacitiesBidirectional_STD.new

o Exported_network_BS17.txt (used in Cost Benefit
analysis — network with time and cost per link)

o Exported_network_BS17_Original.txt
Intermediate files:

e mps_ok COPY_o0JCM_1.chk

e mps_ok_COPY_oW_1.chk

e mps_ok COPY_1CM_1.chk

e mps_ok_COPY_1W_1.chk

e mps_ok_COPY_1_2.chk

o JLISTA.dat
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Catalog Folder

First Level

Second Level

Third Level

Fourth Level

Description

e LinkFlows_Itro.dat

e LinkFlows_Itri.dat

e LowFlows_LPo.dat

e LowFlows_LPi.dat

e LP_Rail_defs.dat

¢ MPS_ ColumnlInfo.dat

e MPS_ColumnSelectInfo.dat

e LP_Rail_LPo0.MPS

e LP_Rail_LP1.MPS

e LP_RAIL_LPo.out

e LP_RAIL_LPi.out

e JLISTAsIn

e ErrorSL.txt

e  ErrorSTN.txt

e LockedSTDLogMod_Soln_CapImpact_o.txt

e LockedSTDLogMod_Soln_CapImpact_1.txt
log files

e 10Log_LPo.log

e IOLog_LPilog

e I0_LOG.log

e LOS_STN.log

e LPo-Alog

e LPi-Alog
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Catalog Folder First Level Second Level Third Level Fourth Level Description
e LP_iter.log
e  RunTime_mps_LP.log
For explanation of relationship between steps, programs and files in RCM see
section 6.6.
{CATALOG_DIR} {Scenario_Folder} LogMod_Y RCM ColumnMerge Intermediate files for each commodity group XX :
e ColGen2LPXX.dat
e LP_RailXX.dat
{CATALOG_DIR} {Scenario_Folder} LogMod_Y RCM ColumnData Intermediate files for ach commodity group XX:
¢ ColGen2LPXX-1.dat
e ColGen2LPXX-2.dat
e LP_RailXX-1.dat
e LP RailXX-2.dat
{CATALOG_DIR} {Scenario_Folder} LogMod_Y RCM Output EmptyCost.data — costs for empty vehicles

Commodity.dat — converted into COMMODITYFlows table present in GDB

CBA_aggr.txt — total costs aggregated by mode and

international/domestic/import/export components
chk.txt

Debug.log

DEIT_Empties.dat

DEIT_L+E.dat

DEIT_L+E_Ferry.dat

EmptyCostRCM.dat

EmptyCost_SplitCheck.dat
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Catalog Folder

First Level

Second Level

Third Level

Fourth Level

Description

LOS.dat
RAIL_TONKM_VKM_SUM.DAT

VhcRepRCM.Dat
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While all the outputs above are described under specific documentation for logistic module and Rail Capacity
Management, Exported_Network_XX.txt is produced through Cube and its format is as follow:

Table 125 - Exported_network_xx.txt

Field Description Data Format Example
A A node Integer 1

B B node Integer 2049
LinkType Link type Integer 110
Length Length in km Double 0.26
Tio01 Time in hours (calculation from UL2/SPEED_1) Double 0.31
T102 Time in hours (calculation from UL2/SPEED_ 2) Double 0.31
T103 Time in hours (calculation from UL2/SPEED_2) Double 0.31
T104 Time in hours (calculation from UL2/SPEED_ 2) Double 0.31
T105 Time in hours (calculation from UL2/SPEED_2) Double 0.31
T106 Time in hours (calculation from UL2/SPEED_ 2) Double -1
T201 Time in hours (calculation from UL2/SPEED_2) Double -1
T202 Time in hours (calculation from UL2/SPEED_ 2) Double -1
T203 Time in hours (calculation from UL2/SPEED_2) Double -1
T204 Time in hours (calculation from UL2/SPEED_ 2) Double -1
T205 Time in hours (calculation from UL2/SPEED_2) Double -1
T206 Time in hours (calculation from UL2/SPEED_ 2) Double -1
T207 Time in hours (calculation from UL2/SPEED_2) Double -1
T208 Time in hours (calculation from UL2/SPEED_ 2) Double -1
T209 Time in hours (calculation from UL2/SPEED_2) Double -1
T210 Time in hours (calculation from UL2/SPEED_ 2) Double -1
T211 Time in hours (calculation from UL2/SPEED_2) Double -1
T212 Time in hours (calculation from UL2/SPEED_ 2) Double -1
1301 Speed has two options: Double N
T302 if CATEGORY is 80, 85, 89 & 540 speed comes from SPEED_ 1 present in Double 1
T303 the network Double -1
T304 For all the others from vehicle parameters table based on vehicle number Double 1
T305 Double -1
T306 Double -1
T307 Double -1
T308 Double -1
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Field Description Data Format Example
T309 Double -1
T310 Double -1
T311 Double -1
T312 Double -1
T313 Double -1
T314 Double -1
T315 Double -1
T316 Double -1
T317 Double -1
T318 Double -1
T319 Double -1
T320 Double -1
T321 Double -1
T322 Double -1
T401 Time in hours (calculation from UL2/SPEED_1) Double -1
Ci01 C101=KM_TAX101*UL2 + TOLL101 Double 0
C102 C102=KM_TAX102*UL2 + TOLL102 Double 0
C103 C103=KM_TAX103*UL2 + TOLL103 Double 0
C104 C104=KM_TAX104*UL2 + TOLL104 Double o)
Cio5 C105=KM_TAX105*UL2 + TOLL105 Double 0
C106 C106=KM_TAX106*UL2 + TOLL106 Double 0
C201 C201=KM_TAX201*UL2 + TOLL201 Double 5.55
C202 C202=KM_TAX202*UL2 + TOLL202 Double 4.62
C203 C203=KM_TAX202*UL2 + TOLL202 Double 4.62
C204 C204=KM_TAX204*UL2 + TOLL204 Double 8.21
C205 C205=KM_TAX205*UL2 + TOLL205 Double 9.27
C206 C206=KM_TAX206*UL2 + TOLL206 Double 46.61
C207 C207=KM_TAX207*UL2 + TOLL207 Double 6.36
C208 C208=KM_TAX208*UL2 + TOLL208 Double 7.4
C209 C209=KM_TAX209*UL2 + TOLL209 Double 7.82
C210 C210=KM_TAX210*UL2 + TOLL210 Double 6.44
Ca11 C211=KM_TAX211*UL2 + TOLL211 Double 7.4
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Field Description Data Format Example
C212 C212=KM_TAX212*UL2 + TOLL212 Double 9.6
C3o1 C301=KM_TAX301*UL2 + TOLL301 Double 0
C302 C302=KM_TAX302*UL2 + TOLL302 Double 0
C303 C303=KM_TAX303*UL2 + TOLL303 Double 0
C304 C304=KM_TAX304*UL2 + TOLL304 Double 0
C305 C305=KM_TAX305*UL2 + TOLL305 Double 0
C306 C306=KM_TAX306*UL2 + TOLL306 Double 0
C3o07 C307=KM_TAX307*UL2 + TOLL307 Double 0
C308 C308=KM_TAX308*UL2 + TOLL308 Double 0
C309 C309=KM_TAX309*UL2 + TOLL309 Double 0
C310 C310=KM_TAX310*UL2 + TOLL310 Double 0
C311 C311=KM_TAX311*UL2 + TOLL311 Double 0
C312 C312=KM_TAX312*UL2 + TOLL312 Double o)
C313 C313=KM_TAX313*UL2 + TOLL313 Double 0
C314 C314=KM_TAX314*UL2 + TOLL314 Double o)
C315 C315=KM_TAX315*UL2 + TOLL315 Double 0
C316 C316=KM_TAX316*UL2 + TOLL316 Double 0
C317 C317=KM_TAX317*UL2 + TOLL317 Double 0
C318 C318=KM_TAX318*UL2 + TOLL318 Double 0
C319 C319=KM_TAX319*UL2 + TOLL319 Double 0
C320 C320=KM_TAX320*UL2 + TOLL320 Double 0
C321 C321=KM_TAX321*UL2 + TOLL321 Double 0
C322 C322=KM_TAX322*UL2 + TOLL322 Double o)
C401 C401=KM_TAX401*UL2 + TOLL401 Double 0
ID_COUNTR

¥ Flag of nationality Integer 1

3.4.8. Other files with different purposes

Under scenario folder a set of files is present with different purposes:
e calibration procedure files

e exported information in dbf, Emme, csv format from geodatabase (to exchange the data with users
without Cube Interface)

e general results from Standard Logistics Module and Rail Capacity Management Module
e warm start procedure

e debugging
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select link analysis
visualization in GIS environment

results using general statistics in excel and comparison across different scenarios

3.4.8.1. Calibration procedure files

The Calibration procedure invokes a cycling process where scaling factors for Port Areas and commodity
groups together the Kiel canal scaling factor are altered along the run. The process produces some txt files
that keep the scaling factor information in each loop.

The scaling factors for port areas and commodity groups are saved in the following files:

CalParameter_Loop_1.txt - parameters in the first loop - this file is a copy of the file specified in "
Initial values for port calibration by Port Area and commodity group:", in the current model "
PortAreaParams_16_Comm.txt" under 05_Inputs\Calibration

CalParameter_Loop_2.txt - parameters estimated after completion of loop 1

CalParameterNextLoop.txt - parameters used in next loop - identical to
CalParameter_Loop_"lastloop".txt, in the example lastloop=2

The scaling factor for Kiel Canal has a different treatment since is only one value:

The initial value is provided by the interface with catalog key " Starting value for scaling factor on
Kiel canal" is copied in ParKiel_{Scenario_code}.txt file;

KielNextValue.txt holds the scaling factor along all the iterations. Its structure is LoopNbr Scaling
factor. The value used is obtained looking up LoopNbr.

The following files contain statistics on the calibration procedure:

Differences_{Scenario_code}.csv - differences in tons between modelled and statistics per port area
and commodity group

PortArea_report_{Scenario_code}_loop1.csv - same information present in
Report_13_Tons_per_PortArea_and_Commodity_Group,

PortArea_report_ RCM_ {Scenario_code}_Loopi.csv - same information present in
Report_13_Tons_per_PortArea_and_Commodity_Group (RCM)

RMSE_ loops.txt — same content of Report_14_Oresund Bridge_Kiel Canal and Jylland for STD and
RCM in each loop

3.4.8.2. Exported files
The following files represent information saved in main geodatabase and exported to allow access to
information for modellers or users without a valid Cube Licence.

Capacity_table_{Scenario_Code}.dbf - scenario specific table with ID_ LINK and CAPACITY for all
rail links. This is the export of Rail_ Capacity  {SCENARIO_SHORTNAME} (merged table between
Rail_Capacity_Base2017 and SC_Rail_ Capacity_ {SCENARIO_SHORTNAME}). See 3.2.3.8 for
table structure.

Rail_capacities_ STD_ {Scenario_Code}.DBF - scenario specific table with initial values from Adjust
Procedure. Rail_Capacity_ {SCENARIO_SHORTNAME} (merged table between

Rail_ Capacity_Base2017 and SC_Rail_ Capacity_{SCENARIO_SHORTNAME}). See 3.2.3.8 for
table structure.

EMME_NET_Base2017.211 and V101_102_LINK_SPEEDS.DAT: Scenario network exported in
EMME format (211) together the speed definitions per each link in DAT format. The speed table has
the following headers " Inode Jnode vi01 vi02" where:
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o Inode=Initial emme node number

o Jnode=final emme node number

o V101 = speed in km/h for vehicle type 101

o V102 = speed in km/h for vehicle types 102-106

e General_Table_{SCENARIO_SHORTNAME}.DBF is the exported table
General_{SCENARIO_SHORTNAME} containing all the main parameters of the model. It is used in
the Samgods application when is required to read a general variable.

¢ RENUM_NODES.DBF has the same information of RENUM_NODES table. This file could be link in
the Matrix Window showing the emme zone number instead of the voyager node numbers. For
details refer to Matrix Window > Using zone labels on the Cube Help.

3.4.8.3. Reports from STD Logistics Module , Rail Capacity Management Module and Cost Benefit Analysis
— ASEK values runs
Three report files are produced using MERGE.exe program:

e ChainChoio_Base2017.rep
e ChainChoio_Base2017FIN.rep
e chainchoiCBAo_Base2017.rep
For their description refer to Logistic Module technical documentation.

Each report contains statistics at vehicle type level, chain level and commodity level. These files are saved as
reports (Report_2_ Logistics Module, Report_2_LM_CHAINS, Report_2_LM_DEMAND) and tables
(VHCL_OD_COV, CHAIN_OD_COV, COM_L_D) in the model.

3.4.8.4. Warm start procedure

The cycling process for LP could be restart after a previous run from a different point. For instance if in a
previous run only LPo has been performed, it is possible to run Rail Capacity Management module adding
LP1. To recode the history of previous run, the type of stages performed is recoded in Log_file.log.

The system maintains this file and the user must never change its content.

Each step (Standard Logistic Module, LPo, LP1 and so forth) produces a line with a different code. These
codes are used to manage the right execution order.

The codes associated to each step are listed in Table 126.

Table 126 - Codes under log_file_x.log.

LP LPAdjust Description Date Time

99 99 STD 16-Feb-15 1:06 AM
-1 o) LPo 16-Feb-15 1:57 AM
99 99 FIN 16-Feb-15 6:52 AM
1 0 LP1 17-Feb-15 8:52 AM

The file logfile_scenario.dat contains the last values printed out from the model, it is a temporary file.
Information is later on saved in log_file_ x.log where x is the loop number. Per each loop a different log file is
produced and maintained.

3.4.8.5. Debugging
Some intermediate outputs are saved in scenario folder to allow checks on some complex calculations.


mk:@MSITStore:C:/Program%20Files%20(x86)/Citilabs/Cube/CubeBase.chm::/MatrixWindow.12.1.html#1075717

The calculation carried out in application Samgods\LOS Calculation\Data preparation leads to a network
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containing all the tolls and taxes defined with the different input tables (TAX_by_link,
TAX_by_CATEGORY, TAX_by_COUNTRY, TOLL_BY_LINK and user extra attributes EC_V and

EC_KM_V) together the different rules to open or close a particular link to a particular vehicle type. The
intermediate output with all the information required for the next steps (LOS calculation, assignment in
Standard Logistics Module and Rail Capacity Management Module) is saved under scenario folder with name
FINAL NETWORK_{Scenario_Code}.NET. This file can be accessed from Data Panel under Scenario
Outputs\Other\ Network with costs for checking.

The .NET file is a binary format used in Cube Interface, therefore only Cube can open and visualize the
network in the Network Window (Graphics). A part this, the structure is identical to a Geodatabase network.
In the network are present the node, Table 127, and link, Table 128, tables.

Table 127 - Format of “FINAL_NETWORK_{Scenario_Code}.NET.node” table.

Field Description Data Format Example

N Node number Integer 1

NORIG Original node number based on the combination of ID_Country, Integer 711400
ID_region and MODE_ N values

SCBSTANN SCBSTANN code Integer 114

ID_REGION Region code Integer 114

MODE_N Mode code Integer ¢}

Ul4 User field (not used in the current model) Double 0

CENTRALL Node description in terms of location String Upplands-Visby

X Coordinate x (SWEREF99_TM) Double 1620000

Y Coordinatey (SWEREF99_TM) Double 6601000

Table 128 - Format of “FINAL_NETWORK_{Scenario_Code}.NET.Link” table.

Field Description Data Format Example
AX/BX Minimum X coordinate Double 10648
AY/BY Minimum Y coordinate Double 257
A Start node Integer 2231
B End node Integer 2353
OBJECTID ID object Integer 625
ID_LINK Link identified for rail link. Two links in opposite direction share the Integer 25
same ID_LINK.
ORIGINALCAP Original value for capacity in bidirectional trains per day Double 23
M_101 Flag 0/1If 1 open to 101 Integer o
M_102 Flag o/1 If 1 open to 102 Integer 0
M_103 Flag 0/1 If 1 open to 103 Integer o]
M_104 Flag 0/1If 1 open to 104 Integer o
M_106 Flag o/1 If 1 open to 106 Integer 0
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Field Description Data Format Example
M_201 Flag 0/1 If 1 open to 201 Integer 1
M_202 Flag 0/1 If 1 open to 202 Integer 3
M_204 Flag 0/1 If 1 open to 204 Integer 1
M_205 | ... Integer 1
M_401 Flag 0/1 If 1 open to 401 Integer o
MODESTR String with all the allowed modes String xdwhi
SPEED_1 Speed in kms per hour for all modes except v102-106 in Sweden Double 70
SPEED_2 Speed in kms per hour for vehicle types v102-106 in Sweden Double 0
CATEGORY Link category Integer 70
FUNCTION Index for vdf function Double 66
NLANES Number of lanes (may be a decimal number) Double 1
UL2 Distance in kms. User link data in emme used to enable holding link Double 1.36
lengths longer than 999 kms.
UL3 Capacity for vessels on sea (dwell tons) Double 0
ID_COUNTRY Country code Integer 1
EC_Vio1 Extra cost on link (defined via EC_V attribute in the network) for vio1 Double -99999
EC_KM_Vio Extra costkm on link (defined via EC_KM_V attribute in the network) Double 109999
for vio1
EC_Vio2 Extra cost on link (defined via EC_V attribute in the network) for vio2 Double -99999
EC_KM._Vioz Extra costkm on link (defined via EC_KM_V attribute in the network) Double 09999
for vio2
EC_Vioz | ... Double -99999
EC_KM_Vio3 | ..... Double -99999
AORIG Emme initial node number Integer 4246
BORIG Emme final node number Integer 9088
KM_TAXi101 Sum of TAX_C, EC_KM_V for Vio1 Double o)
TOLL101 Sum of TAX_LT, TAX_ L, EC_V,TOLL_L for Vio1 Double o)
KM_TAX102 Sum of TAX_C, EC_KM_YV for Vio2 Double o)
TOLL102 Sum of TAX_LT, TAX_ L, EC_V,TOLL_L for V102 Double o)
KM_TAX1i03 | ..... Double 0o
TOLLioz | ... Double o)
KM_TAX401 Sum of TAX_C, EC_KM_YV for V401 Double 0o
TOLL401 Sum of TAX_LT, TAX_L, EC_V,TOLL_L for V401 Double (o}
MODE_L Mode Integer 2

The variables listed above has the following meaning:
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e TAX_C: country tax based on Tax_Country_{SCENARIO_SHORTNAME} table - SEK/km

e TAX_LT: tax by category on Tax_Category_{SCENARIO_SHORTNAME} table - SEK

e TAX_L:tax by link on Tax_Link_{SCENARIO_SHORTNAME} table - SEK

e TOLL_L: toll on link from Toll_Link {SCENARIO SHORTNAME} table - SEK

e EC_V: extra cost applied using EC_V attribute in the network (see user manual for details) - SEK

e EC_KM_YV: extra cost km applied using EC_KM_V attribute in the network (see user manual for
details) - SEK

Those taxes and tolls are recombined into two attributes:
¢ KM_TAX: includes TAX_ Cand EC_KM_V, in other words values based on distance
e TOLL: includes TAX_LT, TAX_ L, TOLL_L and EC_V, therefore values based on a link

The final results of KM_TAX and TOLL are not merely the sum of the individual values since TAX_C,
TAX_LT and TAX_ L mutually exclude each other. We have the following cases:

e if TAX_Lis specified, TAX_C and TAX_LT will be not applied
e if TAX_Lis not specified and TAX_LT has a value, only TAX_LT will be applied
o if TAX_L and TAX_LT are not specified, only TAX_C will be applied.

Also values equal to zero have a meaning, since a zero-valued tax could be specified by TAX_L=0, and that
will give a tax level at 0. To treat this case all the values are initialized to -99999, before applying any specific
values from tables in geodatabase.

Furthermore, the following tables are saved:

e Tax_by_Link_{Scenario_code}.DBF: taxes for each link in specific scenario (see structure from
3.2.3.11)

e Tax_Category_{Scenario_code}.DBF: Taxes by category type (see structure from 3.2.3.9)
e Tax_Country_{Scenario_code}.DBF: Taxes by country (see structure from 3.2.3.10)
e Toll_by_link_{Scenario_code}.DBF: tolls by link (see structure from 3.2.3.12)

e Vh_par_tot.DBF: union of part A and Part B vehicle parameters tables by vehicle type and
commodity group

e Check_overcapacity_{Scenario_code}.DBF: number of links overcapacity before applying RCM
procedure.

3.4.8.6. Select link analysis
The Select Link application has two different modalities:

e The former allows to skim the loaded vehicles and tons for specific chains going through a list of
nodes or links and per commodity.

e The latter is a fixed tool to produce the road matrices (in terms of loaded, unloaded and ton matrices
for road mode).

The standard output for the two cases is therefore different. All the outputs for option A (select link) are
linked in the GUI. No outputs for Option B are accessible from the interface but reside under the SelectLink
folder selected in setting up the scenario.

Option A: Select Link

Under SelectLink\{SelectLink_name} the following files listed in Table 129 will be present.
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Table 129 - List of outputs under SelectLink folder for SelectLink output Suffix STD refers to Standard

Logistics Results, SL to RCM.

RCM_COMMODITY.NET

STD_COMMODITY.NET

AIR_TON_FIN_MainSc2040.MAT

AIR_TON_MainSc2040.MAT

AIR_VHCLFLOW_FIN_MainSc2040.MAT

AIR_VHCLFLOW_MainSc2040.MAT

RAIL_TON_FIN_MainSc2040.MAT

RAIL_TON_MainSc2040.MAT

RAIL_VHCLFLOW_FIN_MainSc2040.MAT

RAIL_VHCLFLOW_MainSc2040.MAT

ROAD_TON_FIN_MainSc2040.MAT

ROAD_TON_MainSc2040.MAT

ROAD_VHCLFLOW_FIN_MainSc2040.MAT

ROAD_VHCLFLOW_MainSc2040.MAT

SEA_TON_FIN_MainSc2040.MAT

SEA_TON_MainSc2040.MAT

SEA_VHCLFLOW_FIN_MainSc2040.MAT

SEA_VHCLFLOW_MainSc2040.MAT

ChainsSL.dat

ChainsSLSTD.dat

ConCumSL.dat

ConCumSLSTD.dat

ConnectionsSL.dat

ConnectionsSLSTD.dat

LinksSumSL.dat

LinksSumSLSTD.dat

Output

File name Type Description

SelectDirect.ctl control file for program

SelectDirectSTD.ctl Control file

ErrorSL.txt LOG error

ErrorSLSTD.txt LOG error

RCM.NET Output network with selected volumes by vehicle type
STD.NET Output network with selected volumes by vehicle type

Output network with selected volumes by commodity group

Output network with selected volumes by commodity group

Matrices in Binary format

Selected chain list in RCM

Selected chain list in STD

Matrix in dat format

Matrix in dat format

Link list with loaded vehicles and tons

Link list with loaded vehicles and tons
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Option B: Traversal Matrices

Table 130 - List of outputs under SelectLink folder for a Traversal Matrices output.
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File name Output name Format

SelectLink\SLTravmat ErrorSL.txt String file
ErrorSLSTD.txt String file
SelectDirect.ctl Control file
SelectDirectSTD.ctl Control file

SelectLink\SLTravmat\FIN

v101_emp.314

314 Emme matrix file

v101_ton.314

314 Emme matrix file

v101_vhcl.314

314 Emme matrix file

v102_emp.314

314 Emme matrix file

v102_ton.314

314 Emme matrix file

v102_vhcl.314

314 Emme matrix file

v103_emp.314

314 Emme matrix file

v103_ton.314

314 Emme matrix file

v103_vhcl.314

314 Emme matrix file

v104_emp.314

314 Emme matrix file

v104_ton.314

314 Emme matrix file

v104_vhcl.314

314 Emme matrix file

v105_emp.314

314 Emme matrix file

v105_ton.314

314 Emme matrix file

v105_vhcl.314

314 Emme matrix file

SelectLink\SLTravmat\STD

v101_emp.314

314 Emme matrix file

v101_ton.314

314 Emme matrix file

v101_vhcl.314

314 Emme matrix file

v102_emp.314

314 Emme matrix file

v102_ton.314

314 Emme matrix file

v102_vhcl.314

314 Emme matrix file

v103_emp.314

314 Emme matrix file

v103_ton.314

314 Emme matrix file

v103_vhcl.314

314 Emme matrix file

v104_emp.314

314 Emme matrix file

v104_ton.314

314 Emme matrix file

v104_vhcl.314

314 Emme matrix file

v105_emp.314

314 Emme matrix file

v105_ton.314

314 Emme matrix file
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v105_vhcl.314 314 Emme matrix file

3.4.8.7. GIS maps
These folders contain compatible output networks for ArcGIS users. The folder can be shared among other
people without the Cube interface requirements.

The maps are listed in Table 131 where:

o The first folder has the absolute tons and vehicles per commodity group and totals saved in a
geodatabase feature class under the gdb file.

e The second folder has the differences between the two scenarios for the same quantities.

For unit and meaning of attributes present in ABS_GIS{SCENARIO_SHORTNAME}, folder refer to Table
96.
Table 131 - GIS maps.

File name Output name Format

GeodatabaseYYYY_COM.gdb where YYYY is the base year 2017 or
Personal geodatabase ArcGIS format
the prognosis year 2040

GeodatabaseYYYY_COM.vpr (present after mxd is opened) where . .
Cube visual project file
YYYY is the base year 2017 or the prognosis year 2040

ArcGIS map document for tons (by commodity
Output_COM_STD_GIS_TON.mxd

ABS_GIS{SCENARI group) Standard Logistic Model
O_SHORTNAME}

ArcGIS map document for vehicles (by
Output_COM_STD_GIS_VHCL.mxd . o
commodity group) Standard Logistic Model

ArcGIS map document for tons (by commodity
Output_COM_RCM_GIS_TON.mxd . .
group) Rail Capacity Management

ArcGIS map document for vehicles (by
Output_COM_RCM_GIS_VHCL.mxd . . .
commodity group) Rail Capacity Management

GeodatabaseDIFFYYYY-2017_STAN.gdb where YYYY is the base
Personal geodatabase ArcGIS format
year 2017 or the prognosis year 2040

GeodatabaseDIFFYYYY-2017_STAN.vpr where YYYY is the base . .
DIFF_GISYYYY_2017 Cube visual project file
year 2017 or the prognosis year 2040

Output_BaseYYYY_2017_COM_GIS.mxd where YYYY is the base
ArcGIS map document
year 2017 or the prognosis year 2040

3.4.8.8. Outputs_Calibration_Template_rev4.xlsm

In the past several reports were post produced after full run with quite an important level of effort. Thus, the
reports were created to ease this procedure and for further easement the output called “Calibration_1.txt” is
produced for each scenario which contains all the following reports:

e Report 1 TonKm (*1,000,000) total domestic by mode (international for air)
e Report 2 Port areas statictics (ktons)

e Report 3 ktonkm by commodity group on rail
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e Report 4 Kiel and Oresund bridges (percentage diff on Oresund, Percentage transport on Kiel Canal
vs Kiel+Jylland)

e Report 5 Tonkm Road vehicle type distribution
e Report 6 Tonkm Rail main vehicle types
e Report 7 Vhkm Road distribution
e Report 8 Tons Sea distribution
The spreadsheet has the following tabs:
e Inputs
e Data Import
e Reports
e Diagrams_1_scenario
e Diagrams_all_scenarios

To import calibration_ 1.txt go under “Inputs” tab and click on “Import Data” button (providing location of
scenario you want to import) seen in Figure 3.

All tables under “Reports” and diagrams under “Diagrams_1_scenario” are automatically updated.

There is also the option to import other scenarios for comparison from other excel files. In the example under
“Outputs_Calibration_Test6.xlsm” Test6 has been imported. To import another scenario, it is sufficient to
click “Get comparison data”. This will automatically update “Reports” and “Diagrams_ all_scenarios”.

The excel file has been built with the following principles:
1. You must create a file for each scenario;

2. You can keep track of all previous scenarios, importing incrementally each previous scenario. For
instance: first scenario in my example is Base2012. This will be populated only with statistics and
Base2012 values. Second scenario will import first its own values (Test1) and Base2012 values will be
paste from first excel. Test 2 will be populated with its own values and Test1 and Base 2012 will be
copied from “Output_Calibration_Test1.xlsm” file. Etc.

3. [Itis possible to keep memory up to 22 scenarios.
No actions are required by final user in updating tables or diagrams. The user must just fill out properly

fields (entries marked as <-- just change this) present under “Inputs” spreadsheet and click two buttons.

Main Scenario
File name Calibration 1.txt <--fixed name
Scenario folder C:\Models\Samgods V12D 20190108\Scenario Tree\Year 2012\Base2012% <--just change this

Impert Data ‘

Scenario for Comparison

Scenario Name Tests <--just change this
File Path \\Manchfile\Manch\tp\ 107662 Samgods V2 1\30 Technical\32 support\Outputs Calibration), <--just change this
File Mame Cutputs_Calibration_Teste.xlsm

Get comparison data ‘

Figure 3 - Interface to import results for base year.
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4 The model structure

The Samgods model could be described as a set of different software integrated in a standalone interface. The
technical documentation refers to the GUI interface implemented in Cube software and in this chapter the
different physical elements constituting the model will be explored. The naming and syntax used is derived
from the Cube Software.

The model can be viewed in Cube interface opening the catalog file, always placed under the model folder,
having extension .cat. The purpose with this file is to coordinate all the various parts of the model in terms of:

e Applications - files with .app extension

e Scenario keys - elements saved in .cat file

e Location of input and output data - based on program steps present in each application
e Give access to all the input and output data by scenario

e Define the rules on how to use the model (developer or user class)

The catalog file (named SamGods.cat) stores all the connections, maps and definition values for each entity
listed above.

The catalog keys, listed in the catalog files, have a variety of purposes. They can define:
e The execution order for the applications
¢ Enable or disable the creation of specific outputs
e Point to an input file or parameter

The Cube-applications represent the programming parts, using the input data and applying the set of rules
defined via the scripting language, they produce specific outputs and manage the data (see the description of
each application for more details).
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The list of catalog keys defined in the model, classified by user rights and application usage are listed in Table 132.

Table 132 - Catalog keys.

Catalog key name Example of value User Application
Catalog name Interface name
Install_driver Hard Drive where the model resides C:\ Developer Installation
Samgods Model
Elasticity module
Cube_software Cube software 6.1.1 Developer Installation
GIS_software ArcGis Software 10.2.2 Developer Installation
Python_Software Python software 27 Developer Installation
LogMod_ software Logistics Model Software 1.1.1 Developer Installation
Cube_Folder Location of Cube Program C:\Program Files (x86)\ Developer Installation
Installation_DOS Path to cmd.exe C:\windows\sysnative\cmd.exe Developer Installation
Samgods Model
Select Link Analysis
Elasticity module
Cost Benefit Analysis - ASEK Values
Python Location of python program C:\Python27\ArcGIS10.2 Developer Installation
JavaVersion Location of Java folder C:\Windows\System32 Developer Create the editable files
Edit the data
Samgods Model
Handling scenario
Compare Scenarios
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Catalog key name

Catalog name

Interface name

Example of value

User

Application

Select Link Analysis

Elasticity module

Installation

Base_ Scenario

Scenario name for the BASE Scenario

Base2017

Developer

Samgods Model

Select Link Analysis

Elasticity module

Cost Benefit Analysis - ASEK Values

Installation

Scenario_copy

Which scenario do you want to copy as new

scenario?

Base2017

All

Create the editable files

Edit the data

Samgods Model

Handling scenario

PWC_Matrices

Select Link Analysis

Elasticity module

Cost Benefit Analysis - ASEK Values

Create the editable files

Waittime

Wait time for prompt messages during

execution (default 10 minutes=600 seconds)

600

Developer and
Advanced User

Create the editable files

read_ write

Do you want to lock the scenario

permanently from further editing?

Yes

All

Edit the data

Samgods Model
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value in scenario network)

Catalog key name Example of value User Application
Catalog name Interface name
Cost Benefit Analysis - ASEK Values
Elasticity Module
Edit the data
Edit_soft Select from which source you want to import | GIS Window (Use input files constructed by the Cube All Edit the data
your edits GUI)
EMME_data Emme network file C:\Models\SamGods_V12\05_Input_Data\2017_204 | All Edit the data
0\revi50424\Base2040_corr\Samgods_Base_2040(r
ev150424).211
EMME_ speed Emme speed table C:\Models\SamGods_V12\o5_Input_Data\2017_204 | All Edit the data
o\revi50424\new_road_2030_Samgods_1_0_V101_
102_link_speeds.DAT
Up_parameters General parameters [Table] {CATALOG_DIR}\Scenario_Data.mdb\General_Base | Developer Edit the data
2017
GCOST Attibute name for the extracost on specific EC_V All Edit the data
link (SEK)
GCOST_D Attibute name for the extracost on specific EC_KM_V All Handling scenario
link (SEK/km) .
Edit the data
DF Number of operating days per year for all 250 Developer and Handling scenario
modes (except for Rail Mode) (days/year Advanced User
(excep ) (days/year) Edit the data
DFR Number of operating days per year for Rail 250 Developer and Handling scenario
Mode (days/year Advanced User
(days/year) Edit the data
Zones Number of zones/terminals in network (see 1377 All Handling scenario

Edit the data
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Catalog key name Example of value User Application
Catalog name Interface name
LogParam General parameters for Logistic Module {CATALOG_DIR}\Scenario_Tree\Base2017\Scenario | Developer Samgods Model
[Table] _Data.mdb\LogMod_Base2017 PWC_Matrices
Select Link Analysis
Cost Benefit Analysis - ASEK Values
Elasticity Module
Edit the data
INTER_RATE Interest rate used in cost calculations 0.1 All Handling scenario
(6/year) Edit the data
STUFF Stuffing cost (SEK/tonne) 60 (18 for ASEK) All Handling scenario
Edit the data
LSTCNT Number of transport chain solutions for the 5 All Handling scenario
Logistics Module Edit the data
DATA Output variables for the optimal transport 6,7 All Handling scenario
solution [e.g.1,2,3, max is 8] Edit the data
FACTOR Initial consolidation factor in BuildChain 0.75 All Handling scenario
(First iteration - from o0 to 1) Edit the data
CONTYPE Allow consolidation for all lorry types Yes All Handling scenario
Edit the data
INODLO Evaluate transport chains one leg at a time Yes All Handling scenario
Edit the data
MATD4FO 100 All Handling scenario
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Catalog key name Example of value User Application
Catalog name Interface name
Lower bound for frequency optimazation Edit the data
(Annual Tonnes/Shipment)
CONSOL_L Lower bound for consolidation factor 0.05 All Handling scenario
(applied to all commodities - from o to 1) )
Edit the data
CONSOL_U Upper bound for consolidation factor 0.95 All Handling scenario
(applied to all commodities from o to 1) ]
Edit the data
TONNES Calculation for demand affecting shipment DYNAMIC_AVERAGE All Handling scenario
size
Edit the data
LOGCTL Do you want to log parameters from control | Yes All Handling scenario
files? .
Edit the data
LOGFLS Do you want to log reading of input data? Yes All Handling scenario
Edit the data
LOGCST Do you want to log cost values from vehicle Yes All Handling scenario
files? ]
Edit the data
BESTOUT For which logistic solutions do you want to 1 All Handling scenario
produce output data? (0=none, 1=Best .
Edit the data
solution, 2=Best + Second)
Del_tmp Do you want to delete the temporary Tick All Handling scenario
eodatabase? (Tick=yes
8 ( yes) Edit the data
Mxd_ file ArcMap GIS Project File {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data

RTNAME}\Input_Data.mxd
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Catalog key name Example of value User Application

Catalog name Interface name

Up_cargo Commodity data [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
RTNAME}\Scenario_Data.mdb\Cargo_{SCENARIO_
SHORTNAME}

Up_Vehicles_par General parameters of Vehicle types [Table] | {CATALOG_DIR}\Scenario_Tree\Base2017\Scenario | All Edit the data
_Data.mdb\Vehicles_Parameters_Base2017_PartA

Up_Vehicles_par_B Specific parameters of Vehicle types by {CATALOG_DIR}\Scenario_Tree\Base2017\Scenario | All Edit the data

commodity group [Table] _Data.mdb\Vehicles_Parameters_Base2017_PartB

Up_Tax_C Table with tax by country (SEK/km) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
RTNAME}\Scenario_Data.mdb\Tax_Country_{SCEN
ARIO_SHORTNAME}

Up_Tax_L Tax by Category (SEK) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
RTNAME}\Scenario_Data.mdb\Tax_Category_{SCE
NARIO_SHORTNAME}

Up_tax_link Tax by Link (SEK) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
RTNAME}\Scenario_Data.mdb\Tax_Link_ {SCENARI
O_SHORTNAME}

Up_toll Toll for bridges (SEK) [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
RTNAME}\Scenario_Data.mdb\Toll_Link_{SCENAR
I0_SHORTNAME}

Up_net Network specific of scenario [Geodata] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
RTNAME}\Scenario_Data.mdb\Network

Up_node_terminals Port terminals pilot fees values {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data

(SEK/vehicle) [Geodata] RTNAME}\Scenario_Data.mdb\Ports_Swe
Up_nodes Zones and terminals attributes [Geodata] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data

RTNAME}\Scenario_Data.mdb\Nodes

183




The model structure

files?

Catalog key name Example of value User Application
Catalog name Interface name
Up_no_comm Nodes commodities (interchanges allow) {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Edit the data
[Geodata] RTNAME}\Scenario_Data.mdb\Nodes_commodities
Up_freq Frequency data (# transport/ {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO | All Edit the data
week)[Geodata] RTNAME}\Scenario_Data.mdb\Frequency_network
Up_Rail_Capacity Table with Rail Capacity [Table] {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO | All Edit the data
RTNAME}\Scenario_Data.mdb\Rail_ Capacity {SCE
NARIO_SHORTNAME}
Step_by_step Run only one step, or run all steps All steps All Samgods Model
Year Choose PWC matrices 2016 All Elasticity Module
Samgods Model
Select_cal_cos_mode Select the mode for the LOS Calculation and | All All PWC_Matrices
the Assignment steps . .
Select Link Analysis
Elasticity Module
Samgods Model
Select_commodity Select commodities for the Logistics Module | o All Elasticity Module
(for all commodities, select 0)
Samgods Model
log_out Do you want to produce buildchainxx.log None All Compare Scenarios

Handling scenario

Change matrix format

Cost Benefit Analysis - ASEK Values

Elasticity Module

Samgods Model
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Catalog key name Example of value User Application
Catalog name Interface name
Elasticity Module
CON_RATE_SELECTION Do you want to use exogenous consolidation No All Samgods Model
rates? Elasticity Module
FOLDER_CR If yes in previous catalog key, provide location of | {CATALOG_DIR}\Scenario_Tree\Year_2017\Base2017\LogM | All Samgods Model
consolidation rates folder od_1\ChainChoi\output\
Elasticity Module
Cluster_p Do you want to run the Logistics Moduleon | Yes All Samgods Model
several processors? Elasticity Module
Cluster_nodes How many processors would you liketorun | 4 All Cost Benefit Analysis - ASEK Values
simultaneously? Samgods Model
Elasticity Module
Cluster_nodes_LP2CC How many processors would you liketorun | 4 All Cost Benefit Analysis - ASEK Values
simultaneously for LP2CC? Samgods Model
Elasticity Module
scal_factor Scaling factor for outputs Thousands All Cost Benefit Analysis - ASEK Values
Samgods Model
Elasticity Module
RescLOS Do you want to produce rescaled LOS and No All Cost Benefit Analysis - ASEK Values
MC matrices per commodity group? Samgods model
Elasticity Module
UTIL_PERCENT Cut off criteria for RCM process (will 30 D/A-user Samgods model

consider links with Number of vehicles over

Elasticity Module
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(o)

Catalog key name Example of value User Application
Catalog name Interface name
Capacity > XX% where XX is the value
defined)
maxiters_EA Maximum number of iterations in Rail 1 D/A-user Samgods model
assignment ..
Elasticity Module
SpeedFlowCurve Delay function for Empty assignment 2*10000*(MAX(0,VOLC[LIL.ID_LINK]-C)) D/A-user Select Link Analysis
(Derivate)
Samgods model
Elasticity Module
Save_Output_ RCM Options to save output files from RCM Yes, for all iterations All Select Link Analysis
process
Samgods Model
Elasticity Module
RCM_Loop Maximum number of loops for Linear 1 All Samgods Model
Programming process (LP
8 &P (LF) Elasticity Module
Lock_file File with list of locked solutions Locked_empty.dat D/A-user Samgods Model
Elasticity Module
Debug_ checklist Link number to use in debug mode 51,82,84 D/A-user Cost Benefit Analysis - ASEK Values
CheckLinkN_itXX.dat Max 10 links (comma
Samgods Model
s, €X. 1,25,182,164)
Elasticity Module
RAIIMODES List of rail modes in RCM GHhIiTUDdAEFf D/A-user Samgods Model
Elasticity Module
RAILVHCL List of vehicle types on Rail mode 201,202,203,204,205,000,000,000,000,000,000,00 D/A-user Cost Benefit Analysis - ASEK Values

Samgods Model
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Catalog key name Example of value User Application
Catalog name Interface name
Elasticity Module
PortCalibration Initial values for port calibration by Port C:\Models\SamGods_V12\o5_Input_Data\Calibratio | Developer Samgods Model
Area and Commodity grou n\PortAreaParams_MainSc2017R094.txt
ty group \ - 78094 Elasticity Module
StartKiel Starting value for scaling factor on Kiel canal | 1.9 Developer Samgods Model
Elasticity Module
OverallLoopMax Maximum number of loops in calibration 1 Developer Samgods Model
process . .
Select Link Analysis
ParametersPortCal Parameters for port calibration procedure {CATALOG_DIR}\05_Input_Data\Calibration\Param | Developer Samgods Model
(step length, minimum value, threshold, eters_portcalibration.dbf
default)
ParametersKiel Parameters for Kiel calibration procedure {CATALOG_DIR}\05_Input_Data\Calibration\Param | Developer Samgods Model
(step length, minimum value, threshold, eters_Kielcalibration.dbf
default)
Resume_option Restart process from loop 1 Developer Samgods Model
Cost Benefit Analysis - ASEK Values
ConsolTable Consolidation factors table {CATALOG_DIR}\05_Input_Data\Input_Data.mdb\ D/A-user Elasticity Module
BuildChain_ CONSOL
Samgods Model
Handling scenario
Cost Benefit Analysis - ASEK Values
Elasticity Module
Select_compare What do you want to compare? All All Compare Scenarios
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matrices?

Catalog key name Example of value User Application

Catalog name Interface name

ScenarioC_name Scenario's name to use in comparison (ex. Base2017 All Compare Scenarios
Test17)

ScenarioC_dir Scenario folder for comparison (ex. {CATALOG_DIR}\Scenario_Tree\Base2017\ All Compare Scenarios
{CATALOG_DIR}\Scenario_Tree\Year_201
7\Test17\)

Choice Select how you want to use Handling (3) EXPORT the model in a new folder using the All Handling scenario
Scenario application current scenario as Base

New_folder For choice 3 or 4 provide an absolute path to | C:\SamGods_v2\ All Handling scenario
the location of the destination model (ex.
C:\Samgods_New_version\)

New_Base For choice 3 or 4 provide the name of the Base2017 All Handling scenario
base scenario in the destination model

Imp_Selection Do you want to control the imported No All Handling scenario
scenario?

Format Do you want to export in csv, DBF or GDB CSV All Change matrix format
format?

GDB_c_u Do you want to create a new geodatabase or Existing All Change matrix format
use an existing one?

GDB_folder Define the GDB where the matrix should be {CATALOG_DIR}\Scenario_Tree\{SCENARIO_SHO All Change matrix format
exported RTNAME}\Outputo_{SCENARIO_SHORTNAME}.m

db
COST
Type_mat What kind of matrix do you want to export? COST All Change matrix format
Type_mode What is the mode that you want for the ROAD All Change matrix format
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Catalog key name Example of value User Application
Catalog name Interface name
Type_VHCL What vehicle type do you want for the LOS 101 All Change matrix format
matrices?
Type_COST Do you want the distance, time, domestic Extracost All Change matrix format
distance or extracost LOS matrix?
Type_VHCL_1 What type of vehicle type (or total) do you 202 All Change matrix format
want for the VEHICLES and TONNES
matrices?
ReferenceScenario ASEK costs (Base2017ASEK if Year_ 2017, Base2017ASEK All Cost Benefit Analysis - ASEK Values
MainSc2040ASEK if Year_2040)
ScenarioJA_ Dir Full scenario folder for comparison (JA- C:\Models\Samgods_V12D_20190531\Scenario_Tree | All Cost Benefit Analysis - ASEK Values
reference scenario - before investment) \Year_2017\Base2017\
(Base2017 folder if Year_ 2017, MainSc2040
folder if Year_2040)
ScenarioJA_Name Scenario's name to use in comparison (JA- Base2017 All Cost Benefit Analysis - ASEK Values
reference scenario - before investment)
(Base2017 if Year_2017, MainSc2040 if
Year_2040)
Include_empties Include the cost of empty transports in the No All Cost Benefit Analysis - ASEK Values
calculation of system costs
Domestic W Weighting factor Domestic 1.0 All Cost Benefit Analysis - ASEK Values
Import_ W Weighting factor Import 0.5 All Cost Benefit Analysis - ASEK Values
Export W Weighting factor Export 0.5 All Cost Benefit Analysis - ASEK Values
Transit_ W Weighting factor Transit 0.0 All Cost Benefit Analysis - ASEK Values
CSTVARI Stochastic approach: parameter for logit C:\Models\Samgods_V12D_20200501\05_Input_Dat | Developer Samgods model

distribution (0=no stochastic approach used

a\Input_Data.mdb\CSTVARI

Cost Benefit Analysis - ASEK Values
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Catalog key name Example of value User Application
Catalog name Interface name
or actual value i.e. 0.1) by commodity and fof Elasticity Module
type
N_flows Total number of commodities (excluding 16 Developer Samgods model
empty commodities) Cost Benefit Analysis - ASEK Values
Elasticity Module
PWC_Matrices
SHIPCUT Shipment size cut-off (tonnes) 1 All Samgods model
Elasticity Module
CAPCOST Marginal cost limit in MPS.jar (SEK) 998801 All Samgods model
Elasticity Module
EXTRA_CAPCOST Acquisition of extra capacity (SEK) 1000000000 All Samgods model
Elasticity Module
Chains List of chains for different numbers of Chain_ List_2040 D/A-user Samgods model
vehicle types Elasticity Module
Cost Benefit Analysis - ASEK Values
Dometic_ W Weighting factor Domestic 1 All Cost Benefit Analysis - ASEK Values
Import_ W Weighting factor Import 0.5 All Cost Benefit Analysis - ASEK Values
Export W Weighting factor Export 0.5 All Cost Benefit Analysis - ASEK Values
Transit_ W Weighting factor Transit 0 All Cost Benefit Analysis - ASEK Values
FolderSL SelectLink analysis name (max 6 characters) | SL1 All Select Link Analysis
List_type Numbering system for link list ID_LINK (Example 1,2,201,207) All Select Link Analysis
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Catalog key name Example of value User Application

Catalog name Interface name

A_B List of links 1,15,329 All Select Link Analysis

VISITLINK Selection criteria for links ANY ; any of given links must be used All Select Link Analysis

List_type_n Numbering system for node list Voyager (Example 1,2049,2083,2039) All Select Link Analysis

N List of nodes 111,011,102 All Select Link Analysis

VISITNODE Selection criteria for nodes ANY ; any of given nodes must be used All Select Link Analysis

SL_Comm List of commodities for Select Link Analysis 0 All Select Link Analysis
(o for All)

Selection_rule Select the method being applied for node AND link selection (both met) All Select Link Analysis
conditions on nodes and links

TravMat Do you want to produce traversal matrices? Yes All Select Link Analysis
(Untick=no Tick=yes)

GISMaps Do you want to produce GIS Maps by Yes All Select Link Analysis
Commodity group?

Scenario_Table Table with scenarios want to run for the C:\Models\Samgods_V12D_20190829\05_Input_Dat | All Elasticity Module
elasticity calculation a\Input_Data.mdb\Scenarios_ List

Min_Loop Lowest scenario in sensitivity run 1 All Elasticity Module

Max_Loop Highest scenario in sensitivity run 10 All Elasticity Module

CON_RATE_SELECTION Do you want to use exogenous consolidation | Yes All Samgods model
rates? Elasticity Module

FOLDER_CR Location of consolidation rates folder {CATALOG_DIR}\Scenario_Tree\Year_2017\Base201 | All Samgods model

7\LogMod_1\ChainChoi\output\ Flasticity Module
scal_factor Scaling factor for outputs Thousands All Samgods model

Elasticity Module
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Catalog key name

Catalog name

Interface name

Example of value

User

Application

Cost Benefit Analysis - ASEK Values
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The list of applications and subgroups defined in the model is shown in Table 133. Numbers between

parentheses represent the execution order within a subgroup.

Table 133 - Applications and subgroups.

Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Installati {CATALOG_DIR}\02_Applicaions\5_Installation\Ins
on tallation_st.app
{CATALOG_DIR}\0o2_Applications\1_Editing\Setup.
app
Prepare
temporary {CATALOG_DIR}\0o2_Applications\1_Editing\EDIT
data (1) _PREPAR.app
Creat Editable {CATALOG_DIR}\02_Applications\1_Editing\EDIT
reate
tables (2) _TABLES.app
the
editable Editable map {CATALOG_DIR}\0o2_Applications\1_Editing\EDIT
files data (3) _MAP.app
{CATALOG_DIR}\02_Applications\1_Editing\Edit.a
pp
Create the
tables
specific of {CATALOG_DIR}\o2_Applications\1_Editing\CREA
scenario (1) TE_TABLES.app
Numbering
System {CATALOG_DIR}\02_Applications\1_Editing\Numb
Voyager ering\NUMBERo1.app
{CATALOG_DIR}\02_Applications\1_Editing\EMM
Emme Edits EEDITS.app
Compare
Nodes and
Node_ termi {CATALOG_DIR}\o2_Applications\1_Editing\Comp
nals arison\COMPARo1.app
Compare {CATALOG_DIR}\o2_Applications\1_Editing\EDIT
other tables _OTHERS.app
Rail
Capacity and {CATALOG_DIR}\0o2_Applications\1_Editing\Capaci
Net Checks ty\RAILCAoO1.app
Frequency {CATALOG_DIR}\0o2_Applications\1_Editing\Frequ
matrices ency.app
Save changes
Edit the in the main {CATALOG_DIR}\0o2_Applications\1_Editing\CREA
data gdb (2) TE_SAVE.app
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Applicat
ion

name

Subgroup

level 1

Subgroup

level 2

Subgroup
level 3

Subgroup
level 4

File name

Regions for

links

{CATALOG_DIR}\o2_Applications\1_Editing\Regio
ns\REGIONo1.app

Samgods
Model

{CATALOG_DIR}\o2_Applications\2_Run\SamGod
_VY.app

Initialization

®

{CATALOG_DIR}\02_Applications\2_Run\Ini\INIT
TAoo.app

LOS
calculation

(4)

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\COST_VY.app

Data

Preparation

{CATALOG_DIR}\o2_Applications\2_Run\Costs_V
Y\DATAPREPARATION_VY.app

Tax

calculation

{CATALOG_DIR}\o2_Applications\2_Run\Costs_V
Y\DATAPREPARATION_VY_o1.app

Data for
RCM

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\DATARCM.APP

Samgods
Model

Road

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\ROAD.app

Rail

{CATALOG_DIR}\o2_Applications\2_Run\Costs_V
Y\RAIL.app

Sea

{CATALOG_DIR}\o02_Applications\2_Run\Costs_V
Y\SEA.app

Air

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\AIR.app

Conversion
from VY to
LogMod

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\CONVERALL.app

From VY to
LogMod
Road

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\CONCOSTVYE2.app

From VY to
LogMod Rail

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\CONRAILVYE2.app

From VY to
LogMod Sea

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\CONSEAVYE2.app

From VY to
LogMod Air

{CATALOG_DIR}\02_Applications\2_Run\Costs_V
Y\CONAIRVYE2.app

Logistics
Module (5)

{CATALOG_DIR}\0o2_Applications\2_Run\Logistic
ModVY\LOGMOD.app

Prepare data

{CATALOG_DIR}\02_Applications\2_Run\Logistic
ModVY\PREPARE.app
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Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Prepare Data {CATALOG_DIR}\02_Applications\2_Run\Logistic
second part ModVY\PREPARE_01.app
Prepare Data {CATALOG_DIR}\02_Applications\2_Run\Logistic
third part ModVY\PREPARE_o02_rev.app
Run the
logistic {CATALOG_DIR}\02_Applications\2_Run\Logistic
model ModVY\RUNTMODEL.app
{CATALOG_DIR}\02_Applications\2_Run\Logistic
Save Reports ModVY\SAVEREPORTS.app
Assignment {CATALOG_DIR}\0o2_Applications\2_Run\ASS_VY\
(6) ASS_VY.app
Conversion
from
LogMod to {CATALOG_DIR}\02_Applications\2_Run\ASS_VY
VY \CONVERSION OF EMME MATRICES.app
Road {CATALOG_DIR}\0o2_Applications\2_Run\ASS_VY
Assignment \ASS_ROAD_VY.app
Rail {CATALOG_DIR}\02_Applications\2_Run\ASS_VY
Assignment \ASS_RAIL_VY.app
Sea {CATALOG_DIR}\02_Applications\2_Run\ASS_VY
Assignment \ASS_SEA_VY.app
Air {CATALOG_DIR}\02_Applications\2_Run\ASS_VY
Assignment \ASS_AIR_VY.app
{CATALOG_DIR}\02_Applications\2_Run\Results\
Results (7) RESULTS.app
{CATALOG_DIR}\02_Applications\2_Run\Results\
Results 1.0 RESULTS_NEW.app
{CATALOG_DIR}\02_Applications\2_Run\Results\
Port Areas PORTARoO1.app
GIS maps by
Commodity {CATALOG_DIR}\0o2_Applications\2_Run\Results\
groups Bidireo2.app
Samgods
Oresund Kiel {CATALOG_DIR}\02_Applications\2_Run\Results\
and Jylland ORESUNo1.app
Reports per
geographical {CATALOG_DIR}\0o2_Applications\2_Run\Results\
aggregation REPORToO1.app
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Applicat
ion

name

Subgroup

level 1

Subgroup

level 2

Subgroup
level 3

Subgroup
level 4

File name

Rail Capacity
Management

®

{CATALOG_DIR}\02_Applications\9_RCM1\RAILC
Ao1.app

Data
Preparation
LP

{CATALOG_DIR}\02_Applications\9_RCM1\Datapr
ep_LP\DATAPRo1.app

Warm start

{CATALOG_DIR}\02_Applications\9_RCM1\WARM
STo1.app

LP Loop

{CATALOG_DIR}\0o2_Applications\9_RCM1\LP\LP
LOOPo1.app

LPo step

{CATALOG_DIR}\0o2_Applications\9_RCM1\LP\LP
0\LPOSTEP.app

LP1+ step

{CATALOG_DIR}\0o2_Applications\9_RCM1\LP\LP1
\LP1STo1.app

Run
BuildChainR
CM and
ChainChoiR
CM

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP1
\RUNBUILDCHAINRCM.app

Run MPS LP

Extract

{CATALOG_DIR}\o2_Applications\9_ RCM1\LP\LP1
\RUNMPS_LP_EXTRACT.app

Check

convergence

{CATALOG_DIR}\02_Applications\9_RCM1\LP\LP1
\CHECKCo1.app

Run Final

Process

{CATALOG_DIR}\02_Applications\9_RCM1\Final\
RUNFINo1.app

Prepare

control files

{CATALOG_DIR}\o2_Applications\g9_RCM1\Final\P
REPARE_o02.app

Run the final

process

{CATALOG_DIR}\o2_Applications\9_RCM1\Final\
RUNTMODEL.app

Save Reports

{CATALOG_DIR}\02_Applications\9_RCM1\Final\S
AVEREPORTS.app

RCM
Assignment

(9)

{CATALOG_DIR}\02_Applications\9_RCM1\ASS_V
Y\ASS_VY.app

Conversion
from
LogMod to
VY

{CATALOG_DIR}\02_Applications\\9_RCM1\ASS_
VY\\CONVERSION OF EMME MATRICES.app




The application structure

Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Road
Assignment {CATALOG_DIR}\02_Applications\\9_RCM1\ASS_
RCM VY\\ASS_ROAD_VY.app
Rail
Assignment {CATALOG_DIR}\02_Applications\\9_ RCM1\ASS_
RCM VY\\ASS_RAIL_VY.app
Sea
Assignment {CATALOG_DIR}\02_Applications\\9_ RCM1\ASS_
RCM VY\\ASS_SEA_VY.app
Air
Assignment {CATALOG_DIR}\o2_Applications\\9_ RCM1\ASS_
RCM VY\\ASS_AIR_VY.app
Results RCM {CATALOG_DIR}\02_Applications\9_RCM1\Results
(10) \RESULTS.app
{CATALOG_DIR}\02_Applications\9_RCM1\Results
Reports 1.0 \REPORTNEW.app
PORT {CATALOG_DIR}\02_Applications\9_RCM1\Results
AREAS \PORTARO1.app
GIS maps on
commodity {CATALOG_DIR}\02_Applications\9_RCM1\Results
Samgods o
groups \ Bidireo1.app
Oresund Kiel {CATALOG_DIR}\02_Applications\9_RCM1\Results
and Jylland \ORESUNo1.app
{CATALOG_DIR}\02_Applications\9_RCM1\Results
Rail Capacity \RAILCAoO1.app
Reports per
geographical {CATALOG_DIR}\02_Applications\9_RCM1\Results
aggregation \REPORToO1.app
Parameters
calculation {CATALOG_DIR}\02_Applications\2_Run\Calibr\P
(11) ARAMETERS.app
{CATALOG_DIR}\02_Applications\3_Compare\Com
pare.app
LOS Matrices {CATALOG_DIR}\0o2_Applications\3_Compare\LOS
(€] MAT.app
OD Matrices {CATALOG_DIR}\02_Applications\3_Compare\OD
(2) _matrices\ODMATRo1.app
Compare | Assignment {CATALOG_DIR}\0o2_Applications\3_Compare\ASS
Scenarios | (3) IGNMENT.app
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Applicat
ion

name

Subgroup

level 1

Subgroup

level 2

Subgroup
level 3

Subgroup
level 4

File name

Comparison

(4)

{CATALOG_DIR}\02_Applications\3_Compare\Com
parot.app

Handling

scenario

{CATALOG_DIR}\0o2_Applications\4_Handling\Han
dling.app

Delete (1)

{CATALOG_DIR}\0o2_Applications\4_Handling\DE
LETE.app

Compact (2)

{CATALOG_DIR}\0o2_Applications\4_Handling\CO
MPACT.app

Scenario

Export (3)

{CATALOG_DIR}\o2_Applications\4_Handling\SCE
NARIOEXPORT.app

Model
Export

{CATALOG_DIR}\02_Applications\4_Handling\MO
DELEXPORT.app

General

tables

{CATALOG_DIR}\02_Applications\4_Handling\GE
NERAL_TABLES.app

Create the

new base

{CATALOG_DIR}\o2_Applications\4_Handling\CR
EATE_NEW_BSE.app

Create the
new scenario
specific

tables

{CATALOG_DIR}\02_Applications\4_Handling\CR
EATE_SS_TABLE_T.app

Create the
scenario

tables

{CATALOG_DIR}\02_Applications\4_Handling\CR
EATE_SS_TABLE.app

Create the
scenario
specific

tables

{CATALOG_DIR}\o2_Applications\4_Handling\CR
EATE_SS_TABLE_2.app

Scenario

Import (4)

{CATALOG_DIR}\o2_Applications\4_Handling\SCE
NARIOIMPORT.app

PWC_Ma

trices

{CATALOG_DIR}\02_Applications\6_PWC_matrice
s\PWC_MAo1.app

Change
matrix

format

{CATALOG_DIR}\02_Applications\7_Matrix_form)\
Changeo1.app

Select
Link
Analysis

{CATALOG_DIR}\02_Applications\10_SelectLink\S
electLinko1.app

Data
prepare(1)

{CATALOG_DIR}\o2_Applications\10_SelectLink\D
ATAPRo1.app
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Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Selection for
loaded
unloaded
vehicles and {CATALOG_DIR}\02_Applications\10_SelectLink\S
tons(2) ELECTION_T_LV.app
Create
selection {CATALOG_DIR}\o2_Applications\10_SelectLink\C
files REATEFILES.app
Produce
matrices
with
volumes and {CATALOG_DIR}\02_Applications\10_SelectLink\P
tons RODUCEMAPS.app
Produce
maps with
volumes and {CATALOG_DIR}\o2_Applications\10_SelectLink\P
tons RODUCMAPS.app
Produce
maps by
Commodity {CATALOG_DIR}\02_Applications\10_SelectLink\S
group TAN.app
{CATALOG_DIR}\02_Applications\11_CBA\CBA_AS
o1.app
Data {CATALOG_DIR}\o2_Applications\11_CBA\DATAP
Preparation REPARATION_VY.APP
Tax {CATALOG_DIR}\o2_Applications\11_CBA\DATAP
calculation REPARATION_VY_01.APP
Data for {CATALOG_DIR}o02_Applications\11_CBA\DATAR
CBA CM.APP
CBA {CATALOG_DIR}o02_Applications\11_CBA\LP2CC\
Analysis(2) LP2CCCBA.APP
{CATALOG_DIR}\o2_Applications\11_CBA\LP2CC\
Prepare data PREPARE.app
Prepare Data {CATALOG_DIR}\o2_Applications\11_CBA\LP2CC\
second part PREPARE_o1.app
Cost
Benefit Prepare Data {CATALOG_DIR}\o2_Applications\11_CBA\LP2CC\
enefi
. third part PREPARE_o02.app
Analysis -
ASEK {CATALOG_DIR}\02_Applications\11_CBA\LOSCAL
Values Los call 01.APP
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Applicat
ion

name

Subgroup

level 1

Subgroup

level 2

Subgroup
level 3

Subgroup
level 4

File name

Run LP2CC

{CATALOG_DIR}\o2_Applications\11_CBA\LP2CC\
RUNTMODEL.app

Save Reports

{CATALOG_DIR}\0o2_Applications\11_CBA\LP2CC\
SAVEREPORTS.app

Main

Reports

{CATALOG_DIR}\0o2_Applications\11_CBA\LP2CC\
MAINREPORTSo1.app

Elasticity
Module

{CATALOG_DIR}\o2_Applications\12_Elasticity\Ela
sticity_Module_v2.app

Initialization

)

{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Run\1_Ini\INITIA0O.app

LOS
calculation

(4)

{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Run\2_Costs\COST_VY.app

Data

Preparation

{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Run\2_Costs\DATAPREPARATION_VY.app

Tax

calculation

{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Run\2_Costs\DATAPREPARATION_VY_EL.app

Data for
RCM

{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Run\2_Costs\DATARCM.APP

Road

{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Run\2_Costs\ROAD.app

Rail

{CATALOG_DIR}\0o2_Applications\12_Elasticity\1_
Run\2_Costs\RAIL.app

Sea

{CATALOG_DIR}\0o2_Applications\12_Elasticity\1_
Run\2_ Costs\SEA.app

Air

{CATALOG_DIR}\o2_Applications\12_ Elasticity\1_
Run\2_Costs\AIR.app

Conversion
from VY to
LogMod

{CATALOG_DIR}\0o2_Applications\12_Elasticity\1_
Run\2_Costs\CONVERALL.app

From VY to
LogMod
Road

{CATALOG_DIR}\02_Applications\12_Elasticity\1_
Run\2_Costs\CONCOSTVYE2.app

From VY to
LogMod Rail

{CATALOG_DIR}\02_Applications\12_Elasticity\1_
Run\2_Costs\CONRAILVYE2.app

From VY to
LogMod Sea

{CATALOG_DIR}\02_Applications\12_Elasticity\1_
Run\2_Costs\CONSEAVYE2.app

From VY to
LogMod Air

{CATALOG_DIR}\0o2_Applications\12_Elasticity\1_
Run\2_Costs\CONAIRVYE2.app
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Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Logistics {CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Module (5) Run\3_LogisticMod\LOGMOD.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Prepare data Run\3_LogisticMod\PREPARE.app
Prepare Data {CATALOG_DIR}\0o2_Applications\12_Elasticity\1_
second part Run\3_LogisticMod\PREPARE_o1.app
Prepare Data {CATALOG_DIR}\o2_Applications\12_Elasticity\1_
third part Run\3_LogisticMod\PREPARE_02_rev.app
Run the
logistic {CATALOG_DIR}\o2_Applications\12_Elasticity\1_
model Run\3_LogisticMod\RUNTMODEL.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\1_
Save Reports Run\3_LogisticMod\SAVEREPORTS.app
Rail Capacity
Management {CATALOG_DIR}\o2_Applications\12_Elasticity\2__
6) RCM\RAILCAPACITYMANAGEMENT.app
Data
Preparation {CATALOG_DIR}\o2_Applications\12_Elasticity\2__
LP RCM\1_Dataprep_LP\DATAPRoO1.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\2__
LP Loop RCM\2_LP_steps\LPLOOPo1.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\2_
LPo step RCM\2_LP_steps\LPOSTEP.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\2_
LP1+ step RCM\2_LP_steps\LP1STo1.app
Run
BuildChainR
CM and
ChainChoiR | {CATALOG_DIR}\o2_Applications\12_Elasticity\2_
CM RCM\2_LP_steps\RUNBUILDCHAINRCM.app
Run MPS LP | {CATALOG_DIR}\o2_Applications\12_Elasticity\2_
Extract RCM\2_LP_steps\RUNMPS_LP_EXTRACT.app
Check {CATALOG_DIR}\o2_Applications\12_Elasticity\2_
convergence | RCM\2_LP_steps\CHECKCo1.app
Elasticity {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
Report (7) Elasticities\ELASTIo1.app
Assignment {CATALOG_DIR}\02_Applications\12_Elasticity\3_
8)* Elasticities\1_Run\4_AssSTD\ASS_VY.app
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Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Conversion
from {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
LogMod to Elasticities\1_Run\4_AssSTD\CONVERSION OF
VY EMME MATRICES.app
Road {CATALOG_DIR}\02_Applications\12_Elasticity\3_
Assignment Elasticities\1_Run\4_AssSTD\ASS_ROAD_VY.app
Rail {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
Assignment Elasticities\1_Run\4_AssSTD\ASS_Rail_VY.app
Sea {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
Assignment Elasticities\1_Run\4_AssSTD\ASS_SEA_VY.app
Air {CATALOG_DIR}\02_Applications\12_Elasticity\3_
Assignment Elasticities\1_Run\4_AssSTD\ASS_AIR_VY.app
{CATALOG_DIR}\02_Applications\12_Elasticity\3_
Results (9)* Elasticities\1_Run\5_ResultsSTD\Results.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\3_
Results 1.0 Elasticities\1_Run\5_ResultsSTD\REPORT_New.app
{CATALOG_DIR}\o2_Applications\12_Elasticity\3_
Port Areas Elasticities\1_Run\5_ResultsSTD\PORTARO1.app
Oresund Kiel {CATALOG_DIR}\02_Applications\12_Elasticity\3_
and Jylland Elasticities\1_Run\5_ResultsSTD\ORESUNo1.app
Reports per
geographical {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
aggregation Elasticities\1_Run\5_ResultsSTD\REPORToO1.app
RCM
Assignment {CATALOG_DIR}\0o2_Applications\12_Elasticity\3_
(10)* Elasticities\2_ RCM\4_AssRCM\ASS_VY.app
Conversion
from {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
LogMod to Elasticities\2_ RCM\4_AssRCM\CONVERSION OF
VY EMME MATRICES.app
Road
Assignment {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
RCM Elasticities\2_ RCM\4_AssRCM\ASS_ROAD_VY.app
Rail
Assignment {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
RCM Elasticities\2_ RCM\4_AssRCM\ASS_RAIL_VY.app
Sea
Assignment {CATALOG_DIR}\o2_Applications\12_Elasticity\3_
RCM Elasticities\2_ RCM\4_AssRCM\ASS_SEA_VY.app
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Applicat
ion Subgroup Subgroup Subgroup Subgroup
name level 1 level 2 level 3 level 4 File name
Air
Assi t
ssigamen {CATALOG_DIR}o2_Applications\12_Elasticity\3_
RCM Elasticities\2_ RCM\4_AssRCM\ASS_AIR_VY.app
Results RCM CATALOG_DIR}\02_Applications\12_Elasticity\2_R
(1)* CM\5_ResultsRCM\RESULTS.app
{CATALOG_DIR}\02_Applications\12_Elasticity\2_
Results 1.0 RCM\5_ResultsRCM\REPORTNEW.app
{CATALOG_DIR}\02_Applications\12_Elasticity\2_
Port Areas RCM\5_ResultsRCM\PORTARO1.app
Oresund Kiel {CATALOG_DIR}\o2_Applications\12_Elasticity\2__
and Jylland RCM\5_ResultsRCM\ORESUNo1
{CATALOG_DIR}\o2_Applications\12_Elasticity\2__
Rail Capacity RCM\5_ResultsRCM\RAILCAoO1.app
Reports per
geographical {CATALOG_DIR}\02_Applications\12_Elasticity\2_
aggregation RCM\5_ResultsRCM\REPORTO1
GIS maps
by
Commodity {CATALOG_DIR}\02_Applications\12_Elasticity\2_
groups RCM\5_ResultsRCM\BIDIREO1.app

*Inactive in the elasticity model — kept for future development

5 The application structure

5.1. “Installation” application

Input data:

¢ None

Output data:

e Create the “Model_description” table in the Input_data.mdb and empty.mdb (under
{CATALOG_DIR}\02_Applications\Edits) files. The first one is the general geodatabase, the second

one is the template used for all the output geodatabases.

Purposes:

e Change the map for the files used in the model structure.

e Store the general definitions of the model for long-term storage purposes.

5.2. “Create the editable files” application

Input data:

e Scenario specific tables in the main geodatabase and base tables.
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Output data:

e Scenario specific tables in the main geodabase and scenario data in the temporary geodatabase under
scenario folder with name Scenario_data.mdb. Txt files under the work folder
{CATALOG_DIR}\02_Applications\1_Editing to manage different checks and time data.

Purpose:
e Join the scenario tables and the base tables to create the editable data for the current scenario.

Application Description Programs
verify if scenario already exists under main database (Input_data.mdb) through a
set of batch files
- create the check.txt file (check if general parameters table already exist in the main
geodatabase)
- create the date_time1.txt (last modification of Scenario_data.mdb)
- create the date_time.txt (current time)
- create the report1.txt (verify if the temporary geodatabase already exists)
First case: The scenario does not exist
- jump step 4 because the temporary geodatabase does not exist tto7
- copy all the scenario specific table from the scenario selected by Scenario_copy catalog key
Second case: The scenario already exists but without temporary geodatabase
- jump step 4 because the temporary geodatabase does not exist
Third case: The scenario already exists and exist the temporary geodatabase
First sub case: the scenario is lock - no actions are required. Process goes to end

Prepare Second sub case: the scenario is still editable - go to next step and check if any edit was made

temporary data before this run in the temporary geodatabase. If yes goes to next step. If no goes to end.
Copy the scenario specific table in the temporary geodatabase Scenario_data.mdb | -
General_{SCENARIO_SHORTNAME} 8
Logmod__ {SCENARIO_SHORTNAME} 9
SC_{SCENARIO_SHORTNAME}_Cargo 10
SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters Part A 11
SC_{SCENARIO_SHORTNAME} Vehicles_Parameters Part B 12
SC_{SCENARIO_SHORTNAME}_Link 13
SC_{SCENARIO_SHORTNAME}_Node 13
SC_{SCENARIO_SHORTNAME}_Node_Terminals (Port_swe) 14
SC_{SCENARIO_SHORTNAME}_ Nodes 15
SC_{SCENARIO_SHORTNAME}_ Nodes_commodities 16
SC_{SCENARIO_SHORTNAME}_Frequency_data_link 17
SC_{SCENARIO_SHORTNAME}_Frequency_data_node 18
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Application Description Programs
SC_{SCENARIO_SHORTNAME}_Tax_Country 19
SC_{SCENARIO_SHORTNAME}_ Tax_Category 20
SC_{SCENARIO_SHORTNAME}_Tax_Link 21
SC_{SCENARIO_SHORTNAME}_Toll_Link 22
SC_{SCENARIO_SHORTNAME}_PropLink 23
SC_{SCENARIO_SHORTNAME}_Rail_Capacity 24
Merge the scenario tables with the base tables in the temporary geodatabase -
SC_{SCENARIO_SHORTNAME}_Cargo plus Cargo_Base2017 1
SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA plus

2
Vehicles_parameters_Base2017_PartA
SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB plus
. 3

Editable tables | Vehicles_parameters_Base2017_PartB

(2)

SC_{SCENARIO_SHORTNAME}_Tax_Country plus Tax_Country_Base2017 4

SC_{SCENARIO_SHORTNAME}_Tax_Category plus Tax_Category_Base2017 5

SC_{SCENARIO_SHORTNAME}_Tax_Link plus Tax_Link_Base2017 6

SC_{SCENARIO_SHORTNAME}_Toll_Link plus Toll_Link_Base2017 7

SC_{SCENARIO_SHORTNAME}_Rail_Capacity plus Rail_Capacity_Base2017 8

Merge the scenario tables with the base tables in the temporary geodatabase

creating networks and feature classes to use in GIS window

Sc_{SCENARIO_SHORTNAME}_Link and Sc_{SCENARIO_SHORTNAME}_Node plus

Base2017_Link and Base2017_Node

prepare the data to add general information from lookup tables (modes table) and create Cube

1to

network 4
. save in EMME format the Cube network created in the previous steps 5

Editable map

data (3) SC_ {SCENARIO_SHORTNAME}_node_Terminals plus Node_terminals_Base2017 6to7
Sc_{SCENARIO_SHORTNAME}_Nodes plus Nodes_Base2017 8to9
Sc_{SCENARIO_SHORTNAME}_Nodes_commodities_ Base2017 10to 11
Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Link and
Sc_{SCENARIO_SHORTNAME}_Frequency_Data_Node plus Base:2017_Frequency_Data 12t013
Network
Copy Samgods_zones feature class in temporary geodatabase and end the process 14

5.3. “Edit the data” application

Input data:

e Scenario tables in the temporary geodatabase Scenario_Data.mdb under scenario folder.

Output data:
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e Scenario specific tables in the main geodabase. Txt files under the work folder
{CATALOG_DIR}\02_Applications\1_Editing to manage time data.

Purpose:

e Compare the editable tables, networks and feature classes in the temporary geodatabase with the
base data in the main geodatabase Input_data.mdb; after comparison save the updated scenario
tables, General _{SCENARIO_SHORTNAME} and Logmod_{SCENARIO_SHORTNAME} tables.

Application

Description

Program
S

Subprogra
ms

Create the
tables
specific of
scenario

)

Check if “Create the editable files” was run

1

Check if the scenario is in read or write/read mode

2

Delete the previous report file REPORT_ED_BS06.txt

if read mode, any change in scenario specific table is NOT copied
back in the main database. All next steps will be skipped.

if read/write mode then all next steps will be run

Create SC_{SCENARIO_SHORTNAME}_Cargo in temporary
geodatabase

Create
SC_{SCENARIO_SHORTNAME}_Vehicles_parameters_PartA
in temporary geodatabase

Create
SC_{SCENARIO_SHORTNAME}_Vehicles_parameters_PartB
in temporary geodatabase

Check if edits come from the Voyager or the Emme network

Numberin

g system

In case of edits from Voyager, check all the codes to
create the correct original number for the nodes:

Check the number of zones, ID_REGION, ID_COUNTRY and
MODE_N codes

Based on the previous codes defined set the SCBSTANN code

Code the NORIG value for the zones

Code the NORIG value for the nodes

Delete the information related to modes joined in the "Create
editable files"

Merge all the new ORIG codes created

Skim network for subsequent steps

Dump the base scenario network

Dump the current scenario network

Convert network from EMME to Voyager format

Compare node and link tables of the base scenario with the

current scenario

1,2

4,5,6

7,8

9,10

11

12

13,16

14

15

17
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Program | Subprogra
Application Description 8t prog
S ms
Check if edits come from the Voyager or the Emme network 10
In case of edits from EMME, check all the codes to create
the correct original number for the nodes:
Check if EMME network is defined in 211 format; in other words
1
if catalog key has proper value
Create link and node tables from EMME network 2
Check the number of zones, ID_REGION, ID_COUNTRY and
MODE_N codes 3
Based on the previous codes defined set the SCBSTANN code 4
Check the number of zones 5,6,7,8
Emme Node table union 1 9
Edits
Recode the link table 10
Recode the extra attribute 11
Merge link and node data in the current scenario network 12
Dump the current scenario network 13
Dump the base scenario network in dbf format for subsequent )
steps 4
Compare node and link tables of base scenario with current )
scenario >
Recodes modes on EMME rules 17,18,19
Coming from edits from Voyager or edits from EMME, the )
2
process continues from this point
Compare current scenario with base scenario and
scenario specific tables for nodes and node terminals
Dump Base scenario Node terminals 1
Dump current scenario Node terminals 2
Compare | Compare node terminals tables of current scenario with base
Nodes and | scenario ’
13
Node_ter .
. Create SC_{SCENARIO_SHORTNAME} Node_Terminals 4
minals
Dump Base scenario Nodes 5
Dump current scenario Nodes 6
Compare nodes tables of current scenario with base scenario 7
Create SC_{SCENARIO_SHORTNAME}_Nodes 8
Compare current scenario with base scenario and create the
. . . 14
following scenario specific tables:
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Program | Subprogra
Application Description 8t prog
s ms
SC_{SCENARIO_SHORTNAME} Nodes_Commodities 1
SC_{SCENARIO_SHORTNAME}_Tax_Country 2
Compare
other SC_{SCENARIO_SHORTNAME}_ Tax_Category 3
tabl
aples SC_{SCENARIO_SHORTNAME}_Tax_Link 4
SC_{SCENARIO_SHORTNAME}_Toll_Link 5
Check rail management data and create a scenario
specific table for rail capacity
Check consistency with network and ID_LINK numbers 1,2,3
1
Dump Rail capacity table for base scenario > 4
Rail Dump Rail capacity table for current scenario 5
Capacity
Checks Create SC_{SCENARIO_SHORTNAME}_Rail_Capacity 6
Create node list from network link table step 1 7
Create node list from network link table step 2 8
Compare node list from node and link tables to identify UNUSED
nodes 0
Verify the maximum zone number among different tables 16 to 21
If the network does not have any new zones, create the
Sc_{SCENARIO_SHORTNAME} Frequency_Data_Link and 22 t0 26
0
SC_{SCENARIO_SHORTNAME}_Freqeuncy_Data_Node tables
in the temporary geodatabase
If new terminals are added to the network it will create a
list of frequency values based on the default frequency
table
Create the LOS matrices to understand the connections between )
,2
terminals
Frequency | get the default values for the frequency matrices based on the 27
matrices | A default_frequency table 3
Filter the default values only for the new zones 4,5,6
Convert the frequency matrices to network format and merge
with the scenario frequency network to preserve previous edits 7
Dump the network 8
Create the
Sc_{SCENARIO_SHORTNAME}_ Frequency_Data_Link and 8
2
SC_{SCENARIO_SHORTNAME}_Freqeuncy_Data_Node tables
in the temporary geodatabase
Jump specific steps (if not need to updated frequencies) 29
Delete check.txt 1 1
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Program | Subprogra

Application Description
s ms
Check the record number in SC_Links 2,3
Dump network 4
Classify cases 5
If you need the geoprocessing tool to classify links 6
Regions Create temporary network considering classified cases 7
for links
r Call python for link classification 8
Check if you need weight calculation 9,10
Weight calculation 11,12
Merge all tables and create
. 13,14,15,16
SC_{SCENARIO_SHORTNAME}_PropLink
Save the scenario specific tables from the temporary
geodatabase to the main geodatabase:
SC_{SCENARIO_SHORTNAME}_Cargo 2

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartA |3

SC_{SCENARIO_SHORTNAME}_Vehicles_Parameters_PartB |4

Save Copy SC_{SCENARIO_SHORTNAME}_Link and

changes in SC_{SCENARIO_SHORTNAME}_Node tables via python script >

the main -

adb (2) SC_{SCENARIO_SHORTNAME} Node_ Terminals (Port_Swe) |6
SC_{SCENARIO_SHORTNAME}_nodes 7
SC_{SCENARIO_SHORTNAME} nodes_commodities 8
SC_{SCENARIO_SHORTNAME}_Frequency Data_Link 9
SC_{SCENARIO_SHORTNAME}_Frequency Data_Node 10
SC_{SCENARIO_SHORTNAME}_ Tax_Country 11
SC_{SCENARIO_SHORTNAME}_Tax_Category 12
SC_{SCENARIO_SHORTNAME}_ Tax_Link 13
SC_{SCENARIO_SHORTNAME}_Toll_Link 14
SC_{SCENARIO_SHORTNAME}_PropLink 15
SC_{SCENARIO_SHORTNAME} Rail_Capacity 16
Delete temporary txt file containing time and date stamps 17
Update information of time and date on temporary txt 18

Update the state of the scenario (write to only read) and

19
ZONES_M

Update the General_Base table:
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Program | Subprogra
Application Description 8t prog
s ms
Save new value in the temporary geodatabase 0
Scenario_Data.mdb
Save new value in the main geodatabase Input_Data.mdb 21
Update the LogMod_ Base table:
Save new value in the temporary geodatabase
Scenario_Data.mdb and in the main geodatabase 22,23
Input_Data.mdb
Delete all the temporary files created along the run 24
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5.4. "Samgods” application

Input data:

e Scenario tables and base tables in main geodatabase Input_data.mdb.

Output data:

e Refer to Output section 3.4.

Purpose:

e Provide all the input data required by the Logistics and the Rail Capacity Management Modules and
derive a set of standard outputs alongside the results under Logmod folder produced by the external
programs.

The description has two tables, the first one related to the Standard Logistics Module in Table 134, the
second one to the Rail Capacity Management Module in Table 135.

Table 134 - Samgods application: first part Standard Logistics Module.

Progra | Subprogra
Application Description ms ms
Check free space available on computer and pull out
freespace.txt file and exogenous consolidation rates |1
Read freespace.txt and process the number to a
token variable 2,3
Based on values in token variable, give a warning to
user. If there is enough space no warning is raised. | 4
Set initial value for Kiel Canal and provide the file to
Initialization (1) . 5
cycling process
Loop (2) Copy the input parameters for the current loop 2
Control the resume option of cycling process and
Pilot (3) warm start procedure within a fixed loop 3
Create if outputX.mdb exists, if not it is created. 1 1
Load the parameters from
general_{SCENARIO_SHORTNAME} table into the
system variables 1 2
Verify if few outputs already exist and if they have
the same input data 1 3
Check if the scenario is locked or still editable 1 4
Create the Vehicle_parameter_PartA table for the
scenario 1 5
Create the Cargo table for the scenario 1 6
LOS Data
. . Create the network for the scenario 1 7
calculati | Preparatio
on (4) n (1) Dump in dbf format the link and node tables 1 8
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Progra | Subprogra
Application Description ms ms

Set the node class (see table A_nodeclass) value for
all the nodes 1 9 1
Classify the links based on the class node and the
ID_COUNTRY in the A_Categories code - identify
the country id for each link 1 9 2
Convert all the scenario tables for taxes and tolls to 3to
a link format 1 9 12
Create the network with all the extra attributes with
undefined values 1 9 13
Recode the mode for each vehicle type 1 9 15
Update with scenario values all the extra attributes | 1 9 14
Add the fields for MODE 1 9 16
Create the equations to save the final value for tax
and extracost 1 9 17
Save the final values (TAX_TOT,EXCTTOT and

Tax calculation TOLL) for each link and by vehicle type 1 9 18
Create the intrazonal matrix in dbf format 1 10-11
Change the format of intrazonal matrix from dbf to
MAT 1 12
Save the node_labels table in Outputo.mdb 1 13
Create the port area table for the scenario 1 14
Control the execution order and skip some steps not
required in cycling process 1 15
Create the Capacity_table for current scenario 1 16
Merge the network from step 9 and the Capacity
table to use in next assignments 1 17
Export final network with time and cost per link for
usage in ASEK calculation or external checks 1 18 1
Create
{SCENARIO_DIR}\LogMod\RCM\Nodes_ List.txt |1 18 2
Create
{SCENARIO_DIR}\LogMod\RCM\Links_ List.txt 1 18 3
Read Capacity_table_{SCENARIO_CODE}.DBF

Data for RCM and prepare data for next step 1 18 4,5
Control the execution order on cycling process and
options to run step by step the model 1 19
Select which mode run based on

PILOT 2 Select_cal_cos_mode catalog key 2




The application structure

Progra | Subprogra

Application Description ms ms
Execution order, start the road mode 3 1
Delete
{SCENARIO_DIR}\LogMod\RCM\PathTreeRoad.t
xt if exist 3 2
Loop between vehicle types (from 101 to 106) 3 3

Set the values for VOT and KMCOST reading the

Vehicle_parameters table 3 4

Calculate the Km_TAX, TOLL, DIST_COST, VOT

variables and MAX_SPEED 3 5
Define the speed values and free flow times 3 6
Skim the los matrices 3 7
Merge the 5 LOS matrices in one file 3 8

9 to
Updated the outputs table with new output 3 10

Skip all the other steps if Select_cal_cos_mode has

Road (3) "Road" value 3 11
Execution order, start the rail mode 4 1
Delete
{SCENARIO_DIR}\LogMod\RCM\PathTreeRail.txt
if exist 4 2
Loop between vehicle types (from 201 to 212) 4 3

Set the values for VOT and KMCOST reading the
Vehicle_parameters table for the first mode 4 4

Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 4 5

Skim the los matrices 4 6

For all the vehicle types except 202 there is a unique
mode, so jump the subsequent steps. For 202 go to

next step 4 7

Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 4 8

Skim the los matrices 4 9

Label to skip the steps 7 and 8 if vehicle type

different from 202 4 10
Merge the 9 LOS matrices in one file 4 11
Rail (4) Updated the outputs table with new output 4 12,13
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Progra | Subprogra
Application Description ms ms
Skip all the other steps if Select_cal_cos_mode has
"Rail" value 4 14
Execution order, start the sea mode 5 1
Delete
{SCENARIO_DIR}\LogMod\RCM\PathTreeSea.txt
if exist 5 2
Read Port Area table and set up transoceanic factors
in MAT format 5 3
Loop between vehicle types (from 301 to 322) 5 4
Set the values for VOT and KMCOST reading the
Vehicle_parameters table for the first mode 5 5
Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 5 6
Skim the los matrices 5 7
8to
Merge the 21 LOS matrices in one file 5 10
11to
Updated the outputs table with new output 5 12
Skip all the other steps if Select_cal_cos_mode has
Sea (5) "Sea" value 5 13
Execution order, start the air mode 6 1
Delete
{SCENARIO_DIR}\LogMod\RCM\PathTreeAir.txt
if exist 6 2
Set the value of vehicle type 6 3
Set the values for VOT and KMCOST reading the
Vehicle_parameters table for the first mode 6 4
Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 6 5
Skim the los matrices 6 6
Updated the outputs table with new output 6 7t0 8
Skip all the other steps if Select_cal_cos_mode has
Air (6) "Air" value 6 9
Select which mode run based on
Select_cal_cos_mode catalog key 7 1
Conversio Mode Road 7 2 1
n from VY
¢ From VY to LogMod Road Loop between vehicle types (from 1 to 5) 7 2 2
0




The application structure

Progra | Subprogra
Application Description ms ms
LogMod Read the vehicle type number to rename properly
@) the output files 7 > 3

Crate the dbf tables from the matrix file adding the
NORIG code 7 2 4
Sort the records and create the
Viox_dist.314,Viox_timeh.314, Vioxxkr.314 and
Viox_ddist.314 under LogMod\Input\LOS folder 7 2 5
Skip all the other steps if Select_cal_cos_mode has
"Road" value 7 2 6
Mode Rail 7 3 1
Loop between vehicle types (from 6 to 13) 7 3 2
Read the vehicle type number to rename properly
the output files 7 3 3
Crate the dbf tables from the matrix file adding the
NORIG code 7 3 4
Sort the records and create the
Vaox_dist.314,V20x_timeh.314, V2ox_xkr.314 and
V2ox_ddist.314 under LogMod\Input\LOS folder 7 3 5
Skip all the other steps if Select_cal_cos_mode has

From VY to LogMod Rail "Rail" value 7 3 6
Mode Sea 7 4 1
Loop between vehicle types (from 14 to 34) 7 4 2
Read the vehicle type number to rename properly
the output files 7 4 3
Crate the dbf tables from the matrix file adding the
NORIG code 7 4 4
Sort the records and create the
V3ox_dist.314,V30x_timeh.314, V30x_xkr.314 and
V3ox_ddist.314 under LogMod\Input\LOS folder 7 4 5
Skip all the other steps if Select_cal_cos_mode has

From VY to LogMod Sea "Sea" value 7 4 6
Mode air 7 5 1
Crate the dbf tables from the matrix file adding the
NORIG code 2
Sort the records and create the
V401_dist.314,V401_timeh.314, V401_xkr.314 and

From VY to LogMod Air V401_ddist.314 under LogMod\Input\LOS folder 7 5 3
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Progra | Subprogra

Application Description ms ms

Skip all the other steps if Select_cal_cos_mode has
"Air" value 7 5 4

Label to skip properly the unselected modes and
PILOT 8 select if run the logistic model, selection based on

Step_by_ Step catalog key 8

Write in txt format the Cargo_ Base2017 table under

LogMod\Input\Cost with name Cargo.txt 1 1

Merge the scenario specific table and the base table

for Node_ terminals_Base2017 1 2

Write in txt format the

Node_terminals_ {SCENARIO_SHORTNAME}
table under LogMod\Input\Cost with name
Pilotfees.txt 1 3

Merge Vehicle parameters table A and B and apply

scaling parameters 1 4,5,6

Write in txt format the Vehicle_parameters table
under LogMod\Input\Cost with name
VHCLS_COMo01.TXT, VHCLS_COMo02.TXT,
VHCLS_COMo03.TXT, VHCLS_COMo04.TXT,
VHCLS_COMo05.TXT, VHCLS_COMo06.TXT,
VHCLS_COMo7.TXT, VHCLS_COMO08.TXT,
VHCLS_COMo09.TXT ,VHCLS_COM10.TXT,

Logistic
Modul Prepare VHCLS_COM11.TXT, VHCLS_COM12.TXT,
odule
®) data (1) VHCLS_COM13.TXT, VHCLS_COM14.TXT,
01 (5
VHCLS_COM15.TXT and VHCLS_COM16.TXT 1 7,8

Write in txt format the Vehicle_parameters table
under LogMod\Input\General with name

averagevehiclecapacity.txt 1 9

Convert LDB_ ratio from the geodatabase table onto

dat file 1 10

Convert MaxCap and consol exception from the

geodatabase table onto dat file 1 11

Move in dbf format for the scenario specific tables
SC_{SCENARIO_SHORTNAME}_Frequency_data
_Link and
SC_{SCENARIO_SHORTNAME}_Frequency_Data

_node 1 12

Merge the dbf table with the base frequency

network 1 13

Change the format from network to matrix 1 14




The application structure

Progra | Subprogra
Application Description ms ms
Write in txt format under LOGMOD\INPUT\LOS)\
the 10 files for frequency (.314) 1 15
Write in txt format under LOGMOD\INPUT\LOS\
the FREQIWW.314 file 1 16
Merge the scenario specific table and the base table
for Nodes_{SCENARIO_SHORTNAME} 2 1
Add parameters for varner Kanal 2 2
Write in txt format the
Nodes_ {SCENARIO_SHORTNAME}table under
LogMod\Input\Nodes with name Nodes.txt 2 3
Prepare
data Merge the scenario specific table and the base table
second for
part (2) Nodes_commodities_ {SCENARIO_SHORTNAME} | 2 4
Write in txt format the
Nodes_ Commodities_ {SCENARIO_SHORTNAME}
table under LogMod\Input\Nodes into 17 txt files 2 5t06
Create
{SCENARIO_DIR}\LogMod\Extract\emptyfrac.dat
for EXTRACT procedure 2 7
Prepare consolidation factors by commodity group
for subsequent steps 3 1
Change the format for BuildChain_ MODES table
for subsequent steps 3 2
Prepare BuildChain_Common.ctl and
BuildChain_ Special.ctl 3 3
Prepare ChainChain_Common.ctl,
ChainChoi_ Special.ctl and
\INPUT\GENERAL\OtherCostMatters.ctl files 3 4
Prepare Manage the execution order of building
data third exogenous_ consolidation_rate_dir.ctl. If no
part (3) external files are provided, the process skips the
creation of the control file. 3 5
Create the exogenous_consolidation_rate_ dir.ctl
file under ChainChoi folder with information of the
location of the external consolidation rates. 3 6
Manage the execution order of building
exogenous_consolidation_rate_dir.ctl. If no
external files are provided, the process skips the
creation of the control file. 3 7
Built CTL files for BuildChain 3 8
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Progra | Subprogra
Application Description ms ms
Identify starting and ending part for each
commodity group 3 9
Build CTL files for ChainChoi 3 10
Identify starting and ending part for each
commodity group 3 11
Loop from commodity 1 to commodity 16 to create
the control files for BuildChain.exe, ChainChoi.exe
and LP2CC.exe programs 3 12
Control if jump another commodities 3 13
Create control files for BuildChain under
LogMod\BUILDCHAIN 3 14
Create control files for ChainChoi under
LogMod\CHAINCHOI 3 15
Skip other commodities if not selected All (0) 3 16
Convert the Chain_list table in txt format under
LOGMOD\INPUT\CHAINTYPE.LIS 3 17
Create control files for Extract program under
LogMod\Extract 3 18
Create control files for Mergerep program under
LogMod\MERGEREP\ 3 19
Control execution order 3 20
Create RUNALL batch file based on catalog key
selection 4 1
Create COMMODITY.BAT to call buildchain,
chainchoi and ConsolidRateMode iteratively 4 2
Create batch files to call extract procedure 4 3
Create batch files to call runall.bat procedure and
parallel process 4 4
Call to normal process (no parallelization) and
parallelization process 4 5
Create Mergerepall.bat 4 6
Run mergerep process 4 7
Prepare CTL for compact spanning trees 4 8
Run the
L. Create Compact Batch file 4 9
logistic
model (4) Run Compact program 4 10
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Progra | Subprogra
Application Description ms ms
Save the report file from ChainChoi.exe (.rep) under
scenario folder 5 1
Change the format of report file into Voyager 5 2103
Merge domestic distances from LOS files for
subsequent step 5 4
Delete temporary files used to accumulate results 5to
from all commodities 5 11
Filter node table and produce table with only zones | 5 12
Loop over commodities (ID_LOOPC) 5 13
Control the commodities that must be used (if all or
single commodity) 5 14
Delete headers from
ChainChoi\OUTPUT\ChainChoiXXo1.out files 5 15
Calculate sum of variables for reports 5,6,7,8 5 16
Save
Merge ChainChoiXX.rep files (input for reports 10
Reports
and 11) 5 17
5)
Merge VhclRepXXrep files (input for reports 12) 5 18
Merge ChainChoiXX.rep files (input for report 6b) | 5 19
Merge ChainChoiXX.rep files (input for report 19) 5 20
Script to control the commodities that must be used
(works in pair with 14) 5 21
Calculate report 5 and 6 5 22
Calculate report 7 and 8 5 23
Calculate report 10 and 11 5 24
Calculate report 12 5 25
Calculate report 6b and 19 5 26
27to
Updated the outputs table with new output 5 28
Label to skip the report phase 5 29
Loop for all the commodities (from 1 to 35) 1 1
Load the vehicle number from Vehicle parameters
table 1 2
Conversio
Covert the 314 format in matrix format 1 3to5
n from
Assignm | LogMod 6 to
ent (6) to VY (1) Merge by mode the matrices 1 11
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Progra | Subprogra
Application Description ms ms
12 to
Updated the output tables with new output 1 13
Select the mode based on Select_cal_cos_mode
PILOT 2
catalog key 2
Execution order, start the road mode 3 1
Loop between vehicle types (from 1 to 6) 3 2
Set the values for VOT and KMCOST reading the
Vehicle_parameters table 3 3
Calculate the Km_TAX, TOLL, DIST_COST, VOT
variables and MAX SPEED 3 4
Define the speed values and free flow times 3 5
Assignment 3 6
Merge the 6 networks, one for each lorry type, into
one file 3 7
Updated the outputs table with new output 3 8toog
Road
Assignme Skip all the other steps if Select_cal_cos_mode has
nt (3) "Road" value 3 10
Execution order, start the rail mode 4 1
Loop between vehicle types (from 7 to 17) 4 2
Set the values for VOT and KMCOST reading the
Vehicle_parameters table for the first mode 4 3
Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 4 4
Assignment 4 5
For all the vehicle types except 202 there is a unique
mode, so jump the subsequent steps. For 202 go to
next step 4 6
Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 4 7
Assignment 4 8
Label to skip the steps 7 and 8 if vehicle type
different from 202 4 9
Merge the12, one for each train type (one is done for
vehicle 203, but that one is integrated with
. 202),networks into one file 4 10,11
Rail
Assignme 12 to
nt (4) Updated the outputs table with new output 4 13




The application structure

Progra | Subprogra
Application Description ms ms
Skip all the other steps if Select_cal_cos_mode has
"Rail" value 4 14
Execution order, start the sea mode 5 1
Loop between vehicle types (from 18 to 39) 5 2
Set the values for VOT and KMCOST reading the
Vehicle_parameters table for the first mode 5 3
Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 5 4
Assignment 5 5
Merge the 22, one for each sea vessel or ferry type,
networks in one file 5 6to8
9to
g Updated the outputs table with new output 5 10
ea
Assignme Skip all the other steps if Select_cal_cos_mode has
nt (5) "Sea" value 5 11
Execution order, start the air mode 6 1
Set the values for VOT and KMCOST reading the
Vehicle_parameters table for the first mode 6 2
Calculate the Km_TAX, TOLL, DIST_COST and
VOT variables 6 3
Assignment 6 4
Save the network in geodatabase format 6 5
Ab Updated the outputs table with new output 6 6toy
r
Assignme Skip all the other steps if Select_cal_cos_mode has
nt (6) "Air" value 6 8
PILOT 7 Set the execution order 7
Label to start the report phase and check in the
matrices and the networks exist under the scenario
folder 1
Merge all the assigned networks by mode into a
single, common network 2
Create the report for vehicle and vehicle km 3
Save the report in the geodatabase 4
Create network with bidirectional flow 5 1
Results
Produce report 3 5 2
Results | 1.0 (5)
() Port Areas (3) Read report 6b 5 3 1
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Progra | Subprogra
Application Description ms ms
Sum over port areas 5 3 2
Produce report 13 5 3 3
Create ArcGIS folder to export maps in ESRI format | 5 4 1
Prepare COMMODITY_STD.BAT 5 4 2
Prepare COMMODITY_STD.CTL 5 4 3
Run selectdirect to produce output by commodity
group
({SCENARIO_DIR}\LogMod\RCM\Output\COMM
ODITY_STD.dat) 5 4 4
5to
Prepare table for map 5 4 7
Export SHP file 5 4 8
GIS maps by Commodity Run python to import SHP file onto gdb and update
groups (4) mxd with scenario name 5 4 9
Merge final network with other statistics 5 5 1
Calculate total values 5 5 2
Oresund Kiel and Jylland (5) | Produce report 14 5 5 3
Merge Prop_link_Base2017 with scenario table 5 6 1
Dump link table for assigned network 5 6 2
Add CATEGORY ID_COUNTRY REGION
ID_COUNTY attributes based on values in
Prop_link 5 6 3
Produce report 9 5 6 4
Produce first part of report 17 5 6 5
Reports per geographical
aggregation (6) Produce first part of report 18 5 6 6
Produce report 16 totals 5 6 7
Produce report 17 totals 5 6 8
Produce report 18 totals 5 6 9
Produce report 16 adding county names 5 6 10
Produce report 17 adding county names 5 6 11
Produce report 18 adding county names 5 6 12
Updated the outputs table with new output 6to7
Update
REPORT_GS_{SCENARIO_SHORTNAME}.prn
file with the list of outputs created during the run 8




The application structure

Progra | Subprogra
Application Description ms ms
Delete all the temporary files 9

Update the logfile for entire run

10

Table 135 - Samgods application: second part Rail Capacity Management Module.
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The application structure

Pro
Application Description gra | Subprograms
ms
Data Set the number of rail links as temporary ) )
Preparati variable
onLP (1) Rename OD vehicles from _o to _STD 1 2
Read log_file.log and set up variables that will
2 1
be evaluated in next step
Warm
start (2) Set the execution order for LP Loop (3)
depending on which step has been performed | 2 2
in previous run (LPo, LP1 or LP2+)
Setup MPS.ctl control file 3 1|1
Prepare 1_ RUN_MPS_LPo_step1.BAT 3 1|2
Execute 1 RUN_MPS_LPo_step1.BAT 3 1|3
Check if run finished successfully, otherwise
3 1|4
prompt the user
Check number of links over capacity, if not 6
3 1 |5
present any link, skip RCM
Rail
Prepare 2_runLP.bat 3 1|7
Capacit
y LPo step (1) Execute 2_runLP.bat 3 1|8
Manag
ement Prepare 3_RUN_MPS_LPo_step2.BAT 3 1|9
®
Execute 3_ RUN_MPS_LPo_step2.BAT 3 1 |10
LP L . . . .
0P Check if run finished successfully, otherwise
3 3 1|1
prompt the user
Back up LPo results before moving to the next
o 3 |1 |2
iteration
Update log_file.log file 3 1 |13
Skip next steps (user choice) 3 1 |14
Label for LP1+ process 3 2 |1
Loop over maximum number of LP1 from
catalog key "Maximum number of loops for 3 2 |2
Linear Programming process (LP)"
LP1+ (2)
Set minimum loop number for a warm start 3 2 |3
Run Print out the RUNALL_RCM.BAT batch file
BuildC for running the column generation step for all | 3 2 |4 1
hainR the commodities
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Pro
Application Description gra | Subprograms
ms
CM Print out the batch file for calling the
and BuildChain and ChainChoi programs in 3 2 |4 2
Chain proper sequence
ChoiR K T
Select if run parallelization or normal
CM (4) 3 2 4 3
procedure
Label to jump to parallelization process 3 2 |4 4
Prepare control files for parallelization
3 2 (4 5
process
Run parallelization process 3 2 |4 6
Prepare 1_ RUN_MPS_LP1_step1.BAT 3 2 |5 1
Execute 1. RUN_MPS_LP1_step1.BAT 3 2 |5 2
Check if run finished successfully, otherwise
3 2 |5 3
prompt the user
Run
MPS Prepare 2_runi.bat 3 2|5 |a
LP
Extract Execute 2_runi.bat 3 2 |5 5
(5)
Prepare 3_RUN_MPS_LP1_step2.BAT 3 2 |5 6
Execute 3_ RUN_MPS_LP1_step2.BAT 3 2 |5 7
Check if run finished successfully, otherwise 8
3 2 |5
prompt the user
Setup RCM_last_loop 3 2 |6 1
Check Back up current loop 3 2 |6 2
conver
gence Update log_file.log 3 2 |6 3
(6)
Skip the process if the maximum number of
3 2|6 |4
loops has been reached
Label for final process 5 1|1
Prepare control files Build control file for extract procedure 5 1|2
Run final | ()
Check if no links are overcapacity. If so skip
process 5 1|3
final process
@
Print out the RUNALL_FIN.BAT batch file for
Run the final
calling the LP2CC program for all the 5 2 |1
process (2) .
commodities
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Pro
Application Description gra | Subprograms
ms
Print out the batch file COMMODITY.BAT for
call alternatively the BuildChain and 5 2 |2
ChainChoi programs
Create the batch file for the extract procedure | 5 2 |3
Set up files to describe the number of 5 2 |4
processors and batch file for calling
Samgods_ Parallelization_Module.jar
Run RUNALL.BAT and EXTRACTALL.BAT
using the Parallelization Module or standard | 5 2 |5
procedure
Create the batch file for merge.exe 5 2 |6
Call the external program "Merge reports" 5 2 |7
Save the report file from ChainChoi.exe (.rep) | 5 3 |1
Change the format of the report file in 2to
5 3
Voyager 3
Merge domestic distances from LOS files for
5 3 |4
subsequent step
Delete temporary files used to accumulate 5to
-, 5 3
results from all commodities 11
Print out the zone labels table 12
Loop over commodities (ID_LOOPC) 5 3 |13
Control the commodities that must be used (if
. . 5 3 |14
all or single commodity)
Delete headers from
Save Reports (3) ChainChoi\OUTPUT\ChainChoiXXot.out |5 |3 |15
files
Calculate sum of variables for reports 5,6,7,8 | 5 3 |16
Merge ChainChoiXX.rep files (input for
5 3 |17
reports 10 and 11)
Merge VhelRepXXrep files (input for reports 3
1
12) 5 3
Merge ChainChoiXX.rep files (input for
5 3 |19
report 6b)
Merge ChainChoiXX.rep files (input for
5 3 |20
reports 19)
Control the commodities that must be used
5 3 |21
(works in pair with step 14)
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Pro
Application Description gra | Subprograms
ms
Calculate report 5 and 6 5 3 |22
Calculate report 7 and 8 5 3 |23
Calculate report 10 and 11 5 3 |24
Calculate report 12 5 3 |25
Calculate report 6b and 19 5 3 |26
27
Updated output tables with new output 5 3 |to
28
Rename LogMod\LOG\logxx.log into
5 3 129
logxxSTD.log
Update log file 5 3 |30
Note: Same as for .
STD Loop for all the vehicle types (from 1 to 40) 1 1
Load the vehicle number from
1 2
Vehicle_parameters table
3
Conversi . .
Covert the 314 format into matrix format 1 to
on from
5
LogMod
to VY (1) ) . . 6
Merge the matrices by mode in a unique MAT
1 to
file
11
12
RCM Updated output tables with new output 1 to
Assign 13
ment
©) PILOT _
@ Choose mode for assignment 2
2
Note: Same as for .
Loop between vehicle types (from 1 to 6) 3 1
STD
Set the values for VOT and KMCOST reading
2
the Vehicle_parameters table 3
Road
Assignm Calculate the Km_TAX, TOLL, 5 5
ent (3) DIST_COST,VOT variables and MAX_SPEED
Define the speed values and free flow times 3 4
Assignment 3 5
Merge the 5 network in one file 3 6
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Pro
Application Description gra | Subprograms
ms
7
Updated the outputs table with new output 3 to
8
Note: Different from Read number of bidirectional links with
4 1
STD capacity value (maximum ID_LINK)
Prepare network for assignment 4 2
Calculate OD Empty, Loaded and Tons
Lo . 4 3
matrices in daily volumes
Rail
Assignm Assign Loaded, Empties and Tons matrices 4 4
ent (4) Merge results from empty assignment and
tons and loaded assignment - convert in 4 5
Year
6
Updated the outputs table with new output 4 to
7
Note: Same as for )
STD Loop between vehicle types (from 18 to 39) 5 1
Set the values for VOT and KMCOST reading
the Vehicle_parameters table for the first 5 2
mode
Calculate the Km_TAX, TOLL, DIST_COST
5 3
Sea and VOT variables
Assignm
ent (5) Assignment 5 4
5
Merge the 21 networks in one file 5 to
7
8
Updated the outputs table with new output 5 to
9
Set the values for VOT and KMCOST reading
the Vehicle_parameters table for the first
mode 6 1
Calculate the Km_TAX, TOLL, DIST_COST
Air and VOT variables 6 2
Assignm .
Assignment 6 3
ent (6)
Save the network in geodatabase format 6 4
5
to
Updated the outputs table with new output 6 6
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Pro
Application Description gra | Subprograms
ms
PILOT .
o Just run a single step or all RCM process 7
7
Check execution order a label to jump here 1
Merge all the assigned network by mode in a
2
unique network
Create the report for vehicle and vehicle km 3
Save the report in the geodatabase 4
Create network with bidirectional flow 5 1
Compare assigned networks STD and RCM 5 2
Produce report 3 5 3
Read report 6 5 4 |1
Port Areas (4) Sum over port areas 5 4 |2
Produce report 13 5 4 |3
GIS maps by .
. Create ArcGIS folder to export maps in ESRI
Commodity groups 5 5 |1
format
5)
. 2 -
Prepare CTL and Batch files 5 5
Results 3
RCM -
10) Run selectdirect to produce output by
10
commodity group
5 5 |4
Revort {SCENARIO_DIR}\LogMod\RCM\Output\C
eports
OMMODITY_XTD.dat
1.0 (5)
Prepare table for map 5 5 -
Export SHP file 5 517
Calculate report 21 5 5 |8
Run python to import SHP file onto gdb and
. . 5 519
update mxd with scenario name
Merge final network with other statistics 5 6 |1
Oresund Kiel and
Calculate total values 5 6 |2
Jylland (6)
Produce report 14 5 6 |3
Create bidirectional flow from
1,
LOAD_NET_RAIL_RCM > 7
Rail Capacity (7)
Create report 15 first step 5 7 |2
Create report 15 second step 5 7 13
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Pro
Application Description gra | Subprograms
ms
Merge Prop_link_Base2017 with scenario 5 8 |1
table
Dump link table for assigned network 5 8 |2
Add CATEGORY ID_COUNTRY REGION 5 8 |3
ID_COUNTY attributes based on values in
Prop_link
Produce report 9 5 5 |4
Reports per Produce first part of report 17 5 5 15
geographical
aggregation (8) Produce first part of report 18 5 516
Produce report 16 totals 5 517
Produce report 16 adding county names 5 5|8
Produce report 17 totals 5 519
Produce report 17 adding county names 5 5 |10
Produce report 18 totals 5 5 |11
Produce report 18 adding county names 5 5 |12
Domestic tonkm for calibration.txt file 5 9
. 6to
Updated the outputs table with new output
7
Save RCM results and other report 8
Update
REPORT_GS_{SCENARIO_SHORTNAME}.
S . . 9
prn file with the list of outputs created during
the run
Skip the process if user selected to run step by
1
step some parts
Parame Calculation of scaling factors per port area
2
ters and commodity group. See 6.8.2 for details
Caleula Prepare data for next calculation 3
tion
(11) Calculation of scaling factor for Kiel canal. See
4
6.8.3 for details
Label to skip the process 5
Pilot .
End of cycling process
#12




5.5. “Compare scenarios” application

Input data:

e LOS matrices

e OD matrices STD

e loaded networks STD and RCM for base scenario and selected scenario.

Output data:

e matrices with differences and networks with differences under scenario folder.

Purpose:

e Compare the matrices and the loaded network between scenarios.

Applied methods in the model

Application Description Programs | Subprograms
Execution order based on "Select_compare" catalog key 1 1
Compare Road LOS matrix between base scenario and selected scenario 1 2
Compare Rail LOS matrix between base scenario and selected scenario 1 3
LOS Compare Sea LOS matrix between base scenario and selected scenario 1 4
matrices (1) Compare Air LOS matrix between base scenario and selected scenario 1 5
Execution order based on "Select_compare" catalog key 2 1
Compare OD Loaded vehicle matrices by road 2 2
Compare OD Loaded vehicle matrices by rail 2 3
Compare OD Loaded vehicle matrices by sea 2 4
Compare OD Loaded vehicle matrices by air 2 5
Compare OD tonne matrices by road 2 6
Compare OD tonne matrices by rail 2 7
Compare OD tonne matrices by sea 2 8
Compare OD tonne matrices by air 2 9
Compare OD empty vehicle matrices by road 2 10
Compare OD empty vehicle matrices by rail 2 11
OD Matrices Compare OD empty vehicle matrices by sea 2 12
(2) Compare OD empty vehicle matrices by air 2 13
Execution order based on "Select_compare" catalog key 3 1
Compare the loaded networks from Standard Logistics Module 3 2
Assignment Compare the loaded networks from Rail Capacity Management Module 3 3
(3) End of process 3 4
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Application Description Programs | Subprograms
Create {Scenario_Dir}\DIFF_GIS2040_2017 where store gdb and mxd 4 1

Comparison Calculate differences among COMMODITYflows tables 4 2

@ Move information in shp format 4 3
Save in gdb feature class 4 4

5.6. “Handling scenario”

Input data:

e For the export function of the entire model.

Output data:

e Depends on the choice made by user. With the export function a new model will be set up in the
folder indicated by “New_folder” catalog key. It will also result in an exported scenario in another
model in case the “Exp_selection” catalog key is set to 2.

Purpose:

¢ To manage the model in the following ways:

e To delete a scenario,

e To compress the geodatabases,

e To export a model or a single scenario,

e To check the catalog values for an imported scenario.

Application

Description

Progra

Subprograms

Set the execution order based on "Delete" catalog key

1

Check if the scenario is in read mode. In this case go to the end of

process

Delete (1)

Skip all the other applications

Compact

(2)

Call the python script compact_GDB.pyt to compress the
input_data.mdb and outputo.mdb

Model
Export
(€Y]

If "Exp_selection" is equal to 1, create the entire model structure

in a new folder and copy all the applications and script files.

General
Tables
(2)

Create DaTE_TIME.TXT to check the data of the system and

change the execution order based on "Exp_selection" catalog key

Update the Model_description table in the new Input_Data.mdb

file in the new model folder

to

Copy the tables and feature classes from the existing
input_data.mdb to the new one. Also if the "Exp_selection" is set

to 2, verify that the Input_Data.mdb exists in the new folder
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Progra
Application Description ms Subprograms
5
to
If not exist jump all the processes to allow a verification by user. 3 2|6
Update the General_NewBase table in the new geodatabase 3 2 |7
Update the LogMod_ NewBase table in the new geodatabase 3 2 |8
Skip all these steps if "Exp_selection" catalog key is set to 2. The
previous check (2.3.4) has pointed out if is possible run this part. | 3 3|1
Merge SC_{SCENARIO_SHORTNAME}_ Link and
SC_{SCENARIO_SHORTNAME}_ Node with base data to create
the new base network 3 3|2
Merge the
SC_{SCENARIO_SHORTNAME}_Frequency_Data_Link and
SC_{SCENARIO_SHORTNAME}_Frequency_Data_Node with
the base frequency_data_Base2017 to obtain the new frequency
network 3 313
Merge Sc_{SCENARIO_SHORTNAME}_Cargo and
Cargo_Base2017 to create the new cargo table 3 3 4
Merge Sc_ {SCENARIO_SHORTNAME}_Node_Terminals with
Node_Terminals_Base2017 to obtain the new Node_Terminals
Base table 3 315
Merge Sc_{SCENARIO_SHORTNAME}_Nodes_Commodities
with Nodes_ Commodities_ Base2017 to create the new
Nodes_Commodities table 3 316
Merge SC_Nodes_{SCENARIO_SHORTNAME}to
Nodes_Base2017 to obtain the new base nodes table 3 317
Create the new Tax_Country_{SCENARIO_SHORTNAME}table
joining Sc_ {SCENARIO_SHORTNAME}_Tax_Country with
Tax_Country_Base2017 3 3|8
Create the new Tax_ Category_{SCENARIO_SHORTNAME}table
joining Sc_ {SCENARIO_SHORTNAME}_Tax_Category with
Tax_Category_Base2017 3 319
Create the new Tax_Link_{SCENARIO_SHORTNAME}table
joining Sc_ {SCENARIO_SHORTNAME}_Tax_Link with
Tax_Link_Base2017 3 3 |10
Create the new Toll_Link_{SCENARIO_SHORTNAME}table
joining Sc_ {SCENARIO_SHORTNAME}_Toll_Link with
Toll_Link_Base2017 3 3 |11
Create Merge Vehciles_parameters_Base2017_PartA with
the new SC_{SCENARIO_SHORTNAME}_Vehicle_parameters_PartA to
base (3) obtain a new Vehicle_parameters base table 3 3 |12
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Progra
Application Description ms Subprograms
Merge Vehciles_parameters_Base2017_PartB with
SC_{SCENARIO_SHORTNAME}_Vehicle_parameters_PartB to
obtain a new Vehicle_parameters base table 3 3 (13
Merge ProprLink_Base2017 with
SC_{SCENARIO_SHORTNAME}_ProprLink to obtain a new
PropLink base table 3 3114
Merge Rail_Capacity_Base2017 with
SC_{SCENARIO_SHORTNAME}_Rail_Capacity to obtain a new
Rail_Capacity base table 3 3|15
Do the next steps if "Exp__selection" is equal to 2. If equal 1 the
Create
base scenario already exists 3 4|1 |1
the
scenari 2
o tables to
(1) Rebuild the base scenario for the current scenario 3 4 |1 15
Create
the
Create scenari
thenew |o
scenario | specific 1
specific | tables( | Compare all the tables between the new base and the current to
tables (4) | 2) scenario 3 4 |2 |18
Select the execution order based on "Imp_Selection" catalog key
and create Ckeck.txt file to verify if the scenario exists in the
Input_Data.mdb 4 1
2
t
Check if the selected scenario exists, otherwise give a prompt and o
go to the end of process 4 3
Scenario Compare the values for the catalog keys existing in the catalog file
Import and in general {SCENARIO_SHORTNAME}table, creating a
) report REPORT_HL_BS05.TXT 4 4
End of the process 4 5

5.7. “PWC_matrices” application

Input data:

e PWC matrices under {CATALOG_DIR}\ 01_Programs\LogMod\Input\{Year}\PWC folder in txt
format. {Year} is the catalog key controlling the set of matrices per each provided year (for example
2016 or 2040).

Output data:
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¢ PWC matrices under {CATALOG_DIR}\ 01_Programs\LogMod\Input\PWC\VY_F folder in binary

voyager format.

Purpose:
e Visualize the PWC_matrices with Cube Interface.

Description Programs

Check existence of PWC matrices, if not warning the user 1

Prepare lookup table with correspondence between Voyager and EMME numbers for zones and terminals 2

Loop over commodities 1 to 9, read PWC matrices, convert in DBF tables and finally in Voyager MAT files From 3 to 11

Loop over commodities 10 to 16, read PWC matrices, convert in DBF tables and finally in Voyager MAT files From 12 to
19

Delete temporary txt files (to save disk space) From 20 to
29

If PWC matrices not present, skip all process to let user check settings 30

5.8. “Change matrix format” application

Input data:
e COST and

e  OD matrices for vehicles and tonnes under {CATALOG_DIR}\Scenario_Tree\{Scenario_name}

folder.

Output data:

e dbf or txt file of a selected matrix.

Purpose:

e Export a specific matrix into dbf or csv format.

Description Programs

Detect the user choice and create temporary variable to jump at the right process 1

Read the temporary variable and jump to the right process 2

Export cost matrix in CSV format, DBF format or as table under MDB From 3to 8

Jump here if chosen Demand matrices instead 9

Export demand matrix in CSV format, DBF format or as table under MDB From 10 to
17

5.9. “Select Link Analysis” application

Input data:

e Results from Samgods full run (both STD and RCM). Provide a list of nodes, links and commodities

for the analysis.

Output data:
e Under SelectLink folder the output data listed in section 3.4.8.6.
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Purpose:

e Perform select link analysis

Pro
L Lo Subprogr
Application Description gra
ams
ms
Data prepare (1) Prepare the vehicle parameters table 1
Prepare the folder for outputs and necessary programs
2 1|1
in RCM folder
2
Read link list (RCM\Links_ List.txt) and prepare dbf t
2 1
table for next steps o
3
Read ID_LINK values in catalog key and prepare file for
2 1|4
next steps
Read A and B r values in catalog key and prepare file for
2 1|5
next steps
Union of link selection and conversion of Voyager 6
2 1
numbering to Emme numbering
Read node table from node list RENUM_NODES.DBF 2 1|7
Create selection files
(1) Read N vr values in catalog key and prepare file for next 8
2 1
steps
Conversion of node list in Emme numbers if required 2 119
Selection for loaded Check the combination of selections (maximum number 1
. 2 1
unloaded vehicles and of selections allowed for nodes and links) o)
tons (2)
Warning windows if exceeding some limits 2 1 (11
3 . . 1
Set up control files for DirectSelect.jar program 2 1
2
. . . 1
Setup batch files to run DirectSelect.jar program 2 1
3
1
Run the program 2 1
4
Move the results from RCM folder to Selectlink folder 2 2 |1
Strip off header 2 2 |2
Read output file STD solutions and convert in dbf 2 2 |3
Produce matrices Read dbf table and convert in in OD table 2 2 |4
with volumes and
tons (2) Read OD table and convert in MAT file 2 2 |5
Strip off header 2 2 |6
Read output file RCM solutions and convert in dbf 2 2 |7
Read dbf table and convert in in OD table 2 2 |8
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Pro
o e .. Subprogr
Application Description gra
ams
ms
Read OD table and convert in MAT file 2 2 |9
Delete headers in LinksSumSLSTD.dat (STD results) 2 3 |1
Convert link results in DBF format 2 3 |2
Create attribute names and values 2 3|3
. Delete headers in LinksSumSL.dat (RCM results) 2 3 |4
Produce maps with
volumes and tons Convert link results in DBF format 2 3|5
(3 .
Create attribute names and values 2 3|6
Dump network in NET format 2 3 |7
Create NET file with results of select link analysis STD 2 3|8
Create NET file with results of select link analysis RCM | 2 3|9
Call selectdirect.jar to produce outputs by commodity
2 4 |1
group
Convert CommoditySLSTD.dat in DBF format 2 4 |2
Merge bidirectional network and commodity table for
2 4 |3
STD and produce SHP file
Convert CommoditySL.dat in DBF format 2 4 |4
Produce maps by . .
. Merge bidirectional network and commodity table for
Commodity group 2 4 |5
RCM and produce SHP file
€))
Call python to move data from SHP to gdb format
(independently by Cube) or Option to skip GDB and 2 4 |6
produce net format
Produce NET for STD 2 4 |7
Produce NET for RCM 2 4 |8
Handle choice between gdb or net output 2 4 |9
13 M . ” H H
5.10. Cost Benefit Analysis - ASEK Values” application
Input data:

e Results from Samgods full run (both STD and RCM). Provide the Toll, tax, scaling factors parameters
from ASEK scenario (need to specify ASEK catalog key).

Output data:

e Listed in section 3.4.

Purpose:

e Produce reports and statistics excluding the calibration factors and using as basis the ASEK values
(e.g. values suitable for Cost Benefit Analysis).
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- .. Prog
Application Description Subprograms
rams
PILO ) .
T Set specific folders under LogMod for CBA calculation 1
1
Check the choices made by user; if not right starts a prompt. Create the outputX.mdb if
1|1
not exist and if required. 2
Load the parameters from general_{SCENARIO_SHORTNAME]} table into the system
1|2
variables 2
Verify if few outputs already exist and if they have the same input data 2 1|3
Check if the scenario is locked or still editable 2 1|4
Create the Vehicle_parameter table for the scenario 2 1|5
Create the Cargo table for the scenario 2 1|6
Create the network for the scenario 2 1|7
Dump in dbf format the link and node tables 2 1|8
Set the node class (see table A_nodeclass) value for all the nodes 2 119 1
Classify the links based on the class node and the ID_COUNTRY in the A_ Categories
. . . . 119 2
Data code - identify the country id for each link 2
Prepa
P 3
ration . .
Convert all the scenario tables for taxes and tolls to a link format 119 to
@) 2 12
Tax
calculati | Create the network with all the extra attributes with undefined values 2 119 13
on Recode the mode for each vehicle type 2 1109 15
Update with scenario values all the extra attributes 2 19 14
Add the fields for MODE 2 119 16
Create the equations to save the final value for tax and extracost 2 19 17
Save the final values (TAX_TOT, EXCTTOT and TOLL) for each link and by vehicle type | o 119 18
Create the intrazonal matrix in dbf format 2 1 |10
Change the format of intrazonal matrix from dbf to MAT 2 1|1
Save the node_labels table in Outputo.mdb 2 1 |12
Data for | Export final network with time and cost per link for usage in ASEK calculation or
1|1 1
CBA external checks 2 3
Write in txt format the Cargo_Base2017 table under LogMod\Input\Cost with name
Cargo.txt 3 1|1
CBA
Prepare
Analy data (1) Merge the scenario specific table and the base table for Node_terminals_Base2017 3 1|2
sis (3)
Write in txt format the Node_terminals_ {SCENARIO_SHORTNAME} table under
LogMod\Input\Cost with name Pilotfees.txt 3 13
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S - Prog
Application Description Subprograms
rams
4’5)
Merge Vehicle parameters table A and B and apply scaling parameters 3 1|6
Write in txt format the Vehicle_parameters table under LogMod\Input\Cost with name
VHCLS_COMo01.TXT, VHCLS_COMo02.TXT, VHCLS_COMo03.TXT,
VHCLS_COMo04.TXT, VHCLS_COMo05.TXT, VHCLS_COMO06.TXT,
VHCLS_COMo07.TXT, VHCLS_COM08.TXT, VHCLS_COM09.TXT
,VHCLS_COM10.TXT, VHCLS_COM11.TXT, VHCLS_COM12.TXT,
VHCLS_COM13.TXT, VHCLS_COM14.TXT, VHCLS_COM15.TXT and
VHCLS_COM16.TXT 3 17,8
Write in txt format the Vehicle_parameters table under LogMod\Input\General with
name averagevehiclecapacity.txt 3 119
Copy all the other files from Input\Nodes to Input_CBA\Nodes 3 2 |1
Prepare Merge the scenario specific table and the base table for
2 |2
data Nodes_{SCENARIO_SHORTNAME} 3
second Add parameters for Varner Kanal 3 2|3
part (2)
Write in txt format the Nodes_ {SCENARIO_SHORTNAME}table under
2
LogMod\Input_CBA\Nodes with name Nodes.txt 3 4
Prepare
data Convert the Chain_list table in txt format under
1
third LOGMOD\Input_CBA\CHAINTYPE.LIS 3
part (3) 3
Move parameters for port areas in CBA folder 3 4 |1
LOS Call Prepare {SCENARIO_DIR}\LogMod\RCM\LOS_CBA.ctl control file for LOS rescaling | g 4 |2
@ Prepare CB_RUN_LOS.BAT to call selectDirect.jar to rescale LOS matrices 3 4 |3
Run process and infill LOS folder with proper matrices 3 4 |4
Print out the batch file to call logistic model selecting the commodity based on the value
5|1
in Select_commodity catalog key 3
Print out the batch file for call ASEK calculation 3 5|2
Change the execution order if selected the normal logistic model or advanced. Call the
513
batch files RUNALL.BAT 3
Run
LP2CC Label to jump the normal logistic model and run advanced 3 5 |4
(5) Set up files to describe then number of processors and batch file for call the
Samgods_ Parallelization_Module.jar 3 51°
Run RUNALL.BAT using Parallelization Module 3 5|6
Create the batch file for merge.exe 3 517
Call the external program "Merge reports" and check results 3 58
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S - Prog
Application Description Subprograms
rams
Prepare {SCENARIO_DIR}\LogMod\RCM\UTI_CBA.ctl 3 519
{SCENARIO_DIR}\LogMod\RCM\CB_RUN_UTI.BAT 3 5 |10
Run CB_RUN_ UTIL.BAT to get rescaled costs and reports for empties 3 5 |11
Pilot to skip process if not main JA scenario 3 6 |1
Delete temporary files used to accumulate results from all commodities 3 6 |2
Save the report file from ChainChoi (.rep) 3 6|3
Change the format of report file into Voyager 3 6 |4
Merge domestic distances from LOS files for subsequent step 3 6 |5
Loop over commodities (ID_LOOPC) 3 6|6
Control the commodities that must be used (if all or single commodity) 3 6|7
Delete headers from ChainChoi\OUTPUT\ChainChoiXXo1.out files 3 6 (8
Calculate sum of variables for reports 5,6,7,8 3 6|9
Merge ChainChoiXX.rep files (input for reports 10 and 11) 3 6 |10
Merge VhelRepXXrep files (input for reports 12) 3 6 |11
Merge ChainChoiXX.rep files (input for report 6b) 3 6 |12
Save
Reports | Merge ChainChoiXX.rep files (input for report 19) 3 6 |13
(©) Script to control the commodities that must be used (works in pair with 14) 3 6 |14
Calculate report 5 and 6 3 6 |15
Calculate report 7 and 8 3 6 |16
Calculate report 10 and 11 3 6 |17
Calculate report 12 3 6 |18
Calculate report 6b and 19 3 6 |19
OrderCosts and Inventory Report 20 3 6 |20
21
Updated the outputs table with new output 6 | and
3 22
Jump here to skip reports if not JA 3 6 |23
Create report on empties for UA scenario 3 6 |24
Skip previous step if JA scenario 3 6 |25
Read {SCENARIO_DIR}\LogMod\RCM\output\VehicleTrpEmpInv_Input_CBA.dat
Ma and convert in DBF — table holds vehicle costs and vehicles on ferry costs and vhvelkm 3
ain
and tonkm 7 |1
Reports
) Add attributes to handle ferry vehicles and vehicles on ferry 3 7 |2
Create Vehicles_loaded_and_empty_witin_Swedish_territory_CBA report 3 713
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S - Prog
Application Description Subprograms

rams
Read {SCENARIO_DIR}\LogMod\RCM\output\VehicleTrpEmpInv_Input_XTD.dat
and convert in DBF — table holds vehicle costs and vehicles on ferry costs and vhvelkm 3
and tonkm vam
Add attributes to handle ferry vehicles and vehicles on ferry 3 715
Merge CBA and RCM reports to create table

3
Costs_D_I_X_T_{Scenario_ShortName}_CBA 716
Comparison of Costs_D_I_X_T_{Scenario_ShortName}_CBA across JA and UA
scenarios for final report 3
{SCENARIO_DIR}\CBA_Final_report_{SCENARIO_CODE}.txt 7 |7

fro
Update list of reports under m8
{SCENARIO_DIR}\REPORT_SG_{SCENARIO_CODE}.TXT 3 to
7 | 10
PILO
Rename back Logmod folder 4
T4
5.11. “Elasticity module” application

The structure is identical to Samgods , with the following exceptions:

e all the assignment and report steps are deactivated

e The derivation of consolidation rates for iteration >1. For the first iteration , equivalent to a

Standard Samgods Run, the catalog key “Do you want to use exogenous consolidation rates?” is

active and user can chose their own setting. For next scenarios, where ID_SCENARIO>1 in
Scenarios_ List table”, the exogenous consolidation rates will be derived from the first iteration, i.e.

the reference. Please find further details under the User Manual.

Do you want to use exogenous consolidation rates?
" Yes (Update also next catalog key)
@ No

If yes in previous catalog key, provide location of consolidation rates folder

The extra module Elasticity Report calculates elasticities based on Webtag formulation (see par. 8.12.7 of

User Manual for details) and produces final report.

‘{CATALOG_DIR} \Scenario_Tree\Year_2040MainSc2040\L.ogmod_1\ChainChoi‘output

Description Program | Subprograms
Jump here after RCM 7 1
Calculate elasticities for STD process comparing scenario 1 vs current scenario 7 2
Calculate elasticities for RCM process comparing scenario 1 vs current scenario 7 3
Merge previous calculations together and save final report 7 4
Jump to the end of the process 7 5

241



Applied methods in the model

6 Applied methods in the model

6.1. Manage different loading times, costs and capacities for different

commodities

In Samgods V1.2.1 the scaling factors can be applied by COMMODITY group and vehicle type.
COORDINATION FACTOR, parameters for transfer points have been added in the list of scaling parameters
as well. Each commodity is not anymore classified in DRY, GC and LIQ since variation in cost is now defined
by Commodity group. Under ScalingF_Veh are now present the following attributes:

NC_LCO, CONT_LCO
DFLTFREQ

NC_LTI, CONT_LTI
F_DUES_VH,F _DUES_TON
CAPACITY

VESSELTYPE
ONFER_H_C,ONFER KM_C
POSICOST

NC_LCOT, NC_LTIT, CONT_LCO_T, CONT_LTI_T: new parameters for transfer on container and
non-container time and cost parameters

COORFACT: previously present in vehicle table but not rescaled.

The vehicle cost table has been divided in two parts, first part is by vehicle type and second part is by vehicle
type and commodity group. Scaling factors are applied in both cases arriving at maximum flexibility where
all different attributes can be modified by commodity group.

To setup this differentiation the following technique has been applied:

1. For each commodity, the original values in Vehicle parameters table are multiplied by the factors

present in ScalingF_Veh. For instance:
NC_LCO(com1)(vhel1)(modified) = NC_LOC (TableB) * Scaling factor NC_LOC(com1)(vhcl1)
Considering Commodity 1 vehicle type 101:

NC_LOC (modified) = 10.43 (vehicle type 101 and commodity 1) *0.9(Commodity 1 and vehicle
type 101)=9.387

2. In each control file for BuildChainXX.ctl the definition of VHCL control parameter that gives the

name and location of vehicle parameters has modified using commodity name (where XX is the
commodity group number) VHCL=.\Input\Cost\VHCLS_COMXX.TXT

3. Ineach control file for ChainCHainXX.ctl the definition of VHCL control parameter that gives the

name and location of vehicle parameters has modified using commodity name (where XX is the
commodity group number) VHCL=.\Input\Cost\VHCLS_COMXX.TXT

In Table 136 the coupling between Vehicle parameters Part A and B and ScalingF_ Veh table is shown.

Scaling factors can get three different values:

A value >0 which represent an actual scaling factor

-1: no scaling factor will be applied (equivalent to apply 1 — introduced to mark the entries which
hold the original values)



e -2: high cost 99988 (infinity cost).

Table 136 - Scaling factors and vehicle parameter tables.

Attribute in table

Table

ScalingF_Veh

OBJECTID

ID

VEH_NR

DESCRIPTIO

LABEL

KM_COST

HOURS_COST

DFLTFREQ

F_DUES_VH

F_DUES_TON

CAPACITY

VESSELTYPE

ONFER_H_C

ONFER_KM_C

POSICOST

SPEED

VDF_SPEC

MODE_1

MODE_2

FUNC_FILE

EMPTY_V

COORFACT

MAX_SPEED

A

NO

NO

NO

NO

OBJECTID

ID

ID_COM

VEH_NR

NC_LCO

NC_LTI

NC_LCOT

NC_LTIT

NO
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CONT_LCO

CONT_LTI

CONT_LCO_T

CONT_LTI_T

In Table 137 the list of VHCL definitions in BuildChain and ChainChoi.

Table 137 - List of values for VHCL control parameter in BuildChain and ChainChoi control files.

ID_COM VHCL in BuildChain and
ChainChoi

1 VHCLS_COMO01.TXT
2 VHCLS_COMo02.TXT
3 VHCLS_COMo03.TXT
4 VHCLS_COMo04.TXT
5 VHCLS_COMo05.TXT
6 VHCLS_COMO06.TXT
7 VHCLS_COMo7.TXT
8 VHCLS_COMO08.TXT
9 VHCLS_COMo09.TXT
10 VHCLS_COM10.TXT
11 VHCLS_COM11.TXT
12 VHCLS_COM12.TXT
13 VHCLS_COM13.TXT
14 VHCLS_COM14.TXT
15 VHCLS_COM15.TXT
16 VHCLS_COM16.TXT

6.2. Manage different consolidation factors for different commodity groups

The consolidation range, expressed as a lower and upper limit, can be specified in two separate ways in the
general control file for BuildChain and ChainChoi.

A first control parameter, CONSOL, represents a general range used when no mode specific range is
specified. These range can be specified in the GUI via the following two catalog keys:

e Lower bound for consolidation factor (applied to all commodities - from o to 1) 0.05
e  Upper bound for consolidation factor (applied to all commodities from o to 1) 0.95
A second set of CONSOL<mode> parameters can be specified using the table:

e "Low and upper bounds for consolidation factors" under Scenario Inputs\General tables of Data
Panel.
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The access to this table is only for developer or advance user in application Edit the data.

The Logistics Module will give the priority to the second values, specified by submode and commodity, and
ignore the first general values. An example of general control file with these parameters specified is (notice
the difference between CONSOL CONSOL<mode>):

¢ CONSOL=0.05,0.95
¢ CONSOLA=0.05,0.5
¢ CONSOLB=0.05,0.5
¢ CONSOLC=0.05,0.5
¢ CONSOLS=0.5,0.9

In the calibration process a unique set of consolidation parameters per mode has shown limitations and
different sets for specific commodities have been used for the calibration. BuildChain_ CONSOL table has 16
commodity lower and upper bounds for consolidation parameters. The implemented logic is:

e CONSOL L and CONSOL_U hold the default values

e CONSOL_LXX - CONSOL_UXX, where XX is commodity, hold values that change in comparison to
the default values. Where there is a value -1, the default value will be used

The current structure has the advantage to clearly point to differences in values across each commodity.

Table 138 - CONSOL<mode> parameters General (CONSOL_L, CONSOL_U) and by commodity group.

E=] ™ [ [Ta] T - | -] - — ™ ™ T ]
e HEHEHEBHEHBEBEBEHEHEBHBEEHBEHEEBEEHBEEIBEEEEE
ol S Carfl I Y Y O I I A O O S O S P U P N N S S I I Y I I O D B
E IR EHEHEHE EE E B E R EEE EHE B EE HEHEEEEHEEEEEEEE
JS|81812|2|1812|518121818|2181218|1212181212|15/14181581218/212|81815|13|813|3
= L= L= = L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L= L=
1[4 if -1f -1 -1} -1 -1 -1} -1f -1f -1y -1f -3} -1y -1} -3f -1 -1} -1} -1| -1} -3f -3f -1 -1f -3f -1) -1} -3f -1 -1} -1f -1f -1
2B if -1 -1 -1} -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1) -1} -3f -1 -1 -1f -1f -1 From Default
3l if -1 -1 -1} -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1) -1} -3f -1 -1 -1f -1f -1
4{C if -1f -1} -1} -1 -1 -1| -1f -1f -1} -1f -31f -1} -1} -3f -1 -1} -1} -1| -1} -1f -1f -1 -1} -3f -1f -1} -1f -1f -1) -1} -1f -1] € dity specific
5[5 if -1 -1 -1} -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1) -1} -3f -1 -1 -1f -1f -1
Efx if -1 -1 -1} -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1) -1} -3f -1 -1 -1f -1f -1
b 2 -1 -1 0| i -1f -1 -1f -1f -1 -1] -3f -1f -1] -1 QE 1| 0. i -1 -1y -1f -1f -1} -1} -1f -1 -1} -3f -1f -1 -1f -1
Al 2( -1 -1] 0| if -1f -1 -1f -1f -1 -1] -1f -1] -1] -1| QE 1| 0.8 1| -1| -1} -1f -1f -1} -1} -1f -1} -1} -3f -1f -1} -1f -1
5[E 2( -1 -1] 0| if -1f -1 -1f -1f -1 -1] -1f -1] -1] -1| QE 1| 0.8 1| -1| -1} -1f -1f -1} -1} -1f -1} -1} -3f -1f -1} -1f -1
13F 2( -1 -1] 0| if -1f -1 -1f -1f -1 -1] -1f -1] -1] -1| QE 1| 0.8 1| -1| -1} -1f -1f -1} -1} -1f -1} -1} -3f -1f -1} -1f -1
11)f 2( -1 -1] 0| if -1f -1 -1f -1f -1 -1] -1f -1] -1] -1| QE 1| 0.8 1| -1| -1} -1f -1f -1} -1} -1f -1} -1} -3f -1f -1} -1f -1
12|15 2( -1 -1] 0| if -1f -1 -1f -1f -1 -1] -1f -1] -1] -1| QE 1| 0.8 1| -1| -1} -1f -1f -1} -1} -1f -1} -1} -3f -1f -1} -1f -1
13|k 2 -1 -1 0| i -1f -1 -1f -1f -1 -1] -3f -1f -1] -1 QE 1| 0. i -1 -1y -1f -1f -1} -1} -1f -1 -1} -3f -1f -1 -1f -1
14 2 -1 -1 0| i -1f -1 -1f -1f -1 -1] -3f -1f -1] -1 QE 1| 0. i -1 -1y -1f -1f -1} -1} -1f -1 -1} -3f -1f -1 -1f -1
15]i 20 -1 -1] 07 if -1 -1} -1f -1f -1| -1} -1f -1} -1} @7 -1 o3 -1 -1| -1} -1| -1f -1} -1} -3f -1 -1} -3f -3f -1 -1f -1
1E|l 20 -1 -1] 07 if -1 -1} -1f -1f -1| -1} -1f -1} -1} @7 -1 o3 -1 -1| -1} -1| -1f -1} -1} -3f -1 -1} -3f -3f -1 -1f -1
177 20 -1 -1] 07 if -1 -1} -1f -1f -1| -1} -1f -1} -1} @7 -1 o3 -1 -1| -1} -1| -1f -1} -1} -3f -1 -1} -3f -3f -1 -1f -1
18|} 20 -1 -1] 07 if -1 -1} -1f -1f -1| -1} -1f -1} -1} @7 -1 o3 -1 -1| -1} -1| -1f -1} -1} -3f -1 -1} -3f -3f -1 -1f -1
15)) 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
20K 3 -1 -1 -3} -1 -1 -1} -1f -1f -1y -1f -1f -1y -1} -3f -1 -1} -1} -1| -1} -3f -3f -1 -1f -3f -1) -1} -3f -1 -1 -1f -1f -1
21|L 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
22| 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
23|M 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
24|10 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
25|F 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
2|0 3 -1 -1 -3} -1 -1 -1} -1f -1f -1y -1f -1f -1y -1} -3f -1 -1} -1} -1| -1} -3f -3f -1 -1f -3f -1) -1} -3f -1 -1 -1f -1f -1
27 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
28| 3 -1 -1 -1 -1 -1 -1| -1f -1| -1} -1f -1f -1} -1} -3f -af -1} -1} -1) -1} -1f -1f -1} -1f -3f -1 -1} -3f -1 -1} -1f -1f -1
25|k 4 -1 -1 -1 -1} -1} -1| -1f -1} -1} -1f -1f -1} -1} -1f -3 -1 -1} -1| -1} -3if -1f -1} -1f -1f -1} -1) -3f -1 -1} -1f -1f -1

In each BuildChainxx.ctl or ChainChoixx.ctl the control parameter INCL=points to the right values
depending if xx (the commodity group number) has a value that differ from general values (value in table
different from -1). In all the other cases, the general values will be used.

To manage the different cases the following process is in place:

e From BuildChain_CONSOL, commodity by commodity, it is determined if special values are applied
checking how many -1 are present under CONSOL_LXX and CONSOL_UXX. If the count of -1s
sums to 29 it means default values must be used.
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o If default values must be used under BuildChainxx.ctl INCL=BuildChain_ Common.ctl will be
included, otherwise INCL=BuildChain_ Special.ctl will be present and under BuildChainxx.ctl it will
be present the section for modified Lower and upper bound;

e Similarly to BuildChain, Chainchoixx.CTL will have INCL=ChainChoi-Common.ctl if default values
must be used, while INCL=ChainChoi_Special.ctl will be present and under ChainChoixx.ctl all
values for lower and upper bound will be included.

e BuildChain_ Special.ctl and ChainChoi_Special.ctl just exclude the section with default values for
lower and upper bound.

For instance, commodity group uses default values, so we have:

| BUILDCHAINO1.CTL - Notepad - [m] X

File Edit Format View Help

|-start 1 1

COMMODITY=01

INCL=BuildChain_common.ctl

VHCL=. .\Input\Cost\VHCLS_COM@1.TXT

--LOSDIR=..\Input\LOS\S@1

PWC=C: \Models\Samgods_V12D_20190829\@1_Programs\LogMod\Input\PWC\2016\PWC_01.txt

And BuildChain _Common.ctl looks like:

_\ BuildChain_Common.ctl - Notepad

File Edit Format View Help
|LoGSELECT=0
CONSOL=8.85,0.95
CONSOLA=0.4@,0.60
CONSOLB=0.40,0.60
CONSOLC=0.40,0.60
CONSOLC=0.40,0.60
CONSOLS=0.1@,0.35
CONSOLX=0.40,0.60
CONSOLd=0.60,0.95
CONSOLD=0.6@,0.95
CONSOLE=0.6@,0.95
CONSOLF=0.60,0.95
CONSOLT=0.60,0.95
CONSOLG=0.6@,0.95
| conNsoLh=0.60,0.95
{ CONSOLH=0.60,0.95
{ CONSOLi=0.66,0.98
CONSOLI=0@.66,0.98
CONSOLT=0.66,1.00
CONSOLU=0.66,1.00
CONSOLJ=0.05,0.60
CONSOLK=0.@5,0.60
CONSOLL=0.05,0.60
CONSOLM=0.05,0.60
CONSOLN=0.05,0.60
CONSOL0=0.05,0.60
CONSOLP=0.15,0.90
| consoLQ=e.15,8.90
CONSOLV=0.05,0.60
CONSOLW=0.05,0.60
CONSOLR=0.15,0.80




Commodity group 2 uses special values, so under BuildChainxx.ctl we have:

| BUILDCHAINO2.CTL - Notepad

File Edit Format View Help
|-start 1 2
COMMODITY=082
INCL=BuildChain_Special.ctl
CONSOLA=0.40,0.60
CONSOLB=0.40,0.60
CONSOLc=0.40,0.60
CONSOLC=0.40,0.60
CONSOLS=0.18,0.35
CONSOLX=08.48,0.60
CONSOLd=0.63,0.93
CONSOLD=0.63,0.98
CONSOLE=0.63,0.98
CONS0OLF=©.63,0.98
CONSOLT=0.63,0.93
CONSOLG=0.63,0.98
CONSOLh=0.63,0.93
CONSOLH=0.63,0.98
CONSOLi=0.71,0.93
CONSOLI=0.71,0.98
CONSOLT=0.71,1.00
CONSOLU=0.71,1.00
CONSOLJ=0.05,0.60
CONSOLK=0.05,0.60
CONSOLL=0.05,0.60
CONSOLM=0.05,0.60
CONSOLN=0.05,0.60
CONSOLO=0.85,0.60
CONSOLP=0.15,0.90
CONSOLQ=0.15,0.90
CONSOLV=0.05,0.60
CONSOLW=0.05,0.60
CONSOLR=0.15,0.80

_'\ BuildChain_Special.ctl - Notepad

File Edit Format View Help

|LOGSELECT=0

CONSOL=0.85,0.95
TONNES=DYNAMIC_AVERAGE
NAMEROOT=ChainChoi
JLIST=..\RCM\JLISTA.DAT
TYPES=..\Input\chaintype.lis

NODES=. .\Input\Nodes
PILOTFEES=..\Input\Cost\pilotfees.txt
CARGO=. .\Input\Cost\cargo.txt
CONSOLDIR=. .\ChainChoi\OUTPUT\CoVa
LOSDIR=..\Input\LOS

LOSFAC=. .\Input\General\CalibrationParameters.txt
WRTLOS=0

ALl 1 ADDV TVYNE FAKCAl —1

6.3. Control files revision for ASEK calculation

And BuildChain_ Special.ctl misses section with lower and upper bound:

Applied methods in the model

The ASEK calculation requires to rerun LP2CC.exe (last step for RCM) with a separate set of costs and
parameters (saved under Logmod\Input_CBA) and a different INTEREST and STUFF values. Instead of
recreating the control parameters (CTL) for ChainChoi, the control setup has changed in the following

manner:

e In ChainChoi_Common.ctl a new control parameter ASEK=..\Input_CBA will redirect the reading of
the input data from Input folder to Input_ CBA folder (e.g. the control file will contain always Input
folder, in CBA analysis the folder name will be replaced by ASEK name)
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e A second control parameter is OTHERCOST=..\Input\COST\OtherCostMatters.txt that points to the
file that contains INTEREST and STUFF values

¢ A new file resides under LOGMOD\INPUT\COST\OtherCostMatters.txt and
LOGMOD\INPUT_CBA\COST\OtherCostMatters.txt respectively. The first with values for Standard
Logistic Module and RCM, the second for the specific calculation of CBA.

6.4. Maximum Speed on Road Mode

The speed limits for road vehicles can be specified in the MAX_SPEED attribute under
Input_Data.mdb\Vehicles_parameters_PartA_{ScenarioName}. 116 km/h is the defined speed limit as it
has been identified as the maximum speed in current network.

In Table 139 the maximum of Speed_1 (vehicle 101) and Speed_ 2 (vehicles 102 to 106) from the current
network is shown, grouping by Modestr. As can be seen, road modes ¢, a, b and B have the maximum speed
116 km/h in Speed_1 and 110 km/h in Speed_ 2.

Table 139 - Maximum speed in current network

Queryl
MaxOfSPEED_1 | MaxOfSPEED_2 MODESTR

90 0 X

50 50 xabBc
116 95 xabc
110 110 Xac
76 0 xd
40 0 xdfFhitDIH
50 0 xdfFhitu
50 0 xdfFhituDIH
75 0 xdfh
112 0 xdfhi
91 0 xdFhit
64 0 xdFhitu
96 0 xdFht
50 0 xdh
122 0 xdhi
91 0 xdhit
64 0 xdhitu
55 0 xfFh
94 0 xfh
81 0 xFhi
85 0 xFhit
92 0 xh
121 0 xhi
40 0 xhitu
49 0 xhtu
40 0 Xp

25 0 Xpq
600 0 Xr

12 0 Xy

12 0 Xyz
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The MAX_SPEED has been included in the input table as a new attribute and the implementation of
constraints in maximum speed within the road assignment under Samgods model assignment and RCM
assignment.

6.5. Capacity constraints on sea mode

There are two different mechanisms in place for the sea mode to limit the usage of some services and ports:

A. Constraints applied at network level (e.g. by link level, as for the Kiel Canal example, see Figure
4). This are managed at the BuildChain step and applies only to the type vehicle. Should a too
large vehicle be used as type vehicle, any path using the link cannot be used. As described below
this is managed by removing links with too low capacity before running the LOS-calculations for
the type vehicle.

B. Constraints applied in the evaluation of alternatives during ChainChoi process (as per the Vinern
Lake). When evaluated at the ChainChoi-level the generated alternatives may be generated with a
too large vehicle, but at this level only the vehicles small enough will be allowed. As described
below this is managed by using a port capacity limit in lake Vanern for the allowed vessel capacity
in the Vénern ports (otherwise the paths would have to be scrutinized after the LOS-calculations
which is possible but not efficient).

In the following two paragraphs will be discuss their implementation in the model.

6.5.1. Capacity constrains in Kiel Canal

To apply capacity constraints on network level different actions have been performed:
e provided the information of which Dwell Capacity is allowed in Kiel Canal
e compared the capacity of the vessel type with the allowed capacity in the Kiel Canal
e removed the Kiel Canal as available link when skimming the LOS matrices for sea
The first point required a modification on the input network:

e Modified for the links 551679-550658 and 550658-551679 the mode attribute allowing all the vessel
types ("xyzpq")

Coded in UL3 field the maximum dwell capacity of 20.000 tonnes.
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Figure 4 - The Kiel canal link.

The second and third point has required a change in the scripting related the network handling and LOS
calculation:

1. when setting up the network attributes (Network step 6 under LOS Calculation > Sea application)

The vessel capacity from vehicle parameter table (red file in the picture) is read via a Lookup
command:

LOOKUP LOOKUPI=1 NAME=SEA COST,

LOOKUP[1]=VEH_NR, RESULT=KM_COST, ; KM_COST (distance cost in SEK)

LOOKUP[2]=VEH_NR, RESULT=HOURS_COST, ; HOURS_COST (Vot in SEK)

LOOKUP[3]=VEH_NR, RESULT=SPEED, ; Speed for vehicles classes 1-17

LOOKUP[4]=VEH_NR, RESULT=CAPACITY ;capacity for vessel - to compare with UL3

The capacity per each vehicle type (denoted as @ MATRIX.N_VEHICLES@) is compared in the script with

the capacity coded in the network (LI.1.UL3). If the vessel capacity is greater than the link capacity, the link is
marked with a new attribute CLOSED=1:

IF(LI.1.UL3<SEA_COST(4,@MATRIX.N_VEHICLES@)&&LI.1.UL3<>0);comparison between vessel capacity and
canal capacity coded in UL3

CLOSED=1

ENDIF

2.

During the LOS calculation (Highway step 7 under LOS Calculation > Sea application)

The information of which links must be closed has recorded in the network attribute CLOSED=1 previously
generated in the Network program. Using an IF statement, all the links marked as closed are added to

GROUP=1. GROUP is an array available inside the HIGHWAY program to mark group of links and used for
different purposes, in this case to exclude those links from the path calculation

IF(LI.CLOSED=1) ADDTOGROUP=1
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In the phase ILOOP, when generating the paths, the keyword EXCLUDEGROUP filter the available links
excluding those on group 1.

PATHLOAD PATH=LW.SEA@MATRIX.N_VEHICLES@,
MW/[1]=PATHTRACE(LI.UL2),
MW[2]=PATHTRACE(LI.To_SEA@MATRIX.N_VEHICLES@),
MW/[3]=PATHTRACE(LW.SEA@MATRIX.N_VEHICLES@),
MW[4]=PATHTRACE(LW.EXTRACOST@MATRIX.N_VEHICLES@),

MW/[5]=PATHTRACE(LW.DDIST@MATRIX.N VEHICLES@), EXCLUDEGROUP=1

6.5.2. Capacity constrains in Vanern Lake

Some issues have been detected when applying the method described in the previous paragraph to Vanern
Lake:

e the method limits the available choices with connectivity described in the LOS-matrices

e the LOS-matrices are fully applied in ChainChoi procedure for all vehicles. In the BuildChain
procedure only the "typical” vessel is applied

e if there are no paths built for the "typical" vessel, no solution would be available for the evaluation

o for the Kiel Canal that has not represented a problem since there is an alternative path not using the
canal, but for Vanern Lake there is only one path in and out from Vénern. Since the appointed
"typical" vessel does not comply with the capacity limits there is not any available connection, and
therefore the chain is not constructed. Consequently, ChainChoi cannot at the succeeding stage select
an appropriate vessel for the OD-leg through Vénern canal.

The solution applied is therefore the following:

e in the BuildChain stage the values for MaxDwtContainerVessel(Tonnes),
MaxDwtRoroVessel(Tonnes) and MaxDwtOtherVessel(Tonnes) are unconstrained (e.g. 9999999)

e in the ChainChain stage the values for MaxDwtContainerVessel(Tonnes),
MaxDwtRoroVessel(Tonnes) and MaxDwtOtherVessel(Tonnes) are specified as 4001 tons (limit for
ports in the lake).

The solution has required:

e changes in input data (Nodes_Base2017) table adding the VanernCan attribute (with ton limits for
each port in port area 14)

e A new set of attributes under nodes.txt table is used in ChainChoi CC_MAXDWTCONV,
CC_MAXDWTRORY and CC_MAXDWTOTHYV with values present under VanernCan

¢  When running BuildChain it will be used MAXDWTCONV, MAXDWTRORYV and MAXDWTOTHV
values

¢  When running ChainChoi it will be used CC_MAXDWTCONV, CC_MAXDWTRORYV and
CC_MAXDWTOTHYV values

6.6. Rail Capacity Management procedure

For a detailed description of Rail Capacity Management procedure see reference 4. Here, we will describe the
implementation in the Cube Interface, and the flow chart of information in each step of the procedure.

As a general concept the RCM procedure is an iterative process that:
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starts from the results obtained from the Standard Logistics Module

e uses some extra input files placed under LogMod\RCM folder

e setsup alinear programming problem that will generate viable alternative solutions in each iteration

(compared to the best solution from standard logistics module). Should not any new alternative
solutions be generated we are at the optimum!

e produces a new set of output files in terms ChainChoiNN_ 01LPX.out solutions to set up new OD
matrices for empties and loaded vehicles

e the number of iterations is controlled by the user (setting up the related catalog key "Maximum
number of loops for Linear Programming process (LP)")

All the steps could be summarized in Figure 5.

STD Logmod
1.
1. LOS Calculation
2.Build Chain (3 ierations)
3. ChainChoi (3 iterations)
4.ConsolidRateMode (3 iterations)
5. Extract
6. Assign flows. Report generation.

!

2. RCM

1. if all capacities are satisfied and if the LP-solutions have converged => Stop and goto
Finalize the Solution.

Case LPO [1st LP): Use initial solution + One alternative/f2f-relation

Case LP1++ (2™++ LP): Column generation scheme:
A. Start with BuildChain4RCM => New chains for rail trp chains initially. 1 iteration
B. Continue with ChainChoi4RCM => 1 new alternative/f2f. 1 iteration

4. Construct and solve the new LP-model - LP1++. Shadow price output inserted into
marginal costs matrices using spanning tree data. Intermediate assignments are
done to construct loaded and empty train flows. Return tostep 1.

¥
3. Finalize the Solution
1. The solution is assigned to the network included congested assignment for empty

trains.
2. Outputsare saved in data base tables.

3. Reports and statistics are produced

Figure 5 - Flow chart of the logistics model and RCM.
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6.6.1. LPO step

LPo steps corresponds to point 2.2. in Figure 5. This process invokes four different steps with the following
purposes:

e Step 1: all the results from the Standard Logistics Module, including spanning tree data for the
railway paths to allow for link load calculations, are merged together in some extra input files for
construction of the standardized MPS-formatted file LP_ Rail LPo.MPS. This is the file with all the
variables and equations in the linear programming problem with the proper format for LP_Solve.exe
program. The MPS. jar program is called from Cube with its control file mps_LP.ctl that contains all
the input and output files (locations and names), and control parameters in the related batch file
(JCMW). We refer to the documentation of the Java-program mps.jar for further details, please see
reference 1.

e  Step 2: the external linear program solver software is called to solve the LP problem and produces
the LP_Rail_LPo.out file

e Step 3: reads the LP_Rail_Lpo.out files and extract information about marginal costs for active
capacity constraints. These are summarized into marginal costs per railway path using the spanning
tree data and placed into marginal cost matrices (Vxxx_MC.314). ChainChoi solutions are assembled
from the LP-solution and placed into approximate firm-to-firm solution files
(ChainChoiNN_o02LPX.out). f2f-solutions split into two or more alternatives are split exactly
according to the LP-solution, without a detailed recalculation of the costs.

e Step 4: From the ChainChoiNN_ o2LPX.out files the extract procedure is used to estimate a new set
of OD matrices for empties and loaded trains (also for tonnes but that is not needed) for all the train

types.

In Figure 6 the file naming and flow chart representing the process is shown.

. . 0_Compact.bat
Extra inputs:

RCM\Nodes_List.txt
RCM\RailLinkCapacitiesBidirectional_STD.dat
1 _RUN_MPS_LPO_stepl.BAT

Samgod Standard (1.2)

RCM\JLISTA.dat
RCM\ColumnData\ColGen2LPNN-1.dat
RCM\ColumnData\LP_RailNN-1.dat
RCM\LP_Rail_defs.dat
RCM\LP_Rail_LP0.MPS

ChainChoi\OUTPUT\ChainChoi01STD.out
Extract\OUTPUT\OD_EmpXXX_STD.314

Extract\OUTPUT\OD_VhcIXXX_STD.314

RCM\LP_Rail_LP0.MPS 2_runl.bat RCM\LP_Rail_LPO.out

INPUT\LOS\VXXX_MC.314

RCM\LP_Rail_LPO.out
ChainChoi\OUTPUT\ChainChoiNNO1LPX.out

3 RUN_MPS_LPO_step2.BAT

Figure 6 - LPO process: input and output data and processes involved, where XXX is vehicle number
3 digit format and NN is the commodity group number.

The requested input data, apart from the ones produced by the Standard Logistics Module, is produced in
different steps of the Samgods application:

1. PathTreeRail.txt: this file contains spanning tree data (reference 4 (Appendix C) for details on the
structure) that represents all the possible paths from each origin to each destination present in the
rail network. This is produced during the LOS calculation for Rail under Samgods Model > LOS
Calculation > Rail application in Highway steps #6 and #9. This is not a standard output for Voyager
software since it is a customization required by Trafikverket. The instructions for the proper
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installation are given in the User Manual. First batch file 0_Compact.bat transform spanning tree
data to compact format (extension cmp).

Nodes_ List.txt and Links_ List.txt: List of nodes and links in the network both with emme and
voyager number systems and primary key (Internal_node_number) per each element. They are
produced under Samgods Model > LOS Calculation > Data Preparation > Data for RCM at steps #2
and #3. These are necessary because the backtracking of the paths utilize the mapping between these
two sets of nodes and links, respectively.

RailLinkCapacitiesBidirectional _STD.dat: this is the translation in String format (ascii) of the
Rail_Capacity_{SCENARIO_SHORTNAME} table for the specific scenario. The file is produced
under Samgods Model > LOS Calculation > Data Preparation > Data for RCM at steps #4.

The output files from the process are presented in Table 140.

Table 140 - Output files from LPO, where XXX is vehicle type 3 digit format.

Output file Description

RCM\JLISTA.dat List of transport chain solutions from all the commodity

groups and definition of super index, e.g. a primary key for

each solution. This primary key will be referred to in the MPS

file

RCM\ColumnData\ColGen2LLPNN-1.dat Intermediate file

RCM\ColumnData\LP_RailNN.dat Intermediate file

RCM\LP_Rail_defs.dat Computed data for the constraints in the Linear programming
problem

RCM\LP_Rail_LP0o.MPS Linear Programming problem in MPS format that will be

solved by LP_Solve.exe program

RCM\LP_Rail_LPo.out Results of linear programming problem solution in

LP_Solve.exe format

INPUT\LOS\vXXX_MC.314 Marginal cost matrices for V201, V202, ..V212 (only rail
mode).
ChainChoi\OUTPUT\ChainChoiNNo1LPX.out Transport chain solutions produced

6.6.2. LP1 step

LP1 steps corresponds to point 2.3 in Figure 5. This process invokes the same four steps as LPo but with two
extra steps as shown in Figure 7:

Step 1: run BuildChain.exe and ChainChoi.exe programs (Column generation model). These are
special runs of the logistics modules BuildChain and ChainChoi that only operates on the transport
relations defined in JLISTA.dat (the ones initially using railway). They are used for computing a new
first best solution given the updated marginal costs. The modules are run with the same conditions
as in iteration 3 of Standard Logistics Module in which a large number of endogenously generated
input data, such as consolidation factors and volumes, are left unchanged.

Step 2, 3, 4 and 5: same steps 1, 2, 3 of LPo
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Step 5: convergence check to establish if the process should be iterated further or can be stopped. The
number of iterations is controlled by “Maximum number of loops for Linear Programming process (LP)". The
output files from the process can be seen in Table 141.

RCM\JLISTA.dat

Standard LogMod (1.2)
ChainChoi\OUTPUT\ChainChoiNNdata0O6STD.out

Extra inputs:
RCM\Nodes_List.txt
RCM\RailLinkCapacitiesBidirectional_STD.dat

RCM (BuildChain ChainChoi
ChainChoi\OUTPUT\ChainChoiNNRCM.out

RCM\LP_Rail_LP1.MPS

RCM\LP_Rail_LP1.out

1_RUN_MPS_LP1_stepl.BAT

3_RUN_MPS_LP1_step2.BAT

BuildChain\QUTPUT\ChainsNN_RCM.dat

RUNALL_RCM.BAT ChainChoi\OUTPUT\ChainChoiNNRCM.out

RCM\JLISTA.dat
RCM\ColumnData\ColGen2LPNN-2.dat
RCM\ColumnData\LP_RailNN-2.dat
RCM\LP_Rail_defs.dat
RCM\LP_Rail_LP1.MPS

2_runLP.bat

RCM\LP_Rail_LP1.out

INPUT\LOS\vXXX_MC.314
ChainChoi\OUTPUT\ChainChoiNNO1LPX.out

Figure 7 - LP1 process: input and output data and processes involved.

Table 141 - Output files from LP1, where XXX is the vehicle type 3 digit format and NN is the commodity

group number.

Output file

Description

ChainChoi\OUTPUT\ChainChoiNNRCM.out

Transport chains in column generator process

RCM\ColumnData\ColGen2LLPNN-2.dat

Intermediate file

RCM\ColumnData\LP_RailNN-2.dat

Intermediate file

RCM\LP_Rail_LP1.MPS

Linear Programming problem in MPS format that will be solved by

LP_Solve.exe program

RCM\LP_Rail_LP1.out

Results of linear programming problem solution in LP_Solve.exe

format

INPUT\LOS\vXXX_MC.314 (over-writing previous files)

Marginal cost matrices for V201, V202, .V212 (only rail mode).

ChainChoi\OUTPUT\ChainChoiNNo1LPX.out (over-

writing previous files)

Transport chain solutions produced

6.6.3. Final process (FIN)

The final results of Rail Capacity Management saved in ChainChoiNNLPX.out files are read and rewritten to
the final solution files ChainChoiNNXTD.out, where NN is commodity group number, shown in Figure 8. In
theory only the split solutions from the LP model should be modified in this process, but marginal changes in
transport costs and total costs occur in many places. The output files from the process are presented in Table

142.
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ChainChoi\OUTPUT\ChainChoiNNXTD.out
ChainChoi\OUTPUT\ChainChoiNNXTD.fac
ChainChoi\OUTPUT\ChainChoiNNXTD.rep
ChainChoi\OUTPUT\ChainChoiNNXTD.cst

ChainChoi\OUTPUT\ChainChoiNNO1LPX.out runLP2CC.bat

Figure 8 - Final process: input and output data and processes involved.

Table 142 - Output files from FIN process.

Output file Description

ChainChoi\OUTPUT\ChainChoiNNXTD.out Final transport chain solutions with STD
Logmod format

ChainChoi\OUTPUT\ChainChoiNNXTD.fac Aggregate report on load factors for
commodity NN

ChainChoi\OUTPUT\ChainChoiNNXTD.rep Aggregate report on costs, tonne volumes,
transport statistics etc. for commodity NN

ChainChoi\OUTPUT\ChainChoiNNXTD.cst detailed cost log for commodity NN for
selected cases

6.7. Rail Assignment

6.7.1. Capacity constraints

In current implementation the process is not used since optimization lead in LPo and 1 do not require any
further balancing. It is kept here for reference.

To distribute empty trains according to an assignment including options to distribute the empty train routes
while considering generalized time, marginal cost and on top of that capacity constraints the following
assignment model has been coded in Highway assignment:

MUN Y41 gin types Liinks(Tegular costs) * (empty trains flows) + ¥ cqpacities Penalty(overload)

(5.1)
where:
e Penalty(overload): an optional function for penalizing loading above capacity

e Costs: costs specified in vehicle parameters and network (operational costs, taxes, tolls and extra
costs)

e Overload: total bidirectional trains minus bidirectional capacity
The penalty function used in the equation (5.1) is:
Penalty(overload) = 10000 X (max|[0, (Xiraintypes Sdirections(€mpty and loaded train flows) —
capacity])2(5.2)

The Assignment method described above is formulated as system optimization instead of user equilibrium.
The first formulation is not applicable in Voyager scripting; therefore the optimal solution has been
reformulated as:

INTEGRAL(0,Q) t(q)dq = [T(q)]o? = T(Q) — T(0) = T(Q).
where:

e t(q) = vd-function
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e T(q) = the primitive function of the vd-function
Thus, by using as vd-function the derivative of the penalty function:

Vdf(overload) = 2 x 10000 x
(max|0, (Ttraintypes 2directions(empty and loaded train flows) — Capacity|)

(5.3)

and integrating over flows from o to Q (=all flows on the link), we obtain an objective value equal to the
system optimal value for the penalty function term.

The proposed assignment method has been implemented in the highway program via the following steps:

e the bidirectional volumes for each rail link with capacity are stored in one array where the dimension
is the ID_LINK from capacity table

e in the adjust procedure, when the times are corrected based on the vdf functions, two functions are
applied:

e for all rail links that have no capacity (e.g. 0) the fix time derived from vehicle parameters is applied

o for all rail links with specified capacity, the bidirectional flows stored in the array are retrieved and
compared to the capacity, if overcapacity the vdf function specified in (5.3) is applied

e the volumes are averaged along the iterations using the MSA algorithm (CONVERGENCE=AVE).

6.7.2. Domestic flows allowed only on domestic links

To avoid unrealistic routes for domestic flows (e.g. where the origin and destination are inside Sweden and
foreign railway links are used for empty flows) a designated procedure has been put in place. The procedure
works in the following manner:

e adummy matrix containing information if an OD is domestic or not is used to filter the demand
matrix

e two different classes (domestic flows and all the others) are provided to the assignment

e inthe LINKREAD phase (when all the variables for the assignment are specified) an IF statement is
used to add to group 10 all the non-domestic links (similar technique used also in Kiel Canal)

e in the ILOOP phase (when all the possible paths are constructed) two different sets of paths are
produced:

e the first set has the input matrix containing only the domestic flows and the links on group 10 are
excluded (using EXCLUDEGROUP=10) statement in PATHLOAD commend

e the second set uses the matrix with all the other flows and all the links are open in the network (no
EXCLUDEGROUTP is coded for 10).

6.8. Calibration procedures

6.8.1. Forbidden over-seas ship transports to domestic small ports

In current implementation the process is not used since revision of network has made redundant this feature.
It is included as potential tool.

To prevent over-seas transport to enter selected small ports in Sweden in the LOS matrices the combination
of OD from/to transoceanic ports is entered with a high impedance.

The following changes have been made in the model:

e The table "PortNodes" has been updated with a new field: TransOceanFac. Ports having the value
equals 10 are small ports in Sweden (74 ports)
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e Inthe Sea application, under LOS calculation, additional logic has been inserted in step 3 of the
MATRIX procedure. Its function is to read the PortNodes table to identify small ports and to read the
Transoceanic factor. Furthermore, it sets a dummy matrix with scaling factors that will be applied in
the next Highway step. The details of calculation are:

TransOceanL="1075-1099' ;range of zones that represent the transoceanic ports

JLOOP

OrigZone=Renumber(1,I) ; origin zone number in emme format

DestZone=Renumber(1,J) ; destination zone number in emme_format
OrigFactor=TransOceanic(1,0rigZone) ; origin factor from port definition table (-1 means is not a port)

DestFactor=TransOceanic(1,DestZone) ; destination factor from port definition table (-1 means is not a port)

;not transoceanic

IF((INLIST(I,TransOceanL)=0)&&(INLIST(J,TransOceanl.)=0)) ;if both the ports are domestic no factors are
applied

MW][1]=1 ;no factor

ENDIF

IF((INLIST(I,TransOceanL)=1)||(INLIST(J,TransOceanL)=1)) ;if one of them is transoceanic the final factor is the
multiplication of factor in origin and factor in destination

MW][1]=(1+OrigFactor)*(1+DestFactor)
ENDIF

ENDJLOOP

e Inthe Sea application, under LOS calculation, the HIGHWAY step 7 reads the dummy matrix
produced with the previous step and applies the factor to the TIME skim:

MW/[200]=MI.1.1 ; LOS factor

MW[2]=MW/[2]*MW[200] ;apply los factor

6.8.2. Rescaling factors for LOS matrices in sea mode

The rescaling factors are produced by the cycling process and they are used to rescale the TIME skims
applying a factor that varies per port area and commodity group.

Their implementation and calibration have required several steps in various parts of the model. They are:
e arevision of Nodes table including information of PORTAREANR
e arevision of nodes.txt file including information of PORTAREANR

e anew routine in BuildChain.exe and Chainchoi.exe that reads the scaling factors and holds in
memory the rescaled values for the following LOS matrices:

e V301_timeh.314, ..., V322_timeh.314 LOS

e The time value is rescaled for each OD applying the combined factor from port area in origin and
destination and commodity group. An example is shown in Table 143.
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e the program uses the input files CalibrationParameters.txt placed under Input folder and collects the
port area numbers from PortAreas_def.txt. The first is a copy of
PortAreaParams_{SCENARIO_SHORTNAME}.txt (it is the first loop of the calibration process) or
the current values estimated in the previous loop (saved under scenario folder and named
CalParameterNextLoop.txt)

e Under the Parameters Calculation application the scaling factors are re-estimated by comparing the
port statistics per port area and commodity group with model values. The values are adjusted based
on the results. The function applied is as follow:

If (Abs(Diff) < 100) Then ; if the difference between modelled and statistics is less than 100 tons (DIFMAX)
Adjust = factor ; the previous value is maintained
Endif
If (Diff < 0) Then ; if the difference is a negative value it means we have to reduce the factor (that is an impedance)
Adjust = factor - 0.05 ; new factor = previous factor -0.05 (STEP)
If (Adjust < 0.01) Then ; if the adjust factor is less than 0.01 (MINVAL)
Adjust = 0.05 ; is set to a minimum value 0.05 (VALO)
End If
Else ; if the difference is a positive value it means we have to increase the factor (that is an impedance)
Adjust = factor + 0.05 ; new factor = previous factor+0.05 (STEP)
End If
End If

e The parameters that control the process are:
¢ DIFMAX: maximum difference between modelled and statistics (100 means 100 tons)
e STEP: the value that will use to increase the factor

e  MINVAL: boundary value to evaluate small or negative factors. if Adjust <= MINVAL then Adjust =
VALo

e VALO: reset value used if the function goes negative

e All of them could be revised modifying the table Parameters_portcalibration.dbf, see Table 144.

e The statistic used for the comparison is
{CATALOG_DIR}\o5_Input_Data\Input_Data.mdb\Port_statistics

Table 143 - Example on rescaling calculation for LOS sea mode.

Origin weighting factor | Destination weighting factor Final Final
Orig Dest TIMEH (Commodity group 1) (Commodity group 1) value TIMEH
718021 718121 10.067336 | 1.1 1.1 1.21 (1.1*1.1) | 12.18148
718021 718221 0.637215 1.1 1.1 1.21 0.77103
718021 718821 9.50218 1.1 1.1 1.21 11.60654
718021 719221 7.884646 1.1 1.1 1.21 9.540422
718021 | 730521 | 12.73721 1.1 1 1.1 14.01093
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718021 731921 11.457068 | 1.1 1 1.1 12.60277
718021 738221 | 9.061406 1.1 1 1.1 9.967547
718021 738222 | 9.066202 1.1 1 1.1 9.972822

Table 144 - Parameter to control the revision of scaling factors.

ID STEP MINVAL DIFMAX VALo

1 0.02 0.01 100 0.02

The set of matrices per commodity group are provided to the Logistics Module and Rail Capacity
Management procedure specifying a different LOS folder in the BuildChainXX.ctl and ChainChoi.ctl control
files, an example for commodity 01 could look like:

INCL=buildchain_common.ctl
COMMODITY=o01
VHCL=..\Input\Cost\vhcls_dry_bulk.txt
LOSDIR-=..\Input\LOS\So1

PWC={CATALOG _DIR} _150307\01_Programs\LogMod\Input\PWC\2030\PWC_o1.txt

6.8.3. Rescaling factor for Kiel Canal

A similar procedure to the one described in section 6.8.2 has been applied to toll on Kiel Canal.
Its implementation has been developed as follow:
e An initial scaling factor is provided using catalog key " Starting value for scaling factor on Kiel canal”

e Under "LOS calculation > Data preparation" the application Network step 17 takes this value and
rescale the TOLL value for each vessel type:

TOLL301=LI.1.TOLL301*parKiel(1,@LOOP_CAL@)

TOLL302=LI.1.TOLL302*parKiel(1,@LOOP_CAL@)
TOLL303=LI.1.TOLL303*parKiel(1,@LOOP_CAL@)
TOLL304=LI.1.TOLL304*parKiel(1,@LOOP_CAL@)

TOLL305=LI.1.TOLL305*parKiel(1, @LOOP_CAL@)

where @LOOP_CAL@ represent the variable representing the current loop.
e A new set of output LOS matrices has produced rerunning the LOS calculation for Sea Mode
e Those matrices are subsequently rescaled for the scaling factors per port area and commodity group

e Under Parameters Calculation application the scaling factor is re-estimated comparing the
distribution of flows between Kiel Canal and North of Jylland (here is compared the percentage of
the tons through Kiel Canal against those going north of Jylland) from the model results and
statistics (present in {CATALOG_DIR}\o5_Input_Data\Input_Data.mdb\Other_ statistics table).
The function applied is as follow:

If (Abs(Diff) < 100) Then ; if the difference between modelled and statistics is less than 100 tons (DIFMAX)
Adjust = factor ; the previous value is maintained

endif
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If (Diff < 0) Then ; if the difference is a negative value it means we have to reduce the factor (that is an impedance)
Adjust = factor - 0.05 ; new factor = previous factor -0.05 (STEP)
If (Adjust < 0.01) Then ; if the adjust factor is less than 0.01 (MINVAL)
Adjust = 0.05 ; is set to a minimum value 0.05 (VALO)
End If
Else ; ifthe difference is a positive value it means we have to increase the factor (that is an impedance)
Adjust = factor + 0.05 ; new factor = previous factor+0.05 (STEP)
End If
End If

e The parameters that control the process are:

¢ DIFMAX: maximum difference between modelled and statistics (2 means 2%)

e STEP: the value that will use to increase the factor

e MINVAL: cut off value to evaluate small or negative factors

e VALOo: reset value used if the function goes negative

e All of them could be revised modifying the table Parameters_kielcalibration.dbf, see Table 144.

e The statistic used for the comparison is
{CATALOG_DIR}\o5_Input_Data\Input_Data.mdb\Other_ statistics table

6.9. Samgods Parallelization Module

The purpose of the Samgods Parallelization Module is to speed up the execution process by using
parallelization. This is done by splitting up the workload of two or several independent program calls from
running on one processor in a sequence to run on several processors in parallel.

Initially the module sorts the workload of program execution steps from the longest runtime to the shortest,
then starts executing the program steps given the priority from the sorted list. The program steps are
executed in parallel until the number of simultaneous executions have reached a specified limit given by the
user. Each time one program step has finished, the module tries to run the next program step on the list. In
the end of the process the module returns after having checked that all steps in the original program call
sequence did finish.

The input to the program is three input files with fixed file names:
e “execution_times.txt",
e 'runall.bat"
¢ "NR_OF_PROGRAM_INSTANCES.TXT”.

The file name runall.bat may be altered and overrun with the first expression in the parameter list of the
module.

6.9.1. The input files

e “execution_times.txt”: This file gives the information the module needs to sort list of execution steps.
The input in this file has two pieces of information per row. One is a reference to the program call to
be run and the other one is the estimated runtime for that program to finish. Semicolon is used as a
delimiter.

261




Applied methods in the model

e “runall.bat”: This file contains the sequence of program calls to be executed. The parallelization
module interprets two keywords namely call and rem. If the line starts with call the module reads the
line and if the line starts with rem the module jumps to the next line. After the word call the name to
the file to be called by the OS is found and lastly the parameter passed to the file to be called (this is
the reference number to the execution times mentioned above.) It may look something like this: “call
commodity 10”.

e “nr_of program_instances.txt”: This file contains one number that tells the module how many
program steps that could be ran simultaneously. It is good practice to set this number to less or equal
the number of processors available for execution on the CPU or Server used. (One limiting factor
may also be the available memory.)

6.9.2. Controlling the execution

After having read the input files and sorted the list of program steps, the module writes a batch file for all
steps that are associated with a corresponding stop file. Each batch file contains the call that where originally
found in “runall.bat”. The last line in each batch file has a command to delete the corresponding stop file. For
the module to know that a particular program step has finished, frequently checks are made if the associated
stop file still exist or not. If it does not, the module tries to run the next program execution step on the list. If
there are no steps left to run and there are no stop files left, the execution finishes and returns.
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7 Programs and licenses required

7.1. Programs

7.1.1. Cube software

For the Samgods GUT to function, certain Cube software is required. They are:
e Cube Base: 6.4.5
e Cube Voyager: 6.4.5
e Cube GIS: ArcGIS 10.6
This software is available at
e http://citilabs-website-resources.s3.amazonaws.com/release/cube645setup.exe

7.1.2. JAVA software

e Java runtime environment (jre). Platform: 1.6. Product: 1.6.0_17 (later program versions are also
possible to use)

e Java virtual machine Windows x64
Location for the above programs:

e http://www.java.com/sv/download/ or http://download.oracle.com/otn-pub/java/jdk/7/jre-7-
windows-x64.exe

e  http://www.oracle.com/technetwork/java/javase/downloads/java-se-jre-7-download-432255.html

7.1.3. LP solver software

The linear program solver is an external program. Currently the solver is CLP. It is a 64-bit version of the
linear programming optimizer built in June 2018 with C++ in Microsoft Development Studio. For more
information, please consult https://projects.coin-or.org/Clp. Microsoft Visual C++ Redistributable for Visual
Studio software might be required. The 64 bit version is required since tests with the 32-bit version of CLP
resulted in failures for larger problems (possibly recoding of CLP could have solved the problem).

7.1.4. Licence requirements

e  Cube software

For the above Cube software, Citilabs License 2019 is required (but newer software and license versions may
be available later on).

e JAVA software
No licences are required.
e CLP64

Eclipse Public License (EPL). No licences are required.
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